ASCII object reference

Ihr Internet Browser ist nicht geeignet. Verwenden Sie einen Browser, der Frames darstellen kann.


ASCII Deutsch ACC

ASCII - Kommando | ACC |
Syntax Senden | ACC [Data] |
Syntax Empfangen | ACC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3501 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1601 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 1 (dec)
Default | 10 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Drehzahlregelung

Beschreibung

Das Kommando ACC definiert die Beschleunigungsrampe des Drehzahlreglers. Die Beschleunigungsrampe ACC wird nur bei Sollwertsprüngen benutzt, die eine Erhöhung der Drehzahl nach sich ziehen (Beschleunigungsvorgang). Für den Bremsvorgang gilt der Parameter DEC.


ASCII Deutsch ACCR

ASCII - Kommando | ACCR |
Syntax Senden | ACCR [Data] |
Syntax Empfangen | ACCR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3502 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1602 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 2 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Beschleunigungsrampe Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando ACCR definiert die Beschleunigungsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. Die Vorgabe erfolgt in msek und bezieht sich auf die Endgeschwindigkeit der entsprechenden Betriebsart: VJOG beim Tippbetrieb bzw. VREF bei der Referenzfahrt.
Die Beschleunigungsrampe ACCR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).


ASCII Deutsch ACCUNIT

ASCII - Kommando | ACCUNIT |
Syntax Senden | ACCUNIT [Data] |
Syntax Empfangen | ACCUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3659 (hex)
DIM | - | PROFIBUS PNU | 1945 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. , 5 | DPR | 345 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Art der Beschleunigungsvorgabe im System

Beschreibung

Mit dem Kommando ACCUNIT kann die systemweite Beschleunigungseinheit
definiert werden. Diese Einheit gilt sowohl für die Rampen des Trajektoriengenerators (interne Fahrsätze, OPMODE 8) als auch für die Brems-/Beschleunigungsrampen des Drehzahlreglers.

ACCUNIT = 1 Beschleunigung wird in rad/sek² vorgegeben
ACCUNIT = 2 Beschleunigung wird in UPM/sek vorgegeben
ACCUNIT = 3 Beschleunigung wird in PUNIT/sek²
ACCUNIT = 4 Beschleunigung wird in 1000*PUNIT/sek²
ACCUNIT = 5 Beschleunigung wird in 1000000*PUNIT/sek²

Bei der Einstellung ACCUNIT=0 ist es weiterhin möglich die Fahrsatzbeschleunigung in mm/sek² vorzugeben (Bit 12 der Fahrsatzart=1).
Bei der Einstellung ACCUNIT=1 wird dieses Bit ignoriert, d.h. die Rampen werden
ausschließlich in rad/sek² erwartet.

Bei der Änderung der Variable ACCUNIT werden alle Beschleunigungs-/Brems-Parameter die davon betroffen sind, intern auf die jeweils gültige Einheit umgerechnet. Dazu gehören folgende Parameter:
ACC,ACCR,DEC,DECR,DECSTOP,DECDIS

Die automatische Parameteranpassung gilt nicht für die internen Fahrsätze. Aus diesem Grund sollte die Festlegung der gültigen Beschleunigungseinheit vor der Erstellung des ersten Fahrsatzes erfolgen.
Bei einer Änderung von ACCUNIT zu einem späteren Zeitpunkt, müssen die Anfahr-/Bremsbeschleunigungswerte aller Fahrsätze überprüft und ggf. korrigiert werden.

Die Anfahr-/Bremsrampen der Fahrsätze werden grundsätzlich durch die Einstellung PTMIN begrenzt. Diese Einstellung erfolgt in den ACCUNIT-Einheiten oder in msek

Achtung !!
Bei ACCUNIT=0 wird die maximale Beschleunigung durch kleine PTMIN-Werte eingestellt, bei ACCUNIT>0 durch große Werte


ASCII Deutsch ACTFAULT

ASCII - Kommando | ACTFAULT |
Syntax Senden | ACTFAULT [Data] |
Syntax Empfangen | ACTFAULT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3503 (hex)
DIM | - | PROFIBUS PNU | 1603 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 3 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Fehler Stop Modus

Beschreibung

Mit Hilfe des Kommandos ACTFAULT kann das Verhalten des Antriebes beim Auftreten eines Fehlers bestimmt werden.
ACTFAULT=0: Beim Auftreten eines Fehlers wird die Endstufe sofort gesperrt, der Antrieb trudelt aus.
ACTFAULT=1: Beim Auftreten eines Fehlers wird eine Nothalt-Prozedur eingeleitet, die aus folgenden Schritten besteht:
1. Umschalten des Reglermodes auf die Drehzahlregelung (OPMODE=0)
2. Umschalten der Bremsrampe des Drehzahlreglers (DEC) auf die Nothaltrampe (DECSTOP)
3. Setzen des internen Drehzahlsollwertes auf 0 (vor dem Rampengenerator).
4. Starten eines Timers (Time-Out-Zeit = 5 sek)

Sobald der interne Drehzahlsollwert (hinter dem Rampengenerator) den Wert 0 erreicht hatte, wird die Endstufe gesperrt und der ursprüngliche Reglermode eingestellt. Dies geschieht auch, wenn der Time-Out abgelaufen ist bevor der Drehzahlsollwert den Wert 0 erreicht hatte.


ASCII Deutsch ACTIVE

ASCII - Kommando | ACTIVE |
Syntax Senden | ACTIVE |
Syntax Empfangen | ACTIVE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3504 (hex)
DIM | - | PROFIBUS PNU | 1604 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 4 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Endstufe freigegeben/gesperrt

Beschreibung

Das Kommando ACTIVE liefert den aktuellen Zustand der Endstufe.
ACTIVE=1 Endstufe ist freigegeben
ACTIVE=0 Endstufe ist gesperrt

Für die Freigabe der Endstufe müssen, abhängig von der Reglerkonfiguration,
folgende Bedingungen erfüllt sein:

1. Standardkonfiguration (keine Netzbtb-Funktion aktiv)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden

2. Netzbtb-Funktion aktiv (O1MODE oder O2MODE=3)
- Software enable gesetzt
- Hardware enable gesetzt
- BTB vorhanden
- Netz-BTB vorhanden
- Zwischenkreisspannung > Unterspannung-Meldeschwelle


ASCII Deutsch ACTRS232

ASCII - Kommando | ACTRS232 |
Syntax Senden | ACTRS232 [Data] |
Syntax Empfangen | ACTRS232 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3655 (hex)
DIM | - | PROFIBUS PNU | 1941 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 341 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Freigabe des RS232-Watchdogs

Beschreibung

Das Kommando ACTRS232 aktiviert bzw. deaktiviert die Überwachung der seriellen Schnittstelle (RS232-Watchdog).

ACTRS232=0 keine Überwachung der seriellen Kommunikation
ACTRS232=1 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird jede Bewegung angehalten und die Warnung n04 angezeigt. Die Warnung muß über die Funktion "Fehler quittieren" gelöscht werden.
ACTRS232=2 Rs232-Watchdog aktiviert. Die Watchdog-Zeit kann über das Kommando RS232T in msek eingestellt werden. Der Watchdog wird mit jedem seriellen Kommando getriggert. Wenn er abläuft, so wird die aktuelle Bewegung angehalten und ACTRS232 auf 0 gesetzt. Es wird keine Warnung ausgegeben.

Nach dem Einschalten des Verstärkers ist der RS232-Watchdog immer deaktiviert (ACTRS232=0). Beim Starten einer Service-Funktion über die serielle Schnittstelle, sollte das PC-Programm (bzw. eine externe Steuerung) dafür sorgen, daß die Überwachung der Schnittstelle eingeschaltet wird. Dadurch wird sichergestellt, daß beim Abbruch der Kommunikation bzw. bei einem PC-Absturz die Service-Funktion automatisch abgebrochen wird.


ASCII Deutsch ADDR

ASCII - Kommando | ADDR |
Syntax Senden | ADDR [Data] |
Syntax Empfangen | ADDR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 3505 (hex)
DIM | - | PROFIBUS PNU | 1605 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 5 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Stationsadresse

Beschreibung

Mit dem Kommando ADDR wird die Feldbus-Adresse des Verstärkers definiert (CANBUS/PROFIBUS/SERCOS). Nach der Änderung der Adresse sollten alle Parameter im EEPROM abgespeichert werden (s. SAVE-Kommando) und der Verstärker aus- und eingeschaltet werden.

Wenn MDRV = 0, ist die Multilink-Funktionalität abgeschaltet. Damit kann dann ADDR von 0 .. 127 vorgegeben werden.


ASCII Deutsch AENA

ASCII - Kommando | AENA |
Syntax Senden | AENA [Data] |
Syntax Empfangen | AENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3506 (hex)
DIM | - | PROFIBUS PNU | 1606 (dec) IND = 0000xxxx (bin)
Bereich | 0 ,1 | DPR | 6 (dec)
Default | 1 |
Opmode | 0, 2, 4, 5, 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Initialisierungszustand der Software-Freigabe

Beschreibung

Mit dem Kommando AENA (Auto Enable) kann der Zustand des Software-Enable beim Einschalten des Verstärkers definiert werden.

Damit die Endstufe freigegeben wird, muß sowohl das Hardware-Enable als auch das Software-Enable gesetzt werden (Reihenschaltung).
Mit dem Software-Enable wird einer externen Steuerung die Möglichkeit gegeben, über eine Bus-Anschaltung (CANBUS/PROFIBUS/SERCOS/RS232) bzw. über eine Slot-Erweiterungskarte, die Endstufe softwaremässig zu sperren bzw. freizugeben.
Bei Geräten, die mit einem analogen Sollwert arbeiten (OPMODE=1,3) wird beim Einschalten des Verstärkers das Software-Enable automatisch gesetzt, so daß diese Geräte sofort betriebsbereit sind (Hardware-Enable vorausgesetzt).
Bei allen anderen Geräten, die mit einem digitalen Sollwert arbeiten (OPMODE=0,2,4..8), wird beim Einschalten das Software-Enable auf den Wert von AENA gesetzt.

Die Variable AENA hat auch eine Funktion beim Resettieren des Verstärkers nach einem Fehler (über digitalen Eingang 1 bzw. mit dem ASCII-Kommando CLRFAULT).
Bei Fehlern, die softwaremässig resettiert werden können, wird, nachdem der Fehler gelöscht wurde, das Software-Enable auf den Zustand von AENA gesetzt.
Auf diese Weise ist das Verhalten des Verstärkers beim Software-Reset analog zu dem Einschaltverhalten.


ASCII Deutsch ALIAS

ASCII - Kommando | ALIAS |
Syntax Senden | ALIAS [Data] |
Syntax Empfangen | ALIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 8 ASCII Characters | DPR | Nein
Default | DRIVE0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Symbolischer Verstärker-Name

Beschreibung

Mit dem Kommando ALIAS kann einem Verstärker ein symbolischer Name zugewiesen werden. Bei Verwendung des PC-Bedienprogrammes erscheint dieser Name in der Titelzeile aller geöffneten Parameter-Fenster.
Im Multi-Drive-Mode (Parametrieren von mehreren über den CAN-BUS verbundenen Verstärkern) kann anhand des ALIAS-Namen das Parameter-Fenster dem zugehörigen Verstärker eindeutig zugeordnet werden.


ASCII Deutsch AN11NR

ASCII - Kommando | AN11NR |
Syntax Senden | AN11NR [Data] |
Syntax Empfangen | AN11NR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3699 (hex)
DIM | - | PROFIBUS PNU | 2009 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4 | DPR | 409 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Nr. der INxTRIG Variable, bei analoger Vorgabe

Beschreibung

Mit dem Parameter AN11NR kann die Nummer (x) des digitalen Eingangs festgelegt werden, dessen Hilfsvariable (IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG) über den analogen Eingang SW2 beeinflußt werden soll. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.


ASCII Deutsch AN11RANGE

ASCII - Kommando | AN11RANGE |
Syntax Senden | AN11RANGE [Data] |
Syntax Empfangen | AN11RANGE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 369A (hex)
DIM | - | PROFIBUS PNU | 2010 (dec) IND = 0000xxxx (bin)
Bereich | -262144 .. 262143 | DPR | 410 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Bereich für die analoge Änderung von INxTRIG

Beschreibung

Der Parameter AN11RANGE beschreibt die Wert-Änderung der Variable IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG, wenn die Spannung am analogen Eingang 2 (SW2) von 0 auf 10V geändert wird. Diese Variable wird nur bei den Einstellungen ANCNFG=11 und ANCNFG=12 benutzt.

Beispiel:

ANCNFG=11
AN11NR=1
IN1TRIG=1000
AN11RANGE=500

bei SW2=0V IN1TRIG = 1000
bei SW2=10V IN1TRIG = 1500
bei SW2=-10V IN1TRIG = 500


ASCII Deutsch ANCNFG

ASCII - Kommando | ANCNFG |
Syntax Senden | ANCNFG [Data] |
Syntax Empfangen | ANCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3507 (hex)
DIM | - | PROFIBUS PNU | 1607 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 14 | DPR | 7 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Konfiguration der analogen Eingänge

Beschreibung

Mit dem Kommando ANCNFG kann die Funktion der analogen Eingänge konfiguriert werden. Da die Variable ANCNFG für die Konfiguration des Gerätes benutzt wird, muß nach einer Änderung der Variable der Regler aus- und eingeschaltet werden (vorher SAVE aufrufen).
Zustand |  | Beschreibung
ANCNFG=0 | (Xcmd=Setp.1) | SW1 wird je nach OPMODE als Drehzahl- (OPMODE=1) bzw. Stromsollwert (OPMODE=3) benutzt. Falls einer der digitalen Eingänge für Sollwert-Umschaltung konfiguriert wurde (IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG=8), wird je nach Zustand dieses Eingangs, SW1 (Eingang=Low) oder SW2 (Eingang=High) als Drehzahl- bzw. Stromsollwert benutzt. Skalierung: SW1=10V Drehzahlsollwert=VSCALE1 (OPMODE 0,1) SW1=10V Stromsollwert=ISCALE1 (OPMODE 2,3) SW2=10V Drehzahlsollwert=VSCALE2 (OPMODE 0,1) SW2=10V Stromsollwert=ISCALE2 (OPMODE 2,3)
ANCNFG=1 | v_cmd=Setp.1, Icmd=Setp.2 | SW2 wird als Stromsollwert benutzt (bei OPMODE = 3), SW1 dient als Drehzahlsollwert (bei OPMODE = 1) Skalierung: SW1 = 10V Drehzahlsollwert = VSCALE1 SW2 = 10V Stromsollwert = ISCALE2
ANCNFG=2 | Setp.1 = nsoll, Setp.2 = Isoll | SW1 wird als Drehzahlsollwert benutzt. SW2 wird als Stromvorsteuerung (bei OPMODE=0,1) benutzt Skalierung: SW2=10V Stromvorsteuerung=ISCALE2
ANCNFG=3 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK
ANCNFG=4 | Xcmd=Setp.1+Setp.2 | SW1 und SW2 werden summiert und je nach OPMODE als Sollwert benutzt. Für die Skalierung werden die Kommandos ISCALE1,ISCALE2 (OPMODE 3) oder VSCALE1,VSCALE2 (OPMODE 1) benutzt.
ANCNFG=5 | Xcmd=Setp.1*Setp.2 | SW1 und SW2 werden multipliziert. Das Produkt wird je nach OPMODE als Strom- bzw. Drehzahlsollwert benutzt. SW1 = Sollwert (ISCALE1/VSCALE1) SW2 = Skalierungsfaktor 10V = 100% / -10V = -100%
ANCNFG=6 | Electronic Gearing | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. SW2 wird zur Korrektur von GEARO (elektrisches Getriebe) benutzt. MitVSCALE2 kann der Korrekturfaktor (in %) vorgegeben werden. Z.B. VSCALE2=20 SW2= +10V GEAROeff = GEARO*1.2 SW2= -10V GEAROeff = GEARO*0.8 SW2= 0V GEAROeff = GEARO
ANCNFG=7 | Setp.1 = Isoll, Setp.2 = Nmax | SW1 wird als Stromsollwert benutzt (OPMODE muss auf 3 stehen), SW2 bestimmt die erreichbare Drehzahl Skalierung: SW1=10V Stromsollwert=ISCALE1 SW2=10V Drehzahlgrenze Nmax=VSCALE2 Die Drehzahl des Motors wird bei Erreichen von Nmax begrenzt
ANCNFG=8 | Setp.1 = Psoll | SW1 wird als Positionssollwert benutzt (nur bei OPMODE=5 aktiv). Der Verfahrbereich für die "analoge Positionierung" wird durch die Parameter SRND und ERND bestimmt. Skalierung: SW1 = 0V Position = SRND SW1 = +/- 10V Position = ERND Wenn der Verstärker eingeschaltet wird, so ist zunächst der Referenzpunkt nicht gesetzt und es erfolgt keine Bewegung, auch wenn der OPMODE bereits auf 5 gesetzt ist. Nun muss zunächst eine Referenzfahrt über einen digitalen Eingang gestartet werden. Die Umschaltung auf OPMODE=8 wird automatisch vorgenommen. Wenn die Referenzfahrt beendet ist, kann der digitale Eingang wieder auf low geschaltet werden und dann wird automatisch die über den Eingang 1 vorgegebene Position angefahren. POSCNFG muss auf "0" eingestellt sein.
ANCNFG=9 |  | Analog Input 1: Sollwert Strom oder Drehzahl (wie ANCNFG 0) Analog Input 2: Ferraris Sensor
ANCNFG=10 | Reserviert |
ANCNFG=11 |  | Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (SW2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes SW2 wirkt sich unmittelbar auf die Hilfsvariable INxTRIG aus (Reaktionszeit ca 1..10 msek, s. auch Beschreibung der Parameter AN11NR und AN11RANGE
ANCNFG=12 |  | Korrektur einer IN1TRIG, IN2TRIG, IN3TRIG oder IN4TRIG-Variable über den analogen Eingang 2 (SW2). Die Nummer (x) der Hilfsvariable INxTRIG wird mit dem Parameter AN11NR festgelegt. Der Bereich der Parameteränderung wird über die Variable AN11RANGE eingestellt. Die Änderung des Sollwertes SW2 wirkt sich erst bei der nächsten steigenden Flanke auf dem Eingang INPUTx aus. s. auch Beschreibung der Parameter AN11NR und AN11RANGE.
ANCNFG=13 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung des positiven Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der negative Strom wird nicht beeinflusst. Das heißt, das in der positiven Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird.
ANCNFG=14 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 wird je nach OPMODE als Drehzahl- bzw. Stromsollwert benutzt. Betrag aus SW2 wird für die Strombegrenzung des negativen Stromes benutzt Skalierung: +/- 10V -> eingestellter Spitzenstrom IPEAK +/- 5V -> 50% vom Spitzenstrom IPEAK Der positive Strom wird nicht beeinflusst. Das heißt, das in der negativen Drehrichtung der Beschleunigungsstrom und in der anderen Drehrichtung der Abbremsstrom begrenzt wird.


ASCII Deutsch ANDB

ASCII - Kommando | ANDB |
Syntax Senden | ANDB [Data] |
Syntax Empfangen | ANDB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3508 (hex)
DIM | Millivolts | PROFIBUS PNU | 1608 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 10000.0 | DPR | 8 (dec)
Default | 0 |
Opmode | 1, 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Totband für den analogen Drehzahlsollwert

Beschreibung

Die Spannung, die unter dem vorgegebenem Grenzwert liegt, wird als "Rauschen" betrachtet und intern auf 0 gesetzt. Damit kann bei Sollwert 0 ein Stillstand des Antriebes erreicht werden.
Je nach Betriebsart wirkt sich dieser Parameter auf SW1 oder SW2 (abhängig davon welcher Sollwerteingang als Drehzahlquelle benutzt wird).
S. auch Kommando ANCNFG.


ASCII Deutsch ANIN1

ASCII - Kommando | ANIN1 |
Syntax Senden | ANIN1 |
Syntax Empfangen | ANIN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3509 (hex)
DIM | Millivolts | PROFIBUS PNU | 1609 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 9 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW1

Beschreibung

Das Kommando ANIN1 liefert den aktuellen Spannungswert am Analog-Eingang SW1.


ASCII Deutsch ANIN2

ASCII - Kommando | ANIN2 |
Syntax Senden | ANIN2 |
Syntax Empfangen | ANIN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 350A (hex)
DIM | Millivolts | PROFIBUS PNU | 1610 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 10 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Spannung am Analog-Eingang SW2

Beschreibung

Das Kommando ANIN2 liefert den aktuellen Spannungswert am Analog-Eingang SW2.


ASCII Deutsch ANOFF1

ASCII - Kommando | ANOFF1 |
Syntax Senden | ANOFF1 [Data] |
Syntax Empfangen | ANOFF1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350B (hex)
DIM | Millivolts | PROFIBUS PNU | 1611 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 11 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW1

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang SW1 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANOFF2

ASCII - Kommando | ANOFF2 |
Syntax Senden | ANOFF2 [Data] |
Syntax Empfangen | ANOFF2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 350C (hex)
DIM | Millivolts | PROFIBUS PNU | 1612 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 12 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Analogoffset für den Analogeingang SW2

Beschreibung

Mit diesem Parameter kann der Eingangsoffsetdrift am Sollwerteingang SW2 korrigiert werden. Damit kann ein Analogoffset der externen Steuerung ausgeglichen werden.


ASCII Deutsch ANZERO1

ASCII - Kommando | ANZERO1 |
Syntax Senden | ANZERO1 |
Syntax Empfangen | ANZERO1 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 350F (hex)
DIM | - | PROFIBUS PNU | 1615 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 15 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | -
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW1

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 1 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 1 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF1. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.


ASCII Deutsch ANZERO2

ASCII - Kommando | ANZERO2 |
Syntax Senden | ANZERO2 |
Syntax Empfangen | ANZERO2 | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3510 (hex)
DIM | - | PROFIBUS PNU | 1616 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 16 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | -
Kurzbeschreibung | Offsetabgleich für den Analogeingang SW2

Beschreibung

Mit diesem Kommando kann der automatische Offsetabgleich für den Analogeingang 2 gestartet werden. Dazu sollte vor der Ausführung des Kommandos der Sollwert am Analogeingang 2 kurzgeschlossen werden. Nachdem das Kommando ausgeführt wurde, steht der ermittelte Offsetwert in dem Parameter ANOFF2. Damit der Wert dauerhaft im EEPROM abgespeichert wird, sollte das Kommando SAVE (im EEPROM speichern) ausgeführt werden.


ASCII Objektreferenz

Ihr Internet Browser ist nicht geeignet. Verwenden Sie einen Browser, der Frames darstellen kann.


ASCII Deutsch AUTOHOME

ASCII - Kommando | AUTOHOME |
Syntax Senden | AUTOHOME [Data] |
Syntax Empfangen | AUTOHOME <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D7 (hex)
DIM |  | PROFIBUS PNU | 1671 (dec) IND = 0001xxxx (bin)
Bereich | 0,1 | DPR | 471 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

Mit dem Kommando AUTOHOME kann das automatische Starten einer Referenzfahrt beim Freigeben der Endstufe aktiviert werden.

AUTOHOME=1 Beim Freigeben der Endstufe wird automatisch eine Referenzfahrt Gestartet (s. Kommando MH)

AUTOHOME=0 Keine automatische Referenzfahrt bei der Endstufenfreigabe


ASCII Deutsch AVZ1

ASCII - Kommando | AVZ1 |
Syntax Senden | AVZ1 [Data] |
Syntax Empfangen | AVZ1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3511 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1617 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 100.0 | DPR | 17 (dec)
Default | 1 |
Opmode | 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Filter-Zeitkonstante für den Analogeingang SW1

Beschreibung

Filter-Zeitkonstante für den Analogeingang SW1 (62,5µs Zykluszeit)


ASCII Deutsch \

ASCII - Kommando | \ |
Syntax Senden | \ [Data] |
Syntax Empfangen | \ <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Unsigned8 | CANBus Objektnummer | 362B (hex)
DIM | - | PROFIBUS PNU | 1899 (dec) IND = 0000xxxx (bin)
Bereich | 0(=Master) .. 63 | DPR | 299 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Unsigned8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Anwahl der Remote Adresse

Beschreibung

Bei einem CAN-Netzwerk an dem mehrere Verstärker angeschlossen sind, gibt es die Möglichkeit über eine serielle Verbindung zu einem der Geräte (Master), eine Kommunikation zu allen anderen Verstärkern herzustellen. Dazu wird mit dem Kommando SCAN am Master-Gerät eine automatische Erkennung aller angeschlossenen Verstärkers eingeleitet. Die Antwort auf das SCAN-Kommando enthält eine Adressenaufstellung aller erkannten Verstärker.
Mit dem Kommando "\ Addr" kann das Gerät mit der Adresse "Addr" aktiviert werden. Jedes weitere Kommando das über die serielle Schnittstelle übertragen wird, wird von der Master-Station ignoriert und über CAN-Bus an die aktivierte Verstärker-Station weitergeleitet. Die Antworten, die diese Station über CAN-Bus liefert, werden auf die serielle Schnittstelle umgeleitet. Mit dem Kommando "\ 0" kann die Slave-Station abgewählt und die Master-Station wieder aktiviert werden.

Wenn MDRV = 0 gesetzt wird, so wird die Multi-Link Funktionalität abgeschaltet.


ASCII Deutsch BCC

ASCII - Kommando | BCC |
Syntax Senden | BCC |
Syntax Empfangen | BCC <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 363A (hex)
DIM | - | PROFIBUS PNU | 1914 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 314 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | EEPROM-Checksumme

Beschreibung

Die Variable BCC liefert eine Checksumme für den Parameterbereich des seriellen EEPROM's.
In diesem Bereich werden bei einem SAVE-Kommando alle internen Parameter des Verstärkers in ASCII-Form abgelegt. Die Checksumme entsteht durch Aufsummieren aller gespeicherten Bytes und wird mit jedem LOAD bzw. SAVE-Kommando neu berechnet. Sie dient lediglich der Erkennung von EEPROM-Fehlern.
Sie kann auch benutzt werden, um zu erkennen, ob der in der Steuerung vorhandene Datensatz mit dem im Servo hinterlegten übereinstimmt.


ASCII Deutsch CALCCOG

ASCII - Kommando | CALCCOG |
Syntax Senden | CALCCOG [Data] |
Syntax Empfangen | CALCCOG | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | rpm | PROFIBUS PNU | Nein
Bereich | 0 .. 5 | DPR | Nein
Default | 2 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Erfassen der Cogging - Tabelle

Beschreibung

IN VORBEREITUNG !

CALCCOG startet die automatische Erfassung einer Cogging - Tabelle (siehe auch COGGING). Der Verstärker muss enabled sein und die Motorwelle muss sich frei drehen können, am besten ohne sonstigen Anbau. Die Verstärkung des Drehzahlreglers (GV) muss so hoch wie möglich eingestellt sein.

Während des Suchlaufs, macht der Motor zwei volle Umdrehungen mit der eingestellten Geschwindigkeit. Während der ersten Umdrehung, wird eine grobe Erfassung und während der zweiten Umdrehung eine feine Erfassung der Tabellenwerte vorgenommen.

Nachdem die Funktion abgeschlossen ist, muss die 24V - Versorgung des Verstärkers aus- und eingeschaltet werden. Damit wird die Tabelle ins FLASH kopiert.
Die Anti-Cogging funktion arbeitet zur Zeit nur bei Resolver, Hiperface oder EnDAT-Gebern mit FBTYPE = 0, 2 oder 4.

Bevor die Funktion CALCCOG gestartet werden kann, muss die Anti-Cogging Funktion mit dem Parameter COGGING freigeschaltet werden.


ASCII Deutsch CALCHP

ASCII - Kommando | CALCHP |
Syntax Senden | CALCHP [Data] , [Data] |
Syntax Empfangen | CALCHP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3512 (hex)
DIM | rpm | PROFIBUS PNU | 1618 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 200 | DPR | 18 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Hiperface-Parameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung der Hiperface-Parameter gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor eine volle Umdrehung mit der vorgegebener Drehzahl. Während dieser Phase werden die Offset-Parameter (HISOFFS/HICOFFS) sowie sinus/cosinus-Verstärkungsfaktor (HIFACT1) berechnet. Nachdem die Funktion ausgeführt wurde, können die neu ermittelten Parameter mit dem Kommandos HSAVE im Geber oder bei FBTYPE=7 im EEPROM mit dem Kommando SAVE abgespeichert werden.
Die Funktion CALCHP ist nur dann verfügbar, wenn als Feedback-Device ein Hiperface, ein EnDAT-Geber (FBTYPE=2 oder 4) oder ein Sinusgeber (FBTYPE=7) vorgewählt wurde.
Nach dem Kommando kann die Drehzahl und der Winkel, die bei der Ausführung des Kommandos verwendet werden sollen, angeben werden.

Z.B. CALCHP 5 10, Führe CALCHP mit 5 Upm und einem Bewegungswinkel von 10° aus.


ASCII Deutsch CALCRK

ASCII - Kommando | CALCRK |
Syntax Senden | CALCRK [Data] |
Syntax Empfangen | CALCRK | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3513 (hex)
DIM | rpm | PROFIBUS PNU | 1619 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 200 | DPR | 19 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Resolverparameter

Beschreibung

Mit diesem Kommando kann eine automatische Ermittlung des Resolver-Parameters RK (sinus/cosinus-Verstärkungsfaktor) gestartet werden. Dazu muß die Endstufe freigegeben und der Antrieb frei verfahrbar sein. Während der Ausführung dieses Kommandos macht der Motor eine volle Umdrehung mit der vorgegebenen Drehzahl. Falls CALCRK ohne Parameter gestartet wird, so wird die Defaulteinstallung benutzt. Nachdem die Funktion ausgeführt wurde, kann der neu ermittelte Parameter RK mit dem Kommando SAVE im EEPROM abgespeichert werden.
Mit diesem Kommando kann die Stromwelligkeit des Motors bei hohen Drehzahlen reduziert werden. Kann nur bei Resolverrückführung benutzt werden.


ASCII Deutsch CALCRP

ASCII - Kommando | CALCRP |
Syntax Senden | CALCRP |
Syntax Empfangen | CALCRP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3514 (hex)
DIM | - | PROFIBUS PNU | 1620 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 20 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ermittlung der Resolverphase

Beschreibung


ASCII Deutsch CBAUD

ASCII - Kommando | CBAUD |
Syntax Senden | CBAUD [Data] |
Syntax Empfangen | CBAUD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3515 (hex)
DIM | kBaud | PROFIBUS PNU | 1621 (dec) IND = 0000xxxx (bin)
Bereich | 10,20,50,100,125,250,333,500,666,800,1000 | DPR | 21 (dec)
Default | 500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Übertragungsrate CAN-Bus

Beschreibung

Übertragungsrate CAN-Bus


ASCII Deutsch CLRFAULT

ASCII - Kommando | CLRFAULT |
Syntax Senden | CLRFAULT |
Syntax Empfangen | CLRFAULT | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3518 (hex)
DIM | - | PROFIBUS PNU | 1624 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 24 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Löschen des Verstärker-Fehlers

Beschreibung

Das CLRFAULT Kommando löscht den Fehlerzustand eines Verstärkers. Abhängig von der Art des anstehenden Fehlers wird ein Software- bzw. Hardware-Reset des Verstärkers ausgeführt.
Bei einem Software-Reset ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die vollständige Initialisierungsphase durchlaufen (wie bei Power-On).
Außer den Verstärker-Fehlern (Display-Anzeige Fxx) werden auch folgende Warnungen gelöscht:
- Schleppfehler
- Ansprechüberwachung

Bei der Vorwahl CLRWARN=1 (separates Löschen von Warnungen) bewirkt dieses Kommando das Löschen aller anstehenden Warnungen.
Die Aufstellung aller möglichen Fehlermeldungen mit der Information über erforderlichen Hardware/Software-Reset kann der Beschreibung des Kommandos ERRCODE entnommen werden.

Das Kommando CLRFAULT kann entweder über den ASCII-Kanal (Befehl CLRFAULT) oder über den CAN / PROFIBUS (Bit „Fehler löschen“ im Steuerword) oder aber über einen digitalen Eingang (Funktion „Regler RESET“) ausgeführt werden.


ASCII Deutsch CLRHR

ASCII - Kommando | CLRHR |
Syntax Senden | CLRHR |
Syntax Empfangen | CLRHR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3519 (hex)
DIM | - | PROFIBUS PNU | 1625 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 25 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Löschen des Bit 5 im Statutsregister STAT

Beschreibung

Nach jedem Einschalten bzw. Hardware-Reset des Verstärkers wird das Bit 5 (0x20)
im STAT-Kommando auf 1 gesetzt. Mit dem Kommando CLRHR kann dieses Bit auf 0
gesetzt werden.

Mögliche Anwendung:
Die Parametriersoftware fordert alle Verstärkerparameter an, sobald ein Hardware-Reset (Bit 5 im STAT-Kommando) erkannt wurde. Nachdem alle Parameter eingelesen wurden, wird mit dem CLRHR-Kommando das Hardare-Reset-Bit auf 0 gesetzt. Das Status-Register STAT wird zyklisch abgefragt. Sobald das Hardware-Reset-Bit auf 1 steht, bedeutet es, daß der Verstärker aus- und eingeschaltet wurde und daß alle Parameter neu eingelesen werden müssen.


ASCII Deutsch CLRORDER

ASCII - Kommando | CLRORDER |
Syntax Senden | CLRORDER [Data] |
Syntax Empfangen | - | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 351A (hex)
DIM | - | PROFIBUS PNU | 1626 (dec) IND = 0000xxxx (bin)
Bereich | 0;1 ..180; 192 .. 255 | DPR | 26 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Löschen eines Fahrsatzes

Beschreibung

Mit dem Kommando „CLRORDER xx“ wird der Fahrsatz xx gelöscht.


ASCII Deutsch COGGING

ASCII - Kommando | COGGING |
Syntax Senden | COGGING [Data] |
Syntax Empfangen | COGGING <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CF (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 463 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable + Restet (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Freischalten der Cogging - Kompensation

Beschreibung

IN VORBEREITUNG !

COGGING schaltet die Cogging Kompensationsfunktion ein, welche abhängig vom Winkel der Motorwelle einen Kompensationstrom addiert.
COGGING muss zunächst auf "1" gesetzt werden, bevor der Erfassungslauf mit CALCCOG gestartet werden kann.

Wenn COGGING = 1 ist, wird das Cogging des Motors kompensiert, wenn danach die CALCCOG - Funktion gestartet wird. Bei COGGING = 0 ist die Funktion abgeschaltet und die erfasste Tabelle wird gelöscht.

Die Cogging-Kompensation arbeitet nur in FBTYPE = 0, 2 und 4.


ASCII Deutsch COLDSTART

ASCII - Kommando | COLDSTART |
Syntax Senden | COLDSTART |
Syntax Empfangen | COLDSTART | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3632 (hex)
DIM | - | PROFIBUS PNU | 1906 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 306 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Hardware-Reset des Verstärkers

Beschreibung

Hardware-Reset des Verstärkers. Hierzu muss der Verstärker disabled sein. Alle Fehler werden zurückgesetzt. Wenn Konfigurationsparameter geändert wurden, kann der Verstärker nach dem COLDSTART wieder freigegeben werden.


ASCII Deutsch CONTINUE

ASCII - Kommando | CONTINUE |
Syntax Senden | CONTINUE |
Syntax Empfangen | CONTINUE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351D (hex)
DIM | - | PROFIBUS PNU | 1629 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 29 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Fortsetzen des letzten Fahrauftrages

Beschreibung

Mit dem Kommando CONTINUE kann ein zuvor mit dem Kommando STOP abgebrochener Fahrsatz fortgesetzt werden (zu Ende gefahren werden). Dies ist besonders wichtig bei einem Fahrsatz mit relativer Verfahrstrecke.


ASCII Deutsch CPHASE

ASCII - Kommando | CPHASE |
Syntax Senden | CPHASE [Data] |
Syntax Empfangen | CPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0, 1 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Deaktivierung der Motorphasenüberwachung

Beschreibung

Die Motorphasenüberwachung überwacht, ob eine Anschlussleitung unterbrochen ist. CPHASE = 0 deaktiviert diese Überwachung.


ASCII Deutsch CTUNE

ASCII - Kommando | CTUNE |
Syntax Senden | CTUNE [Data] |
Syntax Empfangen | CTUNE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351E (hex)
DIM | Hz | PROFIBUS PNU | 1630 (dec) IND = 0000xxxx (bin)
Bereich | 400 .. 3000 | DPR | 30 (dec)
Default | 1200 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Optimierung der Stromreglerparameter

Beschreibung

Autotune-Funktion für den Stromregler. Hierzu muss der OPMODE = 2 gesetzt sein.


ASCII Deutsch CUPDATE

ASCII - Kommando | CUPDATE |
Syntax Senden | CUPDATE |
Syntax Empfangen | CUPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 351F (hex)
DIM | - | PROFIBUS PNU | 1631 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 31 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Programm-Update über CAN-Bus

Beschreibung

Das CUPDATE-Kommando aktiviert eine Funktion, die über CAN-Bus-Schnittstelle Daten empfangen und in den Programmspeicher des Verstärkers eintragen kann. Nachdem diese Funktion aktiviert wurde,werden keine Kommandos mehr über die serielle Schnittstelle angenommen.
Für den Download der Daten auf der PC-Seite sollte das Programm PRGDOWN.EXE eingesetzt werden. Dieses Programm arbeitet im Handshake-Verfahren mit der Firmware zusammen und bereitet die Daten für die CAN-Übertragung vor.


ASCII Deutsch DEC

ASCII - Kommando | DEC |
Syntax Senden | DEC [Data] |
Syntax Empfangen | DEC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3522 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1634 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 34 (dec)
Default | 10 |
Opmode | 0, 1, 8 (bei EXTPOS=1,4) | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für den Drehzahlsollwert

Beschreibung

Das Kommando DEC definiert die Bremsrampe des Drehzahlreglers. Die Bremsrampe DEC wird nur bei Sollwertsprüngen benutzt, die eine Verringerung der Drehzahl nach sich ziehen (Bremsvorgang). Für den Beschleunigungsvorgang gilt der Parameter ACC.
Die Bremsrampe DEC gilt für jede Sollwertänderung, die digital oder analog vorgegeben wird. Für die Sollwertänderungen, die intern aufgrund von Nothaltsituationen generiert werden (z.B Verstärkerfehler bzw. Wegnahme der Endstufenfreigabe), gelten separate Bremsrampen (DECSTOP/DECDIS).

Die Rampe kann mit verschiedenen Einheiten belegt werden. Details hierzu sind beim Parameter ACCUNIT aufgeführt.


ASCII Deutsch DECDIS

ASCII - Kommando | DECDIS |
Syntax Senden | DECDIS [Data] |
Syntax Empfangen | DECDIS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3523 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1635 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 35 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahl-Bremsrampe beim Sperren der Endstufe

Beschreibung

Beim Sperren der Endstufe (Wegnahme des Hardware- oder Software-Enable) wird der interne Drehzahlsollwert mit der eingestellten DECDIS-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Die Rampe DECDIS wirkt sich nur bei Motoren mit konfigurierter Bremse (MBRAKE=1) bzw. bei der Vorwahl STOPMODE=1 aus.
Bei STOPMODE=0 wird die Endstufe sofort gesperrt und der Antieb trudelt aus.


ASCII Deutsch DECR

ASCII - Kommando | DECR |
Syntax Senden | DECR [Data] |
Syntax Empfangen | DECR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3524 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1636 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 36 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe für Referenzfahrt/Tippbetrieb

Beschreibung

Das Kommando DECR definiert die Bremsrampe für den Tippbetrieb und für die Referenzfahrt mit dem internen Lageregler. Die Vorgabe erfolgt in msek und bezieht sich auf die Endgeschwindigkeit der entsprechenden Betriebsart: VJOG beim Tippbetrieb bzw. VREF bei der Referenzfahrt.
Die Bremsramperampe DECR kann u.U. beim Starten des Tippbetriebes/Referenzfahrt durch die minimale Beschleunigungszeit PTMIN begrenzt werden (siehe Beschreibung des Parameters PTMIN).
Die Rampe kann mit verschiedenen Einheiten belegt werden. Details hierzu sind beim Parameter ACCUNIT aufgeführt.


ASCII Deutsch DECSTOP

ASCII - Kommando | DECSTOP |
Syntax Senden | DECSTOP [Data] |
Syntax Empfangen | DECSTOP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3525 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1637 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 37 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Bremsrampe in Nothaltsituation

Beschreibung

Bei Nothaltsituationen wird der interne Drehzahlsollwert mit der eingestellten DECSTOP-Rampe auf 0 gesetzt. Erst nachdem der Istwert der Drehzahl die Stillstandsschwelle (VEL0) unterschritten hatte, wird die Endstufe gesperrt.
Eine Nothaltsituation liegt in folgenden Fällen vor:
- Verstärkerfehler (bei ACTFAULT=1)
- Schleppfehler
- Ansprechüberwachung (Feldbusgeräte)
- Hardware/Software-Endschalter
- Nothalt-Funktion über digitalen Eingang (INxMODE=27)
- Nothalt-Funktion über Feldbus (Steuerwort)


ASCII Deutsch DENA

ASCII - Kommando | DENA |
Syntax Senden | DENA [Data] |
Syntax Empfangen | DENA <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362D (hex)
DIM | - | PROFIBUS PNU | 1901 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 301 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | DPR Software Disable Reset Modus

Beschreibung

Bei externen DPR-SLOT-Karten gibt es die Möglichkeit durch Wegnahme des DPR-Software-Enable ggf. anstehende Geräte-Fehler zu löschen. Diese Funktion kann mit Hilfe der Variable DENA aktiviert oder gesperrt werden.

DENA=0 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen (kundenspezifisches Protokoll: Beckhoff).

DENA=1 Die Wegnahme des Software-Enable führt zu Hardware/Software-Reset des Verstärkers.
Der Reset erfolgt nur dann wenn ein Fehler bzw die Warnungen "Schleppfehler" oder "Ansprechüberwachung aktiv" anstehen.

DENA=2 Kein Reset bei Wegnahme von Software-Enable.


ASCII Deutsch DI2T

ASCII - Kommando | DI2T |
Syntax Senden | DI2T [Data] |
Syntax Empfangen | DI2T <Data> | Vorhanden in |
Type | ro | Setup Software | Nein
ASCII Format | Integer 8 | CANBus Objektnummer | Nein
DIM | % | PROFIBUS PNU | Nein
Bereich | 0 ... 100 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer 8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe |  | EEPROM |
Kurzbeschreibung | Regler I2T Auslastung

Beschreibung

Gibt die durchschnittliche I2T Belastung des Motors in % von DICONT wieder. Dieser Durchschnittswert ist gefiltert mit einer Zeitkonstanten von 16 Sekunden.


ASCII Deutsch DICONT

ASCII - Kommando | DICONT |
Syntax Senden | DICONT |
Syntax Empfangen | DICONT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3527 (hex)
DIM | Amperes | PROFIBUS PNU | 1639 (dec) IND = 0000xxxx (bin)
Bereich | 1.5 .. 20.0 | DPR | 39 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Geräte-Nennstrom

Beschreibung

DICONT gibt den Geräte-Nennstrom zurück.


ASCII Deutsch DIFVAR

ASCII - Kommando | DIFVAR |
Syntax Senden | DIFVAR |
Syntax Empfangen | DIFVAR <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3528 (hex)
DIM | - | PROFIBUS PNU | 1640 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 40 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Parameterunterschiede zu den Default-Einstellungen

Beschreibung

Das Kommando liefert eine Liste mit Parametern, deren Einstellungen nicht den Defaultwerten entsprechen. Die Liste enthält Einträge in folgender Form:

PARAMETER Wert (Default) PARAMETER = Parametername
Wert = aktuelle Parametereinstellung
Default = Defaultwert des Parameters


ASCII Deutsch DILIM

ASCII - Kommando | DILIM |
Syntax Senden | DILIM [Data] |
Syntax Empfangen | DILIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362C (hex)
DIM | - | PROFIBUS PNU | 1900 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 300 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | DPR Strombegrenzung aktivieren

Beschreibung

Bei externen DPR-SLOT-Karten gibt es eine Möglichkeit den Gerätestrom über das DPR (RAM-Schnittstelle zu der SLOT-Karte) zu begrenzen. Diese Funktionalität muß mit der Konfigurationsvariable DILIM freigegeben werden.


ASCII Deutsch DIPEAK

ASCII - Kommando | DIPEAK |
Syntax Senden | DIPEAK |
Syntax Empfangen | DIPEAK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3529 (hex)
DIM | Amperes | PROFIBUS PNU | 1641 (dec) IND = 0000xxxx (bin)
Bereich | 3.0 .. 70.0 | DPR | 41 (dec)
Default | Hardware Defined |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Geräte-Spitzenstrom

Beschreibung

DIPEAK gibt den Geräte-Siptzenstrom zurück.


ASCII Deutsch DIS

ASCII - Kommando | DIS |
Syntax Senden | DIS |
Syntax Empfangen | DIS | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 352B (hex)
DIM | - | PROFIBUS PNU | 1643 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 43 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Software Disable der Endstufe

Beschreibung

Mit dem Kommando DIS wird die Software-Freigabe für die Endstufe auf 0 gesetzt. Je nach Konfiguration (s. MBRAKE,STOPMODE) trudelt der Antrieb aus bzw. wird kontrolliert heruntergefahren.


ASCII Deutsch DISDPR

ASCII - Kommando | DISDPR |
Syntax Senden | DISDPR [Data] |
Syntax Empfangen | DISDPR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3673 (hex)
DIM | - | PROFIBUS PNU | 1971 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 371 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Disablen des DPR-Zugriffs für Schreibbefehle

Beschreibung

Mit dem Parameter DISDPR=1 kann die Übernahme der Sollwerte von einer externen Slot-DPR-Karte (z.B. Lightbus) gesperrt werden. In diesem Fall werden nur noch Lesezugriffe (Auslesen der Istwerte) akzeptiert. Die Schreibzugriffe wie z.B. Übergabe der Sollwerte, Freigeben/Sperren der Endstufe, Umschalten der Betriebsart usw. werden vollständig ignoriert. Bei dieser Einstellung ist es möglich bei laufender externer Kommunikation die internen Service-Funktionen des Verstärkers (konstante Drehzahl, konstanter Strom ...) zu nutzen.

DISDPR=0 Übernahme der Sollwerte freigeschaltet
DISDPR=1 keine Übernahme der Sollwerte von der externen Slot-Karte

Die Einstellung für DISDPR wird nicht im EEPROM abgespeichert und gilt nur bis zum nächsten Ausschalten des Verstärkers.


ASCII Deutsch DNBAUD

ASCII - Kommando | DNBAUD |
Syntax Senden | DNBAUD [Data] |
Syntax Empfangen | DNBAUD <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM | kbaud | PROFIBUS PNU | Nein
Bereich | 125,250,500 | DPR | Nein
Default | 125 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | DeviceNet Baudrate

Beschreibung


ASCII Deutsch DNDUMP

ASCII - Kommando | DNDUMP |
Syntax Senden | DNDUMP [Data] |
Syntax Empfangen | DNDUMP <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich |  | DPR | Nein
Default |  |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM |
Kurzbeschreibung | Debugging Information DeviceNet

Beschreibung


ASCII Deutsch DNMACID

ASCII - Kommando | DNMACID |
Syntax Senden | DNMACID [Data] |
Syntax Empfangen | DNMACID <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0...63 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung |

Beschreibung


ASCII Deutsch DOVRIDE

ASCII - Kommando | DOVRIDE |
Syntax Senden | DOVRIDE [Data] |
Syntax Empfangen | DOVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Int16 | CANBus Objektnummer | 36B6 (hex)
DIM | - | PROFIBUS PNU | 2038 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8192 | DPR | 438 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Int16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Vorgabe eines digitalen Override-Faktors

Beschreibung

Beim Aktivieren einer digitalen OVERRIDE-Funktion (s. Kommando OVRIDE=3)
Wird mit Hilfe dieses Parameters der digitale Override-Faktor vorgegeben.
Dabei gilt folgende Normierung:

DOVRIDE=0 Fahrsatzgeschwindigkeit = 0
DOVRIDE=8192 Fahrsatzgeschwindigkeit = 100 %


ASCII Deutsch DPRILIMIT

ASCII - Kommando | DPRILIMIT |
Syntax Senden | DPRILIMIT [Data] |
Syntax Empfangen | DPRILIMIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Int16 | CANBus Objektnummer | 3658 (hex)
DIM | - | PROFIBUS PNU | 1944 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 3280 | DPR | 344 (dec)
Default | 3280 |
Opmode | All | Datentyp Bus/DPR | Int16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Nein
Kurzbeschreibung | Digitale Begrenzung des Spitzenstroms über DPR

Beschreibung

Mit dem Kommando DPRILIMIT kann der Spitzenstrom digital begrenzt werden.
Dabei gilt folgende Normierung:

DPRILIMIT=3280 Strombegrenzung=DIPEAK
DPRILIMIT=0 Strombegrenzung = 0

Beim Einschalten des Verstärkers wird die Variable DPRILIMIT auf 3280 (keine Strombegrenzung)gesetzt. Sie wird nicht im EEPROM abgespeichert, d.h. um die Begrenzung zu aktivieren muß die Variable über Feldbus/Slot-Karte/RS232/IO-Kommandosequenz beschrieben werden.

Die digitale Strombegrenzung muß mit der Konfigurationsvariable DILIM=1 freigeschaltet werden.


ASCII Deutsch DR_TYPE

ASCII - Kommando | DR_TYPE |
Syntax Senden | DR_TYPE |
Syntax Empfangen | DR_TYPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 352E (hex)
DIM | - | PROFIBUS PNU | 1646 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 8 | DPR | 46 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Liefert die Endstufenkennung

Beschreibung

Mit dem Kommando DR_TYPE kann die Endstufenkennung ausgelesen werden.


ASCII Deutsch DREF

ASCII - Kommando | DREF |
Syntax Senden | DREF [Data] |
Syntax Empfangen | DREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 352C (hex)
DIM | - | PROFIBUS PNU | 1644 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 44 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Fahrtrichtung für die Referenzfahrt

Beschreibung

Mit dem Parameter DREF kann die Vorzugs-Fahrtrichtung bei einer Referenzfahrt und beim Positionieren mit einer Modulo-Achse (POSCNFG=2) definiert werden.
Zustand | Kurzbeschreibung | Beschreibung
DREF = 0 | Negative Fahrtrichtung | Eine Referenzfahrt wird immer mit einer negativen Geschwindigkeit (-VREF) gestartet. Bei einer Modulo-Achse wird eine Position mit einer negativen Geschwindigkeit angefahren (bei DIR=1 wird die Zielposition von rechts angefahren).
DREF = 1 | Positive Fahrtrichtung | Eine Referenzfahrt wird immer mit einer positiven Geschwindigkeit (+VREF) gestartet. Bei einer Modulo-Achse wird eine Position mit einer positiven Geschwindigkeit angefahren (bei DIR=1 wird die Zielposition von links angefahren).
DREF = 2 | Entfernungsabhängige Fahrtrichtung | Bei der Referenzfahrtart Nr.5 (NREF=5, innerhalb einer Umdrehung) wird die Fahrtrichtung abhängig von der Entfernung zum nächsten Nulldurchgang des Resolvers gewählt (der Antrieb fährt auf dem kürzesten Weg zum Nullpunkt). Bei einer Modulo-Achse fährt der Antrieb auf dem kürzesten Weg zum Zielpunkt.


ASCII Deutsch DRVCNFG

ASCII - Kommando | DRVCNFG |
Syntax Senden | DRVCNFG [Data] |
Syntax Empfangen | DRVCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3672 (hex)
DIM | - | PROFIBUS PNU | 1970 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 370 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Konfigurationsvariable für CAN-Bus Kompatibilität

Beschreibung

Die Konfigurationsvariable stellt sicher, dass bei neuen oder erweiterten CAN-Bus Funktionen, keine Inkompatibilitäten zu früheren Versionen entsteht. Falls bei neueren Versionen einen Inkompatibilität festgestellt wird, so kann diese Funktion wieder deaktiviert werden, in dem das entsprechende Bit zurückgesetzt wird.
Bit | Beschreibung
Bit 0 (0x1) | = 1 CAN-OPEN Einschalt-Telegramm 0 Bytes lang = 0 CAN-OPEN Einschalt-Telegramm 8 Bytes lang
Bit 1 (0x2) | = 1 Beeinflußung der CAN-OPEN-Zustandsmaschine durch Enable/Disable. Die CAN-open-Zustandsmaschine richtet sich nach dem internen Zustand des Servoverstärkers bei einer Änderung dieses Zustandes. =0 Die Zustandsmaschine wird bei enable/disable des Verstärkers nicht upgedated.
Bit 2 (0x4) | = 1 Überprüfung der SDO-Länge, Generierung eines Emergency-Objektes bei fehlerhafter SDO-Länge. = 0 keine Überprüfung der SDO-Länge
Bit 3 (0x8) | = 1 Abspeichern der Feldbus-Mappingdaten im seriellen EEPROM = 0 kein Abspeichern der Mappingdaten
Bit 4 (0x10) | Reserviert
Bit 5 (0x20) | Wenn das Bit 0x20 gesetzt ist, so wird die Meldung “Referenzpunkt gesetzt” (s. TRJSTAT) um die Zeit INPT verzögert. Dadurch kann, ähnlich wie bei der Meldung “In Position”, ein Flankenwechsel Low/High erzwungen werden. Dies ist besonders bei den Referenzfahrtarten “Setzen des Referenzpunktes” bzw. “Innerhalb einer Umdrehung” sinnvoll. Bei diesen Referenzfahrten kann es vorkommen, daß bei einem erneuten Starten der Referenzfahrt (bei bereits gesetztem Referenzbit), kein Wechsel Low/High innerhalb des Referenzbits festgestellt wird. (ab 4.96)
Bit 6 (0x40) | = 1 keine Überwachung der max. Spannung des Sinus/Cosinus-Gebers an X1 (Drive 400 X2) = 0 die max. Spannung des Sincos-Gebers an X1 (Drive 400 X2) wird überwacht.
Bit 7 (0x80) | Bei gesetztem Bit 7 (0x80) wird die Überlauf-Überwachung eines Multi-Turn-Gebers abgeschaltet. (ab 4.94)
Bit 8 (0x100) | Bei gesetztem Bit 8 (0x100) wird ein Single-Turn Geber wie Multi-Turn behandelt. Beim Einschalten wird die absolute Position Innerhalb einer Umdrehung übernommen. Es ist keine Referenzfahrt erforderlich. (ab 4.94)


ASCII Deutsch DUMP

ASCII - Kommando | DUMP |
Syntax Senden | DUMP |
Syntax Empfangen | DUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 352F (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 47 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Auflistung aller EEPROM-Variablen

Beschreibung

Das Kommando liefert eine Liste aller im seriellen EEPROM abspeicherbaren Parameter mit den aktuellen Werten. Alle Parameter, die verstärkerspezifisch sind (z.B. A/D-Offsetwerte) fangen mit einem ";" (Semikolon) an.


ASCII Deutsch EGEARI

ASCII - Kommando | EGEARI |
Syntax Senden | EGEARI [Data] |
Syntax Empfangen | EGEARI <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 1 ... long Integer | DPR | Nein
Default | 1024 |
Opmode | 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Loop | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

Mit den Parameter EGEARO und EGEARI wird der Skalierungsfaktor eines externen Lagegebers eingestellt um die Auflösung auf 32 Bit pro Umdrehung zu bringen. Mit dem Parameter EGEARO als Multiplikator und EGEARI als Divisor.

Beispiel 1
Ein externer 5V ROD Encoder mit 500 Strichen soll zur Lageregelung (EXTPOS = 3) genutzt werden. Um das Gebersignal auf 32 Bit pro Umdrehung zu bringen werden die Parameter EGEARO und EGEARI folgendermaßen eingestellt:
EGEARO/ EGEARI = 2^32/ (500 * 4)
EGEARO = 268435456
EGEARI = 125

Beispiel 2
Zusätzlich zum Beispiel 1 gibt es en Getriebe zwischen Motor und Last. Das Getriebe hat ne Übersetzung von 10 Motor Umdrehungen zu 3 Last Umdrehungen.
EGEARO/ EGEARI = (2^32 / (500 * 4)) * (3 / 10)
EGEARO = 402653184
EGEARI = 625


ASCII Deutsch EGEARO

ASCII - Kommando | EGEARO |
Syntax Senden | EGEARO [Data] |
Syntax Empfangen | EGEARO <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 ... Long Integer | DPR | Nein
Default | 1 |
Opmode | 4 ... 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Loop | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

Mit den Parameter EGEARO und EGEARI wird der Skalierungsfaktor eines externen Lagegebers eingestellt um die Auflösung auf 32 Bit pro Umdrehung zu bringen. Mit dem Parameter EGEARO als Multiplikator und EGEARI als Divisor.

Beispiel 1
Ein externer 5V ROD Encoder mit 500 Strichen soll zur Lageregelung (EXTPOS = 3) genutzt werden. Um das Gebersignal auf 32 Bit pro Umdrehung zu bringen werden die Parameter EGEARO und EGEARI folgendermaßen eingestellt:
EGEARO/ EGEARI = 2^32/ (500 * 4)
EGEARO = 268435456
EGEARI = 125

Beispiel 2
Zusätzlich zum Beispiel 1 gibt es en Getriebe zwischen Motor und Last. Das Getriebe hat ne Übersetzung von 10 Motor Umdrehungen zu 3 Last Umdrehungen.
EGEARO/ EGEARI = (2^32 / (500 * 4)) * (3 / 10)
EGEARO = 402653184
EGEARI = 625


ASCII Deutsch EMRGTO

ASCII - Kommando | EMRGTO |
Syntax Senden | EMRGTO [Data] |
Syntax Empfangen | EMRGTO <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 10 ... 32767 | DPR | Nein
Default | 5000 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

EMRGTO definiert die Fehlerfall Zeit bei der einstellung ACTFAULT=1 and STOPMODE=1.

Nachdem die ACTFAULT (Regler Fehler) oder STOPMODE (Enstufen) Bedingungen erfüllt sind, versucht der Regler die Achse auf Geschwindiglkeit 0 abzubremsen. Ist dies nicht möglich, so wird die Endstufe spätestens nach der mit EMRGTO eingestellten Zeit gesperrt.


ASCII Deutsch EN

ASCII - Kommando | EN |
Syntax Senden | EN |
Syntax Empfangen | EN | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3530 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 48 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Setzen des Software-Enable

Beschreibung

Mit dem Kommando EN wird die Software-Freigabe für die Endstufe gesetzt.
Wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen), so ist die Endstufe freigegeben.
Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die Leistungsspannung eingeschaltet wurde und die Ladeschaltung den Zwischenkreis aufgeladen hat. Wenn die Leistungsspannung bei enabletem Gerät weggeschaltet wird, so bleibt das Gerät enabled, bis die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet.


ASCII Deutsch ENCLINES

ASCII - Kommando | ENCLINES |
Syntax Senden | ENCLINES [Data] |
Syntax Empfangen | ENCLINES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer24 | CANBus Objektnummer | 3533 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0000xxxx (bin)
Bereich | 65535 | DPR | 51 (dec)
Default | 1000 |
Opmode | All | Datentyp Bus/DPR | Integer24
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Auflösung eines Sincos-Gebers

Beschreibung

ENCLINES beschreibt die Auflösung (ohne Vierfachauswertung) des Encoders wenn dieser als Standardrückführung verwendet wird. Bei rotierenden Motoren ist die Strichzahl pro Umdrehung anzugeben, bei Linearmotoren wird die Anzahl der Striche pro Polteilung angegeben. Wird ein ENDAT oder Hiperface Geber benutzt, so wird die Strichzahl automatisch beim initialisieren gesetzt.


ASCII Deutsch ENCMODE

ASCII - Kommando | ENCMODE |
Syntax Senden | ENCMODE [Data] |
Syntax Empfangen | ENCMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3534 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 52 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Auswahl der Encoder-Emulation

Beschreibung

Auswahl der Encoder-Emulation am Stecker X5

ENCMODE=0 Encoder-Emulation abgeschaltet
ENCMODE=1 ROD-Ausgabe
ENCMODE=2 SSI-Ausgabe
ENCMODE=3 ROD-Interpolation Ausgabe
Diese Einstellung ist nur bei einem SINCOS-Motor möglich (FBTYPE>0). Bei der ROD-Interpolation werden pro Motorumdrehung ENCOUT*ENCLINES Impulse ausgegeben. Bei ENCMODE=3 sind folgende ENCOUT-Einstellungen möglich: 4,8,16,32,64,128


ASCII Deutsch ENCOUT

ASCII - Kommando | ENCOUT |
Syntax Senden | ENCOUT [Data] |
Syntax Empfangen | ENCOUT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3535 (hex)
DIM | CPR | PROFIBUS PNU | 1653 (dec) IND = 0000xxxx (bin)
Bereich | see Description | DPR | 53 (dec)
Default | 1024 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Auflösung für die Encoder-Emulation (ROD)

Beschreibung

Auflösung für die Encoder-Emulation (ROD)

ENCOUT definiert die Anzahl der Impulse, die bei einer Motorumdrehung über die ROD-Schnittstelle ausgegeben werden.
Bei Resolvermotoren (FBTYPE=0) kann die Strichzahl von 256 bis 4096 auf alle ganzzahligen Werte eingestellt werden. Es wird ein Nullimpuls pro Umdrehung ausgegeben.
Bei FBTYPE =7 kann die Strichzahl nur auf ganze 2er Potenzen eingestellt werden. Hier sind Strichzahlen von 256, 512, 1024, .. , 262144, 524288 möglich.

Bei FBTYPE=2 und 4 können auch alle ganzzahligen Strichzahlen zwischen 256 und 4096 ausgegeben werden.


ASCII Deutsch ENCZERO

ASCII - Kommando | ENCZERO |
Syntax Senden | ENCZERO [Data] |
Syntax Empfangen | ENCZERO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3537 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. ENCOUT-1 | DPR | 55 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Output | EEPROM | Ja
Kurzbeschreibung | Nullimpulsoffset (ROD-Ausgabe)

Beschreibung

Mit Hilfe des Kommandos ENCZERO kann die Ausgabe des ROD-Nullimpulses innerhalb einer Umdrehung verschoben werden. Die Verschiebung erfolgt im Uhrzeigersinn z.B.
ENCOUT 1024
ENCZERO 256 Der Nullimpuls wird bei 90 Grad ausgegeben.

Wirkt auch bei SSI - Ausgabe.


ASCII Deutsch ERND

ASCII - Kommando | ERND |
Syntax Senden | ERND [Data] |
Syntax Empfangen | ERND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3638 (hex)
DIM | - | PROFIBUS PNU | 1912 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 312 (dec)
Default | 2^31-1 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Endposition Modulo-Achse

Beschreibung

Mit dem Parameter ERND wird das Ende des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Der Anfang des Bereiches kann mit dem Kommando SRND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für ERND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI,PGEARO).


ASCII Deutsch ERRCODE

ASCII - Kommando | ERRCODE |
Syntax Senden | ERRCODE |
Syntax Empfangen | ERRCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Ausgabe der aktiven Fehlermeldungen

Beschreibung

Das Kommando ERRCODE liefert die Information über aktuell anstehende Fehler im Klartext.


ASCII Deutsch ERRCODE *

ASCII - Kommando | ERRCODE * |
Syntax Senden | ERRCODE * |
Syntax Empfangen | ERRCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 0xFFFFFFFF | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Ausgabe des Fehlerregisters

Beschreibung

Das Kommando ERRCODE * liefert die Information über aktuell anstehende Fehler in Form einer Bit-Variable. Ein Bit wird gesetzt sobald der zugehörige Fehler erkannt worden ist. Das Löschen der Fehlerbits erfolgt beim Hardware-Reset des Verstärkers.
Fehler, die mit dem Kürzel SW gekennzeichnet sind, können auch per Software-Reset (Funktion „Fehler löschen“, CLRFAULT) gelöscht werden.

Unter Level werden die verschiedenen Fehlerbehandlungen angegeben.

Level 2: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt drehzahlgeregelt mit der Nothalt-Rampe (DECSTOP). Nach dem Erreichen der Stillstandsschwelle VEL0 (spätestens nach 5 Sekunden) wird die Endstufe gesperrt. Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 3: Eine Störung führt zum Anhalten des Antriebs (Nothalt). Das Abbremsen erfolgt ohne Positionsinformation der Rückführeinheit. Nach dem Erreichen des Stillstands wird die Endstufe gesperrt.Der Verstärker ist nicht mehr betriebsbereit (kein BTB), weiterer Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx). Darüber hinaus wird im Statusregister ein Fehlerbit gesetzt, das über einen digitalen Ausgang nach außen gemeldet werden kann.

Level 4: Eine Störung führt zum sofortigen Sperren der Endstufe. Der Antrieb trudelt unkontrolliert aus, der Verstärker ist nicht mehr betriebsbereit (kein BTB). Der weitere Betrieb ist erst nach dem Quittieren der Störung möglich. Die Störung wird im Display als Fehler Nr. xx angezeigt (Anzeige Fxx).
Das Fehlerbit, das im Statusregister gesetzt wird, kann über einen digitalen Ausgang nach außen gemeldet werden.

Bei den Fehlern, die gleichzeitig den Ebenen 2/3 und 4 zugeordnet sind, entscheidet über die Ebenen-Zugehörigkeit der Zustand der Parameter ACTFAULT und MBRAKE.

ACTFAULT=1 oder MBRAKE=1 LEVEL 2 bzw. 3 (Default-Einstellung)
ACTFAULT=0 und MBRAKE=0 LEVEL 4
Bit/Displ./Reset/Level | Bitkombination | Beschreibung
00/F01/SW/2,4 0x00000001 =1 Fehler Kühlkörpertemperatur
wird gesetzt sobald die aktuelle Kühlkörpertemperatur (TEMPH) den maximal zulässigen Wert (MAXTEMPH) überschreitet.
01/F02/SW/2,4 0x00000002 =1 Fehler Überspannung
wird gesetzt sobald die Zwischenkreisspannung den max. zulässigen Wert (gegeben über VBUSBAL) überschreitet.
02/F03/SW/2 0x00000004 =1 Schleppfehler bei Ausführung der externen Trajektorie (OPMODE=6/SERCOS)
wird gesetzt sobald die Geschwindigkeit, die über die externe Trajektorie vorgegeben wird, die max. Drehzahl VLIM/VLIMN überschreitet.
03/F04/HW/3,4 0x00000008 =1 Feedback-Fehler
wird gesetzt wenn die Amplitude der Resolver/Encoder-Signale den minimalen Grenzwert unterschreitet
04/F05/SW/2,4 0x00000010 =1 Fehler Unterspannung
wird gesetzt sobald die Zwischenkreisspannung den min. zulässigen Wert (VBUSMIN) unterschreitet.
05/F06/HW/2,4 0x00000020 =1 Fehler Motortemperatur
wird gesetzt sobald der Widerstand des Motortemperaturfühlers (TEMPM) den maximal zulässigen Wert (MAXTEMPM) überschreitet.
06/F07/HW/2,4 | 0x00000040 | =1 wird gemeldet wenn die internen Versorgungsspannungen fehlerhaft sind.
07/F08/SW/3,4 0x00000080 =1 Fehler Überdrehzahl
wird gesetzt wenn die aktuelle Motordrehzahl (V) den max. zulässigen Wert (VOSPD) überschreitet.
08/F09/HW/4 0x00000100 =1 Fehler EEPROM
wird gesetzt, wenn beim Lesen/Schreiben des seriellen EEPROM´s ein Fehler aufgetreten ist. Dieser Fehler kann wird verursacht entweder durch ein fehlerhaftes EEPROM oder durch eine fehlerhafte Daten-Checksumme. In dem zweiten Fall kann der Fehler durch erneutes Abspeichern der Daten (SAVE) beseitigt werden.
09/F10/HW | 0x00000200 | Reserve
10/F11/HW/2,4 0x00000400 =1 Fehler Bremse
wird gesetzt, wenn der Bremsenschalter einen Fehler meldet (z.B. Bremse nicht angeschlossen).
11/F12/HW | 0x00000800 | =1 Fehler Motorphase. Dieser Fehler tritt auf, wenn eine Motorphase nicht richtig angeschlossen ist. Dieser Fehler kann abgeschaltet werden, in dem CPHASE = 0 gesetzt wird.
12/F13/SW/2,4 0x00001000 =1 Fehler Umgebungstemperatur
wird gesetzt sobald die aktuelle Umgebungstemperatur (TEMPE) den maximal zulässigen Wert (MAXTEMPE) überschreitet.
13/F14/HW/2,4 0x00002000 =1 Fehler Endstufe
Es sind folgende Ursachen möglich: Erdschluß, Motorkurzschluß oder Ballastkurzschluß.
14/F15/SW/2,4 0x00004000 =1 I2tmax überschritten
wird gesetzt wenn I2t 115 % (bei FOLDMODE=0) bzw. 105 % (bei FOLDMODE=1) überschritten hatte.
15/F16/SW/2,4 | 0x00008000 | =1 Netz-BTB
16/F17/HW/2,4 0x00010000 =1 Fehler A/D-Wandler
wird gesetzt wenn beim Einschalten des Verstärkers zu große Stromoffsetwerte gemessen werden.
17/F18/HW/2,4 | 0x00020000 | =1 Ballast-Fehler (defekter Ballasttransistor, Vorwahl „Ballastwiderstand extern“ bei Anschluß des internen Ballastwiderstandes).
18/F19/SW/2,4 | 0x00040000 | =1 fehlende Netzphase bei PMODE=2
19/F20/HW/2,4 0x00080000 =1 Slot-Error
Diese Fehlermeldung wird generiert, wenn bei vorhandener Slot-Erweiterungskarte ein Fehler erkannt wurde. Die mögliche Fehlerursache hängt von der Art der Slot-Erweiterungskarte ab.
1. I/O-Erweiterungskarte – Der Fehler wird generiert, wenn die 24V-Versorgungsspannung der Erweiterungskarte abgeschaltet wird.
2. DPR-Erweiterungskarten (Beckhoff,L&B,Sigmatek)
Die Fehlermeldung erscheint, wenn der DPR-Innterrupt von der Erweiterungskarte ausbleibt (die Überwachungszeit kann mit dem Parameter EXTWD in msek eingestellt werden).
3. PROFIBUS:
Initialisierungsfehler nach dem Einschalten
20/F21/HW/2,4 0x00100000 =1 Handling Error
PROFIBUS:
Wird der Operationsmode (OPMODE) bei betriebsbereitem PROFIBUS über einen anderen Kommunikationskanal geändert, wird diese Fehlermeldung generiert und der Antrieb, falls erforderlich, notgebremst.
Ausnahme: Betriebsart –126 (nur Profibus). Gesicherte Betriebsart nach dem Einschalten.
21/F22/HW/2,4 0x00200000 =1 Erdschluß
Die Erdschluß-Überwachung ist nur bei den 40/70A Endstufen realisiert.
22/F23/HW/2,4 0x00400000 =1 CANBUS Bus-Off
Fehler in der CAN – Kommunikation
Die Kommunikationsstörung BUSOFF wird direkt von der Schicht 2 (CAN Controller) überwacht und gemeldet. Diese Meldung kann unterschiedliche Ursachen haben. Hier einige Beispiele: Telegramm wird gesendet, obwohl kein weiterer CAN – Knoten angeschlossen ist, CAN Knoten weisen unterschiedliche Baudraten auf, Busleitung defekt, Reflexionen auf den Leitungen aufgrund fehlerhafter Leitungsabschlüsse,......

Ein BUSOFF wird vom Servostar nur gemeldet, wenn ein weiterer CAN Knoten angeschlossen ist und mindesten ein Objekt zu Beginn erfolgreich abgesetzt werden konnte. Der Zustand BUSOFF wird mit der Fehlermeldung F23 signalisiert. Sollte beim Auftreten dieses Fehlers die Endstufe freigegeben (enable) sein und eine Fahrfunktion ausgeführt werden, wird der Antrieb mit der Notbremsrampe angehalten und die Endstufe gesperrt (disable).
23/F24/SW/2,4 | 0x00800000 | Warnung in Fehler gewandelt (definiert durch WMASK)
24/F25/HW/3,4 | 0x01000000 | Kommutierungsfehler (Durchgehen des Motors)
25/F26/SW/2,4 | 0x02000000 | Hardware-Endschalter - Fehler bei Referenzfahrt (definiert durch REFLS)
26/F27/HW/4 0x04000000 =1 Fehler „-AS-Option“
Diese Fehlermeldung wird generiert, wenn beim Aktivwerden der AS-Option die Endstufe freigegeben war (ab Version 3.44).
27/F28/SW/2 0x08000000 =1 Fehler „externe Trajektorie“
wird generiert, wenn der Sollwertsprung bei der Vorgabe der externen Positions-Trajektorie den maximal zuläßigen Wert überschreitet.
28/F29/SW/2 | 0x10000000 | =1 Sercos-Fehler
29/F30/SW | 0x20000000 | Sercos Notstop Time-out
30/F31/SW | 0x40000000 | Reserve
31/F32/HW/4 0x80000000 =1 Systemfehler
zeigt einen internen Fehler an. Dieser Fehler wird beim Einschalten des Verstärkers generiert, wenn die Systemüberprüfung während der Initialisierungsphase nicht erfolgreich abgeschlossen werden konnte.
Es sind folgende Ursachen möglich:
1. Fehlerhafte Datentabelle im Flash (mögliche Ursache: abgebrochener Firmware-Update).
2. Macro-Fehler (fehlerhaftes Macro-Programm)
3. Software-Watch-Dog (Fehler bei der Programmausführung)
4. Serielles EEPROM (Fehler beim Lesen/Schreiben des seriellen EEPROM´s)
5. FPGA-Fehler (Fehler beim Laden des FPGA-Programmes)
6. Makro-RAM - zu wenig RAM für die Makro-Programme
Beim Einschalten des Verstärkers, wird im Falle eines Systemfehlers, die genaue Fehlerursache über die serielle Schnittstelle (RS232) ausgegeben.


ASCII Deutsch ESPEED

ASCII - Kommando | ESPEED |
Syntax Senden | - |
Syntax Empfangen | ESPEED <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3675 (hex)
DIM | rpm | PROFIBUS PNU | 1973 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 16000 | DPR | 373 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | -
Kurzbeschreibung | Maximale Drehzahl in Abhängigkeit vom Gebertyp

Beschreibung

Das Kommando ESPEED liefert die maximale Drehzahl, die bei der vorhandenen
Rückführeinheit (FBTYPE), vom Antrieb gefahren werden kann.


ASCII Deutsch EXTWD

ASCII - Kommando | EXTWD |
Syntax Senden | EXTWD [Data] |
Syntax Empfangen | EXTWD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 353A (hex)
DIM | Milliseconds | PROFIBUS PNU | 1658 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 58 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Überwachungszeit für Feldbus-Befehle

Beschreibung

Mit dem Parameter EXTWD kann die Überwachungszeit (Watch-Dog) für die Feldbus/Slot-Kommunikation definiert werden. Die Überwachung ist nur dann aktiv, wenn der Parameter EXTWD einen Wert größer 0 enthält (EXTWD=0, Überwachung abgeschaltet) und die Endstufe freigegeben ist. Falls die eingestellte Zeit abgelaufen ist, ohne daß der Timer neu getriggert wurde,so wird die Warnung n04 (Ansprechüberwachung) generiert und der Antrieb angehalten. Der Verstärker bleibt weiterhin betriebsbereit und die Endstufe freigegeben. Bevor ein neues Fahrkommando (Sollwert) akzeptiert wird, muß diese Warnung gelöscht werden (Funktion CLRFAULT oder INxMODE=14).
Beim DeviceNet wird die Überwachung mit dem Wert 1/0 ein-/ausgeschaltet. (Die Watchdog Zeit wird über den DeviceNet Controller gesetzt.)


ASCII Deutsch FBTYPE

ASCII - Kommando | FBTYPE |
Syntax Senden | FBTYPE [Data] |
Syntax Empfangen | FBTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 20 | DPR | 59 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Vorwahl der Rückführeinheit

Beschreibung

Mit dem Kommando FBTYPE kann die Art des Feedback-Devices vorgewählt werden.
Die eingestellte Geberart wird nur beim Einschalten des Verstärkers initialisiert d.h. nach jeder Änderung dieser Variable, muß der Verstärker aus- und eingeschaltet werden.
Die Encoder-Parameter können mit dem entsprechenden ASCII-Kommando (in Klammern) verändert und mit dem Kommando HSAVE im Encoder-Eeprom abgespeichert werden. Die Encoder-Kommandos (HISOFFS, HICOFFS, HIFACT1, HSAVE) sind nur dann verfügbar, wenn eine Kommunikation zum angeschlossenen Encoder aufgebaut werden konnte.
Falls der Encoder nicht angesprochen werden konnte, so wird die Fehlermeldung ENCODER-FEHLER F04 angezeigt.
Beim Laden der Daten aus dem Encoder wird die Einstellung der Motornummer im Encoder mit der internen Einstellung (MNUMBER) verglichen. Falls die Nummern unterschiedlich sind, so wird versucht aus der internen Motordatenbank einen Motordatensatz mit der im Encoder abgelegten Motornummer zu laden. Gleichzeitig wird die Warnung „NEUER MOTORDATENSATZ“ n12 angezeigt.
Damit beim nächsten Einschalten keine Warnung ausgegeben wird, sollte die aktuelle MNUMBER-Einstellung mit dem Kommando SAVE im EEPROM abgespeichert werden. Falls keine gültige Motordatensatznummer aus dem Encoder geladen werden konnte (z.B. bei einem zum ersten Mal benutzten Encoder), so werden keine Motor-Daten geladen. Die Warnung n12 wird aber weiterhin ausgegeben. Mit dem HSAVE-Kommando kann die aktuelle Einstellung der Motornummer (MNUMBER) im Encoder abgespeichert werden, so daß beim nächsten Einschalten keine Warnung mehr generiert wird.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7/16) und damit ohne Fähigkeit Parameter abzuspeichern, werden die Offsetwerte HISOFFS / HICOFFS / HIFACT1 im seriellen EEPROM des Verstärkers abgespeichert. Nach einer Änderung können diese Werte mit dem SAVE-Kommando dauerhaft gespeichert werden.
Zustand | Art des Gebers | Beschreibung
FBTYPE = 0 | Resolver | Daten werden aus dem EEPROM des Verstärkers geladen.
FBTYPE = 2 Hiperface (Stegmann) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 3 Resolver, EnDAT oder Hiperface Automatische Ermittlung des angeschlossenen Rückführungssystems.
Es wird zunächst versucht eine Kommunikation zum Endat (FBTYPE=4) aufzubauen. Falls diese Kommunikation nicht aufgebaut werden konnte, wird als nächstes ein Hiperface-Geber angesprochen (FBTYPE=2). Falls auch diese Kommunikation nicht aufgebaut werden konnte wird ein Resolver als Feedback-Device eingestellt (FBTYPE=0).
Unabhängig vom Ergebnis der automatischen Suche bleibt die FBTYPE-Einstellung (FBTYPE=3) erhalten. Um zu überprüfen welcher Geber erkannt wurde, kann das Kommando „M FBTYPE“ benutzt werden.
FBTYPE = 4 EnDAT (Heidenhain) Beim Einschalten des Verstärkers werden alle im Encoder-EEPROM abgespeicherten Daten geladen. Dazu gehören:
Offsetkorrektur Sinus (HISOFFS)
Offsetkorrektur Cosinus (HICOFFS)
Amplitudennormierung (HIFACT1)
Motornummer (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 6 Sinus/Cosinusgeber Sinus/Cosinus-Geber, Laden von MPHASE aus dem seriellen EEPROM,
Abspeichern der Faktoren HISOFFS,HICOFFS,HIFACT1 im seriellen EEPROM.
FBTYPE = 7 Sinus/Cosinusgeber Sinus/Cosinus-Geber (automatische Ermittlung von MPHASE), Abspeichern
der Faktoren HISOFFS,HICOFFS,HIFACT1 im seriellen EEPROM.
Nach dem Einschalten der 24V oder nach einem COLDSTART wird zunächst eine Warnmeldung n14 angezeigt. Nach dem Enablen des Verstärkers wird dann zunächst der Wake&Shake-Modus aktiviert, um den Kommutierungswinkel zu ermitteln. Hierzu macht der Motor eine kurze Ruckbewegung. Danach wird die Warnung zurückgesetzt.
FBTYPE=8 | RS422 & Wake&Shake | Diese Einstellung kann nur mit GEARMODE=3 und ENCMODE=0 verwendet werden (Siehe ENCLINES).
FBTYPE=9 RS422 Rückführung
MPHASE wird aus dem EEPROM geladen 		Diese Einstellung kann nur mit GEARMODE=3 und ENCMODE=0 verwendet werden.
FBTYPE=10 | Ohne Rückführung (Sensorless)
FBTYPE=11 | SIN-Cosinusgeber Rückführung mit Hall-Sensor
FBTYPE=12 RS422-Rückführung mit Hall Sensor

Bei Linearmotoren kompensiert MPHASE = 180 invertierte Hall Sensoren. Ebenso kann hiermit eine Fehljustage der Halls ausgeglichen werden.
FBTYPE = 16 | Hochfahren mit Resolver -> Umschalten auf sincos (FBTYPE=7) | Die Kommutierungsinformation wird beim Einschalten über den Resolver eingelesen. Dann wird auf den hochauflösenden Geber umgeschaltet, der dann zur Drehzahl- und Positionsrückführung benutzt wird. Das Umschalten auf sincos erfolgt nach einer Einschaltverzögerung gleichzeitig mit der Freigabe der ROD-Simulation.


ASCII Deutsch FLASH

ASCII - Kommando | FLASH |
Syntax Senden | FLASH [Data] |
Syntax Empfangen | FLASH <Data> | Vorhanden in |
Type | wo | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D9 (hex)
DIM |  | PROFIBUS PNU | 1673 (dec) IND = 0001xxxx (bin)
Bereich | 0 ... 4 | DPR | 473 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer8
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM |
Kurzbeschreibung |

Beschreibung

IN VORBEREITUNG !

Das Kommando FLASH wird benutzt um Firmware/Parameter-Daten zwischen dem Verstärker und der externen Flash-Karte zu transferieren.

Die externe Flash-Karte dient als externes Speichermedium sowohl für die Firmware als auch für die Verstärker-Parameter. Mit ihrer Hilfe kann ein Firmware-Update sehr schnell durchgeführt werden, ohne daß zusätzliche Hardware (z.B PC) erforderlich ist. Die Upload/Download-Kommandos für den Verstärker können entweder mit Hilfe von ASCII-Kommando FLASH bzw durch Betätigung der Taster S1/S2 an der Frontplatte der Flash-Karte ausgelöst werden.

Das FLASH-Kommando kann mit folgenden Optionen benutzt werden:

FLASH=0 Ausgabe eines Informationstextes über die Versionsnummer der auf der Flash-Karte abgespeichertn Firmware. In der zweite Zeile wird zum Vergleich die aktuelle Verstärker-Firmwareversion angezeigt.

FLASH=1 Speichern aller Verstärker-Daten auf die Flash-Karte (UPLOAD).Es werden die aktuelle Firmware-Version, Verstärker-Parameter, Motor-Datenbank, PLC-Programm, Kurvenprofile sowie Flash-Fahrsätze
auf die Flash-Karte geschrieben. Dieses Kommando wird auch ausgelöst, wenn der Taster S1 betätigt wird.
Während der Ausführung dieses Kommandos erscheint in dem mittleren Display-Segment der Buchstabe ‚u‘ (UPLOAD). Nachdem das Kommando beendet wurde, erfolgt ein automatischer Reset des Verstärkers.

FLASH=2 Laden aller Verstärker-Daten von der Flash-Karte (DOWNLOAD).Es werden die Firmware-Version, Verstärker-Parameter, Motor-Datenbank, PLC-Programm, Kurvenprofile sowie Flash-Fahrsätze in den Verstärker geladen. Dieses Kommando wird auch ausgelöst, wenn der Taster S2 betätigt wird.
Während der Ausführung dieses Kommandos erscheint in dem mittleren Display-Segment der Buchstabe ‚d‘ (DOWNLOAD). Nachdem das Kommando beendet wurde, erfolgt ein automatischer Reset des Verstärkers.

FLASH=3 Löschen der externen Flash-Karte.

FLASH=4 Laden der Parameter-Daten von der Flash-Karte in den Verstärker. Es werden ausschließlich die Daten aus dem seriellen EEPROM (Parameter-Speicher) übertragen.

ACHTUNG !!
Das FLASH-Kommando darf nur bei gesperrter Endstufe und abgeschalteter Netzspannung ausgeführt werden. Während der Ausführung dieses Kommandos
darf die Versorgungsspannung des Verstärkers (24 V) nicht ausgeschaltet werden.
Bei Nichtbeachtung droht ein Verlust der Daten/Firmware im Verstärker bzw. auf der Flash-Karte.

Bei Verstärkern, die keine Firmware-enthalten, wird beim Einschalten automatisch das Monitor-Programm gestartet. Die Unterstützung der Flash-Karte im Monitor-Programm wurde erst ab der Version 7.2 implementiert. Die Benutzung der Flash-Karte mit älteren Versionen des Monitor-Programmes ist nicht möglich.

Aufgrund des beschränkten Speicherplatzes ist die Unterstützung der Flash-Karte durch das Monitor-Programm (Version >= 7.2) nur auf die wichtigsten Funktionen begrenzt. Das FLASH-Kommando kann mit folgenden Optionen benutzt werden:

FLASH=0,1,2

Bei den Optionen 1 und 2 werden ausschließlich Flash-Eprom-Daten übertragen.
Das Speichern/Laden von den Parameter-Daten mit Hilfe des Monitor-Programmes ist nicht möglich. Bei Bedarf, können diese Daten nachträglich, von der Firmware aus, mit dem Kommando FLASH=4 geladen werden.


ASCII Deutsch FLTCNT

ASCII - Kommando | FLTCNT |
Syntax Senden | FLTCNT |
Syntax Empfangen | FLTCNT <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0, 65535 per Fault Message | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando FLTCNT gibt eine Aufstellung aller möglichen Fehlermeldungen mit der zugehörigen Anzahl der bisher aufgetretenen Fehler im Klartext aus. Vor der eigentlichen Fehlerliste wird die Gesamtzahl der Fehler (Summe der Einzelfehler) ausgegeben.


ASCII Deutsch FLTCNT *

ASCII - Kommando | FLTCNT * |
Syntax Senden | FLTCNT * |
Syntax Empfangen | FLTCNT * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 1 x Integer32 + 32 x Integer16 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Fehleranzahl

Beschreibung

Das Kommando liefert eine Liste von 33 Zahlen:
Zahl 1. Gesamtzahl der Fehler (Integer32)
Zahl 2. Anzahl des Auftretens für den Fehler F01
Zahl 3. Anzahl des Auftretens für den Fehler F02
..........
Zahl 33. Anzahl des Auftretens für den Fehler F32


ASCII Deutsch FLTHIST

ASCII - Kommando | FLTHIST |
Syntax Senden | FLTHIST |
Syntax Empfangen | FLTHIST <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | Number and TRUN | PROFIBUS PNU | Nein
Bereich | 10 No. of Last Messages+Times | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie den zugehörigen Betriebsstundenstand beim Auftreten des Fehlers im Klartext aus.


ASCII Deutsch FLTHIST *

ASCII - Kommando | FLTHIST * |
Syntax Senden | FLTHIST * |
Syntax Empfangen | FLTHIST * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | 20 x Integer32 | CANBus Objektnummer | Nein
DIM | Number and TRUN | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Fehlerstatistik: Anzeige der letzten 10 Fehler

Beschreibung

Das Kommando FLTHIST * gibt eine Liste mit den 10 zuletzt aufgetretenen Fehlern sowie dem zugehörigen Betriebsstundenstand beim Auftreten des Fehlers als Zahlen aus.
Die Ausgabe sieht wie folgt aus:
n1 t1 n2 t2 n3 t3 ....n10 t10
n - Fehlernummer
t - Zeitpunkt des Auftretens (Betriebsstundenzähler) [in 1024/60000 Minuten]


ASCII Deutsch FLUXM

ASCII - Kommando | FLUXM |
Syntax Senden | FLUXM [Data] |
Syntax Empfangen | FLUXM <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3689 (hex)
DIM | - | PROFIBUS PNU | 1993 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 393 (dec)
Default | 4500 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Nennfluss des Synchronmotors

Beschreibung

IN VORBEREITUNG !

FLUXM is ein Leseparameter, welcher den Nennfluss des Synchronmotors angibt. Dieser Parameter wird über die Drehmomentkonstante Kt bestimmt. Die Einheit ist counts. Es kann der Fluss in Vs berechnet werden, indem die Counts durch 22000 geteilt werden.

Dieser Parameter ist bei sensorlosem Betrieb wichtig.


ASCII Deutsch FW

ASCII - Kommando | FW |
Syntax Senden | FW |
Syntax Empfangen | FW <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3657 (hex)
DIM | - | PROFIBUS PNU | 1943 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 343 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Liefert die Versionsnummer der Firmware

Beschreibung

Das Kommando FW liefert die Versionsnummer der aktuellen Firmware. Das Kommando erscheint in der Ausgabe des DUMP-Kommandos und damit gehört es zum Parametersatz des Verstärkers.


ASCII Deutsch GEARFILT

ASCII - Kommando | GEARFILT |
Syntax Senden | GEARFILT [Data] |
Syntax Empfangen | GEARFILT <Data> | Vorhanden in |
Type |  | Setup Software | Nein
ASCII Format | Command | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 1 ...8 | DPR | Nein
Default | 4 |
Opmode | 0 | Datentyp Bus/DPR | Command
Verstärker Status | Enable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position | EEPROM | -
Kurzbeschreibung |

Beschreibung

Beim elektronischen Getriebe ( OPMODE = 4 ), kann ein Tiefpaßfilter zweiter Ordnung aktiviert werden, um den Sollwert zu glätten. Der Befehl GEARFILT setzt hierbei die Frequenz fest.

GEARFILT f (HZ)
1 318
2 159
3 80
4 40
5 20
6 10
7 5
8 2.5

Der Filter sollte nur benutzt werden wenn es bei der Anwendung notwendig ist, da er eine dynamische Verzögerung zwischen Master und Slave hervorruft. Standardmäßig kann GEARFILT = 4 mit 40 Hz Einsatzfrequenz gewählt werden.


ASCII Deutsch GEARI

ASCII - Kommando | GEARI |
Syntax Senden | GEARI [Data] |
Syntax Empfangen | GEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 353E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 2147483647 | DPR | 62 (dec)
Default | 8192 |
Opmode | 4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Eingangsfaktor "elekronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.


ASCII Deutsch GEARMODE

ASCII - Kommando | GEARMODE |
Syntax Senden | GEARMODE [Data] |
Syntax Empfangen | GEARMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 353F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 17 | DPR | 63 (dec)
Default | 6 |
Opmode | 4 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Masterschnittstelle für "elektronisches Getriebe"

Beschreibung

Mit dem Parameter GEARMODE kann die Quelle für die Master-Sollwertvorgabe (Position) konfiguriert werden.

Es ist möglich gleichzeitig Resolver, Sincos und ROD-Signale auszuwerten.
Damit kann der Resolver für die Kommutierung, Sincos für die externe Lageregelung und ROD für
Master/Slave-Funktion eingesetzt werden. Um diese Funktion zu nutzen müssen folgende
Einstellungen gemacht werden:

EXTPOS= 1...3 (Einlesen der Position für externe Lageregelung)
GEARMODE=10...17 Zusätzlich zu den bei GEARMODE 0 .. 7 vorgegebenen Auswahlmöglichkeiten, kann ein Sinus-Encoder an X1 für die Lageregelung verwendet werden (EXTPOS = 1).
Zustand | Beschreibung
GEARMODE=0 Encoder follower X3, 24V.
An den digitalen Eingängen 1 und 2 kann ein Encoder mit A/B-Signalen mit einem Signalpegel von 24V angeschlossen werden. Es müssen keine weiteren Eingangsfunktionen angewählt werden. Falls welche ausgewählt wurden, so werden diese ignoriert.
GEARMODE=1 Puls/Richtungseingang an X3, 24V
INPUT1=Richtung (Low=positiv, High=negativ)
INPUT2=Pulse
Es müssen keine weiteren Eingangsfunktionen angewählt werden. Falls welche ausgewählt wurden, so werden diese ignoriert.
GEARMODE=2 | Wirkt wie GEARMODE=0
GEARMODE=3 Encoder Folger an X5 (Drive 400 X4).
An X5 (Drive 400 X4) kann ein Inkrementalgeber mit 5V - A/B-Signalen angeschlossen werden.
ENCMODE muss auf "0" gesetzt werden.
GEARMODE=4 Puls/Richtung an X5 (Drive 400 X4).
An X5 (Drive 400 X4) kann eine Schrittmotorsteuerung mit 5V - Puls/Richtung-Signalen angeschlossen werden.
ENCMODE muss auf "0" gesetzt werden.
GEARMODE=5 | Wirkt wie GEARMODE=3
GEARMODE=6 | Sinus Encoder an X1 (Drive 400 X2). Es werden nur die Nulldurchgänge der Sinus/Cosinussignale ausgewertet. Keine analoge Auswertung.
GEARMODE=7 SSI-Input X5 (Drive 400 X4). Bei Einstellung GEARMODE=7, OPMODE=4 wird das Einlesen der SSI-Position über den Encoder-Eingang aktiviert. Alle 250µsek wird die SSI-Position eingelesen und die Differenz zu der vorhergehenden (250µsek alten) Position gebildet. Anschließend wird diese Differenz mit dem Skalierungsfaktor multipliziert und auf den letzten Positionssollwert aufaddiert.

Skalierungsfaktor = 2^(33-SSIOUT)* GEARO / GEARI ; bei PRBASE=20
Skalierungsfaktor = 2^(29-SSIOUT) * GEARO / GEARI ; bei PRBASE=16

Die absoluten Positionen vom Master/Slave können mit Hilfe des jeweiligen ROFFS-Parameters verschoben werden. Um die absoluten Positionswerte des Masters und Slaves untereinander abzugleichen, muß eine Referenzfahrt NREF=8 gestartet werden (digitaler Eingang, ASCII-Kommando MH, Feldbus). Beim Start dieser Referenzfahrt wird die aktuelle Absolutposition des Masters eingelesen, mit dem Skalierungsfaktor und dem Offsetwert ROFFS2 umgerechnet und als Zielposition eines Referenzfahrsatzes übernommen. Anschliessend wird die Betriebsart umgeschaltet (OPMODE=8) und eine Referenzfahrt zu der Zielposition mit der Referenzgeschwindigkeit VREF und den Referenzrampen ACCR/DECR gestartet. Nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben. Daraufhin sollte die Steuerung den Start-Eingang zurücknehmen, damit der Master/Slave-Betrieb (OPMODE=4) wieder aktiviert werden kann.

Zu Testzwecken (bei Einstellung MSG = 2) kann auf dem Slave-Drive die SSI-Position des Masters mit dem Kommando „M NEWSSI“ angezeigt werden. Die aktuelle Position des Slaves (in Counts) kann mit dem Kommando „M PFB“ angezeigt werden. Das Verhältnis dieser beiden Positionen entspricht dem Skalierungsfaktor.

Für einen Master/Slave-Betrieb mit 2 Verstärkern müssen folgende Einstellungen vorgenommen werden:

Master: (liefert die SSI-Position)
ENCMODE 2 Vorwahl der Encoder-Emulation (1=ROD, 2=SSI)
SSIGRAY Damit muß Datenformat vorgewählt werden (0=binär/1=gray)
SSIINV 1 SSI-Clock (0=standard, 1=invertiert)
SSIMODE = 1 0=single turn / 1= multi turn
SSIOUT = 0 Baudrate 0=200 Kbaud / 1=1MBaud
GEARMODE=8 | SINCOS- Encoder an X1 (Drive 400 X2). Der Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog ausgewertet werden, wenn der zusätzliche Encoder zur Lageregelung benutzt wirdEXTPOS=1. Damit steht eine wesentlich höhere Auflösung zur Verfügung.
GEARMODE=9 | EnDAT- Encoder an X1 (Drive 400 X2). Der Unterschied zu GEARMODE=6 ist, dass auch der Parameterkanal gelesen wird und damit die absolute Position zur Verfügung steht. ENCLINES wird automatisch auf si eingestellt, dass die interne Scalierung auf 20Bit pro Umdrehung des Gebers eingestellt ist. Der Positionswert kann nur zur Positionierung bei EXTPOS=1 verwendet werden. Ein weiterer Unterschied zu GEARMODE=6 ist, dass die Sinus/Cosinusspuren auch analog eingelesen werden.
GEARMODE=10 Encoder follower X3, 24V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=11 Pulse and direction X3, 24V
INPUT1=Richtung (Low=positiv, High=negativ)
INPUT2=Pulse
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=12 Wirkt wie GEARMODE=0
Sinus Encoder an X1 zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=13 encoder follower X5 (Drive 400 X4), 5V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=14 Pulse and direction X5 (Drive 400 X4), 5V
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=15 Wirkt wie GEARMODE=3
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1
GEARMODE=16 | Wirkt wie GEARMODE = 6
GEARMODE=17 SSI-Input X5 (Drive 400 X4). Bei Einstellung GEARMODE=7, OPMODE=4 wird das Einlesen der SSI-Position über den Encoder-Eingang aktiviert. Alle 250µsek wird die SSI-Position eingelesen und die Differenz zu der vorhergehenden (250µsek alten) Position gebildet. Anschließend wird diese Differenz mit dem Skalierungsfaktor multipliziert und auf den letzten Positionssollwert aufaddiert.

Skalierungsfaktor = 2^(33-SSIOUT)* GEARO / GEARI ; bei PRBASE=20
Skalierungsfaktor = 2^(29-SSIOUT) * GEARO / GEARI ; bei PRBASE=16

Die absoluten Positionen vom Master/Slave können mit Hilfe des jeweiligen ROFFS-Parameters verschoben werden. Um die absoluten Positionswerte des Masters und Slaves untereinander abzugleichen, muß eine Referenzfahrt NREF=8 gestartet werden (digitaler Eingang, ASCII-Kommando MH, Feldbus). Beim Start dieser Referenzfahrt wird die aktuelle Absolutposition des Masters eingelesen, mit dem Skalierungsfaktor und dem Offsetwert ROFFS2 umgerechnet und als Zielposition eines Referenzfahrsatzes übernommen. Anschliessend wird die Betriebsart umgeschaltet (OPMODE=8) und eine Referenzfahrt zu der Zielposition mit der Referenzgeschwindigkeit VREF und den Referenzrampen ACCR / DECR gestartet. Nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben. Daraufhin sollte die Steuerung den Start-Eingang zurücknehmen, damit der Master/Slave-Betrieb (OPMODE=4) wieder aktiviert werden kann.

Zu Testzwecken (bei Einstellung MSG 2) kann auf dem Slave-Drive die SSI-Position des Masters mit dem Kommando „M NEWSSI“ angezeigt werden. Die aktuelle Position des Slaves (in Counts) kann mit dem Kommando „M PFB“ angezeigt werden. Das Verhältnis dieser beiden Positionen entspricht dem Skalierungsfaktor.

Für einen Master/Slave-Betrieb mit 2 Verstärkern müssen folgende Einstellungen vorgenommen werden:

Master: (liefert die SSI-Position)
ENCMODE 2 Vorwahl der Encoder-Emulation (1=ROD, 2=SSI)
SSIGRAY Damit muß Datenformat vorgewählt werden (0=binär/1=gray)
SSIINV 1 SSI-Clock (0=standard, 1=invertiert)
SSIMODE 1 0=single turn / 1= multi turn
SSIOUT 0 Baudrate 0=200 Kbaud / 1=1MBaud
Sinus Encoder zusätzlich zur Lageregelung über EXTPOS = 1


ASCII Deutsch GEARO

ASCII - Kommando | GEARO |
Syntax Senden | GEARO [Data] |
Syntax Empfangen | GEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3540 (hex)
DIM | - | PROFIBUS PNU | 1664 (dec) IND = 0000xxxx (bin)
Bereich | -2147483647 .. 2147483647 | DPR | 64 (dec)
Default | 8192 |
Opmode | 4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Ausgangsfaktor "elekronisches Getriebe"

Beschreibung

Bei Master/Slave-Anwendungen (OPMODE=4) kann mit diesem Parameter das Master/Slave-Übersetzungsverhältnis eingestellt werden.


ASCII Deutsch GET

ASCII - Kommando | GET |
Syntax Senden | GET |
Syntax Empfangen | GET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3541 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 65 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Ausgabe der aufgezeichneten SCOPE-Daten

Beschreibung

Das GET-Kommando liefert eine Liste mit den zuletzt aufgezeichneten SCOPE-Daten. Die Liste besteht aus n+3 Zeilen (n=Anzahl der aufgenommenen Daten)
Zeile 1: Kommentarzeile z.B. "Drive Recording"
Zeile 2: n,Zeitbasis in msek z.B. 10,0.25 (10 Datenzeilen, Zeitbasis 250 usek)
Zeile 3: var1,var2,var3 Namen der aufgezeichneten Variablen z.B. VCMD, V, ICMD
Zeile 4: data1,data2,data3 aufgezeichnete Daten z.B. 0,20.3, -0.5
Zeile 5: data1,dat2,data3
..
Zeile n+3: data1,data2,data3

s.auch RECORD, RECTRIG


ASCII Deutsch GF

ASCII - Kommando | GF |
Syntax Senden | GF [Data] |
Syntax Empfangen | GF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3667 (hex)
DIM | - | PROFIBUS PNU | 1959 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... 2000 | DPR | 359 (dec)
Default | 15 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Flussreglers

Beschreibung

IN VORBEREITUNG !

Diese Objekt wird nur bei Einstellung MTYPE=3, Asynchronmaschine, verwendet. Der Parameter GF ist die Proportionalverstärkúng des Flussreglers. Der Flussregler ist als PI-Regler ausgelegt (siehe GFTN).


ASCII Deutsch GFTN

ASCII - Kommando | GFTN |
Syntax Senden | GFTN [Data] |
Syntax Empfangen | GFTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3668 (hex)
DIM | ms | PROFIBUS PNU | 1960 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... 1000 | DPR | 360 (dec)
Default | 50 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Nachstellzeit des Flussreglers

Beschreibung

IN VORBEREITUNG !

Diese Objekt wird nur bei Einstellung MTYPE=3, Asynchronmaschine, verwendet. Der Parameter GFTN ist die Nachstellzeit des Flussreglers. Der Flussregler ist als PI-Regler ausgelegt (siehe GF).


ASCII Deutsch GP

ASCII - Kommando | GP |
Syntax Senden | GP [Data] |
Syntax Empfangen | GP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3542 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1666 (dec) IND = 0000xxxx (bin)
Bereich | 0.001 .. 25.0 | DPR | 66 (dec)
Default | 0.15 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Proportionalverstärkung

Beschreibung

Lageregler: Proportionalverstärkung

Dieser Parameter wird sowohl bei dem P-Lageregler (EXTPOS=1,3,4), als auch PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPFFT

ASCII - Kommando | GPFFT |
Syntax Senden | GPFFT [Data] |
Syntax Empfangen | GPFFT <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0.0 ... 5.0 | DPR | Nein
Default | 1 |
Opmode | 4,5,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Stromvorsteuerung - Positionsregelkreis

Beschreibung

Mit der Stromvortsteuerung kann der Schleppfehler minimiert werden.

Dieser Parameter hat für den P- und PI-Positionsregler in folgenden Fällen Einfluß:
1.Es werden Tabbellenfahrsätze genutzt und das zugehörige Bit von O_C ist aktiv. ;
2.Interne Fahrprofile SPSET = 3 werden benutzt ;
3.Interne Fahrprofile SPSET = 4 werden benutzt 1;

Falls GV geändert wird, nachdem GPFFT eingestellt wurde, wird GPFFT umgekehrt proportional angepaßt.


ASCII Deutsch GPFFV

ASCII - Kommando | GPFFV |
Syntax Senden | GPFFV [Data] |
Syntax Empfangen | GPFFV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3545 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 50.0 | DPR | 69 (dec)
Default | 1.0 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Vorsteuerung Drehzahl

Beschreibung

Lageregler: Vorsteuerung Drehzahl

Dieser Parameter wird sowohl bei dem P-Lageregler (EXTPOS=1,3,4), als auch PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GPRED

ASCII - Kommando | GPRED |
Syntax Senden | GPRED [Data] |
Syntax Empfangen | GPRED <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | Nein
DIM |  | PROFIBUS PNU | Nein
Bereich | 0...200 | DPR | Nein
Default | 100 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM |
Kurzbeschreibung |

Beschreibung

GPRED defines the reduction/attenuation ratio for the proportional gain of the position loop during
the motion task phase. This parameter is activ only for P position loop (EXTPOS=4).


ASCII Deutsch GPTN

ASCII - Kommando | GPTN |
Syntax Senden | GPTN [Data] |
Syntax Empfangen | GPTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3546 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1670 (dec) IND = 0000xxxx (bin)
Bereich | 1.0 .. 200.0 | DPR | 70 (dec)
Default | 50 |
Opmode | 4, 5, 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler: Nachstellzeit

Beschreibung

Lageregler: Nachstellzeit

Dieser Parameter wird nur bei dem PI-Lageregler (EXTPOS=0,2) benutzt.


ASCII Deutsch GV

ASCII - Kommando | GV |
Syntax Senden | GV [Data] |
Syntax Empfangen | GV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3548 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 62.5*GVTN | DPR | 72 (dec)
Default | 1 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Proportionalverstärkung

Beschreibung

GV gibt die proportionale Verstärkung des Drehzahlreglers an. Beeinflusst auch GVTN.Anders als beim SR 600 ist die Dimension jetzt As/rad. Die Umrechnung der SR600 Kreisverstärkungen erfolgt Verstärkerabhängig in As/rad: GV[SR300] = GV[SR600] * DIPEAK [in A]/ 314.15rad/s
Beim SR 601 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 3A / 314.15rad/s = 0.010 As/rad
Beim SR 603 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 6A / 314.15rad/s = 0.019 As/rad
Beim SR 606 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 12A / 314.15rad/s = 0.0138 As/rad
Beim SR 610 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 20A / 314.15rad/s = 0.064 As/rad
Beim SR 610/30 / 614 / 620 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 40A / 314.15rad/s = 0.127 As/rad
Beim SR 640 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 80A / 314.15rad/s = 0.255 As/rad
Beim SR 670 beträgt GV[SR600] = 1 -> GV[SR300] = 1 * 160A / 314.15rad/s = 0.509 As/rad
Beim SR 403 beträgt GV[SR400] = 1 -> GV[SR300] = 1 * 9A / 314.15rad/s = 0.029 As/rad
Beim SR 406 beträgt GV[SR400] = 1 -> GV[SR300] = 1 * 12A / 314.15rad/s = 0.038 As/rad


ASCII Deutsch GVTN

ASCII - Kommando | GVTN |
Syntax Senden | GVTN [Data] |
Syntax Empfangen | GVTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 354D (hex)
DIM | Milliseconds | PROFIBUS PNU | 1677 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 , GV/62.5 .. 1000.0 | DPR | 77 (dec)
Default | 10 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlregler: Nachstellzeit

Beschreibung

Die Drehzahlregler-Nachstellzeit ist die Zeitkonstante des Integralanteils im Drehzahlregler. Wenn GVTN = 0 gesetzt wird, so ist der Integralanteil abgeschaltet.


ASCII Deutsch HDUMP

ASCII - Kommando | HDUMP |
Syntax Senden | HDUMP |
Syntax Empfangen | HDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 3551 (hex)
DIM | - | PROFIBUS PNU | 1681 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 81 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Ausgabe aller SinCos Variablen

Beschreibung

Ausgabe aller SinCos Feedback Variablen


ASCII Deutsch HELP

ASCII - Kommando | HELP |
Syntax Senden | HELP |
Syntax Empfangen | HELP <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Ausgabe der Parameter-Hilfe-Information

Beschreibung

Mit dem Parameter HELP <name> kann eine Hilfe-Information für den ASCII Parameter "name" angezeigt werden. Zu der Hilfe-Information gehören Eingabe-Grenzwerte sowie der aktuelle und der Default-Wert des Parameters.
Z.B: HELP GV
GV act=6 min=0 max=1000 default=1


ASCII Deutsch HICOFFS

ASCII - Kommando | HICOFFS |
Syntax Senden | HICOFFS [Data] |
Syntax Empfangen | HICOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3552 (hex)
DIM | Millivolts | PROFIBUS PNU | 1682 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 82 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Hiperface: Cosinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HICOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HICOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HIFACT1

ASCII - Kommando | HIFACT1 |
Syntax Senden | HIFACT1 [Data] |
Syntax Empfangen | HIFACT1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3553 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 0000xxxx (bin)
Bereich | 12000 .. 19000 | DPR | 83 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)

Beschreibung

Das Kommando HIFACT1 setzt die Amplitudennormierung des Sinus-Signal der Absolutspur (SinCoder). Die Amplitudennormierung ist bei dem Wert 16384 = 1.

Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HIFACT1-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HISOFFS

ASCII - Kommando | HISOFFS |
Syntax Senden | HISOFFS [Data] |
Syntax Empfangen | HISOFFS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3554 (hex)
DIM | Millivolts | PROFIBUS PNU | 1684 (dec) IND = 0000xxxx (bin)
Bereich | -10000 .. 10000 | DPR | 84 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Encoder
Kurzbeschreibung | Hiperface: Sinus-Offset (Inkrementalspur)

Beschreibung

Das Kommando HISOFFS setzt die Offsetkorrektur in mV des Cosinus-Signal der Inkrementalspur.
Das Kommando ist nur dann verfügbar, wenn ein SinCos-Geber als Rückführeinheit (FBTYPE=2,4,7) vorgewählt ist. Je nach Art des eingesetzten Gebers wird die HISOFFS-Einstellung im EEPROM des Gebers (FBTYPE=2,4, Kommando HSAVE) abgespeichert.
Bei einem Geber ohne einen Parameterkanal (FBTYPE=7) und damit ohne internes EEPROM, wird diese Einstellung im EEPROM des Verstärkers abgespeichert (Kommando SAVE).


ASCII Deutsch HSAVE

ASCII - Kommando | HSAVE |
Syntax Senden | HSAVE |
Syntax Empfangen | HSAVE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 3556 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 86 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Hiperface: Speichern der Parameter im Geber

Beschreibung

Das Kommando HSAVE speichert die Variablen für den Encoder ( HIPERFACE / EnDat ) bei der Einstellung FBTYPE=2 oder =4 im seriellen EEPROM des Encoders. Durch die Einstellung FBTYPE=7 werden nur die Variablen für die Inkrementalspur sowie MNUMBER und MPHASE im internen seriellen EEPROM des Verstärkers gespeichert.
Das Kommando ist nur dann verfügbar, wenn vom Verstärker ein sinus/cosinus
Geber erkannt wurde (FBTYPE =2;4;7).
FBTYPE = 2 HIPERFACE (Stegmann)
FBTYPE = 4 EnDat (Heidenhain)
FBTYPE = 7 SINCOS – Encoder ohne eigenem ser. EEPROM

Das Kommando HSAVE speichert folgende Variablen.
MNUMBER*
MPHASE*
HICOFFS*
HISOFFS*
HIFACT1*
* Bei FBTYPE = 7 werden diese Parameter im seriellen EEPROM des Verstärkers abgespeichert.

Hiperface-Geber, welche bereits einen Dateninhalt haben, können gelöscht werden. Hierzu muss HSAVE mit dem Schalter "ERASE" gesendet werden (HSAVE ERASE).


ASCII Deutsch HVER

ASCII - Kommando | HVER |
Syntax Senden | HVER |
Syntax Empfangen | HVER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3557 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 0000xxxx (bin)
Bereich | max 50 ASCII Characters | DPR | 87 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Ausgabe der Hardware-Version

Beschreibung

Das Kommando HVER liefert eine Hardwareversion-Bezeichnung in folgender Form:
"Drive 3xx Hardware Version (yy) zzzz"
xx - Endstufenbezeichnung (Stromstärke)
yy - Bezeichnung der Hardware-Version
zzzz - Datum der ersten Hardware-Revision


ASCII Deutsch I

ASCII - Kommando | I |
Syntax Senden | I |
Syntax Empfangen | I <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3558 (hex)
DIM | Amperes | PROFIBUS PNU | 1688 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 88 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Stromistwert

Beschreibung

Der aktuelle Betrag des Stromistwertes in [A]


ASCII Deutsch I2TLIM

ASCII - Kommando | I2TLIM |
Syntax Senden | I2TLIM [Data] |
Syntax Empfangen | I2TLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 355A (hex)
DIM | % | PROFIBUS PNU | 1690 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 90 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | I2t-Meldeschwelle

Beschreibung

I2TLIM definiert eine I2T-Meldeschwelle. Sobald der I2T-Wert die eingestellet Schwelle überschreitet, so wird die Warnung "n01" generiert. Diese Meldung kann über einen digitalen Ausgang (Funktion OxMODE=11) an eine Steuerung weitergeleitet werden.


ASCII Deutsch ICMD

ASCII - Kommando | ICMD |
Syntax Senden | ICMD |
Syntax Empfangen | ICMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355B (hex)
DIM | Amperes | PROFIBUS PNU | 1691 (dec) IND = 0000xxxx (bin)
Bereich | -DIPEAK .. DPEAK | DPR | 91 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Stromsollwert

Beschreibung

Interner Stromsollwert


ASCII Deutsch ICMDVLIM

ASCII - Kommando | ICMDVLIM |
Syntax Senden | ICMDVLIM [Data] |
Syntax Empfangen | ICMDVLIM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3685 (hex)
DIM | VUNIT | PROFIBUS PNU | 1989 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 389 (dec)
Default | 0 |
Opmode | 2,3 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlbegrenzung im Stromreglermode

Beschreibung

Der Parameter ICMDVLIM definiert eine digitale Drehzahlbegrenzung (Einheit: VUNIT) bei Vorgabe eines Stromsollwertes bei OPMODE = 2 und 3.
Die Funktion wird nur aktiviert bei ICMDVLIM>0. Eine Änderung von ICMDVLIM>0 auf ICMDVLIM=0 bzw. umgekehrt, ist nur bei gesperrter Endstufe möglich (Änderung der Konfiguration). Eine Änderung von ICMDVLIM>0 auf ICMDVLIM>0 ist dagegen auch bei freigegebener Endstufe möglich.


ASCII Deutsch ID

ASCII - Kommando | ID |
Syntax Senden | ID |
Syntax Empfangen | ID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 355D (hex)
DIM | Amperes | PROFIBUS PNU | 1693 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 93 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | D-Anteil vom Strom-Istwert

Beschreibung

Feldbildender Stromistwert (D-Richtung)


ASCII Deutsch IN

ASCII - Kommando | IN |
Syntax Senden | IN |
Syntax Empfangen | IN <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3560 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 96 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeige der A/D-Spannungen

Beschreibung

Das Kommando IN gibt die Eingangsspannungen der 8 A/D-Kanäle in counts (-4096...4096) aus.
Kanal 0: Kühlkörpertemperatur
Kanal 1: Umgebungstemperatur
Kanal 2: Ballastleistung
Kanal 3: I_U
Kanal 4: Motortemperatur
Kanal 5: Zwischenkreisspannung [4096 counts = 1015 V]
Kanal 6: Netzspannung [4096 counts = 800 V]
Kanal 7: I_W


ASCII Deutsch IN1

ASCII - Kommando | IN1 |
Syntax Senden | IN1 |
Syntax Empfangen | IN1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3561 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 97 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT1

Beschreibung

Zustand des digitalen Eingangs INPUT1


ASCII Deutsch IN1HCMD

ASCII - Kommando | IN1HCMD |
Syntax Senden | IN1HCMD [Data] |
Syntax Empfangen | IN1HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN1HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN1MODE=30,33 konfigurierten Eingang 1, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
INHCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN1LCMD

ASCII - Kommando | IN1LCMD |
Syntax Senden | IN1LCMD [Data] |
Syntax Empfangen | IN1LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN1LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN1MODE=30,33 konfigurierten Eingang1, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN1LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN1MODE

ASCII - Kommando | IN1MODE |
Syntax Senden | IN1MODE [Data] |
Syntax Empfangen | IN1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3562 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 98 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT1

Beschreibung

Mit dem Kommando IN1MODE kann die Funktion des digitalen Eingangs INPUT1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN1MODE=0 | Keine Funktion | Der Zustand des digitalen Eingangs INPUT1 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN1MODE=1 Verstärker Reset Beim Auftreten eines Verstärker-Fehlers (BTB=0, Display-Anzeige Fxx) führt eine steigende Flanke auf diesem Eingang zum Resettieren des Fehlers, wenn ein Fehler ansteht. Wenn kein Fehler ansteht, so wird der Eingang ignoriert. Je nach Art des Fehlers, erfolgt ein Hardware- bzw. Software-Reset des Verstärkers. Bei einem Software-Reset, ist der Verstärker sofort betriebsbereit, bei einem Hardware-Reset wird die gesamte Initialisierungsphase durchlaufen (Power on), so dass die Parameter aus dem EEPROM geladen werden.
Falls beim Einschalten des Verstärkers ein High-Zustand (24V) am INPUT1 erkannt wird, so wird die Initialisierungsphase unterbrochen bis der Eingang den Zustand Low (0V) aufweist. Dieser "Wartezustand" des Verstärkers kann am Display ("A"-Zeichen im ersten Segment) erkannt werden.
IN1MODE=2 | Keine Funktion
IN1MODE=3 | Keine Funktion
IN1MODE=4 | Keine Funktion
IN1MODE=5 | Keine Funktion
IN1MODE=6 | Keine Funktion
IN1MODE=7 | Keine Funktion
IN1MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT1, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN1MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN1MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN1MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT1 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN1MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN1MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN1MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN1MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN1MODE=16 | Fahrauftrag/Referenzfahrt IN1TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN1MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN1MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN1TRIG in % von IPEAK vorgegeben.
IN1MODE=19 | keine Funktion
IN1MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN1TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (vorgegeben durch VUNIT) und nicht in UPM.
IN1MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN1MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN1MODE=23 | Fahrauftrag/Referenzfahrt IN1TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN1TRIG vorgegeben wurde. Falls IN1TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN1MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN1TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT1 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN1MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 1)
IN1TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT1=LOW und OPMODE=8 bei INPUT1=HIGH)
IN1MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird.
IN1MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variable LATCHX32 (positive Flanke) oder LATCHX32N (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCHX16 (positive Flanke) oder LATCHX16N (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 8 msek.
Die Latchfunktion funktioniert nicht bei POSCNFG=1.
IN1MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN1MODE=28 | Reserve
IN1MODE=29 | Reserve
IN1MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN1MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN1MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN1MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN1MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN1MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN1MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN1TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von N1TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN1TRIG berechnet werden:

IN1TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN1TRIG = 208
IN1TRIG kann auch negativ werden.
IN1MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN1MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN1MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN1MODE=38 gewesen sein muss.
IN1MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN1TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN1TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN1TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN1TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUT1 festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN1TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN1TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN1TRIG = 0x000afe0c = 720396
IN1MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN1MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUT1 bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN1MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN1MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN1MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN1TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN1TRIG

ASCII - Kommando | IN1TRIG |
Syntax Senden | IN1TRIG [Data] |
Syntax Empfangen | IN1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3563 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 99 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN1MODE

Beschreibung

Die Funktion der Hilfsvariable IN1TRIG hängt von der Konfiguration IN1MODE ab.


ASCII Deutsch IN2

ASCII - Kommando | IN2 |
Syntax Senden | IN2 |
Syntax Empfangen | IN2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3564 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 100 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT2

Beschreibung

Zustand des digitalen Eingangs INPUT2


ASCII Deutsch IN2HCMD

ASCII - Kommando | IN2HCMD |
Syntax Senden | IN2HCMD [Data] |
Syntax Empfangen | IN2HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN2HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN2MODE=30,33 konfigurierten Eingang 2, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN2HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN2LCMD

ASCII - Kommando | IN2LCMD |
Syntax Senden | IN2LCMD [Data] |
Syntax Empfangen | IN2LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN2LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN2MODE=30,33 konfigurierten Eingang 2, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN2LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN2MODE

ASCII - Kommando | IN2MODE |
Syntax Senden | IN2MODE [Data] |
Syntax Empfangen | IN2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3565 (hex)
DIM | - | PROFIBUS PNU | 1701 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 101 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT2

Beschreibung

Mit dem Kommando IN2MODE kann die Funktion des digitalen Eingangs INPUT2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN2MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT2 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN2MODE=1 | keine Funktion
IN2MODE=2 | keine Funktion
IN2MODE=3 | keine Funktion
IN2MODE=4 | keine Funktion
IN2MODE=5 | keine Funktion
IN2MODE=6 | keine Funktion
IN2MODE=7 | keine Funktion
IN2MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT2, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN2MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN2MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN2MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT2 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN2MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN2MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN2MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN2MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN2MODE=16 | Fahrauftrag/Referenzfahrt IN2TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN2MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN2MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN2TRIG in % von IPEAK vorgegeben.
IN2MODE=19 | reserviert
IN2MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN2TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN2MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN2MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN2MODE=23 | Fahrauftrag/Referenzfahrt IN2TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN2TRIG vorgegeben wurde. Falls IN2TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN2MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODES, die umgeschaltet werden sollen, werden in der Hilfsvariable IN3TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT2 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN2MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 2)
IN2TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT2=LOW und OPMODE=8 bei INPUT2=HIGH)
IN2MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN2MODE=26 Positionslatch Eine Flanke bewirkt das Einfrieren der aktuellen Ist-Position. Der 32-Bit Positionswert wird in der Variable LATCH32 (positive Flanke) oder LATCH32N (negative Flanke) abgespeichert. Der 16-Bit Positionswert (absolut innerhalb einer Umdrehung) wird in der Variable LATCH16 (positive Flanke) oder LATCH16N (negative Flanke) abgelegt. Der erfolgte Latch-Vorgang wird über entsprechende Status-Bits (DRVSTAT) mitgeteilt.
Die min. Impulslänge, die mit Hilfe dieses Einganges erfasst werden kann (Low/High und High/Low Wechsel) beträgt 500 µsek. Der minimale Abstand zwischen zwei Latch-Impulsen beträgt 8 msek.
Die Latchfunktion funktioniert nicht bei POSCNFG=1.
IN2MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN2MODE=28 | Reserve
IN2MODE=29 | Reserve
IN2MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN2MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN2MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN2MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN2MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN2MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN2MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN2TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN2TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN2TRIG berechnet werden:

IN2TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN2TRIG = 208
IN2TRIG kann auch negativ werden.
IN2MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN2MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN2MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN2MODE=38 gewesen sein muss.
IN2MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN2TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN2TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN2TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN2TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN2TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN2TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN2TRIG = 0x000afe0c = 720396
IN2MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN2MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN2MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN2MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN2MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN2TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN2PM

ASCII - Kommando | IN2PM |
Syntax Senden | IN2PM [Data] |
Syntax Empfangen | IN2PM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 362E (hex)
DIM | - | PROFIBUS PNU | 1902 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 302 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Modus In-Position 2

Beschreibung

Mit dem Kommando IN2PM kann die Funktion der Zwischenmeldung bei einer Fahrauftragsfolge konfiguriert werden.

Die Funktion „Zwischenmeldung bei einer Fahrauftragsfolge“ (Folge InPos) ist verfügbar, wenn eine I/O-Erweiterungskarte eingesetzt wird (Klemme X11B4) oder wenn ein digitaler Ausgang des Grundgerätes mit der Funktion OxMODE=16 konfiguriert wurde. Beim Start des ersten Fahrsatzes einer Fahrsatzfolge wird der Ausgang „Folge InPos“ immer auf 0 gesetzt. Das Verhalten des Ausgangs beim Ausführen der Fahrsatzfolge hängt von der Konfigurationsvariable IN2PM ab.

IN2PM=0 – Der Ausgang wird invertiert beim Starten eines Folgefahrsatzes.
IN2PM=2 – Der Ausgang wird invertiert am Ende eines Fahrsatzes.
IN2PM=1 – Beim Start eines Fahrsatzes wird der Ausgang auf 0 gesetzt, am Ende eines Fahrsatzes wird der Ausgang High.

Bei einer Fahrsatzfolge in der die Fahrsätze sofort gestartet werden, sind nur die Einstellungen IN2PM=0 oder IN2PM=2 sinnvoll. Bei der Einstellung IN2PM=1 ist der High-Zustand so kurz, daß er u.U. gar nicht von der externen Steuerung registriert werden kann.

Wenn ein Folgefahrsatz mit Hilfe eines I/O gestartet werden soll (INxMODE=15), so sollte die Einstellung IN2PM=2 bzw. IN2PM=1 benutzt werden. Bei dieser Einstellung wird das Ende eines Fahrsatzes durch den High-Zustand (IN2PM=1) bzw. durch den Zustandwechsel (IN2PM=2) am „Folge-InPos“-Ausgang gemeldet. Daraufhin kann die externe Steuerung über den Eingang „Folgefahrauftrag starten“ das Fortsetzen der Fahrauftragsfolge veranlassen.


ASCII Deutsch IN2TRIG

ASCII - Kommando | IN2TRIG |
Syntax Senden | IN2TRIG [Data] |
Syntax Empfangen | IN2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3566 (hex)
DIM | - | PROFIBUS PNU | 1702 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 102 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN2MODE

Beschreibung

Die Funktion der Hilfsvariable IN2TRIG hängt von der Konfiguration IN2MODE ab.
s. IN2MODE


ASCII Deutsch IN3

ASCII - Kommando | IN3 |
Syntax Senden | IN3 |
Syntax Empfangen | IN3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3567 (hex)
DIM | - | PROFIBUS PNU | 1703 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 103 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT3

Beschreibung

Zustand des digitalen Eingangs INPUT3


ASCII Deutsch IN3HCMD

ASCII - Kommando | IN3HCMD |
Syntax Senden | IN3HCMD [Data] |
Syntax Empfangen | IN3HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando INH3CMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN3MODE=30,33 konfigurierten Eingang 3, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN3HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN3LCMD

ASCII - Kommando | IN3LCMD |
Syntax Senden | IN3LCMD [Data] |
Syntax Empfangen | IN3LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN3LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN3MODE=30,33 konfigurierten Eingang 3, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN3LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN3MODE

ASCII - Kommando | IN3MODE |
Syntax Senden | IN3MODE [Data] |
Syntax Empfangen | IN3MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3568 (hex)
DIM | - | PROFIBUS PNU | 1704 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 104 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT3

Beschreibung

Mit dem Kommando IN3MODE kann die Funktion des digitalen Eingangs INPUT3 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
IN3MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT3 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN3MODE=1 | keine Funktion
IN3MODE=2 | PSTOP | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=3 | NSTOP (4.78) | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=4 | PSTOP mit Integral off | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=5 | keine Funktion
IN3MODE=6 | PSTOP+NSTOP | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=7 | PSTOP+NSTOP mit Integral off | Der Low-Pegel sperrt sowohl die positive als auch die negative Drehrichtung. Gleichzeitig wird auf dem Display die Warnung n10 und n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN3MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT3, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN3MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN3MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN3MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT3 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN3MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN3MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN3MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN3MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN3MODE=16 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN3MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN3MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN3TRIG in % von IPEAK vorgegeben.
IN3MODE=19 | reserviert
IN3MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN3TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN3MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN3MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN3MODE=23 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN3TRIG vorgegeben wurde. Falls IN3TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN3MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN3TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT3 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN3MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 3)
IN3TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT3=LOW und OPMODE=8 bei INPUT3=HIGH)
IN3MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN3MODE=26 | keine Funktion
IN3MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN3MODE=28 | Reserve
IN3MODE=29 | Reserve
IN3MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN3MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN3MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN3MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN3MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN3MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN3MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN3TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN3TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN3TRIG berechnet werden:

IN3TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN3TRIG = 208
IN3TRIG kann auch negativ werden.
IN3MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN3MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN3MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN3MODE=38 gewesen sein muss.
IN3MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN3TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN3TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN3TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN3TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN3TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN3TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN3TRIG = 0x000afe0c = 720396
IN3MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN3MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN3MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN3MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN2MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN2TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN3TRIG

ASCII - Kommando | IN3TRIG |
Syntax Senden | IN3TRIG [Data] |
Syntax Empfangen | IN3TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3569 (hex)
DIM | - | PROFIBUS PNU | 1705 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 105 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN3MODE

Beschreibung

Die Funktion der Hilfsvariable IN3TRIG hängt von der Konfiguration IN3MODE ab.
s. IN3MODE


ASCII Deutsch IN4

ASCII - Kommando | IN4 |
Syntax Senden | IN4 |
Syntax Empfangen | IN4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356A (hex)
DIM | - | PROFIBUS PNU | 1706 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 106 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Eingangs INPUT4

Beschreibung

Zustand des digitalen Eingangs INPUT4


ASCII Deutsch IN4HCMD

ASCII - Kommando | IN4HCMD |
Syntax Senden | IN4HCMD [Data] |
Syntax Empfangen | IN4HCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für High-Pegel

Beschreibung

Mit dem Kommando IN4HCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine steigende Flanke auf dem, mit der Funktion IN4MODE=30,33 konfigurierten Eingang 4, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN4HCMD GV 10; GVTN 15

Wenn eine low/high-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 10 und die Nachstellzeit auf 15ms gesetzt.


ASCII Deutsch IN4LCMD

ASCII - Kommando | IN4LCMD |
Syntax Senden | IN4LCMD [Data] |
Syntax Empfangen | IN4LCMD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | -
Kurzbeschreibung | Kommando-Buffer für Low-Pegel

Beschreibung

Mit dem Kommando IN4LCMD kann eine ASCII-Befehlsfolge definiert werden. Diese Befehlsfolge wird immer dann ausgeführt, wenn eine fallende Flanke auf dem, mit der Funktion IN4MODE=30,33 konfigurierten Eingang 4, erkannt wird. Eine Befehlsfolge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon (;) getrennt sind. Die maximale Länge dieser Befehlsfolge beträgt 56 Zeichen.

Beispiel:
IN4LCMD GV 5; GVTN 10

Wenn einehigh/low-Flanke erkannt wird, so wird die Verstärkung des Drehzahlreglers auf 5 und die Nachstellzeit auf 10ms gesetzt.


ASCII Deutsch IN4MODE

ASCII - Kommando | IN4MODE |
Syntax Senden | IN4MODE [Data] |
Syntax Empfangen | IN4MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356B (hex)
DIM | - | PROFIBUS PNU | 1707 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 107 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Eingangs INPUT4

Beschreibung

Mit dem Kommando IN4MODE kann die Funktion des digitalen Eingangs INPUT4 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden.
Es können folgende Funktionen konfiguriert werden:
Zustand / State | Funktion | Beschreibung
IN4MODE=0 | keine Funktion | Der Zustand des digitalen Eingangs INPUT4 wird eingelesen und kann über die Feldbus/Slot-Schnittstelle ausgewertet werden.
IN4MODE=1 | keine Funktion
IN4MODE=2 | PSTOP (4.78) | Der Low-Pegel sperrt die positive Drehrichtung (Uhrzeigersinn bei DIR=1, gegen Uhrzeigersinn bei DIR=0). Gleichzeitig wird auf dem Display die Warnung n10 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=3 | NSTOP | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=4 | keine Funktion
IN4MODE=5 | NSTOP mit Integral off | Der Low-Pegel sperrt die negative Drehrichtung (Uhrzeigersinn bei DIR=0, gegen Uhrzeigersinn bei DIR=1). Gleichzeitig wird auf dem Display die Warnung n11 angezeigt. Falls beim drehenden Antrieb eine fallende Flanke auf diesem Eingang erkannt wird, so bremst der Antrieb (drehzahlgeregelt, OPMODE=0,kein Integralanteil) mit der Rampe DECSTOP. Nachdem der Stillstand erreicht wurde, wird die ursprüngliche Betriebsart des Reglers aktiviert.
IN4MODE=6 | keine Funktion
IN4MODE=7 | keine Funktion
IN4MODE=8 | Sollwertumschaltung SW1/SW2 | Bei der Konfiguration ANCNFG=0, kann mit dem digitalen Eingang INPUT4, die Sollwert-Quelle SW1/SW2 umgeschaltet werden (Low = SW1, High=SW2). Der digitale Eingang schaltet nur die physikalische Sollwert-Schnittstele um. Die Funktion des Sollwerteingangs (Strom-/Drehzahlsollwert) hängt von der eingestellten Betriebsart OPMODE ab.
IN4MODE=9 Nummerbit Alle digitalen Eingänge, die mit der Funktionsnummer 9 konfiguriert wurden, werden als Bits einer Zahl (binäre Darstellung) interpretiert (IN1=LSB,IN4=MSB). Die mit Hilfe dieser Eingänge vorgewählte Nummer, kann für folgende Funktionen benutzt werden:
1. Fahrsatznummer
wenn ein Eingang mit der Funktion 17 (INxMODE=17) konfiguriert wurde, so wird bei einer steigenden Flanke auf diesem Eingang ein Fahrsatz mit der vorgewählten Nummer gestartet.
2. VCT-Nummer
wird ein digitaler Eingang mit der Funktion 35 (INxMODE=35) konfiguriert, so wird bei einer steigenden Flanke auf diesem Eingang, ein Drehzahl/Strom-Eintrag mit der vorgewählten Nummer (VCT-Tabelle) aktiviert.
IN4MODE=10 | Integral Off | Ein High-Pegel (24V) auf diesem Eingang schaltet den Integral-Anteil des Drehzahlreglers ab. Bei Low-Pegel (0V) wird der Integralanteil wieder aktiviert.
IN4MODE=11 | 1:1-Regelung | Mit dem Eingang INPUT4 kann die Betriebsart des Verstärkers (OPMODE) zwischen der Drehzahl- und Stromregelung umgeschaltet werden. Je nach der Betriebsart-Voreinstellung (OPMODE) findet die Umschaltung zwischen OPMODE=0 (Low) und OPMODE=2 (High) bzw. OPMODE=1 (Low) und OPMODE=3 (High).
IN4MODE=12 | Home-Position | An diesem Eingang kann ein Referenzschalter angeschlossen werden. Der Endschalter wird bei bestimmten Referenzfahrtarten des Lagereglers benötigt (High-Pegel=Referenzschalter belegt).
IN4MODE=13 | ROD/SSI-Umschaltung | Mit dem digitalen Eingang kann die Art der Encoder-Emulation (ENCMODE) zwischen ROD (ENCMODE=1, Low-Pegel) und SSI (ENCMODE=2, High-Pegel) umgeschaltet werden.
IN4MODE=14 | Warnung löschen | Eine steigende Flanke auf dem digitalen Eingang löscht eine ggf. anstehende Warnung (Schleppfehler/Ansprechüberwachung).
IN4MODE=15 | Folgefahrauftrag Starten | Bei Definition einer Fahrauftragsfolge gibt es eine Möglichkeit, die einzelnen Fahrsätze dieser Folge über einen digitalen Eingang zu starten. Falls für einen Folgefahrsatz als Startbedingung ein bestimmter I/O-Pegel definiert wurde, so wird dieser Fahrsatz erst dann gestartet, wenn dieser Pegel auf diesem Eingang erkannt wurde. Bis zu diesem Zeitpunkt bleibt der Antrieb stehen.
IN4MODE=16 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN4MODE=17 | Fahrauftrag/Referenzfahrt starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer über die Eingänge INxMODE=9 vorgegeben wurde. Falls die Nummer=0, so wird eine Referenzfahrt gestartet. Eine fallende Flanke auf diesem Eingang löst das STOP-Kommando aus (Anhalten einer Bewegung).
IN4MODE=18 | Auf Spitzenstrom2 umschalten | Der digitale Eingang schaltet den Spitzenstrom zwischen dem eingestellten Wert IPEAK (Low) und dem Spitzenstrom2 (High) um. Der Wert für den Spitzenstrom2 wird über die Hilfsvariable IN4TRIG in % von IPEAK vorgegeben.
IN4MODE=19 | reserviert
IN4MODE=20 Tippbetrieb starten Eine steigende Flanke startet einen Tippbetrieb (Einrichtbetrieb/Endlosfahrt). Die Geschwindigkeit wird in der Hilfsvariable IN4TRIG vorgegeben. Da der Tippbetrieb über den internen Lageregler abgewickelt wird, so ist der OPMODE=8 die Voraussetzung für diese Betriebsart.
Die Vorgabe der Geschwindigkeit erfolgt in den Einheiten des Lagereglers (VUNIT) und nicht in UPM.
IN4MODE=21 | Unterspannung ein/aus | Der digitale Eingang schaltet die Überwachung der Unterspannung ein (High) und aus (Low).
IN4MODE=22 | Fortsetzen eines Fahrsatzes | Eine steigende Flanke am digitalen Eingang startet den, zuletzt mit dem STOP-Kommando abgebrochenen, Fahrsatz. Diese Funktion bietet die einzige Möglichkeit einen abgebrochenen Relativ-Fahrsatz zu Ende zu fahren.
IN4MODE=23 | Fahrauftrag/Referenzfahrt IN3TRIG starten | Eine steigende Flanke auf diesem Eingang startet einen Fahrsatz dessen Nummer in der Hilfsvariable IN4TRIG vorgegeben wurde. Falls IN4TRIG=0, so wird eine Referenzfahrt gestartet. Im Gegensatz zu der Funktion 16, löst eine fallende Flanke kein STOP-Kommando aus.
IN4MODE=24 Umschalten der Betriebsart (OPMODE) Die Nummern der OPMODEs, die umgeschaltet werden sollen, werden in der Hilfsvariable IN4TRIG eingetragen. Die Bits 0..7 enthalten die Nummer des OPMODEs auf den umgeschaltet wird, wenn eine fallende Flanke auf dem zugehörigen Eingang erkannt wird, die Bits 8...15 enthalten die Nummer für die steigende Flanke. Beim Einschalten des Reglers wird der OPMODE entsprechend dem Eingangspegel eingestellt (keine Flanke notwendig).

Beispiel:
Um mit dem digitalen Eingang INPUT4 zwischen dem Mode „analoge Drehzahlregelung“ (LOW-Zustand) und dem Mode „Lageregelung“ (HIGH-Zustand) umschalten zu können, muß folgende Einstellung vorgenommen werden:

IN4MODE = 24 (Aktivieren der Funktion für den Eingang Nr. 4)
IN4TRIG = 2049 (2049 (Dez) = 801 (Hex), also OPMODE=1 bei INPUT4=LOW und OPMODE=8 bei INPUT4=HIGH)
IN4MODE=25 Setzen des ROD-Nullimpulsoffsets Mit der steigenden Flanke auf dem digitalen Eingang wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen. Anschließend wird die Funktion SAVE aufgerufen und die neue Einstellung im seriellen EEPROM abgespeichert.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuelle Position (innerhalb einer Umdrehung) ausgegeben wird.
IN4MODE=26 | keine Funktion
IN4MODE=27 | Nothalt | Der Low-Pegel leitet eine Nothalt-Phase ein (Abbruch einer Bewegung und Anhalten des Antriebes mit der Rampe DECSTOP). Unabhängig von der eingestelleten Betriebsart (OPMODE), wird während der Nothaltphase der Drehzahlregler aktiviert.
IN4MODE=28 | Reserve
IN4MODE=29 | Reserve
IN4MODE=30 Ausführen einer beliebigen Kommandofolge Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMD [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMD [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=30 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMD, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMD ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 30 konfiguriert sein.
IN4MODE=31 Ausführen einer beliebigen Kommandofolge 2 Eine steigende bzw. fallende Flanke auf dem digitalen Eingang führt eine beliebige Kommando-Folge aus.
Die Kommando-Folge besteht aus einzelnen ASCII-Kommandos, die mit einem Semicolon-Zeichen (;) getrennt sind.
Die Kommando-Folge für die steigende Flanke wird mit dem Kommando INHCMDX [Kommandofolge], die für die fallende Flanke mit dem Kommando INLCMDX [Kommandofolge] definiert.
Die maximale Länge der Kommando-Folge beträgt 56 Zeichen.

Falls ein digitaler Eingang mit der Funktion INxMODE=31 konfiguriert
wurde, so wird bei einer steigenden Flanke auf diesem Eingang die Kommandofolge
aus dem Buffer INHCMDX, bei einer fallenden Flanke die Kommandofolge aus dem Buffer INLCMDX ausgeführt. Beim Einschalten des Verstärkers wird entsprechend dem aktuellen Zustand des digitalen
Eingangs, die zugehörige Kommandofolge automatisch ausgeführt (keine Flanke notwendig).

Anmerkung: Es darf nur ein einzelner Eingang mit der Funktion 31 konfiguriert sein.
IN4MODE=32 | Bremse ein/aus | Der High-Pegel auf dem digitalen Eingang lüftet die Bremse (falls konfiguriert). Die Funktion dieses Eingangs ist nur bei gesperrten Endstufe und beim geschlossenen BTB (kein Verstärkerfehler) aktiv. Ab der Version 4.78 kann die Bremse auch bei einem Fehler geöffnet werden)
IN4MODE=33 | wie 30 | Im Gegensatz zu Funktion 30 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN4MODE=34 | wie 31 | Im Gegensatz zu Funktion 31 werden die Antworten, die bei der Ausführung einer Kommandofolge vom Verstärker generiert werden nicht unterdrückt, sondern über die serielle Schnittstelle ausgegeben.
IN4MODE=35 | Anwahl eines Drehzahl/Strom-Eintrages | Eine steigende Flanke auf dem digitalen Eingang bewirkt die Übernahme eines VCT-Eintrages (s. Kommando VCT). Die Nummer des VCT-Eintrages wird über die mit der Funktionsnummer 9 konfigurierten digitalen Eingänge vorgegeben.
IN4MODE=36 Addition von Eingangspulsen bei Getriebefunktion Getriebemodus OPMODE 4
Bei einem High-Signal werden zusätzliche Inkremente pro Zeiteinheit in den Masterzähler eingezählt, so dass der Slave mit einer über IN4TRIG eingestellten Differenzgeschwindigkeit verfahren werden kann. Damit kann eine Synchronisierung von Master und Slave vorgenommen werden. Die Skalierung von IN4TRIG ist in internen Counts (20 Bit pro Umdrehung des Motors) pro 250 µs. Die Differenzdrehzahl ( n ) muss bekannt sein, dann kann IN4TRIG berechnet werden:

IN4TRIG = n * min * 250 / 60

Beispiel: n = 50 1/min
IN4TRIG = 208
IN4TRIG kann auch negativ werden.
IN4MODE=37 Umschaltung der Quelle für die Positionserfassung bei EXTPOS=1. = 0 Position vom externen Geber (Vorwahl mit GEARMODE).
= 1 Position wird vom ersten Geber am Motor (Resolver bzw. hochauflösenden Geber EnDAT oder Hiperface) erfasst.
IN4MODE=38 | Freigabesignal für Folgefahrauftrag | Definition von einem Fahrauftrag mit Folgefahrsätzen. Wenn nun die Funktion INxMODE=15 verwendet wird (Start der Folgefahrsätze über I/O) so kann die Funktion IN4MODE=38 dazu benutzt werden, eine Freigabe des Starts des Folgefahrauftrages zu ermöglichen. Das bedeutet, dass bevor der Folgefahrsatzstart (INxMODE=15) akzeptiert wird, erst einmal eine steigende Flanke an IN4MODE=38 gewesen sein muss.
IN4MODE=39 Konstante Drehzahl für bestimmte Zeit Mit der Funktion INxMODE=39 kann für eine bestimmte Zeit eine drehzahlgeregelte Bewegung mit konstanter Drehzahl gestartet werden.
Die Parameter Zeit und Drehzahl werden in der Hilfsvariable IN4TRIG vorgegeben.
Die Drehzahl belegt die unteren 16 Bits der Hilfsvariable und wird in den gültigen VUNIT-Einheiten vorgegeben. Die Fahrzeit wird in msek vorgegeben und belegt die Bits 16..31 der Variable IN4TRIG.
Eine steigende Flanke am Eingang INPUTx bewirkt eine Umschaltung der Betriebsart OPMODE auf die „digitale Drehzahlregelung“ OPMODE=0 und Vorgabe eines Drehzahlsollwertes (Bits 0..15 von IN4TRIG). Gleichzeitig wird der Zeit-Wert (Bits 16..31 von IN4TRIG) in einen 1msek-Timer geladen.
Wenn der Timer abgelaufen ist bzw. eine fallende Flanke am Eingang INPUTx festgestellt wird,
so wird der digitale Drehzahlsollwert auf 0 gesetzt. Nachdem Drehzahl 0 erreicht worden ist (Stillstand), wird die Betriebsart OPMODE auf die Ausgangsbetriebsart umgeschaltet.

Beispiel für die Definition der Hilfsvariable IN4TRIG
1. Velocity = 1000 UPM
Zeit = 10 sek = 10000 msek
IN4TRIG = 0x271003E8 = 655361000
0x2710 = 10000 msek
03E8 = 1000 UPM

2. Velocity = -500 UPM
Zeit = 10 msek
IN4TRIG = 0x000afe0c = 720396
IN4MODE=40 Zusätzlicher Hardware-Eingang Bei dieser Einstellung wird der digitale Eingang x in die Reihe mit dem Hardware-Enable geschaltet.
Nur bei High-Zustand auf diesem Eingang kann die Endstufe freigegeben werden.

Diese Funktion kann gleichzeitig auch bei mehreren Eingänge konfiguriert werden. In diesem Fall werden
alle so konfigurierten Eingänge in die Reihe mit dem Hardware-Enable geschaltet.

Diese Funktion ist ab der Firmware-Version 4.91 verfügbar.
IN4MODE=41 Schneller Nothalt Bewirkt das Auslösen eines Nothaltes über den digitalen Eingang INPUTx bei Low-Pegel. Der Antrieb bremst mit der DECSTOP-Rampe. Nachdem der Stillstand erreicht worden ist (V<VEL0),
wird die Endstufe gesperrt. Damit ist die Nothalt-Phase abgeschlossen.
Während der Nothalt-Phase wird in der Variable TRJSTAT das Bit 24 (0x01000000) gesetzt.
Der Nothalt wird in der 250µs-Task ausgewertet.
IN4MODE=42 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben (ab Firmware 5.51).
IN4MODE=43 Aktivieren bzw. deaktivieren des Master/Slave-Betriebes mit Wegdifferenzausgleich. Aktivieren bzw. deaktivieren des Master/Slave-Betriebes in OPMODE = 4.
Diese Funktion ist nur bei der Slave-Achse sinnvoll.
Bei der steigenden Flanke am digitalen Eingang wird die Slave-Geschwindigkeit von 0 bis auf die Master-Geschwindigkeit, bzw. von Master-Geschwindigkeit auf 0
verändert. Die Rampenzeiten werden durch ACCR (Beschleunigungsrampe) und DECR (Bremsrampe vorgegeben
Im Gegensatz zur Funktion IN4MODE=42 wird die Master-Position beim Setzen des digitalen Eingangs gelatcht und die bei der Beschleunigung aufgetretene Wegdifferenz aufgeholt. Zusätzlich dazu kann noch ein Positionsoffset über IN4TRIG in PGEARI - Einheiten vorgegeben werden (ab Firmware 5.51).


ASCII Deutsch IN4TRIG

ASCII - Kommando | IN4TRIG |
Syntax Senden | IN4TRIG [Data] |
Syntax Empfangen | IN4TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 356C (hex)
DIM | - | PROFIBUS PNU | 1708 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 108 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für IN3MODE

Beschreibung

Die Funktion der Hilfsvariable IN4TRIG hängt von der Konfiguration IN4MODE ab.
s. IN4MODE


ASCII Deutsch Index

\
ACC
ACCR
ACCUNIT
ACTFAULT
ACTIVE
ACTRS232
ADDR
AENA
ALIAS
AN11NR
AN11RANGE
ANCNFG
ANDB
ANIN1
ANIN2
ANOFF1
ANOFF2
ANZERO1
ANZERO2
AUTOHOME
AVZ1
BCC
CALCCOG
CALCHP
CALCRK
CALCRP
CBAUD
CLRFAULT
CLRHR
CLRORDER
COGGING
COLDSTART
CONTINUE
CPHASE
CTUNE
CUPDATE
DEC
DECDIS
DECR
DECSTOP
DENA
DI2T
DICONT
DIFVAR
DILIM
DIPEAK
DIS
DISDPR
DNBAUD
DNDUMP
DNMACID
DOVRIDE
DPRILIMIT
DR_TYPE
DREF
DRVCNFG
DUMP
EGEARI
EGEARO
EMRGTO
EN
ENCLINES
ENCMODE
ENCOUT
ENCZERO
ERND
ERRCODE
ERRCODE *
ESPEED
EXTWD
FBTYPE
FLASH
FLTCNT
FLTCNT *
FLTHIST
FLTHIST *
FLUXM
FW
GEARFILT
GEARI
GEARMODE
GEARO
GET
GF
GFTN
GP
GPFFT
GPFFV
GPRED
GPTN
GV
GVTN
HDUMP
HELP
HICOFFS
HIFACT1
HISOFFS
HSAVE
HVER
I
I2TLIM
ICMD
ICMDVLIM
ID
IN
IN1
IN1HCMD
IN1LCMD
IN1MODE
IN1TRIG
IN2
IN2HCMD
IN2LCMD
IN2MODE
IN2PM
IN2TRIG
IN3
IN3HCMD
IN3LCMD
IN3MODE
IN3TRIG
IN4
IN4HCMD
IN4LCMD
IN4MODE
IN4TRIG
INPOS
INPT
INS0
INS1
INS2
INS3
INS4
INS5
INS6
INS7
INS8
IPEAK
IPEAKN
IPEAKP
IQ
ISCALE1
ISCALE2
ISTFR
J
K
KC
KEYLOCK
KTN
LASTWMASK
LATCH32
LATCH32N
LATCHX32
LATCHX32N
LDUMP
LED1
LED2
LED3
LEDSTAT
LIST
LOAD
M
M_1000
M_125
M_1600
M_250
M_250p
M_4000
M_DISABLE
M_ENABLE
M_INIT
M_IRQ
M_RESET
M_SMACRO
M_TASK
M_UMACRO
MAXSDO
MAXTEMPE
MAXTEMPH
MAXTEMPM
MBRAKE
MDBCNT
MDBGET
MDBLIST
MDBSET
MDUMP
MH
MI2T
MICONT
MIMR
MIPEAK
MJ
MJOG
MKT
ML
MLGC
MLGD
MLGP
MLGQ
MNAME
MNUMBER
MOVE
MPHASE
MPOLES
MRESBW
MRESPOLES
MRS
MSERIALNO
MSG
MSLBRAKE
MSPEED
MTANGLP
MTIME
MTMUX
MTR
MTYPE
MUNIT
MVANGLB
MVANGLF
MVANGLP
MVR
NONBTB
NREF
NREFMT
O_ACC1
O_C
O_DEC1
O_FN
O_FT
O_P
O_V
O1
O1MODE
O1TRIG
O2
O2MODE
O2TRIG
OBJCO
OCOPY
OLIST
OPMODE
OPTION
ORDER
OS1
OS2
OS3
OS4
OS5
OVRIDE
P1...P16
PASS
PASSCNFG
PASSX
PBAL
PBALMAX
PBALRES
PE
PEINPOS
PEMAX
PFB
PFB0
PGEARI
PGEARO
PMODE
PNOID
POP
POPI
POPI2
POPV
POSCNFG
POSRSTAT
PPOTYP
PRBASE
PRD
PROMPT
PSTATE
PTARGET
PTBASE
PTEACH
PTMIN
PUNIT
PV
PVMAXN
PVMAXP
RDP
RDPBIAS
RDPCLAMP
RDPINT
RDPKI
RDPKP
RDPON
READNIMP
READY
RECDONE
RECING
RECOFF
RECORD
RECRDY
RECTRIG
REFIP
REFLS
REFMODE
REFPOS
REMOTE
RESOLVER
RESPHASE
RK
ROFFS
ROFFS0
ROFFS2
RS232T
RSTVAR
RXPDO1A
RXPDO1B
RXPDO2A
RXPDO2B
RXPDO3A
RXPDO3B
RXPDO4A
RXPDO4B
S
SAVE
SERIALNO
SETREF
SETROFFS
SETVCT
SLEN
SLOTIO
SMNUMBER
SRND
STAGECODE
STAT
STATCODE
STATCODE *
STATIO
STATUS
STEP
STOP
STOPMODE
SWCNFG
SWE1
SWE2
T
TASK
TBRAKE
TBRAKE0
TEMPE
TEMPH
TEMPM
TRJSTAT
TRUN
TXPDO1A
TXPDO1B
TXPDO2A
TXPDO2B
TXPDO3A
TXPDO3B
TXPDO4A
TXPDO4B
UCOMP
UPDATE
UVLTMODE
V
VBUS
VBUSBAL
VBUSMAX
VBUSMIN
VBW
VCMD
VCOMM
VCTAB
VEL0
VER
VJOG
VLIMN
VLIMP
VLO
VMIX
VOSPD
VREF
VREF0
VSCALE1
VSCALE2
VSTFR
VTUNE
VUNIT
WMASK
WPOS
WPOSE
WPOSP
WPOSX


ASCII Deutsch Index Gruppe

DI2T |
MI2T |
PASS |
ANIN1 | Actual Values
ANIN2 | Actual Values
I | Actual Values
ID | Actual Values
IN | Actual Values
IN1 | Actual Values
IQ | Actual Values
LED1 | Actual Values
LED2 | Actual Values
LED3 | Actual Values
PBAL | Actual Values
PE | Actual Values
PFB | Actual Values
PFB0 | Actual Values
PRD | Actual Values
PV | Actual Values
TASK | Actual Values
TEMPE | Actual Values
TEMPH | Actual Values
TEMPM | Actual Values
V | Actual Values
VBUS | Actual Values
VCMD | Actual Values
ACCUNIT | Amplifier
ACTFAULT | Amplifier
BCC | Amplifier
CLRFAULT | Amplifier
CUPDATE | Amplifier
DICONT | Amplifier
DIPEAK | Amplifier
DIS | Amplifier
DR_TYPE | Amplifier
EN | Amplifier
FW | Amplifier
K | Amplifier
LASTWMASK | Amplifier
LOAD | Amplifier
M | Amplifier
M_1000 | Amplifier
M_125 | Amplifier
M_1600 | Amplifier
M_250 | Amplifier
M_250p | Amplifier
M_4000 | Amplifier
M_DISABLE | Amplifier
M_INIT | Amplifier
M_IRQ | Amplifier
M_RESET | Amplifier
M_SMACRO | Amplifier
M_TASK | Amplifier
M_UMACRO | Amplifier
OPMODE | Amplifier
SAVE | Amplifier
UPDATE | Amplifier
VBUSMAX | Amplifier
VBUSMIN | Amplifier
VBW | Amplifier
VCOMM | Amplifier
VTUNE | Amplifier
WMASK | Amplifier
AN11NR | Analog I/O
AN11RANGE | Analog I/O
ANCNFG | Analog I/O
ANDB | Analog I/O
ANOFF1 | Analog I/O
ANOFF2 | Analog I/O
ANZERO1 | Analog I/O
ANZERO2 | Analog I/O
AVZ1 | Analog I/O
ISCALE1 | Analog I/O
ISCALE2 | Analog I/O
VSCALE1 | Analog I/O
VSCALE2 | Analog I/O
ADDR | Basic Setup
AENA | Basic Setup
ALIAS | Basic Setup
CBAUD | Basic Setup
DENA | Basic Setup
DILIM | Basic Setup
EMRGTO | Basic Setup
ERRCODE | Basic Setup
FLTCNT * | Basic Setup
FLTHIST * | Basic Setup
HVER | Basic Setup
KEYLOCK | Basic Setup
M_ENABLE | Basic Setup
MAXTEMPE | Basic Setup
MAXTEMPH | Basic Setup
MAXTEMPM | Basic Setup
MSLBRAKE | Basic Setup
PASSCNFG | Basic Setup
PASSX | Basic Setup
PBALMAX | Basic Setup
PBALRES | Basic Setup
PMODE | Basic Setup
RSTVAR | Basic Setup
SERIALNO | Basic Setup
STAGECODE | Basic Setup
STOPMODE | Basic Setup
TBRAKE | Basic Setup
TBRAKE0 | Basic Setup
TRUN | Basic Setup
UVLTMODE | Basic Setup
VBUSBAL | Basic Setup
VER | Basic Setup
\ | Communication
ACTRS232 | Communication
DIFVAR | Communication
DISDPR | Communication
DNDUMP | Communication
DNMACID | Communication
DRVCNFG | Communication
DUMP | Communication
EXTWD | Communication
FLASH | Communication
HELP | Communication
LIST | Communication
MAXSDO | Communication
MSG | Communication
OBJCO | Communication
PNOID | Communication
PPOTYP | Communication
PROMPT | Communication
PSTATE | Communication
RS232T | Communication
CTUNE | Current Controller
I2TLIM | Current Controller
ICMD | Current Controller
ICMDVLIM | Current Controller
IPEAK | Current Controller
IPEAKN | Current Controller
IPEAKP | Current Controller
KC | Current Controller
KTN | Current Controller
MLGC | Current Controller
MLGD | Current Controller
MLGP | Current Controller
MLGQ | Current Controller
POP | Current Controller
POPI | Current Controller
POPI2 | Current Controller
POPV | Current Controller
REFIP | Current Controller
IN1HCMD | Digital I/O
IN1LCMD | Digital I/O
IN1MODE | Digital I/O
IN1TRIG | Digital I/O
IN2 | Digital I/O
IN2HCMD | Digital I/O
IN2LCMD | Digital I/O
IN2MODE | Digital I/O
IN2TRIG | Digital I/O
IN3 | Digital I/O
IN3HCMD | Digital I/O
IN3LCMD | Digital I/O
IN3MODE | Digital I/O
IN3TRIG | Digital I/O
IN4 | Digital I/O
IN4HCMD | Digital I/O
IN4LCMD | Digital I/O
IN4MODE | Digital I/O
IN4TRIG | Digital I/O
INS0 | Digital I/O
INS1 | Digital I/O
INS2 | Digital I/O
INS3 | Digital I/O
INS4 | Digital I/O
INS5 | Digital I/O
INS6 | Digital I/O
INS7 | Digital I/O
INS8 | Digital I/O
O1 | Digital I/O
O1MODE | Digital I/O
O1TRIG | Digital I/O
O2 | Digital I/O
O2MODE | Digital I/O
O2TRIG | Digital I/O
OS1 | Digital I/O
OS2 | Digital I/O
OS3 | Digital I/O
OS4 | Digital I/O
OS5 | Digital I/O
SETVCT | Digital I/O
SLOTIO | Digital I/O
STATIO | Digital I/O
VCTAB | Digital I/O
ACTIVE | Drive Status
CLRHR | Drive Status
COLDSTART | Drive Status
ERRCODE * | Drive Status
FLTCNT | Drive Status
FLTHIST | Drive Status
LEDSTAT | Drive Status
NONBTB | Drive Status
OPTION | Drive Status
READY | Drive Status
REMOTE | Drive Status
STAT | Drive Status
STATCODE | Drive Status
STATCODE * | Drive Status
STATUS | Drive Status
TRJSTAT | Drive Status
CALCCOG | Feedback
CALCHP | Feedback
CALCRK | Feedback
CALCRP | Feedback
COGGING | Feedback
FBTYPE | Feedback
HDUMP | Feedback
HICOFFS | Feedback
HIFACT1 | Feedback
HISOFFS | Feedback
HSAVE | Feedback
MPHASE | Feedback
MRESBW | Feedback
MRESPOLES | Feedback
READNIMP | Feedback
RESOLVER | Feedback
RESPHASE | Feedback
RK | Feedback
ROFFS0 | Feedback
SMNUMBER | Feedback
VLO | Feedback
DNBAUD | Fieldbus
DPRILIMIT | Fieldbus
RXPDO1A | Fieldbus
RXPDO1B | Fieldbus
RXPDO2A | Fieldbus
RXPDO2B | Fieldbus
RXPDO3A | Fieldbus
RXPDO3B | Fieldbus
RXPDO4A | Fieldbus
RXPDO4B | Fieldbus
TXPDO1A | Fieldbus
TXPDO1B | Fieldbus
TXPDO2A | Fieldbus
TXPDO2B | Fieldbus
TXPDO3A | Fieldbus
TXPDO3B | Fieldbus
TXPDO4A | Fieldbus
TXPDO4B | Fieldbus
GEARI | Gearing
GEARMODE | Gearing
GEARO | Gearing
ROFFS2 | Gearing
CPHASE | Motor
ENCLINES | Motor
FLUXM | Motor
GF | Motor
GFTN | Motor
LDUMP | Motor
MBRAKE | Motor
MDBCNT | Motor
MDBGET | Motor
MDBLIST | Motor
MDBSET | Motor
MDUMP | Motor
MICONT | Motor
MIMR | Motor
MIPEAK | Motor
MJ | Motor
MKT | Motor
ML | Motor
MNAME | Motor
MNUMBER | Motor
MPOLES | Motor
MRS | Motor
MSERIALNO | Motor
MSPEED | Motor
MTANGLP | Motor
MTIME | Motor
MTR | Motor
MTYPE | Motor
MVANGLB | Motor
MVANGLF | Motor
MVANGLP | Motor
MVR | Motor
GET | Oscilloscope
J | Oscilloscope
RECDONE | Oscilloscope
RECING | Oscilloscope
RECOFF | Oscilloscope
RECORD | Oscilloscope
RECTRIG | Oscilloscope
S | Oscilloscope
STEP | Oscilloscope
T | Oscilloscope
RECRDY | Oszilloscope
GEARFILT | Position
O_C | Position Controler
ACCR | Position Controller
AUTOHOME | Position Controller
CLRORDER | Position Controller
CONTINUE | Position Controller
DECR | Position Controller
DOVRIDE | Position Controller
DREF | Position Controller
ERND | Position Controller
GP | Position Controller
GPFFT | Position Controller
GPFFV | Position Controller
GPRED | Position Controller
GPTN | Position Controller
IN2PM | Position Controller
INPOS | Position Controller
INPT | Position Controller
LATCH32 | Position Controller
LATCH32N | Position Controller
LATCHX32 | Position Controller
LATCHX32N | Position Controller
MH | Position Controller
MJOG | Position Controller
MOVE | Position Controller
MTMUX | Position Controller
MUNIT | Position Controller
NREF | Position Controller
NREFMT | Position Controller
O_ACC1 | Position Controller
O_DEC1 | Position Controller
O_FN | Position Controller
O_FT | Position Controller
O_P | Position Controller
O_V | Position Controller
OCOPY | Position Controller
OLIST | Position Controller
ORDER | Position Controller
OVRIDE | Position Controller
P1...P16 | Position Controller
PEINPOS | Position Controller
PEMAX | Position Controller
PGEARI | Position Controller
PGEARO | Position Controller
POSCNFG | Position Controller
POSRSTAT | Position Controller
PRBASE | Position Controller
PTARGET | Position Controller
PTBASE | Position Controller
PTEACH | Position Controller
PTMIN | Position Controller
PUNIT | Position Controller
PVMAXN | Position Controller
PVMAXP | Position Controller
REFLS | Position Controller
REFMODE | Position Controller
REFPOS | Position Controller
ROFFS | Position Controller
SETREF | Position Controller
SETROFFS | Position Controller
SRND | Position Controller
STOP | Position Controller
SWCNFG | Position Controller
SWE1 | Position Controller
SWE2 | Position Controller
UCOMP | Position Controller
VJOG | Position Controller
VREF | Position Controller
VREF0 | Position Controller
WPOS | Position Controller
WPOSE | Position Controller
WPOSP | Position Controller
WPOSX | Position Controller
EGEARI | Position Loop
EGEARO | Position Loop
ENCMODE | Position Output
ENCOUT | Position Output
ENCZERO | Position Output
RDP | Rack Drive Panel
RDPBIAS | Rack Drive Panel
RDPCLAMP | Rack Drive Panel
RDPINT | Rack Drive Panel
RDPKI | Rack Drive Panel
RDPKP | Rack Drive Panel
RDPON | Rack Drive Panel
SLEN | Sercos
ACC | Velocity Controller
DEC | Velocity Controller
DECDIS | Velocity Controller
DECSTOP | Velocity Controller
ESPEED | Velocity Controller
GV | Velocity Controller
GVTN | Velocity Controller
ISTFR | Velocity Controller
VEL0 | Velocity Controller
VLIMN | Velocity Controller
VLIMP | Velocity Controller
VMIX | Velocity Controller
VOSPD | Velocity Controller
VSTFR | Velocity Controller
VUNIT | Velocity Controller


ASCII Deutsch Index Objekt

MAXSDO | Object 0
EMRGTO | Object 0
GPRED | Object 0
ACC | Object 1
ACCR | Object 2
ACTFAULT | Object 3
ACTIVE | Object 4
ADDR | Object 5
AENA | Object 6
ANCNFG | Object 7
ANDB | Object 8
ANIN1 | Object 9
ANIN2 | Object 10
ANOFF1 | Object 11
ANOFF2 | Object 12
ANZERO1 | Object 15
ANZERO2 | Object 16
AVZ1 | Object 17
CALCHP | Object 18
CALCRK | Object 19
CALCRP | Object 20
CBAUD | Object 21
CLRFAULT | Object 24
CLRHR | Object 25
CLRORDER | Object 26
CONTINUE | Object 29
CTUNE | Object 30
CUPDATE | Object 31
DEC | Object 34
DECDIS | Object 35
DECR | Object 36
DECSTOP | Object 37
DICONT | Object 39
DIFVAR | Object 40
DIPEAK | Object 41
DIS | Object 43
DREF | Object 44
DR_TYPE | Object 46
DUMP | Object 47
EN | Object 48
ENCLINES | Object 51
ENCMODE | Object 52
ENCOUT | Object 53
ENCZERO | Object 55
EXTWD | Object 58
FBTYPE | Object 59
GEARI | Object 62
GEARMODE | Object 63
GEARO | Object 64
GET | Object 65
GP | Object 66
GPFFV | Object 69
GPTN | Object 70
GV | Object 72
GVTN | Object 77
HDUMP | Object 81
HICOFFS | Object 82
HIFACT1 | Object 83
HISOFFS | Object 84
HSAVE | Object 86
HVER | Object 87
I | Object 88
I2TLIM | Object 90
ICMD | Object 91
ID | Object 93
IN | Object 96
IN1 | Object 97
IN1MODE | Object 98
IN1TRIG | Object 99
IN2 | Object 100
IN2MODE | Object 101
IN2TRIG | Object 102
IN3 | Object 103
IN3MODE | Object 104
IN3TRIG | Object 105
IN4 | Object 106
IN4MODE | Object 107
IN4TRIG | Object 108
INPOS | Object 109
IPEAK | Object 110
IPEAKN | Object 111
IQ | Object 112
ISCALE1 | Object 113
ISCALE2 | Object 114
K | Object 115
KC | Object 116
KEYLOCK | Object 117
ML | Object 119
LATCH32 | Object 122
LATCH32N | Object 123
LATCHX32 | Object 124
LATCHX32N | Object 125
LED1 | Object 126
LED2 | Object 127
LED3 | Object 128
LEDSTAT | Object 129
LIST | Object 130
LOAD | Object 131
MAXTEMPE | Object 132
MAXTEMPH | Object 133
MAXTEMPM | Object 134
MBRAKE | Object 135
MDBCNT | Object 136
MDBGET | Object 137
MDBSET | Object 138
MDUMP | Object 139
MH | Object 141
MICONT | Object 142
MIPEAK | Object 143
MJOG | Object 145
MVANGLP | Object 146
MKT | Object 147
MLGC | Object 149
MLGD | Object 150
MLGP | Object 151
MLGQ | Object 152
MNUMBER | Object 153
MPHASE | Object 156
MPOLES | Object 157
MRESBW | Object 160
MRESPOLES | Object 161
MSG | Object 162
MSPEED | Object 163
MTANGLP | Object 165
MTYPE | Object 166
MVANGLB | Object 167
MVANGLF | Object 168
M_RESET | Object 169
NONBTB | Object 170
NREF | Object 173
O1 | Object 174
O1MODE | Object 175
O1TRIG | Object 176
O2 | Object 177
O2MODE | Object 178
O2TRIG | Object 179
OPMODE | Object 180
OPTION | Object 181
OVRIDE | Object 182
O_ACC1 | Object 183
O_C | Object 185
O_DEC1 | Object 186
O_FN | Object 188
O_FT | Object 189
O_P | Object 190
O_V | Object 191
PBAL | Object 192
PBALMAX | Object 193
PBALRES | Object 194
PE | Object 197
PEINPOS | Object 198
PEMAX | Object 199
PFB | Object 200
PFB0 | Object 201
PGEARI | Object 202
PGEARO | Object 203
PMODE | Object 205
PNOID | Object 206
POSCNFG | Object 207
PPOTYP | Object 208
PRBASE | Object 209
PRD | Object 210
PROMPT | Object 211
PSTATE | Object 212
PTBASE | Object 213
PTMIN | Object 214
PV | Object 215
PVMAXP | Object 216
PVMAXN | Object 217
READNIMP | Object 220
READY | Object 221
RECDONE | Object 222
RECING | Object 223
RECOFF | Object 224
RECRDY | Object 225
REFIP | Object 226
REFPOS | Object 227
REMOTE | Object 228
RESPHASE | Object 229
RK | Object 230
ROFFS | Object 231
RS232T | Object 232
RSTVAR | Object 233
S | Object 234
SAVE | Object 235
SERIALNO | Object 239
SETREF | Object 240
SETROFFS | Object 241
SLEN | Object 242
SLOTIO | Object 243
STAT | Object 251
STATIO | Object 252
STATUS | Object 253
STOP | Object 254
STOPMODE | Object 255
SWCNFG | Object 256
SWE1 | Object 260
SWE2 | Object 262
T | Object 270
TASK | Object 271
TEMPE | Object 272
TEMPH | Object 273
TEMPM | Object 274
TRJSTAT | Object 275
TRUN | Object 276
UVLTMODE | Object 279
V | Object 280
VBUS | Object 282
VBUSBAL | Object 283
VBUSMAX | Object 284
VBUSMIN | Object 285
VCMD | Object 286
VEL0 | Object 288
VJOG | Object 289
VLIMP | Object 290
VLIMN | Object 291
VMIX | Object 293
VOSPD | Object 295
VREF | Object 296
VSCALE1 | Object 297
VSCALE2 | Object 298
\ | Object 299
DILIM | Object 300
DENA | Object 301
IN2PM | Object 302
KTN | Object 303
INPT | Object 304
UCOMP | Object 305
COLDSTART | Object 306
SETVCT | Object 309
WPOS | Object 310
SRND | Object 311
ERND | Object 312
BCC | Object 314
REFMODE | Object 316
VLO | Object 317
WMASK | Object 318
WPOSE | Object 319
WPOSP | Object 320
WPOSX | Object 321
MOVE | Object 322
POSRSTAT | Object 323
P1...P16 | Object 324
PTARGET | Object 340
ACTRS232 | Object 341
ROFFS2 | Object 342
FW | Object 343
DPRILIMIT | Object 344
ACCUNIT | Object 345
VCOMM | Object 346
MTMUX | Object 347
ROFFS0 | Object 348
REFLS | Object 349
VUNIT | Object 351
PUNIT | Object 352
GF | Object 359
GFTN | Object 360
MIMR | Object 363
MTR | Object 364
MVR | Object 365
TBRAKE | Object 366
TBRAKE0 | Object 367
MSLBRAKE | Object 369
DRVCNFG | Object 370
DISDPR | Object 371
MUNIT | Object 372
ESPEED | Object 373
STAGECODE | Object 386
ICMDVLIM | Object 389
MRS | Object 390
FLUXM | Object 393
SMNUMBER | Object 405
VREF0 | Object 408
AN11NR | Object 409
AN11RANGE | Object 410
MSERIALNO | Object 419
ISTFR | Object 420
VSTFR | Object 421
DOVRIDE | Object 438
RDP | Object 439
RDPBIAS | Object 440
RDPCLAMP | Object 441
RDPINT | Object 442
RDPKI | Object 443
RDPKP | Object 444
RDPON | Object 445
INS0 | Object 446
INS1 | Object 447
INS2 | Object 448
INS3 | Object 449
INS4 | Object 450
INS5 | Object 451
INS6 | Object 452
INS7 | Object 453
INS8 | Object 454
OS1 | Object 455
OS2 | Object 456
OS3 | Object 457
OS4 | Object 458
OS5 | Object 459
LASTWMASK | Object 462
COGGING | Object 463
NREFMT | Object 466
PASSX | Object 468
PASS | Object 469
AUTOHOME | Object 471
PASSCNFG | Object 472
FLASH | Object 473


ASCII Deutsch INPOS

ASCII - Kommando | INPOS |
Syntax Senden | INPOS |
Syntax Empfangen | INPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 356D (hex)
DIM | - | PROFIBUS PNU | 1709 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 109 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | In-Position-Meldung

Beschreibung

Das Kommando INPOS liefert den Zustand des IN-Position-Bits des Statusregisters (DRVSTAT).
Solange die Differenz zwischen der letzten Zielposition (Fahrauftrag) und der Istposition (PFB) kleiner ist als das eingestellte IN-Position-Fenster (PEINPOS), so wird eine 1 gemeldet, ansonsten eine 0.

Siehe auch INPT


ASCII Deutsch INPT

ASCII - Kommando | INPT |
Syntax Senden | INPT [Data] |
Syntax Empfangen | INPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3630 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1904 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 304 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | In-Position-Verzögerung

Beschreibung

Das Kommando INPT definiert eine Verzögerungszeit für die In-Position-Meldung. Beim Start eines Fahrsatzes wird die In-Position-Meldung zurückgenommen und erst nach Ablauf der eingestellten Zeit die Überwachung des In-Position-Fensters aktiviert. Diese Funktion ist besonders wichtig bei Positioniervorgängen innerhalb des In-Position-Fensters. In diesem Fall wird auf jeden Fall sichergestellt, daß die In-Position-Meldung für eine definierte Zeit zurückgenommen wird.

Siehe auch INPOS


ASCII Deutsch INS0

ASCII - Kommando | INS0 |
Syntax Senden | INS0 |
Syntax Empfangen | INS0 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BE (hex)
DIM | - | PROFIBUS PNU | 2046 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 446 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A0 der I/O Erweiterungskarte

Beschreibung

INS0 kann benutzt werden, um den Status des digitalen Eingangs A0 (Klemme 1) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS1

ASCII - Kommando | INS1 |
Syntax Senden | INS1 |
Syntax Empfangen | INS1 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BF (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 447 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A1 der I/O Erweiterungskarte

Beschreibung

INS1 kann benutzt werden, um den Status des digitalen Eingangs A1 (Klemme 2 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS2

ASCII - Kommando | INS2 |
Syntax Senden | INS2 |
Syntax Empfangen | INS2 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C0 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 448 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A2 der I/O Erweiterungskarte

Beschreibung

INS2 kann benutzt werden, um den Status des digitalen Eingangs A2 (Klemme 3 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS3

ASCII - Kommando | INS3 |
Syntax Senden | INS3 |
Syntax Empfangen | INS3 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C1 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 449 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A3 der I/O Erweiterungskarte

Beschreibung

INS3 kann benutzt werden, um den Status des digitalen Eingangs A3 (Klemme 4 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS4

ASCII - Kommando | INS4 |
Syntax Senden | INS4 |
Syntax Empfangen | INS4 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C2 (hex)
DIM | - | PROFIBUS PNU | 1650 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 450 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A4 der I/O Erweiterungskarte

Beschreibung

INS4 kann benutzt werden, um den Status des digitalen Eingangs A4 (Klemme 5 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS5

ASCII - Kommando | INS5 |
Syntax Senden | INS5 |
Syntax Empfangen | INS5 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C3 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 451 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A5 der I/O Erweiterungskarte

Beschreibung

INS5 kann benutzt werden, um den Status des digitalen Eingangs A5 (Klemme 6 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS6

ASCII - Kommando | INS6 |
Syntax Senden | INS6 |
Syntax Empfangen | INS6 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C4 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 452 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A6 der I/O Erweiterungskarte

Beschreibung

INS6 kann benutzt werden, um den Status des digitalen Eingangs A6 (Klemme 7 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS7

ASCII - Kommando | INS7 |
Syntax Senden | INS7 |
Syntax Empfangen | INS7 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C5 (hex)
DIM | - | PROFIBUS PNU | 1653 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 453 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von Eingang A7 der I/O Erweiterungskarte

Beschreibung

INS7 kann benutzt werden, um den Status des digitalen Eingangs A7 (Klemme 8 von X11A) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz anzuwählen.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch INS8

ASCII - Kommando | INS8 |
Syntax Senden | INS8 |
Syntax Empfangen | INS8 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C6 (hex)
DIM | - | PROFIBUS PNU | 1654 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 454 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status von FSTART_IO der I/O Erweiterungskarte

Beschreibung

INS8 kann benutzt werden, um den Status des digitalen Eingangs FSTART_IO (Klemme 2 von X11B) der I/O Erweiterungskarte einzulesen. Der Eingang wird normalerweise benutzt, um einen Fahrsatz zu starten.
Durch Setzen von IO11IN = 2 kann der Eingang auch für eine andere Verwendung freigeschaltet werden.


ASCII Deutsch IPEAK

ASCII - Kommando | IPEAK |
Syntax Senden | IPEAK [Data] |
Syntax Empfangen | IPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 356E (hex)
DIM | Amperes | PROFIBUS PNU | 1710 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 ... DIPEAK | DPR | 110 (dec)
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom

Beschreibung

Stellt den gewünschten Impulsstrom IPEAKP und IPEAKN (Effektivwert) ein.


ASCII Deutsch IPEAKN

ASCII - Kommando | IPEAKN |
Syntax Senden | IPEAKN [Data] |
Syntax Empfangen | IPEAKN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | 0.0 ... DIPEAK | DPR | Nein
Default | IMAX |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Negative Spitzenstrombegrenzung

Beschreibung

Max. negativer Impulsstrom des Motors in A rms. Kann bei I2T Begrenzung auf DICONT oder MICONT zurückfallen.


ASCII Deutsch IPEAKP

ASCII - Kommando | IPEAKP |
Syntax Senden | IPEAKP [Data] |
Syntax Empfangen | IPEAKP <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A rms | PROFIBUS PNU | Nein
Bereich | 0 ... DIPEAK | DPR | Nein
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | + | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Max.positiver Impulsstrom des Motors in A rms

Beschreibung

Max. positiver Impulsstrom des Motors in A rms. Kann bei I2T Begrenzung auf DICONT oder MICONT zurückfallen.


ASCII Deutsch IQ

ASCII - Kommando | IQ |
Syntax Senden | IQ |
Syntax Empfangen | IQ <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3570 (hex)
DIM | Amperes | PROFIBUS PNU | 1712 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 112 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Q-Anteil des Stromistwertes

Beschreibung

Drehmomentbildender Stromistwert (Q-Richtung)


ASCII Deutsch ISCALE1

ASCII - Kommando | ISCALE1 |
Syntax Senden | ISCALE1 [Data] |
Syntax Empfangen | ISCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3571 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1713 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 100.0 | DPR | 113 (dec)
Default | DIPEAK |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 1

Beschreibung

Definiert die Normierung des analogen SW1-Eingangs (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISCALE2

ASCII - Kommando | ISCALE2 |
Syntax Senden | ISCALE2 [Data] |
Syntax Empfangen | ISCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3572 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1714 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 100.0 | DPR | 114 (dec)
Default | DIPEAK |
Opmode | 3 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | Skalierungsfaktor für den analogen Stromsollwert 2

Beschreibung

Definiert die Normierung des analogen SW2-Eingangs (falls Stromsollwert in OPMODE = 3). Der eingestellte Strom-Wert entspricht der maximalen Eingangsspannung (10V).


ASCII Deutsch ISTFR

ASCII - Kommando | ISTFR |
Syntax Senden | ISTFR [Data] |
Syntax Empfangen | ISTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A4 (hex)
DIM | A | PROFIBUS PNU | 2020 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. IPEAK | DPR | 420 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Reibungskompensation

Beschreibung

IN VORBEREITUNG !

Die beiden Kommandos ISTFR und VSTFR definieren die Eckwerte für die Friktion-Kompensation. Mit ISTFR wird diese Kompensation aktiviert und bewirkt die Aufschaltung einer drehzahlabhängigen Stromvorsteuerung.
Wenn IFSTFR von 0 auf einen anderen Wert geändert wird, so muss der Parameter zunächst gespeichert werden und ein Reset muss erfolgen. Dann kann der Parameter Online geändert werden.

V=0 -> IFRICT = 0
V= 50% von VSTFR -> IFRICT = 50% von ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% von VSTFR -> IFRICT = -50% von ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII Deutsch J

ASCII - Kommando | J |
Syntax Senden | J [Data] |
Syntax Empfangen | J <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | rpm (velocity) / Milliseconds (Time) | PROFIBUS PNU | Nein
Bereich | -15000.0 .. 15000.0 (=velocity),long int (Time) | DPR | Nein
Default | - |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Service-Funktion "konstante Drehzahl"

Beschreibung

Mit dem Kommando "J <n> <t>" kann eine konstante Drehzahl <n> (in UPM) für eine bestimmte Zeit <t> (in msek) vorgegeben werden. Fehlt die Eingabe der Zeit <t>, so läuft der Antrieb im Endlosbetrieb.


ASCII Deutsch K

ASCII - Kommando | K |
Syntax Senden | K |
Syntax Empfangen | K | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3573 (hex)
DIM | - | PROFIBUS PNU | 1715 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 115 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Software-Sperre der Endstufe

Beschreibung

Das K-Kommando stellt eine verkürzte (Kommandolänge) Form des Kommandos "DIS" dar.


ASCII Deutsch KC

ASCII - Kommando | KC |
Syntax Senden | KC [Data] |
Syntax Empfangen | KC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3574 (hex)
DIM | - | PROFIBUS PNU | 1716 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.0 | DPR | 116 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Stromistwert-Vorsteuerung Stromregler

Beschreibung

KC ist ein Parameter des Stromregelkreises. Zur Kompensation von Verzugszeiten kann dem gemessenen Motorstrom eine vorhersehbare Stromänderung hinzugefügt werden (Strom Prädiktion). KC 1 schaltet diese ein, KC 0.5 setzt sie auf 50 % und KC 0 schaltet sie aus. Das Ausschalten der Stromprädiktion kann die Stabilität des Stromregelkreises beeinträchtigen.


ASCII Deutsch KEYLOCK

ASCII - Kommando | KEYLOCK |
Syntax Senden | KEYLOCK [Data] |
Syntax Empfangen | KEYLOCK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3575 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 117 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Sperre für die Tastenbedienung

Beschreibung

Bei KEYLOCK=1 ist die Bedienung des Verstärkers über die Tasten auf der Frontplatte gesperrt. Die Anzeige-Funktionen des Gerätes (Fehlermeldungen, Warnungen) sind weiterhin aktiv.


ASCII Deutsch KTN

ASCII - Kommando | KTN |
Syntax Senden | KTN [Data] |
Syntax Empfangen | KTN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 362F (hex)
DIM | Milliseconds | PROFIBUS PNU | 1903 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 2.0 | DPR | 303 (dec)
Default | 0.6 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Stromreglers

Beschreibung

Integralanteil des Stromreglers


ASCII Deutsch LASTWMASK

ASCII - Kommando | LASTWMASK |
Syntax Senden | LASTWMASK |
Syntax Empfangen | LASTWMASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36CE (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0001xxxx (bin)
Bereich | long int | DPR | 462 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Fehlerspeicher von WMASK

Beschreibung

Über WMASK kann eine Maske erstellt werden, welche Warnungen in Fehler umgewandelt werden sollen. Falls der Fehler F24 auftritt, kann dann über LASTWMASK ausgelesen werden, welche Warnungen zu diesem Fehler geführt haben.


ASCII Deutsch LATCH32

ASCII - Kommando | LATCH32 |
Syntax Senden | LATCH32 |
Syntax Empfangen | LATCH32 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357A (hex)
DIM | - | PROFIBUS PNU | 1722 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 122 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Gelachte 32 Bit-Position (positive Flanke)

Beschreibung

IN VORBEREITUNG !

Das Kommando LATCH32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH16 benutzt werden.
Die Kommandos LATCH16 und LATCH32 bewirken das Löschen des Status-Bits 20 "positiver Latch erfolgte" im Statusregister DRVSTAT.


ASCII Deutsch LATCH32N

ASCII - Kommando | LATCH32N |
Syntax Senden | LATCH32N |
Syntax Empfangen | LATCH32N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 357B (hex)
DIM | - | PROFIBUS PNU | 1723 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 123 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 32 Bit-Position (negative Flanke)

Beschreibung

IN VORBEREITUNG !

Das Kommando LATCH32N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 2 (IN2MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCH16N benutzt werden.
Die Kommandos LATCH16N und LATCH32N bewirken das Löschen des Status-Bits 23 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX32

ASCII - Kommando | LATCHX32 |
Syntax Senden | LATCHX32 |
Syntax Empfangen | LATCHX32 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357C (hex)
DIM | - | PROFIBUS PNU | 1724 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 124 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelatchte 32 Bit-Position (positive Flanke)

Beschreibung

IN VORBEREITUNG !

Falls das Einlesen einer externen Geber-Position aktiviert ist (EXTPOS=1,2), so wird diese Position beim Auftreten eines Latch-Ereignisses (IN1MODE=26) automatisch gespeichert.
Das Kommando LATCHX32 gibt die Position aus, die mit der letzten positiven Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCHX16 benutzt werden.
Die Kommandos LATCHX16 und LATCHX32 bewirken das Löschen des Status-Bits 25 "positiver Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LATCHX32N

ASCII - Kommando | LATCHX32N |
Syntax Senden | LATCHX32N |
Syntax Empfangen | LATCHX32N <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 357D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 125 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 2.07 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.7
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Gelachte 32 Bit-Position (negative Flanke)

Beschreibung

IN VORBEREITUNG !

Falls das Einlesen einer externen Geber-Position aktiviert ist (EXTPOS=1,2), so wird diese Position beim Auftreten eines Latch-Ereignisses (IN1MODE=26) automatisch gespeichert.
Das Kommando LATCHX32N gibt die Position aus, die mit der letzten negativen Flanke am digitalen Eingang 1 (IN1MODE=26) , gelatcht wurde. Der Positionswert ist absolut innerhalb von 4096 Umdrehungen und wird in um (mit Berücksichtigung der Lagereglerauflösung PGEARI/PGEARO) ausgegeben. Um eine absolute Position innerhalb einer Umdrehung zu erhalten, sollte das Kommando LATCHX16N benutzt werden.
Die Kommandos LATCHX16N und LATCHX32N bewirken das Löschen des Status-Bits 26 "negativer Latch erfolgte" im Statusregister TRJSTAT.


ASCII Deutsch LDUMP

ASCII - Kommando | LDUMP |
Syntax Senden | LDUMP [data] |
Syntax Empfangen | LDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Parameterausgabe eines Motordatensatzes

Beschreibung

Mit dem Kommando LDUMP <name> können die Parameter des Motordatensatzes <name> aus der internen Motordatenbank ausgegeben werden. Als <name> muß eine gültige Motorbezeichnungen aus der Motordatenbank angegeben werden (s. MDBLIST). Falls der Parameter <name> nicht angegeben wird, so werden die aktuell geladenen Motor-Parameter angezeigt.


ASCII Deutsch LED1

ASCII - Kommando | LED1 |
Syntax Senden | LED1 [Data] |
Syntax Empfangen | LED1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357E (hex)
DIM | - | PROFIBUS PNU | 1726 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 126 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED1-Segmentes

Beschreibung

IN VORBEREITUNG !

Das Kommando LED1 liefert den aktuellen Zustand (7-Segment-Code) des LED1-Segmentes (links).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED1 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED2

ASCII - Kommando | LED2 |
Syntax Senden | LED2 [Data] |
Syntax Empfangen | LED2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 357F (hex)
DIM | - | PROFIBUS PNU | 1727 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 127 | DPR | 127 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED2-Segmentes

Beschreibung

IN VORBEREITUNG !

Das Kommando LED2 liefert den aktuellen Zustand (7-Segment-Code) des LED2-Segmentes (mitte).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED2 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LED3

ASCII - Kommando | LED3 |
Syntax Senden | LED3 [Data] |
Syntax Empfangen | LED3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3580 (hex)
DIM | - | PROFIBUS PNU | 1728 (dec) IND = 0000xxxx (bin)
Bereich | 0 ..127 | DPR | 128 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | -
Kurzbeschreibung | Anzeigestatus des LED3-Segmentes

Beschreibung

IN VORBEREITUNG !

Das Kommando LED3 liefert den aktuellen Zustand (7-Segment-Code) des LED3-Segmentes (rechts).

Bit-Belegung einer 7-Segment-Anzeige

Bit 0 (0x01, 1) Segment A (oben)
Bit 1 (0x02, 2) Segment B (oben rechts)
Bit 2 (0x04, 4) Segment C (unten rechts)
Bit 3 (0x08, 8) Segment D (unten)
Bit 4 (0x10, 16) Segment E (unten links)
Bit 5 (0x20, 32) Segment F (oben links)
Bit 6 (0x40, 64) Segment G (mitte)

Bei einem Schreibzugriff LED3 <code> wird der vorgegebene Code auf dem Display ausgegeben.
Dies ist nur dann sinnvoll, wenn die interne Display-Ausgabe abgeschaltet ist (LEDSTAT 0).
Die Ausgabe eines Dezimalpunktes ist nicht möglich.


ASCII Deutsch LEDSTAT

ASCII - Kommando | LEDSTAT |
Syntax Senden | LEDSTAT [Data] |
Syntax Empfangen | LEDSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3581 (hex)
DIM | - | PROFIBUS PNU | 1729 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 16 | DPR | 129 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Seitennummer für das LED-Display

Beschreibung

IN VORBEREITUNG !

Die Variable LEDSTAT zeigt die Nummer der aktuellen "Display-Seite". Durch die Änderung der Variable LEDSTAT, kann über die serielle Schnittstelle die Anzeige umgeschaltet werden.
Es gilt folgende Zuordnung:
LEDSTAT=0 Ansteuerung der Anzeige abgeschaltet
LEDSTAT=1 Status-Anzeige
LEDSTAT=2 Feldbusadresse
LEDSTAT=3 CAN-Baudrate
LEDSTAT=4 Parameter S01 (Kp Drehzahlregler)
LEDSTAT=5 Parameter S02 (Tn Drehzahlregler)
LEDSTAT=6 Parameter S03 (Sollwert-Offset)
LEDSTAT=7 Parameter S04 (Motornummer)
LEDSTAT=8 Parameter S05 (Encoder-Vorwahl)
LEDSTAT=9 Parameter S06 (Bremsenvorwahl)
LEDSTAT=10 Parameter S07 (Multidrive-Vorwahl, ab Software 3.00)
LEDSTAT=11 Laden der Daten aus dem EEPROM
LEDSTAT=12 Speichern der Daten im EEPROM
LEDSTAT=13 Default-Werte setzen (ab Software 3.00)
LEDSTAT=14 Neukonfiguration des Verstärkers (M_RESET, ab Software 3.00)
LEDSTAT=15 Fehlermeldungen
LEDSTAT=16 Seriennummer


ASCII Deutsch LIST

ASCII - Kommando | LIST |
Syntax Senden | LIST |
Syntax Empfangen | LIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 3582 (hex)
DIM | - | PROFIBUS PNU | 1730 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 130 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Auflistung aller ASCII-Kommandos

Beschreibung

Es werden alle Kommandos aufgelistet, die für die vorhandene Verstärker/Motor-Konfiguration möglich sind. ASCII-Befehle, die bestimmte Hardware voraussetzen (z.B. Hiperface/Endat, Profibus,Sercos) werden nur dann angezeigt, wenn die entsprechende Hardware korrekt erkannt wurde.


ASCII Deutsch LOAD

ASCII - Kommando | LOAD |
Syntax Senden | LOAD |
Syntax Empfangen | LOAD | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3583 (hex)
DIM | - | PROFIBUS PNU | 1731 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 131 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Laden der Parameter aus dem seriellen EEPROM

Beschreibung

Das Kommando LOAD bewirkt das Laden der Parameter aus dem seriellen EEPROM. Alle Parameteränderungen, die seit dem letzten SAVE-Kommando (Abspeichern im seriellen EEPROM) durchgeführt wurden, gehen verloren.


LOGO

Deutsche ASCII Objektreferenz

Switch language to English

sortiert nach:


ASCII Deutsch M

ASCII - Kommando | M |
Syntax Senden | M [Data] |
Syntax Empfangen | M <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Lesen/Schreiben einer Macro-Variable

Beschreibung

Mit dem Kommando "M" kann jede interne Macro-Variable angesprochen werden.
Macro-Variablen sind Variablen, die von den Macro-Routinen benutzt werden. Sie werden innerhalb einer Macro-Routine mit ihren Namen angesprochen. Die vollständige Variablen-Information (Name, Adresse) wird in Form einer Tabelle verwaltet. Es gibt zwei Arten von Macro-Variablen:
1. System-Variablen - diese Variablen werden fest von der Firmware vorgegeben. Sowohl die Namen als auch die Adressen von diesen Variablen sind innerhalb einer bestimmten Firmware-Version konstant. Die Tabelle mit den Variablen-Daten liegt im Programmbereich, so daß der Zugriff auf System-Variablen jederzeit möglich ist.
2. User-Variablen - diese Variablen werden während der Initialisierungsphase des Verstärkers in den Macro-Routinen angelegt. Das Vorhandensein einer bestimmten Variable bzw. deren physikalische Adresse hängt von der Konfiguration des Verstärkers ab. Die Tabelle mit Variablen-Informationen wird im RAM angelegt und normalerweise nur während der Übersetzung der Macro-Programme (Initialisierungsphase) benötigt. Nachdem die Initialisierung abgeschlossen ist, wird die Tabelle aus dem Speicher entfernt. Der Zugriff auf die User-Variablen mit dem M-Kommando ist in diesem Fall nicht möglich.
Falls beim Einschalten des Verstärkers die Parametereinstellung MSG=2 gefunden wird, so wird die Variablen-Tabelle für die User-Variablen im Speicher gelassen. Auf diese Weise kann auch eine User-Variable mit dem M-Kommando angesprochen werden.
Das Kommando M kann in einer der drei Formen benutzt werden:
1. "M" es wird eine Liste aller System- und User-Variablen ausgegeben.

2. "M name" es wird eine Informationszeile zu der Variable <name> in folgender Form ausgegeben:
"Name [TYPE] Adresse FORMAT=Wert"
Die einzelnen Komponenten haben folgende Bedeutung:
name = Name der Macro-Variable
TYPE = Variablentype (SYSTEM oder USER)
adresse = physikalische Adresse der Variable (Hexadezimale Darstellung)
FORMAT = Variablenart (BYTE,WORD,LONG,STRING), der Zusatz FAST bedeutet, daß die Variable im internen (schnellen) RAM abgelegt ist.
Wert= Variableninhalt (Hexadezimale Darstellung bzw. ASCII-String je nach FORMAT)

3. "M Name Wert" die Zahl "Wert" wird in der Variable "Name" eingetragen.
Die Angabe "Wert" wird in dezimaler Darstellung erwartet. Bei Voreinstellung der Zeichenfolge "0x" kann die Zahl auch in hexadezimaler Darstellung angegeben werden.


ASCII Deutsch M_125

ASCII - Kommando | M_125 |
Syntax Senden | M_125 |
Syntax Empfangen | M_125 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 125 usek Macro-Programmes

Beschreibung

Source-Code der 125 usek Macro-Funktion (Stromregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_250

ASCII - Kommando | M_250 |
Syntax Senden | M_250 |
Syntax Empfangen | M_250 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 250 usek Macro-Programmes

Beschreibung

Source-Code der 250 usek Macro-Funktion (Drehzahlregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_250p

ASCII - Kommando | M_250p |
Syntax Senden | M_250p |
Syntax Empfangen | M_250p <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 250p usek Macro-Programmes

Beschreibung

Source-Code der 250 usek Macro-Funktion (Lageregler) wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_1000

ASCII - Kommando | M_1000 |
Syntax Senden | M_1000 |
Syntax Empfangen | M_1000 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 1msek Macro-Programmes

Beschreibung

Source-Code der 1msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT 2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_1600

ASCII - Kommando | M_1600 |
Syntax Senden | M_1600 |
Syntax Empfangen | M_1600 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 16 msek Macro-Programmes

Beschreibung

Source-Code der 16 msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_4000

ASCII - Kommando | M_4000 |
Syntax Senden | M_4000 |
Syntax Empfangen | M_4000 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des 4 msek Macro-Programmes

Beschreibung

Source-Code der 4 msek Macro-Funktion wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_DISABLE

ASCII - Kommando | M_DISABLE |
Syntax Senden | M_DISABLE |
Syntax Empfangen | M_DISABLE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des Disable Macro-Programmes

Beschreibung

Source-Code der Disable-Macro-Funktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim disablen des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_ENABLE

ASCII - Kommando | M_ENABLE |
Syntax Senden | M_ENABLE |
Syntax Empfangen | M_ENABLE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Listing des Enable Macro-Programmes

Beschreibung

Source-Code der Enable-Macro-Funktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim enablen des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_INIT

ASCII - Kommando | M_INIT |
Syntax Senden | M_INIT |
Syntax Empfangen | M_INIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing der Macro-Initialisierungsfunktion

Beschreibung

Source-Code der Macro-Initialisierungsfunktion wird auf dem Bildschirm ausgegeben. Sie wird nur einmal beim Hochfahren des Verstärkers durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_IRQ

ASCII - Kommando | M_IRQ |
Syntax Senden | M_IRQ |
Syntax Empfangen | M_IRQ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing der Macro-Interruptfunktion

Beschreibung

Source-Code der Macro-Interruptfunktion wird auf dem Bildschirm ausgegeben. Sie wird beim Aufruf eines Makro-Interrupts durchlaufen. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_RESET

ASCII - Kommando | M_RESET |
Syntax Senden | M_RESET |
Syntax Empfangen | M_RESET | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35A9 (hex)
DIM | - | PROFIBUS PNU | 1769 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 169 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disable | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Neuübersetzung der Macro-Programme

Beschreibung

Alle Macro-Programme werden beim Einschalten des Verstärkers übersetzt (compiliert) und gestartet. Die Übersetzung der Macro-Programme wird durch s.g. Konfigurationsvariablen gesteuert. Die Werte dieser Konfigurationsvariablen müssen bereits vor dem Start des Übersetzungsvorganges feststehen. Falls der Wert einer Konfigurationsvariable zu einem späteren Zeitpunkt verändert wird, so wirkt sich diese Änderung erst bei der nächsten Überstzung der Macro-Programme aus. Das bedeutet, daß nach einer Änderung einer Konfigurationsvariable, diese Änderung zunächst im EEPROM abgespeichert (SAVE Kommando) und der Verstärker aus- und eingeschaltet werden muß.
Eine Alternative bietet das Kommando M_RESET. Mit diesem Kommando wird eine Neu-Übersetzung der Makro-Programme erzwungen, ohne daß der Verstärker aus- und eingeschaltet werden muß. Da diese Funktion, im Gegensatz zu der Initialisierungsphase, bei freigeschalteten Interrupts ausgeführt wird, beträgt ihre Ausführungszeit entsprechend länger (ca. 5 Minuten).


ASCII Deutsch M_SMACRO

ASCII - Kommando | M_SMACRO |
Syntax Senden | M_SMACRO [*] |
Syntax Empfangen | M_SMACRO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Anzeige der verfügbaren System-Macros

Beschreibung

Eine Aufstellung aller verfügbaren System-Macros wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.
Eine Bildschirmzeile hat folgendes Format: NAME (Parameter) Info
NAME - Name des Macros
(Parameter) - Macro-Übergabeparameter
Info - Macro-Kurzbeschreibung

Das Kommando M_SMACRO * liefert für jedes Macro eine Zusatzzeile, in der die Formate der Übergabeparameter angegeben sind. Es gelten folgende Abkürzungen:
f - fast: der Parameter ist eine Variable, die in dem schnellen Prozessor-RAM liegen muß.
G - global: der Parameter ist eine Variable im schnellen oder langsamen RAM
v - variable: der Parameter ist eine Variable
c- konstante: der Parameter ist eine Konstante (Zahl)
b - Byte: 8-Bit Parameter
w - Word: 16-Bit Parameter
l - Long: 32-Bit Parameter


ASCII Deutsch M_TASK

ASCII - Kommando | M_TASK |
Syntax Senden | M_TASK |
Syntax Empfangen | M_TASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Listing des Macro-Hauptprogrammes

Beschreibung

Source-Code des Macro-Hauptprogrammes wird auf dem Bildschirm ausgegeben. Dieser Programmteil wird immer durchlaufen, wenn keine andere Routine durchlaufen wird (Idle). Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.


ASCII Deutsch M_UMACRO

ASCII - Kommando | M_UMACRO |
Syntax Senden | M_UMACRO [*] |
Syntax Empfangen | M_UMACRO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Anzeige der verfügbaren User-Macros

Beschreibung

Eine Aufstellung aller verfügbaren User-Macros wird auf dem Bildschirm ausgegeben. Bei Einstellung "PROMPT=2" erfolgt die Ausgabe seitenweise. Ein Tastedruck bewirkt die Ausgabe der nächsten Bildschirmseite, mit <ESC> kann die Ausgabe abgebrochen werden.
Ausgabeformat kann der Beschreibung M_SMACRO entnommen werden.

Anmerkung:
Da zur Zeit ausschließlich SYSTEM-Macros verwendet werden, wird eine leere User-Macro-Liste ausgegeben.


ASCII Deutsch MAXSDO

ASCII - Kommando | MAXSDO |
Syntax Senden | MAXSDO |
Syntax Empfangen | MAXSDO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3500 (hex)
DIM | - | PROFIBUS PNU | 1600 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 0 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | -
Kurzbeschreibung | Anzahl der Objekte im Parameterkanal

Beschreibung

Das Kommando MAXSDO liefert die Anzahl der Objekte für das Objekt-Parametrierkanal.


ASCII Deutsch MAXTEMPE

ASCII - Kommando | MAXTEMPE |
Syntax Senden | MAXTEMPE [Data] |
Syntax Empfangen | MAXTEMPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3584 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1732 (dec) IND = 0000xxxx (bin)
Bereich | 10 .. 80 | DPR | 132 (dec)
Default | 70 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Umgebungstemperatur

Beschreibung

Abschaltwert der Umgebungstemperatur. Wenn TEMPE den Schwellwert erreicht, wird ein Fehler ausgelöst.


ASCII Deutsch MAXTEMPH

ASCII - Kommando | MAXTEMPH |
Syntax Senden | MAXTEMPH [Data] |
Syntax Empfangen | MAXTEMPH <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3585 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1733 (dec) IND = 0000xxxx (bin)
Bereich | 20 .. 85 (90 ;SR640,SR670) | DPR | 133 (dec)
Default | 80 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Kühlkörpertemperatur

Beschreibung

Abschaltwert der Kühlkörpertemperatur. Wenn die Kühlkörpertemperatur (TEMPH) diesen Wert überschreitet, so wird im Verstärker ein Fehler ausgelöst.


ASCII Deutsch MAXTEMPM

ASCII - Kommando | MAXTEMPM |
Syntax Senden | MAXTEMPM [Data] |
Syntax Empfangen | MAXTEMPM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3586 (hex)
DIM | Ohm (KOhm) | PROFIBUS PNU | 1734 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 6000.0 | DPR | 134 (dec)
Default | 291 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Abschaltwert der Motortemperatur (Widerstand)

Beschreibung

Abschaltwert der Motortemperatur (Widerstand in kOhm)

Eingabe in Kohm bis 1.5, 1.5 entspricht 1500 Ohm real


ASCII Deutsch MBRAKE

ASCII - Kommando | MBRAKE |
Syntax Senden | MBRAKE [Data] |
Syntax Empfangen | MBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3587 (hex)
DIM | - | PROFIBUS PNU | 1735 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 135 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Vorwahl für Motorbremse

Beschreibung

Vorwahl für Motorbremse
Wenn die Motorbremse angewählt wurde, ändert sich das Disable-Verhalten des Gerätes.

MBRAKE = 0 Haltebremsenfunktion ist abgeschaltet
MBRAKE = 1 Haltebremsenfunktion ist aktiviert. Beim Enablen des Verstärkers wird die Bremse gelüftet. Beim Disablen des Verstärkers fällt die Bremse nach dem Stoppen der Achse wieder ein.
MBRAKE = 2 Beim Wake&Shake - Modus (FBTYPE = 7 oder 8) wird die Bremse nicht gelüftet, bis der Wake&shake-Modus abgeschlossen ist.


ASCII Deutsch MDBCNT

ASCII - Kommando | MDBCNT |
Syntax Senden | MDBCNT |
Syntax Empfangen | MDBCNT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3588 (hex)
DIM | - | PROFIBUS PNU | 1736 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 127 | DPR | 136 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Anzahl der Motorsätze

Beschreibung

Das Kommando MDBCNT liefert die Anzahl der Motordatensätze die für die vorhandene Endstufe/Feedback-Kombination geladen werden können. Durch Änderung der Feedback-Einstellung FBTYPE kann erreicht werden, daß z.B. nur die Datensätze für Resolver-, bzw. Endat-Motoren berücksichtigt werden.


ASCII Deutsch MDBGET

ASCII - Kommando | MDBGET |
Syntax Senden | MDBGET |
Syntax Empfangen | MDBGET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3589 (hex)
DIM | - | PROFIBUS PNU | 1737 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. MDBCNT | DPR | 137 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Info-Zeile für einen Motordatensatz

Beschreibung

Das Kommando MDBGET liefert eine Informationszeile (Directory-Eintrag) für den zuletzt mit dem MDBSET-Kommando angewählten Motordatensatz. Die Informationszeile besteht aus folgenden Komponenten:
Datensatznummer, Motorname, Motornummer, Motorfamilie
Die einzelnen Komponenten haben folgende Bedeutung:
Datensatznummer: Nummer des Motordatensatzes innerhalb der Motordatenbank. Über diese Nummer kann ein Motordatensatz mit dem Kommando MDBSET adressiert werden. Mit jedem MDBGET-Aufruf wird diese Nummer automatisch erhöht.
Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)
Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER-Kommando aus der Motordatenbank zu laden.
Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)

Die Kommando-Gruppe MDBCNT,MDBSET,MDBGET kann von einer externen Steuerung benutzt werden, um das Inhaltsverzeichnis der Motordatenbank einzulesen. Die Vorgehensweise sit wie folgt:
1. Mit dem "MDBCNT"-Kommando die Anzahl der verfügbaren Datensätze einlesen.
2. Mit dem "MDBSET 1"-Kommando den Datensatzzeiger auf den ersten Datensatz setzen.
3. Mit dem "MDBGET"-Kommando den ersten Direcory-Eintrag einlesen.
4. Schritt 3 wiederholen bis die Anzahl der verfügbaren Datensätze (MDBCNT) eingelesen wurde.

Eine Alternative bietet das Kommando MDBLIST. Mit diesem Kommando kann das gesamte Inhaltsverzeichnis angezeigt werden.


ASCII Deutsch MDBLIST

ASCII - Kommando | MDBLIST |
Syntax Senden | MDBLIST [*] |
Syntax Empfangen | MDBLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Nein
Kurzbeschreibung | Inhaltsverzeichnis der Motordatenbank

Beschreibung

Mit dem Kommando MDBLIST kann das Inhaltsverzeichnis der Motordatenbank (für die vorhandene Endstufe/Feedback-Kombination) ausgegeben werden. Pro Bildschirmzeile wird ein Motordatenbank-Eintrag im folgenden Format angezeigt:
Motorname, Motornummer, Motorfamilie, Verstärkerbezeichnung

Die einzelnen Komponenten haben folgende Bedeutung:
Motorname: eine symbolische Motorbezeichnung (max. 12 Zeichen lang)
Motornummer: eine Nummer, über die ein bestimmter Motor eindeutig identifiziert werden kann. Diese Nummer wird verwendet, um einen Datansatz mit dem MNUMBER-Kommando aus der Motordatenbank zu laden.
Motorfamilie: eine Zusatzbezeichnung (nur für internen Gebrauch)

Bei Einstellung "PROMPT 2" erfolgt eine formatierte Ausgabe, die besonders für die Terminaldarstellung geeignet ist.

Mit dem Kommando "MDBLIST *" kann das gesamte Inhaltsverzeichnis der Motordatenbank ausgegeben werden. Im Gegensatz zu der MDBLIST-Ausgabe erscheinen in dem Inhaltsverzeichnis auch Motordatensätze die für die aktuelle Endstufe/Feedback-Kombination nicht geeignet sind. Diese Datensätze werden zwar angezeigt, sie können aber nicht geladen werden.
Im Vergleich zu der "MDBLIST"-Ausgabe wurde die "MDBLIST *"-Ausgabe um die Spalten "Verstärkerbezeichnung" und "Feedback" erweitert. Anhand dieser Bezeichnungen kann erkannt werden, für welche Endstufe/FBTYPE-Einstellung dieser Datensatz erstellt wurde.
Verstärkerbezeichnung: (3xx, wobei xx=Stromstärke).
Feedback: 0=Resolver, 2=Hiperface, 4=Endat


ASCII Deutsch MDBSET

ASCII - Kommando | MDBSET |
Syntax Senden | MDBSET [Data] |
Syntax Empfangen | MDBSET <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 358A (hex)
DIM | - | PROFIBUS PNU | 1738 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. MDBCNT | DPR | 138 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Vorwahl eines Motordatensatzes

Beschreibung

Mit dem MDBSET-Kommando kann ein bestimmter Datensatz aus der Motordatenbank adressiert werden. Das anschliessende MDBGET-Kommando liefert den Directory-Eintrag für den angewählten Motordatensatz. S. Beschreibung MDBGET.


ASCII Deutsch MDUMP

ASCII - Kommando | MDUMP |
Syntax Senden | MDUMP |
Syntax Empfangen | MDUMP <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 358B (hex)
DIM | - | PROFIBUS PNU | 1739 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 139 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | -
Kurzbeschreibung | Anzeige der aktuellen Motorparameter

Beschreibung

Auflistung der aktuellen Motorparameter


ASCII Deutsch MH

ASCII - Kommando | MH |
Syntax Senden | MH |
Syntax Empfangen | MH | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 358D (hex)
DIM | - | PROFIBUS PNU | 1741 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 141 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Start der Referenzfahrt

Beschreibung

Mit dem MH-Kommando (move home) kann über die serielle Schnittstelle eine Referenzfahrt gestartet werden. Die Referenzfahrt-Art, Richtung und Geschwindigkeit werden den Parametern NREF,DREF und VREF entnommen.
Siehe auch SETREF besonders für OPMODE 1...6.


ASCII Deutsch MI2T

ASCII - Kommando | MI2T |
Syntax Senden | MI2T [Data] |
Syntax Empfangen | MI2T <Data> | Vorhanden in |
Type | ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM | % | PROFIBUS PNU | Nein
Bereich | 0 ... 100 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe |  | EEPROM | Nein
Kurzbeschreibung | Motor I2T Auslastung

Beschreibung

Gibt die durchschnittliche I2T Belastung des Motors in % von MICONT wieder. Dieser Durchschnittswert ist gefiltert mit der Zeitkonstanten MTIME.


ASCII Deutsch MICONT

ASCII - Kommando | MICONT |
Syntax Senden | MICONT [Data] |
Syntax Empfangen | MICONT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358E (hex)
DIM | Amperes | PROFIBUS PNU | 1742 (dec) IND = 0000xxxx (bin)
Bereich | 10% of DICONT, .. 2* DICONT | DPR | 142 (dec)
Default | DICONT |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Nennstrom

Beschreibung

Dieser Parameter begrenzt den Nennstrom des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MIMR

ASCII - Kommando | MIMR |
Syntax Senden | MIMR [Data] |
Syntax Empfangen | MIMR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366B (hex)
DIM | A | PROFIBUS PNU | 1963 (dec) IND = 0000xxxx (bin)
Bereich | (0.0 ... 0.8) * ICONT | DPR | 363 (dec)
Default | 0.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Magnetisierungsstrom (Asynchronmotor)

Beschreibung

IN VORBEREITUNG !

Dieses Objekt ist nur bei Einstellung MTYPE=3 (Asynchronmotor) aktiv.
MIMR definiert den Magnetisierungsstrom des Asynchronmotors, welcher normalerweise auf 40% - 50% des Dauerstroms des Motors gesetzt wird.
Unterhalb der Nenndrehzahl des Motors bleibt der Magnetisierungsstrom konstant. Wenn der Motor oberhalb der Nenndrehzahl betrieben wird, so wird der Strom entsprechend der Motordrehzahl verkleinert (Feldschwächung).

Bei dem sensorlosen Synchronmotor (MTYPE=2, FBTYPE=10), definiert dieser Parameter den Strom bei kleinen Drehzahlen. Da in diesem Bereich das Maschinenmodell noch nicht funktioniert, wird der Motor hier wie ein Schrittmotor betrieben.


ASCII Deutsch MIPEAK

ASCII - Kommando | MIPEAK |
Syntax Senden | MIPEAK [Data] |
Syntax Empfangen | MIPEAK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 358F (hex)
DIM | Amperes | PROFIBUS PNU | 1743 (dec) IND = 0000xxxx (bin)
Bereich | 10% of DIPEAK, .. 2*DIPEAK | DPR | 143 (dec)
Default | DIPEAK |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Spitzenstrom

Beschreibung

Dieser Parameter begrenzt die IPEAK-Einstellung des Verstärkers in Abhängigkeit vom max. Motordauerstrom.


ASCII Deutsch MJ

ASCII - Kommando | MJ |
Syntax Senden | MJ [Data] |
Syntax Empfangen | MJ <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | kgcm^2 | PROFIBUS PNU | Nein
Bereich | 0.01 ... 3000 | DPR | Nein
Default | 3 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Massenträgheitsmoment des Motors

Beschreibung

Massenträgheitsmoment des Motors


ASCII Deutsch MJOG

ASCII - Kommando | MJOG |
Syntax Senden | MJOG |
Syntax Empfangen | MJOG | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 3591 (hex)
DIM | - | PROFIBUS PNU | 1745 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 145 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Start des Tippbetriebes

Beschreibung

Mit dem MJOG-Kommando kann über die serielle Schnittstelle der Tippbetrieb gestartet werden. Die Tippbetrieb-Geschwindigkeit wird dem Parameter VJOG entnommen (vorzeichenbehaftet).
Der Tippbetrieb kann gefahren werden, ohne vorher eine Referenzfahrt duchführen zu müssen. Die Hardware-Endschalter werden ausgewertet. Die Software-Endschalter werden ausgewertet, wenn der Referenzpunkt gesetzt ist, sonst nicht. Als Rampen werden ebenfalls die Rampen der Referenzfahrt benutzt (ACCR, DECR, VJOG).


ASCII Deutsch MKT

ASCII - Kommando | MKT |
Syntax Senden | MKT [Data] |
Syntax Empfangen | MKT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3593 (hex)
DIM | - | PROFIBUS PNU | 1747 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 10.0 | DPR | 147 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor KT

Beschreibung

Die Drehmomentkonstante des Motors in Nm/A.

Dieser Parameter wird bei sensorlosen Antrieben benutzt. Diese Variabele kann online kontrolliert werden über die Gleichung:

Kt = 60 * SQRT(3) * Ui / ( 2 * PI * n)

Ui Induzierte Spannung des Motors
n Aktuelle Drehzahl des Motors


ASCII Deutsch ML

ASCII - Kommando | ML |
Syntax Senden | L [Data] |
Syntax Empfangen | ML <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3577 (hex)
DIM | mH | PROFIBUS PNU | 1719 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 119 (dec)
Default | 10 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Statorinduktivität des Motors

Beschreibung

Statorinduktivität Phase-Phase in mH.


ASCII Deutsch MLGC

ASCII - Kommando | MLGC |
Syntax Senden | MLGC [Data] |
Syntax Empfangen | MLGC <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3595 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1749 (dec) IND = 0000xxxx (bin)
Bereich | 0.2 .. 1.0 | DPR | 149 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Dauerstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGC gibt die relative Verstärkung bezogen auf MLGQ bei Dauerstrom an.

MLGC = 0.8 bedeutet, dass die Verstärkung des Stromreglers bei Dauerstrom 80% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = 0 auf Strom = MICONT.


ASCII Deutsch MLGD

ASCII - Kommando | MLGD |
Syntax Senden | MLGD [Data] |
Syntax Empfangen | MLGD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3596 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1750 (dec) IND = 0000xxxx (bin)
Bereich | 0.4 .. 1.0 | DPR | 150 (dec)
Default | 0.7 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung des D-Stromreglers

Beschreibung

Der D-Anteil des Stromregler (feldbildende Komponente). Der Parameter MLGD gibt die relative Verstärkung bezogen auf MLGQ an.

MLGD = 0.6 bedeutet, dass die Verstärkung des D-Stromreglers 60% von MLGQ beträgt.


ASCII Deutsch MLGP

ASCII - Kommando | MLGP |
Syntax Senden | MLGP [Data] |
Syntax Empfangen | MLGP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3597 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1751 (dec) IND = 0000xxxx (bin)
Bereich | 0.1 .. 1.0 | DPR | 151 (dec)
Default | 0.4 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Relative Stromreglerverstärkung bei Spitzenstrom

Beschreibung

Der Stromregler enthält eine adaptive Änderung der Verstärkung in Abhängigkeit des Stromes. Der Parameter MLGP gibt die relative Verstärkung bezogen auf MLGQ bei Spitzenstrom an.

MLGP = 0.6 bedeutet, dass die Verstärkung des Stromreglers bei Spitzenstrom 60% von MLGQ beträgt. Es erfolgt eine lineare Interpolation der Verstärkung von Strom = MICONT auf Strom = MIPEAK.


ASCII Deutsch MLGQ

ASCII - Kommando | MLGQ |
Syntax Senden | MLGQ [Data] |
Syntax Empfangen | MLGQ <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3598 (hex)
DIM | - | PROFIBUS PNU | 1752 (dec) IND = 0000xxxx (bin)
Bereich | 0.01 .. 15.0 | DPR | 152 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Absolute Verstärkung des Stromreglers

Beschreibung

MLGQ gibt die proportionale Verstärkung des Stromreglers an. Beeinflusst auch MLGC, MLGP und MLGD KTN.Anders als beim SR 600 ist die Dimension jetzt V/A. Die Umrechnung erfolgt Verstärkerabhängig:
MLGQ = MLGQ[SR600] * 480 V / DIPEAK[in A].
Beim SR 601 beträgt DIPEAK 3A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 3A = 160 V/A
Beim SR 603 beträgt DIPEAK 6A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 6A = 80 V/A
Beim SR 606 beträgt DIPEAK 12A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 12A = 40 V/A
Beim SR 610 beträgt DIPEAK 20A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 20A = 24 V/A
Beim SR 610-30 / 614 / 620 beträgt DIPEAK 40A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 40A = 12 V/A
Beim SR 640 beträgt DIPEAK 80A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 80A = 6 V/A
Beim SR 670 beträgt DIPEAK 160A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 160A = 3 V/A
Beim SR 403 beträgt DIPEAK 9A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 9A = 53 V/A
Beim SR 406 beträgt DIPEAK 12A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 12A = 40 V/A
Ein Schätzwert für MLGQ ist 7.5 * L[in H]
Zum Betreiben eines 10 mH Motors sollte MLGQ ca. 0.075 V/A betragen.


ASCII Deutsch MNAME

ASCII - Kommando | MNAME |
Syntax Senden | MNAME [Data] |
Syntax Empfangen | MNAME <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 12 ASCII Characters | DPR | Nein
Default | Blanks |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor-Name

Beschreibung

Der Parameter MNAME steht im direkten Zusammenhang mit der Motornummer MNUMBER.
Beim Ladden eines Motordatensatzes aus der Motordatenbank (Kommando MNUMBER), wird
auch die Motorbezeichnung MNAME übernommen. Falls eine kundenspezifische Motorbezeichnung vergeben werden soll, so kann dies mit dem Kommando MNAME geschehen.
Bei Änderung des Motornamens wird die Motornummer (MNUMBER) auf 0 gesetzt (als Kennzeichen für den kundenspezifischen Motordatensatz).


ASCII Deutsch MNUMBER

ASCII - Kommando | MNUMBER |
Syntax Senden | MNUMBER [Data] |
Syntax Empfangen | MNUMBER <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3599 (hex)
DIM | - | PROFIBUS PNU | 1753 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 153 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Laden eines Motor-Datensatzes

Beschreibung

Mit dem Kommando "MNUMBER nr" wird ein Motordatensatz (mit der Motornummer nr) aus der Motordatenbank geladen. Bei Vorgabe von "MNUMBER 0" wird kein Datensatz geladen sondern lediglich die Variable MNUMBER auf 0 gesetzt. Diese Einstellung bedeutet einen kundenspezifischen Motor-Datensatz.


ASCII Deutsch MOVE

ASCII - Kommando | MOVE |
Syntax Senden | MOVE [Data] |
Syntax Empfangen | MOVE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3642 (hex)
DIM | - | PROFIBUS PNU | 1922 (dec) IND = 0000xxxx (bin)
Bereich | 0,1,..,180,192 .. 255 | DPR | 322 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Starten eines Fahrsatzes

Beschreibung

Das Kommando "MOVE nr" startet den Fahrsatz "nr" aus dem Fahrsatzspeicher.
Falls das Kommando ohne Parameter benutzt wird, so wird die zuletzt gestartete Fahrsatznummer angezeigt.


ASCII Deutsch MPHASE

ASCII - Kommando | MPHASE |
Syntax Senden | MPHASE [Data] |
Syntax Empfangen | MPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 359C (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1756 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 360 | DPR | 156 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Phasenlage des Feedback-Systems zum Motor

Beschreibung

Der Parameter Motorphase wird je nach eingesetzter Rückführeinheit (FBTYPE) unterschiedlich gehandhabt.
FBTYPE=0 Resolver
MPHASE wird im seriellen EEPROM des Verstärkers gespeichert (Kommando SAVE) und nach jedem Einschalten des Verstärkers übernommen.

FBTYPE=2,4 Hiperface/Endat
MPHASE wird im EEPROM des Gebers abgelegt (Kommando HSAVE) und nach jedem Einschalten des Verstärkers aus dem Geber eingelesen. Beim Tausch eines Gebers wandert die MPHASE-Einstellung mit dem Geber mit. Beim Einsatz eines neuen Gebers muß der MPHASE-Wert neu ermittelt und in dem Geber abgespeichert werden (HSAVE Kommando).

FBTYPE=7 sinus/cosinus-Geber ohne internes EEPROM
MPHASE wird beim ersten Freigeben der Endstufe automatisch ermittelt (Wake & Shake)
Es gibt keine Notwendigkeit den MPHASE-Wert zu ermitteln bzw. abzuspeichern.


ASCII Deutsch MPOLES

ASCII - Kommando | MPOLES |
Syntax Senden | MPOLES [Data] |
Syntax Empfangen | MPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 359D (hex)
DIM | Poles | PROFIBUS PNU | 1757 (dec) IND = 0000xxxx (bin)
Bereich | 0, 2, 4, 6, .. , 256 | DPR | 157 (dec)
Default | 6 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Anzahl der Motorpole

Beschreibung

Anzahl der Motorpole pro Umdrehung des Motors. MPOLES = 0 wird nicht mehr im Regler gespeichert und auch nicht bei der MMI angezeigt.


ASCII Deutsch MRESBW

ASCII - Kommando | MRESBW |
Syntax Senden | MRESBW [Data] |
Syntax Empfangen | MRESBW <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A0 (hex)
DIM | Hz | PROFIBUS PNU | 1760 (dec) IND = 0000xxxx (bin)
Bereich | 25 .. 1200 | DPR | 160 (dec)
Default | 600 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Resolver-Bandbreite

Beschreibung

MRESBW ist ein Parameter des Luenberger Beobachters und bestimmt die Bandbreite in Hz (Resolver Digital Konverter). Ein hoher Wert (>800 Hz) ergibt ein schnelles (geringe Phasenverschiebung) durch Rauschen gestörtes Signal. Ein niedriger Wert (< 400 Hz) resultiert in einem langsameren (höhere Phasenverschiebung) aber weniger gestörtem Signal. Der Standardwert von 600 Hz ist ein Kompromiß zwischen Störungen und Phasenverschiebung.
Für sensorlose Antriebe wird der Luenberger Beobachter als adaptiver Controller benutzt. MRESBW ist dann die Bandbreite des adaptiven Controllers. Werte sollten dann zwischen 25 und 100 Hz liegen.


ASCII Deutsch MRESPOLES

ASCII - Kommando | MRESPOLES |
Syntax Senden | MRESPOLES [Data] |
Syntax Empfangen | MRESPOLES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A1 (hex)
DIM | - | PROFIBUS PNU | 1761 (dec) IND = 0000xxxx (bin)
Bereich | 2, 4, .. 32 | DPR | 161 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Anzahl der Resolverpole

Beschreibung

Anzahl der Resolverpole (Multispeed-Resolver) pro Umdrehung.


ASCII Deutsch MRS

ASCII - Kommando | MRS |
Syntax Senden | MRS [Data] |
Syntax Empfangen | MRS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3686 (hex)
DIM | Ohm | PROFIBUS PNU | 1990 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 100 | DPR | 390 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Wicklungswiderstand des Stators Phase-Phase

Beschreibung

Wicklungswiderstand des Stators Phase-Phase in Ohm.


ASCII Deutsch MSERIALNO

ASCII - Kommando | MSERIALNO |
Syntax Senden | MSERIALNO [Data] |
Syntax Empfangen | MSERIALNO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36A3 (hex)
DIM | - | PROFIBUS PNU | 2019 (dec) IND = 0000xxxx (bin)
Bereich | Long Int | DPR | 419 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Nein
Kurzbeschreibung | Motorseriennummer bei Encoder mit Parameterkanal

Beschreibung

Mit dem Kommando MSERIALNO kann die Motor-Seriennummer eingegeben werden.
Wird anschließend das Kommando HSAVE eingegeben, so wird diese Nummer in dem seriellen EEPROM des SinCos-Gebers abgespeichert.
Über MSERIALNO kann auch die Seriennummer eines angeschlossenen Motors ausgelesen werden.
Das Kommando MSERIALNO kann nur bei angeschlossenem SinCos-Geber mit Parameterkanal (EnDat oder Hiperface) benutzt werden.


ASCII Deutsch MSG

ASCII - Kommando | MSG |
Syntax Senden | MSG [Data] |
Syntax Empfangen | MSG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35A2 (hex)
DIM | - | PROFIBUS PNU | 1762 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 162 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | RS232-Ausgabe der Warnungen/Fehlermeldungen

Beschreibung

Bei der Einstellung "MSG 2" wird beim Einschalten des Verstärkers (Initialisierungsphase) die Ausführung der einzelnen Initialisierungsschritte über die serielle Schnittstelle gemeldet. Diese Einstellung sollte nur zu Testzwecken (Inbetriebnahmephase) vorgenommen werden. Da das PC-Bedienprogramm grundsätzlich mit der Einstellung "MSG 1" arbeitet, kann die Einstellung "MSG 2"
nur mit Hilfe eines Terminalprogrammes vorgenommen werden (nicht im Terminalfenster des Bedienprogrammes).


ASCII Deutsch MSLBRAKE

ASCII - Kommando | MSLBRAKE |
Syntax Senden | MSLBRAKE [Data] |
Syntax Empfangen | MSLBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3671 (hex)
DIM | - | PROFIBUS PNU | 1969 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32 | DPR | 369 (dec)
Default | 8 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsrampe bei sensorlosem Nothalt

Beschreibung

Bei Ausfall einer Feedback-Einheit (Fehler F04, F08, F25) ist es nicht mehr möglich den Antrieb über die Drehzahlregelung anzuhalten (mit einer definierten Rampe).
In diesem Fall wird versucht über die Stromregelung den Antrieb zum Stillstand zu bringen. Die Drehzahlrampe die sich bei dieser Nothalt-Situation ergibt, hängt von mechanischen Gegebenheiten (Last, Reibung) ab.
Mit dem Kommando MSLBRAKE (Motor sensorles brake) kann die Steigung dieser Rampe
in bestimmten Grenzen beeinflußt werden (je kleiner der Faktor um so länger die Bremsphase).


ASCII Deutsch MSPEED

ASCII - Kommando | MSPEED |
Syntax Senden | MSPEED [Data] |
Syntax Empfangen | MSPEED <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35A3 (hex)
DIM | rpm | PROFIBUS PNU | 1763 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 12000.0 | DPR | 163 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Motor Maximaldrehzahl

Beschreibung

Die Einstellung MSPEED stellt die obere Grenze für folgende Verstärkerparameter: VLIM, VLIMN,
5/6 * VOSPD.
Einzelheiten sind beim Parameter ACCUNIT erklärt.


ASCII Deutsch MTANGLP

ASCII - Kommando | MTANGLP |
Syntax Senden | MTANGLP [Data] |
Syntax Empfangen | MTANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A5 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1765 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 165 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Stromvoreilung

Beschreibung

Stromabhängige Phasenvoreilung zur Ausnutzung des Reluktanz-Drehmomentes.


ASCII Deutsch MTIME

ASCII - Kommando | MTIME |
Syntax Senden | MTIME [Data] |
Syntax Empfangen | MTIME <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | s | PROFIBUS PNU | Nein
Bereich |  | DPR | Nein
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Thermische Zeitkonstante des Motors

Beschreibung

Thermische Zeitkonstante des Motors zu Berechnung von MI2T mit MICONT


ASCII Deutsch MTMUX

ASCII - Kommando | MTMUX |
Syntax Senden | MTMUX [Data] |
Syntax Empfangen | MTMUX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 365B (hex)
DIM | - | PROFIBUS PNU | 1947 (dec) IND = 0000xxxx (bin)
Bereich | 0, 192 ... 255 | DPR | 347 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Voreinstellung für zu bearbeitenden Fahrsatz

Beschreibung

Mit dem Kommando MTMUX kann die Nummer eines Fahrsatzes für die Kommandos O_P,O_V,O_C,O_ACC1,O_ACC2,O_DEC1,O_DEC2,O_FT,O_FN vorgegeben werden.
Jedes von diesen Kommandos greift dann direkt auf den eingestellten Fahrsatz zu.

Der Parameter MTMUX darf nur mit der Nummer eines RAM-Fahrsatzes beschrieben werden.

Die Einstellung für MTMUX wird nicht im EEPROM abgespeichert. Beim Einschalten des Verstärkers wird dieser Parameter automatisch auf 0 gesetzt.


ASCII Deutsch MTR

ASCII - Kommando | MTR |
Syntax Senden | MTR [Data] |
Syntax Empfangen | MTR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366C (hex)
DIM | ms | PROFIBUS PNU | 1964 (dec) IND = 0000xxxx (bin)
Bereich | 30 .. 1000 | DPR | 364 (dec)
Default | 200 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Rotorzeitkonstante

Beschreibung

IN VORBEREITUNG !

Dieses Objekt wird nur bei MTYPE=3 (Asynchronmotor) verwendet.
MTR definiert die Rotorzeitkonstante bei Nennlast (Tr = Lh/Rr). Lh ist die magnetisierende Induktivität und Rr der Rotorwiderstand.


ASCII Deutsch MTYPE

ASCII - Kommando | MTYPE |
Syntax Senden | MTYPE [Data] |
Syntax Empfangen | MTYPE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35A6 (hex)
DIM | - | PROFIBUS PNU | 1766 (dec) IND = 0000xxxx (bin)
Bereich | 1, 2, 3 | DPR | 166 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Art des Motors

Beschreibung

Über MTYPE wird der Verstärker auf den Motortyp eingestellt. Folgende Motortypen sind definiert:

MTYPE=1 Synchron Servomotor
MTYPE=2 Synchronmotor mit ID Stromregelung (für Linearmotore und sensorloses betreiben der Synchronmotore)
MTYPE=3 Asynchronmotor


ASCII Deutsch MUNIT

ASCII - Kommando | MUNIT |
Syntax Senden | MUNIT [Data] |
Syntax Empfangen | MUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 3674 (hex)
DIM |  | PROFIBUS PNU | 1972 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 372 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Einheit der drehzahlabhängigen Motorparameter

Beschreibung

Mit dem Kommando MUNIT kann die Einheit für alle drehzahlabhängigen Motor-Parameter definiert werden. Dazu gehören Parameter MVANGLP und MSPEED.

MUNIT=0 UPM
MUNIT=1 als Einheit wird die VUNIT-Einstellung übernommen


ASCII Deutsch MVANGLB

ASCII - Kommando | MVANGLB |
Syntax Senden | MVANGLB [Data] |
Syntax Empfangen | MVANGLB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35A7 (hex)
DIM | rpm | PROFIBUS PNU | 1767 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 15000 | DPR | 167 (dec)
Default | 3000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Einsatz Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi (MVANGLF) gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLF.


ASCII Deutsch MVANGLF

ASCII - Kommando | MVANGLF |
Syntax Senden | MVANGLF [Data] |
Syntax Empfangen | MVANGLF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35A8 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1768 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 168 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung (Endwert Phi)

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und Motorspannung läßt sich bei hohen Drehzahlen kompensieren. Bei gegebenen Spannungsverhältnissen wird hierdurch ein höheres Drehmoment bei Enddrehzahl ermöglicht. Wahlweise läßt sich auch die erreichbare Enddrehzahl bis zu 30 % steigern. Abhängig von der Motordrehzahl wird zwischen Einsatz Phi (MVANGLB) und der Enddrehzahl die Phasenverschiebung linear bis zum Endwert Phi gesteigert. Die günstigste Einstellung hängt vom Motortyp und der Enddrehzahl ab.
Siehe auch MVANGLB.


ASCII Deutsch MVANGLP

ASCII - Kommando | MVANGLP |
Syntax Senden | MVANGLP [Data] |
Syntax Empfangen | MVANGLP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3592 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1746 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 60 | DPR | 146 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Drehzahlabhängige Voreilung

Beschreibung

Die induktive Phasenverschiebung zwischen Motorstrom und induzierter Motorspannung wird bei hohen Drehzahlen kompensiert.
Diese kann entweder dazu benutzt werden, um bei gleicher Drehzahl ein größeres Drehmoment zu bekommen oder die Enddrehzahl des Motors um bis zu 30% zu erhöhen.
Die Phasenverschiebung wird linear von "0" bei der Drehzahl MVANGLB bis zu dem in MVANGLF vorgegebenen Winkel bei VLIM verändert.


ASCII Deutsch MVR

ASCII - Kommando | MVR |
Syntax Senden | MVR [Data] |
Syntax Empfangen | MVR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 366D (hex)
DIM | rpm | PROFIBUS PNU | 1965 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 365 (dec)
Default | 6000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Motor | EEPROM | Ja
Kurzbeschreibung | Einsatzdrehzahl der Feldschwächung

Beschreibung

IN VORBEREITUNG !

Im Mode für Asynchronmotore (MTYPE=3), muss der Parameter MVR auf die Nenndrehzahl des Motors gesetzt werden. Dieses ist die Schwelle für den Beginn der Feldschwächung.
Für eine zweipoligen Motor am 50Hz-Netz, muss 3000 UPM eingestellt werden, für eine vierpoligen entsprechend 1500 UPM.

Wenn ein sensorloser Motor betrieben werden soll (MTYPE=2 und FBTYPE=10), gibt MVR den Umschaltpunkt zwischen der Stromvorgabe bei kleinen Drehzahlen und dem Maschinenmodell bei größeren Drehzahlen. Der Wert deses Parameters sollte dann zwischen 10 und 20% der Nenndrehzahl des Motors betragen.

Wenn nur Hall-Geber als Rückführung verwendet werden, so gibt der Parameter MVR die Schaltschwelle zwischen der Drehzahlvorhersage über die sensorlose Erfassungsmethode und der reinen Erfassung über die Hall's an. Die Parameter MKT, MKS und L müssen korrekt eingestellt sein. Außerdem muss MTYPE = 2 gesetzt werden. Wenn MVR = 0, wird die sensorlose Erfassung der Drehzahl abgeschaltet.
Der optimale Wert dieses Parameters hängt von der Anzahl der Motorpole und der Nenndrehzahl ab. Normalerweise liegt MVR zwischen 20 und 30% von VLIM.


ASCII Deutsch NONBTB

ASCII - Kommando | NONBTB |
Syntax Senden | NONBTB [Data] |
Syntax Empfangen | NONBTB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AA (hex)
DIM | - | PROFIBUS PNU | 1770 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 170 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Ja
Kurzbeschreibung | Netz-BTB-Überprüfung ein/aus

Beschreibung

Das Fehlen des Netz-BTB-Signals (Netz ein) führt beim Freigeben der Endstufe zu der Fehlermeldung F16 (Netz-Btb). Falls dieses Verhalten unerwünscht ist, so kann die Überwachung des Netz-BTB-Signals ausgeschaltet werden (NONBTB 1). Diese Funktion kann für eine DC-Einspeisung verwendet werden.
Siehe auch UVLTMODE.


ASCII Deutsch NREF

ASCII - Kommando | NREF |
Syntax Senden | NREF [Data] |
Syntax Empfangen | NREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AD (hex)
DIM | - | PROFIBUS PNU | 1773 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 20 | DPR | 173 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzfahrtart

Beschreibung

Bevor eine Positionierfahrt gestartet werden kann (gilt nur für Linearachse), muß eine Referenzfahrt durchgeführt werden. Der dabei gesetzte Referenzpunkt gilt bis zum nächsten Hardware-Reset des Verstärkers. Der Versuch eine Positionierung zu starten ohne daß ein Referenzpunkt gesetzt wurde, wird mit einer Warnung beantwortet (LED-Anzeige n09).
Vor dem Start einer Referenzfahrt wird der ggf. bereits gesetzte Referenzpunkt gelöscht.

Die möglichen Referenzfahrtarten können der nachfolgenden Tabelle entnommen werden.

Für die Referenzfahrten 1 und 3 muß ein digitaler Eingang als Nullposition-Eingang (Home-Position) konfiguriert werden (INxMODE=12 bzw. I/O-Erweiterungskarte).
Für die Referenzfahrten 2 und 4 muß ein digitaler Eingang als Hardware-Endschalter konfiguriert werden (INxMODE=2 oder 3).

Bei den Referenzfahrten 1..5,7 wird die Einstellung des Nullimpulsoffsets für die ROD-Ausgabe berücksichtigt (ENCZERO) d.h. der Nullpunkt wird so gelegt, daß sowohl die Ausgabe des Nullimpulses als auch die Anzeige der 0-Position bei „Nullimpulsoffset“ erfolgen.

Bei allen Referenzfahrten wird die Einstellung des Referenzoffsets (ROFFS) berücksichtigt. Damit kann dem Nullpunkt ein beliebiger absoluter Positionswert zugeordnet werden.

Wenn ein Multiturngeber als Rückführung eingesetzt wird, so kann auch eine beliebige Referenzfahrt gestartet werden. Nach Beendigung der Referenzfahrt, wird RSOFFS übernommen und die ermittelten Parameter automatisch im EEPROM gespeichert. Damit steht die gefundene Position auch noch nach dem Aus-/Einschalten der 24V - Versorgung zur Verfügung.
Zustand | Kurzbeschreibung | Erweiterte Beschreibung
NREF=0 Setzen des Referenzpunktes Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Der Abstand zwischen der Ist- und Soll-Position (Schleppfehler) geht dabei verloren.
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Ab dieser Position wird die Entfernung zum nächsten Nulldurchgang des Resolvers ermittelt und eine Fahrt zu der Nullposition gestartet.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.
NREF=2 Referenzfahrt auf Endschalter mit Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht bis der Hardware-Endschalter verlassen wurde. Dann wird eine Fahrt zum nächsten Nulldurchgang des Resolvers gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb auf der Position ROFFS.
NREF=3 Referenzfahrt auf Referenzschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF), bis eine steigende Flanke am Referenzeingang erkannt wurde. Dieser Position wird die Position ROFFS zugeordnet und der Antrieb wird angehalten.
Falls beim Starten der Referenzfahrt der Referenzschalter belegt ist (Pegel=High), so wird eine Fahrt in die zu DREF entgegengesetzte Richtung gestartet bis eine fallende Flanke auf dem Referenzeingang erkannt wurde. Anschliessend wird die Referenzfahrt neu gestartet.
Falls während der Ausführung der Referenzfahrt ein Hardware-Endschalter erreicht wird (Start der Referenzfahrt hinter dem Referenzschalter), so wird die Fahrtrichtung gedreht und eine Bewegung gestartet, bis eine steigende und anschliessend fallende Flanke auf dem Referenzeingang erkannt wurde (Fahrt zu einer Position vor dem Referenzschalter).Anschliessend wird eine neue Referenzfahrt gestartet.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zu dem gesetzten Nullpunkt (Referenzschalter) hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=4 Referenzfahrt auf Endschalter ohne Nullpunktsuche Der Antrieb fährt in die vorgegebene Richtung (DREF) bis der entsprechende Hardware-Endschalter erreicht wurde. Anschliessend wird die Fahrtrichtung gedreht und eine Fahrt gestartet, bis der Hardware-Endschalter verlassen wird.
Die Position die der Flanke des Endschalters entspricht wird auf ROFFS gesetzt und der Antrieb wird angehalten.
Nach der Ausführung der Referenzfahrt steht der Antrieb an einer zufälligen Position. Die Entfernung zum Endschalter hängt von der gefahrenen Geschwindigkeit und der Bremsrampe ab.
NREF=5 Referenzfahrt innerhalb einer Umdrehung Der Antrieb fährt bis zum nächsten Nullpunkt des Resolvers. Die Fahrtrichtung wird durch die Variable DREF vorgegeben
DREF=0 negativ
DREF=1 positiv
DREF=2 die Richtung wird je nach Entfernung zum Nullpunkt gewählt (kleinste Entfernung).
NREF=6 Setzen des Referenzpunktes 2 Die aktuelle Position wird zum Nullpunkt erklärt (die Ist-/Soll-Position wird auf ROFFS gesetzt).
Im Gegensatz zu NREF=0 geht der Abstand zwischen der Ist- und Ziel-Position (Schleppfehler) nicht verloren.
NREF=7 Auf Anschlag mit Nullpunktsuche Beim Start der Referenzfahrtart 7 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 7 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 positiv, DREF=1 negativ) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird die Drehrichtung gewechselt und eine Fahrt zum nächsten Nullpunkt des Resolvers gestartet. Der Antrieb bleibt im Nullpunkt stehen.Die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.
NREF=8 | Fahren auf die absolute SSI-Position | Beim Start der Referenzfahrt 8 wird eine 32-Bit SSI-Position über den SSI-Eingang (GEARMODE=7) eingelesen, mit den Skalierungsfaktoren GEARI und GEARO und dem Offsetwert ROFFS2 verrechnet, und als Zielposition für einen Fahrsatz benutzt. Der Fahrsatz wird gestartet und nachdem die Zielposition erreicht wurde, wird die Meldung IN-POSITION ausgegeben.
NREF=9 Fahren auf Anschlag ohne Nullimpulssuche Beim Start der Referenzfahrtart 9 wird der aktuelle Spitzenstrom (IPEAK) auf den Wert REFIP (Spitzenstrom für die Referenzfahrt Nr: 9 in Ampere) gesetzt und eine Fahrt in die vorgegebene Richtung (DREF=0 positiv, DREF=1 negativ) gestartet.
Während der Fahrt wird der Schleppabstand überwacht. Beim Überschreiten eines Grenzwertes (PEMAX / 2, die Hälfte des Schleppfehlerfensters), wird an dieser Stelle die IST- und Sollposition wird auf ROFFS gesetzt. Der Spitzenstrom IPEAK wird auf den Ausgangswert gesetzt.


ASCII Deutsch NREFMT

ASCII - Kommando | NREFMT |
Syntax Senden | NREFMT [Data] |
Syntax Empfangen | NREFMT <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36D2 (hex)
DIM |  | PROFIBUS PNU | 1666 (dec) IND = 0001xxxx (bin)
Bereich | 0 ... 511 | DPR | 466 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM |
Kurzbeschreibung | Referenzfahrt mit automatischem Folgefahrauftrag

Beschreibung

Mit dem Kommando NREFMT kann das automatische Starten eines Fahrsatzes am Ende einer Referenzfahrt aktiviert werden. Der Parameter NREFMT kann als eine Bit-Variable (16 Bit) interpretiert werden:

FEDCBA9876543210
xxxxxxxcnnnnnnnn

Bits 0..7 (nnnnnnnn) beschreiben die Nummer des zu startenden Fahrsatzes
Bei Nummer=0 wird kein Fahrsatz gestartet.

Bit 8 (c) =0 Fahrsatz nn wird gestartet erst nachdem der Stillstand erreicht wurde. In diesem Fall werden die Bits „Referenzfahrt läuft=0“ und „Referenzfahrt beendet=1“ vor dem Start des Fahrsatzes nn gesetzt.

=1 fliegender Start des Fahrsatzes nn. Die Bits „Referenzfahrt läuft=0“ und Referenzfahrt beendet=1“ werden erst nach dem Ende des Fahrsatzes nn gesetzt.


ASCII Deutsch O1

ASCII - Kommando | O1 |
Syntax Senden | O1 [data] |
Syntax Empfangen | O1 | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AE (hex)
DIM | - | PROFIBUS PNU | 1774 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 174 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 1

Beschreibung

Das Kommando O1 liefert den Zustand des digitalen Ausgangs 1 (0=Low,1=High).
Falls der digitale Ausgang 1 keiner Funktion zugeordnet ist (O1MODE=0), so kann mit dem Kommando "O1 1" oder "O1 0" der High/Low-Zustand am Ausgang 1 ausgegeben werden.


ASCII Deutsch O1MODE

ASCII - Kommando | O1MODE |
Syntax Senden | O1MODE [Data] |
Syntax Empfangen | O1MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35AF (hex)
DIM | - | PROFIBUS PNU | 1775 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 175 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 1

Beschreibung

Mit dem Kommando O1MODE kann die Funktion des digitalen Ausgangs OUT1 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O1MODE=0 | keine Funktion | Der Zustand des digitalen Ausgangs OUT1 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt werden.
O1MODE=1 | V < O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG unterschritten wird und Low wenn O1TRIG + 0.01 * MSPEED überschritten wird.
O1MODE=2 | V > O1TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O1TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O1TRIG überschritten wird und Low wenn O1TRIG - 0.01 * MSPEED unterschritten wird.
O1MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf high gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises). O1MODE=3 arbeitet nur mit NONBTB = 0.
O1MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde.
O1MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG).
O1MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O1TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O1MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O1MODE=8 | I<O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=9 | I>O1TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O1TRIG in mA).
O1MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O1MODE=11 | I2T | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM) wird mit einem High-Signal gemeldet.
O1MODE=12 | Positionsregister 1 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 1 wird mit einem High-Signal gemeldet.
O1MODE=13 | Positionsregister 2 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 2 wird mit einem High-Signal gemeldet.
O1MODE=14 | Positionsregister 3 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 3 wird mit einem High-Signal gemeldet.
O1MODE=15 | Positionsregister 4 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 4 wird mit einem High-Signal gemeldet.
O1MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O1MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O1MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird (siehe ERRCODE).
O1MODE=19 | Zwischenkreisspannung > O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=20 | Zwischenkreisspannung < O1TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O1TRIG ist (in Volt).
O1MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der wischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O1MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Ecoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM
O1MODE=23 | DPR-Ausgabe | Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O1MODE=0. Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Digital-Ausgang 1 über Device-Net.
O1MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O1MODE=25 | Reserve |
O1MODE=26 | Reserve |
O1MODE=27 | Reserve |
O1MODE=28 | Positionsregister 0 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 0 wird mit einem High-Signal gemeldet. Nur bei Optionskarte I/O-14/8.
O1MODE=29 | Positionsregister 5 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 5 wird mit einem High-Signal gemeldet. Nur bei Optionskarte I/O-14/8.
O1MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Sobald eine der Positionsmeldungen 0...5 einen High-Zustand hat, wird der Ausgang auf High gesetzt, ansonsten wird der Zustand Low ausgegeben.
O1MODE=31 | SW1< O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=32 | SW1 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=33 | SW2 < O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O1TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=34 | SW2 > O1TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O1TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O1MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O1MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O1MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O1MODE=36 | logisches ODER zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=37 | logisches UND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=38 | logisches ODER zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=39 | logisches UND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=40 | logisches ODER zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=41 | logisches UND zwischen POSRSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=42 | Ausgabe einer Übertemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O1TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE) (ab Firmware 3.41)
O1MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0 Diese Funktion ist ab der Firmware 4.01 verfügbar.
O1MODE=44 | Drehzahl In-Position (High aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert kleiner ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=45 | Drehzahl In-Position (low aktiv) | Der Ausgang OUTPUT1 wird gesetzt, wenn die Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O1TRIG. Die Größe des Velocity-In-Position-Fensters (O1TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben.
O1MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 1 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O1MODE=48 | logisches NOR zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=49 | logisches NAND zwischen DRVSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=50 | logisches NOR zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.
O1MODE=51 | logisches NAND zwischen TRJSTAT und O1TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O1TRIG auf den digitalen Ausgang 1 ausgegeben werden.


ASCII Deutsch O1TRIG

ASCII - Kommando | O1TRIG |
Syntax Senden | O1TRIG [Data] |
Syntax Empfangen | O1TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B0 (hex)
DIM | - | PROFIBUS PNU | 1776 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 176 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O1MODE

Beschreibung

Die Funktion der Hilfsvariable O1TRIG hängt von der Konfiguration O1MODE ab.
s. O1MODE


ASCII Deutsch O2

ASCII - Kommando | O2 |
Syntax Senden | O2 [Data] |
Syntax Empfangen | O2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B1 (hex)
DIM | - | PROFIBUS PNU | 1777 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 177 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Zustand des digitalen Ausgangs 1

Beschreibung

Das Kommando O2 liefert den Zustand des digitalen Ausgangs 2 (0=Low,1=High).
Falls der digitale Ausgang 2 keiner Funktion zugeordnet ist (O2MODE=0), so kann mit dem Kommando "O2 1" oder "O2 0" der High/Low-Zustand am Ausgang 2 ausgegeben werden.


ASCII Deutsch O2MODE

ASCII - Kommando | O2MODE |
Syntax Senden | O2MODE [Data] |
Syntax Empfangen | O2MODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B2 (hex)
DIM | - | PROFIBUS PNU | 1778 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 50 | DPR | 178 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Funktion des digitalen Ausgangs 2

Beschreibung

Mit dem Kommando O2MODE kann die Funktion des digitalen Ausgangs OUT2 konfiguriert werden. Nach der Änderung dieses Parameters muß der Verstärker Aus-/Eingeschaltet werden. Es können folgende Funktionen konfiguriert werden:
Zustand | Funktion | Beschreibung
O2MODE=0 | keine Funktion | Der Zustand des digitalen Ausgangs OUT2 kann über die RS232/Feldbus/Slot-Schnittstelle gesetzt werden.
O2MODE=1 | V < O2TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) unterschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG unterschritten wird und Low wenn O2TRIG + 0.01 * MSPEED überschritten wird.
O2MODE=2 | V > O2TRIG | Der Ausgang wird gesetzt, wenn die Ist-Drehzahl den Wert O2TRIG (in UPM) überschreitet. Die Drehzahlauswertung ist mit einer Hysterese versehen. Der Ausgang wird High wenn O2TRIG überschritten wird und Low wenn O2TRIG - 0.01 * MSPEED unterschritten wird.
O2MODE=3 | NETZ-BTB-Meldung | Der Ausgang wird auf 0 gesetzt, solange das Netz-BTB-Signal ansteht (Netzspannung vorhanden) bzw. solange die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) überschreitet. Die Vorwahl dieser Funktion sperrt gleichzeitig die Fehlerüberwachung für das Netz-BTB. Darüber hinaus wird die Funktion für die Software-Freigabe der Endstufe umgeschaltet. Der Wegfall der NETZ-BTB-Meldung führt nicht automatisch zum Abschalten der Endstufe. Solange die Zwischenkreisspannung die Unterspannungsschwelle nicht unterschreitet bleibt die Endstufe freigegeben. Erst beim Unterschreiten der Unterspannungsschwelle wird die Endstufe gesperrt (Leerpumpen des Zwischenkreises). O2MODE=3 arbeitet nur mit NONBTB = 0.
O2MODE=4 | Ballastwiderstand abgeschaltet | Der Ausgang zeigt den Zustand des internen Ballastwiderstandes an. Bei Low-Pegel ist der Ballastwiderstand zugeschaltet, bei High-Pegel abgeschaltet. Der Ballastwiderstand wird immer dann abgeschaltet, wenn die eingestelle Ballastschwelle PBALMAX überschritten wurde.
O2MODE=5 | Software-Endschalter aktiv | Der Ausgang wird gesetzt, wenn ein Software-Endschalter überfahren wurde (Software-Endschalter 1 unterschritten bzw. Software-Endschalter 2 überschritten). Diese Funktion ist nur dann sinnvoll, wenn wenigstens einer der Software-Endschalter konfiguriert wurde (SWCNFG).
O2MODE=6 | Position überschritten | Der Ausgang wird gesetzt, wenn die Position O2TRIG überschritten wurde. Die Position muss in Lagereglereinheiten (PGEARI / PGEARO) vorgegeben werden.
O2MODE=7 | In-Position aktiv | Das Erreichen der Zielposition (In-Position-Fenster PEINPOS) eines Fahrauftrages wird durch Ausgabe eines "High"-Signals gemeldet. Wenn eine Folge von Fahraufträgen automatisch ausgeführt wird, wird die Meldung für das Erreichen der Endposition der Fahrauftragsfolge ausgegeben (Zielposition des letzten Fahrauftrages).
O2MODE=8 | I<O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes kleiner ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=9 | I > O2TRIG | Ein High-Signal wird ausgegeben, solange der Effektivwert des Iststromes größer ist als ein angegebener Wert (O2TRIG in mA).
O2MODE=10 | kein Schleppfehler | Das Verlassen des eingestellten Schleppfehler-Fensters (PEMAX) wird mit einem Low-Signal gemeldet.
O2MODE=11 | I2t | Das Erreichen der eingestellten I2t-Meldeschwelle (I2TLIM) wird mit einem High-Signal gemeldet.
O2MODE=12 | Positionsregister 1 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 1 wird mit einem High-Signal gemeldet.
O2MODE=13 | Positionsregister 2 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 2 wird mit einem High-Signal gemeldet.
O2MODE=14 | Positionsregister 3 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 3 wird mit einem High-Signal gemeldet.
O2MODE=15 | Positionsregister 4 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 4 wird mit einem High-Signal gemeldet.
O2MODE=16 | Folge-In-Position | Das Erreichen der Zielposition (In-Position-Fenster) jedes Fahrauftrages in einer automatisch ausgeführten Folge von Fahraufträgen wird durch Ausgabe eines Low/High-Signales gemeldet. Der Zeitpunkt und die Art der Meldung kann mit dem Parameter IN2PM konfiguriert werden.
O2MODE=17 | Fehler/Warnung | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) oder eine Warnmeldung (Display nxx) vom Servoverstärker gemeldet wird, siehe ERRCODE.
O2MODE=18 | Fehler | Der Ausgang gibt ein High-Signal aus, wenn ein Fehler (Display Fxx) vom Servoverstärker gemeldet wird, siehe ERRCODE.
O2MODE=19 | Zwischenkreisspannung > O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung größer als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=20 | Zwischenkreisspannung < O2TRIG | Ein High-Signal wird ausgegeben, wenn der Istwert der Zwischenkreisspannung kleiner als ein angegebener Wert O2TRIG ist (in Volt).
O2MODE=21 | Endstufenfreigabe | Ein High-Signal wird ausgegeben, wenn der Servoverstärker freigegeben ist. Der Verstärker ist freigegeben, wenn Software-Freigabe und Hardware-Freigabe gesetzt sind und kein Fehler ansteht (BTB-Kontakt geschlossen). Falls die Funktion NETZ-BTB aktiviert ist (OxMODE=3) wird die Endstufe erst freigegeben, wenn die die Leistungsversorgung eingeschaltet wurde und der wischenkreis geladen ist. Wenn die Zwischenkreisspannung die Unterspannungsschwelle (VBUSMIN) unterschreitet, wird wieder disabled..
O2MODE=22 | Nullimpuls | Der Nullimpuls (High-Signal) der Ecoder-Emulation wird gemeldet. Diese Funktion ist nur bei sehr kleinen Drehzahlen sinnvoll. Vmax = 15000 / ENCOUT z.B. ENCOUT=256 Impulse/Umdrehung Vmax = 58 UPM
O2MODE=23 | DPR-Ausgabe | Bei dieser Konfiguration werden interne Funktionen abgeschaltet und der Zustand einer DPR-Speicherzelle (DPR-Slot-Karte Offset 0x3E4) auf den Ausgang gespiegelt. Falls keine DPR-Slot-Karte vorhanden ist, so entspricht diese Einstellung der Einstellung O2MODE=0. Wenn eine Device-Net Optionskarte verwendet wird, erlaubt diese Einstellung die Ausgabe von Digital-Ausgang 2 über Device-Net.
O2MODE=24 | Referenzpunkt gesetzt | Ein High-Signal wird ausgegeben, wenn der Referenzpunkt gesetzt ist. (s. Referenzfahrt NREF).
O2MODE=25 | Reserve |
O2MODE=26 | Reserve |
O2MODE=27 | Reserve |
O2MODE=28 | Positionsregister 0 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 0 wird mit einem High-Signal gemeldet.
O2MODE=29 | Positionsregister 5 | Die eingestellte Funktion (unterschritten/überschritten) des Positionsregisters 5 wird mit einem High-Signal gemeldet.
O2MODE=30 | ODER-Verknüpfung aller Positionsmeldungen | Sobald eine der Positionsmeldungen 0...5 einen High-Zustand hat, wird der Ausgang auf High gesetzt, ansonsten wird der Zustand Low ausgegeben.
O2MODE=31 | SW1 < O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=32 | SW1 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW1 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=33 | SW2 < O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O2TRIG unterschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=34 | SW2 > O2TRIG | Ein High-Signal wird ausgegeben, wenn die Eingangsspannung SW2 den vorgegebenen Schwellenwert O2TRIG überschreitet. Die Eingabe des Schwellenwertes erfolgt in mV (vorzeichenbehaftet).
O2MODE=35 | internes Enable-Signal | Der Zustand des internes Freigabe-Signals wird auf den digitalen Ausgang gespiegelt. Bei Einstellungen MBRAKE=0, STOPMODE=0, ACTFAULT=0, gleicht diese Funktion der Funktion O2MODE=21. Falls eine der oben genannten Optionen aktiviert ist, geht der Ausgang auf Low sobald der Disable-Vorgang eingeleitet ist (Bremsvorgang auf Drehzahl=0). Bei der Funktion O2MODE=21 geht der Ausgang erst auf Low, wenn die Endstufe tatsächlich gesperrt wird (Drehzahl=0 erreicht).
O2MODE=36 | logisches ODER zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=37 | logisches UND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=38 | logisches ODER zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=39 | logisches UND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=40 | logisches ODER zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer ODER Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=41 | logisches UND zwischen POSRSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer UND Verknuepfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden.
O2MODE=42 | Ausgabe einer Übertemperaturwarnung | Mit Hilfe dieser Funktion kann eine Temperaturwarnung konfiguriert werden. Falls einer der Temperaturwerte die zugehörige Abschaltschwelle überschreitet, so wird zunächst nur der digitale Ausgang OUTPUTx auf High gesetzt. Erst nach Ablauf der eingestellter Vorwarnzeit O2TRIG (msek), wird eine Fehlermeldung generiert und die Endstufe gesperrt. Die Vorwarnzeit kann im Bereich 0....30000 msek eingestellt werden und gilt für folgende Temperaturen: Motortemperatur: TEMPM (Schwelle: MAXTEMPM) Kühlkörpertemperatur. TEMPH (Schwelle: MAXTEMPH) Umgebungstemperatur: TEMPE (Schwelle: MAXTEMPE) (ab Firmware 3.41)
O2MODE=43 | Es wird das Vorzeichen der Ist-Drehzahl ausgegeben. | OUTPUT2 = 1 V < -VEL0 OUTPUT2 = 0 V > -VEL0 Diese Funktion ist ab der Firmware 4.01 verfügbar.
O2MODE=44 | Drehzahl In-Position (High aktiv) | Der Ausgang OUTPUT2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert kleiner ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O2MODE=45 | Drehzahl In-Position (low aktiv) | Der Ausgang OUTPUT2 wird gesetzt, wenn die Differenz zwischen dem internen Drehzahlsollwert und dem Drehzahl-Istwert größer ist als O2TRIG. Die Größe des Velocity-In-Position-Fensters (O2TRIG) wird in den gültigen Velocity-Einheiten (VUNIT) vorgegeben (ab 4.30).
O2MODE=46 | Strom im Sollwertfenster (low aktiv) | Der digitale Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert kleiner ist als O1TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=47 | Strom nicht im Sollwertfenster (low aktiv) | Der digitale Ausgang 2 wird gesetzt, wenn der Betrag der Differenz zwischen dem internen Stromsollwert und dem Strom-Istwert größer ist als O2TRIG. Die Größe des Strom-In-Position-Fensters wird in mA vorgegeben.
O2MODE=48 | logisches NOR zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknüpfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=49 | logisches NAND zwischen DRVSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable DRVSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=50 | logisches NOR zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten ODER Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)
O2MODE=51 | logisches NAND zwischen TRJSTAT und O2TRIG | Mit Hilfe dieser Funktionen kann das Ergebnis einer invertierten UND Verknuepfung zwischen der Bit-Variable TRJSTAT und einer Bitmaske aus der Hilfsvariable O2TRIG auf den digitalen Ausgang 2 ausgegeben werden. (ab 4.92)


ASCII Deutsch O2TRIG

ASCII - Kommando | O2TRIG |
Syntax Senden | O2TRIG [Data] |
Syntax Empfangen | O2TRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 179 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Ja
Kurzbeschreibung | Hilfsvariable für O2MODE

Beschreibung

Die Funktion der Hilfsvariable O2TRIG hängt von der Konfiguration O2MODE ab.
s. O2MODE


ASCII Deutsch O_ACC1

ASCII - Kommando | O_ACC1 |
Syntax Senden | O_ACC1 [Data] |
Syntax Empfangen | O_ACC1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B7 (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1783 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 183 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Beschleunigungszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_ACC1 kann die Beschleunigungsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Beschleunigungszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Beschleunigungszeit wird in msek von 0 auf die Zielgeschwindigkeit O_V vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =_C gleich 1.
Die Beschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Anfahrzeit wird
bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_ACC1 als Anfahrzeit in msek gewertet.


ASCII Deutsch O_C

ASCII - Kommando | O_C |
Syntax Senden | O_C [Data] |
Syntax Empfangen | O_C <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35B9 (hex)
DIM | - | PROFIBUS PNU | 1785 (dec) IND = 0000xxxx (bin)
Bereich | int | DPR | 185 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controler | EEPROM | Nein
Kurzbeschreibung | Steuervariable für den Fahrsatz 0

Beschreibung

Das Kommando O_C definiert die Fahrauftragsart für den lokalen Fahrsatz Nr. 0 (Direktfahrsatz). Als Parameter wird eine Bit-Variable übergeben (16 Bits). Die einzelnen Bits dieser Variable haben folgende Bedeutung:
 | Tabelle 1 |
Bit | Wertigkeit | Bedeutung
0 | 0x0001 | Bit für die Art des relativen/absoluten Fahrsatzes (s. Tabelle 2)
1 | 0x0002 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
2 | 0x0004 | Bit für die Art des relativen Fahrsatzes (s. Tabelle 2)
3 | 0x0008 | =0 kein Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition bleibt der Antrieb stehen =1 Folgefahrsatz vorhanden, nach dem Erreichen der Zielposition wird automatisch der Folgefahrsatz gestartet. Die Nummer des Folgefahrsatze wird mit dem Kommando O_FN vorgegeben.
4 | 0x0010 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
5 | 0x0020 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
6 | 0x0040 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
7 | 0x0080 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
8 | 0x0100 | Bit für die Art des Folgefahrsatzes (s. Tabelle 3)
9 | 0x0200 | =0 Der Fahrsatz wird über den internen Trajektoriengenerator gesteuert =1 Es wird der Tabellenfahrsatz gestartet. Hierzu muss die Tabelle über LOOKUP in den Verstärker eingespielt werden. O_ACC2 gibt die Tabellennummer, die gefahren werden soll, an. Die Summe von O_ACC1 und O_DEC1 geben die Verfahrzeit des Profils an. O_V und O_DEC2 haben keine Bedeutung.
10 | 0x0400 | =0 Das Geschwindigkeitsprofil wird in der definierten Richtung durchlaufen. =1 Das Geschwindigkeitsprofil wird in umgekehrter Richtung durchlaufen.
11 | 0x0800 | reserviert
12 | 0x1000 | =0 die Brems- und Anfahrbeschleunigung wird als Brems-/Anfahrzeit von 0 auf die Zielgeschwindigkeit (in msek) vorgegeben. =1 die Brems- und Anfahrbeschleunigung wird in mm/sek² vorgegeben. (s. auch Kommandos O_ACC1, O_ACC2, O_DEC1, O_DEC2).
13 | 0x2000 | =0 die Zielposition und die Zielgeschwindigkeit des Fahrsatzes werden als Inkremente interpretiert. Es findet keine Umrechnung statt. =1 die Zielposition und die Zielgeschwindigkeit werden vor dem Start des Fahrsatzes in Inkremente umgerechnet. Für die Umrechnung werden die Parameter PGEARI und PGEARO benutzt. (s. auch Kommandos O_S, O_V, PGEARI, PGEARO)
14 | 0x4000 | =0 die Geschwindigkeit des Fahrsatzes wird beim Fahrsatzstart als die Zielgeschwindigkeit übernommen. =1 die Zielgeschwindigkeit wird beim Fahrsatzstart analog vorgegeben (SW1). Beim Start des Fahrsatzes wird der analoge SW1-Wert eingelesen und als die Zielgeschwindigkeit übernommen (Skalierung: 10V=VSCALE1). Das Vorzeichen der SW1-Spannung wird ignoriert.
15 | 0x8000 | Bit 3 für die Art des relativen Fahrsatzes (s. separate Tabelle)
 | Tabelle 2 | Art des relativen/absoluten Fahrsatzes
Bit 15/2/1/0 | Bedeutung |
xxx0 | Absoluter Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als die Zielposition gewertet. |
x001 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. Die Zielposition wird abhängig vom Zustand der IN-POSITION-Meldung berechnet: IN-POSITION=1: neue Zielposition=letzte Zielposition+Verfahrstrecke IN-POSITION=0: neue Zielposition=aktuelle Position+Verfahrstrecke |
x011 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=letzte Zielposition+Verfahrstrecke |
x101 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=aktuelle Position+Verfahrstrecke |
0111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=positive Latchposition+Verfahrstrecke (s. auch Kommando LATCH32) |
1111 | Relativer Fahrsatz, die Positionsangabe innerhalb des Fahrsatzes wird als Verfahrstrecke gewertet. neue Zielposition=negativeLatchposition+Verfahrstrecke (s. auch Kommando LATCH32N) |
 | Tabelle 3 | Art des Folgefahrsatzes
Bit 8/7/6/5/4 | Bedeutung |
00000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes. Anschließend wird der Folgefahrsatz gestartet. |
00001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Antrieb fährt mit der Zielgeschwindigkeit bis in die Zielposition des ersten Fahrsatzes. Anschließend wird bei voller Geschwindigkeit auf den Folgefahrsatz umgeschaltet. |
10001 | Fliegendes Umschalten auf den Folgeauftrag in der Zielposition. Der Umschaltpunkt auf den Folgefahrauftrag wird so vorverlegt, daß in der Zielposition des ersten Fahrsatzes die Zielgeschwindigkeit des Folgefahrsatzes bereits erreicht wird. |
00010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte. |
00110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte. |
01000 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01010 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand LOW erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |
01110 | Umschalten auf Folgefahrauftrag mit Abbremsen. Der Antrieb bremst in die Zielposition des ersten Fahrsatzes.Der Folgefahrsatz wird gestartet, wenn der zum Starten des Folgefahrsatzes definierter Eingang (Funktion INxMODE=15) den Zustand HIGH erreicht hatte oder nachdem die programmierte Verzögerungszeit (O_FT) abgelaufen ist. |


ASCII Deutsch O_DEC1

ASCII - Kommando | O_DEC1 |
Syntax Senden | O_DEC1 [Data] |
Syntax Empfangen | O_DEC1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BA (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1786 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32000 | DPR | 186 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Bremsszeit für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_DEC1 kann die Bremsrampe für den Fahrsatz 0 (Direktfahrsatz) definiert werden. Die Normierung der Bremsszeit hängt von den Parameter PGEARI, PGEARO und O_C ab.

1. Das Bit 12 der Fahrsatz-Steuervariable O_C gleich 0.
Die Bremszeit wird in msek von der Zielgeschwindigkeit O_V auf 0 vorgegeben.
2. Das Bit 12 der Fahrsatz-Steuervariable =O_C gleich 1.
Die Bremsbeschleunigung wird in mm/sek2 vorgegeben. Die sich daraus ergebende Bremszeit
wird bei Fahrsatzstart berechnet.

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet. In diesem Fall wird O_DEC1 als Bremszeit in msek gewertet.


ASCII Deutsch O_FN

ASCII - Kommando | O_FN |
Syntax Senden | O_FN [Data] |
Syntax Empfangen | O_FN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BC (hex)
DIM | - | PROFIBUS PNU | 1788 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. ,180,192 .. 255 | DPR | 188 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Folgefahrsatz-Nummer für den Fahrsatz 0

Beschreibung

Mit dem Kommando O_FN kann die Nummer des Folgefahrsatzes definiert werden. Diese Nummer wird nur dann verwendet, wenn das Bit3 (Folgefahrsatz aktiv) des Fahrsatz-Steuerwortes auf 1 steht.
Die Fahrsatz-Nummer kann folgende Werte annehmen:
0 - Direktfahrsatz
1...180 Fahrsatz aus dem Flash-EEPROM
192...255 Fahrsatz aus dem RAM


ASCII Deutsch O_FT

ASCII - Kommando | O_FT |
Syntax Senden | O_FT [data] |
Syntax Empfangen | O_FT | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35BD (hex)
DIM | Milliseconds | PROFIBUS PNU | 1789 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 189 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Verzögerungszeit für den Folge-Fahrsatz

Beschreibung

Mit Hilfe dieses Parameters kann der Start des Folge-Fahrsatzes (falls definiert) verzögert werden. Dieser Parameter wird nur dann ausgewertet, wenn das Bit3 (Folgefahrsatz aktiv) und das Bit7 (Verzögerungszeit aktiv) des Fahrsatz-Steuerwortes gesetzt sind.


ASCII Deutsch O_P

ASCII - Kommando | O_P |
Syntax Senden | O_P [data] |
Syntax Empfangen | O_P | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer64 | CANBus Objektnummer | 35BE (hex)
DIM | - | PROFIBUS PNU | 1790 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 190 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer64
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Zielposition/Verfahrstrecke für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_P kann die Zielposition für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Abhängig von der Fahrauftragsart (absolut oder relativ) wird dieser Parameter als absolute Zielposition oder als relative Verfahrstrecke interpretiert. Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Position/Verfahrstrecke wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 1048576 Inkremente pro Umdrehung
PRBASE=16 -> 65536 Inkremente pro Umdrehung

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Position wird nach folgender Formel umgerechnet:
Position [Inkremente] = O_P * PGEARO / PGEARI

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit, Position und Beschleunigung grundsätzlich interne Einheiten (Counts) verwendet.


ASCII Deutsch O_V

ASCII - Kommando | O_V |
Syntax Senden | O_V [data] |
Syntax Empfangen | O_V | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35BF (hex)
DIM | - | PROFIBUS PNU | 1791 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 191 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Zielgeschwindigkeit für den Fahrsatz 0

Beschreibung

Mit dem Parameter O_V kann die Zielgeschwindigkeit für den Fahrsatz 0 (Direktfahrsatz) vorgegeben werden. Die Normierung der Geschwindigkeit hängt von den Einstellungen PGEARI / PGEARO / PRBASE und O_C ab:

1. Bit13 des Fahrsatz-Kontrollwortes gleich 0 (Vorgabe als interne Einheiten)
Die Geschwindigkeit wird in Counts vorgegeben.
Normierung: PRBASE=20 -> 140/32 Inkremente pro UPM
PRBASE=16 -> 140/512 Inkremente pro UPM

2. Bit 13 des Fahrsatz-Kontrollwortes gleich 1 (Berücksichtigung der Auflösung)
Die Geschwindigkeit wird nach folgender Formel umgerechnet:
Geschwindigkeit [Inkremente] = O_V * PGEARO / PGEARI / 4000

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden für die Geschwindigkeit grundsätzlich interne Einheiten (Counts) verwendet.


ASCII Deutsch OBJCO

ASCII - Kommando | OBJCO |
Syntax Senden | OBJCO |
Syntax Empfangen | OBJCO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Liest CAN-Objekte für Debug-Zwecke aus

Beschreibung

Das ASCII – Objekt OBJCO liest CAN Objekte aus. Das Objekt benötigt bis zu zwei Parameter. Der erste Parameter gibt den Index an, der zweite den Subindex. Der Subindex ist optional. Wird der Subindex nicht mit angegeben, wird intern mit dem Subindex 0 gearbeitet.


ASCII Deutsch OCOPY

ASCII - Kommando | OCOPY |
Syntax Senden | OCOPY [ - Data] |
Syntax Empfangen | OCOPY <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0,1,..,180,192..255 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Speichern der Fahrsätze

Beschreibung

Mit dem Kommando OCOPY können Fahraufträge zwischen verschiedenen Speicherplätzen kopiert werden. Die Fahrsatznummer kann folgende Werte annehmen:
0 - lokaler Fahrsatz/ Direktfahrsatz
1...180 ROM-Fahrsätze, Die ROM -Fahrsätze werden in einem Segment des internen Flash-Eproms abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.
192...255 RAM-Fahrsätze, Die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der ROM-Fahrsätze 1...64 vorinitialisiert.

z.B:
OCOPY 0 1 Abspeichern des lokalen Fahrsatzes (Direktfahrsatz/RAM) als ROM-Fahrauftrag 1
(bei diesem Kommando muß die Endstufe gesperrt sein)
OCOPY 1 192 Kopieren des ersten ROM-Fahrsatzes ins RAM (Nummer 192)
OCOPY 1 - 16 192 Kopieren der ROM-Fahrsätze 1...16 ins RAM (192...207)


ASCII Deutsch OLIST

ASCII - Kommando | OLIST |
Syntax Senden | OLIST [Data] [Data] |
Syntax Empfangen | OLIST <Data> | Vorhanden in |
Type | Multi-line Return Command | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Ausgabe der Fahrsatzdaten

Beschreibung

Mit dem Kommando "OLIST x anzahl" werden ausgehend von dem Fahrauftrag x die Inhalte von "anzahl" aufeinanderfolgenden Fahraufträgen ausgegeben. Die Bedeutung und die Reihenfolge der angezeigten Parameter entsprechen dabei den Parametern des ORDER-Kommandos.
Falls der Parameter "anzahl" fehlt, so wird nur der Inhalt des Fahrsatzes "x" angezeigt.
Falls beide Parameter "x" und "anzahl" fehlen, so werden die Inhalte aller gültigen Fahrsätze angezeigt (d.h. Fahrsätze mit gültigen Daten und korrekter Checksumme).


ASCII Deutsch OPMODE

ASCII - Kommando | OPMODE |
Syntax Senden | OPMODE [Data] |
Syntax Empfangen | OPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35B4 (hex)
DIM | - | PROFIBUS PNU | 1780 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, .. , 8 | DPR | 180 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Betriebsart des Verstärkers

Beschreibung

Mit dem Kommando OPMODE kann die Betriebsart (Grundfunktion) des Verstärkers eingestellt werden. Diese Betriebsart kann zu jedem Zeitpunkt über Feldbus-Schnittstelle bzw. digitales I/O (INxMODE=24) umgeschaltet werden Es sind folgende Einstellungen möglich:
Zustand | Kurzbeschreibung | Beschreibung
OPMODE=0 | Drehzahl digital | Der Drehzahlsollwert kann entweder über die RS232-Schnittstelle (Kommando "J") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden. Bei aktivierter VCT-Funktion (s. INxMODE=35) kann der Drehzahl-Sollwert über die digitalen Eingänge aus einer Drehzahl/Strom-Tabelle angewählt werden.
OPMODE=1 | Drehzahl analog | Der Drehzahlsollwert wird von der Analogschnittstelle SW1/SW2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=2 | Drehmoment digital | Der Stromsollwert kann entweder über die RS232-Schnittstelle (Kommando "T") oder aber über eine Feldbus-Schnittstelle (PROFIBUS,CANBUS,SERCOS,DPR-Slot-Karten) vorgegeben werden.
OPMODE=3 | Drehmoment analog | Der Stromsollwert wird von der Analogschnittstelle SW1/SW2 eingelesen. Die Konfiguration der zu verwendeten SW-Schnittstelle kann mit Hilfe der Parameter ANCNFG, INxMODE=8 vorgenommen werden.
OPMODE=4 | Position elektrisches Getriebe (Master/Slave) | Elektronisches Getriebe Der Lageregler-Positionssollwert wird über die Master (Encoder) Schnittstelle vorgegeben. Die Art der zu verwendeten Schnittstelle kann mit dem Parameter GEARMODE vorgewählt werden.
OPMODE=5 | Position externe Trajektorie | Der Lageregler-Positionssollwert wird über die Feldbus-Schnittstelle (PROFIBUS,CANBUS,DPR-Slot-Karte) vorgegeben. Die Zykluszeit für die Vorgabe des Sollwertes kann mit dem Parameter PTBASE in 250 usek-Schritten eingestellt werden. Der Lageregler sorgt dafür, daß die vorgegebene Sollposition innerhalb der eingestellten Zeit erreicht wird. Bei Einstellung ANCNFG=8 kann die externe Trajektorie über den Analogeingang SW1 vorgegeben werden. Die analoge Spannung wird alle 250 µsek eingelesen und als Positionssollwert für die Lageregelung benutzt. Die Skalierung wird mit Hilfe der Parameter SRND (Position bei 0V) und ERND (Position bei +/- 10V) festgelegt. Bevor diese Funktion aktiv wird, muss zunächst eine Referenz fahrt gestartet werden.
OPMODE=6 | Position SERCOS | Der Lageregler-Positionssollwert wird über die SERCOS-Schnittstelle vorgegeben.
OPMODE=7 | Reserve |
OPMODE=8 | Position Fahrsätze | Bei dieser Einstellung können die internen Fahrsätze ausgeführt werden. Der interne Trajektoriengenerator, der bei dieser Einstellung aktiviert wird, sogt dafür, daß die vorgegebene Fahrsatzposition mit den eingestellten Fahrsatz-Rampen und Fahrsatz-Geschwindigkeit angefahren wird.


ASCII Deutsch OPTION

ASCII - Kommando | OPTION |
Syntax Senden | OPTION |
Syntax Empfangen | OPTION <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Slotkarten-Kennung

Beschreibung

Das Kommando OPTION liefert die Kennung der erkannten Slot-Karte. Es sind zurzeit folgende Kennungen möglich:
H0000 keine Slot-Karte erkannt
H01xx I/O-Erweiterungskarte
H02xx PROFIBUS
H03xx SERCOS
H06xx DeviceNet
H8100 Beckhoff-Lightbus
H8200 Lenord&Bauer
H8300 Sigmatek

Die unteren 8 Bits (xx) zeigen die Hardware-Revision der entsprechenden Karte.


ASCII Deutsch ORDER

ASCII - Kommando | ORDER |
Syntax Senden | ORDER [Data1...Data10] |
Syntax Empfangen | ORDER | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer32 ... Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 180, 192 .. 255 | DPR | Nein
Default | - |
Opmode | 8 | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Definition eines Fahrsatzes

Beschreibung

Mit dem ORDER-Kommando kann ein beliebiger RAM/ROM-Fahrsatz vollständig definiert werden. Das Kommando ORDER kann in 3 verschiedenen Formen benutzt werden:

ORDER Es wird der Inhalt des Direkt-Fahrsatzes (nr=0) angezeigt
ORDER nr Es wird der Inhalt des Fahrsatzes Nummer "nr" angezeigt
ORDER nr o_p o_v o_c o_acc1 o_dec1 o_acc2 o_dec2 o_fn o_ft = Definition des Fahrsatzes "nr"

Der Parameter "nr" gibt die Nummer des zu definierenden Fahrsatzes an. Die Fahrsatznummer kann folgende Werte annehmen:
0 - lokaler Fahrsatz/ Direktfahrsatz
1...180 ROM-Fahrsätze, Die ROM -Fahrsätze werden in einem Segment des internen Flash-Eproms abgelegt. Sie bleiben auch nach dem Ausschalten der 24V-Versorgung im Speicher des Verstärkers. Der Schreibzugriff auf diese Fahrsätze wird nur bei gesperrter Endstufe zugelassen.
192...255 RAM-Fahrsätze, Die RAM-Fahrsätze können beschrieben werden auch während die Endstufe freigegeben ist. Der Inhalt dieser Fahrsätze geht verloren, wenn die 24V-Versorgung abgeschaltet wird. Beim Einschalten des Reglers werden die RAM-Fahraufträge mit den Inhalten der ROM-Fahrsätze 1...64 vorinitialisiert.

Die einzelnen Komponenten o_p ... o_ft haben die gleiche Bedeutung wie das entsprechende ASCII-Kommando .

O_P Zielposition/Verfahrstrecke des Fahrsatzes
O_V Zielgeschwindigkeit
O_C Fahrsatzart (Kontrollwort)
O_ACC1 Anfahrrampe/Anfahrbeschleunigung
O_DEC1 Bremsrampe/Bremsbeschleunigung
O_ACC2 Aufbauzeit für die Anfahrbeschleunigung (>0 für sinus2)
O_DEC2 Aufbauzeit für die Bremsbeschleunigung (>0 für sinus2)
O_FN Nummer des Folgefahrsatzes
O_FT Verzögerungszeit vor dem Start des Folgefahrsatzes


ASCII Deutsch OS1

ASCII - Kommando | OS1 |
Syntax Senden | OS1 [Data] |
Syntax Empfangen | OS1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C7 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 455 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg1" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS1 setzt den Ausgang "PosReg1" (Klemme 6 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 0 auf "0", um den Ausgang vom Positionsregister SWE1 abzuschalten und dann den Zugriff über OS1 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS2

ASCII - Kommando | OS2 |
Syntax Senden | OS2 [Data] |
Syntax Empfangen | OS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C8 (hex)
DIM | - | PROFIBUS PNU | 1656 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 456 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg2" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS2 setzt den Ausgang "PosReg2" (Klemme 7 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 4 auf "0", um den Ausgang vom Positionsregister SWE2 abzuschalten und dann den Zugriff über OS2 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS3

ASCII - Kommando | OS3 |
Syntax Senden | OS3 [Data] |
Syntax Empfangen | OS3 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36C9 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 457 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg3" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS3 setzt den Ausgang "PosReg3" (Klemme 8 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 8 auf "0", um den Ausgang vom Positionsregister SWE3 abzuschalten und dann den Zugriff über OS3 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS4

ASCII - Kommando | OS4 |
Syntax Senden | OS4 [Data] |
Syntax Empfangen | OS4 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CA (hex)
DIM | - | PROFIBUS PNU | 1658 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 458 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg4" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS4 setzt den Ausgang "PosReg4" (Klemme 9 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG Bit 12 auf "0", um den Ausgang vom Positionsregister SWE4 abzuschalten und dann den Zugriff über OS4 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OS5

ASCII - Kommando | OS5 |
Syntax Senden | OS5 [Data] |
Syntax Empfangen | OS5 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36CB (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0001xxxx (bin)
Bereich | 0, 1 | DPR | 459 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Setzen von "Posreg5" der I/O Erweiterungskarte

Beschreibung

Die I/O Erweiterungskarte hat 5 digitale Ausgänge, welche normalerweise zur Ausgabe der Positionsregister SWE0-4 benutzt werden. OS5 setzt den Ausgang "PosReg5" (Klemme 10 von X11B) der I/O Erweiterungskarte.

Setze SWCNFG2 Bit 0 auf "0", um den Ausgang vom Positionsregister SWE0 abzuschalten und dann den Zugriff über OS5 zu ermöglichen.

Dieses Kommando erlaubt den Zugriff auf den Ausgang über Standard Kommunikationskanäle und auch durch Fahrsatz Programmierung.


ASCII Deutsch OVRIDE

ASCII - Kommando | OVRIDE |
Syntax Senden | OVRIDE [Data] |
Syntax Empfangen | OVRIDE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35B6 (hex)
DIM | - | PROFIBUS PNU | 1782 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 3 | DPR | 182 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Override-Funktion

Beschreibung

Mit Override-Funktion kann die Geschwindigkeit eines Fahrsatzes über die analoge/digitale Schnittstelle beeinflußt werden. Wenn diese Funktion aktiviert ist, so wird jede msek der analoge Sollwert eingelesen und für die Skalierung der Fahrsatzgeschwindigkeit benutzt.
SW=10V Fahrsatzgeschwindigkeit = Zielgeschwindigkeit, die im Fahrsatz programmiert ist
SW=5V Fahrsatzgeschwindigkeit = 50% der programmierten Zielgeschwindigkeit

Die OVERRIDE – Funktion ist nicht bei sin^2 – Rampen möglich !

Es sind folgende Einstellungen möglich:
OVRIDE=0 Override-Funktion abgeschaltet
OVRIDE=1 SW1-Eingang für die Override-Funktion aktiviert
OVRIDE=2 SW2-Eingang für die Override-Funktion aktiviert
OVRIDE=3 DigitaleSchnittstelle für die Override-Funktion aktiviert. Die dig. Schnittstellen können sein: Sercos, PROFIBUS, CAN, DPR und alle weiteren Feldbusse.


ASCII Deutsch P1...P16

ASCII - Kommando | P1...P16 |
Syntax Senden | P1 [Data] |
Syntax Empfangen | P1...P16 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3644 (hex)
DIM | - | PROFIBUS PNU | 1924 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 324 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | schnelle Positionsschwelle 1...16

Beschreibung

Die Variablen P1...P16 enthalten die Positionswerte für die Positionsschwellen 1...16.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

P[Inkremente] = P[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von WPOS, WPOSE, WPOSP, WPOSX, POSRSTAT

Die angegebene Objektnummer gilt für P1. Die Objektnummer bis P16 sind aufsteigend.


ASCII Deutsch PASS

ASCII - Kommando | PASS |
Syntax Senden | PASS [Data] |
Syntax Empfangen | PASS <Data> | Vorhanden in |
Type | w | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | -2147483648...2147483647 | DPR | Nein
Default | 0 |
Opmode |  | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe |  | EEPROM |
Kurzbeschreibung | Password Eingabe

Beschreibung

Bei aktiviertem Password-Schutz (PASSX = y) ist eine Änderung von Verstärker-Parametern nur nach
der Eingabe eines gültigen Passwort-Wertes möglich (“PASS y”).


ASCII Deutsch PASSCNFG

ASCII - Kommando | PASSCNFG |
Syntax Senden | PASSCNFG [Data] |
Syntax Empfangen | PASSCNFG <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36D8 (hex)
DIM |  | PROFIBUS PNU | 1672 (dec) IND = 0001xxxx (bin)
Bereich | 0,1 | DPR | 472 (dec)
Default | 0 |
Opmode |  | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM |
Kurzbeschreibung | Passwort Funktion

Beschreibung

Mit dem Kommando PASSCNFG kann die Art der Passwort-Funktion konfiguriert werden.(siehe auch PASS,PASSX)

PASSCNFG=0 bei aktiviertem Passwortschutz sind alle Parameter-Schreibzugriffe gesperrt.

PASSCNFG=1 bei aktiviertem Passwortschutz ist nur das Kommando SAVE gesperrt.


ASCII Deutsch PASSX

ASCII - Kommando | PASSX |
Syntax Senden | PASSX [Data] |
Syntax Empfangen | PASSX <Data> | Vorhanden in |
Type | w | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM |  | PROFIBUS PNU | Nein
Bereich | -2147483648...2147483647 | DPR | Nein
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Passwort-Schutz aktivieren

Beschreibung

Mit dem Parameter PASSX kann der Passwort-Schutz für die Parameter-Eingaben aktiviert werden.
PASSX=0 kein Passwortschutz
PASSX =y Die Parametereingaben sind erst nach der Eingabe des Passwortes “PASS y” möglich.


ASCII Deutsch PBAL

ASCII - Kommando | PBAL |
Syntax Senden | PBAL |
Syntax Empfangen | PBAL <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C0 (hex)
DIM | W | PROFIBUS PNU | 1792 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1500 | DPR | 192 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Ballastleistung

Beschreibung

Istwert der mittleren Ballastleistung


ASCII Deutsch PBALMAX

ASCII - Kommando | PBALMAX |
Syntax Senden | PBALMAX [Data] |
Syntax Empfangen | PBALMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C1 (hex)
DIM | W | PROFIBUS PNU | 1793 (dec) IND = 0000xxxx (bin)
Bereich | see Manual | DPR | 193 (dec)
Default | 80 / 200 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Maximale Ballastleistung

Beschreibung

Mit diesem Parameter kann die Dauerleistung des Ballastwiderstandes begrenzt werden.
Falls der Istwert der Ballastleistung den eingestellten Maximalwert überschreitet, so wird der Ballastwiderstand abgeschaltet. Als Folge kann die Fehlermeldung "Überspannung" ausgelöst werden. Bei einem zu hohen Maximalwert kann der Ballastwiderstand überlastet werden.


ASCII Deutsch PBALRES

ASCII - Kommando | PBALRES |
Syntax Senden | PBALRES [Data] |
Syntax Empfangen | PBALRES <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35C2 (hex)
DIM | - | PROFIBUS PNU | 1794 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 194 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Vorwahl des Ballastwiderstandes

Beschreibung

Über diesen Paramerter kann vorgerwählt werden, ob der interne (0) oder ein externer (> 0) Ballastwiderstand verwendet werden soll. Der Wert > 0 gibt den Ballastwiderstand in Ohm an
Beeinflusst den Parameter PBALMAX.


ASCII Deutsch PE

ASCII - Kommando | PE |
Syntax Senden | PE |
Syntax Empfangen | PE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C5 (hex)
DIM | µm | PROFIBUS PNU | 1797 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 197 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert des Schleppfehlers

Beschreibung

Der Schleppfehler stellt die aktuelle Differenz zwischen dem Lagesoll- und dem Lageistwert dar
und wird in den Einheiten des Lagereglers angezeigt (PGEARI / PGEARO).
s. Beschreibung von PFB


ASCII Deutsch PEINPOS

ASCII - Kommando | PEINPOS |
Syntax Senden | PEINPOS [Data] |
Syntax Empfangen | PEINPOS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C6 (hex)
DIM | PUNIT | PROFIBUS PNU | 1798 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 198 (dec)
Default | 4000 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | In-Position-Fenster

Beschreibung

Falls bei Ausführung eines internen Fahrsatzes die Entfernung zwischen der aktuellen Position und der Zielposition die eingestellte Fenstergröße unterschreitet, so wird die Meldung In-Position generiert (Statusmeldung, Digitaler Ausgang).
Das In-Position-Fenster wird in den Einheiten des Lagereglers eingegeben (PGEARI / PGEARO).
s. Beschreibung von PFB


ASCII Deutsch PEMAX

ASCII - Kommando | PEMAX |
Syntax Senden | PEMAX [Data] |
Syntax Empfangen | PEMAX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C7 (hex)
DIM | µm | PROFIBUS PNU | 1799 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 199 (dec)
Default | 262144 |
Opmode | >=4 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Max. Schleppfehler

Beschreibung

Falls der aktuelle Schleppfehler (PE) den eingestellten Maximalwert überschreitet, so wird der Fahrsatz abgebrochen und die Warnung "Schleppfehler" generiert. Erst nachdem diese Warnung quittiert wird (Kommando CLRFAULT, digitaler Eingang INxMODE=14), kann der Fahrsatz Fortgesetzt (CONTINUE) oder neu gestartet werden.

Die Einstellung PEMAX=0 schaltet die Schleppfehlerüberwachung ab.

Negative Werte in PEMAX (ab Version 4.78) führen nicht zu einem Stillsetzen der Achse bei Schleppfehler. Das Statusbit und die Warnung werden allerdings gesetzt. Es lässt sich dann kein weiterer Fahrsatz starten, bis der Schleppfehler gelöscht wurde. Auch eventuelle Folgefahrsätze werden nicht mehr gestartet.


ASCII Deutsch PFB

ASCII - Kommando | PFB |
Syntax Senden | PFB |
Syntax Empfangen | PFB <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C8 (hex)
DIM | µm | PROFIBUS PNU | 1800 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 200 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | aktuelle Lagereglerposition

Beschreibung

Das Kommando PFB liefert den Istwert der Lageregler-Position. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO und PRBASE.

PFB = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen, 1048576/Umdrehung bei PRBASE=20, 65536/Umdrehung bei PRBASE=16
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB-Kommando die internen Einheiten(Counts).

Wenn die Positionsinformation eines externen Gebers erfasst wird (EXTPOS=1,2,3), so kann diese Information mit Hilfe des PFB0 - Kommandos angezeigt werden.


ASCII Deutsch PFB0

ASCII - Kommando | PFB0 |
Syntax Senden | PFB0 |
Syntax Empfangen | PFB0 <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35C9 (hex)
DIM | Counts | PROFIBUS PNU | 1801 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 201 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Lagereglerposition über den externen Encoder

Beschreibung

Das Kommando PFB0 liefert den Positions-Istwert der anhand der Positionsinformation eines externen Gebers berechnet wird. Die Position über einen externen Geber wird nur dann erfasst, wenn die Konfigurationsvariable EXTPOS auf 1,2,3 steht. Die Einheit des Positionswertes hängt von den Einstellungen PGEARI, PGEARO, ENCIN und EXTMUL ab.

PFB0 = Position * PGEARI / PGEARO
wobei:
Position = Positionswert in Inkrementen (Auflösung: EXTMUL pro Umdrehung)
PGEARI, PGEARO - Lagereglerauflösung

Anmerkung: Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so liefert das PFB0-Kommando die internen Einheiten(Counts).


ASCII Deutsch PGEARI

ASCII - Kommando | PGEARI |
Syntax Senden | PGEARI [Data] |
Syntax Empfangen | PGEARI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CA (hex)
DIM | µm | PROFIBUS PNU | 1802 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 202 (dec)
Default | 10000 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Zähler)

Beschreibung

Der Parameter PGEARI wird in Verbindung mit dem Parameter PGEARO benutzt, um die Lageregler-Position und Geschwindigkeit von SI-Einheiten auf Inkremente umzurechnen.
Der Parameter PGEARO enthält die Anzahl der Inkremente, die gefahren werden, wenn die zu fahrende Strecke PGEARI beträgt.
Die Umrechnung erfolgt nach folgender Formel:

Position[Inkremente] = Position[SI] * PGEARO / PGEARI
Geschwindigkeit[Inkremente] = Geschwindigkeit[SI] * PGEARO / PGEARI / 4000

Wenn PGEARI = PGEARO so findet keine Umrechnung von SI-Einheiten auf Inkremente statt. In diesem Fall muß die Position und Geschwindigkeit in Inkrementen vorgegeben werden.

Geschwindigkeit: 140/32 * Drehzahl in UPM

Beispiele:

PGEARI=10000
PGEARO=1048576
PRBASE=20

Bei einer Auflösung von 10 mm/Umdrehung soll die Fahrstrecke in µm vorgegeben werden. Es soll die Auflösung von 20 Bit/Umdrehung benutzt werden. Für diese Aufgabenstellung sind folgende Einstellungen notwendig:
Position: 1046576 Inkremente/Umdrehung bei PRBASE = 20 oder 65536 Inkremente/Umdrehung bei PRBASE = 16.

Alle Positionsangaben (PFB, O_P, PE, PEMAX, PEINPOS) erfolgen in µm, die Geschwindigkeitvorgaben in µm/sek, Beschleunigungsvorgaben (falls vorgewählt) in 1000µm/sek²

PGEARI = 3600
PGEARO = 65536
PRBASE = 16

Bei einer Auflösung von 360 Grad/Umdrehung soll die Fahrstrecke in 0.1 Grad Schritten vorgegeben werden. Es soll die Auflösung von 16 Bit/Umdrehung benutzt werden. Für diese Aufgabenstellung sind folgende Einstellungen notwendig:

Alle Positionsangaben (PFB, O_P, PE, PEMAX, PEINPOS) erfolgen in 0.1*Grad, die Geschwindigkeitvorgaben in 0.1*Grad/sek, Beschleunigungsvorgaben (falls vorgewählt) in 1000*0.1*Grad/sek²


ASCII Deutsch PGEARO

ASCII - Kommando | PGEARO |
Syntax Senden | PGEARO [Data] |
Syntax Empfangen | PGEARO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CB (hex)
DIM | µm | PROFIBUS PNU | 1803 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 203 (dec)
Default | 1048576 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Lageregler-Auflösung (Nenner)

Beschreibung

Der Parameter PGEARI wird in Verbindung mit dem Parameter PGEARO benutzt, um die Lageregler-Position und Geschwindigkeit von SI-Einheiten auf Inkremente umzurechnen.
Der Parameter PGEARO enthält die Anzahl der Inkremente, die gefahren werden, wenn die zu fahrende Strecke PGEARI beträgt.
Die Umrechnung erfolgt nach folgender Formel:

Position[Inkremente] = Position[SI] * PGEARO / PGEARI
Geschwindigkeit[Inkremente] = Geschwindigkeit[SI] * PGEARO / PGEARI / 4000

Wenn PGEARI = PGEARO so findet keine Umrechnung von SI-Einheiten auf Inkremente statt. In diesem Fall muß die Position und Geschwindigkeit in Inkrementen vorgegeben werden.

Geschwindigkeit: 140/32 * Drehzahl in UPM

Beispiele siehe PGEARI


ASCII Deutsch PMODE

ASCII - Kommando | PMODE |
Syntax Senden | PMODE [Data] |
Syntax Empfangen | PMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CD (hex)
DIM | - | PROFIBUS PNU | 1805 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 205 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Netz-Phase Modus

Beschreibung

Der Parameter PMODE konfiguriert das Verhalten des Verstärkers beim Ausfall einer Netzphase.
PMODE=0 keine Warnung, keine Fehlermeldung, Strombegrenzung auf max. 4A
PMODE=1 Warnung n05, Strombegrenzung auf max. 4A
PMODE=2 Fehlermeldung F19, Sperren der Endstufe

Falls die Strombegrenzung aktiv wird, so gilt sie nur für die Beschleunigungsphasen. Ein Bremsvorgang kann weiterhin mit vollem Strom durchgeführt werden.


ASCII Deutsch PNOID

ASCII - Kommando | PNOID |
Syntax Senden | PNOID |
Syntax Empfangen | PNOID <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35CE (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 206 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Kennung (ID)

Beschreibung

Das Kommando PNOID liest die „Identnummer“ des Verstärkers aus. Anhand dieser Nummer ist der Verstärker im PROFIBUS Netz eindeutig als Teilnehmer zu identifizieren. Die Identnummer wird von der PROFIBUS - Nutzerorganisation vergeben und verwaltet.
Diese Gerätekennung ist auch Bestandteil der Gerätestammdaten (GSD).

PNOID liefert die Identnummer 045D hexadezimal.


ASCII Deutsch POP

ASCII - Kommando | POP |
Syntax Senden | POP time1(msec) time2(msec) |
Syntax Empfangen | POP <Data> | Vorhanden in |
Type | Multi Line Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | -
Kurzbeschreibung | Erzeugen eines Stromsprunges

Beschreibung

Das Kommando POP wird zusammen mit den Kommandos POPI, POPI2 und POPV benutzt, damit der Verstärker einen Stromsprung erzeugt. Dieses Kommando wird nur mit MSG = 2 ausgeführt. POP wird vom "Current Loop Wizard" und anderen Testprogrammen benutzt und wird nicht im Normalbetrieb verwendet.

POP time1 (msec) time2 (msec)

Wenn der Kommando ausgeführt wird, schaltet der Verstärker in OPMODE = 2 und gibt einen Strom definiert mit POPI für die Zeit time1 aus. Anschließend gibt er den Strom definiert mit POPI2 für die Zeit time2 aus, falls time2 angegeben ist. Danach schaltet der Verstärker automatisch in den ursprünglichen OPMODE zurück. Wenn der Motor während der Ausführung des Kommandos die Drehzahlschwelle POPV erreicht, wird das Kommando abgebrochen.


ASCII Deutsch POPI

ASCII - Kommando | POPI |
Syntax Senden | POPI [Data] |
Syntax Empfangen | POPI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -DIPEAK .. DIPEAK | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe des Stromes für das POP - Kommando

Beschreibung

POPI gibt den Strom an, der beim POP - Kommando verwendet wird. POPI wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI2, POPV


ASCII Deutsch POPI2

ASCII - Kommando | POPI2 |
Syntax Senden | POPI2 [Data] |
Syntax Empfangen | POPI2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -DIPEAK .. DIPEAK | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe des Stromes für das POP - Kommando

Beschreibung

POPI2 gibt den Strom an, der beim POP - Kommando im zweiten Schritt verwendet wird. POPI2 wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI, POPV


ASCII Deutsch POPV

ASCII - Kommando | POPV |
Syntax Senden | POPV [Data] |
Syntax Empfangen | POPV <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | Nein
DIM | A | PROFIBUS PNU | Nein
Bereich | -VLIM .. VLIM | DPR | Nein
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Nein
Kurzbeschreibung | Vorgabe der max. Drehzahl für das POP - Kommando

Beschreibung

POPV begrenzt die Drehzahl des Motors bei der Ausführung eines POP - Kommandos. Wenn die Drehzahl des Motors währent eines POP - Kommandos die Schwelle POPV erreicht, so wird das POP - Kommando abgebrochen.POPV wird vom "Current Loop Wizard" und anderen Testprogrammen verwendet. Es wird nicht im Normalbetrieb verwendet.

Siehe auch: POP, POPI, POPI2


ASCII Deutsch POSCNFG

ASCII - Kommando | POSCNFG |
Syntax Senden | POSCNFG [Data] |
Syntax Empfangen | POSCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35CF (hex)
DIM | - | PROFIBUS PNU | 1807 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 207 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Achsentyp

Beschreibung

Mit dem Parameter POSCNFG kann der Achsentype für die Lageregelung eingestellt werden. Es sind folgende Einstellungen möglich:
POSCNFG=0 Linearachse Achse mit begrenztem Verfahrbereich
Die Nullstellung für die Positionserfassung wird durch eine Referenzfahrt festgelegt. Bei dieser Einstellung ist das Setzen des Referenzpunktes die Voraussetzung für die Ausführung von Fahrsätzen.
Nachdem die Referenzfahrt (Setzen des Referenzpunktes) ausgeführt wurde, wird die Lagereglerposition laufend erfasst und behält bis zum Ausschalten des Verstärkers ihre Gültigkeit.
POSCNFG=1 Modulo-Achse Die Lagereglerposition wird auf den Bereich <SRND...ERND> beschränkt. Sobald das Ende dieses Bereiches (ERND-1) erreicht wird,
fängt die Position am Anfang (SRND) wieder an. Die absoluten Zielpositionen für die Fahrsätze müssen in dem gültigen Bereich liegen. Beim Versuch einen absoluten Fahrsatz zu starten dessen Zielposition außerhalb des Bereiches liegt, wird die Warnung n08
(fehlerhafter Fahrsatz) ausgegeben. Bei relativen Fahrsätzen wird die Zielposition so korrigiert, daß sie immer innerhalb des gültigen Bereiches liegt. Da beim Positionieren innerhalb des Modulo-Bereiches eine Zielposition von zwei Seiten angefahren werden kann, kann mit Hilfe der Variable DREF die Vorzugsrichtung definiert werden.
Bezüglich des Referenzpunktes gelten die gleichen Einschränkungen wie bei POSCNFG=0 d.h. die Ausführung einer Referenzfahrt ist Voraussetzung für alle Positioniervorgänge.
Die Beschränkung auf den Modulo-Bereich gilt nicht während der Referenzfahrt d.h während der Referenzfahrt werden die Lagereglerpositionen ähnlich gehandhabt wie bei POSCNFG=0.
Erst nach Abschluß der Referenzfahrt,wird die Begrenzung auf den Modulo-Bereich aktiviert.

Die Einstellung POSCNFG=2 wirkt sich bei allen Betriebsarten (OPMODE) aus. D.h. auch bei analoger Sollwertvorgabe (z.B. OPMODE=1)
wird die Ist-Position (PFB) auf den Modulo-Bereich beschränkt.

s. auch Beschreibung für SRND, ERND, DREF


ASCII Deutsch POSRSTAT

ASCII - Kommando | POSRSTAT |
Syntax Senden | POSRSTAT [Data] |
Syntax Empfangen | POSRSTAT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3643 (hex)
DIM | - | PROFIBUS PNU | 1923 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 323 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Status der schnellen Positionsregister 1...16

Beschreibung

Die Variable POSRSTAT liefert den aktuellen Status der schnellen Positionsregister.
Die Variable ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) als Statusinformation für Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

s. auch WPOS


ASCII Deutsch PPOTYP

ASCII - Kommando | PPOTYP |
Syntax Senden | PPOTYP |
Syntax Empfangen | PPOTYP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35D0 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 0000xxxx (bin)
Bereich | 2 | DPR | 208 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Profibus PPO-Typ

Beschreibung

Das Kommando PPOTYP liest den PROFIBUS DP Telegrammtyp aus. Der Verstärker unterstützt Telegrammtyp 2, d.h. das Telegramm besteht aus 10 Worte (20 Byte) und unterteilt sich in PKW – Teil (4 Worte) und PZD – Teil (6 Worte).

PPOTYP liefert den Wert 2.


ASCII Deutsch PRBASE

ASCII - Kommando | PRBASE |
Syntax Senden | PRBASE [Data] |
Syntax Empfangen | PRBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35D1 (hex)
DIM | - | PROFIBUS PNU | 1809 (dec) IND = 0000xxxx (bin)
Bereich | 16, 20 | DPR | 209 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | interne Lage-Auflösung

Beschreibung

Mit dem ASCII-Kommando PRBASE [16/20] kann die interne Lageauflösung
zwischen 16 und 20 Bits/Umdrehung umgeschaltet werden.
Die Übernahme der Auflösung erfolgt erst nach Aus- und Einschalten des Verstärkers.

20 Bits Inkremente/Umdrehung 0...1048575
Max. Verfahrweg (absolut) +/- 2047 Umdrehungen

16 Bits Inkremente/Umdrehung 0...65535
Max. Verfahrweg (absolut) +/- 32767 Umdrehungen


ASCII Deutsch PRD

ASCII - Kommando | PRD |
Syntax Senden | PRD |
Syntax Empfangen | PRD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D2 (hex)
DIM | Counts | PROFIBUS PNU | 1810 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1048575 | DPR | 210 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | 20 Bit Feedback-Position

Beschreibung

Das Kommando PRD liefert eine 20 Bit-Position (absolut innerhalb einer Umdrehung), die anhand der Signale der Feedback-Einheit (FBTYPE) ermittelt wurde. Diese Position kann, im Gegensatz zu der Lagereglerposition PFB, nicht verändert werden.


ASCII Deutsch PROMPT

ASCII - Kommando | PROMPT |
Syntax Senden | PROMPT [Data] |
Syntax Empfangen | PROMPT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35D3 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 211 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Vorwahl des RS232-Protokolls

Beschreibung

Mit dem Parameter PROMPT kann das Protokoll für die RS232-Übertragung festgelegt werden. Es sind folgende Einstellungen möglich:
PROMPT=0 | kein Echo | Die über die RS232-Schnittstelle empfangenen Daten werden nicht automatisch gespiegelt (gesendet). Es erfolgt keine Ausgabe des Prompt (-->) Zeichens.
PROMPT=1 | Prompt-Zeichen + Echo | Als Eingabenaufforderung wird das Prompt-Zeichen (-->) ausgegeben. Jedes Zeichen, das über die RS232-Schnittstelle empfangen wird, wird sofort zurückgesendet.
PROMPT=2 | Terminal-Mode | Einstellung entspricht der Einstellung PROMPT=1. Zusätzlich werden einige Hilfsfunktionen aktiviert. Dazu gehören: 1. Bei Eingabe eines CR (ENTER) am Anfang der Eingabezeile, wird das zuletzt eingegebene Kommando wiederholt. 2. Bei manchen Kommandos die eine Ausgabe liefern, die länger als eine Bildschirmseite ist, erfolgt die Ausgabe Seitenweise.
PROMPT=3 | Checksumme | Eine serielle Übertragung wird mit einer Checksummer versehen. Bei der Berechnung der Checksumme werden alle Zeichen einer Kommandofolge aufsummiert (Modulo 256 ohne CR). Die auf diese Weise berechnete Checksumme wird als 2-stellige Hex-Zahl (im ASCII-Format) am Ende einer Kommandofolge übertragen. Beispiel: Kommandofolge: ADDR 1<CR> Checksumme: „A“ = 0x41 „D“ = 0x44 „D“ = 0x44 „R“ = 0x52 „ „ = 0x20 „1“ = 0x31 Die Summe beträgt: 0x16C Modulo 256: 0x6c = 108 Das erste Zeichen der zu übertragenden Checksumme = 108/16 + 0x30 = 0x36 = „6“ Das zweite Zeichen der zu übertragenden Checksumme = 108%16 + 0x30 = 0x3c = „<“ Es wird folgende Kommandofolge übertragen: „ADDR 16<“<CR> Beim Empfang einer Kommandofolge wird die Checksumme auf die gleiche Art und Weise gebildet und mit den letzten beiden Zeichen vor dem <CR> verglichen. Bei Übereinstimmung wird das Zeichen ACK (0x06) gesendet, bei falscher Checksumme das Zeichen NACK (0x15).


ASCII Deutsch PSTATE

ASCII - Kommando | PSTATE |
Syntax Senden | PSTATE |
Syntax Empfangen | PSTATE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 35D4 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 212 (dec)
Default | - |
Opmode | - | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Nein
Kurzbeschreibung | Profibus-Status

Beschreibung

Das Kommando PSTATE liest den aktuellen Status der PROFIBUS – Kommunikation aus. Der erste angezeigte Wert liefert den SPC3 WATCHDOG Status, der zweite angezeigte Wert liefert den PROFIBUS DP-Status.

SPC3 WATCHDOG Status
0 = Baudratensuche
1 = Überprüfung der Baudrate
2 = DP Mode, d.h. Buswatchtdog aktiviert

PROFIBUS DP-Status
0 = Warte auf Parametrierung, Erfolgt durch den Master
1 = Warte auf Konfigurierung, Erfolgt durch den Master
2 = Datenaustausch
3 = Fehler, Die Ursache kann z.B. ein fehlerhaftes Parametriertelegramm in der Datentransfer – Phase gewesen sein.

Erst wenn der SPC3 WATCHTDOG Status den Wert 2 und der PROFIBUS DP - Status den Wert 2 aufweist, können Produktivdaten empfangen werden, d. h . es können Daten über den PKW – Teil und PZD – Teil des Verstärkers ausgetauscht werden.


ASCII Deutsch PTARGET

ASCII - Kommando | PTARGET |
Syntax Senden | PTARGET |
Syntax Empfangen | PTARGET <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3654 (hex)
DIM | - | PROFIBUS PNU | 1940 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 340 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | letzte Fahrsatzzielposition

Beschreibung

Mit dem Kommando PTARGET kann die Zielposition des zuletzt gestarteten (und ggf. bereits abgebrochenen) Fahrauftrages abgefragt werden. Diese Position wird als neue Zielposition übernommen, sobald das Kommando CONTINUE abgesetzt wird (Fortsetzen des letzten Fahrsatzes).


ASCII Deutsch PTBASE

ASCII - Kommando | PTBASE |
Syntax Senden | PTBASE [Data] |
Syntax Empfangen | PTBASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35D5 (hex)
DIM | - | PROFIBUS PNU | 1813 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 127 | DPR | 213 (dec)
Default | 4 (1 msec) |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Zeitbasis für die externe Trajektorie

Beschreibung

IN VORBEREITUNG !

Mit dem Parameter PTBASE wird die Interpolationszeit für die externe Trajektorie (OPMODE=5) vorgegeben. Die Zeit wird in 250 µsek-Schritten eingestellt, und gibt den Zeitintervall vor, in dem der nächste Positionssollwert von dem Antrieb erreicht werden soll. Da der interne Lageregler mit einer Abtastzeit von 250 µsek arbeitet, erfolgt eine Interpolation des vorgegebenen Positionssollwertes (externe Trajektorie) in 250 µsek-Schritten.


ASCII Deutsch PTEACH

ASCII - Kommando | PTEACH |
Syntax Senden | PTEACH [Data] |
Syntax Empfangen | PTEACH <Data> | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | Integer8 Integer8 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0,1,..,180,192 .. 255 | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled (only RAM) / Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Teach-In Funktion

Beschreibung

Mit dem Kommando PTEACH kann die aktuelle Position (Lageregelung) als die Zielposition für einen Fahrsatz übernommen werden.

Syntax: PTEACH QNR [ZNR]
QNR – Nummer des Ausgangsfahrauftrages
ZNR – Nummer des Zielfahrauftrages

Bei dem Kommando PTEACH wird der Fahrsatz ZNR in einen temporären Speicher geladen, die aktuelle Position als die Zielposition eingetragen und der vollständige Fahrsatz auf den Speicherplatz ZNR geschrieben. Falls die Nummer ZNR nicht angegeben wird, so wird der Fahrsatz auf den Speicherplatz QNR zurückgeschrieben.
Bei der Übernahme der aktuellen Position wird disese abhängig vom Zustand des Bits 13 von O_C entweder in Inkrementen (Bit=0) oder aber als SI-Einheiten (Bit=1) ausgewertet.
Wenn die Nummer des Zielfahrsatzes im Flash-Eprom liegt (Nr 1...180), so wird das PTEACH-Kommando nur bei gesperrter Endstufe zugelassen.


ASCII Deutsch PTMIN

ASCII - Kommando | PTMIN |
Syntax Senden | PTMIN [Data] |
Syntax Empfangen | PTMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35D6 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1814 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 32767 | DPR | 214 (dec)
Default | 10 |
Opmode | 8 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Min. Beschleunigungsrampe

Beschreibung

Die minimale Beschleunigungsrampe PTMIN gibt die minimale Zeit vor, die für die Geschwindigkeitsänderung von 0 auf PVMAX zuläßig ist. Unabhängig von der Art der Beschleunigungsvorgabe (msek,SI-Einheiten) wird beim Start eines Fahrsatzes die gefahrene Beschleunigung durch PVMAX / PTMIN begrenzt.
Mit Hilfe der Parameter PVMAX, PTMIN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch PUNIT

ASCII - Kommando | PUNIT |
Syntax Senden | PUNIT [Data] |
Syntax Empfangen | PUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3660 (hex)
DIM | - | PROFIBUS PNU | 1952 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10 | DPR | 352 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Vorgabe der Positionsauflösung

Beschreibung

Mit dem Kommando PUNIT kann die systemweite Einheit für alle positionsabhängige Parameter des Lagereglers definiert werden. Es sind folgende Einstellungen möglich:

PUNIT=0 interne Einheit (anwenderspezifisch)
PUNIT=1 1 dm (0.1 m)
PUNIT=2 1 cm (0.01 m)
PUNIT=3 1 mm
PUNIT=4 0.1 mm
PUNIT=5 0.01 mm
PUNIT=6 1 µm
PUNIT=7 0.1 µm
PUNIT=8 0.01 µm
PUNIT=9 1 nm
PUNIT=10 0.1 nm

Der Parameter PUNIT wird ausschließlich für die Darstellung der verwendeten Einheit im PC-Bedienprogramm (MMI) benutzt. Da sowohl die Lageregler-Auflösung (PGEARI) als auch alle Weg-Parameter in denselben Einheiten vorgegeben werden, hat die PUNIT-Einstellung keine Auswirkungen auf die Positionierung.

Bei der Einstellung PUNIT=0 wird keine Weg-Einheit angezeigt. In diesem Fall können anwenderspezifische Einheiten realisiert werden, die ausschließlich von der benutzten Auflösung (PGEARI) abhängig sind.

z.B: PGEARI=360 (Einheit = Grad)
PGEARI=3600 (Einheit= 0.1 Grad)


ASCII Deutsch PV

ASCII - Kommando | PV |
Syntax Senden | PV |
Syntax Empfangen | PV <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1815 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 215 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Ist-Geschwindigkeit (Lageregler)

Beschreibung

Die aktuelle Lageregler-Geschwindigkeit kann mit dem Kommando PV abgefragt werden. Die Normierung der Geschwindigkeit hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch PVMAXN

ASCII - Kommando | PVMAXN |
Syntax Senden | PVMAXN [Data] |
Syntax Empfangen | PVMAXN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D9 (hex)
DIM | VUNIT | PROFIBUS PNU | 1817 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 217 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler (negativ)

Beschreibung

Der Parameter PVMAXN gibt die maximale Geschwindigkeit an (negative Fahrtrichtung), die von einem Fahrsatz nicht überschritten werden kann. Beim Start eines Fahrsatzes wird die Zielgeschwindigkeit des Fahrsatzes auf den Wert PVMAXN begrenzt.
Bei Vorgabe der max. Geschwindigkeit in der positiven Richtung (PVMAX) wird gleichzeitig der Parameter PVMAXN auf den Wert von PVMAX gesetzt. Falls eine separate Einstellung für die negative Fahrtrichtung gewünscht ist, so muß anschliessend der Wert für PVMAXN separat eingegeben werden.
Mit Hilfe der Parameter PVMAX, PTMIN, PVMAXN kann das Verhalten der Anlage besonders während der Inbetriebnahmephase gesteuert werden, ohne daß die einzelnen Fahrsätze geändert werden müßen.


ASCII Deutsch PVMAXP

ASCII - Kommando | PVMAXP |
Syntax Senden | PVMAX [Data] |
Syntax Empfangen | PVMAXP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35D8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1816 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 216 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | max. Geschwindigkeit für den Lageregler

Beschreibung

-


ASCII Deutsch RDP

ASCII - Kommando | RDP |
Syntax Senden | RDP [Data] |
Syntax Empfangen | RDP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Char | CANBus Objektnummer | 36B7 (hex)
DIM | - | PROFIBUS PNU | 2039 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 2 | DPR | 439 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Char
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Aktiviere Rack Drive Panel Mode

Beschreibung

IN VORBEREITUNG !

RDP schaltet die Funktion "Rack Drive Panel" (Losekompensation) frei und lässt eine Einstellung der verschiedenen Modi zu. Informationen hierzu können auch der Applikationsbeschreibung "Rack Drive Panel (RDP): Controlling Backlash" entnommen werden.

0 RDP ist abgeschaltet
1 RDP Betriebsart freigeschaltet; Enable Mode = Fehler disabled auch anderen Servoverstärker
2 RDP Betriebsart freigeschaltet; Enable Mode = Bei einem Fehler übernimmt der andere Verstärker

Siehe auch: RDPBIAS, RDPCLAMP, RDPKI, RDPKP, RDPON, RDPINT


ASCII Deutsch RDPBIAS

ASCII - Kommando | RDPBIAS |
Syntax Senden | RDPBIAS [Data] |
Syntax Empfangen | RDPBIAS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B8 (hex)
DIM | Amp | PROFIBUS PNU | 2040 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. ICONT | DPR | 440 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Rack Drive Panel Verspannungsstrom

Beschreibung

IN VORBEREITUNG !

Gibt die Verspannung der beiden Achsen in A an. Dieser Wert wird normalerweise auf 25% bis 50% vom Dauerstrom ICONT eingestellt. Bei der einen Achse wird er positiv und bei der anderen entsrechend negativ vorgegeben.

Siehe auch RDP


ASCII Deutsch RDPCLAMP

ASCII - Kommando | RDPCLAMP |
Syntax Senden | RDPCLAMP [Data] |
Syntax Empfangen | RDPCLAMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36B9 (hex)
DIM | Rpm | PROFIBUS PNU | 2041 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. VLIM | DPR | 441 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Max Drehzahloffset von Rack Drive Panel

Beschreibung

IN VORBEREITUNG !

Max. Drehzahloffset von Rack Drive Panel. Dieser Wert wird beim Masterantrieb des RDP normalerweise auf 50 UPM gesetzt. Im Slaveantrieb muss dieser Wert auf 0 gesetzt werden.

Siehe auch: RDP


ASCII Deutsch RDPINT

ASCII - Kommando | RDPINT |
Syntax Senden | RDPINT |
Syntax Empfangen | RDPINT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 36BA (hex)
DIM | - | PROFIBUS PNU | 2042 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 442 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Nein
Kurzbeschreibung | Rack Drive Panel Test Variable

Beschreibung

IN VORBEREITUNG !

Gibt den Wert des Integralanteils des Rack Drive Panels wieder. Die Skalierung ist: 9000000 = 1 UPM. Dieser Wert wird limitiert durch RDCLAMP (skaliert in UPM).

Siehe auch RDP


ASCII Deutsch RDPKI

ASCII - Kommando | RDPKI |
Syntax Senden | RDPKI [Data] |
Syntax Empfangen | RDPKI <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BB (hex)
DIM | - | PROFIBUS PNU | 2043 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 443 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Integralanteil des Rach Drive Panel

Beschreibung

IN VORBEREITUNG !

Integralanteil der RDP Gleichlaufregelung. Normalerweise wird dieser Wert beim Masterantrieb auf 13 gesetzt. Beim Slave muss dieser Wert auf 0 gesetzt sein.

Siehe auch RDP


ASCII Deutsch RDPKP

ASCII - Kommando | RDPKP |
Syntax Senden | RDPKP [Data] |
Syntax Empfangen | RDPKP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 36BC (hex)
DIM | - | PROFIBUS PNU | 2044 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 444 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Ja
Kurzbeschreibung | Proportionalverstärkung des Rack Drive Panel

Beschreibung

IN VORBEREITUNG !

Proportionalanteil der RDP Gleichlaufregelung. Normalerweise wird dieser Wert beim Masterantrieb auf 300 gesetzt. Beim Slave muss dieser Wert auf 0 gesetzt sein.

Siehe auch RDP


ASCII Deutsch RDPON

ASCII - Kommando | RDPON |
Syntax Senden | RDPON |
Syntax Empfangen | RDPON <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 36BD (hex)
DIM | - | PROFIBUS PNU | 2045 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 445 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Rack Drive Panel | EEPROM | Nein
Kurzbeschreibung | Test Variable Rack Drive Panel

Beschreibung

IN VORBEREITUNG !

Gibt "1", wenn die Rack Drive Panel Schaltung aktiv ist, sonst eine "0"


ASCII Deutsch READNIMP

ASCII - Kommando | READNIMP |
Syntax Senden | READNIMP |
Syntax Empfangen | READNIMP | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35DC (hex)
DIM | - | PROFIBUS PNU | 1820 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 220 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | -
Kurzbeschreibung | Setzen des ROD-Nullimpulsoffsets

Beschreibung

Mit dem Kommando READNIMP wird die aktuelle Position abhängig von der eingestellten ROD-Auflösung umgerechnet, und in die Variable ENCZERO eingetragen.
Mit dieser Funktion kann erreicht werden, daß der ROD-Nullimpuls immer an der aktuellen Position (innerhalb einer Umdrehung) ausgegeben wird. Falls diese Einstellung dauerhaft übernommen werden soll, so sollte anschließend das SAVE-Kommando (Speichern im seriellen EEPROM) aufgerufen werden.


ASCII Deutsch READY

ASCII - Kommando | READY |
Syntax Senden | READY |
Syntax Empfangen | READY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DD (hex)
DIM | - | PROFIBUS PNU | 1821 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 221 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Zustand von Software-Enable

Beschreibung

Mit dem READY-Kommando kann der Zustand des internen Software-Enable abgefragt werden.


ASCII Deutsch RECDONE

ASCII - Kommando | RECDONE |
Syntax Senden | RECDONE |
Syntax Empfangen | RECDONE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DE (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 222 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufnahme beendet

Beschreibung

Mit dem Kommando RECDONE kann der Zustand der SCOPE-Aufzeichnung abgefragt werden. Das Kommando liefert eine 1, wenn die Aufzeichnung abgeschlossen ist und die Daten mit dem GET-Kommando angefordert werden können.


ASCII Deutsch RECING

ASCII - Kommando | RECING |
Syntax Senden | RECING |
Syntax Empfangen | RECING <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35DF (hex)
DIM | - | PROFIBUS PNU | 1823 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 223 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Aufzeichnug läuft

Beschreibung

Liefert eine 1 wenn Aufzeichnung aktiv. Am Ende einer Aufzeichnung bzw. wenn Aufzeichnung nicht gestartet, wird eine 0 geliefert.


ASCII Deutsch RECOFF

ASCII - Kommando | RECOFF |
Syntax Senden | RECOFF |
Syntax Empfangen | RECOFF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E0 (hex)
DIM | - | PROFIBUS PNU | 1824 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 224 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Scope: Abbruch einer Scope-Aufzeichnung

Beschreibung

Das Kommando RECOFF bricht die ggf. gestartete Scope-Aufzeichnung ab.


ASCII Deutsch RECORD

ASCII - Kommando | RECORD |
Syntax Senden | RECORD [Data] |
Syntax Empfangen | RECORD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 1 .. 10000 (=Time);1 .. 1024(=Points); ASCII String (=Var) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Definition der aufzuzeichnenden Daten

Beschreibung

Mit dem RECORD-Kommando können die Daten für den nächsten SCOPE-Aufzeichnungsvorgang definiert werden. Das Kommando wird in folgender Form benutzt:

RECORD zeit anzahl var1 [var2] [var3] [var4]

zeit: Abtastzeit in 250 µs-Schritten
anzahl: Anzahl der aufzuzeichnenden Abtastpunkte.
Die max. mögliche Anzahl hängt von der Anzahl und Größe der aufzuzeichnenden Variablen ab.
Bei Vorgabe einer zu großen Anzahl wird diese automatisch begrenzt (bei Aufzeichnung von Long/Float-Variablen können max. 512 Punkte aufgezeichnet werden).
var1,var2,var3 - Namen der aufzuzeichnenden Variablen. Außer den Namen von Makro-Variablen können folgende Namen benutzt werden:
I - Stromistwert
ICMDVAL - Stromsollwert
PE - Schleppfehler
V - Drehzahlistwert
VCMD - Drehzahlsollwert
VBUS - Zwischenkreisspannung
PFB - Positionsistwert


ASCII Deutsch RECRDY

ASCII - Kommando | RECRDY |
Syntax Senden | RECRDY |
Syntax Empfangen | RECRDY <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E1 (hex)
DIM | - | PROFIBUS PNU | 1825 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 225 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oszilloscope | EEPROM | Nein
Kurzbeschreibung | Scope: Zustand der RECORD-Funktion

Beschreibung

Nachdem die Aufzeichnung mit RECORD / RECTRIG "scharf" gemacht wurde, gibt das RECRDY-Kommando eine 0 aus. Sobald, die mit RECRDY vorgegebene Trigger-Bedingung erfüllt ist und die Aufzeichnung gestartet wurde, liefert RECRDY eine 1.
(RECRDY=0 bedeutet "warten auf Trigger-Ereignis").


ASCII Deutsch RECTRIG

ASCII - Kommando | RECTRIG |
Syntax Senden | RECTRIG [Data] |
Syntax Empfangen | RECTRIG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | ASCII String (=Mode);Depends upon Mode (=Level);0 .. 1023 (=Loc.); 0, 1 (=Dir.) | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | Nein
Kurzbeschreibung | SCOPE: Aktivieren der Aufzeichnungsfunktion

Beschreibung

Das Kommando RECTRIG bereitet eine Datenaufzeichnung für die SCOPE-Funktion vor.
Das Kommando wird in folgender Form benutzt:

RECTRIG mode level location direction

mode: bezeichnet den Namen einer Variable, die für die Triggerung der Aufzeichnung benutzt werden soll. Bei Verwendung der Bezeichnung IMM wird die Aufzeichnung sofort gestartet. In diesem Fall brauchen die Parameter "level","location" und "direction" nicht angegeben zu werden.

level: spezifiziert den Wert der Variable, der erreicht werden muß, damit die Aufzeichnung aktiviert wird.

location: gibt die Anzahl der "Punkte" an, die vor dem Auftreten des Trigger-Ereignisses aufgezeichnet werden sollen.

direction: spezifiziert die Richtung in der der Wert "level" der Variable "mode" überschritten werden soll, damit die Aufzeichnung aktiviert wird.
direction=0 fallend (Variablenwert wird unterschritten)
direction=1 steigend (Variablenwert wird überschritten)


ASCII Deutsch REFIP

ASCII - Kommando | REFIP |
Syntax Senden | REFIP [Data] |
Syntax Empfangen | REFIP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 35E2 (hex)
DIM | Amperes | PROFIBUS PNU | 1826 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. min(IPEAK,IPEAKN) | DPR | 226 (dec)
Default | min(IPEAK,IPEAKN,DICONT/2) |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Current Controller | EEPROM | Ja
Kurzbeschreibung | Spitzenstrom für die Referenzfahrt 7

Beschreibung

Mit dem Parameter REFIP kann der Spitzenstrom für die Referenzfahrt auf Anschlag definiert werden. Beim Start der Referenzfahrt Nr 7 (auf Anschlag mit Nullpunktsuche) wird der aktuelle Wert des Spitzenstromes IPEAK auf den Wert REFIP gesetzt. Nachdem die Referenzfahrt abgeschlossen wurde, wird der Parameter IPEAK auf den ursprünglichen Wert gesetzt.

Dieser Parameter wird auch dazu benutzt, bei FBTYPE=7 (Wake&Shake-Modus) den Strom zu begrenzen. Wenn der Wake&Shake gestartet wird, wird IPEAK auf REFIP gesetzt und nach Beendigung des Modus, wird der alte Wert von IPEAK wieder eingesetzt.


ASCII Deutsch REFLS

ASCII - Kommando | REFLS |
Syntax Senden | REFLS [Data] |
Syntax Empfangen | REFLS <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365D (hex)
DIM | - | PROFIBUS PNU | 1949 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 349 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Hardware-Endschalterverhalten bei Referenzfahrt

Beschreibung

Mit dem Parameter REFLS kann das Verhalten des Verstärkers beim
Aktivwerden eines Hardware-Endschalters während der Referenzfahrt
definiert werden:

REFLS=0 Umdrehen der Fahrtrichtung am NSTOP und PSTOP
REFLS=1 Umdrehen der Fahrtrichtung am PSTOP, NSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=2 Umdrehen der Fahrtrichtung am NSTOP, PSTOP generiert die Fehlermeldung F26 (Limit Switch)
REFLS=3 NSTOP und PSTOP generieren die Fehlermeldung F26 (Limit Switch)

Gilt bei Referenzfahrtarten 1 und 3


ASCII Deutsch REFMODE

ASCII - Kommando | REFMODE |
Syntax Senden | REFMODE [Data] |
Syntax Empfangen | REFMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 363C (hex)
DIM | - | PROFIBUS PNU | 1916 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3, 4, 5, 6, 7 | DPR | 316 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Quelle des Nullimpulse bei Referenzfahrt

Beschreibung

Das Kommando REFMODE bestimmt die Quelle des Nullimpulses während der Ausführung einer Referenzfahrt.

REFMODE=0 Resolver- oder Singleturn-Encoder-Nulldurchgang, Nulldurchgang pro Umdrehung bei Multiturn-Encoder bei EXTPOS=1 Data-Pin X1-Stecker
REFMODE=1 digitaler Eingang INPUT1
REFMODE=2 digitaler Eingang INPUT2
REFMODE=3 digitaler Eingang INPUT3
REFMODE=4 digitaler Eingang INPUT4
REFMODE=5 Data-Pin des X1-Steckers
REFMODE=6 Nullimpuls des X5-Steckers bei ENCMODE=0
REFMODE=7 Nulldurchgang des Multiturn Absolutwertgebers (pro Umdrehung)


ASCII Deutsch REFPOS

ASCII - Kommando | REFPOS |
Syntax Senden | REFPOS |
Syntax Empfangen | REFPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35E3 (hex)
DIM | Counts | PROFIBUS PNU | 1827 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1048575 | DPR | 227 (dec)
Default | - |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Referenzschalter-Position

Beschreibung

Das Kommando REFPOS liefert die Position (20 Bit, innerhalb einer Umdrehung) an der während der Referenzfahrt das "Referenzkriterium" erkannt wurde. Das "Referenzkriterium" hängt von der Referenzfahrtart NREF ab.

NREF=0,5,6 REFPOS = Position an der die Referenzfahrt gestartet wurde
NREF=1,3 REFPOS = Position an der die steigende Flanke des Referenzschalters erkannt wurde
NREF=2,4 REFPOS = Position an der die fallende Flanke des Endschalters erkannt wurde
NREF=7 REFPOS = Position an der ein Anschlag erkannt wurde (PE>PEMAX / 2)
NREF=8 REFPOS wird nicht verändert


ASCII Deutsch REMOTE

ASCII - Kommando | REMOTE |
Syntax Senden | REMOTE |
Syntax Empfangen | REMOTE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35E4 (hex)
DIM | - | PROFIBUS PNU | 1828 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1 | DPR | 228 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Zustand des Hardware-Enable

Beschreibung

Das Kommando REMOTE spiegelt den Zustand des Hardware-Enable-Eingangs wieder. Eine 1 bedeutet einen High-Zustand des Eingangs (Hardware-Enable gesetzt), eine 0 einen Low-Zustand.


ASCII Deutsch RESOLVER

ASCII - Kommando | RESOLVER |
Syntax Senden | RESOLVER [Data] |
Syntax Empfangen | RESOLVER <Data> | Vorhanden in |
Type | rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | Nein
DIM |  | PROFIBUS PNU | Nein
Bereich | 0 ... 2 | DPR | Nein
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung |

Beschreibung

RESOLVER 0 reduziert die Erregung um 20%.
RESOLVER 2 erhöht die Erregung um 20%.


ASCII Deutsch RESPHASE

ASCII - Kommando | RESPHASE |
Syntax Senden | RESPHASE [Data] |
Syntax Empfangen | RESPHASE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E5 (hex)
DIM | - | PROFIBUS PNU | 1829 (dec) IND = 0000xxxx (bin)
Bereich | -300 .. 50 | DPR | 229 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Resolverphase

Beschreibung


ASCII Deutsch RK

ASCII - Kommando | RK |
Syntax Senden | RK [Data] |
Syntax Empfangen | RK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E6 (hex)
DIM | Counts | PROFIBUS PNU | 1830 (dec) IND = 0000xxxx (bin)
Bereich | 12000 ..19000 | DPR | 230 (dec)
Default | 16384 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Verstärkungsfaktor Resolver-Sinussignal

Beschreibung

Mit dem Parameter RK kann der ggf. vorhandene Amplitudenunterschied zwischen dem Sinus- und Cosinussignal des Resolvers ausgeglichen werden. Es gelten folgende Abhängigkeiten:
RK = 16384 keine Veränderung der Sinus-Amplitude
RK < 16384 Sinussignal wird abgeschwächt
RK > 16384 Sinussignal wird verstärkt

Eine falsche Einstellung dieses Korrekturfaktors führt zu Geschwindigkeitsschwankungen (Rippel) die stark positionsabhängig sind.
Das Kommando CALCRK ermöglicht eine automatische Ermittlung des Korrekturfaktors RK.

Dieser Wert wird bei einem Download von Parametern nicht verändert, da er nur geräteabhängig ist.


ASCII Deutsch ROFFS

ASCII - Kommando | ROFFS |
Syntax Senden | ROFFS [Data] |
Syntax Empfangen | ROFFS | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35E7 (hex)
DIM | µm | PROFIBUS PNU | 1831 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 231 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzoffset

Beschreibung

Je nach der Art des eingesetzten Lageregler-Positionsgebers erfüllt der Parameter ROFFS unterschiedliche Funktionen:

1. Resolver oder Single-Turn-Geber (Referenzfahrt möglich)
Mit dem Parameter ROFFS kann der Referenzposition (Nullposition), die am Ende der Referenzfahrt erreicht wird, eine beliebige absolute Position zugeordnet werden.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab.
Falls die Auflösung auf 1 gesetzt wird (PGEARI=PGEARO) so werden grundsätzlich interne Einheiten (Counts) verwendet.

2. Absolutwertgeber (Multi-Turn, auch mit Referenzfahrt)
Falls der Positionswert des Absolutwertgebers verändert werden muß, so kann dies mit Hilfe der Variable ROFFS erreicht werden. Beim Einschalten des Verstärkers wird der Wert der ROFFS-Variable einmalig zu dem Positionswert des Absolutwertgebers addiert. Da diese Korrektur nur beim Einschalten des Verstärkers durchgeführt wird, muß nach jeder Änderung der ROFFS-Variable, der Parameterwert im EEPROM abgespeichert (Kommando SAVE) und der Verstärker aus- und eingeschaltet werden (Kommando COLDSTART).

Beispiel:
Wenn beim Einschalten des Verstärkers und ROFFS=0 eine Position von 10000 angezeigt wird, so wird durch Eingabe von ROFFS –10000, die Position auf den Wert 0 verschoben.


ASCII Deutsch ROFFS0

ASCII - Kommando | ROFFS0 |
Syntax Senden | ROFFS0 [Data] |
Syntax Empfangen | ROFFS0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365C (hex)
DIM | - | PROFIBUS PNU | 1948 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 348 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Referenz Offset für den zweiten Geber

Beschreibung

Mit dem Parameter ROFFS0 kann eine absolute Referenz-Position für einen externen Geber definiert werden. Die Position die vom externen Geber eingelesen wird (PFB0), wird nach der Ausführung einer Referenzfahrt auf den Wert ROFFS0 gesetzt. Diese Funktion ist nur beim Einlesen des externen Gebers (EXTPOS 2,3) aktiviert.


ASCII Deutsch ROFFS2

ASCII - Kommando | ROFFS2 |
Syntax Senden | ROFFS2 [Data] |
Syntax Empfangen | ROFFS2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3656 (hex)
DIM | PUNIT | PROFIBUS PNU | 1942 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 342 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Gearing | EEPROM | Ja
Kurzbeschreibung | Positionsoffset bei "Absoluter Getriebefunktion"

Beschreibung

IN VORBEREITUNG

Mit dem Parameter ROFFS2 kann die absolute SSI-Position der Master-Achse für den Master/Slave-Betrieb angepasst werden. Dieser Parameter wird nur bei der Ausführung der Referenzfahrt NREF=8 (Fahren auf absolute SSI-Position) benutzt.
Bei dem Start der Referenzfahrt wird eine absolute SSI-Position (GEARMODE=7) von der Master-Achse eingelesen und mit den Ausflösungfaktoren PGEARI / PGEARO verrechnet. Zu der so errechneten Position wird der Offsetwert ROFFS2 addiert und eine Fahrt zu der Zielposition gestartet.


ASCII Deutsch RS232T

ASCII - Kommando | RS232T |
Syntax Senden | RS232T [Data] |
Syntax Empfangen | RS232T <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35E8 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1832 (dec) IND = 0000xxxx (bin)
Bereich | 1 .. 5000 | DPR | 232 (dec)
Default | 2500 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Communication | EEPROM | Ja
Kurzbeschreibung | Watch-Dog Zeit (RS232)

Beschreibung

Bei aktivierten Überwachung der seriellen Schnittstelle (RS232-Watchdog) kann mit dem Kommando RS232T die Watchdog-Überwachungszeit eingestellt werden.
s. auch ACTRS232


ASCII Deutsch RSTVAR

ASCII - Kommando | RSTVAR |
Syntax Senden | RSTVAR |
Syntax Empfangen | RSTVAR | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35E9 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 233 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Setzen aller Parameter auf Default-Werte

Beschreibung

Das Kommando RSTVAR setzt alle Parameter auf die internen Werkseinstellungen zurück. Die Parameter, die im EEPROM abgespeichert sind, werden davon zunächst nicht betroffen. Erst mit dem Kommando SAVE (abspeichern der Parameter im EEPROM) werden die Default-Einstellungen dauerhaft übernommen.


ASCII Deutsch RXPDO1A

ASCII - Kommando | RXPDO1A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO1A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 1 Parameterauswahl

Beschreibung

Mit dem Kommando RXPDO1A werden die folgenden für das CANopen-PDO RX-PDO 1
relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Receive-PDO 1 (2600, 0), dezimal
2. COB-Identifier für das Receive-PDO 1 (1400, 1), hexadezimal
3. Transmission type für Receive-PDO 1 (1400, 2), dezimal
4. Inhibit time für Receive-PDO 1 (1400, 3), dezimal
5. Priority group für Receive-PDO 1 (1400, 4), dezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: RXPDO1A
Schreiben: Kommando: RXPDO1A 1 0x201 255 0 2, es müssen immer alle Parameter
angegeben werden


ASCII Deutsch RXPDO1B

ASCII - Kommando | RXPDO1B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO1B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 1 Mapping Einstellung

Beschreibung

Mit dem Kommando RXPDO1B kann das Mapping des CANopen-PDOs RX-PDO 1
eingestellt werden (in Klammern: zugehörige SDOs):

Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde,
z.B. über RXPDO1A.

Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando:

RXPDO1B

Man erhält das gerade vorliegende Mapping in der Form:

6040002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.:

RXPDO1B 6040002 6060001

zur Einstellung des CANopen Steuerworts und der CANopen-Betriebsart über das
RX-PDO 1.


ASCII Deutsch RXPDO2A

ASCII - Kommando | RXPDO2A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO2A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 2 Parameterauswahl

Beschreibung

Mit dem Kommando RXPDO2A werden die folgenden für das CANopen-PDO RX-PDO 2
relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Receive-PDO 2 (2600, 0), dezimal
2. COB-Identifier für das Receive-PDO 2 (1400, 1), hexadezimal
3. Transmission type für Receive-PDO 2 (1400, 2), dezimal
4. Inhibit time für Receive-PDO 2 (1400, 3), dezimal
5. Priority group für Receive-PDO 2 (1400, 4), dezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: RXPDO2A
Schreiben: Kommando: RXPDO2A 1 0x201 255 0 2, es müssen immer alle Parameter
angegeben werden


ASCII Deutsch RXPDO2B

ASCII - Kommando | RXPDO2B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO2B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 2 Mapping Einstellung

Beschreibung

Mit dem Kommando RXPDO2B kann das Mapping des CANopen-PDOs RX-PDO 2
eingestellt werden (in Klammern: zugehörige SDOs):

Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde,
z.B. über RXPDO2A.

Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando:

RXPDO2B

Man erhält das gerade vorliegende Mapping in der Form:

6040002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.:

RXPDO2B 6040002 6060001

zur Einstellung des CANopen Steuerworts und der CANopen-Betriebsart über das
RX-PDO 2.


ASCII Deutsch RXPDO3A

ASCII - Kommando | RXPDO3A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO3A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 3 Parameterauswahl

Beschreibung

Mit dem Kommando RXPDO3A werden die folgenden für das CANopen-PDO RX-PDO 3
relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Receive-PDO 3 (2600, 0), dezimal
2. COB-Identifier für das Receive-PDO 3 (1400, 1), hexadezimal
3. Transmission type für Receive-PDO 3 (1400, 2), dezimal
4. Inhibit time für Receive-PDO 3 (1400, 3), dezimal
5. Priority group für Receive-PDO 3 (1400, 4), dezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: RXPDO3A
Schreiben: Kommando: RXPDO3A 1 0x201 255 0 2, es müssen immer alle Parameter
angegeben werden


ASCII Deutsch RXPDO3B

ASCII - Kommando | RXPDO3B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO3B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 3 Mapping Einstellung

Beschreibung

Mit dem Kommando RXPDO3B kann das Mapping des CANopen-PDOs RX-PDO 3
eingestellt werden (in Klammern: zugehörige SDOs):

Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde,
z.B. über RXPDO3A.

Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando:

RXPDO3B

Man erhält das gerade vorliegende Mapping in der Form:

6040002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.:

RXPDO3B 6040002 6060001

zur Einstellung des CANopen Steuerworts und der CANopen-Betriebsart über das
RX-PDO 3.


ASCII Deutsch RXPDO4A

ASCII - Kommando | RXPDO4A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO4A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 4 Parameterauswahl

Beschreibung

Mit dem Kommando RXPDO4A werden die folgenden für das CANopen-PDO RX-PDO 4
relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Receive-PDO 4 (2600, 0), dezimal
2. COB-Identifier für das Receive-PDO 4 (1400, 1), hexadezimal
3. Transmission type für Receive-PDO 4 (1400, 2), dezimal
4. Inhibit time für Receive-PDO 4 (1400, 3), dezimal
5. Priority group für Receive-PDO 4 (1400, 4), dezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: RXPDO4A
Schreiben: Kommando: RXPDO4A 1 0x201 255 0 2, es müssen immer alle Parameter
angegeben werden

Anmerkung: Nur bei MDRV = 0 verfügbar !


ASCII Deutsch RXPDO4B

ASCII - Kommando | RXPDO4B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | RXPDO4B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | RX-PDO 4 Mapping Einstellung

Beschreibung

Mit dem Kommando RXPDO4B kann das Mapping des CANopen-PDOs RX-PDO 4
eingestellt werden (in Klammern: zugehörige SDOs):

Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde,
z.B. über RXPDO4A.

Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando:

RXPDO4B

Man erhält das gerade vorliegende Mapping in der Form:

6040002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.:

RXPDO4B 6040002 6060001

zur Einstellung des CANopen Steuerworts und der CANopen-Betriebsart über das
RX-PDO 4.

Anmerkung: Nur bei MDRV = 0 verfügbar !


ASCII Deutsch S

ASCII - Kommando | S |
Syntax Senden | S |
Syntax Empfangen | S | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EA (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 234 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Stop und Disable

Beschreibung

Mit dem Kommando S wird der Antrieb angehalten (Bremsrampe DECSTOP). Sobald die Stillstandsschwelle (VEL0) unterschritten wurde, wird die Endstufe gesperrt.
Das Kommando S entspricht dem Kommando K (bzw. DIS) wenn die Option STOPMODE auf 1 steht.


ASCII Deutsch SAVE

ASCII - Kommando | SAVE |
Syntax Senden | SAVE |
Syntax Empfangen | SAVE | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35EB (hex)
DIM | - | PROFIBUS PNU | 1835 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 235 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Speichern der Daten im EEPROM

Beschreibung

Mit dem Kommando SAVE werden die aktuellen Einstellungen der Verstärkerparameter im seriellen EEPROM abgespeichert. Gleichzeitig wird die Checksumme für das Parameterfeld aktualisiert und im seriellen EEPROM abgelegt. Der Speichervorgang dauert ca. 2 Sekunden. Während dieser Zeit darf die Versorgungsspannung (24 V) des Verstärkers nicht ausgeschaltet werden. Beim Ausschalten der Versorgungsspannung während des Speichervorganges werden u.U. keine gültigen Daten im seriellen EEPROM abgelegt. Beim nächsten Einschalten des Gerätes wird ein Checksummenfehler festgestellt und die Fehlermeldung F09 (EEPROM-Fehler) generiert.
Darüber hinaus werden alle Verstärkerparameter auf interne Default-Werte gesetzt. Um den Fehler F09 zurückzusetzen muß erneut das SAVE-Kommando ausgeführt und der Verstärker aus- und eingeschaltet werden.


ASCII Deutsch SERIALNO

ASCII - Kommando | SERIALNO |
Syntax Senden | SERIALNO |
Syntax Empfangen | SERIALNO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35EF (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 0000xxxx (bin)
Bereich | 10 ASCII characters | DPR | 239 (dec)
Default | Factory default |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Seriennummer des Verstärkers

Beschreibung

Seriennummer des Verstärkers


ASCII Deutsch SETREF

ASCII - Kommando | SETREF |
Syntax Senden | SETREF |
Syntax Empfangen | SETREF | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35F0 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 240 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Setzen des Referenzpunktes

Beschreibung

Mit dem Kommando SETREF wird die aktuelle Position zum Referenzpunkt erklärt (d.h. die aktuelle Position wird auf den Wert ROFFS gesetzt) und das Bit welches ein Fahren von Fahrsätzen ermöglicht, wird gesetzt.
Das SETREF-Kommando entspricht der Ausführung einer Referenzfahrt mit NREF=0.


ASCII Deutsch SETROFFS

ASCII - Kommando | SETROFFS |
Syntax Senden | SETROFFS |
Syntax Empfangen | - | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | 35F1 (hex)
DIM | - | PROFIBUS PNU | 1841 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 241 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Automatische Korrektur von ROFFS

Beschreibung

Mit dem Kommando SETROFFS wird die Referenzoffset-Variable ROFFS
um den Wert der aktuellen Position (PFB) korrigiert. Damit kann der Referenzoffset automatisch den mechanischen Gegebenheiten angepaßt werden.

Beispiel 1:

ROFFS=0 PFB=100
nach SETROFFS ROFFS=-100

Beispiel 2:

ROFFS=100 PFB=70
nach SETROFFS ROFFS=30


ASCII Deutsch SETVCT

ASCII - Kommando | SETVCT |
Syntax Senden | SETVCT [Data] |
Syntax Empfangen | SETVCT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3635 (hex)
DIM | - | PROFIBUS PNU | 1909 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 7 | DPR | 309 (dec)
Default | 0 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Anwahl eines VCT-Eintrages

Beschreibung

IN VORBEREITUNG !

Mit dem Kommando SETVCT kann ein Eintrag der VC-Tabelle (Drehzahlsollwert/Strombegrenzung) aktiviert werden.
Die VC-Tabelle enthält 8 Drehzahl/Strom-Paare (VCT-Einträge).
Wenn ein VCT-Eintrag aktiviert wird, so wird die in dem Eintrag enthaltene Drehzahl als digitaler Drehzahlsollwert übernommen (nur bei OPMODE=0 möglich). Der Stromwert aus dem VCT-Eintrag wird als Strombegrenzung übernommen.
Bei analogen Drehzahlvorgaben (OPMODE=1) wird der Drehzahlsollwert ignoriert, der Stromwert wird aber weiterhin für die Strombegrenzung benutzt.

Bei Eingabe des Kommandos SETVCT ohne zusätzliche Parameter wird die Nummer des zur Zeit aktiven VCT-Eintrages angezeigt.

s. auch Beschreibung des Kommandos VCTAB


ASCII Deutsch Kurzbeschreibung

\ | Anwahl der Remote Adresse
ACC | Beschleunigungsrampe Drehzahlregelung
ACCR | Beschleunigungsrampe Referenzfahrt/Tippbetrieb
ACCUNIT | Art der Beschleunigungsvorgabe im System
ACTFAULT | Fehler Stop Modus
ACTIVE | Endstufe freigegeben/gesperrt
ACTRS232 | Freigabe des RS232-Watchdogs
ADDR | Stationsadresse
AENA | Initialisierungszustand der Software-Freigabe
ALIAS | Symbolischer Verstärker-Name
AN11NR | Nr. der INxTRIG Variable, bei analoger Vorgabe
AN11RANGE | Bereich für die analoge Änderung von INxTRIG
ANCNFG | Konfiguration der analogen Eingänge
ANDB | Totband für den analogen Drehzahlsollwert
ANIN1 | Spannung am Analog-Eingang SW1
ANIN2 | Spannung am Analog-Eingang SW2
ANOFF1 | Analogoffset für den Analogeingang SW1
ANOFF2 | Analogoffset für den Analogeingang SW2
ANZERO1 | Offsetabgleich für den Analogeingang SW1
ANZERO2 | Offsetabgleich für den Analogeingang SW2
AUTOHOME |
AVZ1 | Filter-Zeitkonstante für den Analogeingang SW1
BCC | EEPROM-Checksumme
CALCCOG | Erfassen der Cogging - Tabelle
CALCHP | Ermittlung der Hiperface-Parameter
CALCRK | Ermittlung der Resolverparameter
CALCRP | Ermittlung der Resolverphase
CBAUD | Übertragungsrate CAN-Bus
CLRFAULT | Löschen des Verstärker-Fehlers
CLRHR | Löschen des Bit 5 im Statutsregister STAT
CLRORDER | Löschen eines Fahrsatzes
COGGING | Freischalten der Cogging - Kompensation
COLDSTART | Hardware-Reset des Verstärkers
CONTINUE | Fortsetzen des letzten Fahrauftrages
CPHASE | Deaktivierung der Motorphasenüberwachung
CTUNE | Optimierung der Stromreglerparameter
CUPDATE | Programm-Update über CAN-Bus
DEC | Bremsrampe für den Drehzahlsollwert
DECDIS | Drehzahl-Bremsrampe beim Sperren der Endstufe
DECR | Bremsrampe für Referenzfahrt/Tippbetrieb
DECSTOP | Bremsrampe in Nothaltsituation
DENA | DPR Software Disable Reset Modus
DI2T | Regler I2T Auslastung
DICONT | Geräte-Nennstrom
DIFVAR | Parameterunterschiede zu den Default-Einstellungen
DILIM | DPR Strombegrenzung aktivieren
DIPEAK | Geräte-Spitzenstrom
DIS | Software Disable der Endstufe
DISDPR | Disablen des DPR-Zugriffs für Schreibbefehle
DNBAUD | DeviceNet Baudrate
DNDUMP | Debugging Information DeviceNet
DNMACID |
DOVRIDE | Vorgabe eines digitalen Override-Faktors
DPRILIMIT | Digitale Begrenzung des Spitzenstroms über DPR
DR_TYPE | Liefert die Endstufenkennung
DREF | Fahrtrichtung für die Referenzfahrt
DRVCNFG | Konfigurationsvariable für CAN-Bus Kompatibilität
DUMP | Auflistung aller EEPROM-Variablen
EGEARI |
EGEARO |
EMRGTO |
EN | Setzen des Software-Enable
ENCLINES | Auflösung eines Sincos-Gebers
ENCMODE | Auswahl der Encoder-Emulation
ENCOUT | Auflösung für die Encoder-Emulation (ROD)
ENCZERO | Nullimpulsoffset (ROD-Ausgabe)
ERND | Endposition Modulo-Achse
ERRCODE | Ausgabe der aktiven Fehlermeldungen
ERRCODE * | Ausgabe des Fehlerregisters
ESPEED | Maximale Drehzahl in Abhängigkeit vom Gebertyp
EXTWD | Überwachungszeit für Feldbus-Befehle
FBTYPE | Vorwahl der Rückführeinheit
FLASH |
FLTCNT | Fehlerstatistik: Fehleranzahl
FLTCNT * | Fehlerstatistik: Fehleranzahl
FLTHIST | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLTHIST * | Fehlerstatistik: Anzeige der letzten 10 Fehler
FLUXM | Nennfluss des Synchronmotors
FW | Liefert die Versionsnummer der Firmware
GEARFILT |
GEARI | Eingangsfaktor "elekronisches Getriebe"
GEARMODE | Masterschnittstelle für "elektronisches Getriebe"
GEARO | Ausgangsfaktor "elekronisches Getriebe"
GET | Ausgabe der aufgezeichneten SCOPE-Daten
GF | Proportionalverstärkung des Flussreglers
GFTN | Nachstellzeit des Flussreglers
GP | Lageregler: Proportionalverstärkung
GPFFT | Stromvorsteuerung - Positionsregelkreis
GPFFV | Lageregler: Vorsteuerung Drehzahl
GPRED |
GPTN | Lageregler: Nachstellzeit
GV | Drehzahlregler: Proportionalverstärkung
GVTN | Drehzahlregler: Nachstellzeit
HDUMP | Ausgabe aller SinCos Variablen
HELP | Ausgabe der Parameter-Hilfe-Information
HICOFFS | Hiperface: Cosinus-Offset (Inkrementalspur)
HIFACT1 | Hiperface: Sinus/Cosinus-Faktor (Inkrementalspur)
HISOFFS | Hiperface: Sinus-Offset (Inkrementalspur)
HSAVE | Hiperface: Speichern der Parameter im Geber
HVER | Ausgabe der Hardware-Version
I | Stromistwert
I2TLIM | I2t-Meldeschwelle
ICMD | Stromsollwert
ICMDVLIM | Drehzahlbegrenzung im Stromreglermode
ID | D-Anteil vom Strom-Istwert
IN | Anzeige der A/D-Spannungen
IN1 | Zustand des digitalen Eingangs INPUT1
IN1HCMD | Kommando-Buffer für High-Pegel
IN1LCMD | Kommando-Buffer für Low-Pegel
IN1MODE | Funktion des digitalen Eingangs INPUT1
IN1TRIG | Hilfsvariable für IN1MODE
IN2 | Zustand des digitalen Eingangs INPUT2
IN2HCMD | Kommando-Buffer für High-Pegel
IN2LCMD | Kommando-Buffer für Low-Pegel
IN2MODE | Funktion des digitalen Eingangs INPUT2
IN2PM | Modus In-Position 2
IN2TRIG | Hilfsvariable für IN2MODE
IN3 | Zustand des digitalen Eingangs INPUT3
IN3HCMD | Kommando-Buffer für High-Pegel
IN3LCMD | Kommando-Buffer für Low-Pegel
IN3MODE | Funktion des digitalen Eingangs INPUT3
IN3TRIG | Hilfsvariable für IN3MODE
IN4 | Zustand des digitalen Eingangs INPUT4
IN4HCMD | Kommando-Buffer für High-Pegel
IN4LCMD | Kommando-Buffer für Low-Pegel
IN4MODE | Funktion des digitalen Eingangs INPUT4
IN4TRIG | Hilfsvariable für IN3MODE
INPOS | In-Position-Meldung
INPT | In-Position-Verzögerung
INS0 | Status von Eingang A0 der I/O Erweiterungskarte
INS1 | Status von Eingang A1 der I/O Erweiterungskarte
INS2 | Status von Eingang A2 der I/O Erweiterungskarte
INS3 | Status von Eingang A3 der I/O Erweiterungskarte
INS4 | Status von Eingang A4 der I/O Erweiterungskarte
INS5 | Status von Eingang A5 der I/O Erweiterungskarte
INS6 | Status von Eingang A6 der I/O Erweiterungskarte
INS7 | Status von Eingang A7 der I/O Erweiterungskarte
INS8 | Status von FSTART_IO der I/O Erweiterungskarte
IPEAK | Spitzenstrom
IPEAKN | Negative Spitzenstrombegrenzung
IPEAKP | Max.positiver Impulsstrom des Motors in A rms
IQ | Q-Anteil des Stromistwertes
ISCALE1 | Skalierungsfaktor für den analogen Stromsollwert 1
ISCALE2 | Skalierungsfaktor für den analogen Stromsollwert 2
ISTFR | Drehzahlabhängige Reibungskompensation
J | Service-Funktion "konstante Drehzahl"
K | Software-Sperre der Endstufe
KC | Stromistwert-Vorsteuerung Stromregler
KEYLOCK | Sperre für die Tastenbedienung
KTN | Integralanteil des Stromreglers
LASTWMASK | Fehlerspeicher von WMASK
LATCH32 | Gelachte 32 Bit-Position (positive Flanke)
LATCH32N | Gelachte 32 Bit-Position (negative Flanke)
LATCHX32 | Gelatchte 32 Bit-Position (positive Flanke)
LATCHX32N | Gelachte 32 Bit-Position (negative Flanke)
LDUMP | Parameterausgabe eines Motordatensatzes
LED1 | Anzeigestatus des LED1-Segmentes
LED2 | Anzeigestatus des LED2-Segmentes
LED3 | Anzeigestatus des LED3-Segmentes
LEDSTAT | Seitennummer für das LED-Display
LIST | Auflistung aller ASCII-Kommandos
LOAD | Laden der Parameter aus dem seriellen EEPROM
M | Lesen/Schreiben einer Macro-Variable
M_1000 | Listing des 1msek Macro-Programmes
M_125 | Listing des 125 usek Macro-Programmes
M_1600 | Listing des 16 msek Macro-Programmes
M_250 | Listing des 250 usek Macro-Programmes
M_250p | Listing des 250p usek Macro-Programmes
M_4000 | Listing des 4 msek Macro-Programmes
M_DISABLE | Listing des Disable Macro-Programmes
M_ENABLE | Listing des Enable Macro-Programmes
M_INIT | Listing der Macro-Initialisierungsfunktion
M_IRQ | Listing der Macro-Interruptfunktion
M_RESET | Neuübersetzung der Macro-Programme
M_SMACRO | Anzeige der verfügbaren System-Macros
M_TASK | Listing des Macro-Hauptprogrammes
M_UMACRO | Anzeige der verfügbaren User-Macros
MAXSDO | Anzahl der Objekte im Parameterkanal
MAXTEMPE | Abschaltwert der Umgebungstemperatur
MAXTEMPH | Abschaltwert der Kühlkörpertemperatur
MAXTEMPM | Abschaltwert der Motortemperatur (Widerstand)
MBRAKE | Vorwahl für Motorbremse
MDBCNT | Anzahl der Motorsätze
MDBGET | Info-Zeile für einen Motordatensatz
MDBLIST | Inhaltsverzeichnis der Motordatenbank
MDBSET | Vorwahl eines Motordatensatzes
MDUMP | Anzeige der aktuellen Motorparameter
MH | Start der Referenzfahrt
MI2T | Motor I2T Auslastung
MICONT | Motor Nennstrom
MIMR | Magnetisierungsstrom (Asynchronmotor)
MIPEAK | Motor Spitzenstrom
MJ | Massenträgheitsmoment des Motors
MJOG | Start des Tippbetriebes
MKT | Motor KT
ML | Statorinduktivität des Motors
MLGC | Relative Stromreglerverstärkung bei Dauerstrom
MLGD | Relative Stromreglerverstärkung des D-Stromreglers
MLGP | Relative Stromreglerverstärkung bei Spitzenstrom
MLGQ | Absolute Verstärkung des Stromreglers
MNAME | Motor-Name
MNUMBER | Laden eines Motor-Datensatzes
MOVE | Starten eines Fahrsatzes
MPHASE | Phasenlage des Feedback-Systems zum Motor
MPOLES | Anzahl der Motorpole
MRESBW | Resolver-Bandbreite
MRESPOLES | Anzahl der Resolverpole
MRS | Wicklungswiderstand des Stators Phase-Phase
MSERIALNO | Motorseriennummer bei Encoder mit Parameterkanal
MSG | RS232-Ausgabe der Warnungen/Fehlermeldungen
MSLBRAKE | Bremsrampe bei sensorlosem Nothalt
MSPEED | Motor Maximaldrehzahl
MTANGLP | Stromvoreilung
MTIME | Thermische Zeitkonstante des Motors
MTMUX | Voreinstellung für zu bearbeitenden Fahrsatz
MTR | Rotorzeitkonstante
MTYPE | Art des Motors
MUNIT | Einheit der drehzahlabhängigen Motorparameter
MVANGLB | Drehzahlabhängige Voreilung (Einsatz Phi)
MVANGLF | Drehzahlabhängige Voreilung (Endwert Phi)
MVANGLP | Drehzahlabhängige Voreilung
MVR | Einsatzdrehzahl der Feldschwächung
NONBTB | Netz-BTB-Überprüfung ein/aus
NREF | Referenzfahrtart
NREFMT | Referenzfahrt mit automatischem Folgefahrauftrag
O_ACC1 | Beschleunigungszeit für den Fahrsatz 0
O_C | Steuervariable für den Fahrsatz 0
O_DEC1 | Bremsszeit für den Fahrsatz 0
O_FN | Folgefahrsatz-Nummer für den Fahrsatz 0
O_FT | Verzögerungszeit für den Folge-Fahrsatz
O_P | Zielposition/Verfahrstrecke für den Fahrsatz 0
O_V | Zielgeschwindigkeit für den Fahrsatz 0
O1 | Zustand des digitalen Ausgangs 1
O1MODE | Funktion des digitalen Ausgangs 1
O1TRIG | Hilfsvariable für O1MODE
O2 | Zustand des digitalen Ausgangs 1
O2MODE | Funktion des digitalen Ausgangs 2
O2TRIG | Hilfsvariable für O2MODE
OBJCO | Liest CAN-Objekte für Debug-Zwecke aus
OCOPY | Speichern der Fahrsätze
OLIST | Ausgabe der Fahrsatzdaten
OPMODE | Betriebsart des Verstärkers
OPTION | Slotkarten-Kennung
ORDER | Definition eines Fahrsatzes
OS1 | Setzen von "Posreg1" der I/O Erweiterungskarte
OS2 | Setzen von "Posreg2" der I/O Erweiterungskarte
OS3 | Setzen von "Posreg3" der I/O Erweiterungskarte
OS4 | Setzen von "Posreg4" der I/O Erweiterungskarte
OS5 | Setzen von "Posreg5" der I/O Erweiterungskarte
OVRIDE | Override-Funktion
P1...P16 | schnelle Positionsschwelle 1...16
PASS | Password Eingabe
PASSCNFG | Passwort Funktion
PASSX | Passwort-Schutz aktivieren
PBAL | Istwert der Ballastleistung
PBALMAX | Maximale Ballastleistung
PBALRES | Vorwahl des Ballastwiderstandes
PE | Istwert des Schleppfehlers
PEINPOS | In-Position-Fenster
PEMAX | Max. Schleppfehler
PFB | aktuelle Lagereglerposition
PFB0 | Lagereglerposition über den externen Encoder
PGEARI | Lageregler-Auflösung (Zähler)
PGEARO | Lageregler-Auflösung (Nenner)
PMODE | Netz-Phase Modus
PNOID | Profibus-Kennung (ID)
POP | Erzeugen eines Stromsprunges
POPI | Vorgabe des Stromes für das POP - Kommando
POPI2 | Vorgabe des Stromes für das POP - Kommando
POPV | Vorgabe der max. Drehzahl für das POP - Kommando
POSCNFG | Achsentyp
POSRSTAT | Status der schnellen Positionsregister 1...16
PPOTYP | Profibus PPO-Typ
PRBASE | interne Lage-Auflösung
PRD | 20 Bit Feedback-Position
PROMPT | Vorwahl des RS232-Protokolls
PSTATE | Profibus-Status
PTARGET | letzte Fahrsatzzielposition
PTBASE | Zeitbasis für die externe Trajektorie
PTEACH | Teach-In Funktion
PTMIN | Min. Beschleunigungsrampe
PUNIT | Vorgabe der Positionsauflösung
PV | Ist-Geschwindigkeit (Lageregler)
PVMAXN | max. Geschwindigkeit für den Lageregler (negativ)
PVMAXP | max. Geschwindigkeit für den Lageregler
RDP | Aktiviere Rack Drive Panel Mode
RDPBIAS | Rack Drive Panel Verspannungsstrom
RDPCLAMP | Max Drehzahloffset von Rack Drive Panel
RDPINT | Rack Drive Panel Test Variable
RDPKI | Integralanteil des Rach Drive Panel
RDPKP | Proportionalverstärkung des Rack Drive Panel
RDPON | Test Variable Rack Drive Panel
READNIMP | Setzen des ROD-Nullimpulsoffsets
READY | Zustand von Software-Enable
RECDONE | Scope: Aufnahme beendet
RECING | Scope: Aufzeichnug läuft
RECOFF | Scope: Abbruch einer Scope-Aufzeichnung
RECORD | Scope: Definition der aufzuzeichnenden Daten
RECRDY | Scope: Zustand der RECORD-Funktion
RECTRIG | SCOPE: Aktivieren der Aufzeichnungsfunktion
REFIP | Spitzenstrom für die Referenzfahrt 7
REFLS | Hardware-Endschalterverhalten bei Referenzfahrt
REFMODE | Quelle des Nullimpulse bei Referenzfahrt
REFPOS | Referenzschalter-Position
REMOTE | Zustand des Hardware-Enable
RESOLVER |
RESPHASE | Resolverphase
RK | Verstärkungsfaktor Resolver-Sinussignal
ROFFS | Referenzoffset
ROFFS0 | Referenz Offset für den zweiten Geber
ROFFS2 | Positionsoffset bei "Absoluter Getriebefunktion"
RS232T | Watch-Dog Zeit (RS232)
RSTVAR | Setzen aller Parameter auf Default-Werte
RXPDO1A | RX-PDO 1 Parameterauswahl
RXPDO1B | RX-PDO 1 Mapping Einstellung
RXPDO2A | RX-PDO 2 Parameterauswahl
RXPDO2B | RX-PDO 2 Mapping Einstellung
RXPDO3A | RX-PDO 3 Parameterauswahl
RXPDO3B | RX-PDO 3 Mapping Einstellung
RXPDO4A | RX-PDO 4 Parameterauswahl
RXPDO4B | RX-PDO 4 Mapping Einstellung
S | Stop und Disable
SAVE | Speichern der Daten im EEPROM
SERIALNO | Seriennummer des Verstärkers
SETREF | Setzen des Referenzpunktes
SETROFFS | Automatische Korrektur von ROFFS
SETVCT | Anwahl eines VCT-Eintrages
SLEN | Optische Ausgangsleistung bei Sercos
SLOTIO | I/O-Erweiterungskarte: IN/OUT-Zustand
SMNUMBER | Gespeicherte Motornummer im Geber
SRND | Startposition Modulo-Achse
STAGECODE | Endstufenkennung
STAT | Verstärker-Statuswort
STATCODE | Anzeige der Warnungen in Klartext
STATCODE * | Statusvariable "Warnungen"
STATIO | Status der Ein/Ausgänge
STATUS | detailierte Verstärker-Statusinformation
STEP | Service-Betrieb
STOP | Setzen des Sollwertes auf 0
STOPMODE | Bremsverhalten bei Disable
SWCNFG | Konfiguration der Positionsregister 1...4
SWE1 | Positionsregister 1
SWE2 | Positionsregister 2
T | digitaler Stromsollwert
TASK | Task-Auslastung
TBRAKE | Disableverzögerungszeit bei Bremsenbetrieb
TBRAKE0 | Bremsen Lüftzeit
TEMPE | Istwert der Umgebungstemperatur
TEMPH | Istwert der Kühlkörpertemperatur
TEMPM | Istwert der Motortemperatur
TRJSTAT | Status2-Information
TRUN | Betriebsstundenzähler
TXPDO1A | TX-PDO1 Mapping - Einstellung
TXPDO1B | TX-PDO1 Mapping - Einstellung
TXPDO2A | TX-PDO2 Mapping - Einstellung
TXPDO2B | TX-PDO2 Mapping - Einstellung
TXPDO3A | TX-PDO3 Mapping - Einstellung
TXPDO3B | TX-PDO3 Mapping - Einstellung
TXPDO4A | TX-PDO4 Mapping - Einstellung
TXPDO4B | TX-PDO4 Mapping - Einstellung
UCOMP | Umkehrlose Kompensation
UPDATE | Firmware-Update über RS232
UVLTMODE | Unterspannungsmodus
V | Aktuelle Drehzahl
VBUS | Zwischenkreisspannung
VBUSBAL | Maximale Netzspannung
VBUSMAX | Maximale Zwischenkreisspannung
VBUSMIN | Minimale Zwischenkreisspannung
VBW | Ausgabe eines Bode-Diagrammes
VCMD | interner Drehzahlsollwert in UPM
VCOMM | Drehzahlschwelle für Kommutierungsüberwachung
VCTAB | Definition eines VCT-Eintrages
VEL0 | Stillstandsschwelle
VER | Firmware-Version
VJOG | Tippbetrieb-Geschwindigkeit
VLIMN | Max. negative Drehzahl
VLIMP | Max. Drehzahl
VLO | Software Resolver/Digital Wandler Vorsteuerung
VMIX | Geschwindigkeitmix Feedback / externer Geber
VOSPD | Überdrehzahl
VREF | Referenzfahrt-Geschwindigkeit
VREF0 | Reduzierfaktor Referenzfahrgeschwindigkeit
VSCALE1 | SW1-Drehzahlskalierungsfaktor
VSCALE2 | SW2-Drehzahlskalierungsfaktor
VSTFR | Drehzahleckpunkt bei Reibungskompensation
VTUNE | Ermittlung der Drehzahlreglerparameter
VUNIT | Systemweite Definition der Drehzahl / Geschw.
WMASK | Warnung/Fehler-Maske
WPOS | Freigabe der schnellen Positionsregister
WPOSE | Freigabe der schnellen Positionsregister 1...16
WPOSP | Polarität der schnellen Positionsregister 1...16
WPOSX | Modus der schnellen Positionsregister 1...16


ASCII Deutsch SLEN

ASCII - Kommando | SLEN |
Syntax Senden | SLEN [Data] |
Syntax Empfangen | SLEN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer8 | CANBus Objektnummer | 35F2 (hex)
DIM | m | PROFIBUS PNU | 1842 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 45 | DPR | 242 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Sercos | EEPROM | Ja
Kurzbeschreibung | Optische Ausgangsleistung bei Sercos

Beschreibung

Mit diesem Parameter kann man die optische Ausgangsleistung in Metern für eine genormte 1mm² Plastikfaserkabel einstellen.


ASCII Deutsch SLOTIO

ASCII - Kommando | SLOTIO |
Syntax Senden | SLOTIO |
Syntax Empfangen | SLOTIO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 35F3 (hex)
DIM | - | PROFIBUS PNU | 1843 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 243 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | I/O-Erweiterungskarte: IN/OUT-Zustand

Beschreibung

Das Kommando SLOTIO liefert die Zustände der Ein-/Ausgänge der I/O-Erweiterungsplatine (Format Hxxxxxxxx).
Bit-Nummer Bitkombination Input/Output Beschreibung
0 0x00000001 Input Bit 0 Fahrsatznummer (A0)
1 0x00000002 Input Bit 1 Fahrsatznummer (A1)
2 0x00000004 Input Bit 2 Fahrsatznummer (A2)
3 0x00000008 Input Bit 3 Fahrsatznummer (A3)
4 0x00000010 Input Bit 4 Fahrsatznummer (A4)
5 0x00000020 Input Bit 5 Fahrsatznummer (A5)
6 0x00000040 Input Bit 6 Fahrsatznummer (A6)
7 0x00000080 Input Bit 7 Fahrsatznummer (A7)
8 0x00000100 Input Referenzschalter
9 0x00000200 Input Quittieren des Schleppfehlers
10 0x00000400 Input Starten des Folgefahrsatzes
11 0x00000800 Input Starten des Tippbetriebes
12 0x00001000 Input Fortsetzen eines Fahrsatzes
13 0x00002000 Input Starten des Fahrsatzes Nr. A0...A7
14 0x00004000 Output Meldung „In-Position“
15 0x00008000 Output Meldung „In-Position2“ (Folge)
16 0x00010000 Output Meldung „Schleppfehler“
17 0x00020000 Output Meldung „Positionsregister 1“
18 0x00040000 Output Meldung „Positionsregister 2“
19 0x00080000 Output Meldung „Positionsregister 3“
20 0x00100000 Output Meldung „Positionsregister 4“
21 0x00200000 Output Meldung „Positionsregister 5“
22 0x00400000 Status 24Volt - Ein
23 0x00800000 Status Slot-Fehler
24...31 Reserve


ASCII Deutsch SMNUMBER

ASCII - Kommando | SMNUMBER |
Syntax Senden | SMNUMBER [Data] |
Syntax Empfangen | SMNUMBER <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 3695 (hex)
DIM | - | PROFIBUS PNU | 2005 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 32767 | DPR | 405 (dec)
Default | 0 |
Opmode | - | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Nein
Kurzbeschreibung | Gespeicherte Motornummer im Geber

Beschreibung

Das Kommando SMNUMBER zeigt die im externen Geber (ENDAT/HIPERFACE) abgespeicherte Motornummer an.

Dieses Kommando ist nur bei Einstellungen FBTYPE=4 oder FBTYPE=2 sinnvoll. Bei anderen Einstellungen wird als Motornummer eine 0 ausgegeben.


ASCII Deutsch SRND

ASCII - Kommando | SRND |
Syntax Senden | SRND [Data] |
Syntax Empfangen | SRND <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3637 (hex)
DIM | - | PROFIBUS PNU | 1911 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 311 (dec)
Default | - 2^31 |
Opmode | - | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Startposition Modulo-Achse

Beschreibung

Mit dem Parameter SRND wird der Anfang des Verfahrbereiches für eine Modulo-Achse (POSCNFG=2) festgelegt. Das Ende des Bereiches kann mit dem Kommando ERND eingestellt werden. Alle Positioniervorgänge finden im Positionsbereich <SRND...ERND-1> statt.
Die Eingabe für SRND erfolgt in SI-Einheiten (Berücksichtigung von PGEARI, PGEARO).


ASCII Deutsch STAGECODE

ASCII - Kommando | STAGECODE |
Syntax Senden | - |
Syntax Empfangen | STAGECODE <Data> | Vorhanden in |
Type | Variable r | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3682 (hex)
DIM | - | PROFIBUS PNU | 1986 (dec) IND = 0000xxxx (bin)
Bereich | 1, 2, .., 19 | DPR | 386 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | -
Kurzbeschreibung | Endstufenkennung

Beschreibung

Mit dem Kommando STAGECODE kann die Kennung der Endstufe (Stromstärke) angezeigt werden.

STAGECODE=0 nicht zugelassen (Hardware-Fehler)
STAGECODE=1 SR601
STAGECODE=2 SR603
STAGECODE=3 SR606
STAGECODE=4 SR610
STAGECODE=5 SR614
STAGECODE=6 SR620
STAGECODE=7 SR640
STAGECODE=8 SR670
STAGECODE=9 SR610/30
STAGECODE=10 Reserve
STAGECODE=11 Reserve
STAGECODE=12 Reserve
STAGECODE=13 Reserve
STAGECODE=14 Reserve
STAGECODE=15 Reserve
STAGECODE=16 SR403
STAGECODE=17 SR406
STAGECODE=18 Reserve
STAGECODE=19 Reserve


ASCII Deutsch Revision

ASCII Objekt Beschreibung
Ausgabe REV 1.0
Ausgabe | Bemerkung | Erstellt
REV 1.0 | Erstausgabe | 30.9.03


ASCII Deutsch STAT

ASCII - Kommando | STAT |
Syntax Senden | STAT |
Syntax Empfangen | STAT | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 35FB (hex)
DIM | - | PROFIBUS PNU | 1851 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word) | DPR | 251 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Verstärker-Statuswort

Beschreibung

Das Kommando STAT liefert ein 16-Bit Statuswort im Hex-Format (Hxxxx).

Bit Wertigkeit Bedeutung
0 0x0001 =0 wenn Endstufe freigegeben
=1 Endstufe gesperrt
1 0x0002 =0 wenn Regler betriebsbereit (BTB)
=1 Fehler steht an
2 0x0004 Reserve
3 0x0008 =1 wenn Service-Funktion aktiv
=0 keine Service-Funktion aktiv
4 0x0010 Reserve
5 0x0020 =1 nach einem Hardware-Reset, wird gelöscht mit CLRHR
6 0x0040 =1 Konfigurationsvariable geändert (SAVE und COLDSTART)
=0 keine Konfigurationsvariable geändert
7 0x0080 =1 Sicherheitsrelais aktiv (AS-Option)
=0 Sicherheitsrelais nicht aktiv
8 0x0100 =1 RAM- und EEPROM-Parameter unterschiedlich (wird gelöscht mit SAVE-Kommando).
=0 RAM- und EEPROM-Parameter gleich
9 0x0200 =1 Slot-Erweiterungskarte vorhanden
=0 Slot-Erweiterungskarte nicht vorhanden
10 0x0400 =1 RAM-Parameter modifiziert (wird gelöscht mit DUMP-Kommando)
=0 seit dem letzten DUMP wurden keine RAM-Parameter geändert.
11...15 Reserve

Die Bits 5,6,8 und 10 werden benutzt um eine Änderung der internen Parameter nach Außen bekanntzugeben.

Bit 5 Hardware-Reset
Das Bit 5 wird gesetzt wenn die Parameter aus dem seriellen EEPROM ins RAM kopiert werden (geschieht nach einem Hardware-Reset bzw. beim LOAD-Kommando). Wenn das Bit gesetzt ist, sollte die Parametriersoftware alle Parameter anfordern (DUMP-Kommando) und mit dem Kommando CLRHR das Bit 5 löschen.

Bit 6 Konfigurationsvariable geändert
Bei jeder Änderung einer Konfigurationsvariable (Variablen, die eine Neuübersetzung der Makros erfordern d.h. Reset des Verstärkers), wird diese Bit auf 1 gesetzt. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine SAVE / COLDSTART-Aufforderung (Reset des Reglers) ausgeben. Das Bit 6 wird nur bei einem Hardware-Reset (COLDSTART) gelöscht.

Bit 8 EEPROM/RAM-Parameter unterschiedlich
Jede Änderung eines RAM-Parameters führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt (z.B. Verlassen des Programmes) eine SAVE-Aufforderung (Abspeichern der Daten im EEPROM) ausgeben. Das Bit wird nach einem SAVE-Kommando gelöscht.

Bit 10 RAM-Parameter modifiziert
Jede Änderung eines RAM-Parameters über einen anderen Parametrierkanal als RS232 führt dazu, daß dieses Bit auf 1 gesetzt wird. Falls dieses Bit gesetzt ist, sollte die Parametriersoftware zu einem geeigneten Zeitpunkt eine DUMP-Aufforderung (Einlesen aller Daten) ausgeben. Das Bit wird nach einem DUMP-Kommando gelöscht.


ASCII Deutsch STATCODE

ASCII - Kommando | STATCODE |
Syntax Senden | STATCODE |
Syntax Empfangen | STATCODE <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Anzeige der Warnungen in Klartext

Beschreibung

Anzeige der Warnungen in Klartext


ASCII Deutsch STATCODE *

ASCII - Kommando | STATCODE * |
Syntax Senden | STATCODE * |
Syntax Empfangen | STATCODE * <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 0xFFFFFFFF | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | -
Kurzbeschreibung | Statusvariable "Warnungen"

Beschreibung

Das Kommando STATCODE * liefert die internen Warnungen in Form einer Bit-Variable. Die Belegung der einzelnen Bits kann der nachfolgenden Tabelle entnommen werden.
Bit | Display-Anzeige | Bedeutung
0 / 0x00000001 | n01 | =1 I2T-Meldeschwelle überschritten wird gesetzt, wenn IRMS die eingestellte Schwelle I2TLIM überschreitet wird gelöscht sobald die Meldeschwelle unterschritten wird.
1 / 0x00000002 | n02 | =1 Ballast-Meldung wird gesetzt, wenn die eingestellte Ballastleistung PBALMAX überschritten wird. wird gelöscht, sobald die PBALMAX unterschritten wird.
2 / 0x00000004 | n03 | =1 Schleppfehler wird gesetzt sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
3 / 0x00000008 | n04 | =1 Ansprechüberwachung aktiv wird gesetzt, wenn die BUS/SLOT-Ansprechüberwachungszeit EXTWD überschritten wurde. Wird gelöscht mit dem Kommando CLRFAULT bzw. beim Aktivieren der Funktion „Fehler/Schleppfehler löschen“.
4 / 0x00000010 | n05 | =1 Netzphase fehlt wird gesetzt sobald das Fehlen einer der 3 Netzphasen festgestellt wird. Wird gelöscht wenn alle 3 Netzphasen vorhanden.
5 / 0x00000020 | n06 | =1 Software-Endschalter 1 unterschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 1 SWE1 unterschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition unterhalb von SWE1 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE1 überschritten wird und ein positiver Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
6 / 0x00000040 | n07 | =1 Software-Endschalter 2 überschritten - wird gesetzt sobald die eingestellte Position des Software-Endschalters 2 SWE2 überschritten wird. - Wird gesetzt wenn ein Fahrsatz gestartet wird dessen Zielposition oberhalb von SWE2 liegt (gleichzeitig wird das Bit 8 „Fehlerhafter Fahrauftrag gestartet“ gesetzt). Wird gelöscht wenn die Position SWE2 unterschritten wird und ein negativer Drehzahl/Geschwindigkeitsollwert vorgegeben wird bzw. wenn ein Fahrsatz gestartet wird dessen Zielposition innerhalb des gültigen Verfahrbereiches liegt.
7 / 0x00000080 | n08 | =1 Fehlerhafter Fahrauftrag gestartet wird gesetzt wenn versucht wird einen nichtvorhandenen (fehlerhafte Checksumme) Fahrauftrag zu starten. Wird gelöscht wenn ein gültiger Fahrsatz gestartet wird.
8 / 0x00000100 | n09 | =1 Referenzpunkt nicht gesetzt wird gesetzt, wenn ein Fahrsatz gestartet wird, ohne daß zuvor eine Referenzfahrt durchgeführt wurde. Wird gelöscht nach einer abgeschlossenen Referenzfahrt.
9 / 0x00000200 | n10 | = 1 PSTOP aktiv ist gesetzt solange der Hardware-Endschalter PSTOP aktiv wird gelöscht sobald der Hardware-Endschalter PSTOP inaktiv wird.
10 / 0x00000400 | n11 | =1 NSTOP aktiv ist gesetzt solange der Hardware-Endschalter NSTOP aktiv wird gelöscht sobald der Hardware-Endschalter NSTOP inaktiv wird.
11 / 0x00000800 | n12 | =1 Default-Motordaten geladen wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem EnDAT- oder Hiperface-Geber unterschiedlich sind. Bei Eingabe einer gültigen Motornummer und Abspeichern der Daten im Geber (HSAVE) und im internen EEPROM (SAVE) wird beim nächsten Einschalten des Gebers diese Warnung nicht mehr ausgegeben.
12 / 0x00001000 | n13 | =1 Slot-Warnung (I/O-Karte) wird gesetzt, wenn die 24 V Versorgungsspannung für die I/O-Erweiterungskarte fehlen. Wird gelöscht, wenn die 24V-Versorgung der I/O-Erweiterungskarte vorhanden.
13 / 0x00002000 | n14 | =1 Ermittlung von MPHASE (FBTYPE=7) wird gesetzt beim Einschalten des Verstärkers. Wird gelöscht wenn die Endstufe freigegeben wurde und der Wert für MPHASE ermittelt werden konnte.
14 / 0x00004000 | n15 | =1 fehlerhafter VCT-Eintrag wird gesetzt sobald bei konfigurierter VC-Tabelle ein fehlerhafter VCT-Eintrag angewählt und übernommen werden soll. Nur wirksam bei INxMODE = 35.
15 / 0x00008000 | n16 | Summenwarnung für Warnungen n17...n31
16 / 0x00010000 | n17 | CAN-Sync ist nicht eingelocked.
17 / 0x00020000 | n18 | Bei Multiturn-Geber Rückführung wurde ein Überlauf über die maximale Anzahl von Umdrehungen (+/-2048) festgestellt (ab 4.91).
18...30 | n19 ...n31 | Reserve
31 / 0x80000000 | n32 | =1 ist gesetzt bei einer Beta-Version der Firmware.


ASCII Deutsch STATIO

ASCII - Kommando | STATIO |
Syntax Senden | STATIO |
Syntax Empfangen | STATIO <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | 7 x Integer8 | CANBus Objektnummer | 35FC (hex)
DIM | - | PROFIBUS PNU | 1852 (dec) IND = 0000xxxx (bin)
Bereich | 0,1 (=State) | DPR | 252 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Status der Ein/Ausgänge

Beschreibung

Das Kommando STATIO liefert den aktuellen Zustand der digitalen Ein-/Ausgänge des Servoverstärkers in folgender Reihenfolge:
IN1 IN2 IN3 IN4 ENABLE OUT1 OUT2

Eine 0 an der entsprechender Stelle bedeutet, daß der zugehörige Ein-/Ausgang den Zustand LOW aufweist, bei einer 1 ist der Zustand High.


ASCII Deutsch STATUS

ASCII - Kommando | STATUS |
Syntax Senden | STATUS |
Syntax Empfangen | STATUS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer16 Integer32 Integer16 Integer16 Integer16 | CANBus Objektnummer | 35FD (hex)
DIM | - | PROFIBUS PNU | 1853 (dec) IND = 0000xxxx (bin)
Bereich | int (=Word); long int (=DoubleWord) | DPR | 253 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | detailierte Verstärker-Statusinformation

Beschreibung

Das Kommando STATUS liefert die erweiterte Status-Informationen in Form von 5 Statusvariablen im Hex-Format.

Wort Nr. 1 Format Hxxxx
Bit 0 =0 wenn Hardware-Enable gesetzt (Eingang „ENABLE“ = 24V)
Bit 1 =0 wenn Software-Enable gesetzt
Bit 2 Reserve
Bit 3 =0 wenn Verstärker betriebsbereit (BTB/kein Fehler)

Wort Nr. 2 Format Hxxxxxxxx
Bits 0...31 Fehlervariable (s. ERRCODE)

Wort Nr. 3 Format Hxxxx (Reserve, immer 0)
Wort Nr. 4 Format Hxxxx
=0 keine Service-Funktion aktiv
=1 Service-Funktion „konstanter Strom/konstante Drehzahl“ aktiv
=2 Tippbetrieb MJOX aktiv

Wort Nr. 5 Format Hxxxx

Bit Wertigkeit Bedeutung
0 0x0001 =1 Fahrsatz/Referenzfahrt/Tippbetrieb aktiv
1 0x0002 =1 Referenzpunkt gesetzt
2 0x0004 =1 Referenzschalter belegt (Home-Position)
3 0x0008 =1 IN-POSITION-Meldung
4 0x0010 =1 Position wurde gelatcht (positive Flanke)
5 0x0020 =1 Referenzfahrt läuft
6 0x0040 =1 Tippbetrieb läuft
7 0x0080 =1 Position wurde gelatcht (negative Flanke)
8...15 Reserve


ASCII Deutsch STEP

ASCII - Kommando | STEP |
Syntax Senden | STEP [Data] |
Syntax Empfangen | STEP <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Integer16 Float Integer16 Float | CANBus Objektnummer | Nein
DIM | Milliseconds (DurationN) / rpm (velocityN) | PROFIBUS PNU | Nein
Bereich | Duration:0 to 32767; velocity:-VLIM to +VLIM | DPR | Nein
Default | Duration:1000; velocity1/2: 100/-100 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | Service-Betrieb

Beschreibung

Mit dem STEP-Kommando kann eine Service-Funktion über die Betriebsart "digitale Drehzahlregelung" (OPMODE=0) realisiert werden. Das Kommando kann in folgenden Formen benutzt werden:
1. STEP
Das Kommando liefert die aktuellen Einstellungen für die Service-Funktion
2. STEP T1 V1
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 verstrichen ist, wird der digitale Drehzahlsollwert auf 0 gesetzt.
3. STEP T1 V1 T2 V2
Für die Dauer T1 (msek) wird ein digitaler Sollwert V1 (UPM) vorgegeben. Nachdem die Zeit T1 abgelaufen ist, wird für die Dauer T2 (msek) der digitale Sollwert V2 (UPM) vorgegeben. Nachdem die Zeit T2 abgelaufen ist, fängt erneut der Zyklus T1/V1 an. Mit Hilfe dieses Kommando kann ein endloser Reversierbetrieb realisiert werden.
z.B: STEP 1000 500 1000 -500

Der Service-Betrieb kann immer mit dem STOP-Kommando abgebrochen werden.
Die Voraussetzung für die Ausführung des STEP-Kommandos ist die Betriebsart "digitale Drehzahlvorgabe".


ASCII Deutsch STOP

ASCII - Kommando | STOP |
Syntax Senden | STOP |
Syntax Empfangen | STOP | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | - | CANBus Objektnummer | 35FE (hex)
DIM | - | PROFIBUS PNU | 1854 (dec) IND = 0000xxxx (bin)
Bereich | - | DPR | 254 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | -
Kurzbeschreibung | Setzen des Sollwertes auf 0

Beschreibung

Das STOP-Kommando bricht die Bewegung des Antriebes ab. Abhängig von der gerade aktiven Betriebsart ist das Verhalten des Antriebes unterschiedlich.

1. OPMODE=0 (digitale Drehzahlvorgabe)
Das STOP-Kommando bewirkt das Setzen des Drehzahlsollwertes auf 0. Der Antrieb bremst mit der eingestellten Bremsrampe des Drehzahlreglers (DEC).

2. <OPMODE=2 (digitale Stromvorgabe)
Das STOP-Kommando bewirkt das Setzen des Stromsollwertes auf 0. Der Antrieb trudelt aus.

3. OPMODE=8 (interne Fahrsätze)
Das STOP-Kommando bewirkt den Abbruch des aktuellen Fahrsatzes (Tippbetrieb/Referenzfahrt).
Der Antrieb bremst mit der innerhalb des Fahrsatzes definierten Bremsrampe.
Der Fahrauftrag kann durch das Kommando CONTINUE oder durch einen digitalen Eingang mit INxMODE=22 zu Ende gefahren werden.

Bei Betriebsarten OPMODE=1,3,4,5,6,7 hat das STOP-Kommando keine Funktion.


ASCII Deutsch STOPMODE

ASCII - Kommando | STOPMODE |
Syntax Senden | STOPMODE [Data] |
Syntax Empfangen | STOPMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 35FF (hex)
DIM | - | PROFIBUS PNU | 1855 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 255 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsverhalten bei Disable

Beschreibung

STOPMODE legt das Verhalten des Antriebes beim Disablen der Endstufe fest.
Es sind folgende Einstellungen möglich:
STOPMODE=0 die Endstufe wird sofort gesperrt, der Antreib trudelt aus.
STOPMODE=1 Der Antrieb wird drehzahlgeregelt auf die Drehzahl 0 heruntergefahren (Rampe DECDIS). Beim Unterschreiten der Stillstandschwelle VEL0 wird die Endstufe gesperrt.
Die Endstufe wird auch dann gesperrt, wenn die Drehzahl VEL0 nicht innerhalb von 5 Sek erreicht werden konnte (Time-Out von 5 Sekunden).


ASCII Deutsch SWCNFG

ASCII - Kommando | SWCNFG |
Syntax Senden | SWCNFG [Data] |
Syntax Empfangen | SWCNFG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Unsigned16 | CANBus Objektnummer | 3600 (hex)
DIM | - | PROFIBUS PNU | 1856 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65536 | DPR | 256 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Unsigned16
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Konfiguration der Positionsregister 1...4

Beschreibung

Für die Überwachungsfunktionen gibt es 6 Positionsregister (SWE0...SWE5), die als Software-Endschalter bzw. Nocken-/Meldeschwellen konfiguriert werden können.
Die Register SWE1...SWE4 können mit Hilfe des Konfigurationsparameters SWCNFG,
die Register SWE0 und SWE5 mit Hilfe des Parameters SWCNFG2 konfiguriert werden.
Zu jedem Positionsregister SWEx gibt es das zugehörige Nockenregister SWExN.
Die Nockenregister werden nur bei aktivierter Nockenfunktion benutzt.

Die SWCNFG-Variable kann als eine Bit-Variable betrachtet werden. Die einzelnen Bits haben folgende Bedeutung:

Bit 0 =0 Positions/Nocken-Register SWE1 nicht aktiv
=1 Positions/Nocken-Register SWE1 aktiv
Bit 1 =0 Meldung beim Überschreiten der Position (PFB > SWE1)
Meldung wenn SWE1 < PFB < SWE1N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE1)
Meldung wenn SWE1 > PFB > SWE1N bei aktivierter Nocken-Funktion
Bit 2 =0 SWE1 arbeitet als Meldeschwelle
=1 SWE1 arbeitet als Software-Endschalter 1 (links)
Das Setzen des Referenzpunktes ist je nach FBTYPE mit SETREF oder MH erforderlich
Bit 3 =1 Nocken-Funktion für SWE1 / SWE1N

Bit 4 =0 Positions/Nocken-Register SWE2 nicht aktiv
=1 Positions/Nocken-Register SWE2 aktiv
Bit 5 =0 Meldung beim Überschreiten der Position (PFB > SWE2)
Meldung wenn SWE2 < PFB < SWE2N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE2)
Meldung wenn SWE2 > PFB > SWE2N bei aktivierter Nocken-Funktion
Bit 6 =0 SWE2 arbeitet als Meldeschwelle
=1 SWE2 arbeitet als Software-Endschalter 2 (rechts)
Das Setzen des Referenzpunktes ist je nach FBTYPE mit SETREF oder MH erforderlich
Bit 7 =1 Nocken-Funktion für SWE2 / SWE2N

Bit 8 =0 Positions/Nocken-Register SWE3 nicht aktiv
=1 Positions/Nocken-Register SWE3 aktiv
Bit 9 =0 Meldung beim Überschreiten der Position (PFB > SWE3)
Meldung wenn SWE3 < PFB < SWE3N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE3)
Meldung wenn SWE3 > PFB > SWE3N bei aktivierter Nocken-Funktion
Bit 10 Reserve
Bit 11 =1 Nocken-Funktion für SWE3 / SWE3N

Bit 12 =0 Positions/Nocken-Register SWE4 nicht aktiv
=1 Positions/Nocken-Register SWE4 aktiv
Bit 13 =0 Meldung beim Überschreiten der Position (PFB > SWE4)
Meldung wenn SWE4 < PFB < SWE4N bei aktivierter Nocken-Funktion
=1 Meldung beim Unterschreiten der Position (PFB < SWE4)
Meldung wenn SWE4 > PFB > SWE4N bei aktivierter Nocken-Funktion
Bit 14 Reserve
Bit 15 =1 Nocken-Funktion für SWE4 / SWE4N

Die Nockenfunktion wird mit Hilfe des Nocken-Bits (Bit 3/7/11/15 von SWCNFG und Bit 3/7 von SWCNFG2) aktiviert. Bei gesetztem Nocken-Bit wird eine Nockenmeldung ausgegeben, wenn
die aktuelle Position zwischen den Positionen SWEx und SWExN (x=0...5) liegt. Die Polarität
der Nocken-Meldung kann mit dem Richtungsbit (Bit 1/5/9/13 von SWCNFG bzw. Bit 1/5 von SWCNFG2) definiert werden.

Ausgabe der Positionsmeldung über einen digitalen Ausgang
- Bei vorhandener I/O-Erweiterungskarte werden die einzelnen Positionsmeldungen
über folgende Ausgänge gemeldet:

SWE0: Folge-InPos X11B.4
SWE1: PosReg1 X11B.6
SWE2: PosReg2 X11B.7
SWE3: PosReg3 X11B.8
SWE4: PosReg4 X11B.9
SWE5: Reserve X11B.10

Die Funktionen „Folge-InPos“ und „SWE0-Meldung“ benutzen für die Ausgabe den gleichen Ausgang X11B.4, d.h. sie dürfen nicht gleichzeitig benutzt werden. Wenn Positionsregister SWE0 konfiguriert wurde, so wird die Funktion „Folge-InPos“ über die I/O-Karte gesperrt. Falls notwendig, kann diese Funktion auf einen digitalen Ausgang der Basisplatine umgeleitet werden (O1MODE=16 oder O2MODE=16).

- falls keine I/O-Karte vorhanden ist, können die einzelne Positionsmeldungen über die Ausgänge
der Basisplatine ausgegeben werden.

SWE0: OxMODE=28 x=1,2
SWE1: OxMODE=12 x=1,2
SWE2: OxMODE=13 x=1,2
SWE3: OxMODE=14 x=1,2
SWE4: OxMODE=15 x=1,2
SWE5: OxMODE=29 x=1,2

Alle Positionsmeldungen werden, unabhängig von den Ausgaben über die digitalen Ausgänge,
in einem Statusregister festgehalten, und können sowohl über die serielle als auch
über CAN-/PROFIBUS-Schnittstelle ausgelesen werden.

SWE0: Bit 21 (0x00200000) von DRVSTAT
SWE1: Bit 22 (0x00400000) von DRVSTAT
SWE2: Bit 23 (0x00800000) von DRVSTAT
SWE3: Bit 24 (0x01000000) von DRVSTAT
SWE4: Bit 25 (0x02000000) von DRVSTAT
SWE5: Bit 27 (0x08000000) von DRVSTAT


ASCII Deutsch SWE1

ASCII - Kommando | SWE1 |
Syntax Senden | SWE1 [Data] |
Syntax Empfangen | SWE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3604 (hex)
DIM | - | PROFIBUS PNU | 1860 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 260 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 1

Beschreibung

Die Variable SWE1 enthält den Positionswert für das Positionsregister 1.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE1[Inkremente] = SWE1[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch SWE2

ASCII - Kommando | SWE2 |
Syntax Senden | SWE2 [Data] |
Syntax Empfangen | SWE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3606 (hex)
DIM | - | PROFIBUS PNU | 1862 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 262 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Positionsregister 2

Beschreibung

Die Variable SWE2 enthält den Positionswert für das Positionsregister 2.
Die Normierung der Position hängt von den Einstellungen PGEARI / PGEARO / PRBASE ab und wird nach folgender Formel berechnet:

SWE2[Inkremente] = SWE2[Eingabe] * PGEARO / PGEARI

1048576 Inkremente/Umdrehung bei PRBASE=20
65536 Inkremente/Umdrehung bei PRBASE=16

s. auch Beschreibung von SWCNFG


ASCII Deutsch T

ASCII - Kommando | T |
Syntax Senden | T [Data] |
Syntax Empfangen | T <Data> | Vorhanden in |
Type | Command | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 360E (hex)
DIM | Amperes | PROFIBUS PNU | 1870 (dec) IND = 0000xxxx (bin)
Bereich | -DIPEAK .. DIPEAK | DPR | 270 (dec)
Default | - |
Opmode | 2 | Datentyp Bus/DPR | Integer32
Verstärker Status | Enabled | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Oscilloscope | EEPROM | -
Kurzbeschreibung | digitaler Stromsollwert

Beschreibung

Mit dem Kommando "T <i>" kann ein konstanter Stromsollwert <i> (in A) vorgegeben werden.
Der vorgegeben Stromsollwert gilt solange, bis ein neues T / STOP / OPMODE-Kommando übertragen wird.


ASCII Deutsch TASK

ASCII - Kommando | TASK |
Syntax Senden | TASK |
Syntax Empfangen | TASK <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | String | CANBus Objektnummer | 360F (hex)
DIM | - | PROFIBUS PNU | 1871 (dec) IND = 0000xxxx (bin)
Bereich | max 80 ASCII Characters | DPR | 271 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Task-Auslastung

Beschreibung

Mit dem Kommando TASK wird die Auslastung der einzelnen Firmware-Tasks angezeigt.
Die Zahlen bedeuten Anzahl der Funktionsdurchläufe pro msek.


ASCII Deutsch TBRAKE

ASCII - Kommando | TBRAKE |
Syntax Senden | TBRAKE [Data] |
Syntax Empfangen | TBRAKE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366E (hex)
DIM | ms | PROFIBUS PNU | 1966 (dec) IND = 0000xxxx (bin)
Bereich | 10 .. 10000 | DPR | 366 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Disableverzögerungszeit bei Bremsenbetrieb

Beschreibung

Der Parameter TBRAKE definiert eine Bremsen-Reaktionszeit.
Beim Disablen des Verstärkers (Hardware/Software-Disable) steuert der Verstärker die externe Bremse an. Nachdem der Antrieb gestoppt wurde, wird die Bremse ausgeschaltet. Gleichzeitig wird ein interner Timer mit der Zeit TBRAKE geladen. Erst nachdem die eingestellte Zeit abgelaufen ist, wird die Endstufe gesperrt.


ASCII Deutsch TBRAKE0

ASCII - Kommando | TBRAKE0 |
Syntax Senden | TBRAKE0 [Data] |
Syntax Empfangen | TBRAKE0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer16 | CANBus Objektnummer | 366F (hex)
DIM | ms | PROFIBUS PNU | 1967 (dec) IND = 0000xxxx (bin)
Bereich | -10 .. 10000 | DPR | 367 (dec)
Default | 20 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Bremsen Lüftzeit

Beschreibung

Der Parameter TBRAKE0 definiert eine Reaktionszeit der Bremse beim Lüft-Vorgang.
Beim Freigeben der Endstufe (Hardware/Software-Enable) steuert der Verstärker die externe Bremse an. Während der eingestellten Zeit TBRAKE0 wird der interne Sollwert auf 0 gehalten. Erst nachdem die eingestellte Zeit abgelaufen ist und die Bremse vollständig geöffnet ist, wird der Sollwert akzeptiert und der Antrieb kann bewegt werden.

Bei Eingabe einer Zeit < 0 wird der Sollwert freigeschaltet, bevor die Bremse angesteuert wurde


ASCII Deutsch TEMPE

ASCII - Kommando | TEMPE |
Syntax Senden | TEMPE |
Syntax Empfangen | TEMPE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3610 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1872 (dec) IND = 0000xxxx (bin)
Bereich | -20 .. 90 | DPR | 272 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Umgebungstemperatur

Beschreibung

Anzeige der aktuellen Innentemperatur in °C.


ASCII Deutsch TEMPH

ASCII - Kommando | TEMPH |
Syntax Senden | TEMPH |
Syntax Empfangen | TEMPH <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3611 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1873 (dec) IND = 0000xxxx (bin)
Bereich | -20 .. 90 | DPR | 273 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Kühlkörpertemperatur

Beschreibung

Anzeige der aktuellen Kühlkörpertemperatur in °C.


ASCII Deutsch TEMPM

ASCII - Kommando | TEMPM |
Syntax Senden | TEMPM |
Syntax Empfangen | TEMPM <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3612 (hex)
DIM | Ohm | PROFIBUS PNU | 1874 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 10000 | DPR | 274 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Istwert der Motortemperatur

Beschreibung

Der Istwert der Motortemperatur als Widerstand des Temperaturfühlers (in Ohm) angezeigt.


ASCII Deutsch TRJSTAT

ASCII - Kommando | TRJSTAT |
Syntax Senden | TRJSTAT |
Syntax Empfangen | TRJSTAT <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3613 (hex)
DIM | - | PROFIBUS PNU | 1875 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 0xFFFFFFFF | DPR | 275 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Drive Status | EEPROM | Nein
Kurzbeschreibung | Status2-Information

Beschreibung

Das Kommando TRJSTAT liefert die internen Status-Informationen in Form einer Bit-Variable. Die Statusinformationen werden vorwiegend für interne Funktionen benutzt. Ausschließlich Bits, die mit einem ´*´ markiert wurden, können für externe Funktionen (Steuerung) benutzt werden. Die Bits 16...20 werden zusätzlich in der Statusvariable DRVSTAT gespiegelt.
Bit | Wertigkeit | Bedeutung
0 | 0x00000001 | =1 innerhalb der nächsten msek wird der Ausgang INPOS2 aktualisiert.
1 | 0x00000002 | =1 Am Ende des aktuellen Fahrsatzes wird keine „In-Position“-Meldung ausgegeben (es ist ein Folgefahrsatz vorhanden).
2* | 0x00000004 | =1 Toggle Bit "Fahrsatz abgeschlossen" Wird am Ende eines Fahrsatzes invertiert. Im Gegensatz zu der "In-Position"-Meldung erfolgt das Invertieren des Bits nicht bereits beim Erreichen des In-Position-Fensters, sondern erst beim Erreichen der Zielposition und Abschalten des Trajektoriengenerators. Nach dem Einschalten des Verstärkers ist dieses Bit zunächst auf low. (Ab Firmware 3.41)
3...15 |  | Reserve
16* | 0x00010000 | =1 Auftrag aktiv (Lageregelung) wird gesetzt sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt). Wird gelöscht wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
17* | 0x00020000 | =1 Referenzpunkt gesetzt gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn). Wird gelöscht beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt.
18* | 0x00040000 | =1 Home-Position ist gesetzt solange der Referenzschalter belegt ist. Wird gelöscht sobald der Referenzschalter nicht belegt.
19* | 0x00080000 | =1 In-Position wird gesetzt sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS. Wird gelöscht sobald der Abstand größer als PEINPOS. Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
20* | 0x00100000 | =1 Positionslatch erfolgte (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH16 / LATCH32)
21* | 0x00200000 | =1 Referenzfahrt läuft wird gesetzt sobald eine Referenzfahrt gestartet wurde. Wird gelöscht sobald die Referenzfahrt abgeschlossen bzw. abgebrochen (STOP) wurde.
22* | 0x00400000 | =1 Tippbetrieb läuft wird gesetzt sobald der Tippbetrieb gestartet wurde. Wird gelöscht sobald der Tippbetrieb abgebrochen (STOP) wurde.
23 | 0x00800000 | =1 Positionslatch erfolgte (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht wenn die gelatchte Position ausgelesen wird (LATCH16N / LATCH32N)
24 | 0x01000000 | =1 Nothaltphase aktiv wird gesetzt, während der Nothalt-Prozedur (Bremsphase nach einem Fehler, bei aktiven Endschalter bzw. wenn der Eingang „Nothalt“ den Zustand 0 aufweist).
25 | 0x02000000 | =1 Positionslatch auf Input 1 (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCHX16 / LATCHX32) (ad Version 4.61)
26 | 0x04000000 | =1 Positionslatch auf Input 1 (negative Flanke) wird gesetzt, wenn eine fallende Flanke an dem als Latch-Eingang konfigurierten Input1 (IN1MODE=26) erkannt wurde. Wird gelöscht, wenn die gelatchte Position ausgelesen wird (LATCHX16N / LATCHX32N) (ab Version 4.61)
27 .. 31 |  | Reserve


ASCII Deutsch TRUN

ASCII - Kommando | TRUN |
Syntax Senden | TRUN |
Syntax Empfangen | TRUN <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | 3614 (hex)
DIM | hhhhh:mm | PROFIBUS PNU | 1876 (dec) IND = 0000xxxx (bin)
Bereich | 00000:00 to 99999:45 | DPR | 276 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Betriebsstundenzähler

Beschreibung

Der Betriebsstundenzähler zeigt die Lebens-Laufzeit des Verstärkers Minuten an. Er wird hochgezählt, wenn die 24V - Versorgung eingeschaltet ist
Die interne Auflösung des Betriebsstundenzählers beträgt 1 Sekunde.
Da der Betriebsstundenzähler im seriellen EEPROM des Verstärkers untergebracht ist, wird er nur alle 8 Minuten ins EEPROM geschrieben. Durch Ausschalten der 24 Volt-Versorgung gehen maximal 8 Minuten verloren.


ASCII Deutsch TXPDO1A

ASCII - Kommando | TXPDO1A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO1A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO1 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO1A werden die folgenden für das CANopen-PDO TX-PDO 1 relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Transmit-PDO 1 (2A00, 0), dezimal
2. COB-Identifier für das Transmit-PDO 1 (1800, 1), hexadezimal
3. Transmission type für Transmit-PDO 1 (1800, 2), dezimal
4. Inhibit time für Transmit-PDO 1 (1800, 3), dezimal
5. Priority group für Transmit-PDO 1 (1800, 4), dezimal
6. Registermaske1 für Transmit-PDO 1 (2014, 1), hexadezimal
7. Registermaske2 für Transmit-PDO 1 (2014, 2), hexadezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: TXPDO1A
Schreiben: Kommando: TXPDO1A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
es müssen immer alle Parameter angegeben werden


ASCII Deutsch TXPDO1B

ASCII - Kommando | TXPDO1B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO1B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO1 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO1B kann das Mapping des CANopen-PDOs TX-PDO 1eingestellt werden (in Klammern: zugehörige SDOs):
Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde, z.B. über TXPDO1A.
Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando: TXPDO1B
Man erhält das gerade vorliegende Mapping in der Form: TXPDO1B 6041002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.: TXPDO1B 6041002 6061001 zur Einstellung des CANopen Zustandsworts und der CANopen-Betriebsart über das TX-PDO 1.


ASCII Deutsch TXPDO2A

ASCII - Kommando | TXPDO2A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO2A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO2 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO2A werden die folgenden für das CANopen-PDO TX-PDO 2 relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Transmit-PDO 2 (2A00, 0), dezimal
2. COB-Identifier für das Transmit-PDO 2 (1800, 1), hexadezimal
3. Transmission type für Transmit-PDO 2 (1800, 2), dezimal
4. Inhibit time für Transmit-PDO 2 (1800, 3), dezimal
5. Priority group für Transmit-PDO 2 (1800, 4), dezimal
6. Registermaske1 für Transmit-PDO 2 (2014, 1), hexadezimal
7. Registermaske2 für Transmit-PDO 2 (2014, 2), hexadezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: TXPDO1A
Schreiben: Kommando: TXPDO1A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
es müssen immer alle Parameter angegeben werden


ASCII Deutsch TXPDO2B

ASCII - Kommando | TXPDO2B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO2B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO2 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO2B kann das Mapping des CANopen-PDOs TX-PDO 2eingestellt werden (in Klammern: zugehörige SDOs):
Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde, z.B. über TXPDO2A.
Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando: TXPDO2B
Man erhält das gerade vorliegende Mapping in der Form: TXPDO2B 6041002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.: TXPDO2B 6041002 6061001 zur Einstellung des CANopen Zustandsworts und der CANopen-Betriebsart über das TX-PDO 2.


ASCII Deutsch TXPDO3A

ASCII - Kommando | TXPDO3A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO3A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO3 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO3A werden die folgenden für das CANopen-PDO TX-PDO 3 relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Transmit-PDO 1 (2A00, 0), dezimal
2. COB-Identifier für das Transmit-PDO 3 (1800, 1), hexadezimal
3. Transmission type für Transmit-PDO 3 (1800, 2), dezimal
4. Inhibit time für Transmit-PDO 3 (1800, 3), dezimal
5. Priority group für Transmit-PDO 3 (1800, 4), dezimal
6. Registermaske1 für Transmit-PDO 3 (2014, 1), hexadezimal
7. Registermaske2 für Transmit-PDO 3 (2014, 2), hexadezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: TXPDO3A
Schreiben: Kommando: TXPDO3A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
es müssen immer alle Parameter angegeben werden


ASCII Deutsch TXPDO3B

ASCII - Kommando | TXPDO3B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO3B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO3 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO3B kann das Mapping des CANopen-PDOs TX-PDO 3eingestellt werden (in Klammern: zugehörige SDOs):
Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde, z.B. über TXPDO3A.
Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando: TXPDO3B
Man erhält das gerade vorliegende Mapping in der Form: TXPDO3B 6041002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.: TXPDO3B 6041002 6061001 zur Einstellung des CANopen Zustandsworts und der CANopen-Betriebsart über das TX-PDO 3.


ASCII Deutsch TXPDO4A

ASCII - Kommando | TXPDO4A |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO4A <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO4 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO4A werden die folgenden für das CANopen-PDO TX-PDO 4 relevanten Parameter eingestellt (in Klammern: zugehörige SDOs bei Bedienung über CAN):

1. Auswahl des benutzten PDO-Mappings für das Transmit-PDO 4 (2A00, 0), dezimal
2. COB-Identifier für das Transmit-PDO 4 (1800, 1), hexadezimal
3. Transmission type für Transmit-PDO 4 (1800, 2), dezimal
4. Inhibit time für Transmit-PDO 4 (1800, 3), dezimal
5. Priority group für Transmit-PDO 4 (1800, 4), dezimal
6. Registermaske1 für Transmit-PDO 4 (2014, 1), hexadezimal
7. Registermaske2 für Transmit-PDO 4 (2014, 2), hexadezimal

Beispiel:

Lesen des Ist-Zustands: Kommando: TXPDO4A
Schreiben: Kommando: TXPDO4A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
es müssen immer alle Parameter angegeben werden

Anmerkung: Nur bei MDRV = 0 verfügbar !


ASCII Deutsch TXPDO4B

ASCII - Kommando | TXPDO4B |
Syntax Senden | RXPDO1A [Data] |
Syntax Empfangen | TXPDO4B <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Single Line Multi String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | - | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | Single Line Multi String
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Fieldbus | EEPROM | Ja
Kurzbeschreibung | TX-PDO4 Mapping - Einstellung

Beschreibung

Mit dem Kommando TXPDO1B kann das Mapping des CANopen-PDOs TX-PDO 1eingestellt werden (in Klammern: zugehörige SDOs):
Dies kann nur erfolgen, wenn für das PDO ein freies Mapping vorgewählt wurde, z.B. über TXPDO1A.
Zum Lesen des aktuell eingestellten Mappings gibt man folgendes Kommando: TXPDO1B
Man erhält das gerade vorliegende Mapping in der Form: TXPDO1B 6041002

Das Format ist leicht abweichend von der Vorgabe über Bus. Die Bedeutung eines Mapping-Eintrags xxxxyyz ist dabei folgende:

xxxx Hex-Zahl für den Index des SDO-Eintrags (im Beispiel 6040)
yy Hex-Zahl für den Subindex des SDO-Eintrags (im Beispiel 00)
z Zahl für die Anzahl der Bytes im SDO-Eintrag (im Beispiel 2 Byte = 16 Bit)

Die Eingabe von Mappings bei frei mappbaren PDO-Auswahlen geschieht analog zur
Ausgabe, also z.B.: TXPDO1B 6041002 6061001 zur Einstellung des CANopen Zustandsworts und der CANopen-Betriebsart über das TX-PDO 1.

Anmerkung: Nur bei MDRV = 0 verfügbar !


ASCII Deutsch UCOMP

ASCII - Kommando | UCOMP |
Syntax Senden | UCOMP [Data] |
Syntax Empfangen | UCOMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3631 (hex)
DIM | PUNIT | PROFIBUS PNU | 1905 (dec) IND = 0000xxxx (bin)
Bereich | long int | DPR | 305 (dec)
Default | 0 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Umkehrlose Kompensation

Beschreibung

IN VORBEREITUNG !

Bei manchen Anwendungen ist es erforderlich, daß Fahrsatzpositionen immer nur von einer bestimmten Seite angefahren werden (Korrektur von Fehlern die im Zusammenspiel Zahnstange/ Zahnrad auftreten). Dazu wird beim Start eines Fahrsatzes je nach Fahrtrichtung die Zielposition des Fahrsatzes um einen Korrekturwert verschoben und erst nachdem diese korrigierte Zielposition erreicht wurde, ein Fahrsatz in die echte Zielposition gestartet. Das Verhalten dieser Funktion wird von dem Parameter UCOMP gesteuert. Der Betrag dieses Parameters gibt den Korrekturwert vor, das Vorzeichen: die Richtung bei der diese Korrektur vorgenommen werden soll. Bei einem positiven Vorzeichen erfolgt die Korrektur nur bei positiven Geschwindigkeiten (d.h. die Zielposition wird immer von Rechts angefahren), bei einem negativen Vorzeichen : nur bei negativen Geschwindigkeiten. Um diese Funktion abzuschalten muß der Parameter UCOMP auf 0 stehen (Defaultwert).
z.B.:
1. Istposition=0, Zielposition=1000, UCOMP =100 -> der Antrieb fährt in die Position 1100, dreht um und bleibt bei 1000 stehen.
2. Istposition=1000, Zielposition=0, UCOMP =100 -> der Antrieb fährt direkt in die Position 0
3. Istposition=1000, Zielposition=0, UCOMP= -100 -> der Antrieb fährt in die Position –100, dreht um und bleibt bei 0 stehen.


ASCII Deutsch UPDATE

ASCII - Kommando | UPDATE |
Syntax Senden | UPDATE [Data] |
Syntax Empfangen | UPDATE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | Name | PROFIBUS PNU | Nein
Bereich | ALL,USER,TABLE,PROG,PORDER,MBASE,Lookup | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | Disabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Firmware-Update über RS232

Beschreibung

Das UPDATE-Kommando ermöglicht das Programmieren des internen Flash-EPROMS über die serielle Schnittstelle.

Vorgehensweise beim Software-Update:

1. Anschluß des Reglers an die serielle Schnittstelle eines PC´s
2. Starten des Terminalprogrammes HINT2.EXE COM2: 9600 (der Rechner sollte im DOS-Mode gestartet werden).
Damit wird die Verbindung zwischen dem PC und dem Kommandointerpreter des Verstärkers hergestellt. Um die Verbindung zu überprüfen, kann das Kommando LIST eingegeben werden. Als Antwort sollte auf dem Bildschirm eine Liste mit verfügbaren Kommandos erscheinen.
3. Eingabe des Kommandos UPDATE ALL xxxx in der Kommandozeile.
xxxx - Name der zu programmierenden Firmware-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name ALL benutzt.

Achtung !!! Beim Programmieren mit ALL werden auch die bereits gespeicherten Fahrsätze gelöscht. Diese müssen vor der Programmierung über das Bedienprogramm gerettet und nachher wieder eingespielt werden.

Das Programmieren dauert ca. 40 Minuten.

Während des Programmiervorganges werden die programmierten Adressen angezeigt. Falls die Anzeige stehenbleibt, ohne daß der download abgeschlossen wurde (dieses Problem wurde bei manchen PC´s beobachtet), sollte die ENTER-Taste betätigt werden. Danach wird das Programmieren fortgesetzt.
Falls der Programmiervorgang vorzeitig abgebrochen wird, so meldet sich der Verstärker beim nächsten Einschalten mit dem Monitorprogramm („-„ Zeichen auf der ersten Stelle des Displays).
In diesem Fall kann der Download mit folgender Kommandofolge neu gestartet werden:
X: xxxx
xxxx Name der zu programmierenden Firmware-Datei
Vorgehensweise beim Laden einer Motordatenbank:

Eine Standard-Motordatenbank ist ein Bestandteil der Firmware. Falls eine kundenspezifische Motordatenbank benötigt wird, so kann sie nach dem Programmieren der Firmware nachgeladen werden.
Dazu muß folgendes Kommando eingegeben werden:

UPDATE MBASE xxxx

xxxx - Name der zu programmierenden Motordatenbank-Datei. Es sollte darauf geachtet werden, daß die zu programmierende Datei xxxx in dem aktuellen Verzeichnis liegt. Falls kein Dateiname angegeben wird, so wird als Voreinstellung der Name MBASE benutzt.


ASCII Deutsch UVLTMODE

ASCII - Kommando | UVLTMODE |
Syntax Senden | UVLTMODE [Data] |
Syntax Empfangen | UVLTMODE <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3617 (hex)
DIM | - | PROFIBUS PNU | 1879 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1 | DPR | 279 (dec)
Default | 1 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Unterspannungsmodus

Beschreibung

Die Konfigurationsvariable UVLTMODE aktiviert bzw. sperrt die Unterspannungsüberwachung des Verstärkers. Bei aktivierter Überwachung (UVLTMODE=1) wird die Fehlermeldung F05 (Unterspannung) generiert, sobald die Zwischenkreisspannung die Unterspannungsschwelle VBUSMIN unterschreitet.


ASCII Deutsch V

ASCII - Kommando | V |
Syntax Senden | V |
Syntax Empfangen | V <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3618 (hex)
DIM | MUNIT | PROFIBUS PNU | 1880 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 280 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Aktuelle Drehzahl

Beschreibung

Die aktuelle Drehzahl des Motors.


ASCII Deutsch VBUS

ASCII - Kommando | VBUS |
Syntax Senden | VBUS |
Syntax Empfangen | VBUS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361A (hex)
DIM | Volts | PROFIBUS PNU | 1882 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 900 | DPR | 282 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | Zwischenkreisspannung

Beschreibung

Die aktuelle Zwischenkreisspannung.


ASCII Deutsch VBUSBAL

ASCII - Kommando | VBUSBAL |
Syntax Senden | VBUSBAL [Data] |
Syntax Empfangen | VBUSBAL <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361B (hex)
DIM | - | PROFIBUS PNU | 1883 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2, 3 | DPR | 283 (dec)
Default | 2 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Ja
Kurzbeschreibung | Maximale Netzspannung

Beschreibung

Mit dieser Einstellung wird die für die Motoren zulässige Netzspannung eingestellt. Wenn beispielsweise ein Motor, der für 400V Einspeisung ausgelegt ist, an den Verstärker angeschlossen wird, so sollte die Einstellung VBUSBAL = 2 (400V) sein. Damit wird die Ballast- und Überspannungsschwelle im Verstärker auf für den Motor verträgliche Werte eingestellt. Damit ist sichergestellt, dass der Motor keinen Wicklungsschaden erleidet.
Falls mehrere Verstärker mit Netz und Zwischenkreis parallel geschaltet werden, so müssen alle den gleichen Wert für VBUSBAL haben. Er muss dann auf den Motor mit niedrigsten Nennspannung eingestellt sein.

VBUSBAL=0 (110 V) VBUSMAX=450V
VBUSBAL=1 (230 V) VBUSMAX=800V
VBUSBAL=2 (400 V) VBUSMAX=900V
VBUSBAL=3 (480 V) VBUSMAX=900V


ASCII Deutsch VBUSMAX

ASCII - Kommando | VBUSMAX |
Syntax Senden | VBUSMAX |
Syntax Empfangen | VBUSMAX <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 361C (hex)
DIM | Volts | PROFIBUS PNU | 1884 (dec) IND = 0000xxxx (bin)
Bereich | 450, 800, 900 | DPR | 284 (dec)
Default |  |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Maximale Zwischenkreisspannung

Beschreibung

Der Parameter VBUSMAX zeigt den Wert der Überwachungsschwelle für die Fehlermeldung F02 (Überspannung). Die Fehlermeldung wird generiert sobald die Zwischenkreisspannung den Wert VBUSMAX überschreitet. Die Schwelle VBUSMAX hängt von der Einstellung VBUSBAL ab:

VBUSBAL=0 (230 V) VBUSMAX=450V
VBUSBAL=1 (400 V) VBUSMAX=800V
VBUSBAL=2 (480 V) VBUSMAX=900V


ASCII Deutsch VBUSMIN

ASCII - Kommando | VBUSMIN |
Syntax Senden | VBUSMIN [Data] |
Syntax Empfangen | VBUSMIN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 361D (hex)
DIM | Volts | PROFIBUS PNU | 1885 (dec) IND = 0000xxxx (bin)
Bereich | 30 .. 800 | DPR | 285 (dec)
Default | 100 |
Opmode | All | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Minimale Zwischenkreisspannung

Beschreibung

VBUSMIN legt die untere Schwelle für die Überwachung der Zwischenkreisspannung. Sobald diese Schwelle unterschritten wird, wird die Fehlermeldung F05 (Unterspannung) generiert. Die Überwachung der Unterspannung ist nur unter folgenden Voraussetzungen aktiv:
1. Endstufe freigegeben
2. Überwachung aktiviert UVLTMODE=1
3. NETZBTB-Funktion nicht aktiv (OxMODE<>3)
4. Abschalten der Überwachungsfunktion über einen digitalen Eingang INxMODE=21 nicht aktiv.


ASCII Deutsch VBW

ASCII - Kommando | VBW |
Syntax Senden | VBW |
Syntax Empfangen | VBW | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 | DPR | Nein
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Ausgabe eines Bode-Diagrammes

Beschreibung

VBW [fmin] [fmax] [sample]

Velocity BandWidth

Mit der Funktion VBW wird vom Verstärker ein Bode Diagramm des Drehzahlregelkreises ermittelt. Standard sind 50 (sample) Messungen zwischen 20 Hz (fmin) und 500 Hz (fmax). Gemessen wird die Verstärkung in dB und die Phasenverschiebung in Grad vom offenen und vom geschlossenen Regelkreis. Damit der offene Regelkreis bestimmt werden kann muß GVFR 1 (PI-Regler) sein. Bei MSG 2 werden die Ergebnisse sofort angezeigt, ansonsten können die Daten mit GET abgerufen werden. Zur Nutzung der Funktion VBW sollte der Verstärker Enabled und im OPMODE 0 sein.
Die Welle dreht sich zur Bestimmung nur um wenige Grad. Im Falle von starken Resonanzen können Überschwingungen Fehler auslösen, die das ungeregelte Auslaufen des Antriebs bewirken können.


ASCII Deutsch VCMD

ASCII - Kommando | VCMD |
Syntax Senden | VCMD |
Syntax Empfangen | VCMD <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 361E (hex)
DIM | MUNIT | PROFIBUS PNU | 1886 (dec) IND = 0000xxxx (bin)
Bereich | -VMAX .. VMAX | DPR | 286 (dec)
Default | - |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Actual Values | EEPROM | Nein
Kurzbeschreibung | interner Drehzahlsollwert in UPM

Beschreibung

Die Variable VCMD enthält den internen Drehzahlsollwert (hinter dem Rampengenerator) in UPM.
Je nach eingestellter Betriebsart (OPMODE=0) wird dieser Wert direkt digital vorgegeben (Feldbus,Slot-Karte) bzw. aus dem analogen Drehzahlsollwert (OPMODE=1) berechnet.
Bei den Betriebsarten, die keinen Drehzahlregler verwenden (OPMODE=2,3) enthält die Variable VCMD den Wert der Ist-Drehzahl V.


ASCII Deutsch VCOMM

ASCII - Kommando | VCOMM |
Syntax Senden | VCOMM [Data] |
Syntax Empfangen | VCOMM <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 365A (hex)
DIM | rpm | PROFIBUS PNU | 1946 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 1.2 * MSPEED | DPR | 346 (dec)
Default | 1500 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Ja
Kurzbeschreibung | Drehzahlschwelle für Kommutierungsüberwachung

Beschreibung

Mit dem Kommando VCOMM wird die Drehzahlschwelle für die Überwachung des Kommutierungsfehlers eingestellt.
Der Kommutierungsfehler liegt vor, wenn das Vorzeichen des Strom-Istwertes und das Vorzeichen der Geschwindigkeitsänderung nicht zueinander passen. Dies deutet auf das Durchgehen des Motors hin und wird durch sofortiges Sperren der Endstufe
unterbunden.

Der Kommutierungsfehler wird nur dann Überwacht, wenn die aktuelle Drehzahl die eingestellte Schwelle VCOMM überschreitet. Um die Überwachung abzuschalten, muß
der Schwellenwert VCOMM auf VLIM gesetzt werden.


ASCII Deutsch VCTAB

ASCII - Kommando | VCTAB |
Syntax Senden | VCTAB [Data] |
Syntax Empfangen | VCTAB <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer8 Integer16 Integer32 | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 .. 7, 0 .. +/- VLIM, +/- IPEAK | DPR | Nein
Default | 0 |
Opmode | 0, 1 | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Digital I/O | EEPROM | Nein
Kurzbeschreibung | Definition eines VCT-Eintrages

Beschreibung

IN VORBEREITUNG !

Das Kommando VCTAB dient zur Definition/Anzeige der VC-Tabelle (Velocity/Current-Tabelle). Die VC-Tabelle enthält 8 Drehzahl/Strom-Paare
(VCT-Einträge). Ein VCT-Eintrag kann entweder über die digitalen Eingänge oder aber über ein ASCII- oder SDO-Kommando aktiviert werden.
Wenn ein VCT-Eintrag aktiviert wird, so wird die in dem Eintrag enthaltene Drehzahl als digitaler Drehzahlsollwert übernommen (nur bei OPMODE=0 möglich). Der Stromwert aus dem VCT-Eintrag wird als Strombegrenzung übernommen.
Bei analogen Drehzahlvorgaben (OPMODE=1) wird der Drehzahlsollwert ignoriert, der Stromwert wird aber weiterhin für die Strombegrenzung benutzt.
Die VC-Tabelle wird nicht im seriellen EEPROM sondern in dem Flash-Eprom (Fahrsatz-Segment) abgespeichert. Aus diesem Grund sind die Änderungen der Tabelleneinträge nur bei gesperrten Endstufe möglich.

Das Kommando VCTAB kann in 3 verschiedenen Formen benutzt werden:
1. VCTAB nr vsoll ilimit
Mit diesem Kommando wird der VCT-Eintrag „nr“ mit dem Drehzahlsollwert „vsoll“ und dem Stromgrenzwert „ilimit“ initialisiert.
nr <0...7>
vsoll <-16000 UPM...16000 UPM>
ilimit <0....100000 mA>

In dieser Form darf das Kommando nur bei gesperrten Endstufe benutzt werden.

2. VCTAB nr
Mit diesem Kommando wird der Inhalt des VCT-Eintrages „nr“ ausgegeben.
Die Ausgabe erfolgt im Format VCTAB nr vsoll ilimit

3. VCTAB
Mit diesem Kommando wird der Inhalt der VC-Tabelle über die RS232-Schnittstelle ausgegeben.
Die Ausgabe besteht aus 8 Zeilen, die jeweils folgende Form haben:
VCTAB nr vsoll ilimit

s. auch Beschreibung der Kommandos SETVCT und INxMODE


ASCII Deutsch VEL0

ASCII - Kommando | VEL0 |
Syntax Senden | VEL0 [Data] |
Syntax Empfangen | VEL0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3620 (hex)
DIM | - | PROFIBUS PNU | 1888 (dec) IND = 0000xxxx (bin)
Bereich |  | DPR | 288 (dec)
Default | 5 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Stillstandsschwelle

Beschreibung

Der Parameter VEL0 (Vel "0") legt die Drehzahlschwelle (in UPM) für die Stillstandsmeldung fest.
Die Stillstandsmeldung wird für folgende Funktionen gebraucht:
1. Stillstandsmeldung in dem Statusregister DRVSTAT.
2. Bei konfigurierter Bremse (MBRAKE=1) wird beim Disablen der Endstufe zunächst die Drehzahl auf 0 reduziert und erst nachdem die Drehzahl die Stillstandgrenze unterschritten hatte, die Bremse angesteuert.
3. Bei aktivierten ACTFAULT-Option (aktives Bremsen in Fehlerfall) bzw. STOPMODE-Option (aktives Bremsen beim Disablen der Endstufe), bestimmt die Stillstandsschwelle den Drehzahlwert, unterhalb dessen die Endstufe tatsächlich gesperrt wird.


ASCII Deutsch VER

ASCII - Kommando | VER |
Syntax Senden | VER [*] |
Syntax Empfangen | VER <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Ja
ASCII Format | String | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | max 50 ASCII Characters | DPR | Nein
Default | - |
Opmode | All | Datentyp Bus/DPR | -
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Basic Setup | EEPROM | Nein
Kurzbeschreibung | Firmware-Version

Beschreibung

Das Kommando VER liefert die Versionsbezeichnung sowie das Erstellungsdatum der Firmware.
Die erweiterte Versione des Kommandos (VER *) liefert eine Version-Aufstellung der einzelnen Firmware/Hardware-Komponenten:
- Version der Basis-Firmware
- Hardware-Revision
- CPLD-Version
- FPGA-Version (diese Versionsbezeichnung beschreibt die Art des geladenen FPGA-Programmes und kann je nach Konfiguration des Gerätes unterschiedlich sein ) s., GEARMODE
- CAN: Firmware-Version
- Version der Motor Daten Bank (MDB)
- Profibus/Sercos:Firmware-Version


ASCII Deutsch VJOG

ASCII - Kommando | VJOG |
Syntax Senden | VJOG [Data] |
Syntax Empfangen | VJOG <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3621 (hex)
DIM | see VUNIT | PROFIBUS PNU | 1889 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... VLIM/VLIMN | DPR | 289 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Tippbetrieb-Geschwindigkeit

Beschreibung

Der Tippbetrieb entspricht einem Endlos-Fahrsatz und wird über den internen Lageregler realisiert.
Das Vorzeichen der Geschwindigkeit gibt die Richtung für den Tippbetrieb an. Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VLIMN

ASCII - Kommando | VLIMN |
Syntax Senden | VLIMN [Data] |
Syntax Empfangen | VLIMN <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3623 (hex)
DIM | rpm | PROFIBUS PNU | 1891 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. MSPEED | DPR | 291 (dec)
Default | 3000 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Max. negative Drehzahl

Beschreibung

Der Parameter VLIMN gibt die maximale Drehzahl für die negative Drehrichtung (Drehzahlregler) in UPM an.
Darüber hinaus wird VLIMN für die Begrenzung von PVMAXN benutzt:
PVMAXN <= (VLIMN * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIMP, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIMP bestimmt die maximale Drehzahl für die positive Drehrichtung.


ASCII Deutsch VLIMP

ASCII - Kommando | VLIMP |
Syntax Senden | VLIM [Data] |
Syntax Empfangen | VLIMP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3622 (hex)
DIM | rpm | PROFIBUS PNU | 1890 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. MSPEED | DPR | 290 (dec)
Default | 3000 |
Opmode | 0, 1 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Max. Drehzahl

Beschreibung

Der Parameter VLIMP gibt die maximale Drehzahl für die negative Drehrichtung (Drehzahlregler) in UPM an.
Darüber hinaus wird VLIMP für die Begrenzung von PVMAXP benutzt:
PVMAXP <= (VLIMP * PGEARI * 2^PRBASE) / (60 * PGEARO)

In Verbindung mit dem Parameter VLIMN, kann eine drehrichtungsabhängige Drehzahlbegrenzung realisiert werden. Das Kommando VLIMN bestimmt die maximale Drehzahl für die negative Drehrichtung.


ASCII Deutsch VLO

ASCII - Kommando | VLO |
Syntax Senden | VLO [Data] |
Syntax Empfangen | VLO <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 363D (hex)
DIM | - | PROFIBUS PNU | 1917 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 5.0 | DPR | 317 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Feedback | EEPROM | Ja
Kurzbeschreibung | Software Resolver/Digital Wandler Vorsteuerung

Beschreibung

VLO ist ein Parameter des Luenberger Drehzahl Beobachters. Um den Zeitverzug durch die Differentiation zu minimieren, kann dem Beobachter die drehmomentbildende Komponente des Stroms bereitgestellt werden. Das effektive Trägheitsmoment wird aus der Kreisverstärung des Drehzahlreglers abgeschätzt (GV). Bei VLO 0 ist die Beschleunigungsberücksichtigung ausgeschaltet. Bei VLO 1 wird sie zu 100 % berücksichtigt. Bei VLO 0.5 werden nur 50% der Beschleunigung berücksichtigt. Eine Verkleinerung von VLO kann die Stabilität des Drehzahlregelkreises gefährden.


ASCII Deutsch VMIX

ASCII - Kommando | VMIX |
Syntax Senden | VMIX [Data] |
Syntax Empfangen | VMIX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3625 (hex)
DIM | - | PROFIBUS PNU | 1893 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.0 | DPR | 293 (dec)
Default | 1.0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Geschwindigkeitmix Feedback / externer Geber

Beschreibung

IN VORBEREITUNG !

Beim Einsatz eines externen Gebers für die Lageregelung (EXTPOS=1) wird die Lageregelung über die Positionsinformation des externen Gebers, die Kommutierung und Geschwindigkeitsregelung über die Positionsinformation des über FBTYPE angewählten Gebers realisiert. Mit dem Parameter VMIX kann festgelegt werden, in welchem Verhältnis die Feedback-Einheit am Motor und der externe Geber für die Drehzahlregelung verwendet werden soll.

z.B:
VMIX=1.0 Geschwindigkeit ausschließlich über das mit FBTYPE angewählte Rückführungssystem (100 %)
VMIX=0.5 50 % über das mit FBTYPE angewählte Rückführungssystem/ 50 % externer Geber

VMIX ist nur bei FILTMODE = 0 oder 1 aktiv.
VMIX ist nur im Lagereglermodus OPMODE = 8 verfügbar.


ASCII Deutsch VOSPD

ASCII - Kommando | VOSPD |
Syntax Senden | VOSPD [Data] |
Syntax Empfangen | VOSPD <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Float | CANBus Objektnummer | 3627 (hex)
DIM | rpm | PROFIBUS PNU | 1895 (dec) IND = 0000xxxx (bin)
Bereich | 0.0 .. 1.2*MSPEED | DPR | 295 (dec)
Default | 3600 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Überdrehzahl

Beschreibung

Mit dem Parameter VOSPD kann die Abschaltschwelle für die Fehlermeldung F08 (Überdrehzahl) festgelegt werden. Sobald die aktuelle Drehzahl den eingestellten Schwellenwert überschreitet, so wird die Fehlermeldung F08 generiert und die Endstufe gesperrt.


ASCII Deutsch VREF

ASCII - Kommando | VREF |
Syntax Senden | VREF [Data] |
Syntax Empfangen | VREF <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 3628 (hex)
DIM | µm/s | PROFIBUS PNU | 1896 (dec) IND = 0000xxxx (bin)
Bereich | 0 ... VLIM/VLIMN | DPR | 296 (dec)
Default | 10000 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Referenzfahrt-Geschwindigkeit

Beschreibung

Mit dem Parameter VREF wird der Geschwindigkeitsbetrag (VREF>0) für die Referenzfahrt vorgegeben. Die Referenzrichtung wird der Variable DREF entnommen.
Die Normierung der Geschwindigkeit wird in den Lageregler-Einheiten vorgegeben und hängt von den Parametern PGEARI und PGEARO ab.


ASCII Deutsch VREF0

ASCII - Kommando | VREF0 |
Syntax Senden | VREF0 [Data] |
Syntax Empfangen | VREF0 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 3698 (hex)
DIM | - | PROFIBUS PNU | 2008 (dec) IND = 0000xxxx (bin)
Bereich | 0.01 .. 2.0 | DPR | 408 (dec)
Default | 0.125 |
Opmode | 8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Ja
Kurzbeschreibung | Reduzierfaktor Referenzfahrgeschwindigkeit

Beschreibung

IN VORBEREITUNG !

Mit dem Parameter VREF0 kann die Referenzfahrtgeschwindigkeit VREF
während der Suche eines externen Nullimpulses reduziert werden.
Bei Verwendung einer Referenzfahrt mit Nullpunktsuche, kann die Quelle des Nullimpulses mit dem Parameter REFMODE festgelegt werden. Bei REFMODE>0
wird der Nullimpuls auf dem vorgewählten Hardware-Eingang erwartet (s. REFMODE).
Da das Einlesen des Nullimpulses mit einer Abtastzeit von 250 µsek erfolgt,
ist es oft wünschenswert für die Suchphase eine geringere Referenzfahrtgeschwindigkeit als VREF zu benutzen.

Mit dem Parameter VREF0 kann die Geschwindigkeitreduzierung in % von VREF angegeben werden.

Beispiel 1:

REFMODE=1 Nullimpuls über digitalen Eingang 1
NREF=1 Referenzfahrt auf Referenzschalter mit Nullpunktsuche
VREF=10000 Referenzfahrtgeschwindigkeit 10000 µm/sek
VREF0=0.2 Reduktion der Geschwindigkeit auf 2000 µm/sek

Beim Start der Referenzfahrt fährt der Antrieb mit der Geschwindigkeit 10000 bis zu dem Referenzschalter. Nachdem der Referenzschalter erreicht wurde, wird die Geschwindigkeit auf 20% (2000) reduziert. Der Antrieb fährt mit reduzierter Geschwindigkeit bis ein Nullimpuls am digitalen Eingang 1 (High Pegel) erkannt wird.

Beispiel 2:

REFMODE=2 Nullimpuls über digitalen Eingang 2
NREF=5 Nullposition innerhalb einer Umdrehung
VREF=10000
VREF0=0.2

Da das Kriterium für die Suche des Nullimpulses sofort beim Start der Referenzfahrt erfüllt ist, so wird die Referenzfahrt sofort mit der reduzierten Geschwindigkeit 2000 µm/sek.


ASCII Deutsch VSCALE1

ASCII - Kommando | VSCALE1 |
Syntax Senden | VSCALE1 [Data] |
Syntax Empfangen | VSCALE1 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 3629 (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1897 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 297 (dec)
Default | 3000 |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | SW1-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang SW1 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE1 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang SW1 stellt sich eine VSCALE1-Drehzahl ein.


ASCII Deutsch VSCALE2

ASCII - Kommando | VSCALE2 |
Syntax Senden | VSCALE2 [Data] |
Syntax Empfangen | VSCALE2 <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer16 | CANBus Objektnummer | 362A (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1898 (dec) IND = 0000xxxx (bin)
Bereich | -15000 .. 15000 | DPR | 298 (dec)
Default | 3000 |
Opmode | 1 | Datentyp Bus/DPR | Integer16
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Analog I/O | EEPROM | Ja
Kurzbeschreibung | SW2-Drehzahlskalierungsfaktor

Beschreibung

Falls der Analogeingang SW2 als Sollwerteingang für die Drehzahlregelung benutzt wird, so kann mit dem Parameter VSCALE2 die Normierung der Eingangsspannung festgelegt werden.
Bei 10V-Drehzahlsollwert am Eingang SW2 stellt sich eine VSCALE2-Drehzahl ein.


ASCII Deutsch VSTFR

ASCII - Kommando | VSTFR |
Syntax Senden | VSTFR [Data] |
Syntax Empfangen | VSTFR <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Float | CANBus Objektnummer | 36A5 (hex)
DIM | VUNIT | PROFIBUS PNU | 2021 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 230 UPM | DPR | 421 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung | 1000
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Drehzahleckpunkt bei Reibungskompensation

Beschreibung

IN VORBEREITUNG !

Die beiden Kommandos ISTFR und VSTFR definieren die Eckwerte für die Reibungs-Kompensation. Mit ISTFR wird diese Kompensation aktiviert und bewirkt die Aufschaltung einer drehzahlabhängigen Stromvorsteuerung.

V=0 -> IFRICT = 0
V= 50% von VSTFR -> IFRICT = 50% von ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% von VSTFR -> IFRICT = -50% von ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII Deutsch VTUNE

ASCII - Kommando | VTUNE |
Syntax Senden | VTUNE |
Syntax Empfangen | VTUNE | Vorhanden in |
Type | Command | Setup Software | Nein
ASCII Format | - | CANBus Objektnummer | Nein
DIM | - | PROFIBUS PNU | Nein
Bereich | 0 | DPR | Nein
Default | 0 |
Opmode | 0 | Datentyp Bus/DPR | -
Verstärker Status | Enabled | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | -
Kurzbeschreibung | Ermittlung der Drehzahlreglerparameter

Beschreibung


ASCII Deutsch VUNIT

ASCII - Kommando | VUNIT |
Syntax Senden | VUNIT [Data] |
Syntax Empfangen | VUNIT <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 365F (hex)
DIM | - | PROFIBUS PNU | 1951 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 8 | DPR | 351 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status |  | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Velocity Controller | EEPROM | Ja
Kurzbeschreibung | Systemweite Definition der Drehzahl / Geschw.

Beschreibung

Mit dem Kommando VUNIT kann die systemweite Drehzahl- und Geschwindigkeiteinheit
definiert werden. Diese Einheit gilt für alle Drehzahl-/Geschwindigkeitabhängige Parameter des Drehzahl- und Lagereglers.

VUNIT = 0 Vorgabe der Drehzahl in UPM / Vorgabe der Geschwindigkeit in µm/sek
VUNIT = 1 Einheit = UPM
VUNIT = 2 Einheit = Rad/Sec
VUNIT = 3 Einheit = Grad/Sec
VUNIT = 4 Einheit = Counts/250 µsek
VUNIT = 5 Einheit = PUNIT/Sec
VUNIT = 6 Einheit = PUNIT/Min
VUNIT = 7 Einheit = 1000 * PUNIT / Sec
VUNIT = 8 Einheit = 1000 * PUNIT / Min

Anmerkung:
1. Alle drehzahlabhängige Parameter werden grundsätzlich als 32-Bit Fixpoint
Zahlen (3 Nachkommastellen) vorgegeben. Aus diesem Grund kann bei manchen VUNIT-Einstellungen (besonders VUNIT=6), abhängig von der eingestellten Auflösung PGEARI, nicht der gesamte Drehzahlbereich abgedeckt werden. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

2. Alle geschwindigkeitabhängige Parameter werden grundsätzlich als 32-Bit Integer-Zahlen vorgegeben. Aus diesem Grund ist es nicht möglich, insbesondere bei der Einstellung VUNIT=3, eine Geschwindigkeit mit Nachkommastellen einzugeben. Es ist darauf zu achten, daß jeweils abhängig von der Anwendung eine geeignete Einheit VUNIT verwendet wird.

Umrechnungsfaktoren für die Drehzahleinheiten

VUNIT=1 1 UPM = 1048576*32/(4000*60) =~ 139.8 Counts
VUNIT=2 1 Rad/sek = 1048576*32/(4000*2*PI) =~ 1335 Counts
VUNIT=3 1 Grad/sek = 1048576*32/(4000*360) =~ 23.3 Counts
VUNIT=4 1 Counts/250µs = 32 Counts
VUNIT=5 1 PUNIT / sec = PGEARO / (125 * PGEARI)
VUNIT=6 1 PUNIT / min = (PGEARO * 60) / (125 * PGEARI)
VUNIT=7 1000 PUNIT / sec = PGEARO / (125 * PGEARI * 1000)
VUNIT=8 1000 PUNIT / min = (PGEARO * 60) / (125 * PGEARI * 1000)


ASCII Deutsch WMASK

ASCII - Kommando | WMASK |
Syntax Senden | WMASK [Data] |
Syntax Empfangen | WMASK <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Ja
ASCII Format | Integer32 | CANBus Objektnummer | 363E (hex)
DIM | - | PROFIBUS PNU | 1918 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 4294967295 (1 Bit is 1 warning) | DPR | 318 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Amplifier | EEPROM | Nein
Kurzbeschreibung | Warnung/Fehler-Maske

Beschreibung

Mit dem Parameter WMASK kann eine Warnung in die Fehlermeldung F24 umkonfiguriert werden.
Der Parameter WMASK ist eine Bit-Variable deren Belegung der Statusvariable STATCODE * entspricht. Das gesetzte Bit innerhalb der WMASK-Variable bedeutet, daß das zugehörige Warnung-Bit in der STATCODE *-Variable außer einer Warnung auch die Fehlermeldung F24 generieren soll. Im Gegensatz zu den Warnungen führt eine Fehlermeldung zum Sperren der Endstufe und zum Öffnen des BTB-Kontaktes. Das Umkonfigurieren der Warnungen zu Fehlermeldungen kann besonders bei folgenden Warnungen sinnvoll sein: Schleppfehler, Ansprechüberwachung, Hardware-Endschalter. Die Eingabe muss in Decimal und nicht in Hex erfolgen.


ASCII Deutsch WPOS

ASCII - Kommando | WPOS |
Syntax Senden | WPOS |
Syntax Empfangen | WPOS <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer8 | CANBus Objektnummer | 3636 (hex)
DIM | - | PROFIBUS PNU | 1910 (dec) IND = 0000xxxx (bin)
Bereich | 0, 1, 2 | DPR | 310 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer8
Verstärker Status | Disabled + Reset (Coldstart) | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Ja | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister

Beschreibung

Neben den bereits vorhandenen Software-Endschaltern/Positionsmeldeschwellen (SWCNFG / SWCNFG2) wurde eine weitere Möglichkeit geschaffen um Positionen zu überwachen. Im Gegensatz zu der bereits vorhandenen Lösung, verhält sich die neue Überwachungsfunktion deterministisch. Überschreiten/Unterschreiten einer Position wird innerhalb 1 msek erkannt und gemeldet. Auch der Funktionsumfang der Überwachung wurde erweitert (ständig/einmalig).
Die schnellen Positionsregister werden mit Hilfe der Konfigurationsvariable WPOS freigegeben:
WPOS=0 Positionsregister gesperrt
WPOS=1 Positionsregister freigegeben, keine CAN-Spontanmeldung bei Statusänderung
WPOS=2 Positionsregister freigegeben, CAN-Spontanmeldung bei Statusänderung (diese Einstellung kann nur über den CAN-Bus erfolgen)

Die Änderung der Variable WPOS zwischen 0 und >0 kann nur Offline erfolgen (SAVE und COLDSTART), eine Änderung zwischen 1 und 2 kann auch online erfolgen.

Es gibt insgesamt 16 Positionsregister P1...P16, die mit Hilfe von 3 Steuervariablen konfiguriert werden können. Die Positionsmeldungen werden über eine Statusvariable gemeldet. Alle Steuer-/Statusvariablen sind als 32-Bit Variablen zu sehen bei denen die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16
benutzt werden.

Steuervariablen:
WPOSE Freigabe/Sperren eines Positionsregisters
Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht

WPOSP Polarität für die Positionsmeldung
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

WPOSX – Art der Positionsüberwachung
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit (WPOSE) auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

Statusvariable:
POSRSTAT (z_data.Posrstat) – Positionsmeldung
Bit=0 Positionsmeldung nicht aktiv
Bit=1 Positionsmeldung aktiv (Position überschritten bei WPOSP=0 bzw. unterschritten bei WPOSP=1).

Positionsregister:
Die Positionsregsiter 1 bis 16 können mit dem ASCII-Kommando P1...P16 angesprochen werden. Die Positionswerte werden in den Einheiten des Lagereglers (PGEARI / PGEARO-Umrechnung) vorgegeben.
Die für die schnellen Positionsregister benötigten Variablen WPOSE, WPOSP, WPOSX, P1...P16 können mit dem SAVE-Kommando im seriellen EEPROM abgespeichert werden. Die Positionsregister P1...P16, die nicht benutzt werden, sollten auf 0 gesetzt werden (da der Positionsregister-Default-Wert 0 beträgt, so wird kein Speicher im seriellen EEPROM belegt).
Die einzelnen Positionsmeldungen aus dem Statusregister POSRSTAT können auf die digitalen Ausgänge der Basisplatine ausgegeben werden.

OxMODE=40
Mit Hilfe dieser Funktion wird das Ergebnis einer ODER Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.

OxMODE=41
Mit Hilfe dieser Funktion wird das Ergebnis einer UND Verknüpfung zwischen der Bit-Variable POSRSTAT und einer Bitmaske aus der Hilfsvariable OxTRIG auf den digitalen Ausgang x ausgegeben.


ASCII Deutsch WPOSE

ASCII - Kommando | WPOSE |
Syntax Senden | WPOSE |
Syntax Empfangen | WPOSE <Data> | Vorhanden in |
Type | Variable ro | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 363F (hex)
DIM | - | PROFIBUS PNU | 1919 (dec) IND = 0000xxxx (bin)
Bereich | 0 ..65535 | DPR | 319 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Freigabe der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSE können die schnellen Positionsregister P1...P16 einzeln freigegeben oder gesperrt werden.Die Variable WPOSE ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.

Bit=0 das zugehörige Positionsregister wird nicht überwacht
Bit=1 das Positionsregister wird überwacht
s. auch WPOS


ASCII Deutsch WPOSP

ASCII - Kommando | WPOSP |
Syntax Senden | WPOSP [Data] |
Syntax Empfangen | WPOSP <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3640 (hex)
DIM | - | PROFIBUS PNU | 1920 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 320 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Polarität der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSP können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSP ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 Positionsmeldung wird generiert beim Überschreiten der Position
Bit=1 Positionsmeldung wird generiert beim Unterschreiten der zugehörigen Position

s. auch WPOS


ASCII Deutsch WPOSX

ASCII - Kommando | WPOSX |
Syntax Senden | WPOSX [Data] |
Syntax Empfangen | WPOSX <Data> | Vorhanden in |
Type | Variable rw | Setup Software | Nein
ASCII Format | Integer32 | CANBus Objektnummer | 3641 (hex)
DIM | - | PROFIBUS PNU | 1921 (dec) IND = 0000xxxx (bin)
Bereich | 0 .. 65535 | DPR | 321 (dec)
Default | 0 |
Opmode | All | Datentyp Bus/DPR | Integer32
Verstärker Status | - | Wichtung |
ab Firmware | 1.0 |
Konfiguration | Nein | Letzte Bearbeitung der Seite REV | 1.0
Funktionsgruppe | Position Controller | EEPROM | Nein
Kurzbeschreibung | Modus der schnellen Positionsregister 1...16

Beschreibung

Mit der Bit-Variable WPOSX können die schnellen Positionsregister P1...P16 einzeln konfiguriert werden.Die Variable WPOSX ist als 32-Bit Variable zu sehen bei der die unteren 16 Bits (Bit 0...15) für die Konfiguration der Positionsregister P1...P16 benutzt werden.
Bit=0 die Position wird ständig überwacht
Bit=1 die Position wird nur einmalig überwacht. Beim Erzeugen der Positionsmeldung wird das zugehörige Enable-Bit (WPOSE) auf 0 gesetzt, so daß die Überwachung des Positionsregisters gesperrt wird.

s. auch WPOS


ASCII English ACC

ASCII - Command | ACC |
Syntax Transmit | ACC [Data] |
Syntax Receive | ACC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3501 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1601 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 1 (dec)
Default | 10 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Acceleration Ramp

Description

This variable defines the acceleration ramp for the velocity control loop. The acceleration ramp is only used for command changes resulting in a velocity increase (acceleration). DEC is used for braking (deceleration).


ASCII English ACCR

ASCII - Command | ACCR |
Syntax Transmit | ACCR [Data] |
Syntax Receive | ACCR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3502 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1602 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767 | DPR | 2 (dec)
Default | 10 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Acceleration Ramp for homing/jog modes

Description

This variable defines the acceleration ramp used for jogging and homing with the internal position control loop. The entry is made in msec and is in reference to the final limit velocity for the selected mode (VJOG for jogging or VREF for homing). When starting the homing or jog mode, the ACCR acceleration ramp can (in some circumstances) be limited by the minimum acceleration time PTMIN.


ASCII English ACCUNIT

ASCII - Command | ACCUNIT |
Syntax Transmit | ACCUNIT [Data] |
Syntax Receive | ACCUNIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3659 (hex)
DIM | - | PROFIBUS PNU | 1945 (dec) IND = 0000xxxx (bin)
Range | 0, 1, .. , 5 | DPR | 345 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Type of acceleration setpoint for the system

Description

Using this command, the systemwide acceleration type is defined. This function is used for ramps of the trajectory generator (internal motion tasks OPMODE 8) and also for the ramps of the speed controller.

ACCUNIT = 1 Acceleration is defined in rad/sec²
ACCUNIT = 2 Acceleration is defined in rpm/sec
ACCUNIT = 3 Acceleration is defined in PUNIT/sec²
ACCUNIT = 4 Acceleration is defined in 1000*PUNIT/sec²
ACCUNIT = 5 Acceleration is defined 1000000*PUNIT/sec²

If ACCUNIT=0 is selected, the motion task acceleration can be given in mm/sec² (Bit 12 of the type of the motion task=1).
If ACCUNIT=1 is selected, this Bit is ignored, this means the ramps are calculated in rad/sec².

If ACCUNIT is changed, all acc/dec parameters are calculated in a different way to get the right unit. Affected are ACC, ACCR, DEC, DECR, DECSTOP, DECDIS.

The motion tasks are not affected. So, before defining a motion task ACCUNIT has to be set in right manner. If ACCUNIT is changed later, all motion tasks have to be proofed or changed !!!!

The accdec-ramps of the motion tasks are limited bei PTMIN.

Attention!
High acceleration corresponds to small values of PTMIN at ACCUNIT=0. If ACCUNIT is > 0, PTMIN is small if the acceleration is high.


ASCII English ACTFAULT

ASCII - Command | ACTFAULT |
Syntax Transmit | ACTFAULT [Data] |
Syntax Receive | ACTFAULT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3503 (hex)
DIM | - | PROFIBUS PNU | 1603 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 3 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Active Fault Mode

Description

The ACTFAULT command is used to specify the response of the drive if a fault occurs.
ACTFAULT=0: If a fault occurs, the output stage is immediately inhibited, the drive coasts down.
ACTFAULT=1: If a fault occurs, an Emergency Stop procedure is initiated, that consists of the following steps.
1. Switch over the controller mode to velocity control (OPMODE=0)
2. Change the braking ramp for the velocity control loop (DEC) to the emergency stop ramp (DECSTOP)
3. Set the internal velocity setpoint to 0 (before the ramp generator).
4. Start a timer (with time-out = 5 seconds)

As soon as the internal velocity setpoint (after the ramp generator) has reached 0, the output stage is inhibited and the original controller mode is re-activated. This will also happen if the time-out occurs before the velocity setpoint has reached 0.


ASCII English ACTIVE

ASCII - Command | ACTIVE |
Syntax Transmit | ACTIVE |
Syntax Receive | ACTIVE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3504 (hex)
DIM | - | PROFIBUS PNU | 1604 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 4 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Output stage active/inhibited

Description

The ACTIVE command returns the present status of the output stage.
ACTIVE=1 output stage is active/enabled
ACTIVE=0 output stage is inhibited/disabled

The following conditions must be met to enable the output stage, depending on the controller configuration:

1. Standard configuration (no active MainsBTB function)
- software enable set
- hardware enable set
- BTB is present

2. With active MainsBTB function (O1MODE or O2MODE=3)
- Software enable set
- hardware enable set
- BTB is present
- MainsBTB (Mains supply BTB) is present
- DC-link (DC-bus) voltage > undervoltage threshold


ASCII English ACTRS232

ASCII - Command | ACTRS232 |
Syntax Transmit | ACTRS232 [Data] |
Syntax Receive | ACTRS232 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3655 (hex)
DIM | - | PROFIBUS PNU | 1941 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 341 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | Activate RS232 Watchdog

Description

The ACTRS232 command activates or deactivates the monitoring of the serial interface (RS232-watchdog).

ACTRS232=0 no monitoring of serial communication
ACTRS232=1 the RS232-watchdog is activated. The watchdog timer can be set in msec through the RS232T command. The watchdog must be triggered by every serial command. When the timer runs out, all movement is stopped and the warning n04 is displayed. The warning must be cancelled by the “Acknowledge fault” function.
ACTRS232=2 the RS232-watchdog is activated. The watchdog timer can be set in msec through the RS232T command. The watchdog must be triggered by every serial command. When the timer runs out, the present movement is stopped and ACTRS232 is set to 0. No warning is given out.

After switching on the amplifier, the RS232-watchdog is always deactivated (ACTRS232=0). When a service function is initiated via the serial interface, the PC program (or external controls) should ensure that the monitoring of the serial interface is switched on. In this way, you can be sure that if communication is interrupted or the PC crashes, the service function will be automatically terminated.


ASCII English ADDR

ASCII - Command | ADDR |
Syntax Transmit | ADDR [Data] |
Syntax Receive | ADDR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Unsigned8 | CANBus Object Number | 3505 (hex)
DIM | - | PROFIBUS PNU | 1605 (dec) IND = 0000xxxx (bin)
Range | 0 .. 127 | DPR | 5 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Unsigned8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Multidrop Address

Description

This variable defines the station address (0 to 63) for the amplifier. This address is required by the fieldbus (CANBUS, PROFIBUS, SERCOS, etc.) and for the parameter setting of the servo amplifier in a multi-axis system for an unambiguous identification of the servo amplifier within the system. You can use the keys on the front panel of the servo panel to set the station address (refer to the Installation Manual). After changing the address, all parameters should be stored in the EEPROM (see SAVE) and the amplifier should be switched off and on again.

If MDRV = 0, the address range is changed to 0 .. 127.


ASCII English AENA

ASCII - Command | AENA |
Syntax Transmit | AENA [Data] |
Syntax Receive | AENA <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3506 (hex)
DIM | - | PROFIBUS PNU | 1606 (dec) IND = 0000xxxx (bin)
Range | 0 ,1 | DPR | 6 (dec)
Default | 1 |
Opmode | 0, 2, 4, 5, 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Software Auto-Enable

Description

This variable defines the state of the software enable when the amplifier is switched on. In order to enable the output stage, both the hardware enable and the software enable must be set (series AND configuration). The software enable gives an external control the option of enabling or disabling the output stage by software control, via a bus interface (CANBUS, PROFIBUS, SERCOS, RS232) or an expansion card in a slot.
0 = inactive
1 = active
When using an analog setpoint (OPMODE=1, 3), the software enable is automatically set when the amplifier is switched on, so that these instruments are instantly ready for operation (provided that the hardware enable is already present). When using a digital setpoint (OPMODE=0, 2, 4 through 8), the software enable is set to the same state as AENA at power-on.
For faults that can be reset in software after the fault has been cleared (digital input 1 or CLRFAULT), the software enable is set to the state of AENA. In this way, the response of the amplifier to a software reset is analogous to the power-on behavior.


ASCII English ALIAS

ASCII - Command | ALIAS |
Syntax Transmit | ALIAS [Data] |
Syntax Receive | ALIAS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | max 8 ASCII Characters | DPR | No
Default | DRIVE0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Drive Name

Description

The ALIAS command is used to assign a symbolic name to an amplifier. If the PC setup software is used, this name appears in the title bar of all open parameter windows.
In Multi-Drive mode (parameterizing several amplifiers that are grouped through the CAN bus) the ALIAS name can be used to give a clear assignment of the parameter window to the corresponding amplifier.


ASCII English AN11NR

ASCII - Command | AN11NR |
Syntax Transmit | AN11NR [Data] |
Syntax Receive | AN11NR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3699 (hex)
DIM | - | PROFIBUS PNU | 2009 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3, 4 | DPR | 409 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | No. Of INxTRIG variable, that is changed analog

Description

The parameter AN11NR defines the number (x) of the auxiliary variable IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG, which can be changed by the analog input 2: This parameter has effect only with ANCNFG=11 and ANCNFG=12.


ASCII English AN11RANGE

ASCII - Command | AN11RANGE |
Syntax Transmit | AN11RANGE [Data] |
Syntax Receive | AN11RANGE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 369A (hex)
DIM | - | PROFIBUS PNU | 2010 (dec) IND = 0000xxxx (bin)
Range | -262144 .. 262143 | DPR | 410 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Range of the analog change of INxTRIG

Description

The parameter AN11RANGE gives the change of IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG, that is caused by an analog input 2 step from 0V to 10V. The function is supported using ANCNFG=11 and ANCNFG=12.

Example:

ANCNFG=11
AN11NR=1
IN1TRIG=1000
AN11RANGE=500

at Analog input2 = 0V IN1TRIG = 1000
at Analog input2 = 10V IN1TRIG = 1500
at Analog input2 = -10V IN1TRIG = 500


ASCII English ANCNFG

ASCII - Command | ANCNFG |
Syntax Transmit | ANCNFG [Data] |
Syntax Receive | ANCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3507 (hex)
DIM | - | PROFIBUS PNU | 1607 (dec) IND = 0000xxxx (bin)
Range | 0 .. 14 | DPR | 7 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Configuration of Analog Input

Description

The ANCNFG command is used to configure the function of the analog inputs. Since the ANCNFG variable is used for the configuration of the instrument, the controller must be switched off and then on again after the variable has been changed (use SAVE first).
Status |  | Description
ANCNFG=0 | (Xcmd=Setp.1) | SW1 is used as velocity setpoint or current setpoint depending on the status of OPMODE (velocity in OPMODE =1; current in OPMODE=3). If one of the digital inputs is selected for IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG=8 (switch-over between SW1 and SW2), SW1 (input=low) or SW2 (input=high) have the functionality. Scaling : SW1 velocity Setpoint VSCALE1 (OPMODE=1) SW1 Current Setpoint ISCALE1 (OPMODE=3) SW2 velocity Setpoint VSCALE2 (OPMODE=1) SW2 Current Setpoint ISCALE2 (OPMODE=3)
ANCNFG=1 | v_cmd=Setp.1, Icmd=Setp.2 | SW1 is used as velocity setpoint if OPMODE = 1 (scaling factor VSCALE1) SW2 is used as current setpoint if OPMODE = 3 (scaling factor ISCALE2)
ANCNFG=2 | Setp.1 = nsoll, Setp.2 = Isoll | SW1 velocity setpoint SW2 current feedforward (OPMODE=0,1) scaling factor ISCALE2
ANCNFG=3 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of SW2 limits the current of the drive 10V 100% of IPEAK 5V 50% of IPEAK
ANCNFG=4 | Xcmd=Setp.1+Setp.2 | The sum of SW1 and SW2 is used for velocity or current setpoint, depending on OPMODE. OPMODE 1 velocity setpoint OPMODE 3 current setpoint
ANCNFG=5 | Xcmd=Setp.1*Setp.2 | The multiplikation of SW1 and SW2 is used for velocity or current setpoint, depending on OPMODE. OPMODE 1 velocity setpoint OPMODE 3 current setpoint SW1 VSCALE1/ISCALE1 SW2 10V means 100% -10V means -100%
ANCNFG=6 | Electronic Gearing | SW1 is used as velocity or current setpoint, depending on OPMODE SW2 is used as scaling factor for electronic gearing (OPMODE=4). VSCALE2 is used to define a correction factor in %. e.g. VSCALE2=20 (means 20%) SW2= +10V GEAROeff=GEARO * 1.2 SW2= -10V GEAROeff=GEARO * 0.8 SW2= 0V GEAROeff=GEARO
ANCNFG=7 | Setp.1 = Isoll, Setp.2 = Nmax | SW1 is used as current setpoint (ISCALE1) (OPMODE has to be set to 3). SW2 limits the velocity of the motor SW2=10V, Nmax=(VSCALE2) If the velocity of the motor is greater than Nmax, the velocity is limited.
ANCNFG=8 | Setp.1 = Psoll | SW1 is used as a analog position setpoint (only available in OPMODE=5). The working distance is defined by SRND and ERND. SW1 = 0V Position = SRND SW1= +/-10V Position = ERND When the drive is switched on, the reference point is not set and the drive does not move. The OPMODE can be set to 5. The a reference move can be starte bs digital input. After that, when the homing move is finished, the input can be set to zero again and then the drive moves automatically to the given analog position. POSCNFG has to be "0" (linear axes type).
ANCNFG=9 |  | Analog input 1: velocity or current setpoint (same as ANCNFG=0) Analog input 2: Ferraris sensor
ANCNFG=10 | Reserved |
ANCNFG=11 |  | Change of an IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG variable via the analog input 2. The corresponding Number (x) of the trigger variable is set by AN11NR. The range of the parameter change is defined by AN11RANGE. The change of the analog in 2 directly changes the INxTRIG variable (update time 1 to 10ms), see also AN11NR and AN11RANGE.
ANCNFG=12 |  | Change of an IN1TRIG, IN2TRIG, IN3TRIG or IN4TRIG variable via the analog input 2. The corresponding Number (x) of the trigger variable is set by AN11NR. The range of the parameter change is defined by AN11RANGE. The change of the analog in 2 changes the INxTRIG variable after a rising edge at digital inputx, see also AN11NR and AN11RANGE.
ANCNFG=13 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of SW2 limits the positive current of the drive 10V 100% of IPEAK 5V 50% of IPEAK The negative current is not effected. In the positive direction, the acceleration current is limited and in the negative direction the deceleration current.
ANCNFG=14 | Xcmd=Setp.1, Ipeak1=Setp.2 | SW1 depending on OPMODE velocity or current setpoint (scaling VSCALE1 or ISCALE1) The absolute of SW2 limits the negative current of the drive 10V 100% of IPEAK 5V 50% of IPEAK The positive current is not effected. In the negative direction, the acceleration current is limited and in the negative direction the deceleration current.


ASCII English ANDB

ASCII - Command | ANDB |
Syntax Transmit | ANDB [Data] |
Syntax Receive | ANDB <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3508 (hex)
DIM | Millivolts | PROFIBUS PNU | 1608 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 10000.0 | DPR | 8 (dec)
Default | 0 |
Opmode | 1, 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Dead Band of the Analog Velocity Input Signal

Description

This variable suppresses small analog input signals by setting a dead band zone in which signals are ignored. This function is useful with OPMODE=1 (without higher-level position control). Depending on the operating mode, this parameter applies to SW1 or SW2 (depending on which setpoint input is used as the source for the velocity value). See ANCNFG for additional information.


ASCII English ANIN1

ASCII - Command | ANIN1 |
Syntax Transmit | ANIN1 |
Syntax Receive | ANIN1 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3509 (hex)
DIM | Millivolts | PROFIBUS PNU | 1609 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 9 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Voltage at Analog Input SW1

Description

The ANIN1 command returns the present value of the voltage at the analog input SW1.


ASCII English ANIN2

ASCII - Command | ANIN2 |
Syntax Transmit | ANIN2 |
Syntax Receive | ANIN2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 350A (hex)
DIM | Millivolts | PROFIBUS PNU | 1610 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 10 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Voltage at Analog Input SW2

Description

The ANIN2 command returns the present value of the voltage at the analog input SW2.


ASCII English ANOFF1

ASCII - Command | ANOFF1 |
Syntax Transmit | ANOFF1 [Data] |
Syntax Receive | ANOFF1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 350B (hex)
DIM | Millivolts | PROFIBUS PNU | 1611 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 11 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Analog Offset for input SW1

Description

This variable compensates for the offset voltages of CNC controls and the analog input, ANIN1 (SW1). It can also correct an analog offset from external controls.


ASCII English ANOFF2

ASCII - Command | ANOFF2 |
Syntax Transmit | ANOFF2 [Data] |
Syntax Receive | ANOFF2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 350C (hex)
DIM | Millivolts | PROFIBUS PNU | 1612 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 12 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Analog Offset for input SW2

Description

This variable compensates for the offset voltages of CNC controls and the analog input, ANIN2 (SW2). It can also correct an analog offset from external controls.


ASCII English ANZERO1

ASCII - Command | ANZERO1 |
Syntax Transmit | ANZERO1 |
Syntax Receive | ANZERO1 | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 350F (hex)
DIM | - | PROFIBUS PNU | 1615 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 15 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | -
Short Description | Zero Analog Input SW1

Description

This command can be used to start the automatic offset correction for the analog input 1. The setpoint at analog input 1 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF1 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.


ASCII English ANZERO2

ASCII - Command | ANZERO2 |
Syntax Transmit | ANZERO2 |
Syntax Receive | ANZERO2 | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3510 (hex)
DIM | - | PROFIBUS PNU | 1616 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 16 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | -
Short Description | Zero Analog Input SW2

Description

This command can be used to start the automatic offset correction for the analog input 2. The setpoint at analog input 2 should be short-circuited before using this command. After the command has been carried out, the offset value that was determined is available in the ANOFF2 parameter. To save this value permanently in the EEPROM, you should use the SAVE (save to EEPROM) command.


ASCII English AUTOHOME

ASCII - Command | AUTOHOME |
Syntax Transmit | AUTOHOME [Data] |
Syntax Receive | AUTOHOME <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D7 (hex)
DIM |  | PROFIBUS PNU | 1671 (dec) IND = 0001xxxx (bin)
Range | 0,1 | DPR | 471 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description |

Description

The Command AUTOHOME selects, if the homing procedure will be started automatic.

AUTOHOME=1 After the drive is enabled the homing procedure MH is started automatic

AUTOHOME=0 no automatic homing prcedure started


ASCII English AVZ1

ASCII - Command | AVZ1 |
Syntax Transmit | AVZ1 [Data] |
Syntax Receive | AVZ1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3511 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1617 (dec) IND = 0000xxxx (bin)
Range | 0.2 .. 100.0 | DPR | 17 (dec)
Default | 1 |
Opmode | 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Filter Time Constant Input SW1

Description

Filter time constant for analog input SW1. (62.5µs Update Rate)


ASCII English \

ASCII - Command | \ |
Syntax Transmit | \ [Data] |
Syntax Receive | \ <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Unsigned8 | CANBus Object Number | 362B (hex)
DIM | - | PROFIBUS PNU | 1899 (dec) IND = 0000xxxx (bin)
Range | 0(=Master) .. 63 | DPR | 299 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Unsigned8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | Selection of Remote Address

Description

For a CAN network with several amplifiers, there is an option for using a serial connection to one of the devices (master) to communicate with all the other amplifiers. To do this, the SCAN command is initiated on the master device, which performs an automatic detection of all the drivess that are connected. The response to the SCAN command contains a list of the addresses of all the drives devices that have been detected.

Typing the backslash character followed by a drive address (\ addr) in the range of 0 to 63 selects the addressed drive for communications. Further commands sent via the serial interface are ignored by the master device, and passed on directly across the CAN bus to the activated device. The response that this device outputs to the CAN bus is diverted to the serial interface. The command, \ 0, deselects the slave device and re-activate the master.

The setting MDRV = 0 disables the multi link functionality.


ASCII English BCC

ASCII - Command | BCC |
Syntax Transmit | BCC |
Syntax Receive | BCC <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 363A (hex)
DIM | - | PROFIBUS PNU | 1914 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 314 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | EEPROM check sum

Description

The BCC variable returns a checksum for the parameter area of the serial EEPROM.
When a SAVE command is carried out, all the internal parameters of the amplifier are saved in this area, in ASCII format. The checksum is obtained by summing all the stored bytes, and is recalculated with every LOAD or SAVE command. It is only intended for the detection of EEPROM errors.
But it can also be used to detect whether the data set that is present in the controls matches the data set that is stored in the servo amplifier.


ASCII English CALCCOG

ASCII - Command | CALCCOG |
Syntax Transmit | CALCCOG [Data] |
Syntax Receive | CALCCOG | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | rpm | PROFIBUS PNU | No
Range | 0 .. 5 | DPR | No
Default | 2 |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Determing the Cogging Table

Description

IN PREPARATION !

CALCCOG starts the automatic determination of the cogging table (see also COGGING). To do this, the output stage must be enabled and the motor must be able to move freely, ideally without any mechanical coupling. The gain of the velocity controller GV should be tuned as high as possible.

While this command is being executed, the motor makes two full turns at the predefined speed. During the first turn, the cogging table values is coarsely identified. The second turn makes a fine identification for the cogging table values.

After this function has been completed, the 24 V power supply must be switched off and on to copy the determined table to the FLASH.
Until now, The CALCCOG function is reasonable when a Resolver, Hiperface- or an EnDAT-feedback device has been selected as the feedback device (FBTYPE=0, 2 or 4).

Before starting this processing, the parameter COGGING must be firstly set to one. Please reference to the ASCII command COGGING.


ASCII English CALCHP

ASCII - Command | CALCHP | For Manufacturer Use only
Syntax Transmit | CALCHP [Data] , [Data] |
Syntax Receive | CALCHP | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 3512 (hex)
DIM | rpm | PROFIBUS PNU | 1618 (dec) IND = 0000xxxx (bin)
Range | 0 .. 200 | DPR | 18 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Determining the Hiperface Parameters

Description

This command can be used to start the automatic determination of the Hiperface parameters. To do this, the output stage must be enabled and the drive must be able to move freely. While this command is being carried out, the motor makes a full turn at the predefined velocity. During this phase, the offset parameters (HISOFFS/HICOFFS) and the sine/cosine gain factor (HIFACT1) are calculated. After this function has been completed, the newly determined parameters can be stored in the encoder, using the HSAVE command for FBTYPE = 2 or 4 or using the command SAVE forFBTYPE = 7.
The CALCHP function is only available when a Hiperface- or an EnDAT-Encoder or sine encoder has been selected as the feedback device (FBTYPE=2 or 4 or 7).

The first is to select a certain speed in rpm and the second the angle of the motor that should be moved.

E.g.: CALCHP 5 10, start CALCHP with 5 rpm and move the motor 10 degrees.


ASCII English CALCRK

ASCII - Command | CALCRK | For Manufacturer Use only
Syntax Transmit | CALCRK [Data] |
Syntax Receive | CALCRK | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 3513 (hex)
DIM | rpm | PROFIBUS PNU | 1619 (dec) IND = 0000xxxx (bin)
Range | 0 .. 200 | DPR | 19 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Calculate resolver parameters

Description

This command can be used to start the automatic determination of the resolver parameter RK (sine/cosine gain factor). To do this, the output stage must be enabled and the drive must be able to move freely. While this command is being carried out, the motor makes a full turn at the given velocity. If CALCRK is started without parameter, the default value is used. After this function has been completed, the newly determined RK parameter can be stored in the EEPROM, using the SAVE command.
This command can be used to reduce the current ripple of the motor at high velocity. It can only be used with resolver feedback.


ASCII English CALCRP

ASCII - Command | CALCRP | For Manufacturer Use only
Syntax Transmit | CALCRP |
Syntax Receive | CALCRP | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 3514 (hex)
DIM | - | PROFIBUS PNU | 1620 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 20 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Calculate resolver phase

Description

This command can be used to start the automatic determination of the resolver parameter RESPHASE ( resolver phase shift ).

Before starting this command in the hyper Terminal, switch off the power and disable the drive. At the same time, set MSG = 2. After starting this command, the value of RESPHASE will be then automatically identified. If the process finishes, in the Hyper Terminal shows the value of RESPHASE and the information “ERR 4 feedback !”. This is normal and you can ignore it. Now, type SAVE to store the value of RESPHASE permanently and execute the COLDSTART.


ASCII English CBAUD

ASCII - Command | CBAUD |
Syntax Transmit | CBAUD [Data] |
Syntax Receive | CBAUD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3515 (hex)
DIM | kBaud | PROFIBUS PNU | 1621 (dec) IND = 0000xxxx (bin)
Range | 10,20,50,100,125,250,333,500,666,800,1000 | DPR | 21 (dec)
Default | 500 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Baud Rate CAN Bus

Description

The transmission rate is required by the fieldbus (CANopen) and for the parameter setting of the servo amplifier in multi-axis systems (see the Installation Manual). You can also use the keys on the front panel of the servo amplifier to set the baud rate (see the Installation Manual).


ASCII English CLRFAULT

ASCII - Command | CLRFAULT |
Syntax Transmit | CLRFAULT |
Syntax Receive | CLRFAULT | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3518 (hex)
DIM | - | PROFIBUS PNU | 1624 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 24 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Clear Drive Fault

Description

The CLRFAULT command cancels the fault status of an amplifier. A hardware or software reset of the amplifier is carried out, depending on the type of fault that is present.
After a software reset the amplifier is immediately ready for operation, after a hardware reset the complete initialization phase must be gone through first (as for power-on).
As well as amplifier faults (display Fxx), the following warnings are also deleted.
- contouring/following error
- threshold monitoring

With the selection CLRWARN=1 (separate cancellation of warnings) this command will delete all warnings that are present.
A listing of all possible fault/error messages, with information on the hardware/software reset required, can be found in the description of the ERRCODE command.

The CLRFAULT command can either be implemented through the ASCII channel (CLRFAULT command ) or via the CAN/PROFIBUS (with the “cancel fault” bit in the control word), or through a digital input (“Controller reset” function).


ASCII English CLRHR

ASCII - Command | CLRHR |
Syntax Transmit | CLRHR |
Syntax Receive | CLRHR | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3519 (hex)
DIM | - | PROFIBUS PNU | 1625 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 25 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Bit 5 of status register STAT is cleared

Description

After every start-up or hardware reset of the drive, BIT 5 (0x20) of the STAT register is set to high. This bit is cleared by CLRHR.
Possible usage:
The Software User Interface uploads all the data stored in the drive, if the hardware reset Bit5 in the STAT register is set too high. When the parameter are completely uploaded, the Bit5 is set to low using the command CLRHR. The STAT register is monitored form the Software User Interface all the time and is checked, if it is low. When it becomes high again (drive had a reset) the Software User Interface uploads the data again.


ASCII English CLRORDER

ASCII - Command | CLRORDER |
Syntax Transmit | CLRORDER [Data] |
Syntax Receive | - | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 351A (hex)
DIM | - | PROFIBUS PNU | 1626 (dec) IND = 0000xxxx (bin)
Range | 0;1 ..180; 192 .. 255 | DPR | 26 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Enabled (only RAM) / Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Deleting a Motion Task

Description

The command CLRORDER is used to delete a motion task given by the variable (e.g. CLRORDER 10, means: motion task 10 is deleted).


ASCII English COGGING

ASCII - Command | COGGING |
Syntax Transmit | COGGING [Data] |
Syntax Receive | COGGING <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36CF (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 463 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable + Restet (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Enable of Cogging Compensation

Description

IN PREPARATION !

COGGING enables a cogging compensation function, which adds a cogging current to the current controller in function of the angle of the motor.
Before identifying the cogging parameter of the motor by CALCCOG, the parameter COGGING must be firstly set to "1".

When COGGING = 1, the cogging effect of the PM motor will be online compensated, if the corresponding table was created by CALCCOG. If COGGING = 0, the cogging compensation will be switched off and the table is erased.

The cogging-compensation works only in FBTYPE = 0, 2 and 4.


ASCII English COLDSTART

ASCII - Command | COLDSTART |
Syntax Transmit | COLDSTART |
Syntax Receive | COLDSTART | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3632 (hex)
DIM | - | PROFIBUS PNU | 1906 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 306 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Drive Reset

Description

Software reset (warm boot) of the servo amplifier. The servo amplifier must be disabled. The current faults are cancelled, the servo amplifier software is initialized and communications are re-established. This command has the same effect as turning the drive power off and then back on.


ASCII English CONTINUE

ASCII - Command | CONTINUE |
Syntax Transmit | CONTINUE |
Syntax Receive | CONTINUE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 351D (hex)
DIM | - | PROFIBUS PNU | 1629 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 29 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Continue last position order

Description

The CONTINUE command can be used to continue (and complete) a motion block that was previously interrupted by the STOP command. This is especially important for a motion block with relative paths.


ASCII English CPHASE

ASCII - Command | CPHASE |
Syntax Transmit | CPHASE [Data] |
Syntax Receive | CPHASE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0, 1 | DPR | No
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Deactivate Motor Connection Detection

Description

The motor connection detection trips, if a cable is broken or not connected. CPHASE = 0 disables this function


ASCII English CTUNE

ASCII - Command | CTUNE |
Syntax Transmit | CTUNE [Data] |
Syntax Receive | CTUNE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 351E (hex)
DIM | Hz | PROFIBUS PNU | 1630 (dec) IND = 0000xxxx (bin)
Range | 400 .. 3000 | DPR | 30 (dec)
Default | 1200 |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | -
Short Description | Calculate current parameters

Description

This command calculates current parameters. Set the OPMODE = 2 before starting.


ASCII English CUPDATE

ASCII - Command | CUPDATE |
Syntax Transmit | CUPDATE |
Syntax Receive | CUPDATE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 351F (hex)
DIM | - | PROFIBUS PNU | 1631 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 31 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Program Update (CAN Bus)

Description

The CUPDATE command activates a function that can receive data through a CAN bus interface and save them in the program memory of the amplifier. After this function has been activated, no more commands will be accepted through the serial interface.
The program PRGDOWN.EXE should be used for downloading data on the PC side. This program operates with the hardware in a handshaking procedure, and prepares the data for CAN transmission.


ASCII English DEC

ASCII - Command | DEC |
Syntax Transmit | DEC [Data] |
Syntax Receive | DEC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3522 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1634 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 34 (dec)
Default | 10 |
Opmode | 0, 1, 8 (bei EXTPOS=1,4) | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Deceleration Rate

Description

The DEC command defines the deceleration ramp for the velocity control loop. The DEC deceleration/braking ramp is only used for setpoint step changes that result in a velocity decrease (braking). The ACC parameter is used for acceleration.

The DEC braking ramp applies to all setpoint changes, whether they are provided in analog or digital form. Separate braking ramps (DECSTOP/DECDIS) are used for setpoint changes that are generated internally in emergency stop situations (e.g. amplifier fault, or removal of the amplifier enable).


ASCII English DECDIS

ASCII - Command | DECDIS |
Syntax Transmit | DECDIS [Data] |
Syntax Receive | DECDIS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3523 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1635 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 35 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Deceleration used on Disable Output Stage

Description

When the output stage is disabled (removal of the hardware or software enable), the internal velocity setpoint is set to 0, using the preset DECDIS ramp. The output stage is only disabled when the actual velocity has fallen below the standstill threshold (VEL0).
The DECDIS ramp only has an effect for motors with a configured brake (MBRAKE=1) or with the selection STOPMODE=1.
With STOPMODE=0 the output stage is immediately disabled, and the drive coasts down.


ASCII English DECR

ASCII - Command | DECR |
Syntax Transmit | DECR [Data] |
Syntax Receive | DECR <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3524 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1636 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767 | DPR | 36 (dec)
Default | 10 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Deceleration Ramp for homing/jog modes

Description

The DECR command defines the braking ramp for jog mode or homing with the internal position control loop. The entry is made in msec and is referred to the final limit velocity for the corresponding operating mode: VJOG for jog operation, or VREF for homing.
When starting the homing/jog mode, the DECR deceleration ramp can, in some circumstances, be limited by the minimum acceleration time PTMIN (see description of the PTMIN parameter).

Details are shown at parameter ACCUNIT .


ASCII English DECSTOP

ASCII - Command | DECSTOP |
Syntax Transmit | DECSTOP [Data] |
Syntax Receive | DECSTOP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3525 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1637 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767, VLIM * 4480 (5.41) | DPR | 37 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Quick Stop – braking ramp for emergency situations

Description

In emergency stop situations, the internal setpoint goes to 0 using the preset DECSTOP ramp. The output stage is only disabled when the actual velocity has fallen below the standstill threshold (VEL0).
An emergency stop situation exists in the following cases:
- amplifier fault (with ACTFAULT=1)
- contouring/following error
- threshold monitoring (fieldbus devices)
- hardware/software limit switch activated
- emergency stop function through the digital input (INxMODE=27)
- emergency stop function through the fieldbus (control word)


ASCII English DENA

ASCII - Command | DENA |
Syntax Transmit | DENA [Data] |
Syntax Receive | DENA <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362D (hex)
DIM | - | PROFIBUS PNU | 1901 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 301 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | DPR software disable reset mode

Description

With external DPR-SLOT cards, it is possible to cancel existing instrument faults by removing the DPR software enable. This function can be activated or inhibited by using the DENA variable.

DENA=0 Removing the software enable causes a hardware/software reset of the amplifier.
The reset only takes place when a fault occurs, or the warning “contouring error” or “threshold monitoring activated” is present. (customer-specific protocol: Beckhoff).

DENA=1 Removing the software enable causes a hardware/software reset of the amplifier.
The reset only takes place when a fault occurs, or the warning “contouring error” or “threshold monitoring activated” is present.

DENA=2 No reset if the software enable is removed.


ASCII English DI2T

ASCII - Command | DI2T |
Syntax Transmit | DI2T [Data] |
Syntax Receive | DI2T <Data> | Available in |
Type | ro | MMI | No
ASCII Format | Integer 8 | CANBus Object Number | No
DIM | % | PROFIBUS PNU | No
Range | 0 ... 100 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Integer 8
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group |  | EEPROM |
Short Description | Drive I2T load

Description

This variable returns the average current as a percentage of the continuous current (see DICONT). The average current is filtered with a time constant of 16 seconds.


ASCII English DICONT

ASCII - Command | DICONT |
Syntax Transmit | DICONT |
Syntax Receive | DICONT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3527 (hex)
DIM | Amperes | PROFIBUS PNU | 1639 (dec) IND = 0000xxxx (bin)
Range | 1.5 .. 20.0 | DPR | 39 (dec)
Default | Hardware Defined |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Drive Continuous Current

Description

The continuous current rating of the drive. DICONT is depending on VBUSBAL for drive 403, 406, 614 and 670.


ASCII English DIFVAR

ASCII - Command | DIFVAR |
Syntax Transmit | DIFVAR |
Syntax Receive | DIFVAR <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | - | CANBus Object Number | 3528 (hex)
DIM | - | PROFIBUS PNU | 1640 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 40 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | List Variables with Values

Description

This command produces a list of parameters with settings that differ from the default values. The list contains entries in the following form:

PARAMETER Value (Default) PARAMETER = Parameter name
Value = the actual parameter setting
Default = the default value for the parameter


ASCII English DILIM

ASCII - Command | DILIM |
Syntax Transmit | DILIM [Data] |
Syntax Receive | DILIM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362C (hex)
DIM | - | PROFIBUS PNU | 1900 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 300 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | DPR current limit

Description

With external DPR-SLOT cards it is possible to limit the drive current through the DPR (RAM interface to the SLOT card). This function must be enabled through the DILIM configuration variable.


ASCII English DIPEAK

ASCII - Command | DIPEAK |
Syntax Transmit | DIPEAK |
Syntax Receive | DIPEAK <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3529 (hex)
DIM | Amperes | PROFIBUS PNU | 1641 (dec) IND = 0000xxxx (bin)
Range | 3.0 .. 70.0 | DPR | 41 (dec)
Default | Hardware Defined |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Drive Peak Rated Current

Description

The peak rated current of the drive. DIPEAK is depending on VBUSBAL for drive 403, 406, 614 and 670.


ASCII English DIS

ASCII - Command | DIS |
Syntax Transmit | DIS |
Syntax Receive | DIS | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 352B (hex)
DIM | - | PROFIBUS PNU | 1643 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 43 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Software-Disable

Description

The DIS command sets the software enable for the output stage to 0. Depending on the configuration (see MBRAKE, STOPMODE), the drive will coast down, or be run down under control.


ASCII English DISDPR

ASCII - Command | DISDPR |
Syntax Transmit | DISDPR [Data] |
Syntax Receive | DISDPR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3673 (hex)
DIM | - | PROFIBUS PNU | 1971 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 371 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | Disable DPR access

Description

DISDPR=1 disables the write access of e.g. Lightbus option boards to the drive. Read access is still possible. This enables the service functionality via PC even if the Bus is running.

DISDPR=0 Full access from the controller side.
DISDPR=1 Only read access.

This parameter is not stored in the EEPROM.


ASCII English DNBAUD

ASCII - Command | DNBAUD |
Syntax Transmit | DNBAUD [Data] |
Syntax Receive | DNBAUD <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | No
DIM | kbaud | PROFIBUS PNU | No
Range | 125,250,500 | DPR | No
Default | 125 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | DeviceNet baud rate

Description

The baud rate switch on the DeviceNet option card may be set to 0 (125 KBaud), 1 (250 KBaud) or
2 (500 KBaud). If the switch is set to a value greater than 2, the baud rate is configurable through
the terminal parameter DNBAUD and through DeviceNet. If the switch is set from 0 to 2, the baud
rate cannot be controlled with DNBAUD or DeviceNet.


ASCII English DNDUMP

ASCII - Command | DNDUMP |
Syntax Transmit | DNDUMP [Data] |
Syntax Receive | DNDUMP <Data> | Available in |
Type |  | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range |  | DPR | No
Default |  |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM |
Short Description | Debugging Information DeviceNet

Description

DNDUMP prints out debugging information with the status of the DeviceNet connection.


ASCII English DNMACID

ASCII - Command | DNMACID |
Syntax Transmit | DNMACID [Data] |
Syntax Receive | DNMACID <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0...63 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description |

Description

The MACID (address) switches on the DeviceNet option card may be set to a valid address from 0 to 63. If the switches are set to a value greater than 63, the MACID is configurable through the terminal parameter DNMACID and through DeviceNet. If the switches are set from 0 to 63, the MACID cannot be controlled with DNMACID or DeviceNet.


ASCII English DOVRIDE

ASCII - Command | DOVRIDE |
Syntax Transmit | DOVRIDE [Data] |
Syntax Receive | DOVRIDE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Int16 | CANBus Object Number | 36B6 (hex)
DIM | - | PROFIBUS PNU | 2038 (dec) IND = 0000xxxx (bin)
Range | 0 .. 8192 | DPR | 438 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Int16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Digital Override Factor

Description

If the digital Override function is selected (see OVRIDE=3), DOVRIDE gives the possibility to change the digital scaling.

The scaling is:

DOVRIDE=0 Motion task speed is 0 %
DOVRIDE=8192 Motion task speed is 100 %


ASCII English DPRILIMIT

ASCII - Command | DPRILIMIT |
Syntax Transmit | DPRILIMIT [Data] |
Syntax Receive | DPRILIMIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Int16 | CANBus Object Number | 3658 (hex)
DIM | - | PROFIBUS PNU | 1944 (dec) IND = 0000xxxx (bin)
Range | 0 .. 3280 | DPR | 344 (dec)
Default | 3280 |
Opmode | All | Data Type Bus/DPR | Int16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | No
Short Description | Digital Limiting of the peak Current via DPR

Description

Digiatl Limiting of the peak current via DPR.

The scaling is:
DPRILIMIT=3280 Current limited to DIPEAK
DPRILIMIT=0 Current limited to 0 A

If the drive is switched on, DPRILIMIT is set to 3280 (no current limit). DPRILIMIT is not stored in EEPROM. So to enable the limit, write the data to the variable via fieldbus, RS232 or I/O command buffer.

To enable this function, DILIM has to be set to "1".


ASCII English DR_TYPE

ASCII - Command | DR_TYPE |
Syntax Transmit | DR_TYPE |
Syntax Receive | DR_TYPE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 352E (hex)
DIM | - | PROFIBUS PNU | 1646 (dec) IND = 0000xxxx (bin)
Range | 1 .. 8 | DPR | 46 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Gives the Output Stage Indentification

Description

This command can be used to read the drive type.

DR_TYPE Drive
1 SR601
2 SR603
3 SR606
4 SR610
5 SR614
6 SR620
7 SR640
8 SR670
9 SR610/30
18 SR403
19 SR406


ASCII English DREF

ASCII - Command | DREF |
Syntax Transmit | DREF [Data] |
Syntax Receive | DREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 352C (hex)
DIM | - | PROFIBUS PNU | 1644 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 44 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Direction for Homing

Description

The DREF parameter can be used to define the preferred direction of motion for a homing operation and for positioning with a modulo-axes (POSCNFG=2).
Status | Shortdescription | Description
DREF = 0 | Negative movement | A homing move is always started in the negative direction (-VREF). Using a modulo axes type a position is always searched in negative direction (is DIR=1, the target position is searched in the positive direction).
DREF = 1 | Positive movement | A homing move is always started in the positive direction (+VREF). Using a modulo axes type a position is always searched in positive direction (is DIR=1, the target position is searched in the negative direction).
DREF = 2 | Optimized movement | The shortest distance between the starting position and the zero pulse of the resolver is executed in Homing Mode No. 5 (NREF=5). When a modulo axes type is used, the drive always searches for the shortest distance to reach the position.


ASCII English DRVCNFG

ASCII - Command | DRVCNFG |
Syntax Transmit | DRVCNFG [Data] |
Syntax Receive | DRVCNFG <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3672 (hex)
DIM | - | PROFIBUS PNU | 1970 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 370 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | Yes
Short Description | Configuration Variable for CAN-Bus

Description

The configuration variable makes sure, that new or enhanced features do not create problems with excisting machines. If a function has changed, this can be changed back by setting the corresponding bit.
Bit | Description
Bit 0 (0x1) | =1 The CAN-open switch-on telegram is 0 byte. =0 The CAN-open switch-on telegram is 8 byte.
Bit 1 (0x2) | =1 The state machine is effected by enable/disable. The CAN-open state machine is alligned to the real status of the drive. =0 The state machine is not updated by enable/disable of the drive.
Bit 2 (0x4) | =1 The size of the SDO-object is checked. If a wrong size is detected, an Emergency object is generated. =0 No check of the size of an SDO object
Bit 3 (0x8) | =1 Fieldbus mapping data is stored in the EEPROM =0 Data is not stored
Bit 4 (0x10) | Reserved
Bit 5 (0x20) | If the bit is set, the signal "Homing set" (see TRJSTAT) is delayed by INPT. This gives the possibility, equivalent to the signal "In Position", to get a low/high transition. This is important for homing mode "set homing position" and "homing in one revolution". If the homing move is startet again, the transition can be lost without this function. (4.96)
Bit 6 (0x40) | =1 the max input voltage at the sine/cosine input at X1 (Drive 400 X2) is supervised =0 the the max. input voltage at the sine/cosine input at X1 (Drive 400 X2) is not supervised
Bit 7 (0x80) | The overflow detection of a multi turn encoder is switches off. (4.94)
Bit 8 (0x100) | A single turn encoder is executed as a multi turn encoder. The actual position is set to the single turn absolute position at start-up. Homing is not required. (4.94)


ASCII English DUMP

ASCII - Command | DUMP |
Syntax Transmit | DUMP |
Syntax Receive | DUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 352F (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 47 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | List All EEPROM Variables with Values

Description

This command produces a list of all the parameters that can be stored in the EEPROM, together with their present values. All the amplifier-specific parameters (e.g. A/D-offset values) start with a “;”(semicolon).


ASCII English EGEARI

ASCII - Command | EGEARI |
Syntax Transmit | EGEARI [Data] |
Syntax Receive | EGEARI <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 1 ... long Integer | DPR | No
Default | 1024 |
Opmode | 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Loop | EEPROM | Yes
Short Description |

Description

With the parameter EGEARO and EGEARI the scaling factor from and external position feedback to 32 bit per revolution will set. With the parameter EGEARO as a multiplier and EGEARI as a divisor.
Example 1
An external 5V ROD encoder with 500 lines will used for position loop (EXTPOS = 3). To bring the feedback signal to 32 bit per revolution the parameter EGEARO and EGEARI has to set in the following order.
EGEARO/ EGEARI = 2^32 / (500 * 4)
EGEARO = 268435456
EGEARI = 125

Example 2
Additional to example 1 there will be a gearbox between the motor and the external feedback. The Gearbox has 10 motor revolutions for 3 turns of the load.
EGEARO/ EGEARI = (2^32 / (500 * 4)) * (3 / 10)
EGEARO = 402653184
EGEARI = 625


ASCII English EGEARO

ASCII - Command | EGEARO |
Syntax Transmit | EGEARO [Data] |
Syntax Receive | EGEARO <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 ... Long Integer | DPR | No
Default | 1 |
Opmode | 4 ... 8 | Data Type Bus/DPR | Integer32
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Loop | EEPROM | Yes
Short Description |

Description

With the parameter EGEARO and EGEARI the scaling factor from and external position feedback to 32 bit per revolution will set. With the parameter EGEARO as a multiplier and EGEARI as a divisor.
Example 1
An external 5V ROD encoder with 500 lines will used for position loop (EXTPOS = 3). To bring the feedback signal to 32 bit per revolution the parameter EGEARO and EGEARI has to set in the following order.
EGEARO/ EGEARI = 2^32 / (500 * 4)
EGEARO = 268435456
EGEARI = 125

Example 2
Additional to example 1 there will be a gearbox between the motor and the external feedback. The Gearbox has 10 motor revolutions for 3 turns of the load.
EGEARO/ EGEARI = (2^32 / (500 * 4)) * (3 / 10)
EGEARO = 402653184
EGEARI = 625


ASCII English EMRGTO

ASCII - Command | EMRGTO |
Syntax Transmit | EMRGTO [Data] |
Syntax Receive | EMRGTO <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 10 ... 32767 | DPR | No
Default | 5000 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description |

Description

EMRGTO defines the emergency time out for the ACTFAULT=1 and STOPMODE=1 operations.

After the ACTFAULT (drive error) or STOPMODE (power stage enable) conditions the drive tries
To reduce the velocity to zero. If this fails, the power stage will be disable after the EMRGTO time at the latest.


ASCII English EN

ASCII - Command | EN |
Syntax Transmit | EN |
Syntax Receive | EN | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3530 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 48 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Software-Enable

Description

The EN command sets the software enable for the output stage.
If the software enable and the hardware enable are set and no fault is present (the BTB contact is closed), then the output stage is enabled.
If the MAINS BTB function is activated (OxMODE=3), then the output stage will only be enabled when the supply power has been switched on and the charging circuit has charged up the DC bus. If the supply power is removed from an enabled instrument, then it remains enabled until the DC bus voltage has fallen below the undervoltage limit (VBUSMIN).


ASCII English ENCLINES

ASCII - Command | ENCLINES |
Syntax Transmit | ENCLINES [Data] |
Syntax Receive | ENCLINES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer24 | CANBus Object Number | 3533 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0000xxxx (bin)
Range | 65535 | DPR | 51 (dec)
Default | 1000 |
Opmode | All | Data Type Bus/DPR | Integer24
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | SinCos Encoder Resolution

Description

ENCLINES sets the resolution (number of lines) of the encoder input channel using an ENCODER as feedback unit. In case of Rotary Motors it is the number of lines per revolution, in case of linear Motors it is the number of lines per pole pitch. With an ENDAT or Hiperface Encoder ENCLINES is read automatically during the initialization process.


ASCII English ENCMODE

ASCII - Command | ENCMODE |
Syntax Transmit | ENCMODE [Data] |
Syntax Receive | ENCMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3534 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3 | DPR | 52 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Output | EEPROM | Yes
Short Description | Selection of Encoder Emulation

Description

Selection of the encoder emulation

ENCMODE=0 Encoder emulation switched off
ENCMODE=1 EEO (ROD) output
ENCMODE=2 SSI output
ENCMODE=3 EEO (ROD) interpolation mode
This mode is available with high resolution feedback device (FBTYPE>0).
The encoder output brings ENCOUT * ENCLINES lines per motor rev. Following settings are possible: 4,8,16,32,64,128


ASCII English ENCOUT

ASCII - Command | ENCOUT |
Syntax Transmit | ENCOUT [Data] |
Syntax Receive | ENCOUT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3535 (hex)
DIM | CPR | PROFIBUS PNU | 1653 (dec) IND = 0000xxxx (bin)
Range | see Description | DPR | 53 (dec)
Default | 1024 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Output | EEPROM | Yes
Short Description | Resolution Encoder Emulation EEO (ROD)

Description

The resolution of the encoder emulation EEO (ROD)

ENCOUT defines the number of lines that are given out by the EEO (ROD) interface for one turn of the motor.
Resolver feedback (FBTYPE=0) allows lines per rev from 256 to 4096 with all integer numbers between. One zero pulse per rev.
Encoder feedback (FBTYPE=7) allows all numbers from 256 to 524288, but only degrees of 2 (256, 512, 1024, .. , 262144, 524288).

All integer numbers between 256 and 4096 are enabled also for FBTYPE= 2 and 4.


ASCII English ENCZERO

ASCII - Command | ENCZERO |
Syntax Transmit | ENCZERO [Data] |
Syntax Receive | ENCZERO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3537 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0000xxxx (bin)
Range | 0 .. ENCOUT-1 | DPR | 55 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Output | EEPROM | Yes
Short Description | Zero Pulse Offset EEO (ROD)

Description

The ENCZERO command can be used to shift the output of the EEO (ROD) zero pulse over the range of one turn. The shift is made in the clockwise direction, e.g.
ENCOUT 1024
ENCZERO 256
The zero pulse is given out at the 90° position.

This is also effective for SSI outputs.


ASCII English ERND

ASCII - Command | ERND |
Syntax Transmit | ERND [Data] |
Syntax Receive | ERND <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3638 (hex)
DIM | - | PROFIBUS PNU | 1912 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 312 (dec)
Default | 2^31-1 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | End position of modulo axes

Description

The ERND parameter is used to define the end of the range of movement for a modulo axes (POSCNFG=2). The start of the range can be set by the SRND command. All positioning operations are made in the positioning range <SRND...ERND-1>.
The entry for ERND is made in SI units (taking account of PGEARI, PGEARO).


ASCII English ERRCODE

ASCII - Command | ERRCODE |
Syntax Transmit | ERRCODE |
Syntax Receive | ERRCODE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | -
Short Description | Activated Fault Messages

Description

The ERRCODE command returns the clear text information about any existing faults.


ASCII English ERRCODE *

ASCII - Command | ERRCODE * |
Syntax Transmit | ERRCODE * |
Syntax Receive | ERRCODE * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 .. 0xFFFFFFFF | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Output Error Register

Description

The ERRCODE* command returns the internal status information in the form of a bit-variable. A bit is set for as long as the corresponding error/fault is detected. The bit is deleted by the hardware reset of the amplifier.
Faults that are designated by the SW label can also be deleted by a software reset (function CLRFAULT – clear fault).

Level gives an information about the error handling in the drive.

Level 2:
A fault causes an emergency stop. The stop of the motor is done in velocity control using the emergency stop ramp (DECSTOP). When the motor reaches the zero velocity level (VEL0) (limited by max. 5 sec), the power stage is disabled. The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

Level 3:
A fault causes an emergency stop. The stop of the motor is done without feedback device (sensorless). When the motor has stopped, the power stage is disabled. The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

Level 4:
A fault causes an directly disable of the power stage. The motor has no torque (coast). The Ready-to-Operate relay is switched off. The drive has to be reset before it can be enabled again. The fault is displayed.

Faults, that have different levels (2/3 and 4), the behaivior is controlled by ACTFAULT and MBRAKE or STOPMODE

ACTFAULT=1 or MBRAKE=1 LEVEL 2 or 3 (Default-Setting)
ACTFAULT=0 and MBRAKE=0 LEVEL 4
Bit/Displ./Reset/Level | Bit | Description
00/F01/SW/2,4 0x00000001 =1 Heatsink overtemperature
is set, if the heatsink temperature TEMPH exceeds the max allowed threshold MAXTEMPH.
01/F02/SW/2,4 0x00000002 =1 DC-link overvoltage
Is set, if the DC-link voltage exceeds the max threshold selected by VBUSBAL.
02/F03/SW/2 0x00000004 =1 Contouríng error of the external trajectory (OPMODE=6/SERCOS)
Is set, if the target speed which is given by the extrnal trajectory is higher than VLIM/VLIMN.
03/F04/HW/3,4 0x00000008 =1 Feedback error
Is set, if a feedback error was detected.
04/F05/SW/2,4 0x00000010 =1 Undervoltage protection
Is set, if the DC-link voltage is lower than VBUSMIN (only if the drive is enabled).
05/F06/HW/2,4 0x00000020 =1 Motor overtemperature
is set, if the heatsink temperature TEMPM exceeds the max allowed threshold MAXTEMPM.
06/F07/HW/2,4 | 0x00000040 | =1 if the internal electronic supply is faulty.
07/F08/SW/3,4 0x00000080 =1 Overspeed
Is set, if the velocity of the motor exceeds the overspeed threshold (VOSPD).
08/F09/HW/4 0x00000100 =1 EEPROM Checksum error
Is set, if the data read/written from the EEPROM is not valid.
There are two possibilities, that can cause this error. First is a defect EEPROM and the second is a wrong checksum in the EEPROM. In the second case, a SAVE can solve the problem.
09/F10/HW | 0x00000200 | Reserved
10/F11/HW/2,4 0x00000400 =1 Brake error
Is set, if the brake switch detects a fault (e.g. Brake is selected, but no brake is connected).
11/F12/HW | 0x00000800 | =1 Missing motor connection. This error occurs, if a motor connection (not feedback device) is missing. The error can be disabled by CPHASE = 0.
12/F13/SW/2,4 0x00001000 =1 Ambient overtemperature
is set, if the ambient temperature TEMPE exceeds the max allowed threshold MAXTEMPE.
13/F14/HW/2,4 0x00002000 =1 Output stage fault
This fault can be caused by:
Earth short circuit of the motor
Short circuit of the motor phases
Short circuit of the regen.
14/F15/SW/2,4 0x00004000 =1 I²tmax override
Is set, if I²t exceeds 115% of ICONT (FOLDMODE=0) or 105% of ICONT (FOLDMODE=1).
15/F16/SW/2,4 | 0x00008000 | =1 Mains BTB
16/F17/HW/2,4 | 0x00010000 | =1 A/D converter error
17/F18/HW/2,4 0x00020000 =1 Regen error
destroyed regen transistor
regen resistor extern selected, but the internal one is used.
18/F19/SW/2,4 | 0x00040000 | =1 line phase missing (PMODE=2)
19/F20/HW/2,4 0x00080000 =1 Slot error
Error depends on the type of Slot board:
1. I/O expansion board The error is caused by a missing 24V supply at the I/O board.
2. DPR Slot board
(Beckhoff, L&B, Sigmatek)
The error is generated, if the DPR interrupt fails to appear. The watch-dog time can be selected by EXTWD.
3. PROFIBUS
Error in the initialization time.
20/F21/HW/2,4 0x00100000 =1 PROFIBUS handling error
If the OPMODE is changed by another communication channel than PROFIBUS, when the drive is under control of the PROFIBUS, this error is generated.
Exception: Working mode -126 for PROFIBUS. This is the safe opmode when the drive is switched on.
21/F22/HW/2,4 0x00200000 =1 Earth short circuit
The earth short circuit supervisor of the 40/70 A units.
22/F23/HW/2,4 0x00400000 =1 CANopen Bus-Off
Fault in CAN communication.
The communication fault BUSOFF is generated by layer 2 (CAN controller). This fault can have several resons. Some examples are:
Drive tries to establish communication, but there is no other node.
CAN nodes have different baud rates, Bus cable defekt, reflections because of missing or wrong bus terminations, etc.

A BUSOFF is displayed by the drive, if another CAN node is connected and minimum one errorfree object is generated. If the BUSOFF is generated and the drive is moving the motor, the motor is stopped using the emergency ramp and then the drive is disabled.
23/F24/SW/2,4 | 0x00800000 | Warning generates a error message (defined by WMASK)
24/F25/HW/3,4 | 0x01000000 | Commutation Error (Run-away of the motor)
25/F26/SW/2,4 | 0x02000000 | Hardware limit switch error at homing move (defined by REFLS)
26/F27/HW/4 0x04000000 =1 "-AS-Option" error
If the ENABLE signal of the drive is high and the -AS-option is activated, this error is generated (starting Version 3.44).
27/F28/SW/2 | 0x08000000 | =1 error "external tarjectory" is generated, if an external position profile generator creates a step, that exceeds the maximum value.
28/F29/SW/2 | 0x10000000 | =1 Sercos error
29/F30/SW | 0x20000000 | Sercos Emergency time out
30/F31/SW | 0x40000000 | Reserved
31/F32/HW/4 0x80000000 =1 System error
Is set, if an error occurred in the system check of the initialization phase or a watch-dog error in the working phase.
Following reasons are possible:
1. Wrong program data in the FLASH (e.g. interrupted program download)
2. Macro error (the macros could not be compiled)
3. Software watch-dog activated
4. Error with the EEPROM (read or write).
5. FPGA error (FPGA could not be loaded correctly)
6. Macro RAM (the compilation of the MACROs detect too less RAM)

When the drive is switched on, a detailed message is send vis RS232.


ASCII English ESPEED

ASCII - Command | ESPEED |
Syntax Transmit | - |
Syntax Receive | ESPEED <Data> | Available in |
Type | Variable r | MMI | No
ASCII Format | Float | CANBus Object Number | 3675 (hex)
DIM | rpm | PROFIBUS PNU | 1973 (dec) IND = 0000xxxx (bin)
Range | 0 .. 16000 | DPR | 373 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | -
Short Description | Maximum velocity corresponding to the Feedback Type

Description

The command ESPEED gives the maximum velocity of the motor corresponding to the selected feedback type (FBTYPE).


ASCII English EXTWD

ASCII - Command | EXTWD |
Syntax Transmit | EXTWD [Data] |
Syntax Receive | EXTWD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 353A (hex)
DIM | Milliseconds | PROFIBUS PNU | 1658 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32000 | DPR | 58 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | Yes
Short Description | external watch dog (Fieldbus)

Description

The EXTWD parameter can be used to define the monitoring time (watchdog timer) for the fieldbus/slot communication. The monitoring is only active if the EXTWD parameter has a value greater than zero (EXTWD=0 means monitoring is switched off) and the output stage is enabled. If the preset time runs out, without the timer being retriggered, then the warning n04 (threshold monitoring) is generated and the drive is stopped. The amplifier remains ready for operation, and the output stage is still enabled. This warning must be cancelled (function CLRFAULT or INxMODE=14) before a new motion command (setpoint) can be accepted.
For DeviceNet, set to 1 to enable F04 and 0 to disable. (Watchdog time is set by DeviceNet controller.)


ASCII English FBTYPE

ASCII - Command | FBTYPE |
Syntax Transmit | FBTYPE [Data] |
Syntax Receive | FBTYPE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 353B (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0000xxxx (bin)
Range | 0 .. 20 | DPR | 59 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Selection of Encoder or Resolver

Description

The FBTYPE command is used to select the type of feedback device.
The type of encoder that is set is only initialized when the amplifier is switched on, which means that the amplifier must be switched off and then on again after every change of this variable.
The encoder parameters can be altered by using the appropriate ASCII command (in brackets) and then saved in the encoder EEPROM, using the HSAVE command. The encoder commands (HISOFFS, HICOFFS, HIFACT1, HSAVE) are only available when communication with the connected encoder has been established.
If communication with the encoder is not possible, then the error message ENCODER FAULT F04 is displayed.
When the data are loaded from the encoder, the setting for the motor number in the encoder is compared with the internal setting (MNUMBER). If the numbers are different, then an attempt is made to load a motor data set from the internal motor database that has the same motor number as that stored in the encoder. At the same time, the warning “NEW MOTOR DATA SET” n12 is displayed.
In order to prevent a warning being generated at the next power-on, the latest MNUMBER setting should be saved in the EEPROM, using the SAVE command. If it was not possible to load a valid motor number from the encoder (for instance, when an encoder is used for the first time), then no motor data will be loaded. However, the n12 warning will still be generated. The HSAVE command can be used to save the preset setting for the motor number (MNUMBER) in the encoder, so that no warning will be produced at the next power-on.
When using an encoder without a parameter channel (FBTYPE=7/16), and thus without the facility for storing parameters, the offset values HISOFFS / HICOFFS / HIFACT1 will be saved in the serial EEPROM of the amplifier. After an alteration, these values can be permanently stored by using the SAVE command.
Status | Type of Feedback System | Description
FBTYPE = 0 | Resolver | Data is loaded from the drive EEPROM.
FBTYPE = 2 Hiperface (Stegmann) In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Offset compensation Sine (HISOFFS)
Offset compensation Cosine (HICOFFS)
Amplitude scaling (HIFACT1)
Motor number (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 3 Resolver, EnDAT oder Hiperface Automatic selection of the feedback device.
First the drive tries to communicate with an EnDAT device (FBTYPE=4). If there is no reply, the drive tries to communicate with an Hiperface device (FBTYPE=2). If there is also no communication, the drive selects resolver feedback (FBTYPE=0) and starts to work.
The setting of FBTYPE=3 is not effected by this search.
There is a possibility to read the selected type by the command "M FBTYPE".
FBTYPE = 4 EnDAT (Heidenhain) In the initialization phase, all the data is loaded that is stored in the encoder EEPROM. These are:
Offset compensation Sine (HISOFFS)
Offset compensation Cosine (HICOFFS)
Amplitude scaling (HIFACT1)
Motor number (MNUMBER)
Motorphase (MPHASE)
FBTYPE = 6 Sine/Cosine Encoder Sine/Cosine encoder without parameter channel. MPHASE is stored in the drive EEPROM.
HISOFFS, HICOFFS, HIFACT1 is also stored in the drive EEPROM.
FBTYPE = 7 Sine/Cosine Encoder Sine/Cosine encoder without parameter channel. Automatic detection of MPHASE by Wake&Shake mode.
HISOFFS, HICOFFS, HIFACT1 is also stored in the drive EEPROM.
If the 24V are switched on or the drive has got a COLDSTART, a warning n14 is present. After enabling the drive, a wake & shake mode is activated, to get the commutation angle.
The motor is doning a short move to do that. After that, the n14 is cleared.
FBTYPE=8 | RS422 & Wake&Shake | This setting can only be used, if GEARMODE=3 and ENCMODE=0 (see ENCLINES).
FBTYPE=9 RS422 Feedback Device
MPHASE is loaded out of the EEPROM 		This setting can only be used, if GEARMODE=3 and ENCMODE=0
FBTYPE=10 | Without Feedback Device (sensorless)
FBTYPE=11 | Sine encoder feedback with hall's
FBTYPE=12 RS422 feedback device (A quad B) with hall's

For linear motors, adjusting MPHASE 180 degrees compensates for inverted Hall effect sensors. Also, MPHASE can also compensate for misalignment of Hall sensors."
FBTYPE = 16 | Start-up with resolver (commutation), then switch over to Sine/Cosine encoder (FBTYPE=7) | Commutation information read by resolver feedback. The switch-over to sine/cosine is done after a switch-on delay time together with the encoder simulation.


ASCII English FLASH

ASCII - Command | FLASH |
Syntax Transmit | FLASH [Data] |
Syntax Receive | FLASH <Data> | Available in |
Type | wo | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D9 (hex)
DIM |  | PROFIBUS PNU | 1673 (dec) IND = 0001xxxx (bin)
Range | 0 ... 4 | DPR | 473 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer8
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM |
Short Description |

Description

IN PREPARATION !

The command FLASH is used to transfer firmware/parameter-data between drive and external flash-card.

The external flash-card is used as an external memory for firmware and also als for drive-parameter. This tool can be used to update the firmware without an additional hardware (computer, ...). THe upload/download-commandos can be set by the ASCII-command FLASH or by using the keys S1/S2 at the flash -card.

The FLASH-command options:

FLASH=0 Output of information text with version number of the save firware on the flash card. The second line includes the actual drive firmware version.

FLASH=1 Saves all drive-data into the flash-card (UPLOAD). The actual firmware-version, drive-parameter, data bank, PLC-programm, cam profiles and flash-motion tasks are saved into the flash-card. The command is activated also,if the key S1 is pressed. The drive display-segment shows an ‚u‘during the upload process. (UPLOAD). The procedure ends with an automatic reset of the drive.

FLASH=2 Saves all drive-data into the flash-card (DOWNLOAD).The actual firmware-version, drive-parameter, data bank, PLC-programm, cam profiles and flash-motion tasks are saved into the flash-card. The command is activated also,if the key S2 is pressed. The drive display-segment shows an ‚u‘during the upload process. (DOWNLOAD). The procedure ends with an automatic reset of the drive.

FLASH=3 Erase the exteral flash-card.

FLASH=4 Load parameter-data into the drive.Only data from the serial EEPROM (parameter-memory) are transmitted.

Attention !!
The FLASH-command has to be used only by disabled output stage and switched of main voltage. During this process the 24V DC Link has not to be switched off. If you ignore this you may erase data.

Drives without a firmware will start the monitor programm automatic. The flash-card can be used with monitor-pograms >= version 7.2 implementiert.


ASCII English FLTCNT

ASCII - Command | FLTCNT |
Syntax Transmit | FLTCNT |
Syntax Receive | FLTCNT <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0, 65535 per Fault Message | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Fault Frequency

Description

The FLTCNT command provides a listing of all possible error messages, with the number of occurrences of each type of fault in clear text. The total number of faults (sum of the individual faults) is given out before the fault list.


ASCII English FLTCNT *

ASCII - Command | FLTCNT * |
Syntax Transmit | FLTCNT * |
Syntax Receive | FLTCNT * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | 1 x Integer32 + 32 x Integer16 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | -
Short Description | Fault Frequency

Description

The command returns a list of 33 numbers:
1st number: total number of faults (Integer32)
2nd number number of occurrences of fault F01
3rd number number of occurrences of fault F02
..........
33rd number number of occurrences of fault F32


ASCII English FLTHIST

ASCII - Command | FLTHIST |
Syntax Transmit | FLTHIST |
Syntax Receive | FLTHIST <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | Number and TRUN | PROFIBUS PNU | No
Range | 10 No. of Last Messages+Times | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Fault History: Display last 10 faults

Description

The FLTHIST command produces a list of the last 10 faults that occurred, together with the corresponding number of operating hours at the time of occurrence, in clear text.


ASCII English FLTHIST *

ASCII - Command | FLTHIST * |
Syntax Transmit | FLTHIST * |
Syntax Receive | FLTHIST * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | 20 x Integer32 | CANBus Object Number | No
DIM | Number and TRUN | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | No
Short Description | Fault History: Display last 10 faults

Description

The FLTHIST command produces a list of the last 10 faults that occurred, together with the corresponding number of operating hours at the time of occurrence, in clear text.
The output looks like this:
n1 t1 n2 t2 n3 t3 ....n10 t10
n – fault number
t – time of the event (operating hours counter) [in 1024/60000 minutes]


ASCII English FLUXM

ASCII - Command | FLUXM |
Syntax Transmit | FLUXM [Data] |
Syntax Receive | FLUXM <Data> | Available in |
Type | Variable r | MMI | No
ASCII Format | Float | CANBus Object Number | 3689 (hex)
DIM | - | PROFIBUS PNU | 1993 (dec) IND = 0000xxxx (bin)
Range | 0 .. 10000 | DPR | 393 (dec)
Default | 4500 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Rated Flux Level of Permanent Magnet Motor

Description

IN PREPARATION !

FLUXM is read-only and corresponds to the rated flux level of permanent magnet motor. This variable is determined by the motor torque constant, Kt. The unit is counts and the scaling factor is 22000. This means that Fluxm(counts)/22000 = VoltSec.

This variable is applicable only for the sensorless drive of permanent magnet motor.


ASCII English FW

ASCII - Command | FW |
Syntax Transmit | FW |
Syntax Receive | FW <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Float | CANBus Object Number | 3657 (hex)
DIM | - | PROFIBUS PNU | 1943 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 343 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Displays the Version Number of the Firmware

Description

The command FW displays the versionnumber of the firmware. The command is also appears in the DUMP list and is part of the parameter settings of the drive.


ASCII English GEARFILT

ASCII - Command | GEARFILT |
Syntax Transmit | GEARFILT [Data] |
Syntax Receive | GEARFILT <Data> | Available in |
Type |  | MMI | No
ASCII Format | Command | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 1 ...8 | DPR | No
Default | 4 |
Opmode | 0 | Data Type Bus/DPR | Command
Drive State | Enable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position | EEPROM | -
Short Description |

Description

For the operation of electronic gearing ( OPMODE = 4 ), a second order low pass filter is introduced, to smooth the input position command signal. This command GEARFILT can be used to determine the corresponding frequency of the electronic gearing filter.

GEARFILT f (HZ)

1 318
2 159
3 80
4 40
5 20
6 10
7 5
8 2.5

The filter is only used, if it is necessary, because the filter also introduces a delay to prevent the slave from following the master exactly at time during acceleration and deceleration. Normally, GEARFILT = 4 with 40 Hz cut-frequency is chosen.


ASCII English GEARI

ASCII - Command | GEARI |
Syntax Transmit | GEARI [Data] |
Syntax Receive | GEARI <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 353E (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0000xxxx (bin)
Range | 1 .. 2147483647 | DPR | 62 (dec)
Default | 8192 |
Opmode | 4 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Gearing | EEPROM | Yes
Short Description | Input Factor for Electronic Gearing

Description

In master/slave applications (OPMODE=4) this parameter can be used to set the master/slave translation ratio.


ASCII English GEARMODE

ASCII - Command | GEARMODE |
Syntax Transmit | GEARMODE [Data] |
Syntax Receive | GEARMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 353F (hex)
DIM | - | PROFIBUS PNU | 1663 (dec) IND = 0000xxxx (bin)
Range | 0 .. 17 | DPR | 63 (dec)
Default | 6 |
Opmode | 4 | Data Type Bus/DPR | Integer8
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Gearing | EEPROM | Yes
Short Description | Electronic Gearing Mode

Description

The servo amplifier is controlled through different interfaces from various sources. The GEARMODE variable configures the source that provides the master setpoint (position). For the connector pin assignments, see the Installation Manual.

All devices resolver, SinCos and incremental signals can be used at the same time. Resolver for commutation and speed control, SinCos for position control and incremental encoder for electronic gearing.
Following settings have to be made:

EXTPOS=1 .. 3 (External actual position)
GEARMODE=10 ..17
In addition to GEARMODE 0 ..7, a sine encoder at connector X1 can be used for position control with EXTPOS = 1.
Status Description
GEARMODE=0 Encoder Follower Digital I/O 24V (X3)
With an incremental encoder (track A/B, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored.
GEARMODE=1 Pulse And Direction Digital I/O 24V (X3)
With a stepper motor control (pulse/direction, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored.
INPUT1=direction (Low = positive, High = negative)
INPUT2=pulse
GEARMODE=2 Encoder Follower Digital I/O 24V (X3)
With an incremental encoder (track A/B, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored.
GEARMODE=3 Encoder Follower Digital I/O 5V X5 (Drive 400 X4)
With an incremental encoder connected to connector X5 (Drive 400 X4), terminals 4, 5, 6, 7.
ENCMODE has to be set to "0".
GEARMODE=4 Pulse And Direction Digital I/O 5V X5 (Drive 400 X4)
With a stepper motor control connected to connector X5 (Drive 400 X4), terminals 4, 5, 6, 7.
INPUT1=direction (Low = positive, High = negative)
INPUT2=pulse
ENCMODE has to be set to "0"
GEARMODE=5 Encoder Follower Digital I/O 5V X5 (Drive 400 X4)
With an incremental encoder connected to connector X5 (Drive 400 X4), terminals 4, 5, 6, 7.
ENCMODE has to be set to "0".
GEARMODE=6 With a sine encoder connected to X1 (Drive 400 X2).
Only the zero crossing of the sine(cosine signals are used. No analog processing.
GEARMODE=7 SSI input X5 (Drive 400 X4).
For the Master/Slave mode with two drives you need settings as follow:

Master: (is sending the SSI position)
ENCMODE 2 setting for encoder emulation (1=ROD, 2=SSI)
SSIGRAY = 0 data format (0=binary/1=gray)
SSIINV = 1 SSI-Clock (0=standard, 1=inverted)
SSIMODE = 1 0=single turn / 1= multi turn
SSIOUT = 0 baudrate 0=200 Kbaud / 1=1MBaud

Slave: (is reading the SSI position)
GEARMODE = 7 Setting for the master interface
OPMODE = 4 Master/Slave mode
ENCMODE = 2 always 2 when GEARMODE = 7 (SSI)
SSIGRAY = 0 data format (0=binary/1=gray)
SSIINV = 0 start transmission with MSB (=0) or LSB (=1)
SSIMODE = 0 alarm bit at begin (=1) or at end (=2) or off (=0)
SSIOUT = 25 data bits–1 (26)
IN1MODE = 16 Start input for the motion task
IN1TRIG = 0 0 means: motion task is a homing move
NREF = 8 Number for homing move.

The settings, GEARMODE = 7 and OPMODE =4, activate the read of the SSI-position about the encoder-input. The drive reads the SSI-position every 250 µs and calculates the difference to the previous position. This difference is multiplied by a scaling-factor and added to the last position command value.
With PRBASE = 20: Scaling-factor = 2^(33-SSIOUT)* GEARO / GEARI
With SSIOUT = 25: Scaling-factor = 256*GEARO / GEARI
The absolute position from Master/Slave could move with ROFFS. To adjust the absolute position between Master and Slave, it is necessary to do a homing with the slave drive and NREF = 8 (start with digital input). At the beginning of the homing the Slave drive reads the absolute position from the Master, does the scaling and uses this position as the target position for the homing. The drive changes the operation mode to OPMODE = 8 and starts the homing move to the target position with VREF and ramps ACCR / DECR. When the drive reaches the target position, it sets the INPOSITION message. The PLC resets the start input to activate the Master/Slave-mode (OPMODE = 4).
For testing (with the setting MSG = 2), it is possible to display the Master SSI-position at the Slave drive with the command, "M NEWSSI," in the terminal program of the drive. It is possible to get the Slave position with the command, "M PFB."
GEARMODE=8 SINCOS-Encoder at input X1 (Drive 400 X2). The difference to GEARMODE=6 is, that the parameter channel of the encoder is read and the absolute position is transfered to the position register.
This setting can be used in position mode under EXTPOS=1.
The sine/cosine signals of the encoder are read analog. This increases the resolution significantly.
GEARMODE=9 EnDAT-Encoder at input X1 (Drive 400 X2). The difference to GEARMODE=6 is, that the parameter channel of the encoder is read and the absolute position is transfered to the position register. ENCLINES is calculated automatically to thie internal resolution of 20 Bit per rev of the encoder.
This setting can be used in position mode under EXTPOS=1.
The sine/cosine signals of the encoder are read analog. This increases the resolution significantly.
GEARMODE=10 Encoder follower X3, 24V
Sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)
GEARMODE=11 Pulse and direction X3, 24V
INPUT1=direction (Low=positive, High=negative)
INPUT2=Pulse
Sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)
GEARMODE=12 Encoder Follower Digital I/O 24V (X3)
With an incremental encoder (track A/B, 24V signal level) connected to the digital inputs DIGITAL-IN 1/2, terminals X3/11, 12, an additional function assignment for the inputs is not necessary and any assignments on the screen page, Digital I/O, are ignored. In addition to that, a
sine encoder at X1 (Drive 400 X2) can be used for position control (EXTPOS = 1)
GEARMODE=13 Encoder follower X5 (Drive 400 X4), 5V
Sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)
GEARMODE=14 Pulse and direction X5 (Drive 400 X4), 5V
Sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)
GEARMODE=15 Encoder Follower Digital I/O 5V (X5)
With an incremental encoder connected to connector X5, terminals 4, 5, 6, 7.
ENCMODE has to be set to "0".
In addition to that, a sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)
GEARMODE=16 With a sine encoder connected to X1 (Drive 400 X2).
Only the zero crossing of the sine(cosine signals are used. No analog processing.
GEARMODE=17 SSI input X5 (Drive 400 X4).
For the Master/Slave mode with two drives you need settings as follow:

Master: (is sending the SSI position)
ENCMODE = 2 setting for encoder emulation (1=ROD, 2=SSI)
SSIGRAY = 0 data format (0=binary/1=gray)
SSIINV = 1 SSI-Clock (0=standard, 1=inverted)
SSIMODE = 1 0=single turn / 1= multi turn
SSIOUT = 0 baudrate 0=200 Kbaud / 1=1MBaud

Slave: (is reading the SSI position)
GEARMODE = 7 Setting for the master interface
OPMODE = 4 Master/Slave mode
ENCMODE = 2 always 2 when GEARMODE = 7 (SSI)
SSIGRAY =0 data format (0=binary/1=gray)
SSIINV = 0 start transmission with MSB (=0) or LSB (=1)
SSIMODE = 0 alarm bit at begin (=1) or at end (=2) or off (=0)
SSIOUT = 25 data bits–1 (26)
IN1MODE = 16 Start input for the motion task
IN1TRIG = 0 0 means: motion task is a homing move
NREF = 8 Number for homing move

The settings GEARMODE = 7 and OPMODE =4 activate the function read the SSI-position about the encoder-input. The drive read then the SSI-position every 250 µs and calculate the difference to the old position before. This difference will be multiply with a scaling-factor and add to the last position command value.

Scaling-factor = 2^(33-SSIOUT)* GEARO / GEARI ; with PRBASE=20
With SSIOUT=25: Scaling-factor = 256*GEARO / GEARI

The absolute position from Master/Slave could move with the parameter ROFFS. To adjust the absolute position between Master and Slave, it is necessary to do a homing with the slave drive and NREF = 8 (start with digital input). At the beginning of the homing the Slave drive read the absolute position from the Master, do the scaling and use this position as his target position for the homing. Then the drive change the operation mode to OPMODE = 8 and start the homing move, to the target position with VREF and the ramps ACCR / DECR. When the drive reach the target position he set the INPOSITION message. Then the PLC should reset the start input, to activate the Master/Slave-mode (OPMODE = 4) again.

For testing (with the setting MSG = 2) it is possible to display the Master SSI-position at the Slave drive with the command “M NEWSSI” in the terminal program of the drive. It is possible to get the Slave position with the command "M PFB". The relation between this positions is corresponding to the scaling-factor.
Sine encoder at X1 (Drive 400 X2) for position control (EXTPOS = 1)


ASCII English GEARO

ASCII - Command | GEARO |
Syntax Transmit | GEARO [Data] |
Syntax Receive | GEARO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3540 (hex)
DIM | - | PROFIBUS PNU | 1664 (dec) IND = 0000xxxx (bin)
Range | -2147483647 .. 2147483647 | DPR | 64 (dec)
Default | 8192 |
Opmode | 4 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Gearing | EEPROM | Yes
Short Description | Output Factor for Electronic Gearing

Description

In master/slave applications (OPMODE=4) this parameter can be used to set the master/slave translation ratio.


ASCII English GET

ASCII - Command | GET |
Syntax Transmit | GET |
Syntax Receive | GET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 3541 (hex)
DIM | - | PROFIBUS PNU | 1665 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 65 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Scope: output data

Description

The GET command returns a list with all the most recently recorded SCOPE data. The list consists of n+3 lines (n = no. items of data recorded)
Line 1: commentary e.g. “Drive Recording”
Line 2: n, timebase in msec e.g. 10, 0.25 (10 data lines, timebase 250 microseconds)
Line 3: var1, var2, var3 names of the recorded variables, e.g. VCMD, V, ICMD
Line 4: data1, data2, data3 recorded data, e.g. 0, 20.3, -0.5
Line 5: data1, dat2, data3
..
Line 1: data1, data2, data3

see also RECORD, RECTRIG


ASCII English GF

ASCII - Command | GF | For Manufacturer Use only
Syntax Transmit | GF [Data] |
Syntax Receive | GF <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3667 (hex)
DIM | - | PROFIBUS PNU | 1959 (dec) IND = 0000xxxx (bin)
Range | 0 ... 2000 | DPR | 359 (dec)
Default | 15 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Proportional Gain of the Flux Controller

Description

IN PREPARATION !

This command is only for the induction motor mode (MTYPE = 3).
This rotor flux controller utilizes a standard PI controller.
Rotor flux control loop: propotional gain. (see also GFTN)


ASCII English GFTN

ASCII - Command | GFTN | For Manufacturer Use only
Syntax Transmit | GFTN [Data] |
Syntax Receive | GFTN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3668 (hex)
DIM | ms | PROFIBUS PNU | 1960 (dec) IND = 0000xxxx (bin)
Range | 0 ... 1000 | DPR | 360 (dec)
Default | 50 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Integral Action Time of the Flux Controller

Description

IN PREPARATION !

This command is only for the induction motor mode (MTYPE = 3).
This rotor flux controller utilizes a standard PI controller.
Rotor flux control loop: integral action time constant.(see also GF)


ASCII English GP

ASCII - Command | GP |
Syntax Transmit | GP [Data] |
Syntax Receive | GP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3542 (hex)
DIM | (m/s)/m | PROFIBUS PNU | 1666 (dec) IND = 0000xxxx (bin)
Range | 0.001 .. 25.0 | DPR | 66 (dec)
Default | 0.15 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Control Loop: Proportional Gain

Description

This variable is used both in the P position control loop (EXTPOS=1, 3, 4), and in the PI position control loop (EXTPOS=0, 2). If GP is set too low, the lag or settling time is too long and the drive is too soft. If GP is set too high, the drive oscillates.


ASCII English GPFFT

ASCII - Command | GPFFT |
Syntax Transmit | GPFFT [Data] |
Syntax Receive | GPFFT <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0.0 ... 5.0 | DPR | No
Default | 1 |
Opmode | 4,5,8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position control loop: feed forward for the current setpoint

Description

Position control loop: feed forward for the current setpoint.
Has to be set, that the contouring error is minimized.

This parameter has effect for both P position and PI position control structure only in the following cases:
1.using table based motion task enabled with bit in O_C. ;
2.using SPSET = 3, when the internal motion task profile is used.
3.using SPSET = 4, when the internal motion task profile is used.

If GV is changed after optimizing GPFFT, GPFFT has to be changed also inversely proportional.


ASCII English GPFFV

ASCII - Command | GPFFV |
Syntax Transmit | GPFFV [Data] |
Syntax Receive | GPFFV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3545 (hex)
DIM | - | PROFIBUS PNU | 1669 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 50.0 | DPR | 69 (dec)
Default | 1.0 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Control Loop: Feed Forward for Velocity

Description

This variable is used both in the P position control loop (EXTPOS=1, 3, 4), and in the PI position control loop (EXTPOS=0, 2). Feed forward is used to ease the position controller task. A better setting for GPFFV means better utilization of the dynamic range of the position controller. The most favorable setting (usually about 1.0), depends on factors external to the drive such as friction, dynamic resistance, and stiffness. If GPFFV is set too low, the drive lags. If GPFFV is set too high, the drive oversteers.


ASCII English GPRED

ASCII - Command | GPRED |
Syntax Transmit | GPRED [Data] |
Syntax Receive | GPRED <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | No
DIM |  | PROFIBUS PNU | No
Range | 0...200 | DPR | No
Default | 100 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM |
Short Description |

Description

GPRED defines the reduction/attenuation ratio for the proportional gain of the position loop during
the motion task phase. This parameter is activ only for P position loop (EXTPOS=4).


ASCII English GPTN

ASCII - Command | GPTN |
Syntax Transmit | GPTN [Data] |
Syntax Receive | GPTN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3546 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1670 (dec) IND = 0000xxxx (bin)
Range | 1.0 .. 200.0 | DPR | 70 (dec)
Default | 50 |
Opmode | 4, 5, 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Control Loop: Integral-Action Time

Description

This parameter is only used for the PI position control loop (EXTPOS = 0,2). There is no possibility to switch off the integral part. If a P position control loop and P velocity control loop should be used, set EXTPOS = 1,3,4 and set GVTN = 0


ASCII English GV

ASCII - Command | GV |
Syntax Transmit | GV [Data] |
Syntax Receive | GV <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3548 (hex)
DIM | - | PROFIBUS PNU | 1672 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 62.5*GVTN | DPR | 72 (dec)
Default | 1 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Velocity Control Loop: Proportional Gain

Description

GV gives the proportional (ac) gain of the velocity control loop. This also affects GVTN.Compared with the SR 600 the dimension has changed to As/rad.GV[SR300] = GV[SR600] * DIPEAK [in A]/ 314.15rad/s
Using the SR601 and GV[SR600] = 1 -> GV[SR300] = 1 * 3A / 314.15rad/s = 0.010 As/rad
Using the SR603 and GV[SR600] = 1 -> GV[SR300] = 1 * 6A / 314.15rad/s = 0.019 As/rad
Using the SR606 and GV[SR600] = 1 -> GV[SR300] = 1 * 12A / 314.15rad/s = 0.038 As/rad
Using the SR610 and GV[SR600] = 1 -> GV[SR300] = 1 * 20A / 314.15rad/s = 0.064 As/rad
Using the SR610-30 / 614 / 620 and GV[SR600] = 1 -> GV[SR300] = 1 * 40A / 314.15rad/s = 0.127 As/rad
Using the SR640 and GV[SR600] = 1 -> GV[SR300] = 1 * 80A / 314.15rad/s = 0.255 As/rad
Using the SR670 and GV[SR600] = 1 -> GV[SR300] = 1 * 160A / 314.15rad/s = 0.509 As/rad
Using the SR403 and GV[SR400] = 1 -> GV[SR300] = 1 * 9A / 314.15rad/s = 0.029 As/rad
Using the SR406 and GV[SR400] = 1 -> GV[SR300] = 1 * 12A / 314.15rad/s = 0.038 As/rad


ASCII English GVTN

ASCII - Command | GVTN |
Syntax Transmit | GVTN [Data] |
Syntax Receive | GVTN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 354D (hex)
DIM | Milliseconds | PROFIBUS PNU | 1677 (dec) IND = 0000xxxx (bin)
Range | 0.0 , GV/62.5 .. 1000.0 | DPR | 77 (dec)
Default | 10 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Velocity Control Loop: I-Integration Time

Description

This variable determines the integral-action time/integral time constant. Smaller motors permit shorter integration times. Larger motors or high moments of inertia in the load usually require integration times of 20ms or more. With GVTN=0ms, the I-component is switched off. If the GVTN value is too low, the drive runs roughly or strongly overshoots with high inertia loads. If the GVTN value is too high, the drive is too soft.


ASCII English HDUMP

ASCII - Command | HDUMP |
Syntax Transmit | HDUMP |
Syntax Receive | HDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | 3551 (hex)
DIM | - | PROFIBUS PNU | 1681 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 81 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Output all sin/cos (Hiperface) variables

Description

Produces an output of all the sin/cos feedback variables.


ASCII English HELP

ASCII - Command | HELP |
Syntax Transmit | HELP |
Syntax Receive | HELP <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | Output Parameter Help Information

Description

Using the parameter HELP <name> produces a display of help information for the ASCII parameter “name”. This help information includes input limits and both the actual and default values for the parameter.
e.g. HELP GV
GV act=6 min=0 max=1000 default=1


ASCII English HICOFFS

ASCII - Command | HICOFFS | For Manufacturer Use only
Syntax Transmit | HICOFFS [Data] |
Syntax Receive | HICOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3552 (hex)
DIM | Millivolts | PROFIBUS PNU | 1682 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 82 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Hiperface: Cosine-Offset (incremental track)

Description

The HICOFFS command sets the offset correction (in mV) for the cosine signal of the incremental track.
The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HICOFFS setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HIFACT1

ASCII - Command | HIFACT1 | For Manufacturer Use only
Syntax Transmit | HIFACT1 [Data] |
Syntax Receive | HIFACT1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3553 (hex)
DIM | - | PROFIBUS PNU | 1683 (dec) IND = 0000xxxx (bin)
Range | 12000 .. 19000 | DPR | 83 (dec)
Default | 16384 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Encoder
Short Description | Hiperface: Sin/Cos Gain Factor (incremental track)

Description

The HIFACT1 command sets the amplitude scaling for the sine signal of the absolute track (SinCoder). The amplitude scaling is for the value 16384 = 1.

The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HIFACT1 setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HISOFFS

ASCII - Command | HISOFFS | For Manufacturer Use only
Syntax Transmit | HISOFFS [Data] |
Syntax Receive | HISOFFS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3554 (hex)
DIM | Millivolts | PROFIBUS PNU | 1684 (dec) IND = 0000xxxx (bin)
Range | -10000 .. 10000 | DPR | 84 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Encoder
Short Description | Hiperface: Sin/Cos Offset (incremental track)

Description

The HISOFFS command sets the offset correction (in mV) for the sine signal of the incremental track.
The command is only available when a sin/cos encoder has been selected as the feedback device (FBTYPE=2,4,7). Depending on the type of encoder used, the HISOFFS setting is stored in the EEPROM of the encoder (FBTYPE=2,4, command HSAVE).
When using an encoder without a parameter channel (FBTYPE=7), and thus without an internal EEPROM, this setting will be saved in the EEPROM of the amplifier (command SAVE).


ASCII English HSAVE

ASCII - Command | HSAVE | For Manufacturer Use only
Syntax Transmit | HSAVE |
Syntax Receive | HSAVE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 3556 (hex)
DIM | - | PROFIBUS PNU | 1686 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 86 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Hiperface: Save Parameters in Encoder

Description

If FBTYPE=2 or =4 is set, the HSAVE command saves the variables for the encoder (HIPERFACE / EnDat) in the serial EEPROM of the encoder. With the setting FBTYPE=7, only the variables for the incremental track, as well as MNUMBER and MPHASE are saved in the serial EEPROM of the amplifier.
This command is only available if the amplifier has detected a sin/cos encoder (FBTYPE =2;4;7).
FBTYPE = 2 HIPERFACE (Stegmann)
FBTYPE = 4 EnDat (Heidenhain)
FBTYPE = 7 SINCOS – encoder without its own serial EEPROM

The HSAVE command saves the following variables.
MNUMBER*
MPHASE*
HICOFFS*
HISOFFS*
HIFACT1*
* If FBTYPE = 7, these parameters are saved in the serial EEPROM of the amplifier.

Hiperface encoder, which have contents, can be erased by "HSAVE ERASE".


ASCII English HVER

ASCII - Command | HVER |
Syntax Transmit | HVER |
Syntax Receive | HVER <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 3557 (hex)
DIM | - | PROFIBUS PNU | 1687 (dec) IND = 0000xxxx (bin)
Range | max 50 ASCII Characters | DPR | 87 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | No
Short Description | Output the Hardware Version

Description

The HVER command returns the designation for the hardware version, in the following form:
“Drive 3xx Hardware Version (yy) zzzz”
xx - designation of the output stage (current rating)
yy - designation of the hardware version
zzzz - date of the first hardware revision


ASCII English I

ASCII - Command | I |
Syntax Transmit | I |
Syntax Receive | I <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3558 (hex)
DIM | Amperes | PROFIBUS PNU | 1688 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 88 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Current Monitor

Description

This variable returns the actual current value in amperes. This value is always positive.


ASCII English I2TLIM

ASCII - Command | I2TLIM |
Syntax Transmit | I2TLIM [Data] |
Syntax Receive | I2TLIM <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 355A (hex)
DIM | % | PROFIBUS PNU | 1690 (dec) IND = 0000xxxx (bin)
Range | 0 .. 100 | DPR | 90 (dec)
Default | 80 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | I2T Warning

Description

This variable defines a threshold for the I2T warning. As soon as the I2T values goes above this threshold, the warning, n01, is generated. This warning is passed on to a control system via a digital output (OxMODE=11). If the I2TLIM value is too low, the message appears too soon and the drive is not fully utilized. If the I2TLIM value is too high, limiting occurs at the same time as the message.


ASCII English ICMD

ASCII - Command | ICMD |
Syntax Transmit | ICMD |
Syntax Receive | ICMD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 355B (hex)
DIM | Amperes | PROFIBUS PNU | 1691 (dec) IND = 0000xxxx (bin)
Range | -DIPEAK .. DPEAK | DPR | 91 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | No
Short Description | Current Setpoint

Description

Shows the internal current setpoint.


ASCII English ICMDVLIM

ASCII - Command | ICMDVLIM |
Syntax Transmit | ICMDVLIM [Data] |
Syntax Receive | ICMDVLIM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3685 (hex)
DIM | VUNIT | PROFIBUS PNU | 1989 (dec) IND = 0000xxxx (bin)
Range | 0 .. VLIM | DPR | 389 (dec)
Default | 0 |
Opmode | 2,3 | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Velocity Limit in Current Control

Description

ICMDVLIM defines the velocity limit (given in VUNIT) at current control in OPMODE = 2 and 3.
This function is enabled, if ICMDVLIM is >0. It is a configuration parameter, but if ICMDVLIM was >0 while startup of the drive, this function can be disabled online by setting ICMDVLIM afterwards.


ASCII English ID

ASCII - Command | ID |
Syntax Transmit | ID |
Syntax Receive | ID <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 355D (hex)
DIM | Amperes | PROFIBUS PNU | 1693 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 93 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | D-component of Current Monitor

Description

The D-axes component of the actual current value.


ASCII English IN

ASCII - Command | IN |
Syntax Transmit | IN |
Syntax Receive | IN <Data> | Available in |
Type | Multi-line Return Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 3560 (hex)
DIM | - | PROFIBUS PNU | 1696 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 96 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | -
Short Description | List Analog Voltage Values

Description

The IN command returns the input voltages for the 8 A/D channels as counts (-4096 ... +4096).
Channel 0: Heat sink temperature
Channel 1: Ambient temperature
Channel 2: Regen power
Channel 3: I_U
Channel 4: Motor temperature
Channel 5: DC-link/DC-bus voltage [4096 counts = 1015 V]
Channel 6: Supply voltage [4096 counts = 800 V]
Channel 7: I_W


ASCII English IN1

ASCII - Command | IN1 |
Syntax Transmit | IN1 |
Syntax Receive | IN1 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3561 (hex)
DIM | - | PROFIBUS PNU | 1697 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 97 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | -
Short Description | Status of Digital Input 1

Description

The status of the digital input INPUT1.


ASCII English IN1HCMD

ASCII - Command | IN1HCMD |
Syntax Transmit | IN1HCMD [Data] |
Syntax Receive | IN1HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for high level

Description

The command IN1HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 1 that has been configured with the function IN1MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN1HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN1LCMD

ASCII - Command | IN1LCMD |
Syntax Transmit | IN1LCMD [Data] |
Syntax Receive | IN1LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for low level

Description

The command IN1LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 1 that has been configured with the function IN1MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN1LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN1MODE

ASCII - Command | IN1MODE |
Syntax Transmit | IN1MODE [Data] |
Syntax Receive | IN1MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3562 (hex)
DIM | - | PROFIBUS PNU | 1698 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 98 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 1

Description

The IN1MODE command is used to configure the function of the digital input INPUT1. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN1MODE=0 | Off | The state of the input 1 is read and can be used via fieldbus or Slot card.
IN1MODE=1 | Reset | Software reset of the servo amplifier in the event of a fault. The high input signal is ignored, if the drive has no fault. All the functions and displays are set to the initial status. Parameters that are not stored in the EEPROM are erased, the parameter set that is stored in the EEPROM is loaded. If any of the error messages F01, F02, F03, F05, F08, F13, F16 or F19 ( p.52) are present, then no software-reset will be carried out, just the error message will be deleted. This means that, for example, the encoder output signals are stable and can continue to be evaluated by the controls. When the input is high, while the auxillary 24V supply is switched on, the drive waits, before the input is set to low. This state is symbolised in the display. The first of the three display positions displays a "A".
IN1MODE=2 | Off |
IN1MODE=3 | Off |
IN1MODE=4 | Off |
IN1MODE=5 | Off |
IN1MODE=6 | Off |
IN1MODE=7 | Off |
IN1MODE=8 | SETP.1/SETP.2 | Switches over the setpoint inputs SW/SETP.1/2 at ANCNFG = 0. This function is only effective if the analog set-point function 0,Xcmd=Setp.1 has been selected. High level at the input : Setpoint input 2 (terminals X3/6,7) is active Low level at the input : Setpoint input 1 (terminals X3/4,5) is active
IN1MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (INxMODE =17, Start_MT IO). If you wire up a reference/homing switch (INxMODE =12, Reference) and (also) want to start a following task (INxMODE =15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced. This function can also be used for the VCT entry functionality, to select the adress of the VCT's. The start of the VCT entry is done by selecting one input with INxMODE=35.
IN1MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN1MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN1MODE=12 | Reference | home/reference switch located on machine
IN1MODE=13 | ROD/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE = 2) High level at the input : ROD-compatible position signals (ENCMODE = 1)
IN1MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN1MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started.
IN1MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN1TRIG. Motion task number “0” (IN1TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task.
IN1MODE=17 | Start_MT IO | 17, Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN1MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN1TRIG. Make the conversion according to the following equation: IN1TRIG given in % of IPEAK
IN1MODE=19 | Off |
IN1MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN1TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT.
IN1MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier.
IN1MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN1MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN1TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN1MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN1TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input1=low OPMODE=4 Input1=high OPMODE=8 IN1MODE=24 (Activate Input) IN1TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN1MODE=25 | Zero_latch | Sets the ROD zero pulse offset. The current position, depending on the ROD resolution that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN1MODE=26 | Position Latch | A edge on this input latches the actual position. The position can then be read by LATCHX32 (positive edge) or LATCHX32N (negative edge). The actual 16-Bit position (absolute in one turn) can be read by LATCHX16 (positive edge) and LATCHX16N (negative edge). The status of the latching can be read by the equivalent bits of DRVSTAT. The min. cycle time for a low/high to high/low transaction is 500µs. The min. time between two latch pulses is 8 msec. The Latch function does not work with POSCNFG=1.
IN1MODE=27 | Emergency Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode.
IN1MODE=28 | Reserved |
IN1MODE=29 | Reserved |
IN1MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMD, the command buffer for the negative edge is INLCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=30 function.
IN1MODE=31 | Command Buffer 2 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMDX, the command buffer for the negative edge is INLCMDX. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=31, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=31 function.
IN1MODE=32 | Brake | A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled. If an error message is active, the brake cannot be de-energized. Warning ! With suspended loads, this function will lead to slipping of the axes ! Starting with 4.78, this function also works if the drive has an error.
IN1MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN1MODE=34 | see 31 | Different from the functionality 31, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN1MODE=35 | Select Velocity/Current Entry | A positive edge on the digital input causes a takeover of the corresponding VCT entry (see command VCT). The number of the VCT entry is defined by the digital inputs configured with mode 9.
IN1MODE=36 | Give Offset to Gearing Function | Gearing mode OPMODE =4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN1TRIG. The scaling is in 20Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN1TRIG can be calculated: IN1TRIG= n * 250 / ( 60 * rpm) e.g. n = 50 rpm IN1TRIG = 208
IN1MODE=37 | Change source of the actual position at EXTPOS=1. | = 0 Actual position is generated by the external encoder selected by GEARMODE = 1 Actual position is generated by the first feedback device (resolver od high resolution feedback EnDAT or Hiperface)
IN1MODE=38 | Enable signal for following motion task | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN1MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN1TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT) and the time by the upper 16 bit (given in msec) of the help variable IN1TRIG. A rising edge at INPUT1 changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN1TRIG. After the defined time or a falling edge at INPUT1 is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN1TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN1TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN1TRIG = 0x000afe0c = 720396
IN1MODE=40 | Additional hardware input | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage. (Starting firmware 4.91)
IN1MODE=41 | Fast emergency stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN1MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time (stating with firmware 5.51).
IN1MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN1MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN1TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position(starting with Firmware 5.51).


ASCII English IN1TRIG

ASCII - Command | IN1TRIG |
Syntax Transmit | IN1TRIG [Data] |
Syntax Receive | IN1TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3563 (hex)
DIM | - | PROFIBUS PNU | 1699 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 99 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Variable for IN1MODE

Description

Auxiliary trigger variable for IN1MODE. Certain settings of IN1MODE require you to specify an additional trigger level. See IN1MODE for further details.


ASCII English IN2

ASCII - Command | IN2 |
Syntax Transmit | IN2 |
Syntax Receive | IN2 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3564 (hex)
DIM | - | PROFIBUS PNU | 1700 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 100 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Status of Digital Input 2

Description

The status of the digital input INPUT2.


ASCII English IN2HCMD

ASCII - Command | IN2HCMD |
Syntax Transmit | IN2HCMD [Data] |
Syntax Receive | IN2HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for high level

Description

The command IN2HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 2 that has been configured with the function IN2MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN2HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN2LCMD

ASCII - Command | IN2LCMD |
Syntax Transmit | IN2LCMD [Data] |
Syntax Receive | IN2LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for low level

Description

The command IN2LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 2 that has been configured with the function IN2MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN2LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN2MODE

ASCII - Command | IN2MODE |
Syntax Transmit | IN2MODE [Data] |
Syntax Receive | IN2MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3565 (hex)
DIM | - | PROFIBUS PNU | 1701 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 101 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 2

Description

The IN2MODE command is used to configure the function of the digital input INPUT2. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN2MODE=0 | Off | The state of the input 2 is read and can be used via fieldbus or Slot card.
IN2MODE=1 | Off |
IN2MODE=2 | Off |
IN2MODE=3 | Off |
IN2MODE=4 | Off |
IN2MODE=5 | Off |
IN2MODE=6 | Off |
IN2MODE=7 | Off |
IN2MODE=8 | SETP.1/SETP.2 | Switches over the setpoint inputs SW/SETP.1/2 . This function is only effective if the analog set-point function ANCNFG=0,Xcmd=Setp.1 has been selected. High level at the input : Setpoint input 2 (terminals X3/6,7) is active Low level at the input : Setpoint input 1 (terminals X3/4,5) is active
IN2MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (17, Start_MT IO). If you wire up a reference/homing switch (12, Reference) and (also) want to start a following task (15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced. This function can also be used for the VCT entry functionality, to select the adress of the VCT's. The start of the VCT entry is done by selecting one input with INxMODE=35.
IN2MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN2MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN2MODE=12 | Reference | home/reference switch located on machine
IN2MODE=13 | ROD/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE=2) High level at the input : A/B encoder emulation-compatible position signals (ENCMODE=1)
IN2MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN2MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started.
IN2MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN2TRIG. Motion task number “0” (IN2TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task.
IN2MODE=17 | Start_MT IO | 17, Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN2MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN2TRIG. Make the conversion according to the following equation: IN2TRIG given in % of IPEAK
IN2MODE=19 | Reserved |
IN2MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN2TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT.
IN2MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier.
IN2MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN2MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN2TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN2MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN2TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input2=low OPMODE=4 Input2=high OPMODE=8 IN2MODE=24 (Activate Input) IN2TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN2MODE=25 | Zero_latch | Sets the ROD zero pulse offset. The current position, depending on the A/B encoder emulation resolution that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN2MODE=26 | Position Latch | A edge on this input latches the actual position. The position can then be read by LATCH32 (positive edge) or LATCH32N (negative edge). The actual 16-Bit position (absolute in one turn) can be read by LATCH16 (positive edge) and LATCH16N (negative edge). The status of the latching can be read by the equivalent bits of DRVSTAT. The min. cycle time for a low/high to high/low transaction is 500µs. The min. time between two latch pulses is 8 msec. The Latch function does not work with POSCNFG=1.
IN2MODE=27 | Emergency Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode.
IN2MODE=28 | Reserved |
IN2MODE=29 | Reserved |
IN2MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMD, the command buffer for the negative edge is INLCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=30 function.
IN2MODE=31 | Command Buffer 2 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMDX, the command buffer for the negative edge is INLCMDX. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=31, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=31 function.
IN2MODE=32 | Brake | A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled. If an error message is active, the brake cannot be de-energized. Warning ! With suspended loads, this function will lead to slipping of the axes !
IN2MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN2MODE=34 | see 31 | Different from the functionality 31, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN2MODE=35 | Select Velocity/Current Entry | A positive edge on the digital input causes a takeover of the corresponding VCT entry (see command VCT). The number of the VCT entry is defined by the digital inputs configured with mode 9.
IN2MODE=36 | Give Offset to Gearing Function | Gearing mode 4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN1TRIG. The scaling is in 20Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN1TRIG can be calculated: IN1TRIG= n * 250 / ( 60 * rpm) e.g. n = 50 rpm IN1TRIG = 208
IN2MODE=37 | Change source of the actual position at EXTPOS=1. | = 0 Actual position is generated by the external encoder selected by GEARMODE = 1 Actual position is generated by the first feedback device (resolver od high resolution feedback EnDAT or Hiperface)
IN2MODE=38 |  | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN1MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN2MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN2TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT) and the time by the upper 16 bit (given in msec) of the help variable IN2TRIG. A rising edge at INPUTx changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN2TRIG. After the defined time or a falling edge at INPUTx is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN2TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN2TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN2TRIG = 0x000afe0c = 720396
IN2MODE=40 | Additional hardware enable | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage. (Starting firmware 4.91)
IN2MODE=41 | Fast emercency stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN2MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time (stating with firmware 5.51).
IN2MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN2MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN2TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position(starting with Firmware 5.51).


ASCII English IN2PM

ASCII - Command | IN2PM |
Syntax Transmit | IN2PM [Data] |
Syntax Receive | IN2PM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 362E (hex)
DIM | - | PROFIBUS PNU | 1902 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 302 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | In-Position 2 Mode

Description

The IN2PM command is used to configure the function of the interim message during a motion task (motion block) sequence.

The function “Interim message during a motion task sequence” (NextInPos) is available if an I/O expansion card is used (terminal X11B4) or a digital output of the drive is configured with the function OxMODE=16. At the start of the first motion block (motion task), the “NextInPos” output is always set to 0. The response of the output during the execution of the motion block sequence depends on the configuration variable IN2PM.

IN2PM=0 – the output is inverted at the start of the next block.
IN2PM=2 – the output is inverted at the end of a block.
IN2PM=1 – the output is set to 0 at the start of a motion block, and set to HIGH at the end of a motion block.

With a sequence of motion blocks where the blocks are started immediately, only the IN2PM=0 or IN2PM=2 settings make sense. If the setting is IN2PM=1, the HIGH state is so short that it may not be registered at all by the external control system.

If a following task is started with the aid of an I/O (INxMODE=15), then the IN2PM=2 or IN2PM=1 setting should be used. With this setting, the end of a motion block is signaled by the HIGH state (IN2PM=1) or the change of state (IN2PM=2) at the “NextInPos” output. The external control system can then initialize the continuation of the motion task sequence via the “Start next task” input.


ASCII English IN2TRIG

ASCII - Command | IN2TRIG |
Syntax Transmit | IN2TRIG [Data] |
Syntax Receive | IN2TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3566 (hex)
DIM | - | PROFIBUS PNU | 1702 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 102 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Variable for IN2MODE

Description

Auxiliary trigger variable for IN2MODE. Certain settings of IN2MODE require you to specify an additional trigger level. See IN2MODE for further details.


ASCII English IN3

ASCII - Command | IN3 |
Syntax Transmit | IN3 |
Syntax Receive | IN3 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3567 (hex)
DIM | - | PROFIBUS PNU | 1703 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 103 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Status of Digital Input 3

Description

The status of the digital input INPUT3.


ASCII English IN3HCMD

ASCII - Command | IN3HCMD |
Syntax Transmit | IN3HCMD [Data] |
Syntax Receive | IN3HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for high level

Description

The command IN3HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 3 that has been configured with the function IN3MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN3HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN3LCMD

ASCII - Command | IN3LCMD |
Syntax Transmit | IN3LCMD [Data] |
Syntax Receive | IN3LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for low level

Description

The command IN3LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 3 that has been configured with the function IN3MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN3LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN3MODE

ASCII - Command | IN3MODE |
Syntax Transmit | IN3MODE [Data] |
Syntax Receive | IN3MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3568 (hex)
DIM | - | PROFIBUS PNU | 1704 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 104 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 3

Description

The IN3MODE command is used to configure the function of the digital input INPUT3. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN3MODE=0 | Off | The state of the input 3 is read and can be used via fieldbus or Slot card.
IN3MODE=1 | Off |
IN3MODE=2 | PSTOP | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=3 | NSTOP (4.78) | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=4 | PSTOP+Intg.Off | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN3MODE=5 | Off |
IN3MODE=6 | PSTOP+NSTOP | A low on the input disables the positive and the negative direction. At the same time, a warning "n10" and "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN3MODE=7 | P/Nstop+Intg.Off | A low on the input disables the positive and the negative direction. At the same time, a warning "n10" and "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN3MODE=8 | SETP.1/SETP.2 | Switches over the setpoint inputs SW/SETP.1/2 . This function is only effective if the analog set-point function ANCNFG = 0,Xcmd=Setp.1 has been selected. High level at the input : Setpoint input 2 (terminals X3/6,7) is active Low level at the input : Setpoint input 1 (terminals X3/4,5) is active
IN3MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (17, Start_MT IO). If you wire up a reference/homing switch (12, Reference) and (also) want to start a following task (15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced. This function can also be used for the VCT entry functionality, to select the adress of the VCT's. The start of the VCT entry is done by selecting one input with INxMODE=35.
IN3MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN3MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN3MODE=12 | Reference | home/reference switch located on machine
IN3MODE=13 | ROD/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE=2 High level at the input : A/B encoder-compatible position signals (ENCMODE=1)
IN3MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN3MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started.
IN3MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN3TRIG. Motion task number “0” (IN3TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task (STOP).
IN3MODE=17 | Start_MT IO | 17, Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN3MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN3TRIG. Make the conversion according to the following equation: IN3TRIG given in % of IPEAK
IN3MODE=19 | Reserved |
IN3MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN3TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT.
IN3MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier.
IN3MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN3MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN3TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN3MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN3TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input3=low OPMODE=4 Input3=high OPMODE=8 IN3MODE=24 (Activate Input) IN3TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN3MODE=25 | Zero_latch | Sets the ROD zero pulse offset. The current position, depending on the A/B encoder emulation resolution that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN3MODE=26 | Off |
IN3MODE=27 | Emergency Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode.
IN3MODE=28 | Reserved |
IN3MODE=29 | Reserved |
IN3MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMD, the command buffer for the negative edge is INLCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=30 function.
IN3MODE=31 | Command Buffer 2 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMDX, the command buffer for the negative edge is INLCMDX. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=31, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=31 function.
IN3MODE=32 | Brake | A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled. If an error message is active, the brake cannot be de-energized. Warning ! With suspended loads, this function will lead to slipping of the axes !
IN3MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN3MODE=34 | see 31 | Different from the functionality 31, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN3MODE=35 | Select Velocity/Current Entry | A positive edge on the digital input causes a takeover of the corresponding VCT entry (see command VCT). The number of the VCT entry is defined by the digital inputs configured with mode 9.
IN3MODE=36 | Give Offset to Gearing Function | Gearing mode 4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN3TRIG. The scaling is in 20Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN3TRIG can be calculated: IN3TRIG= n * 250 / ( 60 * rpm) e.g. n = 50 rpm IN3TRIG = 208
IN3MODE=37 | Change source of the actual position at EXTPOS=1. | = 0 Actual position is generated by the external encoder selected by GEARMODE = 1 Actual position is generated by the first feedback device (resolver od high resolution feedback EnDAT or Hiperface)
IN3MODE=38 |  | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN3MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN3MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by INxTRIG. The velocity is given by the lower 16 bit (scaling by VUNIT) and the time by the upper 16 bit (given in msec) of the help variable INxTRIG. A rising edge at INPUTx changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN3TRIG. After the defined time or a falling edge at INPUTx is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN3TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN3TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN3TRIG = 0x000afe0c = 720396
IN3MODE=40 | Additional hardware enable | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage. (Starting firmware 4.91)
IN3MODE=41 | Fast emergency stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN3MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time (stating with firmware 5.51).
IN3MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN3MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN3TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position(starting with Firmware 5.51).


ASCII English IN3TRIG

ASCII - Command | IN3TRIG |
Syntax Transmit | IN3TRIG [Data] |
Syntax Receive | IN3TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3569 (hex)
DIM | - | PROFIBUS PNU | 1705 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 105 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Variable for IN3MODE

Description

Auxiliary trigger variable for IN3MODE. Certain settings of IN3MODE require you to specify an additional trigger level. See IN3MODE for further details.


ASCII English IN4

ASCII - Command | IN4 |
Syntax Transmit | IN4 |
Syntax Receive | IN4 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356A (hex)
DIM | - | PROFIBUS PNU | 1706 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 106 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Status of Digital Input 4.

Description

The status of the digital input INPUT4.


ASCII English IN4HCMD

ASCII - Command | IN4HCMD |
Syntax Transmit | IN4HCMD [Data] |
Syntax Receive | IN4HCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for high level

Description

The command IN4HCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a rising edge is detected at the input 4 that has been configured with the function IN4MODE=30,33
A command sequence consists of individual ASCII commands, separated by a semicolon (;)
The maximum length of this command sequence is 56 characters.

Example:
IN4HCMD GV 10; GVTN 15

If a LOW/HIGH edge is detected, the gain of the velocity control loop is set to 10 and the integral action time is set to 15 msec.


ASCII English IN4LCMD

ASCII - Command | IN4LCMD |
Syntax Transmit | IN4LCMD [Data] |
Syntax Receive | IN4LCMD <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | -
Short Description | Command buffer for low level

Description

The command IN4LCMD can be used to define an ASCII command sequence. This command sequence will always be carried out when a falling edge is detected at the input 4 that has been configured with the function IN4MODE=30,33 A command sequence consists of individual ASCII commands, separated by a semicolon (;) The maximum length of this command sequence is 56 characters.

Example:
IN4LCMD GV 5; GVTN 10

If a HIGH/LOW edge is detected, the gain of the velocity control loop is set to 5 and the integral action time is set to 10 msec.


ASCII English IN4MODE

ASCII - Command | IN4MODE |
Syntax Transmit | IN4MODE [Data] |
Syntax Receive | IN4MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356B (hex)
DIM | - | PROFIBUS PNU | 1707 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 107 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Input 4

Description

The IN4MODE command is used to configure the function of the digital input INPUT4. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
IN4MODE=0 | Off | The state of the input 4 is read and can be used via fieldbus or Slot card.
IN4MODE=1 | Off |
IN4MODE=2 | PSTOP (4.78) | A low on the input disables the positive direction (clockwise if DIR=1, counterclockwise if DIR=0). At the same time, a warning "n10" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN4MODE=3 | NSTOP | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated.
IN4MODE=4 | Off |
IN4MODE=5 | NSTOP+Intg.Off | A low on the input disables the negative direction (clockwise if DIR=0, counterclockwise if DIR=1). At the same time, a warning "n11" is displayed. If a negative edge is recognised while the motor is running, the drive stops the motor in OPMODE=0 (velocity control with setpoint zero) using the DECSTOP ramp. When the motor has stopped, the old OPMODE is activated (without integral part in the velocity controller).
IN4MODE=6 | Off |
IN4MODE=7 | Off |
IN4MODE=8 | SETP.1/SETP.2 | Switches over the setpoint inputs SW/SETP.1/2 . This function is only effective if the analog set-point function ANCNFG=0,Xcmd=Setp.1 has been selected. High level at the input : Setpoint input 2 (terminals X3/6,7) is active Low level at the input : Setpoint input 1 (terminals X3/4,5) is active
IN4MODE=9 | MT_No_Bit | Here you can select the motion tasks that are stored in the servo amplifier (numbers 1...7) or the reference traverse/homing (0). The motion task number is presented externally at the digital inputs as a logical word, with a width of max. 3 bits . An input is required to start the motion task (17, Start_MT IO). If you wire up a reference/homing switch (12, Reference) and (also) want to start a following task (15, Start_MT Next) externally, the number of inputs that are available for selecting the motion tasks will be further reduced. This function can also be used for the VCT entry functionality, to select the adress of the VCT's. The start of the VCT entry is done by selecting one input with INxMODE=35.
IN4MODE=10 | Intg.Off | Switch off the integral component of the velocity controller, the P-gain remains at the set value, the actual- (rotational) velocity feedback remains in operation.
IN4MODE=11 | v/Torq.Contr. | Bypasses the velocity controller. The analog setpoint is taken 1:1 as the setpoint for current control, i.e. change over from velocity control to current (torque) control. High-level at the input : torque control Low-level at the input : velocity control Depending on OPMODE, it changes between OPMODE=0 (low) and OPMODE=2 (high) or OPMODE=1 (low) and OPMODE=3 (high).
IN4MODE=12 | Reference | home/reference switch located on machine
IN4MODE=13 | ROD/SSI | Changeover of the encoder-emulation (position output) on connector X5. High level at the input : SSI-compatible position signals (ENCMODE=2) High level at the input : A/B encoder compatible position signals (ENCMODE=1)
IN4MODE=14 | FError_clear | Clear the warning of a contouring error (display n03) or the response monitoring (display n04).
IN4MODE=15 | Start_MT Next | The following task, that is defined in the motion task by “Start with I/O” is started. The target position of the present motion task must be reached before the following task can be started.
IN4MODE=16 | Start_MT No x | Start a motion task that is stored in the servo amplifier, by giving the motion task number. After the function has been selected you can enter the motion task number as the auxiliary variable IN4TRIG. Motion task number “0” (IN4TRIG=0) initiates homing/reference traverse. A rising edge starts the motion task, a falling edge cancels the motion task.
IN4MODE=17 | Start_MT IO | 17, Start_MT IO Start of the motion task that has the number that is presented, bit-coded, at the digital inputs (PSTOP/NSTOP/DIGITAL-IN1/DIGITAL-IN2, see function 9, MT_No_Bit ). A rising edge starts the motion task a falling edge cancels the motion task by a STOP - command
IN4MODE=18 | Ipeak2 x | Switch over to a second (lower) peak value of current. Scaled as x (0...100) % of the peak current of the instrument. After the function has been selected you can enter the percentage value as the auxiliary variable IN4TRIG. Make the conversion according to the following equation: IN4TRIG given in % of IPEAK
IN4MODE=19 | Reserved |
IN4MODE=20 | Start_Jog v=x | Start of the setup mode "Constant velocity" with a defined speed. After selecting the function, you can enter the speed in IN4TRIG. A rising edge starts the motion, a falling edge cancels the motion. This function works in position control, so OPMODE=8 has to be selected. The speed is given in units of the position controller given by VUNIT.
IN4MODE=21 | U_Mon.off | Turns off the undervoltage monitoring function of the servo amplifier.
IN4MODE=22 | MT Restart | Continues the motion task that was previously interrupted by a STOP - command.
IN4MODE=23 | Start2_MT No x | Start of a motion task that is stored in the servo amplifier, with definition of the motion task number. After selecting the function, you can enter the motion task number in IN4TRIG Motion task number “0” starts the homing run. A rising edge starts the motion task. Warning ! The motion task does not stop automatically if the start signal is removed ! The motion task must be stopped by — a falling edge on another digital input (configured with 16, FStart_Nr x) — the ASCII command STOP — the STOP function via Bus or digital input
IN4MODE=24 | Switch over OPMODE | The two different OPMODEs, that can be selected for switching over via the digital input, are written in the IN4TRIG help variable of the this input. The lower byte consists the OPMODE that should be available when the input has a negative edge. The higher byte consists the OPMODE that should be available when the input has a positive edge. When the drive is switched on, the OPMODE is set automatically to the corresponding state of the input. The contents of the help variable must be in decimal !! e.g.: Input4=low OPMODE=4 Input4=high OPMODE=8 IN4MODE=24 (Activate Input) IN4TRIG=2052 (Decimal 0804h) 2052 (Dec) = 0804 (Hex)
IN4MODE=25 | Zero_latch | Sets the A/B encoder emulation zero pulse offset. The current position, depending on the A/B encoder emulation resolution that is set, is calculated at the rising edge and stored as NI-Offset in ENCZERO. After that, an automatic SAVE is generated. This function is used to perform an automatic setting of the zero pulse in one turn of the motor..
IN4MODE=26 | Off |
IN4MODE=27 | Emergency Stop | Low state on the input starts an emergency stop function, that is executed with the ramp DECSTOP. Independently of the selected OPMODE, in this phase, the drive stops in velocity control. When it has stopped, it switches over to the original mode.
IN4MODE=28 | Reserved |
IN4MODE=29 | Reserved |
IN4MODE=30 | Command Buffer 1 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMD, the command buffer for the negative edge is INLCMD. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=30, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=30 function.
IN4MODE=31 | Command Buffer 2 | A positive or negative edge on the input starts a command buffer. This command buffer contains separate ASCII objects, that are separated with semicolon (;). The command buffer for the positive edge is INHCMDX, the command buffer for the negative edge is INLCMDX. The max. length of that buffers is 56 character for each. If a digital input is configured with INxMODE=31, this input will proceed in that way. When the drive is switched on, the Command buffer is set automatically started to the corresponding state of the input. Remark: Only one of the digital inputs can use the INxMODE=31 function.
IN4MODE=32 | Brake | A rising edge at the input triggers the braking output of the servo amplifier. This function is only available while the amplifier is disabled. If an error message is active, the brake cannot be de-energized. Warning ! With suspended loads, this function will lead to slipping of the axes !
IN4MODE=33 | see 30 | Different from the functionality 30, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN4MODE=34 | see 31 | Different from the functionality 31, the resulting answers of the commands are not suppressed, but are send to the seriell communication channel RS232.
IN4MODE=35 | Select Velocity/Current Entry | A positive edge on the digital input causes a takeover of the corresponding VCT entry (see command VCT). The number of the VCT entry is defined by the digital inputs configured with mode 9.
IN4MODE=36 | Give Offset to Gearing Function | Gearing mode 4. A high signal on the digital input configured with this INxMODE adds a difference velocity to the gearing. This allows a simple synchronisation of two axes. The difference velocity is given to IN4TRIG. The scaling is in 20Bit per revolution every 250µs. The difference velocity (n) must be known, then the IN4TRIG can be calculated: IN4TRIG= n * 250 / ( 60 * rpm) e.g. n = 50 rpm IN4TRIG = 208
IN4MODE=37 | Change source of the actual position at EXTPOS=1. | = 0 Actual position is generated by the external encoder selected by GEARMODE = 1 Actual position is generated by the first feedback device (resolver od high resolution feedback EnDAT or Hiperface)
IN4MODE=38 |  | Definition of a motion task with following motion tasks. If INxMODE=15 is used (start of an following motion task via I/O), IN4MODE=38 can be used, to have an additional enable for the start of the following motion tasks. Means, that the following motion task is started, if once a rising edge on digital input 1 was detected and then the INxMODE=15 input is enabled to start the following motion task.
IN4MODE=39 | Constant velocity for defined time | This function starts a constant velocity for a defined time. The parameters for velocity and time are given by IN4TRIG. The velocity is given by the lower 16 bit (scaling by VUNIT) and the time by the upper 16 bit (given in msec) of the help variable IN4TRIG. A rising edge at INPUTx changes the OPMODE to 0 (digital velocity) and gives the velocity that is given by IN4TRIG. After the defined time or a falling edge at INPUTx is detected, the digital velocity setpoint is set to "0". After the actual velocity has reached "0" the OPMODE is automatically switched back to the old one. Example for defining the help variable IN4TRIG 1. Velocity = 1000 rpm time = 10 sec = 10000 msec IN4TRIG = 0x271003E8 = 655361000 2. Velocity = -500 rpm time = 10 msec IN4TRIG = 0x000afe0c = 720396
IN4MODE=40 | Additional hardware enable | The digital input works as an additional hardware input. Only if this input has a high signal, the power stage is enabled. This Function can be used by several inputs. In this case, the inputs are configured in series. All inputs have to be high to enable the power stage. (Starting firmware 4.91)
IN4MODE=41 | Fast emergency stop | If the input is going to low, the drive stops the motor using the DECSTOP ramp. If zero velocity is reached (V<VEL0), the power stage is disabled. While stopping the motor the bit 24 (0x01000000) in TRJSTAT is set. The input is read in the 250µs task.
IN4MODE=42 | Activate/deactivate electronic gearing | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time (stating with firmware 5.51).
IN4MODE=43 | Activate/deactivate electronic gearing with position latch | Activate/deactivate electronic gearing in OPMODE = 4. This function is practical only with slave axis. A rising edge on the digital input starts the motion from 0 to the master speed and a falling edge changes the speed from master speed to 0. The ramp times can be set by ACCR for the acceleration and DECR for deceleration time In contrast to IN4MODE = 42, the master position is latched at the rising edge of the input and the position delay caused by the ramp is compensated. IN4TRIG gives the possibility to add an position offset (in PGEARI units) to the latched position(starting with Firmware 5.51).


ASCII English IN4TRIG

ASCII - Command | IN4TRIG |
Syntax Transmit | IN4TRIG [Data] |
Syntax Receive | IN4TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 356C (hex)
DIM | - | PROFIBUS PNU | 1708 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 108 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Variable for IN4MODE

Description

Auxiliary trigger variable for IN4MODE. Certain settings of IN4MODE require you to specify an additional trigger level. See IN4MODE for further details.


ASCII English Index

\
ACC
ACCR
ACCUNIT
ACTFAULT
ACTIVE
ACTRS232
ADDR
AENA
ALIAS
AN11NR
AN11RANGE
ANCNFG
ANDB
ANIN1
ANIN2
ANOFF1
ANOFF2
ANZERO1
ANZERO2
AUTOHOME
AVZ1
BCC
CALCCOG
CALCHP
CALCRK
CALCRP
CBAUD
CLRFAULT
CLRHR
CLRORDER
COGGING
COLDSTART
CONTINUE
CPHASE
CTUNE
CUPDATE
DEC
DECDIS
DECR
DECSTOP
DENA
DI2T
DICONT
DIFVAR
DILIM
DIPEAK
DIS
DISDPR
DNBAUD
DNDUMP
DNMACID
DOVRIDE
DPRILIMIT
DR_TYPE
DREF
DRVCNFG
DUMP
EGEARI
EGEARO
EMRGTO
EN
ENCLINES
ENCMODE
ENCOUT
ENCZERO
ERND
ERRCODE
ERRCODE *
ESPEED
EXTWD
FBTYPE
FLASH
FLTCNT
FLTCNT *
FLTHIST
FLTHIST *
FLUXM
FW
GEARFILT
GEARI
GEARMODE
GEARO
GET
GF
GFTN
GP
GPFFT
GPFFV
GPRED
GPTN
GV
GVTN
HDUMP
HELP
HICOFFS
HIFACT1
HISOFFS
HSAVE
HVER
I
I2TLIM
ICMD
ICMDVLIM
ID
IN
IN1
IN1HCMD
IN1LCMD
IN1MODE
IN1TRIG
IN2
IN2HCMD
IN2LCMD
IN2MODE
IN2PM
IN2TRIG
IN3
IN3HCMD
IN3LCMD
IN3MODE
IN3TRIG
IN4
IN4HCMD
IN4LCMD
IN4MODE
IN4TRIG
INPOS
INPT
INS0
INS1
INS2
INS3
INS4
INS5
INS6
INS7
INS8
IPEAK
IPEAKN
IPEAKP
IQ
ISCALE1
ISCALE2
ISTFR
J
K
KC
KEYLOCK
KTN
LASTWMASK
LATCH32
LATCH32N
LATCHX32
LATCHX32N
LDUMP
LED1
LED2
LED3
LEDSTAT
LIST
LOAD
M
M_1000
M_125
M_1600
M_250
M_250p
M_4000
M_DISABLE
M_ENABLE
M_INIT
M_IRQ
M_RESET
M_SMACRO
M_TASK
M_UMACRO
MAXSDO
MAXTEMPE
MAXTEMPH
MAXTEMPM
MBRAKE
MDBCNT
MDBGET
MDBLIST
MDBSET
MDUMP
MH
MI2T
MICONT
MIMR
MIPEAK
MJ
MJOG
MKT
ML
MLGC
MLGD
MLGP
MLGQ
MNAME
MNUMBER
MOVE
MPHASE
MPOLES
MRESBW
MRESPOLES
MRS
MSERIALNO
MSG
MSLBRAKE
MSPEED
MTANGLP
MTIME
MTMUX
MTR
MTYPE
MUNIT
MVANGLB
MVANGLF
MVANGLP
MVR
NONBTB
NREF
NREFMT
O_ACC1
O_C
O_DEC1
O_FN
O_FT
O_P
O_V
O1
O1MODE
O1TRIG
O2
O2MODE
O2TRIG
OBJCO
OCOPY
OLIST
OPMODE
OPTION
ORDER
OS1
OS2
OS3
OS4
OS5
OVRIDE
P1...P16
PASS
PASSCNFG
PASSX
PBAL
PBALMAX
PBALRES
PE
PEINPOS
PEMAX
PFB
PFB0
PGEARI
PGEARO
PMODE
PNOID
POP
POPI
POPI2
POPV
POSCNFG
POSRSTAT
PPOTYP
PRBASE
PRD
PROMPT
PSTATE
PTARGET
PTBASE
PTEACH
PTMIN
PUNIT
PV
PVMAXN
PVMAXP
RDP
RDPBIAS
RDPCLAMP
RDPINT
RDPKI
RDPKP
RDPON
READNIMP
READY
RECDONE
RECING
RECOFF
RECORD
RECRDY
RECTRIG
REFIP
REFLS
REFMODE
REFPOS
REMOTE
RESOLVER
RESPHASE
RK
ROFFS
ROFFS0
ROFFS2
RS232T
RSTVAR
RXPDO1A
RXPDO1B
RXPDO2A
RXPDO2B
RXPDO3A
RXPDO3B
RXPDO4A
RXPDO4B
S
SAVE
SERIALNO
SETREF
SETROFFS
SETVCT
SLEN
SLOTIO
SMNUMBER
SRND
STAGECODE
STAT
STATCODE
STATCODE *
STATIO
STATUS
STEP
STOP
STOPMODE
SWCNFG
SWE1
SWE2
T
TASK
TBRAKE
TBRAKE0
TEMPE
TEMPH
TEMPM
TRJSTAT
TRUN
TXPDO1A
TXPDO1B
TXPDO2A
TXPDO2B
TXPDO3A
TXPDO3B
TXPDO4A
TXPDO4B
UCOMP
UPDATE
UVLTMODE
V
VBUS
VBUSBAL
VBUSMAX
VBUSMIN
VBW
VCMD
VCOMM
VCTAB
VEL0
VER
VJOG
VLIMN
VLIMP
VLO
VMIX
VOSPD
VREF
VREF0
VSCALE1
VSCALE2
VSTFR
VTUNE
VUNIT
WMASK
WPOS
WPOSE
WPOSP
WPOSX


ASCII English Index Group

DI2T |
MI2T |
PASS |
ANIN1 | Actual Values
ANIN2 | Actual Values
I | Actual Values
ID | Actual Values
IN | Actual Values
IN1 | Actual Values
IQ | Actual Values
LED1 | Actual Values
LED2 | Actual Values
LED3 | Actual Values
PBAL | Actual Values
PE | Actual Values
PFB | Actual Values
PFB0 | Actual Values
PRD | Actual Values
PV | Actual Values
TASK | Actual Values
TEMPE | Actual Values
TEMPH | Actual Values
TEMPM | Actual Values
V | Actual Values
VBUS | Actual Values
VCMD | Actual Values
ACCUNIT | Amplifier
ACTFAULT | Amplifier
BCC | Amplifier
CLRFAULT | Amplifier
CUPDATE | Amplifier
DICONT | Amplifier
DIPEAK | Amplifier
DIS | Amplifier
DR_TYPE | Amplifier
EN | Amplifier
FW | Amplifier
K | Amplifier
LASTWMASK | Amplifier
LOAD | Amplifier
M | Amplifier
M_1000 | Amplifier
M_125 | Amplifier
M_1600 | Amplifier
M_250 | Amplifier
M_250p | Amplifier
M_4000 | Amplifier
M_DISABLE | Amplifier
M_INIT | Amplifier
M_IRQ | Amplifier
M_RESET | Amplifier
M_SMACRO | Amplifier
M_TASK | Amplifier
M_UMACRO | Amplifier
OPMODE | Amplifier
SAVE | Amplifier
UPDATE | Amplifier
VBUSMAX | Amplifier
VBUSMIN | Amplifier
VBW | Amplifier
VCOMM | Amplifier
VTUNE | Amplifier
WMASK | Amplifier
AN11NR | Analog I/O
AN11RANGE | Analog I/O
ANCNFG | Analog I/O
ANDB | Analog I/O
ANOFF1 | Analog I/O
ANOFF2 | Analog I/O
ANZERO1 | Analog I/O
ANZERO2 | Analog I/O
AVZ1 | Analog I/O
ISCALE1 | Analog I/O
ISCALE2 | Analog I/O
VSCALE1 | Analog I/O
VSCALE2 | Analog I/O
ADDR | Basic Setup
AENA | Basic Setup
ALIAS | Basic Setup
CBAUD | Basic Setup
DENA | Basic Setup
DILIM | Basic Setup
EMRGTO | Basic Setup
ERRCODE | Basic Setup
FLTCNT * | Basic Setup
FLTHIST * | Basic Setup
HVER | Basic Setup
KEYLOCK | Basic Setup
M_ENABLE | Basic Setup
MAXTEMPE | Basic Setup
MAXTEMPH | Basic Setup
MAXTEMPM | Basic Setup
MSLBRAKE | Basic Setup
PASSCNFG | Basic Setup
PASSX | Basic Setup
PBALMAX | Basic Setup
PBALRES | Basic Setup
PMODE | Basic Setup
RSTVAR | Basic Setup
SERIALNO | Basic Setup
STAGECODE | Basic Setup
STOPMODE | Basic Setup
TBRAKE | Basic Setup
TBRAKE0 | Basic Setup
TRUN | Basic Setup
UVLTMODE | Basic Setup
VBUSBAL | Basic Setup
VER | Basic Setup
\ | Communication
ACTRS232 | Communication
DIFVAR | Communication
DISDPR | Communication
DNDUMP | Communication
DNMACID | Communication
DRVCNFG | Communication
DUMP | Communication
EXTWD | Communication
FLASH | Communication
HELP | Communication
LIST | Communication
MAXSDO | Communication
MSG | Communication
OBJCO | Communication
PNOID | Communication
PPOTYP | Communication
PROMPT | Communication
PSTATE | Communication
RS232T | Communication
CTUNE | Current Controller
I2TLIM | Current Controller
ICMD | Current Controller
ICMDVLIM | Current Controller
IPEAK | Current Controller
IPEAKN | Current Controller
IPEAKP | Current Controller
KC | Current Controller
KTN | Current Controller
MLGC | Current Controller
MLGD | Current Controller
MLGP | Current Controller
MLGQ | Current Controller
POP | Current Controller
POPI | Current Controller
POPI2 | Current Controller
POPV | Current Controller
REFIP | Current Controller
IN1HCMD | Digital I/O
IN1LCMD | Digital I/O
IN1MODE | Digital I/O
IN1TRIG | Digital I/O
IN2 | Digital I/O
IN2HCMD | Digital I/O
IN2LCMD | Digital I/O
IN2MODE | Digital I/O
IN2TRIG | Digital I/O
IN3 | Digital I/O
IN3HCMD | Digital I/O
IN3LCMD | Digital I/O
IN3MODE | Digital I/O
IN3TRIG | Digital I/O
IN4 | Digital I/O
IN4HCMD | Digital I/O
IN4LCMD | Digital I/O
IN4MODE | Digital I/O
IN4TRIG | Digital I/O
INS0 | Digital I/O
INS1 | Digital I/O
INS2 | Digital I/O
INS3 | Digital I/O
INS4 | Digital I/O
INS5 | Digital I/O
INS6 | Digital I/O
INS7 | Digital I/O
INS8 | Digital I/O
O1 | Digital I/O
O1MODE | Digital I/O
O1TRIG | Digital I/O
O2 | Digital I/O
O2MODE | Digital I/O
O2TRIG | Digital I/O
OS1 | Digital I/O
OS2 | Digital I/O
OS3 | Digital I/O
OS4 | Digital I/O
OS5 | Digital I/O
SETVCT | Digital I/O
SLOTIO | Digital I/O
STATIO | Digital I/O
VCTAB | Digital I/O
ACTIVE | Drive Status
CLRHR | Drive Status
COLDSTART | Drive Status
ERRCODE * | Drive Status
FLTCNT | Drive Status
FLTHIST | Drive Status
LEDSTAT | Drive Status
NONBTB | Drive Status
OPTION | Drive Status
READY | Drive Status
REMOTE | Drive Status
STAT | Drive Status
STATCODE | Drive Status
STATCODE * | Drive Status
STATUS | Drive Status
TRJSTAT | Drive Status
CALCCOG | Feedback
CALCHP | Feedback
CALCRK | Feedback
CALCRP | Feedback
COGGING | Feedback
FBTYPE | Feedback
HDUMP | Feedback
HICOFFS | Feedback
HIFACT1 | Feedback
HISOFFS | Feedback
HSAVE | Feedback
MPHASE | Feedback
MRESBW | Feedback
MRESPOLES | Feedback
READNIMP | Feedback
RESOLVER | Feedback
RESPHASE | Feedback
RK | Feedback
ROFFS0 | Feedback
SMNUMBER | Feedback
VLO | Feedback
DNBAUD | Fieldbus
DPRILIMIT | Fieldbus
RXPDO1A | Fieldbus
RXPDO1B | Fieldbus
RXPDO2A | Fieldbus
RXPDO2B | Fieldbus
RXPDO3A | Fieldbus
RXPDO3B | Fieldbus
RXPDO4A | Fieldbus
RXPDO4B | Fieldbus
TXPDO1A | Fieldbus
TXPDO1B | Fieldbus
TXPDO2A | Fieldbus
TXPDO2B | Fieldbus
TXPDO3A | Fieldbus
TXPDO3B | Fieldbus
TXPDO4A | Fieldbus
TXPDO4B | Fieldbus
GEARI | Gearing
GEARMODE | Gearing
GEARO | Gearing
ROFFS2 | Gearing
CPHASE | Motor
ENCLINES | Motor
FLUXM | Motor
GF | Motor
GFTN | Motor
LDUMP | Motor
MBRAKE | Motor
MDBCNT | Motor
MDBGET | Motor
MDBLIST | Motor
MDBSET | Motor
MDUMP | Motor
MICONT | Motor
MIMR | Motor
MIPEAK | Motor
MJ | Motor
MKT | Motor
ML | Motor
MNAME | Motor
MNUMBER | Motor
MPOLES | Motor
MRS | Motor
MSERIALNO | Motor
MSPEED | Motor
MTANGLP | Motor
MTIME | Motor
MTR | Motor
MTYPE | Motor
MVANGLB | Motor
MVANGLF | Motor
MVANGLP | Motor
MVR | Motor
GET | Oscilloscope
J | Oscilloscope
RECDONE | Oscilloscope
RECING | Oscilloscope
RECOFF | Oscilloscope
RECORD | Oscilloscope
RECTRIG | Oscilloscope
S | Oscilloscope
STEP | Oscilloscope
T | Oscilloscope
RECRDY | Oszilloscope
GEARFILT | Position
O_C | Position Controler
ACCR | Position Controller
AUTOHOME | Position Controller
CLRORDER | Position Controller
CONTINUE | Position Controller
DECR | Position Controller
DOVRIDE | Position Controller
DREF | Position Controller
ERND | Position Controller
GP | Position Controller
GPFFT | Position Controller
GPFFV | Position Controller
GPRED | Position Controller
GPTN | Position Controller
IN2PM | Position Controller
INPOS | Position Controller
INPT | Position Controller
LATCH32 | Position Controller
LATCH32N | Position Controller
LATCHX32 | Position Controller
LATCHX32N | Position Controller
MH | Position Controller
MJOG | Position Controller
MOVE | Position Controller
MTMUX | Position Controller
MUNIT | Position Controller
NREF | Position Controller
NREFMT | Position Controller
O_ACC1 | Position Controller
O_DEC1 | Position Controller
O_FN | Position Controller
O_FT | Position Controller
O_P | Position Controller
O_V | Position Controller
OCOPY | Position Controller
OLIST | Position Controller
ORDER | Position Controller
OVRIDE | Position Controller
P1...P16 | Position Controller
PEINPOS | Position Controller
PEMAX | Position Controller
PGEARI | Position Controller
PGEARO | Position Controller
POSCNFG | Position Controller
POSRSTAT | Position Controller
PRBASE | Position Controller
PTARGET | Position Controller
PTBASE | Position Controller
PTEACH | Position Controller
PTMIN | Position Controller
PUNIT | Position Controller
PVMAXN | Position Controller
PVMAXP | Position Controller
REFLS | Position Controller
REFMODE | Position Controller
REFPOS | Position Controller
ROFFS | Position Controller
SETREF | Position Controller
SETROFFS | Position Controller
SRND | Position Controller
STOP | Position Controller
SWCNFG | Position Controller
SWE1 | Position Controller
SWE2 | Position Controller
UCOMP | Position Controller
VJOG | Position Controller
VREF | Position Controller
VREF0 | Position Controller
WPOS | Position Controller
WPOSE | Position Controller
WPOSP | Position Controller
WPOSX | Position Controller
EGEARI | Position Loop
EGEARO | Position Loop
ENCMODE | Position Output
ENCOUT | Position Output
ENCZERO | Position Output
RDP | Rack Drive Panel
RDPBIAS | Rack Drive Panel
RDPCLAMP | Rack Drive Panel
RDPINT | Rack Drive Panel
RDPKI | Rack Drive Panel
RDPKP | Rack Drive Panel
RDPON | Rack Drive Panel
SLEN | Sercos
ACC | Velocity Controller
DEC | Velocity Controller
DECDIS | Velocity Controller
DECSTOP | Velocity Controller
ESPEED | Velocity Controller
GV | Velocity Controller
GVTN | Velocity Controller
ISTFR | Velocity Controller
VEL0 | Velocity Controller
VLIMN | Velocity Controller
VLIMP | Velocity Controller
VMIX | Velocity Controller
VOSPD | Velocity Controller
VSTFR | Velocity Controller
VUNIT | Velocity Controller


ASCII English Index Object

MAXSDO | Object 0
EMRGTO | Object 0
GPRED | Object 0
ACC | Object 1
ACCR | Object 2
ACTFAULT | Object 3
ACTIVE | Object 4
ADDR | Object 5
AENA | Object 6
ANCNFG | Object 7
ANDB | Object 8
ANIN1 | Object 9
ANIN2 | Object 10
ANOFF1 | Object 11
ANOFF2 | Object 12
ANZERO1 | Object 15
ANZERO2 | Object 16
AVZ1 | Object 17
CALCHP | Object 18
CALCRK | Object 19
CALCRP | Object 20
CBAUD | Object 21
CLRFAULT | Object 24
CLRHR | Object 25
CLRORDER | Object 26
CONTINUE | Object 29
CTUNE | Object 30
CUPDATE | Object 31
DEC | Object 34
DECDIS | Object 35
DECR | Object 36
DECSTOP | Object 37
DICONT | Object 39
DIFVAR | Object 40
DIPEAK | Object 41
DIS | Object 43
DREF | Object 44
DR_TYPE | Object 46
DUMP | Object 47
EN | Object 48
ENCLINES | Object 51
ENCMODE | Object 52
ENCOUT | Object 53
ENCZERO | Object 55
EXTWD | Object 58
FBTYPE | Object 59
GEARI | Object 62
GEARMODE | Object 63
GEARO | Object 64
GET | Object 65
GP | Object 66
GPFFV | Object 69
GPTN | Object 70
GV | Object 72
GVTN | Object 77
HDUMP | Object 81
HICOFFS | Object 82
HIFACT1 | Object 83
HISOFFS | Object 84
HSAVE | Object 86
HVER | Object 87
I | Object 88
I2TLIM | Object 90
ICMD | Object 91
ID | Object 93
IN | Object 96
IN1 | Object 97
IN1MODE | Object 98
IN1TRIG | Object 99
IN2 | Object 100
IN2MODE | Object 101
IN2TRIG | Object 102
IN3 | Object 103
IN3MODE | Object 104
IN3TRIG | Object 105
IN4 | Object 106
IN4MODE | Object 107
IN4TRIG | Object 108
INPOS | Object 109
IPEAK | Object 110
IPEAKN | Object 111
IQ | Object 112
ISCALE1 | Object 113
ISCALE2 | Object 114
K | Object 115
KC | Object 116
KEYLOCK | Object 117
ML | Object 119
LATCH32 | Object 122
LATCH32N | Object 123
LATCHX32 | Object 124
LATCHX32N | Object 125
LED1 | Object 126
LED2 | Object 127
LED3 | Object 128
LEDSTAT | Object 129
LIST | Object 130
LOAD | Object 131
MAXTEMPE | Object 132
MAXTEMPH | Object 133
MAXTEMPM | Object 134
MBRAKE | Object 135
MDBCNT | Object 136
MDBGET | Object 137
MDBSET | Object 138
MDUMP | Object 139
MH | Object 141
MICONT | Object 142
MIPEAK | Object 143
MJOG | Object 145
MVANGLP | Object 146
MKT | Object 147
MLGC | Object 149
MLGD | Object 150
MLGP | Object 151
MLGQ | Object 152
MNUMBER | Object 153
MPHASE | Object 156
MPOLES | Object 157
MRESBW | Object 160
MRESPOLES | Object 161
MSG | Object 162
MSPEED | Object 163
MTANGLP | Object 165
MTYPE | Object 166
MVANGLB | Object 167
MVANGLF | Object 168
M_RESET | Object 169
NONBTB | Object 170
NREF | Object 173
O1 | Object 174
O1MODE | Object 175
O1TRIG | Object 176
O2 | Object 177
O2MODE | Object 178
O2TRIG | Object 179
OPMODE | Object 180
OPTION | Object 181
OVRIDE | Object 182
O_ACC1 | Object 183
O_C | Object 185
O_DEC1 | Object 186
O_FN | Object 188
O_FT | Object 189
O_P | Object 190
O_V | Object 191
PBAL | Object 192
PBALMAX | Object 193
PBALRES | Object 194
PE | Object 197
PEINPOS | Object 198
PEMAX | Object 199
PFB | Object 200
PFB0 | Object 201
PGEARI | Object 202
PGEARO | Object 203
PMODE | Object 205
PNOID | Object 206
POSCNFG | Object 207
PPOTYP | Object 208
PRBASE | Object 209
PRD | Object 210
PROMPT | Object 211
PSTATE | Object 212
PTBASE | Object 213
PTMIN | Object 214
PV | Object 215
PVMAXP | Object 216
PVMAXN | Object 217
READNIMP | Object 220
READY | Object 221
RECDONE | Object 222
RECING | Object 223
RECOFF | Object 224
RECRDY | Object 225
REFIP | Object 226
REFPOS | Object 227
REMOTE | Object 228
RESPHASE | Object 229
RK | Object 230
ROFFS | Object 231
RS232T | Object 232
RSTVAR | Object 233
S | Object 234
SAVE | Object 235
SERIALNO | Object 239
SETREF | Object 240
SETROFFS | Object 241
SLEN | Object 242
SLOTIO | Object 243
STAT | Object 251
STATIO | Object 252
STATUS | Object 253
STOP | Object 254
STOPMODE | Object 255
SWCNFG | Object 256
SWE1 | Object 260
SWE2 | Object 262
T | Object 270
TASK | Object 271
TEMPE | Object 272
TEMPH | Object 273
TEMPM | Object 274
TRJSTAT | Object 275
TRUN | Object 276
UVLTMODE | Object 279
V | Object 280
VBUS | Object 282
VBUSBAL | Object 283
VBUSMAX | Object 284
VBUSMIN | Object 285
VCMD | Object 286
VEL0 | Object 288
VJOG | Object 289
VLIMP | Object 290
VLIMN | Object 291
VMIX | Object 293
VOSPD | Object 295
VREF | Object 296
VSCALE1 | Object 297
VSCALE2 | Object 298
\ | Object 299
DILIM | Object 300
DENA | Object 301
IN2PM | Object 302
KTN | Object 303
INPT | Object 304
UCOMP | Object 305
COLDSTART | Object 306
SETVCT | Object 309
WPOS | Object 310
SRND | Object 311
ERND | Object 312
BCC | Object 314
REFMODE | Object 316
VLO | Object 317
WMASK | Object 318
WPOSE | Object 319
WPOSP | Object 320
WPOSX | Object 321
MOVE | Object 322
POSRSTAT | Object 323
P1...P16 | Object 324
PTARGET | Object 340
ACTRS232 | Object 341
ROFFS2 | Object 342
FW | Object 343
DPRILIMIT | Object 344
ACCUNIT | Object 345
VCOMM | Object 346
MTMUX | Object 347
ROFFS0 | Object 348
REFLS | Object 349
VUNIT | Object 351
PUNIT | Object 352
GF | Object 359
GFTN | Object 360
MIMR | Object 363
MTR | Object 364
MVR | Object 365
TBRAKE | Object 366
TBRAKE0 | Object 367
MSLBRAKE | Object 369
DRVCNFG | Object 370
DISDPR | Object 371
MUNIT | Object 372
ESPEED | Object 373
STAGECODE | Object 386
ICMDVLIM | Object 389
MRS | Object 390
FLUXM | Object 393
SMNUMBER | Object 405
VREF0 | Object 408
AN11NR | Object 409
AN11RANGE | Object 410
MSERIALNO | Object 419
ISTFR | Object 420
VSTFR | Object 421
DOVRIDE | Object 438
RDP | Object 439
RDPBIAS | Object 440
RDPCLAMP | Object 441
RDPINT | Object 442
RDPKI | Object 443
RDPKP | Object 444
RDPON | Object 445
INS0 | Object 446
INS1 | Object 447
INS2 | Object 448
INS3 | Object 449
INS4 | Object 450
INS5 | Object 451
INS6 | Object 452
INS7 | Object 453
INS8 | Object 454
OS1 | Object 455
OS2 | Object 456
OS3 | Object 457
OS4 | Object 458
OS5 | Object 459
LASTWMASK | Object 462
COGGING | Object 463
NREFMT | Object 466
PASSX | Object 468
PASS | Object 469
AUTOHOME | Object 471
PASSCNFG | Object 472
FLASH | Object 473


ASCII English INPOS

ASCII - Command | INPOS |
Syntax Transmit | INPOS |
Syntax Receive | INPOS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 356D (hex)
DIM | - | PROFIBUS PNU | 1709 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 109 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Status of In-Position Signal

Description

The INPOS command returns the status of the IN-Position bit of the status register (DRVSTAT).
As long as the difference between the last target position (motion task) and the actual position (PFB) is within the width of the preset In-Position window (PEINPOS), a 1 is signalled, otherwise a 0.

see also INPT


ASCII English INPT

ASCII - Command | INPT |
Syntax Transmit | INPT [Data] |
Syntax Receive | INPT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3630 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1904 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32000 | DPR | 304 (dec)
Default | 10 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | In-Position Delay

Description

The INPT command defines a delay time for the In-Position signal. At the start of a motion block, the In-Position signal is removed, and the monitoring of the In-Position window is only activated again after the end of this preset time. This function is especially important for positioning tasks within the In-Position window. In such a case, it ensures that the In-Position signal is always removed for a definite time.

See also INPOS


ASCII English INS0

ASCII - Command | INS0 |
Syntax Transmit | INS0 |
Syntax Receive | INS0 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36BE (hex)
DIM | - | PROFIBUS PNU | 2046 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 446 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A0 of the I/O Option Card

Description

INS0 is used to read input A0 (terminal 1) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS1

ASCII - Command | INS1 |
Syntax Transmit | INS1 |
Syntax Receive | INS1 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36BF (hex)
DIM | - | PROFIBUS PNU | 1647 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 447 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A1 of the I/O Option Card

Description

INS1 is used to read input A1 (terminal 2 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS2

ASCII - Command | INS2 |
Syntax Transmit | INS2 |
Syntax Receive | INS2 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C0 (hex)
DIM | - | PROFIBUS PNU | 1648 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 448 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A2 of the I/O Option Card

Description

INS2 is used to read input A2 (terminal 3 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS3

ASCII - Command | INS3 |
Syntax Transmit | INS3 |
Syntax Receive | INS3 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C1 (hex)
DIM | - | PROFIBUS PNU | 1649 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 449 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A3 of the I/O Option Card

Description

INS3 is used to read input A3 (terminal 4 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS4

ASCII - Command | INS4 |
Syntax Transmit | INS4 |
Syntax Receive | INS4 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C2 (hex)
DIM | - | PROFIBUS PNU | 1650 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 450 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A4 of the I/O Option Card

Description

INS4 is used to read input A4 (terminal 5 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS5

ASCII - Command | INS5 |
Syntax Transmit | INS5 |
Syntax Receive | INS5 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C3 (hex)
DIM | - | PROFIBUS PNU | 1651 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 451 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A5 of the I/O Option Card

Description

INS5 is used to read input A5 (terminal 6 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS6

ASCII - Command | INS6 |
Syntax Transmit | INS6 |
Syntax Receive | INS6 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C4 (hex)
DIM | - | PROFIBUS PNU | 1652 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 452 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A6 of the I/O Option Card

Description

INS6 is used to read input A6 (terminal 7 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS7

ASCII - Command | INS7 |
Syntax Transmit | INS7 |
Syntax Receive | INS7 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C5 (hex)
DIM | - | PROFIBUS PNU | 1653 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 453 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Input A7 of the I/O Option Card

Description

INS7 is used to read input A7 (terminal 8 of X11A) at the I/O option card. This input is normally used to select a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English INS8

ASCII - Command | INS8 |
Syntax Transmit | INS8 |
Syntax Receive | INS8 <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C6 (hex)
DIM | - | PROFIBUS PNU | 1654 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 454 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of FSTART_IO of the I/O Option Card

Description

INS8 is used to read input FSTART_IO (terminal 2 of X11B) at the I/O option card. This input is normally used to start a motion task, but can be reassigned for general purpose mode by setting IO11IN = 2.


ASCII English IPEAK

ASCII - Command | IPEAK |
Syntax Transmit | IPEAK [Data] |
Syntax Receive | IPEAK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 356E (hex)
DIM | Amperes | PROFIBUS PNU | 1710 (dec) IND = 0000xxxx (bin)
Range | 0.0 ... DIPEAK | DPR | 110 (dec)
Default | IMAX |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Application Peak Current

Description

IPEAK sets the peak rated current IPEAKP and IPEAKNof the application (RMS value). The value to be entered is limited to the lower of the peak rated current of the motor (MIPEAK) or amplifier (DIPEAK). If the IPEAK value is too low, the drive shows following errors and the peak torque is too low. If the IPEAK value is too high, the motor is endangered.


ASCII English IPEAKN

ASCII - Command | IPEAKN |
Syntax Transmit | IPEAKN [Data] |
Syntax Receive | IPEAKN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | A | PROFIBUS PNU | No
Range | 0.0 ... DIPEAK | DPR | No
Default | IMAX |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Negative Peak current Limit

Description

Negative motor peak rms current. Can be reduced to DICONT or MICONT in I2T fallback condition


ASCII English IPEAKP

ASCII - Command | IPEAKP |
Syntax Transmit | IPEAKP [Data] |
Syntax Receive | IPEAKP <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | A rms | PROFIBUS PNU | No
Range | 0 ... DIPEAK | DPR | No
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | + | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | positive motor peak rms current

Description

Positive motor peak rms current. Can be reduced to DICONT or MICONT in I2T fallback condition


ASCII English IQ

ASCII - Command | IQ |
Syntax Transmit | IQ |
Syntax Receive | IQ <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3570 (hex)
DIM | Amperes | PROFIBUS PNU | 1712 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 112 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Q-Component of Current Monitor

Description

The Q-axes component of the actual current value.


ASCII English ISCALE1

ASCII - Command | ISCALE1 |
Syntax Transmit | ISCALE1 [Data] |
Syntax Receive | ISCALE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3571 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1713 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 100.0 | DPR | 113 (dec)
Default | DIPEAK |
Opmode | 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Scaling of Analog Current Setpoint 1

Description

Defines the scaling for the analog setpoint input SW1 (if it is a current setpoint in OPMODE = 3). The current value that is set here corresponds to the maximum input voltage (10V).


ASCII English ISCALE2

ASCII - Command | ISCALE2 |
Syntax Transmit | ISCALE2 [Data] |
Syntax Receive | ISCALE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3572 (hex)
DIM | A/10Volts | PROFIBUS PNU | 1714 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 100.0 | DPR | 114 (dec)
Default | DIPEAK |
Opmode | 3 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | Scaling of Analog Current Setpoint 2

Description

Defines the scaling for the analog setpoint input SW2 (if it is a current setpoint in OPMODE = 3). The current value that is set here corresponds to the maximum input voltage (10V).


ASCII English ISTFR

ASCII - Command | ISTFR |
Syntax Transmit | ISTFR [Data] |
Syntax Receive | ISTFR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36A4 (hex)
DIM | A | PROFIBUS PNU | 2020 (dec) IND = 0000xxxx (bin)
Range | 0 .. IPEAK | DPR | 420 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Data Type Bus/DPR | Integer32
Drive State | Disabled | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Velocity dependant Friction Compensation

Description

IN PREPARATION !

The two objects ISTFR and VSTFR define the friction compensation curve. ISTFR enables the function if it is not "0". The friction compensation changes the additional current from -ISTFR to ISTFR if the velocity changes from -VSTFR to VSTFR.
It is a configuration parameter if it is changed from "0" to another value, other changes can be don online.

V=0 -> IFRICT = 0
V= 50% of VSTFR -> IFRICT = 50% of ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% of VSTFR -> IFRICT = -50% of ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII English J

ASCII - Command | J |
Syntax Transmit | J [Data] |
Syntax Receive | J <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Float | CANBus Object Number | No
DIM | rpm (velocity) / Milliseconds (Time) | PROFIBUS PNU | No
Range | -15000.0 .. 15000.0 (=velocity),long int (Time) | DPR | No
Default | - |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Service Function: Constant Velocity

Description

The command “J <n> <t>” can be used to define a constant velocity <n> (in rpm) for a defined time <t> (in msec). If the <t> entry is missing, the drive runs continuously.


ASCII English K

ASCII - Command | K |
Syntax Transmit | K |
Syntax Receive | K | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3573 (hex)
DIM | - | PROFIBUS PNU | 1715 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 115 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Kill (=Disable)

Description

The K (Kill) command is a short form command of the “DIS” command.


ASCII English KC

ASCII - Command | KC |
Syntax Transmit | KC [Data] |
Syntax Receive | KC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3574 (hex)
DIM | - | PROFIBUS PNU | 1716 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 1.0 | DPR | 116 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | I-Controller Prediction Constant

Description

KC is a tuning variable of the current loop. For compensation of time delay a predicted current value can be used in addition to the measured motor current. KC 1 switches the current prediction on, KC 0.5 sets it to 50% and KC 0 switches it off. Disabling the current prediction can cause an unstable current loop.


ASCII English KEYLOCK

ASCII - Command | KEYLOCK |
Syntax Transmit | KEYLOCK [Data] |
Syntax Receive | KEYLOCK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3575 (hex)
DIM | - | PROFIBUS PNU | 1717 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 117 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Locks the push buttons

Description

If KEYLOCK=1, operation of the amplifier from the keys on the front panel is inhibited.
The display functions of the instrument (error messages, warnings) remain active.


ASCII English KTN

ASCII - Command | KTN |
Syntax Transmit | KTN [Data] |
Syntax Receive | KTN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 362F (hex)
DIM | Milliseconds | PROFIBUS PNU | 1903 (dec) IND = 0000xxxx (bin)
Range | 0.2 .. 2.0 | DPR | 303 (dec)
Default | 0.6 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Current Controller Integral-Action Time

Description

The integral-action time (integration time constant) of the current control loop.


ASCII English LASTWMASK

ASCII - Command | LASTWMASK |
Syntax Transmit | LASTWMASK |
Syntax Receive | LASTWMASK <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36CE (hex)
DIM | - | PROFIBUS PNU | 1662 (dec) IND = 0001xxxx (bin)
Range | long int | DPR | 462 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Fault history of WMASK

Description

WMASK gives the possibility to create a mask to change warnings to errors. If the F24 occurs, LASTWMASK displays the warnings that caused the error.


ASCII English LATCH32

ASCII - Command | LATCH32 |
Syntax Transmit | LATCH32 |
Syntax Receive | LATCH32 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 357A (hex)
DIM | - | PROFIBUS PNU | 1722 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 122 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Latched 32-bit Position (positive edge)

Description

IN PREPARATION !

The LATCH32 command returns the position where latching was performed by the last positive (rising) edge on digital input 2 (IN2MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH16 command should be used.
The commands LATCH16 and LATCH32 have the effect of erasing the status bit 20 “positive latch made” in the status register DRVSTAT.


ASCII English LATCH32N

ASCII - Command | LATCH32N |
Syntax Transmit | LATCH32N |
Syntax Receive | LATCH32N <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 357B (hex)
DIM | - | PROFIBUS PNU | 1723 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 123 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Latched 32-bit Position (negative edge)

Description

IN PREPARATION !

The LATCH32N command returns the position where latching was performed by the last negative (falling) edge on digital input 2 (IN2MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCH16N command should be used.
The commands LATCH16N and LATCH32N have the effect of erasing the status bit 23 “negative latch made” in the status register TRJSTAT.


ASCII English LATCHX32

ASCII - Command | LATCHX32 |
Syntax Transmit | LATCHX32 |
Syntax Receive | LATCHX32 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 357C (hex)
DIM | - | PROFIBUS PNU | 1724 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 124 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 2.07 |
Configuration | No | Last Change of this Object | 1.7
Function Group | Position Controller | EEPROM | No
Short Description | Latched External 32-bit Position (positive edge)

Description

IN PREPARATION !

If read-in from an external encoder position is activated (EXTPOS=1,2), then this position will be stored automatically when a latch event (IN1MODE=26) occurs.
The LATCHX32 command returns the position where latching was performed by the last positive (rising) edge on digital input 1 (IN1MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCHX16 command should be used.
The commands LATCHX16 and LATCHX32 have the effect of erasing the status bit 25 “positive latch made” in the status register TRJSTAT.


ASCII English LATCHX32N

ASCII - Command | LATCHX32N |
Syntax Transmit | LATCHX32N |
Syntax Receive | LATCHX32N <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 357D (hex)
DIM | - | PROFIBUS PNU | 1725 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 125 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 2.07 |
Configuration | No | Last Change of this Object | 1.7
Function Group | Position Controller | EEPROM | No
Short Description | Latched External 32-bit Position (negative edge)

Description

IN PREPARATION !

If read-in from an external encoder position is activated (EXTPOS=1,2), then this position will be stored automatically when a latch event (IN1MODE=26) occurs.
The LATCHX32N command returns the position where latching was performed by the last negative (falling) edge on digital input 1 (IN1MODE=26). The position value is absolute within 4096 turns, and is given out in microns (taking account of the position control loop resolution PGEARI/PGEARO). To obtain an absolute position within one turn, the LATCHX16N command should be used.
The commands LATCHX16N and LATCHX32N have the effect of erasing the status bit 26 “negative latch made” in the status register TRJSTAT.


ASCII English LDUMP

ASCII - Command | LDUMP |
Syntax Transmit | LDUMP [data] |
Syntax Receive | LDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Parameter Output of Motor Data

Description

The command LDUMP <name> can be used to output the parameters for the motor data set <name> from the internal database. The <name> that is entered must be a valid motor designation from the motor database (see MDBLIST). If the <name> parameter is not entered, the motor parameters that are loaded at present will be displayed.


ASCII English LED1

ASCII - Command | LED1 |
Syntax Transmit | LED1 [Data] |
Syntax Receive | LED1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 357E (hex)
DIM | - | PROFIBUS PNU | 1726 (dec) IND = 0000xxxx (bin)
Range | 0 .. 127 | DPR | 126 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | -
Short Description | State of Display 1 Segment

Description

IN PREPARATION !

The command LED1 returns the present status (7-segment code) of the segment in LED1 (left).

Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED1 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LED2

ASCII - Command | LED2 |
Syntax Transmit | LED2 [Data] |
Syntax Receive | LED2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 357F (hex)
DIM | - | PROFIBUS PNU | 1727 (dec) IND = 0000xxxx (bin)
Range | 0 .. 127 | DPR | 127 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | -
Short Description | State of Display 2 Segment

Description

IN PREPARATION !

The command LED2 returns the present status (7-segment code) of the segment in LED2 (center).
Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED2 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LED3

ASCII - Command | LED3 |
Syntax Transmit | LED3 [Data] |
Syntax Receive | LED3 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3580 (hex)
DIM | - | PROFIBUS PNU | 1728 (dec) IND = 0000xxxx (bin)
Range | 0 ..127 | DPR | 128 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | -
Short Description | State of Display 3 Segment

Description

IN PREPARATION !

The command LED3 returns the present status (7-segment code) of the segment in LED2 (right).
Bit-assignment for a 7-segment display:

Bit 0 (0x01, 1) segment A (top)
Bit 1 (0x02, 2) segment B (top right)
Bit 2 (0x04, 4) segment C (bottom right)
Bit 3 (0x08, 8) segment D (bottom)
Bit 4 (0x10, 16) segment E (bottom left)
Bit 5 (0x20, 32) segment F (top left)
Bit 6 (0x40, 64) segment G (center)

A write action LED3 <code> produces the defined code on the display.
This only makes sense if the internal display output has been switched off (LEDSTAT 0).
It is not possible to output a decimal point.


ASCII English LEDSTAT

ASCII - Command | LEDSTAT |
Syntax Transmit | LEDSTAT [Data] |
Syntax Receive | LEDSTAT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3581 (hex)
DIM | - | PROFIBUS PNU | 1729 (dec) IND = 0000xxxx (bin)
Range | 0 .. 16 | DPR | 129 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Display page

Description

IN PREPARATION !

The variable LEDSTAT shows the number of the present “display page”.
Altering the LEDSTAT variable makes it possible the change the display via the serial interface.
The assignments are as follows:
LEDSTAT=0 Display is switched off
LEDSTAT=1 Status display
LEDSTAT=2 Fieldbus address
LEDSTAT=3 CAN Baud rate
LEDSTAT=4 Parameter S01 (Kp velocity control loop)
LEDSTAT=5 Parameter S02 (Tn velocity control loop)
LEDSTAT=6 Parameter S03 (setpoint offset)
LEDSTAT=7 Parameter S04 (motor number)
LEDSTAT=8 Parameter S05 (encoder selection)
LEDSTAT=9 Parameter S06 (brake selection)
LEDSTAT=10 Parameter S07 (Multidrive selection, from software 3.00)
LEDSTAT=11 Load data from the EEPROM
LEDSTAT=12 Save data in the EEPROM
LEDSTAT=13 Set default values (from software 3.00)
LEDSTAT=14 New configuration of the amplifier (M_RESET, from software 3.00)
LEDSTAT=15 Error messages
LEDSTAT=16 Serial number


ASCII English LIST

ASCII - Command | LIST |
Syntax Transmit | LIST |
Syntax Receive | LIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | 3582 (hex)
DIM | - | PROFIBUS PNU | 1730 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 130 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | List All ASCII Commands

Description

All those commands are listed which can be used for to the present motor/amplifier configuration. ASCII commands that require specific hardware (e.g. Hiperface/Endat, Profibus,Sercos) will only be displayed if the corresponding hardware has been recognized correctly.


ASCII English LOAD

ASCII - Command | LOAD |
Syntax Transmit | LOAD |
Syntax Receive | LOAD | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3583 (hex)
DIM | - | PROFIBUS PNU | 1731 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 131 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Load parameters from serial EEPROM

Description

The LOAD command loads the parameters from the serial EEPROM. All parameter changes that have been made since the last SAVE command (save in the serial EEPROM) will be lost.


LOGO

English ASCII Object Reference

Sprachumschaltung nach Deutsch

sorted by


ASCII English M

ASCII - Command | M | For Manufacturer Use only
Syntax Transmit | M [Data] |
Syntax Receive | M <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Read/write Macro Variable

Description

The M command can be used to access any internal macro variable.
Macro variables are variables which can be used by the macro routines. They are called by name within a macro routine. The complete variable information (name, address) is managed in the form of a table. There are two types of macro variable.
1. System variables – these variables are determined by the firmware, and are fixed. Both the names and the addresses for such variables are constant within a given firmware version. The table with the data for the variables is within the programming area, so that the system variables can be accessed at any time.
2. User variables – these variables are set up in the macro routines during the initialization phase of the amplifier. The availability of a specific variable, or its physical address, depends on the amplifier configuration. The table with the information for the variables is set up in the RAM, and is normally only required during the compilation of the macro programs (initialization phase). After the initialization has been concluded, the table is removed from the memory. In this case, it is not possible to access the user variables through the M command.
If the parameter setting MSG=2 is found when the amplifier is switched on, then the table for the user variables is kept in the memory. In this case, it will also be possible to access the user variables through the M command.
The M command can be used in one of three forms:
1. “M” – a list of all the system and user variables is generated

2. “M name” – an information line is generated for the variable <name>, in the following form:
“name [TYPE] address FORMAT=value”
The individual elements are interpreted as follows:
name = name of the macro variable
TYPE = variable type (SYSTEM or USER)
address = physical address of the variable (hexadecimal format)
FORMAT = variable type (BYTE,WORD,LONG,STRING), the suffix FAST means that the variable is stored in the internal (fast) RAM
Value = variable contents (in hexadecimal format, or as ASCII string, depending on FORMAT)

3. “M name value” – the number “value” is entered in the variable “name”
The entry for “value” must be made as a decimal number. If the character sequence “0x” is added as a prefix, the number can be entered in hexadecimal format.


ASCII English M_125

ASCII - Command | M_125 | For Manufacturer Use only
Syntax Transmit | M_125 |
Syntax Receive | M_125 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 125 microsecond Macro Program

Description

The source code of the 125 microsecond macro function (current control loop) is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_250

ASCII - Command | M_250 | For Manufacturer Use only
Syntax Transmit | M_250 |
Syntax Receive | M_250 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 250 microsecond Macro Program

Description

The source code of the 250 microsecond macro function (current control loop) is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_250p

ASCII - Command | M_250p | For Manufacturer Use only
Syntax Transmit | M_250p |
Syntax Receive | M_250p <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 250 microsecond Macro Program

Description

The source code of the 250 microsecond macro function (current control loop) is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_1000

ASCII - Command | M_1000 | For Manufacturer Use only
Syntax Transmit | M_1000 |
Syntax Receive | M_1000 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 1 msec Macro Program

Description

The source code of the 1 msec macro function is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_1600

ASCII - Command | M_1600 | For Manufacturer Use only
Syntax Transmit | M_1600 |
Syntax Receive | M_1600 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 16 msec Macro Program

Description

The source code of the 16 msec macro function is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_4000

ASCII - Command | M_4000 | For Manufacturer Use only
Syntax Transmit | M_4000 |
Syntax Receive | M_4000 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display 4 msec Macro Program

Description

The source code of the 4 msec macro function is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_DISABLE

ASCII - Command | M_DISABLE | For Manufacturer Use only
Syntax Transmit | M_DISABLE |
Syntax Receive | M_DISABLE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display the “Disable” Macro Program

Description

The source code of the macro function “Disable” is displayed on the screen. It is only run once, when the amplifier is disabled. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_ENABLE

ASCII - Command | M_ENABLE | For Manufacturer Use only
Syntax Transmit | M_ENABLE |
Syntax Receive | M_ENABLE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | -
Short Description | Display the “Enable” Macro Program

Description

The source code of the macro function “Enable” is displayed on the screen. It is only run once, when the amplifier is enabled. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_INIT

ASCII - Command | M_INIT | For Manufacturer Use only
Syntax Transmit | M_INIT |
Syntax Receive | M_INIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display the “Init” Macro Program

Description

The source code of the macro function “Initialization” is displayed on the screen. It is only run once, when the amplifier is started up. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_IRQ

ASCII - Command | M_IRQ | For Manufacturer Use only
Syntax Transmit | M_IRQ |
Syntax Receive | M_IRQ <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display the “Interrupt” Macro Program

Description

The source code of the macro function “Interrupt” is displayed on the screen. It is run when a macro-interrupt is called. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_RESET

ASCII - Command | M_RESET | For Manufacturer Use only
Syntax Transmit | M_RESET |
Syntax Receive | M_RESET | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 35A9 (hex)
DIM | - | PROFIBUS PNU | 1769 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 169 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disable | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Recompile Macro Programs

Description

All macro programs are compiled and started when the amplifier is switched on. The compilation of the macro programs is managed by configuration variables. The values for these configuration variables must be fixed before the compilation procedure is started. If the value of a configuration variable is altered at a later time, this change will only take effect with the next compilation of the macro programs. This means, that after changing a configuration variable, this change should first be stored in the EEPROM (see SAVE command) and the amplifier should then be switched off and on again.
The M_RESET command offers an alternative. This command is used to force a new compilation of the macro programs, without having to switch the amplifier off and on again. Since this function, unlike that performed during the initialization phase, is carried out while the interrupts are enabled, it takes longer to complete (about 5 min).


ASCII English M_SMACRO

ASCII - Command | M_SMACRO | For Manufacturer Use only
Syntax Transmit | M_SMACRO [*] |
Syntax Receive | M_SMACRO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display System Macros

Description

A list of all the available system macros is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.
A line on the screen has the following format: NAME (parameter) info
NAME - name of the macro
(parameter) - transfer parameter for macro
info - short description of macro

The command M_SMACRO * generates an additional line for each macro, in which the formats for the transfer parameters are shown. The abbreviations are as follows:
f - fast: the parameter is a variable that must be held in the fast processor RAM.
G - global: the parameter is a variable, to be held in fast or slow RAM
v - variable: the parameter is a variable
c- constant: the parameter is a constant (number)
b - byte: 8-bit parameter
w - word: 16-bit parameter
l - long: 32-bit parameter


ASCII English M_TASK

ASCII - Command | M_TASK | For Manufacturer Use only
Syntax Transmit | M_TASK |
Syntax Receive | M_TASK <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display the Main Macro Program

Description

The source code of the main macro program is displayed on the screen. This program section is always run if no other routine is being performed (idle). The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.


ASCII English M_UMACRO

ASCII - Command | M_UMACRO | For Manufacturer Use only
Syntax Transmit | M_UMACRO [*] |
Syntax Receive | M_UMACRO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Display User Macros

Description

A list of all the available user macros is displayed on the screen. The setting PROMPT=2 makes the display appear page-by-page. Pressing a key steps the display on to show the next side, <ESC> cancels the output to the screen.
The output format can be seen in the M_SMACRO description.

Note:
Since only SYSTEM macros are used at present, an empty user macro list will be output.


ASCII English MAXSDO

ASCII - Command | MAXSDO |
Syntax Transmit | MAXSDO |
Syntax Receive | MAXSDO <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3500 (hex)
DIM | - | PROFIBUS PNU | 1600 (dec) IND = 0000xxxx (bin)
Range | int | DPR | 0 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | -
Short Description | Number of Objects of the Parameter Channel

Description

The command MAXSDO gives the number of objects of the parameter channel.


ASCII English MAXTEMPE

ASCII - Command | MAXTEMPE |
Syntax Transmit | MAXTEMPE [Data] |
Syntax Receive | MAXTEMPE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3584 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1732 (dec) IND = 0000xxxx (bin)
Range | 10 .. 80 | DPR | 132 (dec)
Default | 70 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Ambient Temperature Switch off Threshold

Description

The ambient temperature value for switching off. If the drive temperature (as given by TEMPE) exceeds this value, the drive faults.


ASCII English MAXTEMPH

ASCII - Command | MAXTEMPH |
Syntax Transmit | MAXTEMPH [Data] |
Syntax Receive | MAXTEMPH <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3585 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1733 (dec) IND = 0000xxxx (bin)
Range | 20 .. 85 (90 ;SR640,SR670) | DPR | 133 (dec)
Default | 80 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Heat Sink Temperature Switch off Threshold

Description

The heat sink temperature for switching off. If the heat sink temperature (as given by TEMPH) exceeds this value, the drive faults.


ASCII English MAXTEMPM

ASCII - Command | MAXTEMPM |
Syntax Transmit | MAXTEMPM [Data] |
Syntax Receive | MAXTEMPM <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3586 (hex)
DIM | Ohm (KOhm) | PROFIBUS PNU | 1734 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 6000.0 | DPR | 134 (dec)
Default | 291 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Motor Temperature Switch off Threshold

Description

The motor temperature for switching off (defined by the resistance in kohms).

Entry in kilohms up to 1.5 (1.5 corresponds to about 1500 ohms in reality).


ASCII English MBRAKE

ASCII - Command | MBRAKE |
Syntax Transmit | MBRAKE [Data] |
Syntax Receive | MBRAKE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3587 (hex)
DIM | - | PROFIBUS PNU | 1735 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 135 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Select Motor Holding Brake

Description

MBRAKE enables the brake function for a 24V holding brake in the motor directly from the servo amplifier.

MBRAKE = 0 Brake function is disabled
MBRAKE = 1 Brake function is enabled. The output at the BRAKE terminal is 24V if the ENABLE signal is present (brake off) and 0V if the ENABLE signal is missing (brake activated).
MBRAKE = 2 If the wake&shake mode is activated (FBTYPE = 7 or 8) the holding brake is deactivated after the wake&shake mode .


ASCII English MDBCNT

ASCII - Command | MDBCNT |
Syntax Transmit | MDBCNT |
Syntax Receive | MDBCNT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3588 (hex)
DIM | - | PROFIBUS PNU | 1736 (dec) IND = 0000xxxx (bin)
Range | 1 .. 127 | DPR | 136 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Number of Motor Data Sets

Description

MDBCNT returns the number of motor data sets that can be loaded for the present combination of output stage + feedback. A change of the feedback setting FBTYPE is used, for instance, to ensure that only the data sets for resolver motors or EnDat motors are used.


ASCII English MDBGET

ASCII - Command | MDBGET |
Syntax Transmit | MDBGET |
Syntax Receive | MDBGET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | 3589 (hex)
DIM | - | PROFIBUS PNU | 1737 (dec) IND = 0000xxxx (bin)
Range | 1 .. MDBCNT | DPR | 137 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Get Actual Motor Data Set

Description

The MDBGET command generates an information line (directory entry) for the latest motor data set that was selected with the MDBSET command. The information line consists of the following elements:
data set number, motor name, motor number, motor family
The individual elements are interpreted as follows:
Data set number: the number for the data set within the motor database. This number can be used to address a motor data set with the MDBSET command. This number is increased automatically at every MDBGET call.
Motor name: a symbolic motor designation (max. length 12 characters).
Motor number: a number that can be used to uniquely identify a particular motor. This number is used to load a data set from the motor database with the MNUMBER command.
Motor family: an additional designation (for internal use only).

The group of commands MDBCNT,MDBSET,MDBGET can be used by an external control system, to read out the contents of the motor database. The procedure is as follows:
1. Read out the number of available data sets, using the MDBCNT command.
2. Set the data set pointer to the first data set, using the MDBSET 1 command.
3. Read out the first directory entry, using the MDBGET command.
4. Repeat step 3 until the number of available data sets (MDBCNT) has been read.

The MDBLIST command offers an alternative. This command can be used to display the complete list.


ASCII English MDBLIST

ASCII - Command | MDBLIST |
Syntax Transmit | MDBLIST [*] |
Syntax Receive | MDBLIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | No
Short Description | List of Motor Data Sets

Description

The MDBLIST command returns the list of contents for the motor database (for the present combination of output stage + feedback). One motor database entry is displayed per line on the screen, in the following format:
motor name, motor number, motor family, amplifier designation

The individual elements are interpreted as follows:
Motor name: a symbolic motor designation (max. length 12 characters).
Motor number: a number that can be used to uniquely identify a particular motor. This number is used to load a data set from the motor database with the MNUMBER command.
Motor family: an additional designation (for internal use only).

If PROMPT 2 is set, a formatted output appears, which is especially suitable for terminal display.

The MDBLIST * command can be used to display the complete list of contents for the motor database. The difference to the output generated by MDBLIST is that the contents also include motor data sets that are not suitable for the present combination of output stage and feedback. These data sets will be displayed, but they cannot be loaded.
Compared with the MDBLIST output, the MDBLIST * output has been enlarged by the columns “Amplifier designation” and “Feedback”. These designations can be used to find out for which output stage or FBTYPE setting this data set was created.
Amplifier designation 6xx, where xx = current rating
Feedback: 0=Resolver, 2=Hiperface, 4=Endat


ASCII English MDBSET

ASCII - Command | MDBSET |
Syntax Transmit | MDBSET [Data] |
Syntax Receive | MDBSET <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 358A (hex)
DIM | - | PROFIBUS PNU | 1738 (dec) IND = 0000xxxx (bin)
Range | 1 .. MDBCNT | DPR | 138 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Set Actual Motor Data Set

Description

The MDBSET command can be used to address a specific data set from the motor database. The subsequent MDBGET command provides the directory entry for the selected motor data set (see MDBGET description).


ASCII English MDUMP

ASCII - Command | MDUMP |
Syntax Transmit | MDUMP |
Syntax Receive | MDUMP <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | 358B (hex)
DIM | - | PROFIBUS PNU | 1739 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 139 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | -
Short Description | Display Present Motor Parameters

Description

Displays the currently valid motor parameters.


ASCII English MH

ASCII - Command | MH |
Syntax Transmit | MH |
Syntax Receive | MH | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 358D (hex)
DIM | - | PROFIBUS PNU | 1741 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 141 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Start Homing

Description

The MH (move home) command is used to start a homing movement (reference traverse) via the serial interface. Homing type, direction and speed are taken from the NREF, DREF and VREF parameters.
See also SETREF especially for OPMODE 1...6.


ASCII English MI2T

ASCII - Command | MI2T |
Syntax Transmit | MI2T [Data] |
Syntax Receive | MI2T <Data> | Available in |
Type | ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | No
DIM | % | PROFIBUS PNU | No
Range | 0 ... 100 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group |  | EEPROM | No
Short Description | Motor I2T load

Description

This variable returns the average current as a percentage of the continuous current (see MICONT). The average current is filtered with the time constant MTIME.


ASCII English MICONT

ASCII - Command | MICONT |
Syntax Transmit | MICONT [Data] |
Syntax Receive | MICONT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 358E (hex)
DIM | Amperes | PROFIBUS PNU | 1742 (dec) IND = 0000xxxx (bin)
Range | 10% of DICONT, .. 2* DICONT | DPR | 142 (dec)
Default | DICONT |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor Continuous Current Rating

Description

This parameter limits the nominal current of the amplifier, depending on the maximum continuous current rating of the motor.


ASCII English MIMR

ASCII - Command | MIMR |
Syntax Transmit | MIMR [Data] |
Syntax Receive | MIMR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 366B (hex)
DIM | A | PROFIBUS PNU | 1963 (dec) IND = 0000xxxx (bin)
Range | (0.0 ... 0.8) * ICONT | DPR | 363 (dec)
Default | 0.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Magnetizing Current (Induction Motor)

Description

IN PREPARATION !

This command is only for the induction motor mode (MTYPE = 3).
The MIMR defines the magnetizing current of induction motors, which is normally set in the range of 40%~50% of the rated current of the induction motor.
The magnetizing current maintains constant under the rated velocity. If the motor runs over the rated velocity, the magnetizing current will be decreased according to the rotor mechanical velocity.
This value will be also limited between 10% and 80% of the rated current.

For sensorless drive of PM motor (MTYPE=2, FBTYPE=10), this command determines the starting current. In the low velocity operation range, an injecting current controls the PM motor starting and operation.


ASCII English MIPEAK

ASCII - Command | MIPEAK |
Syntax Transmit | MIPEAK [Data] |
Syntax Receive | MIPEAK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 358F (hex)
DIM | Amperes | PROFIBUS PNU | 1743 (dec) IND = 0000xxxx (bin)
Range | 10% of DIPEAK, .. 2*DIPEAK | DPR | 143 (dec)
Default | DIPEAK |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor Peak Current Rating

Description

MIPEAK limits the IPEAK setting of the amplifier, depending on the maximum peak current rating of the motor. The peak current should not exceed 4 times the rated current (MICONT) of the motor. The actual value is also determined by the peak current (DIPEAK) of the servo amplifier used (defines the maximum value for the entry of IPEAK in the current controller).


ASCII English MJ

ASCII - Command | MJ |
Syntax Transmit | MJ [Data] |
Syntax Receive | MJ <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | kgcm^2 | PROFIBUS PNU | No
Range | 0.01 ... 3000 | DPR | No
Default | 3 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor inertia

Description

Motor inertia


ASCII English MJOG

ASCII - Command | MJOG |
Syntax Transmit | MJOG |
Syntax Receive | MJOG | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 3591 (hex)
DIM | - | PROFIBUS PNU | 1745 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 145 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Start Jog Mode

Description

MJOG starts the jog mode via the serial interface. The velocity in the jog mode is taken from VJOG (with ± sign). Jog mode is defined as a continuous motion at a constant velocity. This type of operation is started without a reference point being set (without homing). The hardware limit switches are monitored. Software limit switches are only monitored if a reference point is set (the drive has been homed). Acceleration and deceleration ramps are taken from the settings for homing (see ACCR, DECR, and VJOG).


ASCII English MKT

ASCII - Command | MKT | For Manufacturer Use only
Syntax Transmit | MKT [Data] |
Syntax Receive | MKT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3593 (hex)
DIM | - | PROFIBUS PNU | 1747 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 10.0 | DPR | 147 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor KT

Description

The torque constant of the motor in Nm/A.

This parameter is used for sensorless control. The value can be online checked according to the following equation:

Kt = 60 * SQRT (3) * Ui / ( 2 * PI * n)

Ui induced voltage of the motor
n actual rotor velocity


ASCII English ML

ASCII - Command | ML |
Syntax Transmit | L [Data] |
Syntax Receive | ML <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3577 (hex)
DIM | mH | PROFIBUS PNU | 1719 (dec) IND = 0000xxxx (bin)
Range | 0 .. 100 | DPR | 119 (dec)
Default | 10 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Stator Inductance of the Motor

Description

The parameter describes the stator inductance between phase and phase in mH.


ASCII English MLGC

ASCII - Command | MLGC |
Syntax Transmit | MLGC [Data] |
Syntax Receive | MLGC <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3595 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1749 (dec) IND = 0000xxxx (bin)
Range | 0.2 .. 1.0 | DPR | 149 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at rated current)

Description

The current control loop includes an adaptive alteration of the gain that depends on the current. The MLGC parameter defines the relative gain referred to MLGQ for continuous current.

MLGC = 0.8 means that the gain of the current control loop for continuous current is 80% of MLGQ. A linear interpolation is made for the gain from current = 0 up to current = MICONT.


ASCII English MLGD

ASCII - Command | MLGD |
Syntax Transmit | MLGD [Data] |
Syntax Receive | MLGD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3596 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1750 (dec) IND = 0000xxxx (bin)
Range | 0.4 .. 1.0 | DPR | 150 (dec)
Default | 0.7 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Adaptive Gain for Current Control loop, D-component

Description

The D-component of the current control loop (field component). The MLGD parameter defines the relative gain referred to MLGQ.

MLGC = 0.6 means that the gain of the current control loop D-component is 60% of MLGQ.


ASCII English MLGP

ASCII - Command | MLGP |
Syntax Transmit | MLGP [Data] |
Syntax Receive | MLGP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3597 (hex)
DIM | ratet to MLGQ | PROFIBUS PNU | 1751 (dec) IND = 0000xxxx (bin)
Range | 0.1 .. 1.0 | DPR | 151 (dec)
Default | 0.4 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Current Control loop Adaptive Gain (Q-component at peak current)

Description

The current control loop includes an adaptive alteration of the gain that depends on the current. The MLGP parameter defines the relative gain referred to MLGQ for peak current.

MLGP = 0.6 means that the gain of the current control loop for peak current is 60% of MLGQ. A linear interpolation is made for the gain from current = MICONT up to current = MIPEAK.


ASCII English MLGQ

ASCII - Command | MLGQ |
Syntax Transmit | MLGQ [Data] |
Syntax Receive | MLGQ <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3598 (hex)
DIM | - | PROFIBUS PNU | 1752 (dec) IND = 0000xxxx (bin)
Range | 0.01 .. 15.0 | DPR | 152 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Absolute Gain of Current Control loop

Description

MLGQ gives the proportional (ac) gain of the current control loop. This also affects MLGC, MLGP and MLGD KTN.Compared with the SR 600 the dimension has changed to V/A.The calculation from a SR600 gain is depending of the drive rating: MLGQ[SR300] = MLGQ[SR600] * 480 V / DIPEAK[in A].
Using the SR 601 DIPEAK is 3A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 3A = 160 V/A
Using the SR 603 DIPEAK is 6A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 6A = 80 V/A
Using the SR 606 DIPEAK is 13A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 12A = 40 V/A
Using the SR 610 DIPEAK is 20A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 20A = 24 V/A
Using the SR 610/30 / 614 / 620 DIPEAK is 40A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 40A = 12 V/A
Using the SR 640 DIPEAK is 80A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 80A = 6 V/A
Using the SR 670 DIPEAK is 160A: MLGQ[SR600] =1 -> MLGQ[SR300] = 1 * 480V / 160A = 3 V/A
Using the SR 403 DIPEAK is 9A: MLGQ[SR400] =1 -> MLGQ[SR300] = 1 * 480V / 9A = 53 V/A
Using the SR 406 DIPEAK is 12A: MLGQ[SR400] =1 -> MLGQ[SR300] = 1 * 480V / 12A = 40 V/A
An estimated value for MLGQ is 7.5 * L[in H]Driving a 10 mH Motor MLGQ will be round 0.075 V/A


ASCII English MNAME

ASCII - Command | MNAME |
Syntax Transmit | MNAME [Data] |
Syntax Receive | MNAME <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | max 12 ASCII Characters | DPR | No
Default | Blanks |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor Name

Description

The MNAME parameter is directly related to the motor number MNUMBER.
When a motor data set is loaded from the motor database (MNUMBER command), the motor designation MNAME is also transferred. If a customer-specific motor designation is to be defined, then this can be done with the MNAME command.
When the motor name is altered, the motor number (MNUMBER) is set to 0, to indicate a customer-specific motor data set.


ASCII English MNUMBER

ASCII - Command | MNUMBER |
Syntax Transmit | MNUMBER [Data] |
Syntax Receive | MNUMBER <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3599 (hex)
DIM | - | PROFIBUS PNU | 1753 (dec) IND = 0000xxxx (bin)
Range | int | DPR | 153 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor Number

Description

The command “MNUMBER nr” is used to load a motor data set with the number “nr” from the motor database. If MNUMBER 0 is entered, then no data set will be loaded, but the variable MNUMBER will simply be set to 0. This setting indicates a customer-specific motor data set.


ASCII English MOVE

ASCII - Command | MOVE |
Syntax Transmit | MOVE [Data] |
Syntax Receive | MOVE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3642 (hex)
DIM | - | PROFIBUS PNU | 1922 (dec) IND = 0000xxxx (bin)
Range | 0,1,..,180,192 .. 255 | DPR | 322 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Start Motion Task

Description

The command “MOVE nr” starts the motion task “nr” from the motion task memory.
If the command is used without a parameter, then the number of the most recently started task will be displayed.


ASCII English MPHASE

ASCII - Command | MPHASE |
Syntax Transmit | MPHASE [Data] |
Syntax Receive | MPHASE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 359C (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1756 (dec) IND = 0000xxxx (bin)
Range | 0 .. 360 | DPR | 156 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Motor Phase, Feedback Offset

Description

The MOTOR PHASE parameter is handled in different ways, depending on the type of feedback (FBTYPE) that is used.
FBTYPE=0 resolver
MPHASE is saved in the serial EEPROM of the amplifier (SAVE command) and is transferred after every power-on of the amplifier.

FBTYPE=2, 4 Hiperface/Endat
MPHASE is saved in the serial EEPROM of the encoder (HSAVE command) and is read out from the encoder after every power-on of the amplifier. So if an encoder is exchanged, the MPHASE setting goes with the encoder. When a new encoder is fitted, the MPHASE value must be re-established and stored in the encoder (HSAVE command).

FBTYPE=7 sin/cos encoder without an internal EEPROM
MPHASE will be determined automatically at the first enable of the output stage (Wake & Shake)
It is not necessary to make a separate determination of the MPHASE value, or to save it.


ASCII English MPOLES

ASCII - Command | MPOLES |
Syntax Transmit | MPOLES [Data] |
Syntax Receive | MPOLES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 359D (hex)
DIM | Poles | PROFIBUS PNU | 1757 (dec) IND = 0000xxxx (bin)
Range | 0, 2, 4, 6, .. , 256 | DPR | 157 (dec)
Default | 6 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Number of Motor Poles

Description

The number of motor poles per turn of the motor.
MPOLES = 0 is not saved into the drive. The setting MPOLES =0 is also not monitored in the MMI.


ASCII English MRESBW

ASCII - Command | MRESBW |
Syntax Transmit | MRESBW [Data] |
Syntax Receive | MRESBW <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A0 (hex)
DIM | Hz | PROFIBUS PNU | 1760 (dec) IND = 0000xxxx (bin)
Range | 25 .. 1200 | DPR | 160 (dec)
Default | 600 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Resolver Bandwidth

Description

MRESBW is a tuning parameter that sets the bandwidth (in Hz) of the inner control loop. A high value (>800 Hz) results in a fast (low phase lag) and noisy velocity signal. A low value (<400 Hz) results in a slow (higher phase lag) and smooth velocity signal. The default value of 600 Hz is a compromise between phase lag and noise. The phase lag can be reduced by providing the acceleration feed forward signal (VLO = 1 ).

With a wide bandwidth, the drive responds more rapidly to control loop deviations and there is a smaller following error (reduced lag). A very wide bandwidth only makes sense with low moments of inertia, low KP, and very high acceleration values. A narrower bandwidth produces a filter effect. The rotational velocity and positional control are smoother (encoder equivalent output is quieter as well).
For the sensorless drive, the Luenberger Observer is used as the adaptive controller. Therefore, the parameter MRESBW corresponds to the bandwidth of the adaptive controller. It is normally set between 25 and 100 Hz.


ASCII English MRESPOLES

ASCII - Command | MRESPOLES |
Syntax Transmit | MRESPOLES [Data] |
Syntax Receive | MRESPOLES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35A1 (hex)
DIM | - | PROFIBUS PNU | 1761 (dec) IND = 0000xxxx (bin)
Range | 2, 4, .. 32 | DPR | 161 (dec)
Default | 2 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Number of Resolver Poles (Multispeed)

Description

The number of resolver poles (multispeed resolver) per turn.


ASCII English MRS

ASCII - Command | MRS |
Syntax Transmit | MRS [Data] |
Syntax Receive | MRS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3686 (hex)
DIM | Ohm | PROFIBUS PNU | 1990 (dec) IND = 0000xxxx (bin)
Range | 0 .. 100 | DPR | 390 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Winding Resistance of the Stator Phase-Phase

Description

The parameter describes the stator winding resistance phase-phase in Ohm


ASCII English MSERIALNO

ASCII - Command | MSERIALNO |
Syntax Transmit | MSERIALNO [Data] |
Syntax Receive | MSERIALNO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36A3 (hex)
DIM | - | PROFIBUS PNU | 2019 (dec) IND = 0000xxxx (bin)
Range | Long Int | DPR | 419 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | No
Short Description | Serial no of the motor for encoder feedback

Description

MSERIALNO give the possibility to add a serial number of the motor. It is stored in the encoder with parameter channel (EnDAT or Hiperface) of the motor by typing in HSAVE.
MSERIALNO gives the serial number of the connected motor with encoder feedback.
This command can only be used, if a motor with encoder is connected.


ASCII English MSG

ASCII - Command | MSG |
Syntax Transmit | MSG [Data] |
Syntax Receive | MSG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35A2 (hex)
DIM | - | PROFIBUS PNU | 1762 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 162 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | Yes
Short Description | Enable / Disable All Messages via RS232

Description

If “MSG 2” is set, then the execution of the individual initialization steps will be signaled through the serial interface when the amplifier is switched on (initialization phase). This setting should only be used for test purposes (e.g. during commissioning). Since the PC operating program basically only works with the setting “MSG 1”, the “MSG 2” setting can only be implemented with the help of a terminal program (not in the terminal window of the operating program).


ASCII English MSLBRAKE

ASCII - Command | MSLBRAKE |
Syntax Transmit | MSLBRAKE [Data] |
Syntax Receive | MSLBRAKE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3671 (hex)
DIM | - | PROFIBUS PNU | 1969 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32 | DPR | 369 (dec)
Default | 8 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | DEC ramp at sensorless emergency stop

Description

If the feedback unit trips (Fault F04, F08 or F25), it is impossible to stop the motor with the standard commutation. Therefore a sensorless stop is implemented. It is not possible to define a ramp, because it depends on the friction and inertia of the system. MSLBRAKE offers the possibility to change the emergency ramp in this case. The lower MSLBRAKE is, the lower is the deceleration of the motor.


ASCII English MSPEED

ASCII - Command | MSPEED |
Syntax Transmit | MSPEED [Data] |
Syntax Receive | MSPEED <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35A3 (hex)
DIM | rpm | PROFIBUS PNU | 1763 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 12000.0 | DPR | 163 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Maximum Rated Motor Velocity

Description

The MSPEED setting fixes the upper limit for the following amplifier parameters: VLIM, VLIMN,
5/6 * VOSPD.

Details are shown at parameter VUNIT .


ASCII English MTANGLP

ASCII - Command | MTANGLP |
Syntax Transmit | MTANGLP [Data] |
Syntax Receive | MTANGLP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A5 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1765 (dec) IND = 0000xxxx (bin)
Range | 0 .. 45 | DPR | 165 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Current Lead

Description

The current-dependent phase lead that is applied to make use of the reluctance torque at motor peak current (MIPEAK.


ASCII English MTIME

ASCII - Command | MTIME |
Syntax Transmit | MTIME [Data] |
Syntax Receive | MTIME <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | s | PROFIBUS PNU | No
Range |  | DPR | No
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weightning | 1000
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor thermal time constant

Description

Motor thermal time constant to calculate MI2T with MICONT


ASCII English MTMUX

ASCII - Command | MTMUX |
Syntax Transmit | MTMUX [Data] |
Syntax Receive | MTMUX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 365B (hex)
DIM | - | PROFIBUS PNU | 1947 (dec) IND = 0000xxxx (bin)
Range | 0, 192 ... 255 | DPR | 347 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Presetting for motion task that is processed later

Description

The command MTMUX presets the number of a motion task that is then prepared to work with commands O_P,O_V,O_C,O_ACC1,O_ACC2,O_DEC1,O_DEC2,O_FT,O_FN.
All this commands then have access to the selected motion task.

MTMUX is only allowed to work with RAM motion tasks.

MTMUX is not stored in EEPROM. While start-up of the drive, MTMUX is automatically set to "0".


ASCII English MTR

ASCII - Command | MTR |
Syntax Transmit | MTR [Data] |
Syntax Receive | MTR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 366C (hex)
DIM | ms | PROFIBUS PNU | 1964 (dec) IND = 0000xxxx (bin)
Range | 30 .. 1000 | DPR | 364 (dec)
Default | 200 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Rotor Time Constant

Description

IN PREPARATION !

This command is only for the induction motor mode (MTYPE = 3).
The MTR defines the rotor time constant at the rated operating point (Tr = Lh/Rr), where Lh and Rr are the magnetizing inductance and rotor resistance, respectively.


ASCII English MTYPE

ASCII - Command | MTYPE |
Syntax Transmit | MTYPE [Data] |
Syntax Receive | MTYPE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35A6 (hex)
DIM | - | PROFIBUS PNU | 1766 (dec) IND = 0000xxxx (bin)
Range | 1, 2, 3 | DPR | 166 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Motor Type

Description

MTYPE sets the drive control algorithms to different motor types as follows:
MTYPE = 1: permanent magnet motor
MTYPE = 2: permanent magnet motor with Id current control
The one case is for the linear permanent magnet motor, the other case is for the sensorless drive of permanent magnet motor.
MTYPE = 3: asynchronous motor (Induction motor)


ASCII English MUNIT

ASCII - Command | MUNIT |
Syntax Transmit | MUNIT [Data] |
Syntax Receive | MUNIT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 3674 (hex)
DIM |  | PROFIBUS PNU | 1972 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 372 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Unit of the Velocity dependant motor parameters

Description

MUNIT changes the units of the velocity dependant motor parameters, e.g. MVANGLP and MSPEED.

MUNIT = 0 rpm
MUNIT = 1 the setting of VUNIT is used


ASCII English MVANGLB

ASCII - Command | MVANGLB |
Syntax Transmit | MVANGLB [Data] |
Syntax Receive | MVANGLB <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35A7 (hex)
DIM | rpm | PROFIBUS PNU | 1767 (dec) IND = 0000xxxx (bin)
Range | 0 .. 15000 | DPR | 167 (dec)
Default | 3000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Velocity-dependent Lead (Start Phi)

Description

This is a compensation for the inductive phase shift between the motor voltage and the motor current at high velocitys. With defined voltage relationships, it permits a higher torque at the final limit velocity. Alternatively, the achievable final limit velocity can be increased by up to 30%. Depending on the motor velocity, the phase shift (commutation angle) is increased linearly from the Start Phi point up to the Limit Phi value (MVANGLF) at the final limit velocity. The most favorable setting depends on the type of motor and the final limit velocity.
See also MVANGLF.


ASCII English MVANGLF

ASCII - Command | MVANGLF |
Syntax Transmit | MVANGLF [Data] |
Syntax Receive | MVANGLF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35A8 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1768 (dec) IND = 0000xxxx (bin)
Range | 0 .. 45 | DPR | 168 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Velocity-dependent Lead (Limit Phi)

Description

This is a compensation for the inductive phase shift between the motor voltage and the motor current at high velocitys. With defined voltage relationships, this permits a higher torque at the final limit velocity. Alternatively, the achievable final limit velocity can be increased by up to 30%. Depending on the motor velocity, the phase shift is increased linearly from the Start Phi point (MVANGLB) up to the End Phi value at the final limit velocity. The most favorable setting depends on the type of motor and the final limit velocity.
See also MVANGLB.


ASCII English MVANGLP

ASCII - Command | MVANGLP |
Syntax Transmit | MVANGLP [Data] |
Syntax Receive | MVANGLP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3592 (hex)
DIM | Electrical Degrees | PROFIBUS PNU | 1746 (dec) IND = 0000xxxx (bin)
Range | 0 .. 60 | DPR | 146 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Velocity-dependent Lead (Commutation Angle)

Description

The inductive phase shift between the motor current and the motor voltage is compensated at high velocities. With the given voltage conditions, a higher torque is achieved at the velocity limit.
Alternatively, the achievable velocity limit is increased by 30%. The phase shift is increased linearly from a value of 0 degrees at MVANGLB up to a final value of MVANGLF degrees at VLIM. The optimum setting depends on the type of motor and velocity limit.


ASCII English MVR

ASCII - Command | MVR |
Syntax Transmit | MVR [Data] |
Syntax Receive | MVR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 366D (hex)
DIM | rpm | PROFIBUS PNU | 1965 (dec) IND = 0000xxxx (bin)
Range | 0 .. 10000 | DPR | 365 (dec)
Default | 6000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Motor | EEPROM | Yes
Short Description | Beginning Velocity of the field weakening

Description

IN PREPARATION !

For the induction motor mode (MTYPE = 3), the parameter MVR is set to the rated rotor mechanical velocity. This vale determines the beginning of the field weakening.
The value for 50 Hz induction motors with two poles is 3000 rpm. For the 50 Hz induction motor with four poles, MVR is 1500 rpm.
If the induction motor is for 60 Hz power line, the correspondent rated velocity should be given.

In the case of sensorless drives of PM motor (MTYPE=2, FBTYPE=10), the parameter MVR determines the switching value from scalar control to vector control. It is normally set to 10% ~ 20% of the rated velocity of the motor.

When using Hall' only, the parameter MVR determines the threshold speed where the actual speed is switched between speed estimation by using sensorless control method and speed calculation by the Hall's. So parameter's of the PM motor MKT, MKS and L must be set correctly. MTYPE has to be set to 2.
If MVR = 0, the compensation for the low speed will be switched off.
An optimal setting of this parameter depends on the relation of the motor poles and the rated speed. Normally it is set to 20 - 30% of the rated speed VLIM.


ASCII English NONBTB

ASCII - Command | NONBTB |
Syntax Transmit | NONBTB [Data] |
Syntax Receive | NONBTB <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AA (hex)
DIM | - | PROFIBUS PNU | 1770 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 170 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | Yes
Short Description | Mains-BTB Check On/Off

Description

If the Mains-BTB signal (power on) is missing, then the output stage will produce a fault message F16 (Mains-BTB) when it is enabled. If this response is not wanted, then the monitoring of the Mains-BTB signal can be switched off (NONBTB 1). This function can be used to control a DC supply.
See also UVLTMODE.


ASCII English NREF

ASCII - Command | NREF |
Syntax Transmit | NREF [Data] |
Syntax Receive | NREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AD (hex)
DIM | - | PROFIBUS PNU | 1773 (dec) IND = 0000xxxx (bin)
Range | 0 .. 20 | DPR | 173 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Homing Mode

Description

For linear movements, before a positioning movement can be started, a homing operation must be carried out. The reference point set in this operation is valid until the next hardware reset of the amplifier. An attempt to start positioning without a reference point being set causes a warning (LCD display n09). Any previously-set reference point is cancelled before the homing operation begins.
A preset zero-point offset is taken into account for the position output and display. Exception: Homing=5. In this case, the true current position is displayed. You can shift the zero-crossing point of the motor shaft within one turn by using ENCZERO.
Zero-point recognition: The reference point is set to the first zero-crossing point of the feedback unit (zero mark) after recognition of the reference switch transition. Two-pole resolvers and all encoders have just one zero-crossing per turn, so the positioning at the zero mark is unambiguous within a motor turn. For four-pole resolvers, there are two zero-crossings per turn. For six-pole resolvers, there are three zero-crossings per turn. If the transition of the reference switch lies very close to the zero-crossing point of the feedback unit, the positioning to the zero mark can vary by one motor turn. The repetition accuracy of homing operations made without zero-point recognition depends on the traversing velocity and the mechanical design of the reference or limit switch.
For homing modes 1 and 3, a digital input must be configured as a zero-mark input (home position) (INxMODE=12 or I/O expansion card).
For homing modes 2 and 4, a digital input must be configured as a hardware limit switch (INxMODE=2 or INxMODE=3).
For homing modes 1, 2, 3, 4, 5, and 7, the setting of the zero-pulse offset for the Encoder Equivalent Output (EEO) output is taken into account (the zero point is set so both the output of the zero pulse and the display of the zero position appear at zero-pulse offset).
The setting of the reference offset (ROFFS) is taken into account for all homing modes. The zero point is assigned to a freely chosen absolute position value.

If a multiturn encoder is used, every homing move can be started. If the homing move is ready, RSOFFS is calculated automatically and a SAVE command is executed.
Wenn the drive is switched off and on, the drive has the same position.
Status | Short Description | Additional Description
NREF=0 Set Reference at actual position The actual position becomes the refernce point ( the target and the actual position are set to ROFFS).
The distance between the actual and the target position is lost.
NREF=1 Traverse to the reference switch with zero-mark recognition. The drive starts a move using DREF, until a positive edge at the reference switch is detected. Then the distance to the next zero point of the resolver is calculated and a move to this position is started.
If the reference switch is present (input signal = high), a move in the opposite direction of DREF is startet until a negative edge is detected. Then the homing move is started.
If a hardware limit switch is detected (start of the homing move behind the reference switch), the direction is changed and a move is started, until a positive and a negative level edge is detected at the reference switch. Then the homing move is started. At the end of the homing move, the target and the actual position are set to ROFFS.
NREF=2 Move to hardware limit-switch, with zero-mark recognition. The drive starts a move using DREF until the hardware limit switch is reached. Then the direction is changed and the drive moves to the next zero point of the resolver.
At the end of the homing move, the target and the actual position are set to ROFFS.
NREF=3 Move to reference switch, without zero-mark recognition. The drive starts a move using DREF, until a positive edge at the reference switch is detected. The position at the edge of the reference move is eqivalent to ROFFS. Then the drive stops.
If the reference switch is present (input signal = high), a move in the opposite direction of DREF is startet until a negative edge is detected. Then the homing move is started.
If a hardware limit switch is detected (start of the homing move behind the reference switch), the direction is changed and a move is started, until a positive and a negative level edge is detected at the reference switch. Then the homing move is started. The real stop position is not the edge of the reference switch and depends on the selected speed and the deceleration ramp.
NREF=4 Move to hardware limit-switch, without zero-mark recognition. The drive starts a move using DREF, until the hardware limit switch is detected. Then the direction is changed and a move is started until the hardware limit switch is high again. The position at the edge of the hardware limit switch is eqivalent to ROFFS. Then the drive stops.
The real stop position is not the edge of the hardware limit switch and depends on the selected speed and the deceleration ramp.
NREF=5 Move to the next zero-mark of the feedback unit. Homing to the next zero point of the resolver. The moving direction is given by variable DREF.
DREF=0 negative
DREF=1 positive
DREF=2 the direction is given by the shortest distance.
NREF=6 Set Reference at actual position, without loosing target position The actual position becomes the reference point ( the position setpoint and the actual position are set to ROFFS).
The difference to NREF=0 is, that the distance between target and actual position is not lost (position error).
NREF=7 Move to mechanical stop with zero-mark recognition When the homing mode 7 is started, the peak current limit threshold IPEAK is set to REFIP (peak current for the homing mode in A) in the drirection given by DREF (DREF=0 positive, DREF=1 negative).
When the drive moves the motor, the contouring error is monitored and if the error becomes higher than PEMAX / 2 (half of the contouring error window), the direction is changed and a move to the next zero point of the resolver is startet. The motor stops in that position and sets the actual and the target position to ROFFS. The peak current of the drive is set back to the original value of IPEAK.
NREF=8 | Move to absolute SSI-position | When a homing mode 8 is started, the actual position of an external Multiturn SSI encoder (GEARMODE=7) is read, calculated with GEARI and GEARO to internal counts and an offset value ROFFS2 is added. The result is a target position for a motion task that is started. When the target position is reached, the IN-POSITION bit is set. This function is done for a gantry application with multiturn encoder feedback and coupling of the two drive using SSI multiturn,
NREF=9 Move to mechanical stop without zero-mark recognition When the homing mode 9 is started, the peak current limit threshold IPEAK is set to REFIP (peak current for the homing mode in A) in the drirection given by DREF (DREF=0 positive, DREF=1 negative).
When the drive moves the motor, the contouring error is monitored and if the error becomes higher than PEMAX / 2 (half of the contouring error window), this position is used to set the actual and the target position to ROFFS. The peak current of the drive is set back to the original value of IPEAK.


ASCII English NREFMT

ASCII - Command | NREFMT |
Syntax Transmit | NREFMT [Data] |
Syntax Receive | NREFMT <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36D2 (hex)
DIM |  | PROFIBUS PNU | 1666 (dec) IND = 0001xxxx (bin)
Range | 0 ... 511 | DPR | 466 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM |
Short Description | Homing wih following motion task

Description

The command NREFMT will start automatically a motion task at the end of the homing.

THe parameter NREFMT is a bit-variable (16 bit)

FEDCBA9876543210
xxxxxxxcnnnnnnnn

Bits 0..7 (nnnnnnnn) number of the automatic startet motion task
number = 0 no motion task will be started.

Bit 8 =0 motion task nn will be startet after the motor stopped. The bits „homing active=0“ and „homing finnished=1“ are set before motion task nn is started.

=1 motion task nn starts immediately. The bits „homing active=0“ and „homing finnished=1“ are set after motion task nn is finnished.


ASCII English O1

ASCII - Command | O1 |
Syntax Transmit | O1 [data] |
Syntax Receive | O1 | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AE (hex)
DIM | - | PROFIBUS PNU | 1774 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 174 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Digital Output 1

Description

The O1 command returns the state of the digital output 1 (0 = Low,1 = High).
If no function is assigned to digital output 1 (O1MODE=0), then the High/Low state can be given out at output 1 by using the command “O1 1” or “O1 0”.


ASCII English O1MODE

ASCII - Command | O1MODE |
Syntax Transmit | O1MODE [Data] |
Syntax Receive | O1MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35AF (hex)
DIM | - | PROFIBUS PNU | 1775 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 175 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Output 1

Description

The O1 command returns the state of the digital output 1 (0 = Low,1 = High). If no function is assigned to digital output 1 (O1MODE=0), then the High/Low state can be given out at output 1 by using the command “O1 1” or “O1 0”.
Status | Function | Description
O1MODE=0 | Off | OFF The state of the digital output 1 can be set/cleared by RS232/Fieldbus or Slot board
O1MODE=1 | v_act<O1TRIG | As long as the absolute value for the motor velocity is lower than a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O1TRIG. The ouput is high, if V < O1TRIG and becomes low, if V > O1TRIG + 0.01 * MSPEED.
O1MODE=2 | v_act>O1TRIG | As long as the absolute value for the motor velocity is higher than a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O1TRIG. The ouput is high, if V > O1TRIG and becomes low, if V < O1TRIG + 0.01 * MSPEED.
O1MODE=3 | Mains-RTO | This signals the operational readiness of the SERVOSTAR™ 600 power output stage. After switching on the mains supply, a HIGH-signal is output until the DC-link circuit is fully charged up. A LOW-signal is output when the charging of the DC-link circuit is finished. If the DC-link voltage falls below 100V, then a HIGH-signal will be output. The “Undervoltage” monitoring is inactive. O1MODE=3 only works, if NONBTB = 0.
O1MODE=4 | Regen off | Signals if the preset regen power (screen page “Basic Setup”) is exceeded.
O1MODE=5 | Sw_limit | This produces a HIGH-signal if a software limit-switch is reached (a preset function of the corresponding position register, set to “SW limit-switch 1” or “SW limit-switch 2” – the function is defined in the screen page “Position”).
O1MODE=6 | Pos.>x | If the position (angular position of the motor shaft) exceeds a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected, you can enter the signaling posi-tion in increment (a number or fraction of motor turns N) as O1TRIG. Make the calculation according to the following equation: x = 1048576 *N *Inkr. Maximum possible entry value:x =2 31 = 2147483648, this corresponds to N = 2048
O1MODE=7 | InPos | When the target position for a motion task has been reached (the InPosition window PEINPOS), this is signaled by the output of a HIGH-signal. A cable break will not be detected. The width of the InPosition window for all the valid motion tasks is entered in the “Position data” screen page. If a sequence of motion tasks is performed one after another, then the signal for reaching the final position of the motion-task sequence will be output (target position of the last motion task). Signaling that the target position of each motion task has been reached, in a sequence of motion tasks, can be achieved with the function “16, Next_InPos”.
O1MODE=8 | I_act<O1TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is lower than a defined value in mA (O1TRIG). After the function has been selected, you can enter the current value as O1TRIG in mA.
O1MODE=9 | I_act>O1TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is higher than a defined value in mA (O1TRIG). After the function has been selected, you can enter the current value as O1TRIG in mA.
O1MODE=10 | Ferror | If the position goes outside the preset contouring-error window, this is indicated by a LOW-signal. The width of the contouring-error window (PEMAX) is entered in the screen page “Position” for all the valid motion tasks.
O1MODE=11 | I2T | If the preset I2T monitoring threshold (I2TLIM) is reached (screen page “Current” ) this is indicated by a HIGH-signal.
O1MODE=12 | Posreg.1 | The preset function of the corresponding position register 1 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O1MODE=13 | Posreg.2 | The preset function of the corresponding position register 2 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O1MODE=14 | Posreg.3 | The preset function of the corresponding position register 3 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O1MODE=15 | Posreg.4 | The preset function of the corresponding position register 4 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O1MODE=16 | Next-InPos | The start of each motion task in an automatically executed sequence of motion tasks is signalled by an inversion of the output signal. The output produces a Low signal at the start of the first motion task of the motion task sequence. The type of message can be set by IN2PM
O1MODE=17 | Error/Warn | The output produces a HIGH-signal if an error or a warning message is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE.
O1MODE=18 | Error | The output produces a HIGH-signal if an error is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE
O1MODE=19 | DC_Link>O1TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is higher than a defined value in volts (O1TRIG). After the function has been selected, you can enter the voltage value as O1TRIG in Volt..
O1MODE=20 | DC_Link < O1TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is lower than a defined value in volts (O1TRIG). After the function has been selected, you can enter the voltage value in O1TRIG in Volt.
O1MODE=21 | ENABLE | A HIGH-signal is output if the servo amplifier is enabled. To obtain the enable, the external Hardware Enable signal must be present, the Enable status must be set in the setup software (or via the fieldbus interface) and no errors must be present that would cause an automatic internal disabling of the servo amplifier. If function OxMODE = is selected, the enable signal is high, if the line voltage is applied and the charging of the link capacitors is finished. The drive is disabled, if the DC-link voltage wents under the threshold VBUSMIN.
O1MODE=22 | Zero_pulse | The zero mark/pulse (HIGH-signal) is indicated by the encoder-emulation. This function is only use-ful at very low velocities. Vmax = 15000 / ENCOUT e.g. ENCOUT=256 Pulses/Rev Vmax = 58 rpm
O1MODE=23 | Slot-DPR | This configuration enables the possibility to output a state from the Slot board (mem DPR Slot Board Offset 0x3E4). If no Slot board is available, this configuration is equal to OxMODE=0. If a Device-Net option board is plugged in the drive, this setting enables access of Device-Net to digital output 1
O1MODE=24 | Ref_OK | The output signals High, if a reference point is available. Reference traverse (homing) has been carried out, or a reference point has been set. (see NREF)
O1MODE=25 | Reserved |
O1MODE=26 | Reserved |
O1MODE=27 | Reserved |
O1MODE=28 | Posreg.0 | The preset function of the corresponding position register 0 is indicated by a HIGH-signal. Valid only with expansion card -I/0-14/08- .
O1MODE=29 | Posreg.5 | The preset function of the corresponding position register 5 is indicated by a HIGH-signal. Valid only with expansion card -I/0-14/08- .
O1MODE=30 | OR-Operation of all Posreg. | If one of the position registers 0...5 indicates high, the output is high, otherwise low.
O1MODE=31 | Analog SW1< O1TRIG | The output is high, if the analog input voltage at SW1 is lower than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=32 | Analog SW1> O1TRIG | The output is high, if the analog input voltage at SW1 is higher than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=33 | Analog SW2 < O1TRIG | The output is high, if the analog input voltage at SW2 is lower than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=34 | Analog SW2 > O1TRIG | The output is high, if the analog input voltage at SW2 is higher than the threshold O1TRIG. The auxiliary variable O1TRIG is given in mV (with sign).
O1MODE=35 | Internal Enable | The state of the internal ENABLE signal is mirrored on the digital output. If the setiings are: MBRAKE=0, STOPMODE=0 and ACTFAULT=0, the function is similar to O1MODE=21. If one of the three variables is "1", the output changes to low, when the drives starts to dec to "0". If O1MODE=21, the output is low, if the drive has stopped and has disabled the output stage.
O1MODE=36 | Logical OR: DRVSTAT - O1TRIG | This function makes a OR operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=37 | Logical AND: DRVSTAT -O1TRIG | This function makes a AND operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=38 | Logical OR: TRJSTAT - O1TRIG | This function makes a OR operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=39 | Logical AND: TRJSTAT - O1TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=40 | Logical OR: POSRSTAT - O1TRIG | This function makes a OR operation between the Bit-variable POSRSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=41 | Logical AND: POSRSTAT - O1TRIG | This function makes a AND operation between the Bit-variable POSRSTAT and a Bit mask given by O1TRIG. The result is present at output 1.
O1MODE=42 |  | This function enables a temperature warning. If one of the three internal measured temperatures reaches the trip level, the digital output ist set to high. After the selected delay time given in O1TRIG the drive generates a error message and disables the output stage. The delay time has the range 0...30000 msec and effects following temperatures: Motor temperature TEMPM, threshold MAXTEMPM Heatsink temperature TEMPH, Threshold MAXTEMPH Ambient temperature TEMPE, threshold MAXTEMPE
O1MODE=43 | The sign of the actual velocity | OUTPUT1 = 1 V < -VEL0 OUTPUT1 = 0 V > -VEL0
O1MODE=44 | Velocity In-Position (active high) | The output 1 is set, if the absolute of the difference between the internal velocity command and the actual velocity is smaller than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT).
O1MODE=45 | Velocity In-Position (aktive low) | The output 1 is set, if the absolute of the difference between the internal velocity command and the actual velocity is bigger than O1TRIG. The size of the window (O1TRIG) is given in valid velocity units (VUNIT). (4.30)
O1MODE=46 | Current in Window (low active) | The digital output 1 is set, if the absolute of the difference between current command and actual value is smaller than the window, defined by O1TRIG. The window is given in mA.
O1MODE=47 | Current not in Window (low active) | The digital output 1 is set, if the absolute of the difference between current command and actual value is greater than the window, defined by O1TRIG. The window is given in mA.
O1MODE=48 | Logical NOR: DRVSTAT - O1TRIG | This function makes a inverted OR operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1. (starting with 4.92)
O1MODE=49 | Logical NAND: DRVSTAT -O1TRIG | This function makes a inverted AND operation between the Bit-variable DRVSTAT and a Bit mask given by O1TRIG. The result is present at output 1. (starting with 4.92)
O1MODE=50 | Logical NOR: TRJSTAT - O1TRIG | This function makes a inverted OR operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1. (starting with 4.92)
O1MODE=51 | Logical NAND: TRJSTAT - O1TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O1TRIG. The result is present at output 1. (starting with 4.92)


ASCII English O1TRIG

ASCII - Command | O1TRIG |
Syntax Transmit | O1TRIG [Data] |
Syntax Receive | O1TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B0 (hex)
DIM | - | PROFIBUS PNU | 1776 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 176 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for O1MODE

Description

The function of the auxiliary variable O1TRIG depends on the configuration of O1MODE.
see O1MODE


ASCII English O2

ASCII - Command | O2 |
Syntax Transmit | O2 [Data] |
Syntax Receive | O2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B1 (hex)
DIM | - | PROFIBUS PNU | 1777 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 177 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | State of Digital Output 2

Description

The O2 command returns the state of the digital output 2 (0 = Low,1 = High).
If no function is assigned to digital output 2 (O2MODE=0), then the High/Low state can be given out at output 2 by using the command “O2 1” or “O2 0”.


ASCII English O2MODE

ASCII - Command | O2MODE |
Syntax Transmit | O2MODE [Data] |
Syntax Receive | O2MODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B2 (hex)
DIM | - | PROFIBUS PNU | 1778 (dec) IND = 0000xxxx (bin)
Range | 0 .. 50 | DPR | 178 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Function of Digital Output 2

Description

The O2MODE command can be used to configure the function of the digital output OUT2. The amplifier must be switched off and then on again after an alteration of this parameter. The following functions can be configured:
Status | Function | Description
O2MODE=0 | Off | OFF The state of the digital output 2 can be set/cleared by RS232/Fieldbus or Slot board
O2MODE=1 | v_act<O1TRIG | As long as the absolute value for the motor velocity is lower than a preset value (O2TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O2TRIG. The ouput is high, if V < O2TRIG and becomes low, if V > O2TRIG + 0.01 * MSPEED.
O2MODE=2 | v_act>O1TRIG | As long as the absolute value for the motor velocity is higher than a preset value (O2TRIG), a HIGH-signal will be output. After the function has been selected you can enter the velocity in rpm in O2TRIG. The ouput is high, if V > O2TRIG and becomes low, if V < O2TRIG + 0.01 * MSPEED.
O2MODE=3 | Mains-RTO | This signals the operational readiness of the SERVOSTAR™ 600 power output stage. After switch-ing on the mains supply, a LOW-signal is output until the DC-link circuit is fully charged up. A HIGH-signal is output when the charging of the DC-link circuit is finished. If the DC-link voltage falls below 100V, then 0V will be output. The “Undervoltage” monitoring is inactive. O1MODE=3 only works with NONBTB = 0.
O2MODE=4 | Regen off | Signals if the preset regen power (screen page “Basic Setup”) is exceeded.
O2MODE=5 | Sw_limit | This produces a HIGH-signal if a software limit-switch is reached (a preset function of the corresponding position register, set to “SW limit-switch 1” or “SW limit-switch 2” – the function is defined in the screen page “Position”).(see SWCNFG)
O2MODE=6 | Pos.>O1TRIG | If the position (angular position of the motor shaft) exceeds a preset value (O1TRIG), a HIGH-signal will be output. After the function has been selected, you can enter the signaling posi-tion in increment (a number or fraction of motor turns N) as O1TRIG. Make the calculation according to the following equation: O1TRIG = 1048576 *N *Inkr. Maximum possible entry value:x =2 31 = 2147483648, this corresponds to N = 2048
O2MODE=7 | InPos | When the target position for a motion task has been reached (the InPosition window), this is signaled by the output of a HIGH-signal. A cable break will not be detected. The width of the InPosition window PEINPOS for all the valid motion tasks is entered in the “Position data” screen page. If a sequence of motion tasks is performed one after another, then the signal for reaching the final position of the motion-task sequence will be output (target position of the last motion task). Signaling that the target position of each motion task has been reached, in a sequence of motion tasks, can be achieved with the function “16, Next_InPos”.
O2MODE=8 | I_act< O2TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is lower than a defined value in mA (O2TRIG). After the function has been selected, you can enter the current value as O2TRIG.
O2MODE=9 | I_act > O2TRIG | The output is a HIGH-signal, as long as the absolute r.m.s. value of the actual current is higher than a defined value in mA (O2TRIG). After the function has been selected, you can enter the current value as O2TRIG.
O2MODE=10 | Ferror | If the position goes outside the preset contouring-error window (PEMAX) , this is indicated by a LOW-signal. The width of the contouring-error window is entered in the screen page “Position” for all the valid motion tasks.
O2MODE=11 | I²t | If the preset I2t monitoring threshold I2TLIM is reached (screen page “Current” ) this is indicated by a HIGH-signal.
O2MODE=12 | Posreg.1 | The preset function of the corresponding position register 1 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O2MODE=13 | Posreg.2 | The preset function of the corresponding position register 2 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O2MODE=14 | Posreg.3 | The preset function of the corresponding position register 3 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O2MODE=15 | Posreg.4 | The preset function of the corresponding position register 4 (the function is defined in the screen page “Position”) is indicated by a HIGH-signal.
O2MODE=16 | Next-InPos | The start of each motion task in an automatically executed sequence of motion tasks is signalled by an inversion of the output signal. The output produces a Low signal at the start of the first motion task of the motion task sequence. The type of message can be set by IN2PM
O2MODE=17 | Error/Warn | The output produces a HIGH-signal if an error or a warning message is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE.
O2MODE=18 | Error | The output produces a HIGH-signal if an error is signaled by the servo amplifier. A list of the error messages can be found under ERRCODE
O2MODE=19 | DC_Link > O2TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is higher than a defined value in volts (O2TRIG). After the function has been selected, you can enter the voltage value as O2TRIG.
O2MODE=20 | DC_Link < O2TRIG | A HIGH-signal is output if the actual value of the DC-link voltage is lower than a defined value in volts (O2TRIG). After the function has been selected, you can enter the voltage value as O2TRIG.
O2MODE=21 | ENABLE | A HIGH-signal is output if the servo amplifier is enabled. To obtain the enable, the external Hardware Enable signal must be present, the Enable status must be set in the setup software (or via the fieldbus interface) and no errors must be present that would cause an automatic internal disabling of the servo amplifier. If function OxMODE = is selected, the enable signal is high, if the line voltage is applied and the charging of the link capacitors is finished. The drive is disabled, if the DC-link voltage wents under the threshold VBUSMIN.
O2MODE=22 | Zero_pulse | The zero mark/pulse (HIGH-signal) is indicated by the encoder-emulation. This function is only useful at very low velocities. Vmax = 15000 / ENCOUT e.g. ENCOUT=256 Pulses/Rev Vmax = 58 rpm
O2MODE=23 | Slot-DPR | This configuration enables the possibility to output a state from the Slot board (mem DPR Slot Board Offset 0x3E4). If no Slot board is available, this configuration is equal to O2MODE=0. If a Device-Net option board is plugged in the drive, this setting enables access of Device-Net to digital output 2+
O2MODE=24 | Ref_OK | The output signals High, if a reference point is available. Reference traverse (homing) NREF has been carried out, or a reference point has been set )
O2MODE=25 | Reserved |
O2MODE=26 | Reserved |
O2MODE=27 | Reserved |
O2MODE=28 | Posreg. 0 | The preset function of the corresponding position register 0 is indicated by a HIGH-signal. Valid only with expansion card -I/0-14/08- .
O2MODE=29 | Posreg. 5 | The preset function of the corresponding position register 5 is indicated by a HIGH-signal. Valid only with expansion card -I/0-14/08- .
O2MODE=30 | OR-Operation of all Posreg. | If one of the position registers 0...5 indicates high, the output is high, otherwise low.
O2MODE=31 | Analog SW1 > O2TRIG | The output is high, if the analog input voltage at SW1 is lower than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=32 | Analog SW1 < O2TRIG | The output is high, if the analog input voltage at SW1 is lower than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=33 | Analog SW2 < O2TRIG | The output is high, if the analog input voltage at SW1 is higher than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=34 | Analog SW2 > O2TRIG | The output is high, if the analog input voltage at SW2 is lower than the threshold O2TRIG. The auxiliary variable O2TRIG is given in mV (with sign).
O2MODE=35 | Internal Enable | The state of the internal ENABLE signal is mirrored on the digital output. If the setiings are: MBRAKE=0, STOPMODE=0 and ACTFAULT=0, the function is similar to O1MODE=21. If one of the three variables is "1", the output changes to low, when the drives starts to dec to "0". If O1MODE=21, the output is low, if the drive has stopped and has disabled the output stage.
O2MODE=36 | Logical OR: DRVSTAT - O2TRIG | This function makes a OR operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=37 | Logical AND: DRVSTAT - O2TRIG | This function makes a AND operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=38 | Logical OR: TRJSTAT - O2TRIG | This function makes a OR operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=39 | Logical AND: TRJSTAT - O2TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=40 | Logical OR: POSRSTAT - O2TRIG | This function makes a OR operation between the Bit-variable POSRSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=41 | Logical AND: POSRSTAT - O2TRIG | This function makes a AND operation between the Bit-variable POSRSTAT and a Bit mask given by O2TRIG. The result is present at output 2.
O2MODE=42 |  | This function enables a temperature warning. If one of the three internal measured temperatures reaches the trip level, the digital output ist set to high. After the selected delay time given in O2TRIG the drive generates a error message and disables the output stage. The delay time has the range 0...30000 msec and effects following temperatures: Motor temperature TEMPM, threshold MAXTEMPM Heatsink temperature TEMPH, Threshold MAXTEMPH Ambient temperature TEMPE, threshold MAXTEMPE Start Firmware 3.41
O2MODE=43 | The sign of the actual velocity | OUTPUT2 = 1 V < -VEL0 OUTPUT2 = 0 V > -VEL0 This function is available starting firmware version 4.01.
O2MODE=44 | Velocity In-Position (active high) | The output 2 is set, if the absolute of the difference between the internal velocity command and the actual velocity is smaller than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT). (4.30)
O2MODE=45 | Velocity In-Position (aktive low) | The output 2 is set, if the absolute of the difference between the internal velocity command and the actual velocity is bigger than O2TRIG. The size of the window (O2TRIG) is given in valid velocity units (VUNIT). (4.30)
O2MODE=46 | Current in Window (low active) | The digital output 2 is set, if the absolute of the difference between current command and actual value is smaller than the window, defined by O1TRIG. The window is given in mA.
O2MODE=47 | Current not in Window (low active) | The digital output 2 is set, if the absolute of the difference between current command and actual value is greater than the window, defined by O2TRIG. The window is given in mA.
O2MODE=48 | Logical NOR: DRVSTAT - O2TRIG | This function makes a inverted OR operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 2. (starting with 4.92)
O2MODE=49 | Logical NAND: DRVSTAT -O2TRIG | This function makes a inverted AND operation between the Bit-variable DRVSTAT and a Bit mask given by O2TRIG. The result is present at output 2. (starting with 4.92)
O2MODE=50 | Logical NOR: TRJSTAT - O2TRIG | This function makes a inverted OR operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 2. (starting with 4.92)
O2MODE=51 | Logical NAND: TRJSTAT - O2TRIG | This function makes a AND operation between the Bit-variable TRJSTAT and a Bit mask given by O2TRIG. The result is present at output 2. (starting with 4.92)


ASCII English O2TRIG

ASCII - Command | O2TRIG |
Syntax Transmit | O2TRIG [Data] |
Syntax Receive | O2TRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B3 (hex)
DIM | - | PROFIBUS PNU | 1779 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 179 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | Yes
Short Description | Auxiliary Variable for O2MODE

Description

The function of the auxiliary variable O2TRIG depends on the configuration of O2MODE.
see O2MODE


ASCII English O_ACC1

ASCII - Command | O_ACC1 |
Syntax Transmit | O_ACC1 [Data] |
Syntax Receive | O_ACC1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35B7 (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1783 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32000 | DPR | 183 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Acceleration Time 1 for Motion Task 0

Description

The command O_ACC1 can be used to define the acceleration ramp for motion task 0 (direct motion block). The scaling of the acceleration time depends on the PGEARI, PGEARO and O_C parameters.

1. Bit 12 of the motion task control variable O_C is = 0.
The acceleration time is given in milliseconds for acceleration from 0 to the target speed O_V.
2. Bit 12 of the motion task control variable O_C is = 1.
The acceleration is given in mm/sec². The resulting run-up time is calculated at the start of the motion task.

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed, position and acceleration. In this case, O_ACC1 is interpreted as a run-up time in msec.


ASCII English O_C

ASCII - Command | O_C |
Syntax Transmit | O_C [Data] |
Syntax Receive | O_C <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35B9 (hex)
DIM | - | PROFIBUS PNU | 1785 (dec) IND = 0000xxxx (bin)
Range | int | DPR | 185 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controler | EEPROM | No
Short Description | Control Variable for Motion Task 0

Description

The O_C command defines the type of motion task for the local motion task 0 (direct motion task). A bit-variable (16 bits) is transferred as the parameter. The individual bits of this variable are interpreted as follows:
 | Table 1 |
Bit | Significance | Meaning
0 | 0x0001 | Bit for the type of motion task (relative or absolute) (see table 2)
1 | 0x0002 | Bit for the type of the relative motion task (see table 2)
2 | 0x0004 | Bit for the type of the relative motion task (see table 2)
3 | 0x0008 | =0 no next motion task, at the end of the motion task, the drive stops. =1 Next motion task selected, at the end of the motion task, automatically the next motion task is started. The number of the next motion task is given by O_FN
4 | 0x0010 | Bit for the type of next motion task (see table 3)
5 | 0x0020 | Bit for the type of next motion task (see table 3)
6 | 0x0040 | Bit for the type of next motion task (see table 3)
7 | 0x0080 | Bit for the type of next motion task (see table 3)
8 | 0x0100 | Bit for the type of next motion task (see table 3)
9 | 0x0200 | =0 The motion task is executed via the internal trajectory generator. =1 A stored lookup table profile is started. The table has to be stored in the flash of the drive. O_ACC2 gives the number of the selected table. The sum of O_ACC1 and O_DEC1 gives the moving time of the profile. O_V and O_DEC2 are ignored.
10 | 0x0400 | =0 The profile is executed in the given direction. =1 The profile is executed in the inverse direction.
11 | 0x0800 | reserved
12 | 0x1000 | =0 the acc and dec of the motion tasks is given in msek from "0" to the target speed. =1 the acc and dec of the motion task is given in mm/sec² (see also commands O_ACC1, O_ACC2, O_DEC1, O_DEC2).
13 | 0x2000 | =0 The target position and target speed of the motion task is interpreted as counts (there is no calculation needed). =1 The target position and target speed is given in SI units. There must be a calulation with PGEARI and PGEARO to get the internal counts (see also O_S, O_V, PGEARI, PGEARO).
14 | 0x4000 | =0 The speed that is given in the motion task is the target speed. =1 The target speed is given by the analog setpoint 1 SW1. When a motion task is started, the anlog input is read and becomes the target speed of the motion task (Scaling: 10V=VSCALE1). The absolute of SW1 is used.
15 | 0x8000 | Bit 3 of the type of the relative motion task (see separate table)
 | Table 2 | Type of relative/absolute Motion Task
Bit 15/2/1/0 | Meaning |
xxx0 | Absolute Motion Task, the position value in the motion task is the new target position |
x001 | Relative Motion Task, the position value in the motion task is added to the old target position. The target position depends on the IN-POSITION message: IN-POSITION=1 target position = last target position + relative position of the motion task IN-POSITION = 0 target position = actual position + relative position of the motion task |
x011 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = last target position + relative position of the motion task |
x101 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = actual position + relative position of the motion task |
0111 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = latched position at the positive edge of the input + relative position of the motion task (see object LATCH32) |
1111 | Relative Motion Task, the position value in the motion task is added to the old target position. target position = latched position at the negative edge of the input + relative move of the motion task (see object LATCH32N |
 | Table 3 | Type of Next motion task
Bit 8/7/6/5/4 | Meaning |
00000 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. Then it starts the next motion task in the sequence. |
00001 | Switch over to next motion task without stop. The drive moves to the target position with target speed of the actual motion task. Then it starts the next motion task in the sequence. |
10001 | Switch over to next motion task without stop. The drive calculates the brake point, that the speed of the motor at target position becomes the speedof the next motion task in the sequence. |
00010 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started, if the digital input selected by INxMODE=15 is switched to low. |
00110 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started, if the digital input selected by INxMODE=15 is switched to high. |
01000 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT). |
01010 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT) or if the digital input selected by INxMODE=15 is set to low. |
01110 | Switch over to next motion task with stop. The drive stops at the target position of the actual motion task. The next motion task in the sequence is started after the selected delay time defined by O_FT) or if the digital input selected by INxMODE=15 is set to high. |


ASCII English O_DEC1

ASCII - Command | O_DEC1 |
Syntax Transmit | O_DEC1 [Data] |
Syntax Receive | O_DEC1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35BA (hex)
DIM | Milliseconds, mm/sec ^2 | PROFIBUS PNU | 1786 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32000 | DPR | 186 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Braking Time 1 for Motion Task 0

Description

The command O_DEC1 can be used to define the deceleration (braking) ramp for motion task 0 (direct motion task). The scaling of the deceleration/braking time depends on the PGEARI, PGEARO and O_C parameters.

1. Bit 12 of the motion task control variable O_C is = 0.
The braking time is given in milliseconds for deceleration from target speed O_V down to 0.
2. Bit 12 of the motion task control variable O_C is = 1.
The deceleration is given in mm/sec². The resulting run-down time is calculated at the start of the motion task.

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed, position and acceleration. In this case, O_DEC1 is interpreted as a run-down time in msec.


ASCII English O_FN

ASCII - Command | O_FN |
Syntax Transmit | O_FN [Data] |
Syntax Receive | O_FN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35BC (hex)
DIM | - | PROFIBUS PNU | 1788 (dec) IND = 0000xxxx (bin)
Range | 0, 1, .. ,180,192 .. 255 | DPR | 188 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Next Task Number for Motion Task 0

Description

The command O_FN can be used to define the number of the following motion block. This number is only used if bit 3 (next block activated) of the motion block control word is set to 1.
The motion block number can have the following values:
0 - direct motion block
1 ... 180 motion block from the Flash EEPROM
192 ... 255 motion block from the RAM


ASCII English O_FT

ASCII - Command | O_FT |
Syntax Transmit | O_FT [data] |
Syntax Receive | O_FT | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35BD (hex)
DIM | Milliseconds | PROFIBUS PNU | 1789 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767 | DPR | 189 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Delay before Next Motion Task

Description

This parameter can be used to delay the start of the next motion task (if one is defined). This parameter is only evaluated if bit 3 (next task activated) and bit 7 (delay time activated) of the motion task control word are set.


ASCII English O_P

ASCII - Command | O_P |
Syntax Transmit | O_P [data] |
Syntax Receive | O_P | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer64 | CANBus Object Number | 35BE (hex)
DIM | - | PROFIBUS PNU | 1790 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 190 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer64
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Target Position/Path for Motion Task 0

Description

The command O_P can be used to define the target position for motion block 0 (direct motion block). Depending on the type of motion task (absolute or relative) this parameter will be interpreted as an absolute target position or a relative path movement. The scaling of the position depends on the PGEARI, PGEARO, PRBASE and O_C parameters.

1. Bit 13 of the motion block control word = 0 (given in internal units)
The position /path is given in counts.
Scaling: PRBASE=20 -> 1048576 increments per turn
PRBASE=16 -> 65536 increments per turn

2. Bit 13 of the motion block control variable is = 1 (taking the resolution into account)
The position is converted according to the following formula:
Position [increments] = O_P * PGEARO / PGEARI

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed, position and acceleration.


ASCII English O_V

ASCII - Command | O_V |
Syntax Transmit | O_V [data] |
Syntax Receive | O_V | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35BF (hex)
DIM | - | PROFIBUS PNU | 1791 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 191 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Target Speed for Motion Task 0

Description

The command O_V can be used to define the target speed for motion block 0 (direct motion block). The scaling of the speed depends on the PGEARI, PGEARO, PRBASE and O_C parameters.

1. Bit 13 of the motion block control word = 0 (given in internal units)
The speed is given in counts.
Scaling: PRBASE=20 -> 140/32 increments per rpm
PRBASE=16 -> 140/512 increments per rpm

2. Bit 13 of the motion block control variable is = 1 (taking the resolution into account)
The speed is converted according to the following formula:
Speed [increments] = O_P * PGEARO / PGEARI / 4000

Note: If the resolution is set to 1 (PGEARI=PGEARO) then internal units (counts) will be used for the speed.


ASCII English OBJCO

ASCII - Command | OBJCO |
Syntax Transmit | OBJCO |
Syntax Receive | OBJCO <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | Mirror CAN - Objects for debug

Description

The ASCII - object mirrors the CAN - objects. The objects needs up to two parameters. The first parameter represents the Index and the second the Subindex. The Subindex is optional. The subindex is internally set to zero, if no Subindex is given.


ASCII English OCOPY

ASCII - Command | OCOPY |
Syntax Transmit | OCOPY [ - Data] |
Syntax Receive | OCOPY <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer8 Integer8 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0,1,..,180,192..255 | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled (only RAM) / Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Save/copy Motion Tasks

Description

The OCOPY command can be used to copy motion tasks from one storage location to another. The motion block number can have the following values:
0 - direct/local motion block
1 ... 180 motion blocks from the ROM. The ROM motion blocks are stored in a segment of the internal Flash EEPROM. They remain in the amplifier memory even after the 24V supply has been switched off. Write access to these motion blocks is only permitted if the output stage has been disabled.
192 ... 180 motion blocks from the RAM. The RAM motion blocks can also be written while the output stage is enabled. But the contents of these motion blocks will be lost if the 24V supply is switched off. When the controller is switched on, the RAM motion blocks will be initialized with the contents of ROM motion blocks 1 ... 64.

e.g.
OCOPY 0 1 save the local motion block (direct motion block /RAM) as ROM motion task 1
(The output stage must be inhibited while this command is carried out)
OCOPY 1 192 copy the first ROM motion block to the RAM (number 192)
OCOPY 1 - 16 192 copy ROM motion blocks 1 ... 16 to the RAM (192 ... 207)


ASCII English OLIST

ASCII - Command | OLIST |
Syntax Transmit | OLIST [Data] [Data] |
Syntax Receive | OLIST <Data> | Available in |
Type | Multi-line Return Command | MMI | No
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | List of Motion Task Data

Description

The command “OLIST x number” is used to output the contents of “number” motion blocks (= motion orders) one after another, starting with block “x”. The interpretation and sequence of the parameters that are shown corresponds to the parameters of the ORDER command.
If the “number” parameter is missing, then just the contents of motion block “x” will be shown.
If both the “x” and the “number” parameter are missing, then the contents of all the valid motion blocks will be shown (i.e. motion blocks with valid data and correct checksums).


ASCII English OPMODE

ASCII - Command | OPMODE |
Syntax Transmit | OPMODE [Data] |
Syntax Receive | OPMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35B4 (hex)
DIM | - | PROFIBUS PNU | 1780 (dec) IND = 0000xxxx (bin)
Range | 0, 1, .. , 8 | DPR | 180 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Operating Mode

Description

The OPMODE command is used to set the operating mode (basic function) for the amplifier. This operating mode can be changed over at any time, through the fieldbus interface or the digital I/O (INxMODE=24). The following settings are possible:
Status | Short Description | Description
OPMODE=0 | Velocity Control Digital | Digital (rotational) velocity There are different possibilities to generate a velocity setpoint: - RS232 Interface ("J" command) - Fieldbus Interface (PROFIBUS, CANopen, SERCOS, DPR Slot boards) - INxMODE 35 (VCT entry started by I/O)
OPMODE=1 | Velocity Control Analog | Analog (rotational) velocity The velocity setpoint is generated by the analog inputs SW1/SW2. The configuration is done with ANCNFG and INxMODE=8.
OPMODE=2 | Current Control Digital | Digital torque The current setpoint can be generated by: - RS232 Interface ("T" command) - Fieldbus Interface (PROFIBUS, CANopen, SERCOS, DPR Slot boards)
OPMODE=3 | Current Control Analog | Analog torque The current setpoint is generated by the analog inputs SW1/SW2. The configuration is done with ANCNFG and INxMODE=8.
OPMODE=4 | Electronic Gearing (Master/Slave) | Position: electr. gearing The target position is generated by an extrenal encoder. The type of the activated interface is selected by GEARMODE.
OPMODE=5 | External Trajectory | Position: ext. position nodes The target position is generated by fieldbus (PROFIBUS, CANopen or DRP Slot board). The cycle time for writing the new position can be selected with the command PTBASE in 250µs steps. The position controller brings the actual position to the new target postion in the selected time. When using ANCNFG=8, the target position is given by the analog input SW1. The analog voltage is read every 250µs and is used as target position for the position controller. The scaling of the anlog input voltage is done with SRND and ERND. Before this function is active, a homing move has to started.
OPMODE=6 | Sercos Position | SERCOS position control
OPMODE=7 | Reserved |
OPMODE=8 | Motion Tasks | Position: motion blocks This setting allows the swtarting of motion tasks and also the homing moves.


ASCII English OPTION

ASCII - Command | OPTION |
Syntax Transmit | OPTION |
Syntax Receive | OPTION <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35B5 (hex)
DIM | - | PROFIBUS PNU | 1781 (dec) IND = 0000xxxx (bin)
Range | int (=Word) | DPR | 181 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Option Slot ID

Description

The OPTION command returns the identification for the slot card that has been detected. The following IDs are possible at present:
H0000 no slot card detected
H01xx I/O-expansion card
H02xx PROFIBUS
H03xx SERCOS
H06xx DeviceNet
H8100 Beckhoff-Lightbus
H8200 Lenord&Bauer
H8300 Sigmatek

The least significant 8 bits (xx) indicate the hardware revision of the corresponding card.


ASCII English ORDER

ASCII - Command | ORDER |
Syntax Transmit | ORDER [Data1...Data10] |
Syntax Receive | ORDER | Available in |
Type | Command | MMI | No
ASCII Format | Integer32 ... Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 .. 180, 192 .. 255 | DPR | No
Default | - |
Opmode | 8 | Data Type Bus/DPR | -
Drive State | Enabled (only RAM) / Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Set Motion Task Parameters

Description

The ORDER command can be used to define any RAM/ROM motion task (= order). The ORDER command can be used in one of three forms:

ORDER the contents of the direct motion task (nr = 0) are shown
ORDER nr the contents of motion task number “nr” are shown
ORDER nr o_p o_v o_c o_acc1 o_dec1 o_acc2 o_dec2 o_fn o_ft = definition of motion task “nr”

The “nr” parameter specifies the number of the motion task that is to be defined. The motion task number can have the following values:
0 - direct/local motion task
1 ... 180 motion tasks from the ROM. The ROM motion tasks are stored in a segment of the internal Flash EEPROM. They remain in the amplifier memory even after the 24V supply has been switched off. Write access to these motion tasks is only permitted if the output stage has been disabled.
192 ... 255 motion tasks from the RAM. The RAM motion tasks can also be written while the output stage is enabled. But the contents of these motion tasks will be lost if the 24V supply is switched off. When the controller is switched on, the RAM motion tasks will be initialized with the contents of ROM motion tasks 1 ... 64.

The individual elements o_p ... o_ft have the same interpretation as the corresponding ASCII commands.

O_P target position/path for the motion task
O_V target speed/velocity
O_C type of motion task (control word)
O_ACC1 acceleration ramp /starting acceleration
O_DEC1 braking ramp / deceleration
O_ACC2 build-up time for the starting acceleration (>0 for sine² / S-curve)
O_DEC2 build-up time for the deceleration (>0 for sine² / S-curve)
O_FN number of following motion tasks
O_FT delay before starting next motion task


ASCII English OS1

ASCII - Command | OS1 |
Syntax Transmit | OS1 [Data] |
Syntax Receive | OS1 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C7 (hex)
DIM | - | PROFIBUS PNU | 1655 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 455 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Set/Reset of "Posreg1" of the I/O Option Card

Description

The I/O option card has 5 output pins which are normally used to signal on position registers SWE0-4.
OS1 sets the digital output "PosReg1" (terminal 6 of X11B) of the I/O option card.

Set SWCNFG Bit 0 to "0" to disable the appropriate register (SWE1) to reassign the output for use in general purpose mode.

This command allows using the output for general purposes through standard communication channels or through motion tasking.


ASCII English OS2

ASCII - Command | OS2 |
Syntax Transmit | OS2 [Data] |
Syntax Receive | OS2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C8 (hex)
DIM | - | PROFIBUS PNU | 1656 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 456 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Set/Reset of "Posreg2" of the I/O Option Card

Description

The I/O option card has 5 output pins which are normally used to signal on position registers SWE0-4.
OS2 sets the digital output "PosReg2" (terminal 7 of X11B) of the I/O option card.

Set SWCNFG Bit 4 to "0" to disable the appropriate register (SWE2) to reassign the output for use in general purpose mode.

This command allows using the output for general purposes through standard communication channels or through motion tasking.


ASCII English OS3

ASCII - Command | OS3 |
Syntax Transmit | OS3 [Data] |
Syntax Receive | OS3 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36C9 (hex)
DIM | - | PROFIBUS PNU | 1657 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 457 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Set/Reset of "Posreg3" of the I/O Option Card

Description

The I/O option card has 5 output pins which are normally used to signal on position registers SWE0-4.
OS3 sets the digital output "PosReg3" (terminal 8 of X11B) of the I/O option card.

Set SWCNFG Bit 8 to "0" to disable the appropriate register (SWE3) to reassign the output for use in general purpose mode.

This command allows using the output for general purposes through standard communication channels or through motion tasking.


ASCII English OS4

ASCII - Command | OS4 |
Syntax Transmit | OS4 [Data] |
Syntax Receive | OS4 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36CA (hex)
DIM | - | PROFIBUS PNU | 1658 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 458 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Set/Reset of "Posreg4" of the I/O Option Card

Description

The I/O option card has 5 output pins which are normally used to signal on position registers SWE0-4.
OS4 sets the digital output "PosReg4" (terminal 9 of X11B) of the I/O option card.

Set SWCNFG Bit 12 to "0" to disable the appropriate register (SWE4) to reassign the output for use in general purpose mode.

This command allows using the output for general purposes through standard communication channels or through motion tasking.


ASCII English OS5

ASCII - Command | OS5 |
Syntax Transmit | OS5 [Data] |
Syntax Receive | OS5 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36CB (hex)
DIM | - | PROFIBUS PNU | 1659 (dec) IND = 0001xxxx (bin)
Range | 0, 1 | DPR | 459 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Set/Reset of "Posreg5" of the I/O Option Card

Description

The I/O option card has 5 output pins which are normally used to signal on position registers SWE0-4.
OS5 sets the digital output "PosReg5" (terminal 10 of X11B) of the I/O option card.

Set SWCNFG2 Bit 0 to "0" to disable the appropriate register (SWE0) to reassign the output for use in general purpose mode.

This command allows using the output for general purposes through standard communication channels or through motion tasking.


ASCII English OVRIDE

ASCII - Command | OVRIDE |
Syntax Transmit | OVRIDE [Data] |
Syntax Receive | OVRIDE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35B6 (hex)
DIM | - | PROFIBUS PNU | 1782 (dec) IND = 0000xxxx (bin)
Range | 0 .. 3 | DPR | 182 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Override Function for Motion Tasks

Description

The override function can be used to influence the speed/velocity for a motion block through the analog/digital interface. When this function is activated, the analog setpoint is read in every millisecond, and used for scaling the velocity for the motion block.
SW=10V motion block velocity = the target velocity that is programmed in the motion block
SW=5V motion block velocity = 50% of the programmed target velocity

The override function does not work with sin^2 curves.

The following settings are possible:
OVRIDE=0 override function is switched off
OVRIDE=1 SW1 input is activated for the override function
OVRIDE=2 SW2 input is activated for the override function
OVRIDE=3 Digital interface is activated for the override function. The digital Interface can be: Sercos, CAN, PROFIBUS, DPR and all other field busses.


ASCII English P1...P16

ASCII - Command | P1...P16 |
Syntax Transmit | P1 [Data] |
Syntax Receive | P1...P16 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3644 (hex)
DIM | - | PROFIBUS PNU | 1924 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 324 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Fast Position Register 1 ... 16

Description

The variables P1 ... P16 contain the position values for the position thresholds 1 ... 16.
The scaling of the position depends on the PGEARI, PGEARO, PRBASE parameters, and is calculated according to the following formula:

P[increments] = P[entered] * PGEARO / PGEARI

1048576 increments/turn at PRBASE=20
65536 increments/turn at PRBASE=16

see also description of WPOS, WPOSE, WPOSP, WPOSX, POSRSTAT

The object number is given for P1. The other object numbers up to P16 are the next ones.


ASCII English PASS

ASCII - Command | PASS |
Syntax Transmit | PASS [Data] |
Syntax Receive | PASS <Data> | Available in |
Type | w | MMI | No
ASCII Format | Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | -2147483648...2147483647 | DPR | No
Default | 0 |
Opmode |  | Data Type Bus/DPR | Integer32
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group |  | EEPROM |
Short Description | Password Input

Description

This variable defines the value of the password. When the password function is activ (PASSX = y)
the change of parameter is only possible after the setting of a valid password value “PASS y”


ASCII English PASSCNFG

ASCII - Command | PASSCNFG |
Syntax Transmit | PASSCNFG [Data] |
Syntax Receive | PASSCNFG <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36D8 (hex)
DIM |  | PROFIBUS PNU | 1672 (dec) IND = 0001xxxx (bin)
Range | 0,1 | DPR | 472 (dec)
Default | 0 |
Opmode |  | Data Type Bus/DPR | Integer8
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM |
Short Description | Password Function

Description

The command PASSCNFG sets the passwort-function.(see also PASS, PASSX)

PASSCNFG=0 all parameter writing procedures are locked

PASSCNFG=1 only parameter SAVE is locked


ASCII English PASSX

ASCII - Command | PASSX |
Syntax Transmit | PASSX [Data] |
Syntax Receive | PASSX <Data> | Available in |
Type | w | MMI | No
ASCII Format | Integer32 | CANBus Object Number | No
DIM |  | PROFIBUS PNU | No
Range | -2147483648...2147483647 | DPR | No
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | activate password function

Description

PASSX activates the password function
PASSX=0 password function switched off
PASSX=y password function switched on.
The change of all parametera is only possible after the setting of a valid password “PASS y”.


ASCII English PBAL

ASCII - Command | PBAL |
Syntax Transmit | PBAL |
Syntax Receive | PBAL <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C0 (hex)
DIM | W | PROFIBUS PNU | 1792 (dec) IND = 0000xxxx (bin)
Range | 0 .. 1500 | DPR | 192 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Actual Regen Power

Description

The actual value of average regen power.


ASCII English PBALMAX

ASCII - Command | PBALMAX |
Syntax Transmit | PBALMAX [Data] |
Syntax Receive | PBALMAX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C1 (hex)
DIM | W | PROFIBUS PNU | 1793 (dec) IND = 0000xxxx (bin)
Range | see Manual | DPR | 193 (dec)
Default | 80 / 200 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Maximum Regen Power

Description

This parameter can be used to limit the continuous power dissipated in the regen resistor.
If the actual value of the power in the regen resistor exceeds the preset maximum value, then the regen resistor is switched off. This may trigger the fault message “Overvoltage” as a result. If the maximum value is too high, the regen resistor may be overloaded.


ASCII English PBALRES

ASCII - Command | PBALRES |
Syntax Transmit | PBALRES [Data] |
Syntax Receive | PBALRES <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35C2 (hex)
DIM | - | PROFIBUS PNU | 1794 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 194 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Select Regen Resistor

Description

This parameter can be used to select whether the internal (0) or an external (> 0) regen resistor should be used.The value > 0 sets the regen resistor in ohm.
It affects the PBALMAX parameter.


ASCII English PE

ASCII - Command | PE |
Syntax Transmit | PE |
Syntax Receive | PE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C5 (hex)
DIM | µm | PROFIBUS PNU | 1797 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 197 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Actual Following Error

Description

The following error (sometimes called lag error or contouring error) is the momentary difference between the position setpoint and the actual position, and is displayed in the same units as the position control loop (PGEARI / PGEARO).
See description of PFB


ASCII English PEINPOS

ASCII - Command | PEINPOS |
Syntax Transmit | PEINPOS [Data] |
Syntax Receive | PEINPOS <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C6 (hex)
DIM | PUNIT | PROFIBUS PNU | 1798 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 198 (dec)
Default | 4000 |
Opmode | >=4 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | In-Position Window

Description

If the distance between the actual position and the target position during the execution of an internal motion block is less than the window width that has been set, then the In-Position signal is generated (status message, digital output).
The In-Position window is entered in the same units as the position control loop (PGEARI / PGEARO).
See description of PFB


ASCII English PEMAX

ASCII - Command | PEMAX |
Syntax Transmit | PEMAX [Data] |
Syntax Receive | PEMAX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C7 (hex)
DIM | µm | PROFIBUS PNU | 1799 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 199 (dec)
Default | 262144 |
Opmode | >=4 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Max. Following Error

Description

If the momentary following error (PE) goes beyond the maximum value set, the motion block is stopped and the Following Error warning is generated. The motion block can only be continued (CONTINUE) or restarted after the warning has been acknowledged (CLRFAULT, digital input INxMODE=14). PEMAX=0 switches off the following error monitoring.
If a following error occurs, negative values (starting version 4.78) do not result in a stop of the axis. The status bit and warning are still there. A following motion task or new motion task cannot be started until the following error is cleared.


ASCII English PFB

ASCII - Command | PFB |
Syntax Transmit | PFB |
Syntax Receive | PFB <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C8 (hex)
DIM | µm | PROFIBUS PNU | 1800 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 200 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Actual Position from Feedback Device

Description

The PFB command returns the actual value of the position (from the position control loop feedback). The unit for the position value depends on the PGEARI, PGEARO and PRBASE settings.

PFB = Position * PGEARI / PGEARO
whereby:
Position = position value in increments, 1048576/turn for PRBASE=20, 65536/turn for PRBASE=16
PGEARI, PGEARO - resolution of position control loop

Note: If the resolution is set to 1 (PGEARI=PGEARO) then the PFB command provides internal units (counts).

If the position information of an external encoder is evaluated (EXTPOS=1,2,3), then this information can be displayed by using the PFB0 command.


ASCII English PFB0

ASCII - Command | PFB0 |
Syntax Transmit | PFB0 |
Syntax Receive | PFB0 <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35C9 (hex)
DIM | Counts | PROFIBUS PNU | 1801 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 201 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Position from External Encoder

Description

The PFB0 command returns the actual position, calculated from the position information provided by an external encoder. The position is only derived from an external encoder if the configuration variable EXTPOS is set to 1,2,3. The unit for the position value depends on the PGEARI, PGEARO, ENCIN and EXTMUL settings.

PFB0 = Position * PGEARI / PGEARO
whereby:
Position = position value in increments (resolution: EXTMUL per turn)
PGEARI, PGEARO - resolution of position control loop

Note: If the resolution is set to 1 (PGEARI=PGEARO) then the PFB0 command provides internal units (counts).


ASCII English PGEARI

ASCII - Command | PGEARI |
Syntax Transmit | PGEARI [Data] |
Syntax Receive | PGEARI <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CA (hex)
DIM | µm | PROFIBUS PNU | 1802 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 202 (dec)
Default | 10000 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Resolution (Numerator)

Description

The parameter PGEARI is used in conjunction with the PGEARO parameter to convert the control loop position and speed from SI units into increments.
The PGEARO parameter contains the number of increments that are moved if the path to be moved has a length of PGEARI.
The conversion is made according to the following formula:

Position[increments] = Position[SI] * PGEARO / PGEARI
Velocity[increments] = Velocity[SI] * PGEARO / PGEARI / 4000

If PGEARI=PGEARO, then there will be no conversion from SI units into increments. In this case, the position and velocity must be given in increments.

Position: 1046576 increments/turn for PRBASE = 20, or 65536 increments/turn for PRBASE = 16

Velocity: 140/32 * speed in RPM

1. Example

PGEARI = 10000
PGEARO = 1048576
PRBASE = 20

The motion task position should be given in µm with a resolution of 10 mm/rev. The internal resolution of 20 Bit/rev (PRBASE=20) is used. Followind settings have to be made:

Position: 1046576 counts/rev at PRBASE = 20 or 65536 counts/rev at PRBASE = 16.

All settings regarding position (PFB, O_P, PE, PEMAX, PEINPOS) are made in µm, the settings regarding speed/velocity in µm/sec, all settings regarding acceleration in 1000µm/sec²

2. Example

PGEARI = 3600
PGEARO = 65536
PRBASE = 16

The position is given in 0.1 degree steps with a resolution of 360.0 degrees/rev. The internal resolution of 16 Bit/rev (PRBASE = 16) is used. Following settings have to be made:

All settings regarding position (PFB, O_P, PE, PEMAX, PEINPOS) are made in 0.1*degree, the settings regarding speed/velocity in 0.1*degree/sec, all settings regarding acceleration in 1000*0.1*degree/sec²


ASCII English PGEARO

ASCII - Command | PGEARO |
Syntax Transmit | PGEARO [Data] |
Syntax Receive | PGEARO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CB (hex)
DIM | µm | PROFIBUS PNU | 1803 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 203 (dec)
Default | 1048576 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Resolution (Denominator)

Description

The parameter PGEARI is used in conjunction with the PGEARO parameter to convert the control loop position and speed from SI units into increments.
The PGEARO parameter contains the number of increments that are moved if the path to be moved has a length of PGEARI.
The conversion is made according to the following formula:

Position[increments] = Position[SI] * PGEARO / PGEARI
Velocity[increments] = Velocity[SI] * PGEARO / PGEARI / 4000

If PGEARI = PGEARO, then there will be no conversion from SI units into increments. In this case, the position and velocity must be given in increments.

Position: 1046576 increments/turn for PRBASE = 20, or 65536 increments/turn for PRBASE = 16

Velocity: 140/32 * speed in RPM

For an example: see PGEARI


ASCII English PMODE

ASCII - Command | PMODE |
Syntax Transmit | PMODE [Data] |
Syntax Receive | PMODE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35CD (hex)
DIM | - | PROFIBUS PNU | 1805 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 205 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Line Phase Error Mode

Description

The PMODE parameter configures the response of the amplifier to the failure of a mains supply phase.
PMODE=0 no warning, no fault message, current limited to max. 4A
PMODE=1 warning n05, current limited to max. 4A
PMODE=2 fault message F19, output stage is disabled

If the current limiting is activated, it only applies to periods of acceleration. A braking operation can still be carried out at full current.


ASCII English PNOID

ASCII - Command | PNOID |
Syntax Transmit | PNOID |
Syntax Receive | PNOID <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35CE (hex)
DIM | - | PROFIBUS PNU | 1806 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 206 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | PROFIBUS ID

Description

The PNOID command reads out the identification number of the Drive. This number is used for the unique identification of the Drive as a participant in the PROFIBUS network. The ID is allocated and managed by the PROFIBUS User Organization.
This instrument ID is also part of the GSD (base data for the instrument).

PNOID returns the identification number 045D (hexadecimal).


ASCII English POP

ASCII - Command | POP | For Manufacturer Use only
Syntax Transmit | POP time1(msec) time2(msec) |
Syntax Receive | POP <Data> | Available in |
Type | Multi Line Command | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | -
Short Description | Generate Current Step

Description

The POP command is used along with POPI, POPI2 and POPV for giving the drive a current step. The command is only available when MSG = 2. POP is used by the Current Loop Tuning Wizard and other test programs; it is not normally used in applications.

POP time1(msec) time2(msec)

When a POP command is entered, the drive will switch the OPMODE = 2 and step at current level POPI for time1 msec, then at POPI2 for time2 msec. Time2 is optional. At the end of the full period, control will return to the prior OPMODE. POPV limits the maximum velocity during the current step - if velocity reaches the POPV limit, the POP command will be canceled.


ASCII English POPI

ASCII - Command | POPI | For Manufacturer Use only
Syntax Transmit | POPI [Data] |
Syntax Receive | POPI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | A | PROFIBUS PNU | No
Range | -DIPEAK .. DIPEAK | DPR | No
Default | 0 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | No
Short Description | Current Level for POP Command

Description

POPI gives the current level for the current step command POP. The value is in amps. POPI is used by the Current Loop Tuning Wizard and other test programs; it is not normally used in applications.

See also: POP, POPI2, POPV


ASCII English POPI2

ASCII - Command | POPI2 | For Manufacturer Use only
Syntax Transmit | POPI2 [Data] |
Syntax Receive | POPI2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | A | PROFIBUS PNU | No
Range | -DIPEAK .. DIPEAK | DPR | No
Default | 0 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | No
Short Description | Current Level for POP Command

Description

POPI2 gives the current level for the second stage of the current step command POP. The value is in amps. POPI2 is used by the Current Loop Tuning Wizard and other test programs; it is not normally used in applications.

See also: POP, POPI, POPV


ASCII English POPV

ASCII - Command | POPV | For Manufacturer Use only
Syntax Transmit | POPV [Data] |
Syntax Receive | POPV <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | No
DIM | A | PROFIBUS PNU | No
Range | -VLIM .. VLIM | DPR | No
Default | 0 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | No
Short Description | Max. Speed Level for POP Command

Description

POPV limits the maximum velocity during a POP current step - if velocity reaches the POPV limit, the POP command will be canceled. POPV is used by the Current Loop Tuning Wizard and other test programs; it is not normally used in applications.

See also: POP, POPI, POPI2


ASCII English POSCNFG

ASCII - Command | POSCNFG |
Syntax Transmit | POSCNFG [Data] |
Syntax Receive | POSCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35CF (hex)
DIM | - | PROFIBUS PNU | 1807 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 207 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Axes Type

Description

Use the axis type to select whether the axis is treated as a linear or rotary axis. This variable does not imply that the motor is a linear or rotary motor, but instead, affects the way the software limit switches are used by the Firmware. The software limit switches are treated in different ways, depending on the selection. The possible settings are:
POSCNFG=0 | Linear Axes | Axes with a limited range of movement. The zero position for position tracking is fixed by a homing operation. With this setting, a set reference point is a precondition to be able to implement motion blocks. After the homing movement (setting the reference point) has been completed, the position is continuously tracked for the control loop, and remains valid until the amplifier is switched off.
POSCNFG=1 | Modulo Axis | Axes with a limited range of movement. The minimum position is SRND and the maximum position is ERND-1. If the maimum position ERND-1 is reached, it automatically switches over to SRND. The absolute target positions have to be in the defined range. If a motion task is startet, which has a absolute position outside the range, a warning "n08" is displayed (wrong motion task). Relative moves are calculated in a way, that the target position always is in the defined range. A positioning in a axes like this, gives two possibilities of direction to the target position. DREF gives the possibility to restrict the direction. This axes type also needs a homing move.


ASCII English POSRSTAT

ASCII - Command | POSRSTAT |
Syntax Transmit | POSRSTAT [Data] |
Syntax Receive | POSRSTAT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3643 (hex)
DIM | - | PROFIBUS PNU | 1923 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 323 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Status of Fast Position Registers 1 ... 16

Description

The variable POSRSTAT returns the present status of the fast position registers.
This variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the status information of position registers P1 ... P16.
Bit=0 position signaling inactive
Bit=1 position signaling active (position overrun for WPOSP=0 or underrun for WPOSP=1).

See also WPOS


ASCII English PPOTYP

ASCII - Command | PPOTYP |
Syntax Transmit | PPOTYP |
Syntax Receive | PPOTYP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35D0 (hex)
DIM | - | PROFIBUS PNU | 1808 (dec) IND = 0000xxxx (bin)
Range | 2 | DPR | 208 (dec)
Default | 2 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | Yes
Short Description | Profibus PPO Type

Description

PPOTYP reads the PROFIBUS DP telegram type. The amplifier supports telegram type 2 (telegram consists of 10 words (20 bytes) and is divided into a PKW section (4 words) and a PZD section (6 words)). PPOTYP returns the value, 2.


ASCII English PRBASE

ASCII - Command | PRBASE |
Syntax Transmit | PRBASE [Data] |
Syntax Receive | PRBASE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35D1 (hex)
DIM | - | PROFIBUS PNU | 1809 (dec) IND = 0000xxxx (bin)
Range | 16, 20 | DPR | 209 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position Resolution

Description

PRBASE changes the internal position resolution between 16 and 20 bits/turn. The resolution is only activated when the amplifier is switched off and then on again. The actual position is 32-bits wide. This setting dictates how many shaft revolutions are registered.

20 bits incremental/turn 0 to 1048575
Maximum path length (absolute) ±2047 turns

16 bits incremental/turn 0 to 65535
Maximum path length (absolute) ±32767 turns

When PRBASE is changed, PGEARO is automatically adjusted.
Change from 16 to 20 bit: PGEARO = PGEARO * 16
Change from 20 to 16 bit: PGEARO = PGEARO / 16
See PGEARO and PGEARI for additional details.


ASCII English PRD

ASCII - Command | PRD |
Syntax Transmit | PRD |
Syntax Receive | PRD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D2 (hex)
DIM | Counts | PROFIBUS PNU | 1810 (dec) IND = 0000xxxx (bin)
Range | 0 .. 1048575 | DPR | 210 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | 20-bit Position Feedback

Description

The PRD command returns a 20-bit position (absolute within one turn) that is derived from the signals of the feedback device (FBTYPE). Unlike the position from the position control loop, PFB, this position cannot be altered.
PRD is not related to PRBASE


ASCII English PROMPT

ASCII - Command | PROMPT |
Syntax Transmit | PROMPT [Data] |
Syntax Receive | PROMPT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35D3 (hex)
DIM | - | PROFIBUS PNU | 1811 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3 | DPR | 211 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | Select RS232 Protocol

Description

The PROMPT parameter can be used to set the protocol for the RS232 transmission. The following settings are possible:
PROMPT=0 | No Echo | The data that are received through the RS232 interface are not automatically echoed (transmitted). There is no output of the prompt (-->) symbol.
PROMPT=1 | "-->" plus Echo | The data that are received through the RS232 interface are automatically echoed (transmitted). The prompt (-->) symbol is given for inputting data.
PROMPT=2 | Terminal Mode | This setting is the same as PROMPT=1 except: 1. If a CR(Enter) command is typed in at the beginning of the line, the last command is repeated. 2. Some commands (like DUMP) output more than one monitor screen. In this cases, the output is automatically stopped after one page.
PROMPT=3 | "-->" plus Echo plus Checksum | This setting is the same as PROMPT=1 except. Additional to that, a Checksum is transmitted and checked in both directions to prevent wrong data. All character of a command are summed (Modulo 256 without CR). e.g. Command string : "ADDR 1<CR>" generate Checksum: "A" = 0x41 "D" = 0x44 "D" = 0x44 "R" = 0x52 " " = 0x20 "1" = 0x31 The sum is: 0x16C Modulo 256: 0x6C = 108 (Dec) First Character: 108/16 + 0x30 =0x36 = "6" Sec. Character: 108%16 + 0x30 = 0x3C = "<" The command string is: "ADDR 16<" <CR> When the command string is received, that same calculation is done and the last two characters in front of the <CR> are compared with the received data. If the checksum is ok, the ACK (0x06) is send, if no NACK (0x15) is send.


ASCII English PSTATE

ASCII - Command | PSTATE |
Syntax Transmit | PSTATE |
Syntax Receive | PSTATE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 35D4 (hex)
DIM | - | PROFIBUS PNU | 1812 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 212 (dec)
Default | - |
Opmode | - | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | No
Short Description | Profibus Status

Description

The command PSTATE reads out the present status of the PROFIBUS communication. The first value that is shown provides the SPC3 WATCHDOG status, the second value provides the PROFIBUS DP-status.
SPC3 WATCHDOG status
0 = baud rate search
1 = check baud rate
2 = DP mode, i.e. the bus watchdog is active

PROFIBUS-DP status
0 = wait for parameterization, performed by the master
1 = wait for configuration, performed by the master
2 = data exchange
3 = fault – the cause could, for instance, have been a faulty parameterization telegram in the data transfer phase.

Productive data can only be received, i.e. data exchanged for the PKW and PZD sections of the Drive, when the SPC3 WATCHDOG status has the value 2, and the PROFIBUS-DP status has the value 2.


ASCII English PTARGET

ASCII - Command | PTARGET |
Syntax Transmit | PTARGET |
Syntax Receive | PTARGET <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3654 (hex)
DIM | - | PROFIBUS PNU | 1940 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 340 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Last Target Position

Description

The command PTARGET can be used to request the target position for the last motion task that was started (and possibly already interrupted). This position is accepted as a new target position, as soon as the CONTINUE command is executed (to continue the last motion task).


ASCII English PTBASE

ASCII - Command | PTBASE |
Syntax Transmit | PTBASE [Data] |
Syntax Receive | PTBASE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35D5 (hex)
DIM | - | PROFIBUS PNU | 1813 (dec) IND = 0000xxxx (bin)
Range | 1 .. 127 | DPR | 213 (dec)
Default | 4 (1 msec) |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Time base for the external trajectory

Description

IN PREPARATION !

The PTBASE parameter is used to define the interpolation time for the external trajectory (OPMODE=5). The time is set in 250 microsecond steps, and defined the time period in which the drive should reach the next position setpoint. Since the internal position control loop works in 250 microsecond steps, an interpolation of the given position setpoint (external trajectory) is also given in 250 microsecond steps.


ASCII English PTEACH

ASCII - Command | PTEACH |
Syntax Transmit | PTEACH [Data] |
Syntax Receive | PTEACH <Data> | Available in |
Type | Command | MMI | No
ASCII Format | Integer8 Integer8 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0,1,..,180,192 .. 255 | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled (only RAM) / Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Teach-In Function

Description

The command PTEACH can be used to accept the present position (from the position control loop) as the target position for a motion block.

Syntax: PTEACH QNR [ZNR]
QNR – Number of the source motion block
ZNR – Number of the target motion block

With the PTEACH command, the motion task ZNR is loaded in to a buffer store, the actual position is entered as the target position, and the complete motion task is written to the memory location for ZNR. If the number ZNR is not entered, then the motion task is written back to the memory location for QNR.
When the actual position is accepted, it depends on the state of O_C bit 13, if the position is calculated either in increments (bit 13 =0) or as SI units (bit 13 =1).
If the number of the target motion task is within the Flash EEPROM range (1 ... 180) then the PTEACH command is only permitted while the output stage is disabled.


ASCII English PTMIN

ASCII - Command | PTMIN |
Syntax Transmit | PTMIN [Data] |
Syntax Receive | PTMIN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35D6 (hex)
DIM | >> ACCUNIT | PROFIBUS PNU | 1814 (dec) IND = 0000xxxx (bin)
Range | 1 .. 32767 | DPR | 214 (dec)
Default | 10 |
Opmode | 8 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Min. Acceleration Ramp for Motion Tasks

Description

The minimum acceleration ramp PTMIN defines the minimum time that is permitted for a velocity change from 0 to PVMAX. Regardless of how the acceleration value is entered (milliseconds, SI units), the acceleration that is used is limited to PVMAX / PTMIN at the start of a motion task.
With the help of the PVMAX and PTMIN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.


ASCII English PUNIT

ASCII - Command | PUNIT |
Syntax Transmit | PUNIT [Data] |
Syntax Receive | PUNIT <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3660 (hex)
DIM | - | PROFIBUS PNU | 1952 (dec) IND = 0000xxxx (bin)
Range | 0 .. 10 | DPR | 352 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Set Resolution of the Position

Description

PUNIT enables a systemwide setting for the unit of position for the position controller. The following settings are possible:

PUNIT=0 internal Unit (user specific)
PUNIT=1 1 dm (0.1 m)
PUNIT=2 1 cm (0.01 m)
PUNIT=3 1 mm
PUNIT=4 0.1 mm
PUNIT=5 0.01 mm
PUNIT=6 1 µm
PUNIT=7 0.1 µm
PUNIT=8 0.01 µm
PUNIT=9 1 nm
PUNIT=10 0.1 nm

The parameter PUNIT is only used for the MMI. It calculates different units for the MMI. All internal calculations (position controller resolution PGEARI and motion tasks are not effected.

IF PUNIT=0 there is no difference to older firmware versions. The unit is defined only by PGEARI.

e.g: PGEARI=360 (Unit = Degree)
PGEARI=3600 (Unit= 0.1 Degree)


ASCII English PV

ASCII - Command | PV |
Syntax Transmit | PV |
Syntax Receive | PV <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D7 (hex)
DIM | VUNIT | PROFIBUS PNU | 1815 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 215 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Actual Velocity (Position Control Loop)

Description

The actual velocity (position control loop) can be requested by using the PV command.
The scaling of the velocity depends on the PGEARI, and PGEARO parameters.


ASCII English PVMAXN

ASCII - Command | PVMAXN |
Syntax Transmit | PVMAXN [Data] |
Syntax Receive | PVMAXN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D9 (hex)
DIM | VUNIT | PROFIBUS PNU | 1817 (dec) IND = 0000xxxx (bin)
Range | 0 .. VLIM | DPR | 217 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Max. (Negative) Velocity for Position Control

Description

The parameter PVMAXN defines the maximum velocity (in the negative direction) that is permitted for a motion task. When a motion task is started, the target velocity for the motion task is limited to the value of PVMAXN.
When the maximum velocity for the positive direction (PVMAX) is defined, the PVMAXN parameter is set to the PVMAX value at the same time. So, if a separate setting is required for the negative direction of movement, the value for PVMAXN must be entered separately, afterwards.
With the help of the PVMAX, PTMIN and PVMAXN parameters it is possible to control the behavior of the system, especially during the commissioning phase, without having to alter the individual motion tasks.


ASCII English PVMAXP

ASCII - Command | PVMAXP |
Syntax Transmit | PVMAX [Data] |
Syntax Receive | PVMAXP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35D8 (hex)
DIM | VUNIT | PROFIBUS PNU | 1816 (dec) IND = 0000xxxx (bin)
Range | 0 .. VLIM | DPR | 216 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Max. Velocity for Position Control

Description

-


ASCII English RDP

ASCII - Command | RDP |
Syntax Transmit | RDP [Data] |
Syntax Receive | RDP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Char | CANBus Object Number | 36B7 (hex)
DIM | - | PROFIBUS PNU | 2039 (dec) IND = 0000xxxx (bin)
Range | 0 .. 2 | DPR | 439 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Char
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | Yes
Short Description | Activate Racjk Drive Panel Mode

Description

IN PREPARATION !

RDP is used to enable RDP (Rack Drive Panel anti-backlash control) and to select the RDP operating mode. See the Application Note “Rack Drive Panel (RDP):
Controlling Backlash” for more information.

0 RDP disabled; normal operation of the amplifier.
1 RDP mode enabled; Enable mode = “Fault Disables Other Drive.”
2 RDP mode enabled; Enable mode = “Fault Forces Other Drive From RDP.”

See also: RDPBIAS, RDPCLAMP, RDPKI, RDPKP, RDPON, RDPINT


ASCII English RDPBIAS

ASCII - Command | RDPBIAS |
Syntax Transmit | RDPBIAS [Data] |
Syntax Receive | RDPBIAS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36B8 (hex)
DIM | Amp | PROFIBUS PNU | 2040 (dec) IND = 0000xxxx (bin)
Range | 0 .. ICONT | DPR | 440 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | Yes
Short Description | Rack Drive Panel Bias Current

Description

IN PREPARATION !

The RDP bias current in Amps. Normally set at 25% - 50% of ICONT. Set positive in one drive and negative in the other.

See also: RDP


ASCII English RDPCLAMP

ASCII - Command | RDPCLAMP |
Syntax Transmit | RDPCLAMP [Data] |
Syntax Receive | RDPCLAMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36B9 (hex)
DIM | Rpm | PROFIBUS PNU | 2041 (dec) IND = 0000xxxx (bin)
Range | 0 .. VLIM | DPR | 441 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | Yes
Short Description | Max. Velocity Offset of the Rack Drive Panel Circuit

Description

IN PREPARATION !

Maximum output of the RDP equalization circuit in rpm. Normally set at 50 rpm in the master drive. Set to 0 in the slave drive.

See also: RDP


ASCII English RDPINT

ASCII - Command | RDPINT |
Syntax Transmit | RDPINT |
Syntax Receive | RDPINT <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 36BA (hex)
DIM | - | PROFIBUS PNU | 2042 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 442 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | No
Short Description | Rack Drive Panel Test Variable

Description

IN PREPARATION !

Rack Drive Panel test variable. Equals the integral value of the Rack Drive Panel equalization circuit. Scaled for 9000000 = 1 rpm (this is 9 million = 1 rpm). Limited by RDCLAMP (scaled in rpm).

See also RDP


ASCII English RDPKI

ASCII - Command | RDPKI |
Syntax Transmit | RDPKI [Data] |
Syntax Receive | RDPKI <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36BB (hex)
DIM | - | PROFIBUS PNU | 2043 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 443 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | Yes
Short Description | Integral gain of Rach Drive Panel

Description

IN PREPARATION !

Integral Gain of the RDP equalization circuit. Normally set at 13 in the master drive. Set to 0 in the slave drive.

See also RDP


ASCII English RDPKP

ASCII - Command | RDPKP |
Syntax Transmit | RDPKP [Data] |
Syntax Receive | RDPKP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 36BC (hex)
DIM | - | PROFIBUS PNU | 2044 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 444 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | Yes
Short Description | Proportional Gain of Rach Drive Panel

Description

IN PREPARATION !

Proportional Gain of equalization circuit. Normall set at 300 in the master drive. Set to 0 in the slave drive.

See also RDP


ASCII English RDPON

ASCII - Command | RDPON |
Syntax Transmit | RDPON |
Syntax Receive | RDPON <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 36BD (hex)
DIM | - | PROFIBUS PNU | 2045 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 445 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Rack Drive Panel | EEPROM | No
Short Description | Test Variable Rack Drive Panel

Description

IN PREPARATION !

Rack Drive Panel test variable. Will read 1 only when Rack Drive Panel is active, otherwise 0.

See also RDP


ASCII English READNIMP

ASCII - Command | READNIMP |
Syntax Transmit | READNIMP |
Syntax Receive | READNIMP | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 35DC (hex)
DIM | - | PROFIBUS PNU | 1820 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 220 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | -
Short Description | Read/Set the EEO (ROD) Zero-Pulse Offset

Description

READNIMP calculates the actual position, depending on the resolution set for the Encoder Equivalent Output (EEO), and enters it as the ENCZERO variable. This function ensures that the Encoder Equivalent Output (EEO) zero-pulse is always generated at the actual position (within a single turn). If this setting is to be permanently accepted, use the SAVE command (save in the serial EEPROM).


ASCII English READY

ASCII - Command | READY |
Syntax Transmit | READY |
Syntax Receive | READY <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DD (hex)
DIM | - | PROFIBUS PNU | 1821 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 221 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Status of the Software Enable

Description

Requests the status of the internal software enable.
READY = 0 Disabled
READY = 1 Enabled


ASCII English RECDONE

ASCII - Command | RECDONE |
Syntax Transmit | RECDONE |
Syntax Receive | RECDONE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DE (hex)
DIM | - | PROFIBUS PNU | 1822 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 222 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | No
Short Description | Scope: Recording Done

Description

The RECDONE command can be used to request the status of the SCOPE recording. The command returns a 1 if the recording is finished and the data can now be requested with the GET command.


ASCII English RECING

ASCII - Command | RECING |
Syntax Transmit | RECING |
Syntax Receive | RECING <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35DF (hex)
DIM | - | PROFIBUS PNU | 1823 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 223 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | No
Short Description | Scope: Recording in Progress

Description

Returns a 1 if the recording is active. At the end of a recording, or if the recording has not started, a 0 is returned.


ASCII English RECOFF

ASCII - Command | RECOFF |
Syntax Transmit | RECOFF |
Syntax Receive | RECOFF | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35E0 (hex)
DIM | - | PROFIBUS PNU | 1824 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 224 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Scope: Cancel Scope Recording

Description

RECOFF stops the SCOPE recording (if started). State after RECOFF: RECRDY=1, RECING=0, RECDONE=0.


ASCII English RECORD

ASCII - Command | RECORD |
Syntax Transmit | RECORD [Data] |
Syntax Receive | RECORD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 1 .. 10000 (=Time);1 .. 1024(=Points); ASCII String (=Var) | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | No
Short Description | Scope: Capture Data for Recording

Description

The RECORD command can be used to define the data for the next SCOPE recording. The command is used in the following form.

RECORD time number var1 [var2] [var3] [var4]

time: the sampling interval in 250 microsecond steps
number: the number of sample points to be recorded.
The maximum possible number depends on the number and size of the variables to be recorded.
If the number entered is too large, it will automatically be limited (when recording Long/Float variables, a maximum of 512 sample points can be recorded).
var1,var2,var3 - names of the variables to be recorded. Apart from the names for macro variables, the following names can be used.
I - actual value of current
ICMDVAL - setpoint for current
PE - following error
V - actual value of velocity
VCMD - setpoint for velocity
VBUS - DC-bus (DC-link) voltage
PFB - actual position


ASCII English RECRDY

ASCII - Command | RECRDY |
Syntax Transmit | RECRDY |
Syntax Receive | RECRDY <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35E1 (hex)
DIM | - | PROFIBUS PNU | 1825 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 225 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oszilloscope | EEPROM | No
Short Description | Scope: Status of RECORD Function

Description

After the recording has been made trigger-ready by RECORD / RECTRIG, the RECRDY command generates a 0. As soon as the trigger condition defined by RECRDY is fulfilled, and the recording starts, RECRDY generates a 1.
(RECRDY=0 means “waiting for trigger event”)


ASCII English RECTRIG

ASCII - Command | RECTRIG |
Syntax Transmit | RECTRIG [Data] |
Syntax Receive | RECTRIG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | ASCII String (=Mode);Depends upon Mode (=Level);0 .. 1023 (=Loc.); 0, 1 (=Dir.) | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | No
Short Description | Scope: Activate Recording Function

Description

The RECTRIG command prepares the SCOPE function for a data recording.
The command is used in the following form.

RECTRIG mode level location direction

mode: designates the name of a variable that is to be used to trigger the recording. If the designation IMM is used, the recording starts immediately. In this case, the parameters “level”, “location” and “direction” do not have to be specified.

level: specifies the value of the variable that has to be reached to trigger the recording.

location: give the number of points that are to be recorded previous to the moment of the trigger event.

direction: specifies in which direction the value must pass the threshold “level” of the “mode” variable in order to trigger the recording.
direction=0 falling (variable value falls below threshold level)
direction=1 rising (variable value goes above threshold level)


ASCII English REFIP

ASCII - Command | REFIP |
Syntax Transmit | REFIP [Data] |
Syntax Receive | REFIP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 35E2 (hex)
DIM | Amperes | PROFIBUS PNU | 1826 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. min(IPEAK,IPEAKN) | DPR | 226 (dec)
Default | min(IPEAK,IPEAKN,DICONT/2) |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Current Controller | EEPROM | Yes
Short Description | Peak Rated Current for Homing 7

Description

The REFIP parameter can be used to set the peak current for homing to a stop. When Homing mode 7 is started (homing to a stop and searching for a zero mark), IPEAK, the normal value for peak current, is set to the value REFIP. When the homing movement is finished, the IPEAK parameter is reset to the previous (normal) value.

This parameter is also used to reduce the current for Wake&Shake mode (FBTYPE=7). If the wake&shake mode is started, IPEAK is set to REFIP. After the mode is stopped, automatically the old IPEAK value is used.


ASCII English REFLS

ASCII - Command | REFLS |
Syntax Transmit | REFLS [Data] |
Syntax Receive | REFLS <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 365D (hex)
DIM | - | PROFIBUS PNU | 1949 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3 | DPR | 349 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Behavior of the Hardware Limit switches at Homing Move

Description

REFLS defines the behavior of the hardware limit switch processing at homing move.

REFLS=0 Change direction at NSTOP and PSTOP
REFLS=1 Change direction at PSTOP, create error message F26 (limit switch) at NSTOP
REFLS=2 Change direction at NSTOP, create error message F26 (limit switch) at PSTOP
REFLS=3 Create error message F26 (limit switch) at NSTOP and PSTOP

Can be used for homing mode 1 and 3


ASCII English REFMODE

ASCII - Command | REFMODE |
Syntax Transmit | REFMODE [Data] |
Syntax Receive | REFMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 363C (hex)
DIM | - | PROFIBUS PNU | 1916 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3, 4, 5, 6, 7 | DPR | 316 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Source of the Zero Pulse in Homing Mode

Description

The command REFMODE selects the source of the zero pulse in homing mode.

REFMODE=0 Resolver- or singleturn encoder-zero, Zero crossing per rev of a multiturn encoder / at EXTPOS=1 Data-Pin X1-connector
REFMODE=1 digital INPUT1
REFMODE=2 digital INPUT2
REFMODE=3 digital INPUT3
REFMODE=4 digital INPUT4
REFMODE=5 Data-Pin of X1-Connector
REFMODE=6 Zero pulse of the connector X5
REFMODE=7 Zero crossing of the absolute multiturn encoder (per rev)


ASCII English REFPOS

ASCII - Command | REFPOS |
Syntax Transmit | REFPOS |
Syntax Receive | REFPOS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35E3 (hex)
DIM | Counts | PROFIBUS PNU | 1827 (dec) IND = 0000xxxx (bin)
Range | 0 .. 1048575 | DPR | 227 (dec)
Default | - |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Reference Switch Position

Description

The REFPOS command returns the position (20-bit, within one turn) to be used for detecting the “Reference criterion” during the homing movement. The “Reference criterion” depends on NREF, the type of homing movement.

NREF=0,5,6 REFPOS = position for starting the homing movement
NREF=1,3 REFPOS = position for detecting the rising edge of the reference switch
NREF=2,4 REFPOS = position for detecting the falling edge of the reference switch
NREF=7 REFPOS = position for detecting a stop (PE>PEMAX / 2)
NREF=8 REFPOS is not altered


ASCII English REMOTE

ASCII - Command | REMOTE |
Syntax Transmit | REMOTE |
Syntax Receive | REMOTE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35E4 (hex)
DIM | - | PROFIBUS PNU | 1828 (dec) IND = 0000xxxx (bin)
Range | 0 .. 1 | DPR | 228 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Status of the Hardware Enable

Description

The REMOTE command indicates the state of the hardware enable input .
A 1 indicates a High state of the inputs (hardware enable is set), a 0 indicates a Low state.


ASCII English RESOLVER

ASCII - Command | RESOLVER |
Syntax Transmit | RESOLVER [Data] |
Syntax Receive | RESOLVER <Data> | Available in |
Type | rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | No
DIM |  | PROFIBUS PNU | No
Range | 0 ... 2 | DPR | No
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Resolver excitation gain adjust +/- 20%

Description

RESOLVER 0 will reduce the excitation by 20%.
RESOLVER 2 will increase the excitation by 20%.


ASCII English RESPHASE

ASCII - Command | RESPHASE |
Syntax Transmit | RESPHASE [Data] |
Syntax Receive | RESPHASE <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E5 (hex)
DIM | - | PROFIBUS PNU | 1829 (dec) IND = 0000xxxx (bin)
Range | -300 .. 50 | DPR | 229 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Resolver Phase

Description

The resolver RESPHASE parameter is defined as the phase shift between the excitation signal and the modulated output sin- and cos- signals, related to 8 kHz modulation excitation signal.

The effective adjustable range of this parameter is between –50 and 50 degree. One special case is RESPHASE = -300, to ensures the compatibility for the hardware version using Sipex A/D converter ( Serialno <= xxx230000 ).

The default value of RESPHASE equals zero and the real value can be determined by starting the ASCII command CALCRP. Please refer to the ASCII command CALCRP.


ASCII English RK

ASCII - Command | RK |
Syntax Transmit | RK [Data] |
Syntax Receive | RK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E6 (hex)
DIM | Counts | PROFIBUS PNU | 1830 (dec) IND = 0000xxxx (bin)
Range | 12000 ..19000 | DPR | 230 (dec)
Default | 16384 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Gain Adjust for Resolver Sine Signal

Description

The RK parameter can be used to correct any amplitude difference that may exist between the sine and cosine signals from the resolver. The relationships are as follows:
RK = 16384 no alteration of the amplitude of the sine signal
RK < 16384 sine signal amplitude is reduced
RK > 16384 sine signal amplitude is increased

An incorrect setting of this correction factor will result in velocity/velocity variations (ripple) which are strongly dependent on the position.
The CALCRK command enables an automatic determination of the correction factor RK.

This value will not be changed by a parameter download, since it only depends on the equipment.


ASCII English ROFFS

ASCII - Command | ROFFS |
Syntax Transmit | ROFFS [Data] |
Syntax Receive | ROFFS | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35E7 (hex)
DIM | µm | PROFIBUS PNU | 1831 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 231 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Reference Offset

Description

The ROFFS parameter can have various functions, depending on the type of position sensor that is used for the position control loop.

1. Resolver or single-turn encoder (homing to reference point is possible)
The ROFFS parameter can be used to assign a freely chosen absolute position as the reference position (zero position) that will be reached at the end of a homing movement.
The scaling of the position depends on the settings for PGEARI, PGEARO, PRBASE.
If the resolution is set to 1 (PGEARI=PGEARO), then internal units (counts) will be used.

2. Absolute encoder (multi-turn, homing to reference point is also possible)
If the position value of the absolute encoder is to be altered, this can be done with the help of the ROFFS variable. When the amplifier is switched on, the value of the ROFFS variable is added once to the position value of the absolute encoder. Since this correction is only made when the amplifier is switched on, the parameter value must be saved in the EEPROM (using the SAVE command) after every alteration of the ROFFS variable, and the amplifier must then be switched off and on again (COLDSTART command).

Example:
If a position 10000 is shown when the amplifier is switched on, with ROFFS=0, then entering ROFFS –10000 will shift the position to the value 0.


ASCII English ROFFS0

ASCII - Command | ROFFS0 |
Syntax Transmit | ROFFS0 [Data] |
Syntax Receive | ROFFS0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 365C (hex)
DIM | - | PROFIBUS PNU | 1948 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 348 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Reference Offset for the second Encoder Feedback

Description

The command ROFFS0 is a reference position of the second encoder. The position is set to this position, when a successful homing move is done. After the homing move, external position can be read by PFB0. This function is only available in mode EXTPOS 2 and 3.


ASCII English ROFFS2

ASCII - Command | ROFFS2 |
Syntax Transmit | ROFFS2 [Data] |
Syntax Receive | ROFFS2 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3656 (hex)
DIM | PUNIT | PROFIBUS PNU | 1942 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 342 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Gearing | EEPROM | Yes
Short Description | Position offset for "absolute Gearing"

Description

IN PREPARATION !

This parameter gives an offset to the absolute SSI-position of the master, read by the slave. This parameter is only used while starting the refernce move NREF=8 (move to absolute position). Starting the reference move, the absolute SSI position (GEARMODE=7) is read by the slave using the resolution PGEARI / PGEARO. The ROFFS2 offset is added then and move to this target position is startet.


ASCII English RS232T

ASCII - Command | RS232T |
Syntax Transmit | RS232T [Data] |
Syntax Receive | RS232T <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35E8 (hex)
DIM | Milliseconds | PROFIBUS PNU | 1832 (dec) IND = 0000xxxx (bin)
Range | 1 .. 5000 | DPR | 232 (dec)
Default | 2500 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Communication | EEPROM | Yes
Short Description | RS232 Watch Dog

Description

If the monitoring of the serial interface is activated (RS232 watchdog), then the RS232T command can be used to set the time for the watchdog timer.
See also ACTRS232


ASCII English RSTVAR

ASCII - Command | RSTVAR |
Syntax Transmit | RSTVAR |
Syntax Receive | RSTVAR | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35E9 (hex)
DIM | - | PROFIBUS PNU | 1833 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 233 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | No
Short Description | Restore Variables (Default Values)

Description

The RSTVAR command resets all parameters/variables to the internal works (default) settings. The parameters which are stored in the EEPROM are not immediately affected by this. The default settings only become permanent when the SAVE command is used (save parameters in the EEPORM).


ASCII English RXPDO1A

ASCII - Command | RXPDO1A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO1A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 1 parameter selection

Description

By the command RXPDO1A the listed CANopen-PDO RX-PDO 1
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Receive-PDO 1 (2600, 0), decimal
2. COB-Identifier for Receive-PDO 1 (1400, 1), hexadecimal
3. Transmission type for Receive-PDO 1 (1400, 2), decimal
4. Inhibit time for Receive-PDO 1 (1400, 3), decimal
5. Priority group for Receive-PDO 1 (1400, 4), decimal
example

Read the actual status: Command: RXPDO1A
Write: Command: RXPDO1A 1 0x201 255 0 2, all parameter have to be set


ASCII English RXPDO1B

ASCII - Command | RXPDO1B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO1B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 1 Mapping Settings

Description

The CANopen-PDOs TX-PDO 1mapping can be set by the command RX PDO 1 (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by RXPDO1A.
To read the actual mapping the command has to be set to: RXPDO1B
The mapping form is: 6040002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (for the exampel 6040)
yy Hex-number for SDO subindex (for the exampel 00)
z number for byte quantity in SDO setting (for the exampel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO1B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 1.


ASCII English RXPDO2A

ASCII - Command | RXPDO2A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO2A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 2 parameter selection

Description

By the command RXPDO2A the listed CANopen-PDO RX-PDO 2
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Receive-PDO 2 (2600, 0), decimal
2. COB-Identifier for Receive-PDO 2 (1400, 1), hexadecimal
3. Transmission type for Receive-PDO 2 (1400, 2), decimal
4. Inhibit time for Receive-PDO 2 (1400, 3), decimal
5. Priority group for Receive-PDO 2 (1400, 4), decimal
example

Read the actual status: Command: RXPDO2A
Write: Command: RXPDO2A 1 0x201 255 0 2, all parameter have to be set


ASCII English RXPDO2B

ASCII - Command | RXPDO2B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO2B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 2 Mapping Settings

Description

The CANopen-PDOs TX-PDO 2mapping can be set by the command RX PDO 2 (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by RXPDO2A.
To read the actual mapping the command has to be set to: RXPDO2B
The mapping form is: 6040002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (for the exampel 6040)
yy Hex-number for SDO subindex (for the exampel 00)
z number for byte quantity in SDO setting (for the exampel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO2B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 2.


ASCII English RXPDO3A

ASCII - Command | RXPDO3A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO3A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 3 parameter selection

Description

By the command RXPDO3A the listed CANopen-PDO RX-PDO 3
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Receive-PDO 3 (2600, 0), decimal
2. COB-Identifier for Receive-PDO 3 (1400, 1), hexadecimal
3. Transmission type for Receive-PDO 3 (1400, 2), decimal
4. Inhibit time for Receive-PDO 3 (1400, 3), decimal
5. Priority group for Receive-PDO 3 (1400, 4), decimal
example

Read the actual status: Command: RXPDO3A
Write: Command: RXPDO3A 1 0x201 255 0 2, all parameter have to be set


ASCII English RXPDO3B

ASCII - Command | RXPDO3B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO3B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 3 Mapping Settings

Description

The CANopen-PDOs TX-PDO 3 mapping can be set by the command RX PDO 3 (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by RXPDO3A.
To read the actual mapping the command has to be set to: RXPDO3B
The mapping form is: 6040002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (for the exampel 6040)
yy Hex-number for SDO subindex (for the exampel 00)
z number for byte quantity in SDO setting (for the exampel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO1B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 3.


ASCII English RXPDO4A

ASCII - Command | RXPDO4A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO4A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 4 parameter selection

Description

By the command RXPDO4A the listed CANopen-PDO RX-PDO 4
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Receive-PDO 4 (2600, 0), decimal
2. COB-Identifier for Receive-PDO 4 (1400, 1), hexadecimal
3. Transmission type for Receive-PDO 4 (1400, 2), decimal
4. Inhibit time for Receive-PDO 4 (1400, 3), decimal
5. Priority group for Receive-PDO 4 (1400, 4), decimal
example

Read the actual status: Command: RXPDO4A
Write: Command: RXPDO4A 1 0x201 255 0 2, all parameter have to be set

Note: Only available with MDRV = 0 !


ASCII English RXPDO4B

ASCII - Command | RXPDO4B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | RXPDO4B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | RX-PDO 4 Mapping Settings

Description

The CANopen-PDOs TX-PDO 4mapping can be set by the command RX PDO 1 (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by RXPDO4A.
To read the actual mapping the command has to be set to: RXPDO4B
The mapping form is: 6040002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (for the exampel 6040)
yy Hex-number for SDO subindex (for the exampel 00)
z number for byte quantity in SDO setting (for the exampel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO1B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 4.

Note: Only available with MDRV = 0 !


ASCII English S

ASCII - Command | S |
Syntax Transmit | S |
Syntax Receive | S | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35EA (hex)
DIM | - | PROFIBUS PNU | 1834 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 234 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Stop Motor and Disable Drive

Description

The S command stops the drive (using the braking ramp DECSTOP). As soon as the velocity/velocity falls below the standstill threshold (VEL0) the output stage is disabled.
The S command corresponds to the command K (or DIS) if the STOPMODE option is set to 1.


ASCII English SAVE

ASCII - Command | SAVE |
Syntax Transmit | SAVE |
Syntax Receive | SAVE | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35EB (hex)
DIM | - | PROFIBUS PNU | 1835 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 235 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Save Data in EEPROM

Description

The SAVE command stores the present settings of the amplifier parameters in the serial EEPROM. At the same time, the checksum for the parameter field is updated and also saved in the serial EEPROM. The save process takes about 2 seconds. During this time, the 24V supply for the amplifier must not be switched off. If this supply voltage is switched off during the save process, this may result in invalid data (or none) being saved in the serial EEPROM. A checksum error will be detected at the next power-on of the equipment, and the fault message F09 will be generated.
Furthermore, all the amplifier parameters will be reset to the default values. In order to reset the F09 fault, the SAVE command must be used once more, and the amplifier must be switched off and on again.


ASCII English SERIALNO

ASCII - Command | SERIALNO |
Syntax Transmit | SERIALNO |
Syntax Receive | SERIALNO <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35EF (hex)
DIM | - | PROFIBUS PNU | 1839 (dec) IND = 0000xxxx (bin)
Range | 10 ASCII characters | DPR | 239 (dec)
Default | Factory default |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | No
Short Description | Drive Serial Number

Description

The serial number of the drive amplifier.


ASCII English SETREF

ASCII - Command | SETREF |
Syntax Transmit | SETREF |
Syntax Receive | SETREF | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35F0 (hex)
DIM | - | PROFIBUS PNU | 1840 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 240 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Set Reference Point

Description

The SETREF command is used to declare the present position as the reference point (i.e. the actual position is set to the value of ROFFS) and to set the bit that permits the execution of motion blocks.
The SETREF command corresponds to the execution of a homing to a reference with NREF=0.


ASCII English SETROFFS

ASCII - Command | SETROFFS |
Syntax Transmit | SETROFFS |
Syntax Receive | - | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | 35F1 (hex)
DIM | - | PROFIBUS PNU | 1841 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 241 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Automatic setting of ROFFS

Description

The command SETROFFS automatically changes the reference offset variable ROFFS according to the actual position (PFB). This enables a automatic setting of ROFFS according to the mechanical requirements.

Example 1:

ROFFS=0 PFB=100
to SETROFFS ROFFS=-100

Example 2:

ROFFS=100 PFB=70
to SETROFFS ROFFS=30


ASCII English SETVCT

ASCII - Command | SETVCT |
Syntax Transmit | SETVCT [Data] |
Syntax Receive | SETVCT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3635 (hex)
DIM | - | PROFIBUS PNU | 1909 (dec) IND = 0000xxxx (bin)
Range | 0 .. 7 | DPR | 309 (dec)
Default | 0 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Select a VCT Entry

Description

IN PREPARATION !

The SETVCT command can be used to activate an entry in the VC table (velocity setpoint / current limit).
The VC table contains 8 velocity/current pairs (VCT entries).
When a VCT entry is activated, the velocity value that has been entered is taken as a digital velocity setpoint (only possible with OPMODE=0). The current value from the VCT entry is taken as the current limit.
With analog velocity setpoint provision (OPMODE=1) the velocity setpoint is ignored, but the current value is still used as the current limit.

If the SETVCT command is entered without additional parameters, the number of the presently active VCT entry is shown.

See also description of the VCTAB command.


ASCII English Shortform

\ | Selection of Remote Address
ACC | Acceleration Ramp
ACCR | Acceleration Ramp for homing/jog modes
ACCUNIT | Type of acceleration setpoint for the system
ACTFAULT | Active Fault Mode
ACTIVE | Output stage active/inhibited
ACTRS232 | Activate RS232 Watchdog
ADDR | Multidrop Address
AENA | Software Auto-Enable
ALIAS | Drive Name
AN11NR | No. Of INxTRIG variable, that is changed analog
AN11RANGE | Range of the analog change of INxTRIG
ANCNFG | Configuration of Analog Input
ANDB | Dead Band of the Analog Velocity Input Signal
ANIN1 | Voltage at Analog Input SW1
ANIN2 | Voltage at Analog Input SW2
ANOFF1 | Analog Offset for input SW1
ANOFF2 | Analog Offset for input SW2
ANZERO1 | Zero Analog Input SW1
ANZERO2 | Zero Analog Input SW2
AUTOHOME |
AVZ1 | Filter Time Constant Input SW1
BCC | EEPROM check sum
CALCCOG | Determing the Cogging Table
CALCHP | Determining the Hiperface Parameters
CALCRK | Calculate resolver parameters
CALCRP | Calculate resolver phase
CBAUD | Baud Rate CAN Bus
CLRFAULT | Clear Drive Fault
CLRHR | Bit 5 of status register STAT is cleared
CLRORDER | Deleting a Motion Task
COGGING | Enable of Cogging Compensation
COLDSTART | Drive Reset
CONTINUE | Continue last position order
CPHASE | Deactivate Motor Connection Detection
CTUNE | Calculate current parameters
CUPDATE | Program Update (CAN Bus)
DEC | Deceleration Rate
DECDIS | Deceleration used on Disable Output Stage
DECR | Deceleration Ramp for homing/jog modes
DECSTOP | Quick Stop – braking ramp for emergency situations
DENA | DPR software disable reset mode
DI2T | Drive I2T load
DICONT | Drive Continuous Current
DIFVAR | List Variables with Values
DILIM | DPR current limit
DIPEAK | Drive Peak Rated Current
DIS | Software-Disable
DISDPR | Disable DPR access
DNBAUD | DeviceNet baud rate
DNDUMP | Debugging Information DeviceNet
DNMACID |
DOVRIDE | Digital Override Factor
DPRILIMIT | Digital Limiting of the peak Current via DPR
DR_TYPE | Gives the Output Stage Indentification
DREF | Direction for Homing
DRVCNFG | Configuration Variable for CAN-Bus
DUMP | List All EEPROM Variables with Values
EGEARI |
EGEARO |
EMRGTO |
EN | Software-Enable
ENCLINES | SinCos Encoder Resolution
ENCMODE | Selection of Encoder Emulation
ENCOUT | Resolution Encoder Emulation EEO (ROD)
ENCZERO | Zero Pulse Offset EEO (ROD)
ERND | End position of modulo axes
ERRCODE | Activated Fault Messages
ERRCODE * | Output Error Register
ESPEED | Maximum velocity corresponding to the Feedback Type
EXTWD | external watch dog (Fieldbus)
FBTYPE | Selection of Encoder or Resolver
FLASH |
FLTCNT | Fault Frequency
FLTCNT * | Fault Frequency
FLTHIST | Fault History: Display last 10 faults
FLTHIST * | Fault History: Display last 10 faults
FLUXM | Rated Flux Level of Permanent Magnet Motor
FW | Displays the Version Number of the Firmware
GEARFILT |
GEARI | Input Factor for Electronic Gearing
GEARMODE | Electronic Gearing Mode
GEARO | Output Factor for Electronic Gearing
GET | Scope: output data
GF | Proportional Gain of the Flux Controller
GFTN | Integral Action Time of the Flux Controller
GP | Position Control Loop: Proportional Gain
GPFFT | Position control loop: feed forward for the current setpoint
GPFFV | Position Control Loop: Feed Forward for Velocity
GPRED |
GPTN | Position Control Loop: Integral-Action Time
GV | Velocity Control Loop: Proportional Gain
GVTN | Velocity Control Loop: I-Integration Time
HDUMP | Output all sin/cos (Hiperface) variables
HELP | Output Parameter Help Information
HICOFFS | Hiperface: Cosine-Offset (incremental track)
HIFACT1 | Hiperface: Sin/Cos Gain Factor (incremental track)
HISOFFS | Hiperface: Sin/Cos Offset (incremental track)
HSAVE | Hiperface: Save Parameters in Encoder
HVER | Output the Hardware Version
I | Current Monitor
I2TLIM | I2T Warning
ICMD | Current Setpoint
ICMDVLIM | Velocity Limit in Current Control
ID | D-component of Current Monitor
IN | List Analog Voltage Values
IN1 | Status of Digital Input 1
IN1HCMD | Command buffer for high level
IN1LCMD | Command buffer for low level
IN1MODE | Function of Digital Input 1
IN1TRIG | Variable for IN1MODE
IN2 | Status of Digital Input 2
IN2HCMD | Command buffer for high level
IN2LCMD | Command buffer for low level
IN2MODE | Function of Digital Input 2
IN2PM | In-Position 2 Mode
IN2TRIG | Variable for IN2MODE
IN3 | Status of Digital Input 3
IN3HCMD | Command buffer for high level
IN3LCMD | Command buffer for low level
IN3MODE | Function of Digital Input 3
IN3TRIG | Variable for IN3MODE
IN4 | Status of Digital Input 4.
IN4HCMD | Command buffer for high level
IN4LCMD | Command buffer for low level
IN4MODE | Function of Digital Input 4
IN4TRIG | Variable for IN4MODE
INPOS | Status of In-Position Signal
INPT | In-Position Delay
INS0 | State of Input A0 of the I/O Option Card
INS1 | State of Input A1 of the I/O Option Card
INS2 | State of Input A2 of the I/O Option Card
INS3 | State of Input A3 of the I/O Option Card
INS4 | State of Input A4 of the I/O Option Card
INS5 | State of Input A5 of the I/O Option Card
INS6 | State of Input A6 of the I/O Option Card
INS7 | State of Input A7 of the I/O Option Card
INS8 | State of FSTART_IO of the I/O Option Card
IPEAK | Application Peak Current
IPEAKN | Negative Peak current Limit
IPEAKP | positive motor peak rms current
IQ | Q-Component of Current Monitor
ISCALE1 | Scaling of Analog Current Setpoint 1
ISCALE2 | Scaling of Analog Current Setpoint 2
ISTFR | Velocity dependant Friction Compensation
J | Service Function: Constant Velocity
K | Kill (=Disable)
KC | I-Controller Prediction Constant
KEYLOCK | Locks the push buttons
KTN | Current Controller Integral-Action Time
LASTWMASK | Fault history of WMASK
LATCH32 | Latched 32-bit Position (positive edge)
LATCH32N | Latched 32-bit Position (negative edge)
LATCHX32 | Latched External 32-bit Position (positive edge)
LATCHX32N | Latched External 32-bit Position (negative edge)
LDUMP | Parameter Output of Motor Data
LED1 | State of Display 1 Segment
LED2 | State of Display 2 Segment
LED3 | State of Display 3 Segment
LEDSTAT | Display page
LIST | List All ASCII Commands
LOAD | Load parameters from serial EEPROM
M | Read/write Macro Variable
M_1000 | Display 1 msec Macro Program
M_125 | Display 125 microsecond Macro Program
M_1600 | Display 16 msec Macro Program
M_250 | Display 250 microsecond Macro Program
M_250p | Display 250 microsecond Macro Program
M_4000 | Display 4 msec Macro Program
M_DISABLE | Display the “Disable” Macro Program
M_ENABLE | Display the “Enable” Macro Program
M_INIT | Display the “Init” Macro Program
M_IRQ | Display the “Interrupt” Macro Program
M_RESET | Recompile Macro Programs
M_SMACRO | Display System Macros
M_TASK | Display the Main Macro Program
M_UMACRO | Display User Macros
MAXSDO | Number of Objects of the Parameter Channel
MAXTEMPE | Ambient Temperature Switch off Threshold
MAXTEMPH | Heat Sink Temperature Switch off Threshold
MAXTEMPM | Motor Temperature Switch off Threshold
MBRAKE | Select Motor Holding Brake
MDBCNT | Number of Motor Data Sets
MDBGET | Get Actual Motor Data Set
MDBLIST | List of Motor Data Sets
MDBSET | Set Actual Motor Data Set
MDUMP | Display Present Motor Parameters
MH | Start Homing
MI2T | Motor I2T load
MICONT | Motor Continuous Current Rating
MIMR | Magnetizing Current (Induction Motor)
MIPEAK | Motor Peak Current Rating
MJ | Motor inertia
MJOG | Start Jog Mode
MKT | Motor KT
ML | Stator Inductance of the Motor
MLGC | Current Control loop Adaptive Gain (Q-component at rated current)
MLGD | Adaptive Gain for Current Control loop, D-component
MLGP | Current Control loop Adaptive Gain (Q-component at peak current)
MLGQ | Absolute Gain of Current Control loop
MNAME | Motor Name
MNUMBER | Motor Number
MOVE | Start Motion Task
MPHASE | Motor Phase, Feedback Offset
MPOLES | Number of Motor Poles
MRESBW | Resolver Bandwidth
MRESPOLES | Number of Resolver Poles (Multispeed)
MRS | Winding Resistance of the Stator Phase-Phase
MSERIALNO | Serial no of the motor for encoder feedback
MSG | Enable / Disable All Messages via RS232
MSLBRAKE | DEC ramp at sensorless emergency stop
MSPEED | Maximum Rated Motor Velocity
MTANGLP | Current Lead
MTIME | Motor thermal time constant
MTMUX | Presetting for motion task that is processed later
MTR | Rotor Time Constant
MTYPE | Motor Type
MUNIT | Unit of the Velocity dependant motor parameters
MVANGLB | Velocity-dependent Lead (Start Phi)
MVANGLF | Velocity-dependent Lead (Limit Phi)
MVANGLP | Velocity-dependent Lead (Commutation Angle)
MVR | Beginning Velocity of the field weakening
NONBTB | Mains-BTB Check On/Off
NREF | Homing Mode
NREFMT | Homing wih following motion task
O_ACC1 | Acceleration Time 1 for Motion Task 0
O_C | Control Variable for Motion Task 0
O_DEC1 | Braking Time 1 for Motion Task 0
O_FN | Next Task Number for Motion Task 0
O_FT | Delay before Next Motion Task
O_P | Target Position/Path for Motion Task 0
O_V | Target Speed for Motion Task 0
O1 | State of Digital Output 1
O1MODE | Function of Digital Output 1
O1TRIG | Auxiliary Variable for O1MODE
O2 | State of Digital Output 2
O2MODE | Function of Digital Output 2
O2TRIG | Auxiliary Variable for O2MODE
OBJCO | Mirror CAN - Objects for debug
OCOPY | Save/copy Motion Tasks
OLIST | List of Motion Task Data
OPMODE | Operating Mode
OPTION | Option Slot ID
ORDER | Set Motion Task Parameters
OS1 | Set/Reset of "Posreg1" of the I/O Option Card
OS2 | Set/Reset of "Posreg2" of the I/O Option Card
OS3 | Set/Reset of "Posreg3" of the I/O Option Card
OS4 | Set/Reset of "Posreg4" of the I/O Option Card
OS5 | Set/Reset of "Posreg5" of the I/O Option Card
OVRIDE | Override Function for Motion Tasks
P1...P16 | Fast Position Register 1 ... 16
PASS | Password Input
PASSCNFG | Password Function
PASSX | activate password function
PBAL | Actual Regen Power
PBALMAX | Maximum Regen Power
PBALRES | Select Regen Resistor
PE | Actual Following Error
PEINPOS | In-Position Window
PEMAX | Max. Following Error
PFB | Actual Position from Feedback Device
PFB0 | Position from External Encoder
PGEARI | Position Resolution (Numerator)
PGEARO | Position Resolution (Denominator)
PMODE | Line Phase Error Mode
PNOID | PROFIBUS ID
POP | Generate Current Step
POPI | Current Level for POP Command
POPI2 | Current Level for POP Command
POPV | Max. Speed Level for POP Command
POSCNFG | Axes Type
POSRSTAT | Status of Fast Position Registers 1 ... 16
PPOTYP | Profibus PPO Type
PRBASE | Position Resolution
PRD | 20-bit Position Feedback
PROMPT | Select RS232 Protocol
PSTATE | Profibus Status
PTARGET | Last Target Position
PTBASE | Time base for the external trajectory
PTEACH | Teach-In Function
PTMIN | Min. Acceleration Ramp for Motion Tasks
PUNIT | Set Resolution of the Position
PV | Actual Velocity (Position Control Loop)
PVMAXN | Max. (Negative) Velocity for Position Control
PVMAXP | Max. Velocity for Position Control
RDP | Activate Racjk Drive Panel Mode
RDPBIAS | Rack Drive Panel Bias Current
RDPCLAMP | Max. Velocity Offset of the Rack Drive Panel Circuit
RDPINT | Rack Drive Panel Test Variable
RDPKI | Integral gain of Rach Drive Panel
RDPKP | Proportional Gain of Rach Drive Panel
RDPON | Test Variable Rack Drive Panel
READNIMP | Read/Set the EEO (ROD) Zero-Pulse Offset
READY | Status of the Software Enable
RECDONE | Scope: Recording Done
RECING | Scope: Recording in Progress
RECOFF | Scope: Cancel Scope Recording
RECORD | Scope: Capture Data for Recording
RECRDY | Scope: Status of RECORD Function
RECTRIG | Scope: Activate Recording Function
REFIP | Peak Rated Current for Homing 7
REFLS | Behavior of the Hardware Limit switches at Homing Move
REFMODE | Source of the Zero Pulse in Homing Mode
REFPOS | Reference Switch Position
REMOTE | Status of the Hardware Enable
RESOLVER | Resolver excitation gain adjust +/- 20%
RESPHASE | Resolver Phase
RK | Gain Adjust for Resolver Sine Signal
ROFFS | Reference Offset
ROFFS0 | Reference Offset for the second Encoder Feedback
ROFFS2 | Position offset for "absolute Gearing"
RS232T | RS232 Watch Dog
RSTVAR | Restore Variables (Default Values)
RXPDO1A | RX-PDO 1 parameter selection
RXPDO1B | RX-PDO 1 Mapping Settings
RXPDO2A | RX-PDO 2 parameter selection
RXPDO2B | RX-PDO 2 Mapping Settings
RXPDO3A | RX-PDO 3 parameter selection
RXPDO3B | RX-PDO 3 Mapping Settings
RXPDO4A | RX-PDO 4 parameter selection
RXPDO4B | RX-PDO 4 Mapping Settings
S | Stop Motor and Disable Drive
SAVE | Save Data in EEPROM
SERIALNO | Drive Serial Number
SETREF | Set Reference Point
SETROFFS | Automatic setting of ROFFS
SETVCT | Select a VCT Entry
SLEN | Sercos Optical Range
SLOTIO | I/O-Expansion Card: I/O States
SMNUMBER | Stored Motor Number in the feedback Device
SRND | Start Position of Modulo Axes
STAGECODE | Power Stage Identification
STAT | Drive Status Word
STATCODE | Plain Text Warnings
STATCODE * | Status Variable “Warnings”
STATIO | I/O Status
STATUS | Detailed Amplifier Status
STEP | Service Operation (STEP Command)
STOP | Stop Motion Task
STOPMODE | Brake Response for Disable
SWCNFG | Configuration of Position Registers 1 ... 4
SWE1 | Position register 1
SWE2 | Position register 2
T | Digital Current Setpoint
TASK | Task Workload
TBRAKE | Disable Delaytime with Holding Brake
TBRAKE0 | Enable Delaytime with Holding Brake
TEMPE | Ambient Temperature
TEMPH | Heat Sink Temperature
TEMPM | Motor Temperature
TRJSTAT | Status2 Information
TRUN | Run-time counter
TXPDO1A | TX-PDO1 Mapping - Setup
TXPDO1B | TX-PDO1 Mapping - Setup
TXPDO2A | TX-PDO2 Mapping - Setup
TXPDO2B | TX-PDO2 Mapping - Setup
TXPDO3A | TX-PDO3 Mapping - Setup
TXPDO3B | TX-PDO3 Mapping - Setup
TXPDO4A | TX-PDO4 Mapping - Setup
TXPDO4B | TX-PDO4 Mapping - Setup
UCOMP | Backlash Compensation
UPDATE | Program Update via RS232
UVLTMODE | Undervoltage Mode
V | Actual Velocity
VBUS | DC-bus voltage
VBUSBAL | Maximum Line Voltage
VBUSMAX | Maximum DC-bus Voltage
VBUSMIN | Minimum DC-bus Voltage
VBW | Generate Bode Diagram
VCMD | Internal Velocity Setpoint in RPM
VCOMM | Velocity Threshold for Commutation error
VCTAB | Define a VCT Entry
VEL0 | Standstill Threshold
VER | Firmware Version
VJOG | Speed for Jog Mode
VLIMN | Max. Negative Velocity
VLIMP | Max. Velocity
VLO | Software Resolver/Digital Converter Feedforward
VMIX | Velocity Mix: Feedback / external Encoder
VOSPD | Overspeed
VREF | Speed for Homing
VREF0 | Homing Mode Reduction factor
VSCALE1 | SW1 Velocity Scaling Factor
VSCALE2 | SW2 Velocity Scaling Factor
VSTFR | Velocity for max. Friction Compensation
VTUNE | Calculate Velocity Control Loop Parameters
VUNIT | Systemwide Definition of Velocity / Speed
WMASK | Warning as Fault Mask
WPOS | Enable Position Registers
WPOSE | Enable Fast Position Registers 1 ... 16
WPOSP | Polarity of Fast Position Registers 1 ... 16
WPOSX | Mode of Fast Position Registers 1 ... 16


ASCII English SLEN

ASCII - Command | SLEN |
Syntax Transmit | SLEN [Data] |
Syntax Receive | SLEN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer8 | CANBus Object Number | 35F2 (hex)
DIM | m | PROFIBUS PNU | 1842 (dec) IND = 0000xxxx (bin)
Range | 0 .. 45 | DPR | 242 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Sercos | EEPROM | Yes
Short Description | Sercos Optical Range

Description

This parameter can be used to set the optical range (in meters) for a standardized 1mm² plastic optical fiber cable.


ASCII English SLOTIO

ASCII - Command | SLOTIO |
Syntax Transmit | SLOTIO |
Syntax Receive | SLOTIO <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 35F3 (hex)
DIM | - | PROFIBUS PNU | 1843 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 243 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | I/O-Expansion Card: I/O States

Description

The SLOTIO command returns the states of the inputs and outputs on the I/O-expansion card (slot card) in the format Hxxxxxxxx
Bit number Bit combination Input/Output Description
0 0x00000001 Input Bit 0 Motion block number (A0)
1 0x00000002 Input Bit 1 Motion block number (A1)
2 0x00000004 Input Bit 2 Motion block number (A2)
3 0x00000008 Input Bit 3 Motion block number (A3)
4 0x00000010 Input Bit 4 Motion block number (A4)
5 0x00000020 Input Bit 5 Motion block number (A5)
6 0x00000040 Input Bit 6 Motion block number (A6)
7 0x00000080 Input Bit 7 Motion block number (A7)
8 0x00000100 Input Reference switch
9 0x00000200 Input Acknowledge Contouring error
10 0x00000400 Input Start next motion block
11 0x00000400 Input Start jog mode
12 0x00001000 Input Continue a motion block
13 0x00002000 Input Start motion block no. A0 ... A7
14 0x00004000 Output “In-Position” signal
15 0x00008000 Output “In-Position2” signal (next)
16 0x00010000 Output Contouring error
17 0x00020000 Output “Position register 1” signal
18 0x00040000 Output “Position register 2” signal
19 0x00080000 Output “Position register 3” signal
20 0x00100000 Output “Position register 4” signal
21 0x00200000 Output “Position register 5” signal
22 0x00400000 Status 24Volt - On
23 0x00800000 Status Slot fault
24...31 Reserve


ASCII English SMNUMBER

ASCII - Command | SMNUMBER |
Syntax Transmit | SMNUMBER [Data] |
Syntax Receive | SMNUMBER <Data> | Available in |
Type | Variable r | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 3695 (hex)
DIM | - | PROFIBUS PNU | 2005 (dec) IND = 0000xxxx (bin)
Range | 0 .. 32767 | DPR | 405 (dec)
Default | 0 |
Opmode | - | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | No
Short Description | Stored Motor Number in the feedback Device

Description

SMNUMBER gives the motor number, that is stored in the feedback device (EnDAT or HIPERFACE).

This Object makes sense with FBTYPE = 2 or 4, otherwise "0" is returned.


ASCII English SRND

ASCII - Command | SRND |
Syntax Transmit | SRND [Data] |
Syntax Receive | SRND <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3637 (hex)
DIM | - | PROFIBUS PNU | 1911 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 311 (dec)
Default | - 2^31 |
Opmode | - | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Start Position of Modulo Axes

Description

The SRND parameter is used to define the start of the range of movement for a modulo axes (POSCNFG=2). The end of the range can be set by the ERND command. All positioning operations are made in the positioning range <SRND...ERND-1>.
The entry for SRND is made in SI units (taking account of PGEARI, PGEARO).


ASCII English STAGECODE

ASCII - Command | STAGECODE |
Syntax Transmit | - |
Syntax Receive | STAGECODE <Data> | Available in |
Type | Variable r | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3682 (hex)
DIM | - | PROFIBUS PNU | 1986 (dec) IND = 0000xxxx (bin)
Range | 1, 2, .., 19 | DPR | 386 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | -
Short Description | Power Stage Identification

Description

Give the identification of the power stage-

STAGECODE=0 not allowed (Hardware error)
STAGECODE=1 SR601
STAGECODE=2 SR603
STAGECODE=3 SR606
STAGECODE=4 SR610
STAGECODE=5 SR614
STAGECODE=6 SR620
STAGECODE=7 SR640
STAGECODE=8 SR670
STAGECODE=9 SR610/30
STAGECODE=10 Reserve
STAGECODE=11 Reserve
STAGECODE=12 Reserve
STAGECODE=13 Reserve
STAGECODE=14 Reserve
STAGECODE=15 Reserve
STAGECODE=16 SR403
STAGECODE=17 SR406
STAGECODE=18 Reserve
STAGECODE=19 Reserve


ASCII English Revision

ASCII Object Description
Edition REV 1.0
Edition | Description | Created
REV 1.0 | Basic Edition | 30.9.03


ASCII English STAT

ASCII - Command | STAT |
Syntax Transmit | STAT |
Syntax Receive | STAT | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 35FB (hex)
DIM | - | PROFIBUS PNU | 1851 (dec) IND = 0000xxxx (bin)
Range | int (=Word) | DPR | 251 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Drive Status Word

Description

The STAT command provides a 16-bit status word in hexadecimal format (Hxxxx).

Bit Value Interpretation
0 0x0001 =0 if output stage is enabled
=1 output stage disabled
1 0x0002 =0 if controller is ready for operation (BTB)
=1 fault present
2 0x0004 reserve
3 0x0008 =1 if service function is active
=0 no service function active
4 0x0004 reserve
5 0x0020 =1 after a hardware reset, is cancelled by CLRHR
6 0x0040 =1 configuration variable was altered (SAVE and COLDSTART)
=0 no configuration variable altered
7 0x0080 =1 safety relay is active (AS-Option)
=0 safety relay is not active
8 0x0100 =1 discrepancy between RAM and EEPROM parameters (cancelled by SAVE command).
=0 RAM and EEPROM parameters are the same
9 0x0200 =1 slot-expansion card is available
=0 slot-expansion card is not available
10 0x0400 =1 RAM parameter modified (cancelled by DUMP command)
=0 no change in RAM parameters since the last DUMP.
11...15 Reserve

Bits 5, 6, 8 and 10 are used for an external signal that internal parameters have been changed

Bit 5 hardware reset
Bit 5 is set if the parameters are copied from the serial EEPROM to the RAM (this happens after a hardware reset of a LOAD command). If this bit is set, all the parameters should be requested by the parameterization software (DUMP command) and bit 5 should be cancelled by the CLRHR command.

Bit 6 configuration variable was altered
Any alteration of a configuration variable (a variable that makes it necessary to recompile the macro, i.e. to reset the amplifier) means that this bit will be set to 1. If this bit is set, the parameterization software should generate a SAVE / COLDSTART command (controller reset) at a suitable moment. Bit 6 is only cancelled by a hardware reset (COLDSTART).

Bit 8 discrepancy between EEPROM and RAM parameters
Any alteration of a RAM parameter means that this bit is set to 1. If this bit is set, the parameterization software should generate a SAVE command (save the data in the EEPROM) at a suitable moment (e.g. on exiting the program). This bit is cancelled by a SAVE command.

Bit 10 RAM parameters modified
Any alteration of a RAM parameter through a parameterization channel other than the RS232 means that this bit is set to 1. If this bit is set, the parameterization software should generate a DUMP command (read all data) at a suitable moment. This bit is cancelled by a DUMP command.


ASCII English STATCODE

ASCII - Command | STATCODE |
Syntax Transmit | STATCODE |
Syntax Receive | STATCODE <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Plain Text Warnings

Description

The warnings are displayed as plain text.


ASCII English STATCODE *

ASCII - Command | STATCODE * |
Syntax Transmit | STATCODE * |
Syntax Receive | STATCODE * <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 .. 0xFFFFFFFF | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | -
Short Description | Status Variable “Warnings”

Description

The STATCODE * command returns the internal warnings in the form of a bit-variable. The assignments for the individual bits can be seen in the following table.
Bit | Display | Meaning
0 / 0x00000001 | n01 | =1 I2T Threshold override
1 / 0x00000002 | n02 | =1 Regen message
2 / 0x00000004 | n03 | =1 Contouring error
3 / 0x00000008 | n04 | =1 watchdog limit reached
4 / 0x00000010 | n05 | =1 Line phase missing
5 / 0x00000020 | n06 | =1 Software limit switch 1 active
6 / 0x00000040 | n07 | =1 Software limit switch 2 active
7 / 0x00000080 | n08 | =1 Wrong motion task started
8 / 0x00000100 | n09 | =1 Reference point not set
9 / 0x00000200 | n10 | =1 PSTOP active
10 / 0x00000400 | n11 | =1 NSTOP active
11 / 0x00000800 | n12 | =1 Default motor settings loaded
12 / 0x00001000 | n13 | =1 Slot warning (I/O extension board)
13 / 0x00002000 | n14 | =1 Calculation of MPHASE active (FBTYPE=7)
14 / 0x00004000 | n15 | =1 Wrong VCT entry started
15 / 0x00008000 | n16 | Is active, if one or more of the warnings n17...n31 are active.
16 / 0x00010000 | n17 | CAN-Sync is not locked
17 / 0x00020000 | n18 | Using Multiturn encoder feedback, a overrun over the maximum number of resolutions (+/-2048) was detected (starting with firmware 4.91)
18...30 | n19 ..n31 | Reserved
31 / 0x80000000 | n32 | =1 Beta version of the firmware


ASCII English STATIO

ASCII - Command | STATIO |
Syntax Transmit | STATIO |
Syntax Receive | STATIO <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | 7 x Integer8 | CANBus Object Number | 35FC (hex)
DIM | - | PROFIBUS PNU | 1852 (dec) IND = 0000xxxx (bin)
Range | 0,1 (=State) | DPR | 252 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | I/O Status

Description

The STATIO command returns the actual state of the digital inputs and outputs of the servo amplifier, in the following sequence.
IN1 IN2 IN3 IN4 ENABLE OUT1 OUT2

A 0 at the appropriate position means that the corresponding input/output is in the Low state, a 1 signifies the High state.


ASCII English STATUS

ASCII - Command | STATUS |
Syntax Transmit | STATUS |
Syntax Receive | STATUS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer16 Integer32 Integer16 Integer16 Integer16 | CANBus Object Number | 35FD (hex)
DIM | - | PROFIBUS PNU | 1853 (dec) IND = 0000xxxx (bin)
Range | int (=Word); long int (=DoubleWord) | DPR | 253 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Detailed Amplifier Status

Description

The STATUS command returns the detailed status information in the form of a 5 status variables in hexadecimal format.

Word no. 1 Format Hxxxx
Bit 0 =0 if hardware enable is set (ENABLE input = 24V)
Bit 1 =0 if software enable is set
Bit 2 reserve
Bit 3 =0 if amplifier is ready for operation (BTB / no fault)

Word no. 2 Format Hxxxx
Bits 0 ... 31 fault variable (see ERRCODE)

Word no. 3 Format Hxxxx
Word no. 4 Format Hxxxx
=0 no service function active
=1 service function “constant current/velocity” is active
=2 jog mode MJOX is active

Word no. 5 Format Hxxxx

Bit Value Interpretation
0 0x0001 =1 motion block / homing movement / jog mode is active
1 0x0002 =1 reference point set
2 0x0004 =1 reference switch occupied (home position)
3 0x0008 =1 IN-POSITION signal
4 0x0010 =1 position has been latched (positive edge)
5 0x0020 =1 homing in progress
6 0x0040 =1 jog mode is running
7 0x0080 =1 position has been latched (negative edge)
8 ... 15 reserve


ASCII English STEP

ASCII - Command | STEP |
Syntax Transmit | STEP [Data] |
Syntax Receive | STEP <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Integer16 Float Integer16 Float | CANBus Object Number | No
DIM | Milliseconds (DurationN) / rpm (velocityN) | PROFIBUS PNU | No
Range | Duration:0 to 32767; velocity:-VLIM to +VLIM | DPR | No
Default | Duration:1000; velocity1/2: 100/-100 |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Service Operation (STEP Command)

Description

The STEP command is used to implement a service function through the operating mode “digital velocity control” (OPMODE=0). The command can be used in the following forms.
1. STEP
The command provides the present settings for the service function.
2. STEP T1 V1
A digital setpoint V1 (RPM) is provided for time T1 (in msec). After T1 has elapsed, the digital setpoint is set to 0.
3. STEP T1 V1 T2 V2
A digital setpoint V1 (RPM) is provided for time T1 (in msec). After T1 has elapsed, a digital setpoint V2 (RPM) is provided for time T2 (in msec). After T2 has elapsed, the T1/V1 cycle starts again. This command can be used to create an endless reversing operation.
e.g. STEP 1000 500 1000 -500

The service operation can always be cancelled by using the STOP command.
The “digital velocity control” operating mode is a precondition for implementing the STEP command.


ASCII English STOP

ASCII - Command | STOP |
Syntax Transmit | STOP |
Syntax Receive | STOP | Available in |
Type | Command | MMI | Yes
ASCII Format | - | CANBus Object Number | 35FE (hex)
DIM | - | PROFIBUS PNU | 1854 (dec) IND = 0000xxxx (bin)
Range | - | DPR | 254 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | -
Short Description | Stop Motion Task

Description

The STOP command breaks off the drive movement. The response of the drive varies according to the operating mode that is valid at the moment.

1. OPMODE=0 (digital velocity control)
The STOP command has the effect of setting the velocity setpoint to 0.
The drive brakes along the preset braking ramp for the velocity control loop (DEC).

2. OPMODE=2 (digital current control)
The STOP command has the effect of setting the current setpoint to 0.
The drive coasts down.

3. OPMODE=8 (internal motion tasks)
The STOP command has the effect of breaking off the present motion task (jog mode / homing movement).
The drive brakes along the decel ramp that is defined in the motion task. The motion task can be restarted by CONTINUE or digital input defined with INxMODE=22.

The STOP command has no function in the OPMODE=1,3,4,5,6,7 operating modes.


ASCII English STOPMODE

ASCII - Command | STOPMODE |
Syntax Transmit | STOPMODE [Data] |
Syntax Receive | STOPMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 35FF (hex)
DIM | - | PROFIBUS PNU | 1855 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 255 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Brake Response for Disable

Description

STOPMODE defines the response of the drive to a disabling of the output stage.
The following settings are possible:
STOPMODE=0 the output stage is immediately disabled, and the drive coasts down.
STOPMODE=1 the drive is run down under velocity control to velocity 0 (DECDIS ramp). When the velocity falls below the standstill threshold VEL0, the output stage is disabled.
The output stage will also be disabled if the VEL0 velocity is not reached within 5 seconds (a 5-second time-out).


ASCII English SWCNFG

ASCII - Command | SWCNFG |
Syntax Transmit | SWCNFG [Data] |
Syntax Receive | SWCNFG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Unsigned16 | CANBus Object Number | 3600 (hex)
DIM | - | PROFIBUS PNU | 1856 (dec) IND = 0000xxxx (bin)
Range | 0 .. 65536 | DPR | 256 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Unsigned16
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Configuration of Position Registers 1 ... 4

Description

6 position registers (SWE0 ... SWE5) are available for monitoring functions, that can be configured as software limit-switches or cam contacts (position switches).
Registers SWE1 ... SWE4 can be configured with the help of the SWCNFG configuration parameter.
Registers SWE0 and SWE5 can be configured with the help of the SWCNFG2 parameter.
A corresponding cam register SWExN is assigned to each position register SWEx.
The cam registers are only used if the cam function is activated.

The SWCNFG variable can be considered as a bit-variable. The individual bits are interpreted as follows:

Bit 0 =0 Position/cam register SWE1 is not active
=1 Position/cam register SWE1 is active
Bit 1 =0 Signal on going above the position (PFB > SWE1)
Signal if SWE1 < PFB < SWE1N and cam function is activated
=1 Signal on going below the position (PFB < SWE1)
Signal if SWE1 > PFB > SWE1N and cam function is activated
Bit 2 =0 SWE1 functions as signal threshold
=1 SWE1 functions as software limit-switch 1 (left)
Das Setzen des Referenzpunktes ist je nach FBTYPE mit SETREF oder MH erforderlich
Bit 3 =1 Cam function for SWE1 / SWE1N

Bit 4 =0 Position/cam register SWE2 is not active
=1 Position/cam register SWE2 is active
Bit 5 =0 Signal on going above the position (PFB > SWE2)
Signal if SWE2 < PFB < SWE2N and cam function is activated
=1 Signal on going below the position (PFB < SWE2)
Signal if SWE2 > PFB > SWE2N and cam function is activated
Bit 6 =0 SWE2 functions as signal threshold
=2 SWE2 functions as software limit-switch 2 (right)
Bit 7 =1 Cam function for SWE2 / SWE2N

Bit 8 =0 Position/cam register SWE3 is not active
=1 Position/cam register SWE3 is active
Bit 9 =0 Signal on going above the position (PFB > SWE3)
Signal if SWE3 < PFB < SWE3N and cam function is activated
=1 Signal on going below the position (PFB < SWE3)
Signal if SWE3 > PFB > SWE3N and cam function is activated
Bit 10 Reserve
Bit 11 =1 Cam function for SWE3 / SWE3N

Bit 12 =0 Position/cam register SWE4 is not active
=1 Position/cam register SWE4 is active
Bit 13 =0 Signal on going above the position (PFB > SWE4)
Signal if SWE4 < PFB < SWE4N and cam function is activated
=1 Signal on going below the position (PFB < SWE4)
Signal if SWE4 > PFB > SWE4N and cam function is activated
Bit 14 Reserve
Bit 15 =1 Cam function for SWE4 / SWE4N

The cam function is activated with the help of the cam bits (bits 3/7/11/15 of SWCNFG and bits 3/7 of SWCNFG2).
If a cam bit is set, a cam signal is generated if the actual position lies between the positions SWEx and SWExN
(x = 0 ... 5). The polarity of the cam signal can be defined by the direction bit (bits 1/5/9/13 of SWCNFG and bits 1/5 of SWCNFG2).

Output of the position signal through a digital output.
- If an I/O-expansion card (slot card) is available, the individual position signals are generated at the following outputs.

SWE0: Next-InPos X11B.4
SWE1: PosReg1 X11B.6
SWE2: PosReg2 X11B.7
SWE3: PosReg3 X11B.8
SWE4: PosReg4 X11B.9
SWE5: Reserve X11B.10

The “Next-InPos” and “SWE0-signal” functions use the same output X11B.4, so they must not be used simultaneously. If position register SWE0 has been configured, then the “Next-InPos” function is inhibited through the I/O card. If necessary, this function can be diverted to a digital output on the motherboard (O1MODE=16 or O2MODE=16).

- if no I/O card is available, then the individual position signals can be given out through the outputs on the motherboard.

SWE0: OxMODE=28 x=1,2
SWE1: OxMODE=12 x=1,2
SWE2: OxMODE=13 x=1,2
SWE3: OxMODE=14 x=1,2
SWE4: OxMODE=15 x=1,2
SWE5: OxMODE=29 x=1,2

All position signals are recorded in a status register, regardless of the outputs via the digital outputs, and can be read out through the serial interface as well as through the CAN/PROFIBUS interface.

SWE0: Bit 21 (0x00200000) of DRVSTAT
SWE1: Bit 22 (0x00400000) of DRVSTAT
SWE2: Bit 23 (0x00800000) of DRVSTAT
SWE3: Bit 24 (0x01000000) of DRVSTAT
SWE4: Bit 25 (0x02000000) of DRVSTAT
SWE5: Bit 27 (0x08000000) of DRVSTAT


ASCII English SWE1

ASCII - Command | SWE1 |
Syntax Transmit | SWE1 [Data] |
Syntax Receive | SWE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3604 (hex)
DIM | - | PROFIBUS PNU | 1860 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 260 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position register 1

Description

The variable SWE1 contains the position value for position register 1.
The scaling of the position depends on the PGEARI / PGEARO / PRBASE parameters, and is calculated according to the following formula:

SWE1[increments] = SWE1[input] * PGEARO / PGEARI

1048576 increments/turn for PRBASE=20
65536 increments/turn for PRBASE=16

see also description of SWCNFG


ASCII English SWE2

ASCII - Command | SWE2 |
Syntax Transmit | SWE2 [Data] |
Syntax Receive | SWE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3606 (hex)
DIM | - | PROFIBUS PNU | 1862 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 262 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Position register 2

Description

The variable SWE2 contains the position value for position register 2.
The scaling of the position depends on the PGEARI / PGEARO / PRBASE parameters, and is calculated according to the following formula:

SWE2[increments] = SWE2[input] * PGEARO / PGEARI

1048576 increments/turn for PRBASE=20
65536 increments/turn for PRBASE=16

see also description of SWCNFG


ASCII English T

ASCII - Command | T |
Syntax Transmit | T [Data] |
Syntax Receive | T <Data> | Available in |
Type | Command | MMI | Yes
ASCII Format | Float | CANBus Object Number | 360E (hex)
DIM | Amperes | PROFIBUS PNU | 1870 (dec) IND = 0000xxxx (bin)
Range | -DIPEAK .. DIPEAK | DPR | 270 (dec)
Default | - |
Opmode | 2 | Data Type Bus/DPR | Integer32
Drive State | Enabled | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Oscilloscope | EEPROM | -
Short Description | Digital Current Setpoint

Description

The “T” command can be used to define a constant current setpoint <i> (in A).
This current setpoint remains effective until a new T / STOP / OPMODE command is executed.


ASCII English TASK

ASCII - Command | TASK |
Syntax Transmit | TASK |
Syntax Receive | TASK <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | String | CANBus Object Number | 360F (hex)
DIM | - | PROFIBUS PNU | 1871 (dec) IND = 0000xxxx (bin)
Range | max 80 ASCII Characters | DPR | 271 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Task Workload

Description

The TASK command shows the loading for the individual firmware tasks.
The figures signify the number of functions performed per millisecond.


ASCII English TBRAKE

ASCII - Command | TBRAKE |
Syntax Transmit | TBRAKE [Data] |
Syntax Receive | TBRAKE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 366E (hex)
DIM | ms | PROFIBUS PNU | 1966 (dec) IND = 0000xxxx (bin)
Range | 10 .. 10000 | DPR | 366 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Disable Delaytime with Holding Brake

Description

TBRAKE defines a disable delay time with holding brake.
If the drive is disabled, it controls the holding brake if selected. After the motor is stopped, the holding brake is switched off and a delay timer (value is TBRAKE) is started. When the time is gone, the drive is disabled.


ASCII English TBRAKE0

ASCII - Command | TBRAKE0 |
Syntax Transmit | TBRAKE0 [Data] |
Syntax Receive | TBRAKE0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer16 | CANBus Object Number | 366F (hex)
DIM | ms | PROFIBUS PNU | 1967 (dec) IND = 0000xxxx (bin)
Range | -10 .. 10000 | DPR | 367 (dec)
Default | 20 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Enable Delaytime with Holding Brake

Description

The parameter TBRAKE0 defines a reaction time of the holding brake when the drive is enabled.
If the drive is enabled (hardware/software enable) thr drive controls the holding brake. During the selected time TBRAKE0, the internal velocity setpoint is set to 0. After the time when the brake is open, the setpoint is accepted internally and the motor can run.

If the TRBAKE0 is set to values <0, the internal setpoint is activated before the holding brake is open.


ASCII English TEMPE

ASCII - Command | TEMPE |
Syntax Transmit | TEMPE |
Syntax Receive | TEMPE <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3610 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1872 (dec) IND = 0000xxxx (bin)
Range | -20 .. 90 | DPR | 272 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Ambient Temperature

Description

Displays the present internal temperature in °C.


ASCII English TEMPH

ASCII - Command | TEMPH |
Syntax Transmit | TEMPH |
Syntax Receive | TEMPH <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3611 (hex)
DIM | Centigrade Degrees | PROFIBUS PNU | 1873 (dec) IND = 0000xxxx (bin)
Range | -20 .. 90 | DPR | 273 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Heat Sink Temperature

Description

Displays the present heat sink temperature in °C.


ASCII English TEMPM

ASCII - Command | TEMPM |
Syntax Transmit | TEMPM |
Syntax Receive | TEMPM <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3612 (hex)
DIM | Ohm | PROFIBUS PNU | 1874 (dec) IND = 0000xxxx (bin)
Range | 0 .. 10000 | DPR | 274 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Motor Temperature

Description

Indicates the motor temperature, in the form of the resistance of the temperature sensor (in ohms).


ASCII English TRJSTAT

ASCII - Command | TRJSTAT |
Syntax Transmit | TRJSTAT |
Syntax Receive | TRJSTAT <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3613 (hex)
DIM | - | PROFIBUS PNU | 1875 (dec) IND = 0000xxxx (bin)
Range | 0 .. 0xFFFFFFFF | DPR | 275 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Drive Status | EEPROM | No
Short Description | Status2 Information

Description

The TRJSTAT command returns the internal status information in the form of a bit-variable. The status information is primarily used for internal functions. Only the bits that are marked by an “*” can be used for external functions (control system). Bits 16 ... 20 are also mirrored in the DRVSTAT status variable.
Bit | Significance | Meaning
0 | 0x00000001 | =1 the output INPOS2 is updated every msec
1 | 0x00000002 | =1 At the end of the actual motion task, the drive outputs no IN-POSITION signal (a motion task sequence was activated.
2* | 0x00000004 | =1 Toggle Bit "Motion task finished". Is toggled at the end of a motion task. The toggling of the Bit is done, if the target position is reached and the profile generator is switched off. This is different to the functionality of the IN-POSITION Bit. When the drive is switched on, this Bit is set to low. (Firmware 3.41)
3...15 |  | Reserved
16* | 0x00010000 | =1 Motion task active (position control) Is set, if a motion task is started( motion task, Jog, Homing). Is cleared, if a motion task has finished or is stopped (STOP).
17* | 0x00020000 | =1 Reference point set Is set, if the homing move has successfully finished or if the feedback device is a multiturn encoder. Is cleared, when a homing move is started.
18* | 0x00040000 | =1 Home position Is high, if the homing switch is active, otherwise low.
19* | 0x00080000 | =1 In-Position Is set, if the difference between the actual position and the target position is smaller than PEINPOS. Is cleared, if the distance is greater.
20* | 0x00100000 | =1 Position latch activated (positive latch) Is set, if a positive edge at Latch input 2 (configured by IN2MODE=26) was detected. Is cleared, if the position is read by LATCH16 / LATCH32.
21* | 0x00200000 | =1 Homing move is active Is set, if a Homing move was started. Is cleared, if the homing move is successful or stopped (STOP).
22* | 0x00400000 | =1 Jog move active Is set, if a Jog move is started. Is cleared, if the Jog move is stopped.
23 | 0x00800000 | =1 Position latch activated (negative latch) Is set, if a negative edge at Latch input 2 (configured by IN2MODE=26) was detected. Is cleared, if the position is read by LATCH16N / LATCH32N.
24 | 0x01000000 | =1 Emergency stop active Is set, if an emergency stop has occurred (DEC-phase after an error, active hardware limit switches, Input configured as Emergency stop with level low.
25 | 0x02000000 | =1 position latch at input1 (positive transition), if a rising edge at input 1 is detected, when input1 is defined as latch input (IN1MODE=26). Is reset, if the latched position is read by LATCHX16 or LATCHX32. (4.61 Firmware)
26 | 0x04000000 | =1 position latch at input1 (negative transition), if a falling edge at input 1 is detected, when input1 is defined as latch input (IN1MODE=26). Is reset, if the latched position is read by LATCHX16N or LATCHX32N. (4.61 Firmware)
27 .. 31 |  | Reserved


ASCII English TRUN

ASCII - Command | TRUN |
Syntax Transmit | TRUN |
Syntax Receive | TRUN <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | 3614 (hex)
DIM | hhhhh:mm | PROFIBUS PNU | 1876 (dec) IND = 0000xxxx (bin)
Range | 00000:00 to 99999:45 | DPR | 276 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Run-time counter

Description

The run-time counter shows the operating life of the amplifier (if the 24V is applied) in minutes.
The internal resolution of the run-time counter is 1 second.
Since the run-time counter value is included in the serial EEPROM of the amplifier, it is only updated in the EEPROM every 8 minutes So switching off the 24V supply can cause a loss in the record of up to 8 minutes.


ASCII English TXPDO1A

ASCII - Command | TXPDO1A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO1A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO1 Mapping - Setup

Description

By the command TXPDO1A the listed CANopen-PDO TX-PDO 1
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Transmit -PDO 1 (2A00, 0), decimal
2. COB-Identifier for Transmit-PDO 1 (1400, 1), hexadecimal
3. Transmission type for Transmit-PDO 1 (1400, 2), decimal
4. Inhibit time for Transmit-PDO 1 (1400, 3), decimal
5. Priority group for Transmit-PDO 1 (1400, 4), decimal
example

Read the actual status: Command: TXPDO1A
Write: Command: TXPDO1A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
all parameter have to be set


ASCII English TXPDO1B

ASCII - Command | TXPDO1B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO1B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO1 Mapping - Setup

Description

The CANopen-PDOs TX-PDO 1mapping can be set by the command TXPDO1B (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by TXPDO1A.
To read the actual mapping the command has to be set to: TXPDO1B
The mapping form is: TXPDO1B 6041002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (im Beispiel 6040)
yy Hex-number for SDO subindex (im Beispiel 00)
z number for byte quantity in SDO setting (im Beispiel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO1B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 1.


ASCII English TXPDO2A

ASCII - Command | TXPDO2A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO2A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO2 Mapping - Setup

Description

By the command TXPDO2A the listed CANopen-PDO TX-PDO 2
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Transmit -PDO 2 (2A00, 0), decimal
2. COB-Identifier for Transmit-PDO 2 (1400, 1), hexadecimal
3. Transmission type for Transmit-PDO 2 (1400, 2), decimal
4. Inhibit time for Transmit-PDO 2 (1400, 3), decimal
5. Priority group for Transmit-PDO 2 (1400, 4), decimal
example

Read the actual status: Command: TXPDO2A
Write: Command: TXPDO2A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
all parameter have to be set


ASCII English TXPDO2B

ASCII - Command | TXPDO2B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO2B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO2 Mapping - Setup

Description

The CANopen-PDOs TX-PDO 2mapping can be set by the command TXPDO2B (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by TXPDO2A.
To read the actual mapping the command has to be set to: TXPDO2B
The mapping form is: TXPDO2B 6041002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (im Beispiel 6040)
yy Hex-number for SDO subindex (im Beispiel 00)
z number for byte quantity in SDO setting (im Beispiel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO2B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 2.


ASCII English TXPDO3A

ASCII - Command | TXPDO3A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO3A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO3 Mapping - Setup

Description

By the command TXPDO3A the listed CANopen-PDO TX-PDO 3
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Transmit -PDO 3 (2A00, 0), decimal
2. COB-Identifier for Transmit-PDO 3 (1400, 1), hexadecimal
3. Transmission type for Transmit-PDO 3 (1400, 2), decimal
4. Inhibit time for Transmit-PDO 3 (1400, 3), decimal
5. Priority group for Transmit-PDO 3 (1400, 4), decimal
example

Read the actual status: Command: TXPDO3A
Write: Command: TXPDO3A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
all parameter have to be set


ASCII English TXPDO3B

ASCII - Command | TXPDO3B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO3B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO3 Mapping - Setup

Description

The CANopen-PDOs TX-PDO 3mapping can be set by the command TXPDO3B (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by TXPDO3A.
To read the actual mapping the command has to be set to: TXPDO3B
The mapping form is: TXPDO3B 6041002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (im Beispiel 6040)
yy Hex-number for SDO subindex (im Beispiel 00)
z number for byte quantity in SDO setting (im Beispiel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO3B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 3.


ASCII English TXPDO4A

ASCII - Command | TXPDO4A |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO4A <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO4 Mapping - Setup

Description

By the command TXPDO4A the listed CANopen-PDO TX-PDO 4
parameter can be selected (in brackets: corresponding SDOs by controlling via CAN):

1. Selection of the used PDO-Mappings for Transmit -PDO 4 (2A00, 0), decimal
2. COB-Identifier for Transmit-PDO 4 (1400, 1), hexadecimal
3. Transmission type for Transmit-PDO 4 (1400, 2), decimal
4. Inhibit time for Transmit-PDO 4 (1400, 3), decimal
5. Priority group for Transmit-PDO 4 (1400, 4), decimal
example

Read the actual status: Command: TXPDO4A
Write: Command: TXPDO4A 1 0x201 255 0 2 0XFFFFFFFF 0XFFFFFFFF,
all parameter have to be set

Note: Only available with MDRV = 0 !


ASCII English TXPDO4B

ASCII - Command | TXPDO4B |
Syntax Transmit | RXPDO1A [Data] |
Syntax Receive | TXPDO4B <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Single Line Multi String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | - | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | Single Line Multi String
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Fieldbus | EEPROM | Yes
Short Description | TX-PDO4 Mapping - Setup

Description

The CANopen-PDOs TX-PDO 1mapping can be set by the command TXPDO1B (in brackets: corresponding SDOs):
This is only possible, if free PDO mapping was selected, for example by TXPDO1A.
To read the actual mapping the command has to be set to: TXPDO1B
The mapping form is: TXPDO1B 6041002

The format is different to the bus format. The syntax of the mapping-values xxxxyyz is:

xxxx Hex-number for SDO index (im Beispiel 6040)
yy Hex-number for SDO subindex (im Beispiel 00)
z number for byte quantity in SDO setting (im Beispiel 2 Byte = 16 Bit)

The input of free mappable PDO is analog to the output, for example: TXPDO1B 6041002 6061001 for CANopen status word setting and the CANopen-OPMODE via TX-PDO 1.

Note: Only available with MDRV = 0 !


ASCII English UCOMP

ASCII - Command | UCOMP |
Syntax Transmit | UCOMP [Data] |
Syntax Receive | UCOMP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3631 (hex)
DIM | PUNIT | PROFIBUS PNU | 1905 (dec) IND = 0000xxxx (bin)
Range | long int | DPR | 305 (dec)
Default | 0 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Backlash Compensation

Description

IN PREPARATION !

For many applications it is necessary to approach motion block positions from one direction only (to avoid backlash errors arising from the interplay of the rack and pinion). To do this, at the start of a motion block the target position for the motion block is shifted by a correction value, and the motion block is only started for the real target value when this corrected position has been reached. The behavior of this function is controlled by the UCOMP parameter. The value of this parameter is the size of the correction, the sign shows the direction in which the correction is to be made. If the sign is positive, the correction is only made for positive velocities (i.e. the target position is always approached from the right), if it is negative, the correction is only made for negative velocities. This function is switched off if UCOMP is set to 0 (default setting).
e.g.
1. Actual position = 0, target position = 1000, UCOMP = 100 -> the drive moves to position 1100, reverses, and stops at position 1000.
2. Actual position = 1000, target position = 0, UCOMP = 100 -> the drive moves directly to position 0
3. Actual position = 1000, target position = 0, UCOMP =-100 -> the drive moves to position -100, reverses, and stops at position 0.


ASCII English UPDATE

ASCII - Command | UPDATE |
Syntax Transmit | UPDATE [Data] |
Syntax Receive | UPDATE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | Name | PROFIBUS PNU | No
Range | ALL,USER,TABLE,PROG,PORDER,MBASE,Lookup | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | Disabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Program Update via RS232

Description

The UPDATE command makes it possible to program the internal Flash EEPROM via the serial interface.

Procedure for a software update:

1. Connect the amplifier to the serial interface of a PC.
2. Start the terminal program HINT2.EXE COM2: 9600 (the computer should be booted in DOS mode).
This establishes the connection between the PPC and the command interpreter of the Drive. To check the connection, enter the LIST command. The response should be a list of all the available commands, shown on the screen.
3. Enter the command UPDATE ALL xxxx in the command line.
xxxx - Name of the firmware file that is to be programmed. Take care that the file xxx for programming is in the active directory. If no file name is entered, then the name ALL is used as a default.

Attention !!! When the drive is programmed with ALL, the loaded motion tasks are deleted. Save motion tasks before programming the firmware.

The programming takes about 40 minutes.

The addresses that are programmed are displayed during the programming procedure. If the display remains static, but the download has not been completed (this problem has been observed on several PCs), then operate the ENTER key. The programming will then carry on.
If the programming procedure is interrupted, then the amplifier will report this in the monitor program at the next power-on (a “-” sign in the first position of the display).
In this case, the download can be restarted by the following command sequence:
X: xxxx
xxxx - Name of the firmware file to be programmed.
Procedure for loading a motor database:

A standard motor database is included as a subset of the firmware. If a customer-specific motor database is required, then it can be loaded after the firmware has been programmed.
This requires the following command:

UPDATE MBASE xxxx

xxxx - Name of the motor database file that is to be programmed. Take care that the file xxx for programming is in the active directory. If no file name is entered, then the name MBASE is used as a default.


ASCII English UVLTMODE

ASCII - Command | UVLTMODE |
Syntax Transmit | UVLTMODE [Data] |
Syntax Receive | UVLTMODE <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3617 (hex)
DIM | - | PROFIBUS PNU | 1879 (dec) IND = 0000xxxx (bin)
Range | 0, 1 | DPR | 279 (dec)
Default | 1 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Undervoltage Mode

Description

The configuration variable UVLTMODE activates or inhibits the undervoltage monitoring of the amplifier.
If the monitoring is activated (UVLTMODE=1), then the fault message F05 (undervoltage) is generated as soon a s the DC-bus voltage falls below the undervoltage threshold VBUSMIN.


ASCII English V

ASCII - Command | V |
Syntax Transmit | V |
Syntax Receive | V <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3618 (hex)
DIM | MUNIT | PROFIBUS PNU | 1880 (dec) IND = 0000xxxx (bin)
Range | -15000 .. 15000 | DPR | 280 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Actual Velocity

Description

The present velocity of the motor.


ASCII English VBUS

ASCII - Command | VBUS |
Syntax Transmit | VBUS |
Syntax Receive | VBUS <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 361A (hex)
DIM | Volts | PROFIBUS PNU | 1882 (dec) IND = 0000xxxx (bin)
Range | 0 .. 900 | DPR | 282 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | DC-bus voltage

Description

The present voltage of the DC-bus.


ASCII English VBUSBAL

ASCII - Command | VBUSBAL |
Syntax Transmit | VBUSBAL [Data] |
Syntax Receive | VBUSBAL <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 361B (hex)
DIM | - | PROFIBUS PNU | 1883 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2, 3 | DPR | 283 (dec)
Default | 2 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | Yes
Short Description | Maximum Line Voltage

Description

This setting is for the maximum permissible voltage for the motor. For instance, if a motor that is rated for a 400V supply is connected to the amplifier, then the setting must be VBUSBAL = 2 (400V). This sets regen and overvoltage thresholds in the amplifier to acceptable values for the motor. This ensures that the motor windings are not damaged.
If several amplifiers are connected to the supply with the DC-buses in parallel, then they must all have the same value for VBUSBAL. It must therefore be set to suit the motor with the lowest voltage rating.

VBUSBAL=0 (110 V) VBUSMAX=450V
VBUSBAL=1 (230 V) VBUSMAX=800V
VBUSBAL=2 (400 V) VBUSMAX=900V
VBUSBAL=3 (480 V) VBUSMAX=900V


ASCII English VBUSMAX

ASCII - Command | VBUSMAX |
Syntax Transmit | VBUSMAX |
Syntax Receive | VBUSMAX <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 361C (hex)
DIM | Volts | PROFIBUS PNU | 1884 (dec) IND = 0000xxxx (bin)
Range | 450, 800, 900 | DPR | 284 (dec)
Default |  |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Maximum DC-bus Voltage

Description

The VBUSMAX parameter shows the value for the monitoring threshold for the fault message F02 (overvoltage).
This fault message is generated as soon as the DC-bus voltage goes above the value of VBUSMAX. The VBUSMAX threshold depends on the setting for VBUSBAL.

VBUSBAL=0 (230 V) VBUSMAX=450V
VBUSBAL=1 (400 V) VBUSMAX=800V
VBUSBAL=2 (480 V) VBUSMAX=900V


ASCII English VBUSMIN

ASCII - Command | VBUSMIN |
Syntax Transmit | VBUSMIN [Data] |
Syntax Receive | VBUSMIN <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 361D (hex)
DIM | Volts | PROFIBUS PNU | 1885 (dec) IND = 0000xxxx (bin)
Range | 30 .. 800 | DPR | 285 (dec)
Default | 100 |
Opmode | All | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Minimum DC-bus Voltage

Description

VBUSMIN defines the lower threshold for monitoring the DC-bus voltage. The fault message F05 (undervoltage) is generated as soon as the DC-bus voltage goes below this threshold. Undervoltage monitoring is only active under the following conditions.
1. Output stage is enabled
2. Monitoring is activated UVLTMODE=1
3. MAINSBTB function is not active (OxMODE<>3)
4. The switch-off of the monitoring function by a digital input (INxMODE=21) is not active.


ASCII English VBW

ASCII - Command | VBW |
Syntax Transmit | VBW |
Syntax Receive | VBW | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 | DPR | No
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Generate Bode Diagram

Description

VBW [fmin] [fmax] [sample]

Velocity BandWidth

Using the function VBW the Drive calculates a velocity loop Bode plot. Default are 50 samples (sample) between 20 Hz (fmin) and 500 Hz (fmax). Output are the gain in db and the phase shift in degree of the open loop and the closed loop of the velocity controller. It is necessary to set GVFR to 1 to get the open loop result. Using MSG 2 the results are immediately shown. Standard is to query the data with the GET command. To use the function VBW the drive should be in OPMODE 0 and enabled. The shaft will move only a few degree. In case of resonance load velocity overshoot can cause a Fault which can result in an uncontrolled coasting of the motor.


ASCII English VCMD

ASCII - Command | VCMD |
Syntax Transmit | VCMD |
Syntax Receive | VCMD <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | Float | CANBus Object Number | 361E (hex)
DIM | MUNIT | PROFIBUS PNU | 1886 (dec) IND = 0000xxxx (bin)
Range | -VMAX .. VMAX | DPR | 286 (dec)
Default | - |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Actual Values | EEPROM | No
Short Description | Internal Velocity Setpoint in RPM

Description

The VCMD variable contains the internal velocity setpoint (after the ramp generator) in RPM.
Depending on the operating mode that is set (OPMODE=0), this value is either provided directly and digitally (fieldbus, slot card) or derived from the analog velocity setpoint (OPMODE=1).
For operating modes that do not use a velocity control loop (OPMODE=2,3) the VCMD variable has the value V of the actual velocity.


ASCII English VCOMM

ASCII - Command | VCOMM |
Syntax Transmit | VCOMM [Data] |
Syntax Receive | VCOMM <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 365A (hex)
DIM | rpm | PROFIBUS PNU | 1946 (dec) IND = 0000xxxx (bin)
Range | 0 .. 1.2 * MSPEED | DPR | 346 (dec)
Default | 1500 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | Yes
Short Description | Velocity Threshold for Commutation error

Description

The command VCOMM defines the threshold for the commutation error function.
The definition of an commutation error is that the sign of the actual current has the right relationship to the sign of the change of the velocity of the motor. This indicates a run-away of the motor and causes a disable of the output stage.

This commutation error is supervised, if the actual velocity is above the VCOMM threshold. To disable the function, VCOMM has to be set to VLIM.


ASCII English VCTAB

ASCII - Command | VCTAB |
Syntax Transmit | VCTAB [Data] |
Syntax Receive | VCTAB <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer8 Integer16 Integer32 | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 .. 7, 0 .. +/- VLIM, +/- IPEAK | DPR | No
Default | 0 |
Opmode | 0, 1 | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Digital I/O | EEPROM | No
Short Description | Define a VCT Entry

Description

IN PREPARATION !

The VCTAB command is used for the definition /display of the VC table (velocity/current table). The VC table contains 8 velocity/current pairs (VCT entries).

A VCT entry can be activated either from the digital inputs or by an ASCII or SDO command.
When a VCT entry is activated, the velocity value that has been entered is taken as a digital velocity setpoint (only possible with OPMODE=0). The current value from the VCT entry is taken as the current limit.
With analog velocity setpoint provision (OPMODE=1), the velocity setpoint is ignored, but the current value is still used as the current limit.
The VC table is not saved in the serial EEPROM, but in the Flash EEPROM (motion task segment). For this reason, changes to the table entries can only be made while the output stage is disabled.

The VCTAB command can be used in one of three different forms:
1. VCTAB nr vsetp ilimit
This command initializes the VCT entry “nr” with the velocity setpoint “vsetp” and the current limit “ilimit”.
nr <0 ... 7>
vsetp <-16000 RPM ... 16000 RPM>
ilimit <0 .... 100000 mA>

The command can only be used in this form while the output stage is disabled.

2. VCTAB nr
This command is used to output the contents of the VCT entry “nr”.
The output is made in the format VCTAB nr vsetp ilimit.

3. VCTAB
This command is used to output the contents of the VCT table via the RS232 interface.
The output consists of 8 lines in the following form:
VCTAB nr vsetp ilimit

See also description of the SETVCT and INxMODE commands.


ASCII English VEL0

ASCII - Command | VEL0 |
Syntax Transmit | VEL0 [Data] |
Syntax Receive | VEL0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3620 (hex)
DIM | - | PROFIBUS PNU | 1888 (dec) IND = 0000xxxx (bin)
Range |  | DPR | 288 (dec)
Default | 5 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Standstill Threshold

Description

The VEL0 (Velocity "0") parameter defines the velocity threshold (in RPM) for the standstill signal.
The standstill signal is required for the following functions:
1. Standstill signal in the status register DRVSTAT.
2. If the brake is configured (MBRAKE=1), then, if the output stage is disabled, first of all the velocity is reduced to 0, and the brake is only applied after the velocity has fallen below the standstill threshold.
3. If the ACTFAULT option is activated (active braking in the event of a fault), or the STOPMODE option (active braking if the output stage is disabled), then the standstill threshold defines the velocity below which the output stage will actually be disabled.


ASCII English VER

ASCII - Command | VER |
Syntax Transmit | VER [*] |
Syntax Receive | VER <Data> | Available in |
Type | Variable ro | MMI | Yes
ASCII Format | String | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | max 50 ASCII Characters | DPR | No
Default | - |
Opmode | All | Data Type Bus/DPR | -
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Basic Setup | EEPROM | No
Short Description | Firmware Version

Description

The command VER returns the version designation and the date of creation for the firmware.
The expanded form of the command (VER *) returns a version list for the various firmware and hardware components.
- Version of the basic firmware
- Hardware revision
- CPLD version
- FPGA version (this version designation labels the type of FPGA program that is loaded, and can vary according to the equipment configuration), see GEARMODE.
- CAN: firmware version
- Version of the motor database (MDB)
- Profibus/Sercos firmware version


ASCII English VJOG

ASCII - Command | VJOG |
Syntax Transmit | VJOG [Data] |
Syntax Receive | VJOG <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3621 (hex)
DIM | see VUNIT | PROFIBUS PNU | 1889 (dec) IND = 0000xxxx (bin)
Range | 0 ... VLIM/VLIMN | DPR | 289 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Speed for Jog Mode

Description

Jog mode is effectively an endless motion task, and is implemented by the internal position control loop.
The sign for the speed indicates the direction for jog operation. The scaling of the velocity is given in position control loop units, and depends on the PGEARI and PGEARO parameters.


ASCII English VLIMN

ASCII - Command | VLIMN |
Syntax Transmit | VLIMN [Data] |
Syntax Receive | VLIMN <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3623 (hex)
DIM | rpm | PROFIBUS PNU | 1891 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. MSPEED | DPR | 291 (dec)
Default | 3000 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Max. Negative Velocity

Description

The VLIMN parameter defines the maximum velocity for the negative direction (velocity control loop) in RPM.
VLIMN is also used for limiting PVMAXN:
PVMAXN <= (VLIMN * PGEARI * 2^PRBASE) / (60 * PGEARO)

When used together with the VLIMP parameter, it is possible to implement a directionally-dependent rotational velocity limit. The VLIMP command determines the maximum velocity for the positive direction.


ASCII English VLIMP

ASCII - Command | VLIMP |
Syntax Transmit | VLIM [Data] |
Syntax Receive | VLIMP <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3622 (hex)
DIM | rpm | PROFIBUS PNU | 1890 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. MSPEED | DPR | 290 (dec)
Default | 3000 |
Opmode | 0, 1 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Max. Velocity

Description

The VLIMP parameter defines the maximum velocity for the negative direction (velocity control loop) in RPM.
VLIMPis also used for limiting PVMAXN:
PVMAXP <= (VLIMP * PGEARI * 2^PRBASE) / (60 * PGEARO)

When used together with the VLIMN parameter, it is possible to implement a directionally-dependent rotational velocity limit. The VLIMN command determines the maximum velocity for the negative direction.


ASCII English VLO

ASCII - Command | VLO |
Syntax Transmit | VLO [Data] |
Syntax Receive | VLO <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 363D (hex)
DIM | - | PROFIBUS PNU | 1917 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 5.0 | DPR | 317 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Feedback | EEPROM | Yes
Short Description | Software Resolver/Digital Converter Feedforward

Description

VLO is a parameter of the Luenberger Velocity Observer. To reduce the delay of the derivation the observer can be served with the torque component of the current. The effective inertia is estimated by the gain of the velocity loop (GV). Setting VLO to zero the acceleration will not influence the observer. With a value of 1 the acceleration is full enabled. With VLO 0.5 the Observer will use 50% of the acceleration torque. Reducing VLO can result in an instable velocity loop.


ASCII English VMIX

ASCII - Command | VMIX |
Syntax Transmit | VMIX [Data] |
Syntax Receive | VMIX <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3625 (hex)
DIM | - | PROFIBUS PNU | 1893 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 1.0 | DPR | 293 (dec)
Default | 1.0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Velocity Mix: Feedback / external Encoder

Description

IN PREPARATION !

If an external encoder is used for the position control EXTPOS=1) then the position control is made with the position information from the external encoder, but the commutation and speed control is made with the position information from the feedback device of the motor (feedback device selected by FBTYPE). The parameter VMIX defines in what ratio the speed information from the feedback device on the motor to the speed information of the external encoder is used for the actual speed calculation.

e.g.
VMIX=1.0 Velocity exclusively from the feedback device selected by FBTYPE (100 %)
VMIX=0.5 50 % feedback device selected by FBTYPE / 50 % external encoder

VMIX is available if FILTMODE = 0 or 1.
VMIX is available only in position mode OPMODE = 8


ASCII English VOSPD

ASCII - Command | VOSPD |
Syntax Transmit | VOSPD [Data] |
Syntax Receive | VOSPD <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Float | CANBus Object Number | 3627 (hex)
DIM | rpm | PROFIBUS PNU | 1895 (dec) IND = 0000xxxx (bin)
Range | 0.0 .. 1.2*MSPEED | DPR | 295 (dec)
Default | 3600 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Overspeed

Description

The VOSPD parameter can be used to set the switch-off threshold for the fault message F08 (overspeed). As soon as the actual velocity exceeds the preset threshold, the fault message F08 is generated and the output stage is disabled.


ASCII English VREF

ASCII - Command | VREF |
Syntax Transmit | VREF [Data] |
Syntax Receive | VREF <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 3628 (hex)
DIM | µm/s | PROFIBUS PNU | 1896 (dec) IND = 0000xxxx (bin)
Range | 0 ... VLIM/VLIMN | DPR | 296 (dec)
Default | 10000 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Speed for Homing

Description

The VREF is used to define the velocity value (VREF>0) for homing to a reference. The direction of the reference is taken from the DREF variable.
The scaling of the velocity is given in position control loop units, and depends on the PGEARI and PGEARO parameters.


ASCII English VREF0

ASCII - Command | VREF0 |
Syntax Transmit | VREF0 [Data] |
Syntax Receive | VREF0 <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 3698 (hex)
DIM | - | PROFIBUS PNU | 2008 (dec) IND = 0000xxxx (bin)
Range | 0.01 .. 2.0 | DPR | 408 (dec)
Default | 0.125 |
Opmode | 8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | Yes
Short Description | Homing Mode Reduction factor

Description

IN PREPARATION !

The parameter VREF0 reduces the homing speed, after the load reaches e.g. the reference switch, while searching for a zero pulse of an external encoder.
The selection of the source of the zero pulse can be selected by REFMODE.
The second homing speed can be reduced by VREF0 in % of VREF.

Example 1:

REFMODE=1 Zeropulse via digital input 1
NREF=1 Homing move with reference switch with zero pulse
VREF=10000 Homing speed 10000 µm/sec
VREF0=0.2 Reduction of the speed to 2000 µm/sec

Starting a homing move, the drive starts to find the reference switch with the speed of 10000 µm/sec. If the reference switch was found, the speed is reduced to 2000 µm/sec and then the search for the zero pulse is started. If the zero pulse was recognised at digital input 1(high level), the homing move is stopped.

Example 2:

REFMODE=2 Zero pulse via digiatl input 2
NREF=5 Zero pulse in one turn of the motor
VREF=10000
VREF0=0.2

The criteria for the search of the zero pulse is fulfilled, so the reference move is directly started with 2000 µm/sec.


ASCII English VSCALE1

ASCII - Command | VSCALE1 |
Syntax Transmit | VSCALE1 [Data] |
Syntax Receive | VSCALE1 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 3629 (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1897 (dec) IND = 0000xxxx (bin)
Range | -15000 .. 15000 | DPR | 297 (dec)
Default | 3000 |
Opmode | 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | SW1 Velocity Scaling Factor

Description

If the analog input SW1 is used as the setpoint input for velocity control, then the VSCALE1 parameter can be used to set the scaling of the input voltage.
A 10V velocity setpoint input at input SW1 produces a velocity of VSCALE1.


ASCII English VSCALE2

ASCII - Command | VSCALE2 |
Syntax Transmit | VSCALE2 [Data] |
Syntax Receive | VSCALE2 <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer16 | CANBus Object Number | 362A (hex)
DIM | rpm / 10 Volts | PROFIBUS PNU | 1898 (dec) IND = 0000xxxx (bin)
Range | -15000 .. 15000 | DPR | 298 (dec)
Default | 3000 |
Opmode | 1 | Data Type Bus/DPR | Integer16
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Analog I/O | EEPROM | Yes
Short Description | SW2 Velocity Scaling Factor

Description

If the analog input SW2 is used as the setpoint input for velocity control, then the VSCALE2 parameter can be used to set the scaling of the input voltage.
A 10V velocity setpoint input at input SW2 produces a velocity of VSCALE2.


ASCII English VSTFR

ASCII - Command | VSTFR |
Syntax Transmit | VSTFR [Data] |
Syntax Receive | VSTFR <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Float | CANBus Object Number | 36A5 (hex)
DIM | VUNIT | PROFIBUS PNU | 2021 (dec) IND = 0000xxxx (bin)
Range | 0 .. 230 UPM | DPR | 421 (dec)
Default | 0 |
Opmode | 0,1,4,5,6,7,8 | Data Type Bus/DPR | Integer32
Drive State | - | Weightning | 1000
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Velocity for max. Friction Compensation

Description

IN PREPARATION !

VSTFR gives the velocity, where the ISTFR is added to the velocity controller. The friction compensation is enabled by ISTFR.

V=0 -> IFRICT = 0
V= 50% of VSTFR -> IFRICT = 50% of ISTFR
V>=VSTFR -> IFRICT = ISTFR
V= -50% of VSTFR -> IFRICT = -50% of ISTFR
V<=-VSTFR -> IFRICT = -ISTFR


ASCII English VTUNE

ASCII - Command | VTUNE |
Syntax Transmit | VTUNE |
Syntax Receive | VTUNE | Available in |
Type | Command | MMI | No
ASCII Format | - | CANBus Object Number | No
DIM | - | PROFIBUS PNU | No
Range | 0 | DPR | No
Default | 0 |
Opmode | 0 | Data Type Bus/DPR | -
Drive State | Enabled | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | -
Short Description | Calculate Velocity Control Loop Parameters

Description


ASCII English VUNIT

ASCII - Command | VUNIT |
Syntax Transmit | VUNIT [Data] |
Syntax Receive | VUNIT <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 365F (hex)
DIM | - | PROFIBUS PNU | 1951 (dec) IND = 0000xxxx (bin)
Range | 0 .. 8 | DPR | 351 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State |  | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Velocity Controller | EEPROM | Yes
Short Description | Systemwide Definition of Velocity / Speed

Description

VUNIT gives the systemwide definition of velocity / speed resolution. This parameter effects all parameters that are related to velocity of the velocity controller and speed of the position controller.

VUNIT = 0 gives velocity in RPM and speed in µm/sec.
VUNIT = 1 Unit = RPM
VUNIT = 2 Unit = Rad/Sec
VUNIT = 3 Unit = Degree/Sec
VUNIT = 4 Unit = Counts/250 µsec
VUNIT = 5 Unit = PUNIT / Sec
VUNIT = 6 Unit = PUNIT / Min
VUNIT = 7 Unit = 1000 * PUNIT / Sec
VUNIT = 8 Unit = 1000 * PUNIT / Min

Remark:
1. All parameters that are related to velovity have a fixed format of 32 Bit with 3 fractional digits. This causes a problem with some of the VUNIT settings (especially VUNIT=6), related to the resolution of the position controller (PGEARI), that not the full range of speed can be used. Under this condition, a different setting of VUNIT is necessary.

2. All parameters that are related to speed have a fixed format of 32 Bit with no fractional digits. This causes a problem with some of the VUNIT settings (especially VUNIT=3) to give fractional digits. Under this condition, a different setting of VUNIT is necessary.

Definition of the Calculation factors

VUNIT=1 1 UPM = 1048576*32/(4000*60) =~ 139.8 Counts
VUNIT=2 1 Rad/sec = 1048576*32/(4000*2*PI) =~ 1335 Counts
VUNIT=3 1 Grad/sec = 1048576*32/(4000*360) =~ 23.3 Counts
VUNIT=4 1 Counts/250µs = 32 Counts
VUNIT=5 1 PUNIT / sec = PGEARO / (125 * PGEARI)
VUNIT=6 1 PUNIT / min = (PGEARO * 60) / (125 * PGEARI)
VUNIT=7 1000 PUNIT / sec = PGEARO / (125 * PGEARI * 1000)
VUNIT=8 1000 PUNIT / min = (PGEARO * 60) / (125 * PGEARI * 1000)


ASCII English WMASK

ASCII - Command | WMASK |
Syntax Transmit | WMASK [Data] |
Syntax Receive | WMASK <Data> | Available in |
Type | Variable rw | MMI | Yes
ASCII Format | Integer32 | CANBus Object Number | 363E (hex)
DIM | - | PROFIBUS PNU | 1918 (dec) IND = 0000xxxx (bin)
Range | 0 .. 4294967295 (1 Bit is 1 warning) | DPR | 318 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Amplifier | EEPROM | No
Short Description | Warning as Fault Mask

Description

The WMASK parameter can be used to reconfigure a warning as the fault message F24.
The WMASK parameter is a bit-variable, with bit assignments that correspond to the STATCODE * status variable. The bit that is set within the WMAKS variable means that the corresponding warning bit in the STATCODE * variable should generate an F24 fault message, as well as a warning. Unlike warnings, a fault message results in the disabling of the output stage, and the opening of the BTB contact. A reconfiguration of a warning to a fault message can be especially relevant for the following warnings: contouring/following error, threshold detection, hardware limit switch. The value has to be entered in decimal.


ASCII English WPOS

ASCII - Command | WPOS |
Syntax Transmit | WPOS |
Syntax Receive | WPOS <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer8 | CANBus Object Number | 3636 (hex)
DIM | - | PROFIBUS PNU | 1910 (dec) IND = 0000xxxx (bin)
Range | 0, 1, 2 | DPR | 310 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer8
Drive State | Disabled + Reset (Coldstart) | Weightning |
Start Firmware | 1.0 |
Configuration | Yes | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Enable Position Registers

Description

In addition to the existing software limit-switches/position thresholds (SWCNFG / SWCNFG2) there is a further option for monitoring positions. Unlike the existing solution, this new monitoring function operates in a deterministic manner. Going above/below a position is detected and signaled within 1 millisecond. The functional range of this monitoring is also expanded (continually/once).
The fast position registers are enabled through the WPOS configuration variable.
WPOS=0 Position register disabled
WPOS=1 Position register enabled, no spontaneous CAN message on change of status.
WPOS=2 Position register enabled, spontaneous CAN message on change of status (this setting is only via CAN-Bus possible).

Changes of the WPOS variable between 0 and >0 can only be made offline (SAVE and COLDSTART), a change between 1 and 2 can also be made online.

There is a total of 16 position registers P1 ... P16, that can be configured with the help of 3 control variables. The position signals are indicated through a status variable. All control/status variables can be considered as 32-bit variables, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.

Control variables:
WPOSE Enable/disable a position register
Bit=0 the corresponding position register is not monitored
Bit=1 the position register is monitored

WPOSP Polarity for the position signaling
Bit=0 Position signal is generated on going above/beyond (overrun) the position
Bit=1 Position signal is generated on going below/behind (underrun) the position

WPOSX – Type of position monitoring
Bit=0 position is monitored continuously
Bit=1 position is monitored once. When the position signal is generated, the corresponding enable bit (WPOSE) is set to 0, so that the monitoring is disabled for this position register,

Status variable:
POSRSTAT (z_data.Posrstat) – Position signaling
Bit=0 position signaling inactive
Bit=1 position signaling active (position overrun for WPOSP=0 or underrun for WPOSP=1).

Position register:
The position registers 1 to 16 can be accessed by the ASCII command P1 ... P16. Position values are displayed in the same units as the position control loop (PGEARI / PGEARO conversion).
The variables that are required for the fast position registers (WPOSE, WPOSP, WPOSX, P1 ... P16) can be saved in the serial EEPROM by using the SAVE command. Those position registers P1 ... P16 which are not used should be set to 0 (since the default value for a position register is 0, no space will be occupied in the serial EEPROM).
The individual position signals from the status register POSRSTAT can be output from the digital outputs of the motherboard.

OxMODE=40
This function is used to produce the result of a logical OR operation (on the bit-variable POSRSTAT and a bit-mask from the auxiliary variable OxTRIG) at the digital output x.

OxMODE=41
This function is used to produce the result of a logical AND operation (on the bit-variable POSRSTAT and a bit-mask from the auxiliary variable OxTRIG) at the digital output x.


ASCII English WPOSE

ASCII - Command | WPOSE |
Syntax Transmit | WPOSE |
Syntax Receive | WPOSE <Data> | Available in |
Type | Variable ro | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 363F (hex)
DIM | - | PROFIBUS PNU | 1919 (dec) IND = 0000xxxx (bin)
Range | 0 ..65535 | DPR | 319 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Enable Fast Position Registers 1 ... 16

Description

The bit-variable WPOSE can be used to enable or disable the fast position registers P1 ... P16. The WPOSE variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.

Bit=0 the corresponding position register is not monitored
Bit=1 the position register is monitored
See also WPOS


ASCII English WPOSP

ASCII - Command | WPOSP |
Syntax Transmit | WPOSP [Data] |
Syntax Receive | WPOSP <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3640 (hex)
DIM | - | PROFIBUS PNU | 1920 (dec) IND = 0000xxxx (bin)
Range | 0 .. 65535 | DPR | 320 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Polarity of Fast Position Registers 1 ... 16

Description

The bit-variable WPOSP can be used to configure the fast position registers P1 ... P16 individually. The WPOSP variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.
Bit=0 Position signal is generated on going above/beyond (overrun) the position
Bit=1 Position signal is generated on going below/behind (underrun) the position

See also WPOS


ASCII English WPOSX

ASCII - Command | WPOSX |
Syntax Transmit | WPOSX [Data] |
Syntax Receive | WPOSX <Data> | Available in |
Type | Variable rw | MMI | No
ASCII Format | Integer32 | CANBus Object Number | 3641 (hex)
DIM | - | PROFIBUS PNU | 1921 (dec) IND = 0000xxxx (bin)
Range | 0 .. 65535 | DPR | 321 (dec)
Default | 0 |
Opmode | All | Data Type Bus/DPR | Integer32
Drive State | - | Weightning |
Start Firmware | 1.0 |
Configuration | No | Last Change of this Object | 1.0
Function Group | Position Controller | EEPROM | No
Short Description | Mode of Fast Position Registers 1 ... 16

Description

The bit-variable WPOSX can be used to configure the fast position registers P1 ... P16 individually. The WPOSX variable can be considered as a 32-bit variable, whereby the lower 16 bits (bits 0 ... 15) are used for the configuration of the position registers P1 ... P16.
Bit=0 position is monitored continuously
Bit=1 position is monitored once. When the position signal is generated, the corresponding enable bit (WPOSE) is set to 0, so that the monitoring is disabled for this position register,

See also WPOS